Trợ giúp:Soạn thảo trực quan/Hướng dẫn sử dụng

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 39% complete.
Outdated translations are marked like this.
PD Lưu ý: Khi bạn chỉnh sửa trang này, bạn đồng ý phát hành đóng góp của bạn theo CC0. Xem trang trợ giúp cộng đồng để biết thêm.
PD


Mở trình soạn thảo trực quan

Để sửa đổi trang dùng Trình soạn thảo trực quan, hãy nhấn chuột vào nút "Sửa đổi" ở đầu trang.

Việc mở chế độ sửa đổi có thể mất vài giây trở lên đối với những trang dài.

Nhấn chuột vào nút “Sửa mã nguồn” sẽ mở trang sửa đổi mã wiki cũ.

VisualEditor edit tab-vi.png

Bạn cũng có thể mở Trình soạn thảo trực quan bằng cách nhấn chuột vào liên kết “sửa” bên cạnh một đề mục.
VisualEditor - Section edit links-en.png

Bắt đầu: thanh công cụ của trình soạn thảo trực quan

Thanh công cụ của Trình soạn thảo trực quan
Thanh công cụ xuất hiện trên đầu cửa sổ khi mở Trình soạn thảo trực quan. Nó bao gồm một số nút thường gặp:

VisualEditor - Toolbar - Undo-redo.png
Hoàn tácLàm lại các thay đổi của bạn.

VisualEditor Toolbar Headings-vi.png
Trình đơn kéo xuống Đề mục: cho phép bạn đổi mức đề mục của văn bản. Các đề mục bình thường trong bài viết sử dụng mức “Đề mục”, còn các đề mục con là "Đề mục con 1", "Đề mục con 2". Định dạng thông thường cho văn bản là "Đoạn văn".

VisualEditor Toolbar Formatting-vi.png

Định dạng: Nhấn "A" sẽ mở ra một menu.

  • “Đậm” (B) viết đậm văn bản đã chọn.
  • “Xiên” (I) viết xiên văn bản đã chọn.
  • “Viết lên trên” (x2) thu nhỏ văn bản đã chọn và đẩy nó xuống dưới dòng một tí.
  • “Viết xuống dưới” (x2) phóng to văn bản đã chọn và kéo nó lên trên dòng một tí.
  • “Gạch ngang lên chữ” (S) gạch ngang qua văn bản đã chọn.
  • Mục "Mã máy tính" (tập hợp các dấu ngoặc nhọn: {}) thay đổi phông chữ của văn bản đã chọn thành phông chữ một khoảng cách, làm cho nó khác biệt với văn bản xung quanh (khoảng cách theo tỷ lệ).
  • Mục "Gạch dưới" (U) thêm một đường gạch chân bên dưới văn bản đã chọn.
  • Mục "Ngôn ngữ" (文A) cho phép bạn gắn nhãn ngôn ngữ (ví dụ: tiếng Nhật) và hướng (ví dụ: từ phải sang trái) của văn bản đã chọn.
  • Mục cuối cùng (VisualEditor MediaWiki theme clear icon bitmap.png), được gọi là "Xóa", loại bỏ tất cả các định dạng ký tự khỏi văn bản đã chọn, bao gồm cả các liên kết.

Nếu bạn chưa chọn bất kỳ văn bản nào, thì khi bạn nhấn "A" để mở trình đơn, rồi chọn một mục, định dạng đó sẽ áp dụng cho văn bản mà bạn bắt đầu nhập, từ bất cứ nơi nào đặt con trỏ của bạn.


VisualEditor - Toolbar - Linking.png
Công cụ liên kết: Biểu tượng chuỗi là công cụ liên kết. Nhấn vào nó (thường sau khi chọn một số văn bản) sẽ mở ra hộp thoại liên kết.

VisualEditor - Cite Pulldown.png
Chú thích nguồn menu: Menu "Chú thích nguồn" được sử dụng để thêm các trích dẫn nội dòng (còn được gọi là "chú thích cuối trang" hoặc "tài liệu tham khảo"). Tất cả các dự án đều có quyền truy cập vào định dạng tham chiếu cơ bản và khả năng sử dụng lại các trích dẫn bằng cách sử dụng menu này. Nó cũng cho phép người dùng truy cập nhanh vào các mẫu trích dẫn cục bộ, nếu chúng được bật trên wiki của họ.

(Hướng dẫn thêm các mẫu trích dẫn cục bộ vào menu Chú thích nguồn tại một wiki cụ thể có sẵn ở mục VisualEditor/Citation tool .)


VisualEditor citoid Cite button-vi.png
Nút Chú thích: Nếu dịch vụ citoid được bật trên wiki của bạn, thì bạn sẽ thấy một Chú thích thay vì menu Chú thích nguồn bạn.

Dịch vụ citoid cố gắng tự động điền vào các mẫu trích dẫn.


VisualEditor Toolbar Lists and indentation-vi.png
Danh sách và thụt lề: Hai mục đầu tiên cho phép bạn định dạng văn bản dưới dạng "Danh sách không đánh số" hoặc "Danh sách đánh số". Hai mục cuối cùng cho phép bạn giảm hoặc tăng mức thụt lề của các mục danh sách.

VisualEditor Insert Menu-vi.png
Chèn: Menu "Chèn" có thể khác nhau ở một số dự án. Dưới đây là danh sách các tùy chọn tất cả có thể xuất hiện.
  • “Hình ảnh và phương tiện” (hình dãy núi) mở hộp thoại phương tiện.
  • Biểu tượng "Bản mẫu" (một mảnh xếp hình) cho phép bạn sửa đổi các bản mẫu.
  • Mục "Bảng" cho phép bạn thêm bảng.
  • Mục "Phụ chú" (một bóng thoại) cho phép bạn thêm bình luận mà người đọc sẽ không nhìn thấy; những bình luận này chỉ có thể thấy khi đang ở chế độ sửa đổi, tại đó chúng được thể hiện bằng biểu tượng dấu chấm than. Trong chế độ sửa đổi, ấn biểu tượng dấu chấm than (Phụ chú) sẽ cho phép bạn sửa đổi hoặc xóa bình luận.
  • Biểu tượng "Chữ tượng hình" (một biểu tượng ankh - ☥) cho phép bạn thêm chữ tượng hình. (Xem bên dưới.)
  • Mục "Đoạn mã" cho phép bạn thêm mã.
  • Mục "Khuông nhạc" cho phép bạn thêm khuông nhạc.
  • “Tập ảnh” (tập ảnh) chèn một tập hình ảnh vào trang.
  • Biểu tượng "Công thức toán" (Σ) mở hộp thoại formula inserter.
  • Mục "Đồ thị" cho phép bạn chèn biểu đồ.
  • Mục "Chữ ký của bạn" cho phép bạn chèn chữ ký mà bạn sử dụng trong dự án. Nó sẽ bị mờ đi (không thể chọn) khi bạn đang chỉnh sửa một loại trang ("không gian tên"), chẳng hạn như một bài viết, trong đó không nên chèn chữ ký.
  • Biểu tượng "Danh sách chú thích tham khảo" (ba cuốn sách) mở ra một hộp thoại trong đó bạn có thể chỉ định nơi các tham chiếu sẽ được hiển thị cho người đọc. Thông thường điều này chỉ cần được thực hiện một lần trên một trang.

'Chèn ký tự đặc biệt: Biểu tượng "Ký tự đặc biệt" (Ω) nằm bên cạnh menu "Chèn". Khi nhấn, nó hiển thị một hộp thoại hiển thị nhiều ký tự đặc biệt. Bằng cách nhấn vào một ký tự cụ thể, bạn đặt nó vào văn bản. Những ký tự đặc biệt này bao gồm một số biểu tượng tiêu chuẩn, dấu phụ và ký hiệu toán học. (Danh sách này có thể được tùy chỉnh cục bộ. Xem VisualEditor/Special characters để biết hướng dẫn.)
VisualEditor Toolbar SpecialCharacters-vi.png

VisualEditor toolbar edit notices icon.png
Nút Chỉnh sửa thông báo hiển thị bất kỳ thông báo nào cho trang.

VisualEditor More Settings-vi.png
Menu Tùy chọn trang' nằm ở bên trái nút Đăng thay đổi và menu Trình chỉnh sửa công tắc. Trên menu này có một nút để mở hộp thoại Tùy chọn với các tab sau (bên trái) :
  • Thể loại cho phép bạn thêm các danh mục vào trang này và điều chỉnh cách sắp xếp trang, khi được hiển thị trong một danh mục bằng cách đặt một chỉ mục khác để sắp xếp.
  • Tùy chọn trang cho phép bạn chuyển hướng trang và điều chỉnh các tùy chọn của chuyển hướng này, điều chỉnh cài đặt liên quan đến việc hiển thị Mục lục, vô hiệu hóa các liên kết chỉnh sửa bên cạnh mỗi tiêu đề và xác định trang là một trang định hướng.
  • Cài đặt nâng cao cho phép bạn điều chỉnh cài đặt liên quan đến lập chỉ mục trang bằng các công cụ tìm kiếm, hiển thị một tab để thêm một phần mới và tiêu đề được hiển thị.
  • Ngôn ngữ hiển thị danh sách các trang bằng các ngôn ngữ khác được liên kết với trang đó.
  • Mẫu được sử dụng hiển thị danh sách các liên kết đến từng mẫu được sử dụng trên trang này.

Các tab của hộp thoại Tùy chọn cũng được hiển thị trong menu Tùy chọn trang thể được mở bằng cách nhấp vào nó. Hơn nữa, menu Tùy chọn trang chứa nút Xem là từ phải sang trái và nút Tìm và thay thế mở ra một hộp thoại nơi bạn có thể chèn các ký tự, thuật ngữ hoặc biểu thức chính quy mà bạn đang tìm kiếm và những biểu thức để thay thế chúng, cùng với một số nút cho các tùy chọn.


VisualEditor bi-directional switching square brackets icon.png
Nút chuyển sang Trình soạn thảo mã nguồn nằm bên cạnh nút Đăng thay đổi Nó cho phép bạn chuyển sang trình soạn thảo wikitext.

Lưu thay đổi

Sau khi bạn sửa đổi xong xuôi, hãy bấm nút “Đăng thay đổi” màu xanh trên thanh công cụ. Nút chỉ cho phép bấm sau khi thực hiện thay đổi. Để hủy tất cả các thay đổi chỉnh sửa của bạn, hãy đóng cửa sổ trình duyệt hoặc nhấn tab "Đọc" phía trên thanh công cụ chỉnh sửa.
VisualEditor toolbar actions-vi.png

Nhấn nút "Đăng thay đổi" màu xanh lam sẽ mở ra một hộp thoại. Sau đó, bạn có thể nhập bản tóm tắt ngắn gọn về hành động của mình, đánh dấu chỉnh sửa của bạn là phụ và/hoặc thêm trang vào tài khoản Trang theo dõi. Hộp tóm tắt tương đương với trường Tóm lược: trong trình soạn thảo wikitext.

Bạn cũng có thể xem lại các thay đổi của mình bằng nút "Xem lại những thay đổi của bạn" để xác nhận rằng chúng sẽ hoạt động như dự định trước khi lưu các thay đổi của bạn. Điều này tương tự như nút "Xem thay đổi" trong trình soạn thảo wikitext.

The "Sửa tiếp" button returns you to the page you were editing. You can publish all of your changes later.

VisualEditor save dialog-vi.png

Sửa liên kết

VisualEditor - Toolbar - Linking.png
Để đặt liên kết, hãy bấm nút “Liên kết” (hình dây xích) trên thanh công cụ, hoặc dùng tổ hợp phím tắt Ctrl+K (hoặc ⌘ Command+K trên Mac).

If you select (highlight) text and then press the "Liên kết" button, that text will be used in creating the link. For a link that involves only one word, you can either select that word or just put the cursor within that word.


VisualEditor-link tool-search results-vi.png
Dù bạn bấm nút hay bấm phím tắt, một hộp thoại sẽ xuất hiện. Bạn có thể nhập tên bài hoặc địa chỉ URL. Trong lúc gõ, Trình soạn thảo trực quan tự động tìm kiếm các tên bài trong wiki mà bạn có thể muốn chọn.

The link tool will try to help with internal links by searching for likely matches. Sau khi nhập hoặc chọn tên bài, hãy bấm ↵ Enter hoặc nhấn chuột bên ngoài hộp thoại hay vào nút đóng (<). Liên kết sẽ xuất hiện trong Trình soạn thảo trực quan nhưng chỉ được lưu khi bạn lưu trang.


VisualEditor-link tool-external link.png
Để liên kết đến một trang trên một trang web khác, quy trình tương tự: Chọn tab “Trang ngoài” là nhập URL vào hộp.

VisualEditor link tool simple link.png
External links without labels look like this: [1]. You can add these by placing your cursor away from any word (e.g., after a space). Open the link tool by pressing on the button or pressing the shortcut keys. Type the URL in the box, and press the "Xong" button to insert the link.

VisualEditor-context menu-link tool.png
Để thay đổi hoặc xóa một liên kết hiện có trong bài, hãy nhấn chuột vào văn bản liên kết và bấm nút “Link” xuất hiện bên cạnh liên kết. Bạn cũng có thể bấm nút này trên thanh công cụ hoặc bấm phím tắt Ctrl+K khi liên kết được chọn. When a link is selected, it appears as blue framed.

Bạn có thể sửa trang đích của liên kết hoặc xóa hẳn liên kết dùng nút “Remove” (hình thùng rác) ở góc phải bên trên của hộp thoại. You can also open the link's target in another window by pressing on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, press within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may press within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.
  • You can also link to categories, files and more.

Sửa chú thích tham khảo

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "Chú thích nguồn" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "Chú thích nguồn" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more-vi.png

VisualEditor citoid Cite button-vi.png
In the third system, you again start by pressing the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-vi.png

Sửa một chú thích đã tồn tại

To edit an existing reference, press on it where it appears in the text (usually as a bracketed number). You will see either a "Chú thích" icon (bookmark) or an icon (and name) for the template that was used to create this reference. In either case, pressing on the "Edit" button will open a dialog where you can edit the reference.
VisualEditor - Editing references 1.png

For the "Chú thích" icon, pressing "Edit" opens the Reference dialog. To start changing the reference information, press on it.

Nhiều wiki sử dụng bản mẫu để chuẩn hóa các chú thích tham khảo. Các chú thích chứa bản mẫu được tô màu xanh khi được lựa chọn.

If a template was used and you press on the reference information, then the Bản mẫu icon (puzzle piece) will appear with some information. Press on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6.png

If what appears when you press on a reference is an icon for a standard template for citations (an example is at right), then pressing "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content will show, initially. To add fields, press on "Bổ sung thêm thông tin" at the bottom of the mini-editor.
VisualEditor - Editing references 5.png

Sau khi đâu vào đấy, bấm nút “Áp dụng các thay đổi”.
VisualEditor Apply Changes-vi.png

Sử dụng lại một chú thích đã tồn tại

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

Để sử dụng lại một chú thích đã tồn tại, đưa con nháy vào vị trí mà bạn muốn chèn chú thích, kéo xuống trình đơn “Insert” và chọn “⧼visualeditor-dialogbutton-reference-tooltip⧽”.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Chú thích nguồn" menu.)

VisualEditor Cite menu re-use.png

Nếu trang có nhiều chú thích, bạn có thể sử dụng hộp tìm kiếm (đề “Tìm kiếm trong chú thích hiện tại”) để lọc chú thích theo văn bản.
VisualEditor - Editing references 18.png

Thêm chú thích mới

Để thêm một chú thích mới, đưa con nháy vào vị trí mà bạn muốn chèn chú thích, kéo xuống trình đơn “Insert” trên thanh công cụ và chọn “⧼visualeditor-dialogbutton-reference-tooltip⧽” (hình dấu trang).
VisualEditor references more-vi.png

Using the "Basic" citation

Shown here is what you will see if you select the basic references item. Trong cửa sổ chú thích tham khảo, bạn có thể thêm, sửa, và trang trí lời chú thích của bạn.

Bạn có thể xếp chú thích này vào nhóm, để chèn danh sách chú thích theo nhóm dùng công cụ “⧼visualeditor-dialog-referencelist-title⧽”.

VisualEditor - Editing references 20.png

Trong hộp thoại Tham chiếu, nếu bạn muốn bao gồm mẫu trích dẫn hoặc bất kỳ mẫu nào khác, trong tham chiếu mới của bạn, hãy nhấn biểu tượng Bản mẫu (mảnh ghép) trong menu thanh công cụ "Chèn" trong trình chỉnh sửa Tham chiếu.
VisualEditor Template Insert Menu-vi.png

Sau đó, tìm mẫu bạn muốn sử dụng, thêm nó và chỉnh sửa nó như bất kỳ mẫu nào khác. (Xem Sửa mẫu bên dưới, nếu bạn cần thêm thông tin về mẫu.)

Sau khi bạn chỉnh sửa xong mẫu mới của mình, hãy nhấn vào "Áp dụng các thay đổi" để quay lại trình chỉnh sửa Tham chiếu và "Áp dụng các thay đổi" một lần nữa để quay lại trang bạn đang chỉnh sửa.

VisualEditor - Editing references 9.png

Nếu chưa có danh sách các tham chiếu trên trang (ví dụ: nếu bạn đang thêm tham chiếu đầu tiên cho trang), bạn cần chỉ định vị trí danh sách tham chiếu và văn bản của chúng, sẽ được hiển thị cho người đọc.

Đặt con trỏ ở nơi bạn muốn hiển thị danh sách tham chiếu (thường là ở cuối trang), mở menu "Chèn" và nhấn biểu tượng "Danh sách chú thích tham khảo" (ba cuốn sách).

VisualEditor References List Insert Menu-vi.png

Nếu bạn đã xếp các chú thích vào nhóm, bạn có thể xác định một nhóm trong cửa sổ này, để chỉ liệt kê các chú thích trong nhóm này.

The final step in the References list dialog is to press "Chèn".

VisualEditor references list-vi.png

Using standard cite templates

Your local wiki may have added extra citation templates to the "Chú thích nguồn" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool .)
VisualEditor - Editing References - Cite Pulldown.png

Pressing on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and press on the "Bổ sung thêm thông tin" option.

Press on "Chèn" when you are done.

VisualEditor - Editing references - Add parameter.png

Editing images and other media files

Biên tập hình ảnh

Để thêm hình mới (hoặc một loại tập tin phương tiện khác) vào trang, hãy kéo xuống trình đơn “Chèn” và chọn “Hình ảnh và phương tiện” (hình dãy núi). Hình sẽ được chèn vào vị trí của con nháy.
VisualEditor Media Insert Menu-vi.png

Sau khi bấm nút “Hình ảnh và phương tiện”, một hộp thoại sẽ xuất hiện. Hộp thoại này tự động tìm tập tin phương tiện trong Wikimedia Commons có liên quan đến trang bạn đang sửa đổi.

Thay đổi văn bản trong hộp tìm kiếm của hộp thoại để tìm tập tin phương tiện khác.

Nhấn chuột vào một hình nhỏ để chọn tập tin.

This places the image onto the page you are editing.

VisualEditor - Media editing 2.png

Hộp thoại phương tiện cho phép thêm (và sửa) lời chú thích. Bạn có thể định dạng hóa hoặc đặt liên kết vào văn bản này.
VisualEditor - Media editing 6.png

Cửa sổ phương tiện cũng cho phép thêm lời chú thích thay thế dành cho những người dùng trình đọc màn hình hoặc tắt hình ảnh trong trình duyệt.
VisualEditor - Media editing 7.png

Trong cửa sổ “Tùy chọn nâng cao”, bạn có thể thay đổi nhiều tùy chọn về hình, thí dụ cách căn chỉnh, kiểu, và kích thước.
VisualEditor - Media editing 8.png

Sau khi xong xuôi, hãy bấm “Áp dụng các thay đổi” để đóng hộp thoại và trở về trình soạn thảo trang.
VisualEditor Apply Changes-vi.png

Đối với một bức ảnh đã có sẵn, bạn có thể thêm hoặc chỉnh sửa chú thích hoặc các cài đặt khác bằng cách click chuột vào bức hình, sau đó click chuột vào biểu tượng "Hình ảnh và phương tiện" xuất hiện bên dưới bức ảnh đó.

You can resize an existing image by pressing on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3.png

Uploading images

You can upload images from a tab in the media dialog, or by dragging and dropping a file into the editor, or by pasting an image from your clipboard.
VisualEditor - Media upload 1.png

Press the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.
VisualEditor - Media upload 1.5.png

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.png

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Editing media galleries

Để chèn tập ảnh mới, bấm nút “Tập ảnh” (hình tập ảnh).
VisualEditor - Gallery1.png

Để sửa đổi một tập ảnh đã tồn tại dùng Trình soạn thảo trực quan, bấm vào tập ảnh; nút sửa đổi tập ảnh sẽ xuất hiện ở góc trên bên phải. Bấm nút để mở cửa sổ có danh sách các hình ảnh trong tập ảnh. Sửa danh sách này để dời, thêm, hay sắp xếp lại các hình ảnh hoặc thay đổi các chú thích. Bấm mũi tên trái (<) để đóng cửa sổ và cập nhật trang. Sau khi sửa tập ảnh xong, xin nhớ lưu toàn bộ trang để lưu các thay đổi của bạn.
VisualEditor - Gallery2.png
Nút này mở cửa sổ tập ảnh, cửa sổ này hiện chỉ có một hộp văn bản thuần. Để thêm hình ảnh vào tập ảnh, nhập tên tập tin, rồi dấu sổ thẳng (|), rồi lời chú thích hình. Mỗi hình trong tập ảnh có hàng riêng. Sau khi định rõ các hình ảnh trong tập ảnh, bấm mũi tên trái (<) để đóng cửa sổ tập ảnh. Tập ảnh sẽ xuất hiện. Hãy nhớ lưu trang để lưu tập ảnh. You can also edit this list to remove or rearrange images or to change captions.

When you press the "Xong" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not publish your changes. As with other changes made using the visual editor, you must publish the entire page in order to publish your work.

VisualEditor - Gallery3.png

Sửa bản mẫu

The powerful MediaWiki template system lets you insert dynamic content, text from other pages, and much more. For a detailed explanation and examples, see the Templates help page.

In the VisualEditor you can search for a relevant template, add an invocation or transclusion on the page you’re editing and, if needed, add custom content using parameters.

Insert new template

Để thêm một bản mẫu mới vào trang, đưa con nháy vào vị trí mà bạn muốn chèn bản mẫu, kéo xuống trình đơn “$template” trên thanh công cụ và chọn “$insert” (hình miếng ghép hình). Then open the Chèn menu and select "OOjs UI icon puzzle-ltr.svg Bản mẫu". Alternatively, type two curly brackets {{ to open the same dialog.
VisualEditor Template Insert Menu-vi.png
Find the template you want to insert by typing either its name or a relevant keyword. Results containing the search term in either the name or description will display in a dropdown. This should help you find a relevant template, even if you don’t know its exact name.

If you’re having trouble finding the kind of template you want by using keywords, you can look on other wiki pages with similar content and view or edit the page source to see which templates are in use. When you find the desired template’s name, you can type it into this field to insert it here.

Screenshot of the template search field in the Visual Editor

Để sửa một bản mẫu đã được chèn vào trang, lựa chọn nó – nó sẽ được tô đậm màu xanh – và bấm nút “$template” (hình miếng ghép hình) mà xuất hiện, hoặc nút "$edit" trên thanh công cụ. When you select the template you want to edit, it turns blue, and a box appears displaying "OOjs UI icon puzzle-ltr.svg Bản mẫu". Then select the "Sửa đổi" link or double click on the template itself to open the template.
Screenshot of the VisualEditor interface with a template selected

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are still shown so that you can click and edit or delete them. The name of the template will be shown next to the puzzle icon and both will be grayed out.
Screenshot of hidden templates in the Visual Editor interface

Tham số bản mẫu

You’ll see this dialog box when you’re adding a new template or editing one already in place. What you see in the box depends on whether the template in question contains TemplateData , helpful metadata added by other editors to make it easier to edit templates in the Visual Editor.

When a template contains TemplateData, the VisualEditor can use it to present annotated fields for you to fill in.


For templates that have some community-provided TemplateData, the VisualEditor displays a list of the named parameters and, often, descriptions and instructions explaining the meaning and required format for each parameter’s values.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

You can disable any optional parameter (which have blue checkboxes on the left side). If a parameter’s checkbox is grayed out and not clickable, the template requires that parameter, so it can’t be disabled.

When you insert a new template, you may find that some optional parameters are pre-selected. That means the author(s) of the template recommends the use of those parameters. It’s best to review all parameters that will be used in a template to ensure you understand their use.

Clicking an unchecked parameter adds it to the template. Clicking a parameter that’s already been added takes you to the parameter’s input field.

Some template parameters will show as “deprecated”. Don’t use deprecated parameters when inserting a template; they’re only visible to you because those parameters are in use on older pages where this template was included.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Adding undocumented parameters

If you’re inserting or editing a template whose author hasn’t laid out its parameters in TemplateData, it has what we call “undocumented” or “unnamed parameters”. In these cases, you should consult the page for the template itself. There you can learn how to correctly employ and work with all of the template’s parameters. This includes learning the exact names of the parameters as written by the template author.

If you find in the documentation that the template expects parameters without have names, fill in numbers as placeholders for the parameter names using the undocumented parameter input, then add next to the values you want to provide as you normally would.

Example:

  • first unnamed parameter: “1”
  • first unnamed parameter’s value: “en_US”
  • second unnamed parameter: “2”
  • second unnamed parameter’s value: “yes”

If you accidentally include nonexistent, misspelled or erroneous parameters, the values you enter for those parameters won’t show up on the page you’re editing.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerated parameters

In this example, the template in question lacks TemplateData but it was possible to autogenerate the parameters. This means that the undocumented parameters have already been added for you, but the names may not be easily understandable and the dialog cannot display any directions or descriptions. As a result the dialog box provides a link to the template’s documentation, which should help you deduce and fill in the template’s various parameters.
Autogenerated parameters in the VisualEditor.png

Editing multi-part template content

During editing, you may open template content consisting of multiple templates or a single template linked to some wikitext. This differs from the nested templates described below. In this case, the templates are better visualized as being stacked or connected.

This content often contains “unbalanced templates,” templates which are incomplete on their own and need to be paired with some wikitext or another template in order to function.

These related pieces of template content must be created in wikitext, but can be edited in the VisualEditor. In these cases you will see a notice at the top of the dialog to signal the situation and a specialized toolbar will be visible at the bottom of the sidebar. There you can use the icon buttons to add additional templates, additional wikitext, delete elements or change their order.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Nested templates

Templates can include other templates as the value for parameters. You’ll recognize it when you see a parameter whose value contains the double curly braces ( {{ }} ) denoting a template.

The VisualEditor can’t present this template within a template (a nested template) using the editor’s easy-to-use interface, so if you want to nest a template yourself, you’ll need to understand how to add the template by hand in wikitext into the appropriate parameter field.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Completing your edit

Sau khi xong xuôi, hãy bấm “Áp dụng các thay đổi” để đóng hộp thoại và trở về trình soạn thảo trang. Then you can preview your edit and make sure it looks the way you want and expect.

You may also see an error message, which (like the other TemplateData mentioned above) is community-provided content and may vary in usefulness. You may need to consult the template’s own documentation to get to the bottom of some errors. If you’re still having trouble, consider posting about your problem on the template’s talk page.

VisualEditor Apply Changes-vi.png

Removing a template

To remove a template in the VisualEditor, click the template box. Press the "Delete" or "Backspace" key on your keyboard. The template will disappear from the page.
Screenshot of the button to remove a template
Removing a template in the VisualEditor

Editing on mobile

When editing a template on a page using the VisualEditor on a mobile device, you’ll see that the sidebar starts out hidden. You can make it visible by pressing the “Show/hide options” button.
Screenshot of editing a template on a mobile device
Editing a template on mobile in the VisualEditor

Thay thế bản mẫu

When you insert a template in a wiki page, its content and appearance are reevaluated every time the page loads, based on the template code and the values of its parameters. This means if someone updates the code of a template, then every page which uses that template will also get updated when they publish.

There’s another, much less common way to use templates, though, and that’s to substitute a template. Doing this permanently includes the template content just as it appears at the moment you insert it. It will not update if the template code is later changed.

Most users won’t ever need to resort to substitution. Substitution is typically only useful when you need to capture the exact appearance of one version of a template, such as when content is under development and needs evaluation.

To substitute a template in the VisualEditor, insert a template using the name syntax subst:<template name>. (Autocomplete doesn’t work in this case.) Then press the blue “Add template” button.

When you’re finished, press “Insert”, which will insert the template content as you see it.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Sửa danh sách

VisualEditor Toolbar Lists and indentation-vi.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just press on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then press on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Editing tables

VisualEditor insert table-vi.png
You can use the visual editor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you press on "Table", in the "Chèn" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, press it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double press in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just press elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
You can add, move or delete a column or a row.

You can merge cells: Select them, then from the Table menu, press on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Sửa thể loại

VisualEditor category item-vi.png
Trình đơn “Thể loại” cho phép truy cập nút “Tùy chọn trang”.

VisualEditor category editing-vi.png
Nút “Thể loại” mở cửa sổ có danh sách các thể loại mà trang đã được xếp vào và cho phép xếp trang vào thêm thể loại.

Cửa sổ cũng cho phép tùy biến từ khóa sắp xếp, từ khóa này xác định vị trí của trang này trong danh sách trang của thể loại.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
To add a category for a page, type the name of the category into the field "Thêm thể loại". As you type, the visual editor will search for possible matching, existing categories. You can either select an existing category, or you can add a category that doesn't yet have its own category page. (Until that category page is created, your new category will show as a red link after you publish all your editing changes.)

VisualEditor - Category editing 2.png
Để dời một thể loại đang chứa trang, nhấn chuột vào thể loại và bấm nút “Dời” (hình thùng rác) trong cửa sổ nổi lên.

Trong cửa sổ nổi lên, bạn cũng có thể tùy biến từ khóa sắp xếp riêng cho thể loại này, ghi đè từ khóa sắp xếp mặc định.


VisualEditor Apply Changes-vi.png
Sau khi đâu vào đấy, bấm nút “Áp dụng các thay đổi” để quay lại trình soạn trang.

Thay đổi tùy chọn trang

VisualEditor page settings item-vi.png
Để thay đổi các tùy chọn trang, mở trình đơn “Tùy chọn trang” và bấm nút “Tùy chọn trang”.

VisualEditor Page Settings-vi.png
Nút “Tùy chọn trang” mở cửa sổ có nhiều tùy chọn về trang.

VisualEditor Page Settings Redirects-vi.png
Để làm cho trang đổi hướng đến trang khác, bấm hộp kiểm “Đổi hướng trang này đến” và nhập tên trang đích vào hộp văn bản.

Hộp kiểm bên dưới đó cho phép làm cho trang không được cập nhật khi trang đích được đổi tên. Tùy chọn này ít được dùng.


VisualEditor Page Settings TOC-vi.png
Bạn có thể ẩn hay hiện bảng mục lục của trang dùng ba nút này. Nút “Nếu cần” (mặc định) có nghĩa rằng trang sẽ có bảng mục lục nếu có ba đề mục trở lên.

VisualEditor Page Settings Edit Links-vi.png
Hộp kiểm này ẩn các liên kết “sửa” bên cạnh các đề mục.

VisualEditor Apply Changes-vi.png
Sau khi đâu vào đấy, bấm nút “Áp dụng các thay đổi” để quay lại trình soạn trang.

Editing maps

Visual editor showing editing an existing map.jpg
You can add and change maps. See Help:VisualEditor/Maps .

Sửa đổi công thức toán

Để chèn một công thức toán mới vào trang, để con nháy vào vị trí của công thức, mở trình đơn “Chèn” và bấm nút “Công thức toán” (Σ).
VisualEditor Formula Insert Menu-vi.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, press the "Chèn" button.
VisualEditor formula-vi.png

Để sửa đổi một công thức đã tồn tại trên trang, nhấn chuột vào nó rồi bấm nút “Σ” nổi lên. Cửa sổ công thức sẽ mở để cho bạn thay đổi công thức.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, press the "Musical notation" option.

To edit an existing musical notation on the page, double press on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, press the "Done" button to close the dialog and publish your changes.
Musical.png

Sửa các bài thơ và các mục đặc biệt khác

Trình soạn thảo trực quan chưa hỗ trợ một số phần tử nâng cao, thí dụ như bài thơ và khuôn nhạc.
VisualEditor editing poem 1.png

Ở phần lớn trường hợp, chúng có thể thay đổi, tuy nhiên không thể tạo cái mới trong Trình soạn thảo trực quan.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, press the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

You'll see a diff. (If you pressed on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, press the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

Phím tắt

Nhiều người quen nhập mã wiki trực tiếp, nhất là mã viết đậm, xiên, và liên kết. Các phím tắt cho phép định dạng hóa văn bản nhanh lẹ mà không phải bấm nút trên thanh công cụ. Một số phím tắt thường gặp trong trình soạn khác cũng hoạt động trong Trình soạn thảo trực quan:

Phím tắt PC Tác động Phím tắt Mac

Ctrl+B Đậm ⌘ Cmd+B

Ctrl+I Xiên ⌘ Cmd+I

Ctrl+K Đặt liên kết ⌘ Cmd+K

Ctrl+X Cắt ⌘ Cmd+X

Ctrl+C Chép ⌘ Cmd+C

Ctrl+V Dán ⌘ Cmd+V

Ctrl+Z Hoàn tác ⌘ Cmd+Z