도움말:시각편집기/사용자 가이드

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 100% complete.

Other languages:
Bahasa Indonesia • ‎Bahasa Melayu • ‎Basa Sunda • ‎Bikol Central • ‎Cebuano • ‎Cmique Itom • ‎Cymraeg • ‎Deutsch • ‎English • ‎Esperanto • ‎Fiji Hindi • ‎Frysk • ‎Ilokano • ‎Interlingue • ‎Jawa • ‎Lëtzebuergesch • ‎Malagasy • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Napulitano • ‎Nederlands • ‎Oromoo • ‎Picard • ‎Scots • ‎Tagalog • ‎Tiếng Việt • ‎Tûnsî • ‎Türkçe • ‎Yorùbá • ‎Zazaki • ‎asturianu • ‎azərbaycanca • ‎bosanski • ‎català • ‎dansk • ‎eesti • ‎emiliàn e rumagnòl • ‎español • ‎euskara • ‎français • ‎furlan • ‎føroyskt • ‎galego • ‎hrvatski • ‎isiXhosa • ‎italiano • ‎latviešu • ‎lietuvių • ‎magyar • ‎norsk bokmål • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎shqip • ‎slovenčina • ‎slovenščina • ‎suomi • ‎svenska • ‎čeština • ‎Ελληνικά • ‎беларуская (тарашкевіца)‎ • ‎български • ‎македонски • ‎русский • ‎саха тыла • ‎српски / srpski • ‎татарча/tatarça • ‎українська • ‎հայերեն • ‎ייִדיש • ‎עברית • ‎العربية • ‎تۆرکجه • ‎سنڌي • ‎فارسی • ‎پښتو • ‎मराठी • ‎संस्कृतम् • ‎हिन्दी • ‎অসমীয়া • ‎বাংলা • ‎মেইতেই লোন্ • ‎ਪੰਜਾਬੀ • ‎ଓଡ଼ିଆ • ‎தமிழ் • ‎తెలుగు • ‎ಕನ್ನಡ • ‎മലയാളം • ‎ไทย • ‎မြန်မာဘာသာ • ‎ქართული • ‎ភាសាខ្មែរ • ‎中文 • ‎日本語 • ‎한국어
PD 참고: 이 문서를 편집하면, CC0에 따라 당신의 기여를 배포하는 데 동의한 것으로 간주됩니다. 자세한 내용은 퍼블릭 도메인 도움말 문서를 보십시오.
PD
문서를 편집하지 않고 시각편집기를 시험하려면, 연습장에서 자유롭게 테스트해 보실 수 있습니다. 연습장에서 시각편집기를 사용하기 위해 로그인하지 않아도 됩니다.


시각편집기 열기

시각편집기를 이용하여 문서를 편집하려면, 문서 상단의 "편집" 탭을 클릭하세요.

편집 창을 여는 것은 몇 초 가량 걸릴 수 있으며, 문서가 길 경우에는 더욱 오래 걸립니다.

"원본 편집" 탭을 클릭하면 기존의 위키문법 소스 편집기가 열립니다.

VisualEditor edit tab-ko.png

또한 각 문단의 "편집" 링크를 클릭하여 시각편집기를 열 수 있습니다.
VisualEditor - Section edit links-en.png

시작하기: 시각편집기 툴바

시각편집기 툴바 스크린샷
시각편집기 툴바는 시각편집기로 편집을 시작할 때 화면 최상단에 나타납니다. 툴바에는 친숙한 아이콘 여러 개를 포함하고 있습니다:

VisualEditor - Toolbar - Undo-redo.png
당신이 한 편집을 '실행 취소'하거나 '다시 실행'합니다.

VisualEditor Toolbar Headings-ko.png
문단 제목 드롭다운 메뉴: 문단 제목의 서식을 변경할 수 있도록 합니다. 문단 제목 스타일을 바꾸려면 커서를 해당 문단 제목에 둔 뒤에 본 메뉴의 항목을 선택합니다. (텍스트를 블럭잡으실 필요는 없습니다.) 문단 제목은 "문단 제목"으로 설정되어 있고, 하위 문단은 "1단계 하위 문단 제목", "2단계 하위 문단 제목" 등입니다 텍스트에 대한 일반적 형식은 "문단"입니다.

VisualEditor Toolbar Formatting-ko.png

형식: "A"을 눌러 메뉴를 엽니다.

  • "굵게" 항목(B)은 선택된 텍스트의 글씨를 굵게 합니다.
  • "기울임꼴" 항목(I)은 선택된 글자를 기울입니다.
  • "위 첨자" 항목(x2)은 선택된 글자 크기를 줄여주면서도 주변 텍스트보다 위치가 살짝 높도록, 즉 윗첨자를 쓰게 해 줍니다.
  • "아래 첨자" 항목(x2)은 선택된 글자 크기를 줄여주면서 주변 텍스트보다 위치가 살짝 낮도록, 즉 아랫첨자를 쓰게 해줍니다.
  • "취소선" 항목(S)은 선택된 텍스트를 가로지르는 취소선을 넣어줍니다.
  • "컴퓨터 코드" 항목(중괄호 묶음: {})은 전후에 위치한 다른 텍스트와 구분되도록 선택된 텍스트를 고정폭 폰트로 바꿔줍니다.
  • "밑줄" 항목(U)은 선택된 텍스트 밑에 밑줄을 넣어줍니다.
  • "언어" 항목(文A)은 선택된 텍스트에 언어(예: 프랑스어)와 읽는 방향(예:오른쪽에서 왼쪽)을 표시하게끔 해줍니다.
  • 마지막으로 "제거"(VisualEditor MediaWiki theme clear icon bitmap.png) 항목은 선택된 텍스트에 적용된 문자 양식(링크 포함)을 모두 제거합니다.

그 어떤 텍스트도 선택하지 않았을 경우, """A"""를 클릭해서 메뉴를 엽니다. 마우스 커서가 어디 있든지 간에 당신이 선택한 텍스트 포맷이 적용됩니다.


VisualEditor - Toolbar - Linking.png
링크 도구: 사슬 모양 아이콘은 링크 도구입니다. 텍스트를 선택한 뒤에 클릭하게 되면 링크 대화창이 열립니다.

VisualEditor - Cite Pulldown.png
인용 menu: "인용"메뉴는 문장에 인용 표시("각주", 혹은 "참고문헌"이라고도 함)을 추가하고자 할 때 사용합니다. 모든 프로젝트에서는 기본적인 참고문헌 양식과 동일한 참고문헌을 다시 사용할 수 있는 기본 기능이 제공됩니다. 해당 위키에서 기능이 활성화되어 있다면, 해당 위키에서 사용되는 각주 틀을 빠르게 불러올 수 있게 해 주기도 합니다.

(각 위키의 인용 메뉴에 인용 틀을 추가하기 위한 도움말은 VisualEditor/Citation tool 에 있습니다.)


VisualEditor citoid Cite button-ko.png
⧼citoid-citefromidtool-title⧽ 버튼: Citiod 서비스가 활성화되어 있다면, 인용 메뉴 대신 ⧼citoid-citefromidtool-title⧽ 메뉴를 볼 수 있습니다.

Citoid 서비스는 자동으로 인용 틀을 채우려고 시도하게 됩니다.


VisualEditor Toolbar Lists and indentation-ko.png
목록 및 들여쓰기: 첫 두 개의 아이콘은 각각 점 목록나 숫자 목록을 만들 수 있도록 합니다. 마지막 두 아이콘은 목록의 들여쓰기나 내어쓰기의 정도를 조절할 수 있도록 합니다.

VisualEditor Insert Menu-ko.png
미디어, 주석 & 틀 도구: 각 아이콘은 대화창을 엽니다. 아래의 목록은 가능한 모든 옵션의 목록입니다.
  • "미디어" 아이콘(산 모양)을 클릭하면 미디어 대화창이 열립니다.
  • "틀" 아이콘 (퍼즐 모양)을 클릭하면 틀을 편집할 수 있습니다.
  • "표" 모양을 통해 표를 삽입할 수 있습니다.
  • "주석" 아이콘(말풍선)은 읽는 사람에게 보이지 않는 주석을 추가할 수 있도록 합니다. 이 주석은 편집할 때만 보입니다. 편집할 때 이 주석은 느낌표 아이콘으로 표시됩니다. 느낌표 아이콘을 클릭하면 주석을 편집하거나 삭제할 수 있습니다.
  • "상형 문자" 아이콘 (고리모양 - ☥)을 통해 상형문자 삽입 모드로 진입할 수 있습니다. (아래를 참조하세요.)
  • "Code block" 아이템은 코드를 삽입할 수 있게 해 줍니다
  • "Musical notation" 아이템은 기보법을 삽입할 수있게 해 줍니다
  • "갤러리" 아이콘 (그림 모음) 을 통해 갤러리를 삽입할 수 있게 해 줍니다.
  • "수학 공식" 아이콘(Σ)을 클릭하면 수식 입력 창이 열립니다.
  • "Graph" 버튼을 통해 그래프를 삽입할 수 있습니다.
  • "당신의 서명" 창을 통해 토론 문서에서 서명을 할 수 있습니다. 위키백과 문서와 같이 서명이 삽입되어서는 안 되는 문서의 종류 ("이름공간")를 인식하며, 이러한 문서에서는 선택할 수 없게 회색으로 처리됩니다.
  • 각주 목록 아이콘 (책 3개)을 누르시면 독자에게 출처를 어디에 표시할 것인지 정할 수 있는 대화 상자가 열리게 됩니다. 일반적으로 이 아이콘은 한 문서에 한 개만 있어야 합니다.

특수 문자 삽입: "특수 문자" (Ω) 아이콘이 "넣기" 메뉴 옆에 있습니다. 클릭하면 여러 특수 문자를 보여주는 대화상자를 보여줍니다. 이들 특수 문자에는 일반적인 기호, 발음 기호, 수학 기호가 포함됩니다. (이 목록은 위키별로 설정할 수 있습니다. VisualEditor/Special characters 을 참조하세요.)
VisualEditor Toolbar SpecialCharacters-ko.png

VisualEditor toolbar edit notices icon.png
편집 공지사항 버튼은 문서에 대한 공지사항을 보여줍니다.

VisualEditor More Settings-ko.png
문서 옵션 메뉴는 변경사항 게시 버튼 왼 쪽에 있습니다. 이 메뉴에서는 아래의 "옵션"을 선택할 수 있습니다.
  • '분류' 을(를) 이용하여 분류를 추가하거나, 분류 안에서 문서가 어떻게 정렬되어야 할 지 정할 수 있습니다.
  • '문서 설정' 을(를) 통해 문서를 넘겨주기로 변환하거나 넘겨주기의 설정을 바꿀 수 있고, 목차의 설정을 변경하거나 문단 옆의 편집 링크를 비활성화하거나 동음이의어 문서로 전환할 수 있습니다.
  • 고급 설정을 통해 검색 엔진의 색인 여부, 새 문단을 추가하는 탭을 보이게 할 지 여부, 그리고 표시되는 제목을 변경할 수 있습니다.
  • 언어s 을(를) 통해 이 문서와 연결된 다른 언어 문서를 확인할 수 있습니다.
  • 사용되는 틀 도구를 통해 이 문서에서 사용되는 틀을 확인할 수 있습니다.

옵션 탭의 탭들은 문서 옵션 창에서도 볼 수 있으며 해당 창을 클릭하여 열 수 있습니다. 추가로, 문서 옵션 메뉴에서는 오른쪽에서 왼쪽으로 보기 버튼과 찾아 바꾸기 기능이 존재합니다. 찾아 바꾸기 기능을 통해 문서에서 특정한 단어, 문구, 또는 정규표현식을 이용해 다른 내용으로 변경할 수 있습니다.


VisualEditor bi-directional switching square brackets icon.png
원본 편집으로 전환 버튼은 변경사항 게시 버튼 옆에 있으며, 클릭하면 위키텍스트 편집기로 전환합니다.

편집 배포하기

편집을 마쳤다면 툴바에 있는 청색 "변경사항 게시" 버튼을 클릭하십시오. 아무런 변화가 청색 버튼을 누를 수 없습니다. 편집을 모두 취소하려면, 브라우저 창을 닫거나 편집 툴바 위의 "읽기" 탭을 누르십시오.
VisualEditor toolbar actions-ko.png

청색 "변경사항 게시" 버튼을 누르면 당신의 편집에 대한 간단한 편집 요약을 입력할 수 있으며, 사소한 편집으로 취급하거나, 앞으로 문서에 대한 편집을 주시하도록 설정할 수 있는 작은 대화창이 열립니다.

"바뀐 내용 검토" 버튼을 통해 바뀐 점이 의도한 대로 변화되었는지 확인할 수 있습니다. 이 기능은 위키텍스트 편집기의 "차이 보기" 기능과 유사합니다.

"편집 재개" 버튼을 통해 편집 모드로 다시 돌아갈 수 있습니다. 편집은 다시 배포할 수 있습니다.

VisualEditor save dialog-ko.png

링크 편집하기

VisualEditor - Toolbar - Linking.png
링크는 툴바에 있는 고리 모양의 "링크" 아이콘을 통해 추가하거나 Ctrl+K (Mac에서 Cmd+K) 단축키를 통해 추가할 수 있습니다.

문자열을 선택하거나 어떤 단어에 커서를 두고 "링크" 버튼을 누르면 해당 문자열에 링크가 삽입됩니다. 단어 하나만 있는 링크의 경우 해당 단어를 선택하거나 커서를 그 단어에 두면 됩니다.


VisualEditor-link tool-search results-ko.png
버튼을 누르든 단축키를 사용하든, 링크 대상을 입력할 수 있는 대화창이 뜹니다.

링크 도구는 기본적으로 내부링크를 검색합니다.


VisualEditor link tool 2015.png
링크할 대상을 입력하고 나면, Enter 키를 누르거나, 상자 밖을 클릭하거나, 닫기 아이콘(완료)을 클릭할 수 있습니다. 당신이 건 링크는 시각편집기 창에는 뜨지만, 문서를 배포하기 전까지는 배포되지 않습니다.

VisualEditor-link tool-external link.png
위키백과 외부의 웹 페이지로 링크할 때에도 과정은 똑같습니다; 입력창에 링크 주소를 입력하면 "외부 링크"로 추가될 것입니다.

VisualEditor link tool simple link.png
레이블 고리 없이 바깥 고리를 사용하면 이렇게 됩니다. : [1] 커서를 임의의 단어 (예 : 공백 뒤)에 두어 추가 할 수 있습니다. 단축키를 누르거나 버튼을 클릭하여 링크 도구를 열 수 있습니다. URL을 박스에 삽입하고, "완료" 버튼을 클릭하면 링크가 삽입됩니다.

VisualEditor-context menu-link tool.png
기존에 있는 링크를 변경하거나 제거하려면, 문자열에 있는 링크를 클릭하고, 옆에 뜨는 "링크" 아이콘을 클릭하십시오. 툴바의 같은 아이콘을 클릭하거나 Ctrl+K 단축키를 사용할 수도 있습니다. 링크를 선택하면 프레임이 파란색으로 나타납니다.

그리고 링크 대상을 편집하거나, 대화창 오른쪽 상단에 있는 쓰레기통 모양의 "제거" 아이콘을 눌러 링크를 없앨 수도 있습니다. 또한 링크를 눌러 링크 대상을 새 창에 열리도록 할 수 있습니다.(외부 링크가 유효한지 확인하는 데 유용합니다.)

링크 레이블 (링크로 표시되는 이름)을 설정했거나 링크 뒤에 본문 내용을 집어넣으려면 키를 누르십시오.

  • 한 번 누르면 링크 편집 모드에서 나와 커서를 링크 맨 뒤로 보냅니다 (파란 프레임).
  • 두 번 누르면 커서는 링크된 요소 뒤에 위치하게 됩니다. 나머지 본문을 입력하면 됩니다.

존재하는 링크의 링크 레이블을 편집하려면, 링크 레이블 안을 클릭하고 새 레이블을 입력하세요. 레이블을 전부 변경하고 싶다면 다음 사항을 명심해야 합니다.

  • 모든 (하이라이트로 표시됨) 링크 레이블을 선택한 후 (아무 키든) 키를 누르면 링크가 삭제됩니다. 처음부터 다시 링크할 수 있습니다.
  • 링크를 유지하려면, 링크 레이블 안을 클릭하여, 본문 내용을 하나씩 필요한 만큼만 지우십시오. 파란 링크 공간이 남아 있을 것입니다. 이제 원래 링크를 이용해 새 레이블을 입력할 수 있습니다.
  • 분류, 파일, 다른 파일을 링크할 수 있습니다.

각주 편집하기

For further information, see 인용 틀 도움말 또는 Citoid의 "인용" 버튼 도움말

어떤 시스템이 사용되는지 이해하기

위키에서 다음 세 가지 중 하나의 각주 시스템을 사용하고 있을 수 있습니다. 오른 쪽에 있는 것이 가장 간단한 구조입니다. "인용" 메뉴에 아무런 인용 틀을 포함하지 않습니다. 이 위키에서 이 시스템을 사용한다면, 이 문서에 있는 내용 외에 더 알아야 할 것이 없습니다.
VisualEditor cite menu default.png

두번째 구조는 첫번째 구조와 동일한 "인용" 메뉴를 사용하지만, 자주 사용되는 여러 인용 틀이 미리 설정되어 있어 빠르게 누를 수 있습니다. 위키에서 이 구조를 사용한다면, Help:VisualEditor/User guide/Citations-Templates 에서 더 많은 정보를 찾을 수 있습니다.
VisualEditor references more.png

VisualEditor citoid Cite button-ko.png
세번째 구조에서 인용 버튼을 눌러 시작하게 됩니다. 선택 창이 열리고, Citoid 시스템을 이용한 자동 인용 프로세스를 사용할 수 있습니다. 위키에서 이 구조를 사용한다면, Help:VisualEditor/User guide/Citations-Full 에서 더 많은 정보를 찾을 수 있습니다.
VisualEditor Citoid Automatic tab.png

이미 존재하는 각주 편집하기

이미 존재하는 주석을 편집하려면, 주석을 클릭하고 (일반적으로 괄호 안의 숫자로 표시됨), 툴바나 클릭한 주석 옆에 뜨는 책갈피 모양의 "각주" 아이콘 또는 아이콘과 이름을 클릭하십시오. 어떤 아이콘을 클릭하던 간에, "편집" 버튼을 클릭하면 주석을 편집할 수 있는 창이 표시됩니다.
VisualEditor - Editing references 1.png

각주 아이콘을 클릭하면, 주석의 내용을 편집할 수 있는 작은 편집기를 포함하고 있는 대화창이 열립니다.

많은 위키에서는 참고 문헌의 형식을 맞추기 위해 틀을 사용합니다. 기존에 있는 주석이 틀이라면, 주석을 편집하려고 선택하면 주석 내용이 푸른 색으로 변합니다.

틀이 사용되었고 주석 정보를 누르게 되면 틀 아이콘 (퍼즐 모양)이 나타나며 추가 정보를 알려 줍니다. "편집" 버튼을 눌러 틀 미니 편집기를 이용해 틀의 내용을 편집할 수 있습니다.

VisualEditor - Editing references 6.png

주석 위의 정보를 클릭했을 때 인용 틀 아이콘 (우측에 예시가 있습니다)이 등장한다면, "편집" 버튼을 누르면 틀 미니 편집기 창을 열 수 있습니다.
VisualEditor - Editing References - Cite Web.png

틀 미니 편집기에서 정보의 유형을 변경하거나 존재하는 내용을 변경할 수 있습니다. 이미 내용이 있는 틀의 값 (틀 변수)만 표시됩니다. 새 값을 추가하려면 미니 편집기 맨 아래의 "자세한 정보 추가" 를 클릭하십시오.
VisualEditor - Editing references 5.png

작업을 마치고, 주석 편집기로 돌아가려면 "바뀜 적용"을(를) 클릭하십시오.
VisualEditor Apply Changes-ko.png

이미 있는 각주를 재사용하기

출처를 제시하고자 할 때 해당되는 주석이 이미 있다면, 이미 있는 주석을 재활용할 수 있습니다.

기존에 있는 주석을 재활용하려면, 커서를 주석을 추가하려고 하는 곳에 둔 다음, "인용" 메뉴의 "주석 재사용" 버튼을 클릭하십시오.

(주의: 위의 주석 구조 중 세 번째 구조를 사용하는 위키의 경우, "인용" 메뉴의 "재사용" 버튼 대신 "재사용" 메뉴가 제시됩니다.)

VisualEditor Cite menu re-use.png

각주 창에서 재사용하고자 하는 각주를 찾아 선택하십시오. 주석이 많다면, "현재 인용 안에서 검색" 레이블의 검색 창을 선택하여 특정 문구를 포함하는 주석만을 볼 수 있습니다.
VisualEditor - Editing references 18.png

새 주석 추가하기

"인용" 메뉴를 이용해 주석을 추가하려면, 문서에 주석을 추가하고자 하는 곳에 커서를 두고, 툴바에 있는 책갈피 모양의 "주석" 아이콘을 클릭하십시오.
VisualEditor references more.png

"기본" 인용 사용하기

아래의 내용은 기본 인용 항목에서 보게 될 내용입니다. 주석 편집기에서, 참고 문헌 내용을 추가, 편집하거나 모양을 바꿀 수 있습니다.

특정한 주석을 그룹에 속하도록 할 수도 있지만, 일반적으로 이 목록은 사용하지않습니다. (이 옵션은 "각주 목록" 도구를 이용해 주석 목록을 따로 표시하기 위해 사용됩니다.)

VisualEditor - Editing references 20.png

주석 편집기의 새 주석에서 인용 틀을 포함하려면, "넣기" 툴바의 틀 아이콘 (퍼즐 모양)을 클릭하세요.
VisualEditor Template Insert Menu-ko.png

그리고, 사용할 틀을 찾아보고, 추가한 후, 기존에 있는 주석을 편집하는 것과 같은 방법을 통해 편집하십시오. (틀 편집에 도움이 필요한 경우 틀 편집하기 문단을 참조하십시오.)

주석 편집기로 돌아가려면 "바뀜 적용"을(를) 클릭하시고, 문서 편집창으로 돌아가려면 "바뀜 적용"을(를) 한번 더 클릭하십시오.

VisualEditor - Editing references 9.png

문서에 주석 목록이 없는 상황이라면(예를 들어 문서에 첫 번째 주석을 추가한 경우), 독자에게 주석 내용을 표시하려면 주석 목록을 추가해야 합니다.

주석 목록을 추가하려면, 주석을 표시하고자 하는 곳(일반적으로 문서 하단)에 커서를 두고, "넣기" 메뉴를 클릭한 다음 책 3권 모양의 "각주 목록" 아이콘을 클릭하십시오,

VisualEditor References List Insert Menu-ko.png

주석에 그룹을 생성했다면, 대화창에서 그룹을 지정해 특정 그룹에 속한 주석을 선택적으로 표시할 수 있습니다.

단순히 주석 목록을 추가하려면, 대화창에서 "넣기"을 클릭하십시오.

VisualEditor references list-ko.png

일반 인용 틀 사용하기

당신의 위키의 "인용" 메뉴 아래에 추가적인 인용 틀이 제공될 수 있습니다. 이런 경우, 이 위키에서 자주 쓰이는 인용 틀이 제공되는 것입니다. (추가적인 인용 틀을 추가하기 위한 방법은 VisualEditor/Citation tool 을(를) 참조하시기 바랍니다.)
VisualEditor - Editing References - Cite Pulldown.png

"책 인용"과 같은 틀 아이콘을 클릭하게 되면 해당 틀을 편집하기 위한 미니 편집기로 이동합니다. 중요한 정보는 별표가 되어 있을 수 있습니다. 자주 사용되는 중요한 정보가 표시될 수 있지만, 모든 값을 채워야 하는 것은 아닙니다.
VisualEditor - Editing references - Cite book required fields.png

추가적인 파라미터를 추가하려면, 틀 미니 편집기를 스크롤하여 "자세한 정보 추가" 옵션을 선택하십시오.

작업을 마쳤으면 "넣기" 을 선택하십시오.

VisualEditor - Editing references - Add parameter.png

사진 편집 및 기타 미디어 파일들

사진 편집

새 사진 (또는 다른 미디어 파일)을 추가하려면 "넣기" 메뉴에서 "미디어" 아이콘 (산 그림)을 클릭하십시오. 이미지는 현재 커서가 위치한 자리에 추가됩니다.
VisualEditor Media Insert Menu-ko.png

"미디어" 아이콘을 클릭하면 현재 편집하는 문서와 관련된 미디어 파일을 위키미디어 공용과 현재 위키에서 자동으로 찾아 주는 대화창이 열립니다.

대화창의 검색어 상자에 찾을 문자열을 바꾸면 다른 미디어 파일을 찾아볼 수 있습니다.

파일을 선택하려면 섬네일을 클릭하십시오.

섬네일을 클릭하면 편집 중인 문서에 사진을 삽입합니다.

VisualEditor - Media editing 2.png

사진을 삽입한 후에 새 창이 열립니다. 이 창에서 사진의 캡션을 삽입하고 수정할 수 있습니다. 캡션에는 포맷 관련 명령어와 링크를 포함할 수 있습니다.
VisualEditor - Media editing 6.png

미디어 창에서 스크린 리더를 사용하는 사용자와 이미지를 보지 않기로 선택한 사용자를 위한 이미지에 대한 설명을 추가할 수 있습니다.
VisualEditor - Media editing 7.png

"고급 설정" 창에서 사진에 대한 여러 변수를 조정할 수 있습니다. 조정할 수 있는 값에는 사진의 정렬 방향, 사진의 종류, 사진의 크기 등을 포함합니다.
VisualEditor - Media editing 8.png

작업을 마쳤다면, 대화창을 닫고 편집기로 돌아가기 위해 "바뀜 적용"을 클릭하십시오.
VisualEditor Apply Changes-ko.png

이미 존재하는 사진을 클릭하고 사진 아래에 등장하는 "미디어" 아이콘을 클릭하면 캡션을 추가/수정하거나 그 외 다른 설정을 조정할 수 있습니다.

이미 올려진 이미지를 누르고 사이즈 변경 아이콘 (하단 양 끝의 쌍방향 화살표)을 조정하는 것으로 사진의 크기를 변경할 수 있습니다.

사진을 드래그 한 후 문서의 다른 위치에 드롭하여 이동할 수 있습니다.

VisualEditor - Media editing 3.png

사진 업로드

미디어 창의 탭을 통하거나, 파일을 편집기에 드래그 앤 드롭하거나, 클립보드의 이미지를 붙여넣음으로써 사진을 올릴 수 있습니다.
VisualEditor - Media upload 1.png

업로드 탭을 누르고 컴퓨터에 저장된 사진을 선택하세요. 파일 이름을 입력하거나, 사진을 박스에 드래그할 수 있습니다. 편집기로 사진을 드래그 앤 드롭했거나 클립보드의 사진을 붙여넣었다면 업로드 창이 자동으로 켜집니다.
VisualEditor - Media upload 1.png

사진에 대한 설명과 분류를 입력하여 다른 사용자들이 이 사진을 찾을 수 있도록 해야 합니다.
VisualEditor - Media upload 2.png

작업이 완료되면 사진은 문서에 자동으로 삽입됩니다.
VisualEditor-logo.svg

갤러리 편집하기

새 갤러리를 추가하려면, "넣기" 메뉴에서 "갤러리" 아이콘 (사진 모음)을 누르세요. (이 창이 보이지 않는다면, 당신의 위키에서 시각편집기에 이 기능을 도입하는 것을 미루기로 결정한 것입니다.)
VisualEditor - Gallery1.png

이미 설정된 갤러리를 수정하려면 갤러리를 클릭하세요. 다음으로, 갤러리 맨 아래 근처의 갤러리 아이콘 (사진 모음) 을 클릭하세요. 갤러리의 모든 사진을 포함하는 갤러리 편집기가 로딩됩니다.
VisualEditor - Gallery2.png
갤러리 편집기는 현재 위키텍스트 편집기를 통해 이미 존재하는 갤러리의 사진을 편집할 수 있도록 해 주는 간단한 박스 창입니다. 갤러리에 새 사진을 추가하려면, 파일 이름을 넣고, 바를 넣은 다음 (|) 해당 사진에 대한 설명을 삽입하세요. 각 사진은 한 줄에 하나씩 넣어야 합니다. 이러한 방식으로 사진을 삭제하거나, 사진의 표시 순서를 변경하거나, 캡션을 변경할 수 있습니다.

"완료" 버튼을 클릭하면, 갤러리 편집기를 나갑니다. 이제 변경한 내용이 저장되면 보일 내용과 같이 표시됩니다.

갤러리 편집기 자체는 변경된 내용을 배포하지 않는다는 점을 기억하세요. 문서에 가해진 다른 변경 사항과 마찬가지로, 변경한 내용을 배포하기 위해서는 문서 전체를 배포해야 합니다.

VisualEditor - Gallery3.png

틀 편집하기

시작하기

문서에 새 틀을 추가하려면, 틀을 삽입하고자 하는 곳에 커서를 위치시키고, 툴바의 "넣기" 메뉴에 있는 퍼즐 모양의 "틀" 아이콘을 클릭하십시오.
VisualEditor Template Insert Menu-ko.png

삽입하고자 하는 틀의 이름을 입력하고, 원하는 틀의 이름이 보이면 클릭한 다음 "틀 추가"을(를) 클릭하십시오.
VisualEditor - Template editing 4.png

이미 문서에 존재하는 틀을 편집할 수도 있습니다. 문서의 틀을 선택하면 파란 색으로 변하며 틀 창이 표시됩니다. 이 때 편집 창을 클릭하세요.
VisualEditor - Template editing 1.png

일부 틀은 문서의 독자에게 보이지 않을 수 있습니다. 시각편집기에서 이러한 틀은 퍼즐 아이콘으로 표시됩니다. 틀의 이름이 퍼즐 아이콘 옆에 표시됩니다.
VisualEditor template not visible.png

틀 아이콘을 선택하면 선택 메뉴가 표시되며, 이 창에서 틀을 편집할 수 있습니다.
VisualEditor template not visible context menu.png

틀 변수

새 틀을 추가하거나 이미 존재하는 틀을 수정할 때, "틀" 창이 표시됩니다. 이 내용은 틀이 TemplateData 시스템으로 정의되었는지 여부에 따라 다른 내용이 표시됩니다.

여기 표시된 틀에는 틀데이터가 정의되어 있지 않습니다. 따라서 이 창은 단순히 틀의 설명 문서를 보여주는 링크를 표시합니다. 틀의 설명 문서를 통해 이 틀에 변수가 있는지 파악할 수 있고, 각 틀에 어느 값이 사용되는지 파악할 수 있습니다. 이름이 없는 변수의 경우 번호를 사용하십시오. 첫번째 이름 없는 변수는 1이고, 두번째 이름 없는 변수는 2이며 이 순서대로 계속됩니다.
VisualEditor template with no TemplateData.png

틀이 틀데이터 정보를 표시하도록 갱신되었다면, 창에 각 틀의 변수 목록을 표시해 줍니다.
VisualEditor template with TemplateData.png

이미 존재하는 틀의 경우 창에 표시되는 변수를 수정하거나, 창 맨 아래의 자세한 정보 추가 버튼을 클릭함으로써 새 변수를 삽입할 수 있습니다.
VisualEditor - Template editing 3.png

틀이 다른 틀을 포함하고 있을 경우, 이 포함된 틀은 이 틀을 표시하는 틀의 변수칸에 나옵니다. 변수 값 안에서 편집되거나 변수를 삭제할 수 있습니다.

새 하위틀은 변수를 추가하는 방식을 따르면 추가할 수 있습니다. 하위 틀 기능이 지원되는지 여부를 틀 설명문서에서 확인하세요. 중첩된 틀은 현재 시각편집기의 도움을 받을 수 없으며, 위키텍스트 편집기를 통해서만 편집할 수 있습니다. (phab:T52182를 참조하세요)

VisualEditor - Template editing 5.png

끝내기

작업을 마쳤다면, "바뀜 적용"을(를) 눌러 창을 닫고 편집기로 돌아가십시오.
VisualEditor Apply Changes-ko.png

틀 풀어쓰기

틀을 반드시 풀어주어야 할 경우에는, 틀 이름 앞에 subst:(콜론 포함)를 넣어주십시오.

subst:를 먼저 쓰면 자동 완성이 되지 않습니다. 자동 완성이 필요하다면 찾는 틀을 먼저 찾고 나서 subst:를 추가하십시오.

그리고, 녹색의 "틀 추가" 버튼을 클릭하십시오.

변수는 평소대로 추가해 입력하고 "넣기"을(를) 클릭합니다.

VisualEditor - Template editing 7.png

"바뀜 적용"을(를) 적용하면 틀이 문서에 표시된 것을 알 수 있습니다.
VisualEditor - Template editing 8.png

목록 만들기

VisualEditor Toolbar Lists and indentation-ko.png
시각편집기를 이용해 목록을 만들거나 이미 존재하는 목록의 양식을 변경할 수 있습니다. 순서화된 목록 (번호)과 순서화되지 않은 목록 (점)의 두가지 종류의 목록이 있습니다.

새 목록을 추가하기 위해서는 표시된 두가지 메뉴 항목 중 하나를 클릭하십시오. 이미 목록을 입력했다면, 입력한 목록을 선택 (하이라이트)한 다음 메뉴 항목을 선택하십시오.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
여기 보이는 예시는 순서대로 정렬되지 않은 목록과 순서대로 정렬된 목록의 예시입니다.

VisualEditor lists 3 select to indent.png
이미 존재하는 목록의 들여쓰기 수준을 조정하려면, 목록에서 변경하려는 부분을 선택하십시오.

VisualEditor lists 4 indentation menu.png
그 다음 , 메뉴를 사용하거나 탭 키를 누르십시오. (탭 키는 해당 내용을 한 단계 들여씁니다. 시프트 키와 탭 키를 동시에 눌러 내용을 내어쓰십시오.)

VisualEditor lists after indenting.png
내용을 들여쓰면 이렇게 표시됩니다.

VisualEditor lists mixed.png
목록의 항목이 들여쓰기 단계가 다르다면, 순서화된 목록과 순서화되지 않은 목록을 섞어 쓸 수 있습니다.

표 편집하기

VisualEditor insert table-ko.png
시각편집기를 통해 표를 삽입하거나 편집할 수 있습니다.

컴퓨터에 저장된 csv 파일을 편집기로 드래그한 후 드롭하여 표를 삽입할 수 있습니다.


"표" 메뉴를 클릭한 후 "넣기" 창을 클릭하면 시각 편집기가 4열 4행의 표를 삽입합니다.

이제 "표" 창을 볼 수 있습니다. 이 메뉴값에서 표의 최상단 줄을 통해 캡션을 추가할 수 있습니다.

VisualEditor empty table.png

셀을 선택하려면 한 번 클릭하십시오.
VisualEditor tables select one cell.png

셀의 내용을 편집하려면 (내용을 추가하거나 변경하려면) 셀을 두 번 클릭하십시오. 아니면 셀을 선택한 다음 엔터를 눌러도 됩니다.

셀 편집을 종료하려면 다른 곳을 클릭하십시오.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
행과 열을 추가하거나 삭제할 수 있습니다.

셀을 병합하려면 병합할 셀을 선택하고, 표 창에서 "셀 병합"을 선택하십시오.
VisualEditor tables merge cells.png

셀을 병합하면, 하나의 셀에 있는 내용만 보존됩니다. 다른 셀에 있는 값은 병합하면서 모두 삭제됩니다. 보존되기를 원하는 내용이 삭제되었다면 변경한 내용을 취소한 다음, 남길 내용을 옮긴 다음 다시 셀을 병합하십시오.
VisualEditor tables post-merge cell.png

병합되었던 셀에서 내용을 분리할 수 있습니다. 병합되어 있던 셀에 있던 내용은 분리된 셀 중 맨 위에 있는 셀에 남습니다. 필요하다면 다른 셀로 오린 후 붙여넣을 수 있습니다.
VisualEditor tables split cells.png

분류 편집하기

VisualEditor category item-ko.png
분류를 편집하려면 "문서 옵션" 메뉴에서 "분류" 항목을 선택하십시오.

VisualEditor category editing-ko.png
"분류" 버튼을 누르면 현재 분류를 나열하고 새 분류를 추가하거나 분류를 삭제할 수 있는 대화창이 열립니다.

분류에서 문서가 어느 위치에 나타날 지 정하는 정렬 키를 변경할 수 있는 옵션 또한 제공됩니다.

예를 들어, "마이크로소프트 오피스 공유 도구"의 정렬 키 값은 "공유 도구"입니다. "마이크로소프트 오피스" 분류에서 이 문서는 "ㅁ" 글자 아래가 아닌 "ㄱ" 글자 아래에 정렬됩니다.


VisualEditor - Category editing 3.png
새 분류를 추가하려면 "분류 추가"라고 쓰인 칸에 분류 이름을 입력하십시오. 분류의 이름을 입력하는 동안 시각편집기가 이미 존재하는 분류를 검색합니다. 새 분류를 만들 수도 있고, 기존에 있는 분류를 선택할 수도 있습니다. (새 분류 문서를 만들 때까지 새 분류 글자는 빨간 색으로 표시됩니다. 편집하던 문서를 저장해도 빨간 색으로 표시됩니다.)

VisualEditor - Category editing 2.png
분류를 제거하려면, 해당 분류를 클릭하여 나타나는 대화창에서 쓰레기통 모양의 "제거" 아이콘을 클릭하십시오.

특정 분류에 대한 정렬 키를 지정할 수도 있습니다. 이는 기본 정렬 키보다 우선 적용됩니다.


VisualEditor Apply Changes-ko.png
분류를 편집하는 작업을 마치고 문서 편집기로 돌아가려면 "바뀜 적용"을(를) 클릭하십시오.

문서 설정 편집하기

VisualEditor page settings item-ko.png
문서의 설정을 편집하려면 툴바의 "문서 옵션" 메뉴를 클릭한 다음 "문서 설정" 버튼을 클릭하십시오.

VisualEditor Page Settings-ko.png
"문서 설정" 버튼은 여러 옵션을 표시하는 창을 표시합니다.

VisualEditor Page Settings Redirects-ko.png
"이 문서를 다음으로 넘겨주기" 체크박스를 클릭한 후 이 문서를 방문하는 사용자가 넘어가야 할 문서의 이름을 입력함으로써 문서를 넘겨주기 문서로 만들 수 있습니다.

맨 아래의 옵션은 문서 이름이 변경될 때 이 넘겨주기를 업데이트하지 않도록 선택할 수 있습니다. 이 기능은 거의 사용되지 않습니다.


VisualEditor Page Settings TOC-ko.png
세개의 값 중 하나를 선택하여 문서의 목차를 어디에 보여줄 지 선택할 수 있습니다. 기본값은 "필요하다면"으로써, 3개 이상의 문단이 있을 때 목차를 보여 줍니다.

VisualEditor Page Settings Edit Links-ko.png
이 체크박스를 선택하면 문단 이름 옆에 있는 해당 문서를 편집하는 창을 비활성화할 수 있습니다.

VisualEditor Apply Changes-ko.png
문서 옵션 편집을 마치고 문서 편집기로 돌아가려면 "바뀜 적용" 버튼을 클릭하십시오.

지도 편집하기

Visual editor showing editing an existing map.jpg
지도를 삽입하고 편집할 수 있습니다. Help:VisualEditor/Maps 문서를 참조하십시오.

수학 수식 편집하기

새로운 수식을 추가하려면 커서를 추가하고자 하는 곳에 위치시키고 툴바의 "넣기" 메뉴의 "수학 공식" 아이콘("Σ")을 클릭합니다.
VisualEditor Formula Insert Menu-ko.png

LaTex 문법으로 수식을 입력할 수 있는 창이 나타납니다. 수식이 입력될 때 마다 모양이 바뀌면서 입력된 수식이 어떤 모양인지 보여줍니다. 수식 입력을 만족스럽게 마쳤다면 "완료"을 누르세요.
VisualEditor formula-ko.png

문서에 원래 있는 수식을 편집하려면, 수식을 클릭한 후, 나타나는 "Σ"아이콘을 클릭합니다. 그러면 수식 창이 열려 변경할 수 있습니다.
VisualEditor - editing existing mathematical formula.png

수학 수식은 본문 안에도 나타나게 할 수 있고(inline), 본문과 별도로 가운데에(block 혹은 display)에 나타나게 할 수 있습니다.
VisualEditor mathematic formula inline.png

악보 편집하기

문서에 새 악보를 추가하려면, 악보를 삽입할 자리에 커서를 위치시키세요. 그런 다음, 툴바의 "삽입" 메뉴에서 "악보" 옵션을 선택하세요.

문서에 이미 존재하는 악보를 편집하려면 악보를 더블클릭하세요.

VisualEditor-Insert-Musical-Notation.png

"기보법" 창이 나타나게 됩니다. 이 창에서 기보법의 장단조를 ABC 식 또는 릴리폰드 식으로 수정할 수 있습니다. 음악 파일 또는 MIDI 파일의 기보법을 링크할 수 있습니다. 작업을 완료했다면, "완료" 버튼을 클릭하여 창을 닫고 변경 사항을 배포할 수 있습니다.
Musical.png

시나 다른 특수 항목 편집하기

시와 별점 기능과 같은 몇몇 항목은 시각편집기에서 아직 지원하지 않습니다.
VisualEditor editing poem 1.png

대부분의 경우 이미 존재하는 항목을 수정할 수는 있지만, 시각편집기를 이용해 새 항목을 삽입할 수는 없습니다.

이러한 기능들이 완전히 지원될 때까지 이미 있는 문서를 복사 및 붙여넣기 하거나, 위키텍스트 편집기에서 직접 편집할 수 있습니다.

VisualEditor editing poem 2.png

위키텍스트 편집기와 시각편집기 전환하기

시각편집기에서 위키텍스트 편집기로 전환하려면 문서 우측 끝의 [[ ]] 버튼을 누르세요.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

문서를 편집하던 중이라면, 저장되지 않은 내용을 유지할 지 여부를 확인해야 합니다. 일반적으로 문서의 내용을 유지하고 싶을 것입니다."

VisualEditor bi-directional switching to wikitext.png

문서의 차이를 볼 수 있습니다. (바뀐 사항을 버렸다면, 편집 창을 바로 볼 것입니다.)

스크롤을 내리면 위키텍스트 편집 창을 볼 수 있습니다.

VisualEditor bi-directional switching diff before wikitext.png

위키텍스트 편집기에서 시각편집기로 전환할 수도 있습니다. 툴바 우측 끝의 연필 아이콘을 클릭하세요.

VisualEditor bi-directional switching pencil icon in wikitext.png

연필 아이콘을 클릭했을 때 문서를 편집한 상태였다면, 변경한 내용을 유지할 것인지 여부를 확인해야 합니다. 변경한 내용을 유지한다면, 바로 시각편집기가 구동됩니다. 변경한 내용을 버린다면, 시각편집기를 구동하기 전에 정말로 문서의 내용을 버리는지 확인해야 합니다.

VisualEditor bi-directional switching to visual editing.png

키보드 단축키

많은 편집자들이 특히 굵은 글씨, 기울인 글씨와 위키링크를 삽입할 때 위키텍스트를 직접 입력하는 데 익숙해 있습니다. 키보드 단축키는 툴바 버튼을 클릭할 필요 없이 빠르게 비슷한 서식 적용을 할 수 있도록 해 줄 것입니다. 흔히 사용하는 일반적인 단축키나 다른 편집자들이 쓰던 단축키들은 시각편집기에서 작동할 것입니다:

PC 단축키 동작 Mac 단축키

Ctrl+B 굵은 글씨 Cmd+B

Ctrl+I 기울인 글씨 Cmd+I

Ctrl+K 링크 삽입하기 Cmd+K

Ctrl+X 잘라내기 Cmd+X

Ctrl+C 복사하기 Cmd+C

Ctrl+V 붙여넣기 Cmd+V

Ctrl+Z 실행 취소 Cmd+Z