Palīdzība:VisualEditor/Lietotāja instrukcijas

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 23% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD Piezīme: Labojot šo lapu, tu piekrīti savu devumu licencēt saskaņā ar CC0 licenci. Papildu informācijai skatīt sabiedrības īpašumā nodotās palīdzības lapas.
PD
If you would like to try the visual editor without editing an article, here is a page where you can freely test it. Tev nav nepieciešams konts, lai lietoto šajā lapā Vizuālo redaktoru.

Vizuālā redaktora atvēršana

Lai rediģētu lapu, lietojot Vizuālo redaktoru, nospied "Edit" pogu redigēšanas joslā lapas augšējā daļā.

Lapas atvēršana reģidēšanai var aizņemt dažas sekundes un vairāk, ja lapa ir ļoti gara.

Nospiežot "Edit source" pogu rediģēšanas joslā, tiks atvērts klasiskais vikiteksta redaktors.

VisualEditor edit tab-en.png

Tu vari atvērt Vizuālo redaktoru arī nospiežot saiti "edit" katrā sadaļā.
VisualEditor - Section edit links-en.png

Darba sākšana: Vizuālā redaktora rīkjosla

Vizuālā redaktora rīkjoslas ekrānuzņēmums
Vizuālā redaktora rīkjosla parādās ekrāna augšējā daļā, kad tu sāc rediģēt, izmantojot to. Tajā ir iekļautas dažas pazīstamas ikonas:

VisualEditor - Toolbar - Undo-redo.png
$atcelt un $atjaunot izmaiņas, ko tu esi veicis.

VisualEditor Toolbar Headings-lv.png
Virsrakstu izvēlne ļauj tev mainīt teksta virsraksta līmeni. Standarta sadaļu virsraktu līmenis ir "Virsraksts". The normal format for text is "Rindkopa".

VisualEditor Toolbar Formatting-lv.png

Formatting: Clicking the "A" opens a menu.

  • The "Pustrekns" item (B) bolds the selected text.
  • The "Kursīvā" item (I) italicizes the selected text.
  • The "Augšraksts" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly higher than the surrounding text.
  • The "Apakšraksts" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly lower than the surrounding text.
  • The "Pārsvītrojums" item (S) adds a solid bar through the selected text.
  • The "Datora kods" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • The "Pasvītrojums" item (U) adds a solid line beneath the selected text.
  • The "Valoda" item (Aあ) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "Noņemt noformējumu", removes all character formatting from the selected text, including links.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
Linking tool: The chain icon is the linking tool. Clicking on it (usually after selecting some text) opens the link dialog.

VisualEditor - Cite Pulldown.png
Atsauce menu: The "Atsauce" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to basic reference formatting and the ability to re-use citations, using this menu. This menu also gives you quick access to local citation templates, if these are enabled on your wiki.

(Instructions for adding local citation templates to the Atsauce menu at a specific wiki are available at VisualEditor/Citation toolVisualEditor/Citation tool.)


VisualEditor citoid Cite button.png
Cite button: If the citoid service is enabled on your wiki, then you will see a Cite button instead of a Atsauce menu.

The citoid service tries to fill out citation templates automatically.


VisualEditor Toolbar Lists and indentation-lv.png
Saraksti un atstarpes: pirmās divas ikonas ļauj tev izveidot numurētus vai aizzīmētus sarakstus. Pēdējās divas ikonas ļauj tev palielināt vai samazināt satura atstarpi.

VisualEditor Insert Menu-lv.png
Mediji, atsauces un iekļāvumi: katra ikona atver izvēlēto dialogu:
  • Ikona "Medijs" (attēls ar kalniem) atver mediju dialogu.
  • The "Veidne" icon (a puzzle piece) allows you to edit templates.
  • The "Table" item allows you to insert a table.
  • The "Komentārs" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode, where they are indicated by an exclamation mark icon. In edit mode, clicking on the exclamation mark icon allows you to edit or delete the comment.
  • The "Hieroglifi" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • The "Galerija" icon (a set of photos) allows you to insert a gallery to the page.
  • The "Formula" icon (Σ) opens the formula inserter dialog.
  • The "Graph" item allows you to insert a graph.
  • The "Tavs paraksts" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • * Ikona "⧼visualeditor-dialogbutton-referencelist-tooltip⧽" (trīs grāmatas) atver atsauču skatīšanas dialogu.

Special character insertion: The "Speciālā rakstzīme" (Ω) icon is next to the "Ievietot" menu. When clicked, it displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (This list may be customized locally. See VisualEditor/Special charactersVisualEditor/Special characters for instructions.)
VisualEditor Toolbar SpecialCharacters-lv.png

VisualEditor toolbar edit notices icon.png
The Edit notices button displays any notices for the page.

VisualEditor More Settings-lv.png
Atcelt vai saglabāt tavas izmaiņas.

VisualEditor bi-directional switching square brackets icon.png
The Pārslēgties uz vikikoda labošanu button is next to the Saglabāt lapu button. It allows you to switch to the wikitext editor.

Izmaiņu saglabāšana

Kad tu esi beidzis rediģēšanu, spied zaļo pogu "Save page" rīkjoslā. Poga nevar tikt nospiesta, ja nav veiktas nekādas izmaiņas. Lai atceltu visas rediģētās izmaiņas, vienkārši aizver pārlūkprogramas logu.
VisualEditor toolbar actions-lv.png

Nospiežot zaļo pogu "Saglabāt lapu", atveras mazs dialogs, kurā tu vai ievadīt izmaiņu kopsavilkumu, atzīmēt savu izmaiņu kā maznozīmīgu un izvēlēties uzraudzīt turpmākās izmaiņas šajā lapā. Kopsavilkuma lauks ir ekvivalents Kopsavilkums: laukam vikiteksta redaktorā.

Skaitlis norāda cik daudz vietas ir atlicis tavā izmaiņu kopsavilkumā. Tu vari arī pārskatīt savas izmaiņas, lai būtu drošs, ka tās strādā kā paredzēts, pirms saglabā savas izmaiņas, līdzīgi kā Rādīt izmaiņas poga vikiteksta redaktorā.

The "Turpināt labošanu" button returns you to the page you were editing. You can save all of your changes later.

VisualEditor save dialog-lv.png

Saišu rediģēšana

VisualEditor - Toolbar - Linking.png

Vikisaites var pievienot izmantojot ikonu "Saite" rīkjoslā vai lietojot īsinājumikonu Ctrl+K (vai Command+K Mac datoros).

Ja tu izvēlies tekstu vai novieto kursoru uz vārda, nospiežot pogu "Link" tiks ievietota saite šajā tekstā.


VisualEditor - Saites - Iekšējās.jpg
Vienalga vai tu lieto pogu, vai arī īsinājumikonu, atvērsies dialoglogs, kurā tu vari ievadīt saiti. Vizuālais redaktors centīsies palīdzēt ar iekšējām saitēm (saitēm uz citām Vikipēdijas lapām), meklējot līdzīgas lapas tikko tu sāc rakstīt.

The link tool will try to help with internal links by searching for likely matches.


frameless|border|center|400px Kad tu esi ievadījis vai izvēlējies saiti, tu vai piespiest Enter, uzklikšķināt ārpus dialoga vai nospiest aizvēršanas ikonu (<). Tava saite parādīsies Vizuālā redaktora lapā, bet tā netiks saglabāta, līdz tu saglabāsi lapu.

VisualEditor - Saites - Ārējās.jpg
Lai ievietotu saiti uz interneta lapu ārpus Vikipēdijas, process ir tieši tāds pats; vienkāši ievadi saiti laukā un tā tiks pievienota kā "Ārējā saite".

VisualEditor link tool simple link.png
External links without labels look like this: [1]. You can add these by placing your cursor away from any word (e.g., after a space). Atver saites rīku, nospiežot uz pogas, vai saitēm. Type the URL in the box, and click the "Gatavs" button to insert the link.

[[File:VisualEditor - Saites - Iekšējās rediģēšana.jpg|frameless|border|400px|center]] Lai izmainītu vai noņemtu eksistējošu saiti tekstā, uzspied un saites tekstā, tad nospied ikonu "Saite", kas parādās netālu. Tu vari arī uzspiest uz tās pašas ikonas rīkjoslā vai lietot īsinājumikonu Ctrl+K, kad ir uzspiests uz saites. When a link is selected, it appears as blue framed.

Tu vari izmainīt saites mērķi vai izņemt to, nospiežot 'Noņemt' pogu (miskaste) dialoga augšējā labajā stūrī. You can also open the link's target in another window by clicking on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

Atsauču rediģēšana

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "Atsauce" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "Atsauce" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-FullHelp:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Rediģēt eksistējošu atsauci

Lai rediģētu eksistējošu atsauci, uzspied uz tās tekstā un nospied ikonu "Atsauce" (grāmatzīme), kas parādās netālu, vai to pašu ikonu rīkjoslā.
VisualEditor - Atsauču rediģēšana 1.jpg

Uzspiežot uz Atsauču ikonas, atveras dialogs, kurā ieķlauts miniredaktors, kur tu vari rediģēt atsauces tekstu.

Vikipēdija latviešu valodā pārsvarā lieto veides, lai formatētu atsauces pēc specifiska standarta. Tu pamanīsi to, ja, rediģējot eksistējošu atsauci, viss saturs iekrāsosies zils, kad tu izvēlies to.

If a template was used and you click on the reference information, then the Veidne icon (puzzle piece) will appear with some information. Click on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Atsauču rediģēšana 6.jpg

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog. frameless|border|center|400px

Uzspiešana uz ikonas "Iekļāvums" (puzles gabals) atļauj tev rediģēt veides individuālos parametrus.
VisualEditor - Atsauču rediģēšana 5.jpg

Uzspied uz pogas "Lietot izmaiņas", kad tu esi pabeidzis un tu aiziesi atpakaļ uz atsauču redaktoru.
VisualEditor Apply Changes-en.png

Izmantojot jau esošu atsauci

Ja lapa jau satur atsauces, tu vari izvēlēties atkal izmantot jau eksistējošu atsauci, ja tā attiecas uz tekstu, kuram tu vēlies pievienot atsauci.

Lai atkal izmantotu jau eksistējošu atsauci, novieto kursoru vietā, kur tu vēlies to pievienot un nospied ikonu "Atsauce" (grāmatzīme) rīkjoslā.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Atsauce" menu.)

VisualEditor - Atsauce.jpg

Ja lapā ir vairākas atsauces, tu vari lietot meklēšanas lauku (ar nosaukumu "Uz ko jūs vēlaties atsaukties?"), lai rādītu tikai tās atsauces, kas atbilst dotajam tekstam. Meklē sarakstā atsauci, ko tu vēlies atkārtoti izmantot un izvēlies to.
VisualEditor - Atsauču rediģēšana 18.jpg

Jaunas atsauces pievienošana

Lai pievienotu jaunu atsauci, novieto kursoru vietā, kur tu vēlies to pievienot un nospied ikonu "Atsauce" (grāmatzīme) rīkjoslā.
VisualEditor - Atsauce.jpg

Izmantojot "Parasto" citēšanu

Shown here is what you will see if you select the basic references item. Atsauču redaktorā tu vari pievienot, rediģēt un formatēt tavas atsauces.

Tu vari atsauces piesaistīt dotai grupai; tas tiek lietots lai parādītu atsauču grupas ar "Atsauču sarakstu" (veidne "Atsauces").

VisualEditor - Atsauču rediģēšana 20.jpg

Ja tu pievieno jaunu atsauci un vēlies tajā iekļaut veidne, uzspied uz ikonas "Iekļāvums" (puzles gabaliņš) atsauces redaktora rīkjoslā.
VisualEditor Template Insert Menu-lv.png

Pēctam sameklē veidni, ko tu vēlies lietot, pievieno to un rediģē kā tu to darītu ar jau eksistējošu.

Uzspied uz pogas "Lietot izmaiņas", lai atgrieztos pie atsauču redaktora un "Lietot izmaiņas" atkal, lai atgrieztos lapā.

VisualEditor - Atsauču rediģēšana 9.jpg

Ja lapā jau nav atsauču saraksta (piemēram, ja tu pievieno pirmo lapas atsauci), tev vajag to pievienot, lai atsauces teksts tiktu rādīts.

Novieto kursoru tur, kur tu vēlies parādīt atsauces (parasti lapas beigās), uz uzspied uz ikonas "Atsauču saraksts" (trīs grāmatas), la pievienotu to.

VisualEditor References List Insert Menu-lv.png

Ja Jūs izmantojat dažādas atsauču grupas, Jūs varat izvēlēties grupu šajā dialogā. Atsuaces, kas pieder šai grupai, tiks attēlotas.

Lai vienkārši pievienotu atsauču sarakstu, nospied "Lietot izmaiņas" dialogā.

VisualEditor references list-lv.png

Izmantojot standarta citēšanas veidnes

Your local wiki may have added extra citation templates to the "Atsauce" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and click on the "Pievienot vairāk informācijas" option.

Nospied "$ievietot-citātu", kad ir pabeigts.

VisualEditor - Editing references - Add parameter.png

Rediģēt attēlus un citus mēdiju failus

Editing images

Lai pievienotu jaunu attēlu (vai citu failu) lapai, nospied ikonu "Medijs" rīkjoslā (attēls ar kalniem).
VisualEditor Media Insert Menu-lv.png

Uzpiežot uz ikonas "Medijs", atveras dialogs, kas automātiski meklē Vikikrātuvē mediju failus, kas attiecas uz lapu, ko tu šobrīd rediģē.

Tu vari meklēt citus mediju failus, izmainot tekstu dialoga meklēšanas laukā.

Uzklikšķini uz sīktēla, lai izvēlētos failu.

This places the image onto the page you are editing.

VisualEditor - Mediju rediģēšana 2.jpg

Mediju dialogs ļauj tev pievienot (un rediģēt) parakstu, kas var saturēt formatējumu un saites.
VisualEditor - Mediju rediģēšana 6.jpg

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
Media editing 7.png

You can also set various parameters for the image in the "Papildu iestatījumi" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

Kad tu esi pabeidzis, uzspied "Lietot izmaiņas", lai aizvērtu dialogu un atgrieztos pie lapas rediģēšanas.
VisualEditor Apply Changes-en.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "Medijs" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Mediju rediģēšana 3.jpg

Uploading images

You can upload images from a tab in the media dialog.
VisualEditor - Media upload 1.PNG

Click the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box.
VisualEditor - Media upload 1.PNG

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.PNG

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Editing media galleries

Lai pievienotu jaunu galeriju, klikšķini uz "Galerija" ikonas (fotogrāfijas).
VisualEditor - Gallery1.png

To edit an existing gallery in the visual editor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you click the "Gatavs" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using the visual editor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

Editing templates

Starting

Lai pievienotu jaunu veidni, novieto kursoru vietā, kur tu vēlies to pievienot un nospied ikonu "Iekļāvums" (puzles gabaliņš) rīkjoslā.
VisualEditor Template Insert Menu-lv.png

Ievadi veidnes, ko tu vēlies ievietot, nosaukumu, un nospied "Pievienot veidni".
VisualEditor - Veidņu pievienošana 4.jpg

Tu vari arī pievienot veidnes, kas jau ir lapā, izvēloties tās (tās iekrāsojas zilas) un nospiežot ikonu "Iekļāvums" (puzles gabaliņš), kas parādās netālu, vai to pašu ikonu rīkjoslā.
VisualEditor - Veidņu rediģēšana 1.jpg

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters

When you add a new template or open an existing one, the "Iekļāvums" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateDataExtension:TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

Tu vari pievienot parametrus vai rediģēt tos, kas jau ir uzskaitīti.

Ja veidne ietver citas veidnes, šīs apakšveidnes parādīsies kā parametri. Tās var rediģēt vai novākt uzklikšķinot uz apakšveidnes nosaukuma.

Jaunas apakšveidnes ir pievienojamas izpildot parametru pievienošanas instrukcijas. Jums var nākties pārbaudīt veidnes dokumentāciju, lai pārliecinātos, ka apakšveidne ir atbalstīta.


Finishing

Kad tu esi pabeidzis, uzspied "Lietot izmaiņas", lai aizvērtu dialogu un atgrieztos pie lapas rediģēšanas.
VisualEditor Apply Changes-en.png

Veidņu aizvietošana

Ja veidnei jābūt substituted, tad ievadi subst: (kolu ieskaitot) pirms veidnes nosaukuma.

Pašpabeišana nestrādā ar subst:; jā ir nepieciešama pašpabeigšana, pievieno subst: vienīgi pēc nepieciešamās veidnes atrašanas.

Pēc tam uzklikšķini zaļo "Add template" taustiņu.

Pievieno kā parasti jebkurus parametrus un "Veic izmaiņas"


Šajā sākuma fāzē Jūs neredzēsiet veidnes paplašināšanos lapā

Editing lists

VisualEditor Toolbar Lists and indentation-lv.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Editing tables

VisualEditor insert table.png
You can use the visual editor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you click on "Table", in the "Ievietot" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
You can add or delete a column or a row.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Rediģēt kategorijas

VisualEditor category item-lv.png
Lai rediģētu kategorijas "Lapas iespējas" sadaļā, nospiediet "Kategorijas" pogu.

VisualEditor category editing-en.png

Taustiņš "Options" atver dialogu, kas uzskaita esošās kategorijas un ļauj Jums pievienot jaunas.

Ir iespējams konfigurēt šķirošanas atslēgu, kas izmantojama lapu uzskaitīšanai kategoriju lapās.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


Lai pievienotu jaunu kategoriju, ievadiet tās nosaukumu "Pievieno kategoriju" laukā. Jūs varat vai nu izveidot jaunu kategoriju vai arī izvēlēties no jau esošajām.

Lai izdzēstu jau esošu kategoriju, uzklikšķiniet uz tās un uzklikšķiniet uz "Izdzēst" ikonas (atkritumu kastes simbola) uznirstošajā dialogā.

Jūs varat arī precizēt īpašai kategorijai atbilstošu šķirošanas atslēgu. Tas apies vispārējo šķirošanas atslēgu.


VisualEditor Apply Changes-en.png
Uzspied uz pogas "Lietot izmaiņas", kad esi pabeidzis, un tu aiziesi atpakaļ uz atsauču redaktoru.

Editing page settings

VisualEditor page settings item-lv.png
To edit a page's settings, click to open the "Lapas iespējas" menu, in the toolbar, and select the "Lapas iestatījumi" button.

VisualEditor Page Settings-en.png
The "Lapas iestatījumi" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-en.png
You can make a page a redirect to another page by checking the "Pāradresēt šo lapu uz" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-en.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "Ja nepieciešams", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-en.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-en.png
Click "Lietot izmaiņas" when you're done editing the Lapas iespējas to return to the page editor.

Matemātisko formulu rediģēšana

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "Formula" icon ("Σ") in the "Ievietot" menu on the toolbar.
VisualEditor Formula Insert Menu-lv.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "Gatavs" button.
VisualEditor formula-lv.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, click the "Musical notation" option.

To edit an existing musical notation on the page, double click on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, click the "Done" button to close the dialog and save your changes.
Musical.png

Rediģēt dzeju vai citus īpašus tekstus

Vizuālais redaktors pagaidām vēl neietver dzejas un mūzikas nošu rediģēšanu. Tāpēc pagaidām, ja gribat to mainīt vai pievienot, Jums primārais vikiteksts jārediģē tiešā veidā.

VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

Klaviatūras saīsnes

Daudzi rediģētāji ir pieraduši vikitekstu ievadīt tieši, jo īpaši trekno rakstu, kursīvu un vikilinkus. Keyboard shortcuts ļauj ātri iekļaut šādu formatējumu bez rīkjoslas rīku izmantošanas. Lūk, Vizuālā redaktora bieži izmantotās vispārīgas saīsnes:

PC saīsne Darbība Mac saīsne

Ctrl+B Trekns Cmd+B

Ctrl+I Kursīvā Cmd+I

Ctrl+K Ietvert linku Cmd+K

Ctrl+X Izgriezt Cmd+X

Ctrl+C Kopēt Cmd+C

Ctrl+V Ielīmēt Cmd+V

Ctrl+Z Atsaukt Cmd+Z