Help:VisualEditor/Kasutusjuhend

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 11% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎Yorùbá • ‎中文
PD Note: When you edit this page, you agree to release your contribution under the CC0. See Public Domain Help Pages for more info.
PD
Kui soovid proovida VisualEditori artiklit loomata, saad katsetada lingitud lehel VisualEditor kasutamiseks sellel lehel pole vaja kontot.


VisualEditori avamine

VisualEditoriga lehekülje redigeerimiseks vajuta lehe ülaservas nupule "Edit".

Lehe avamine toimetamiseks võib võtta mõned sekundid või ka kauem, kui lehekülg on väga suur.

"Muuda lähteteksti" nupule vajutamine avab klassikalise vikiteksti redigeerimisakna.

VisualEditor edit tab-et.png

VisualEditori saab avada ka igas lõigus olevat "muuda" linki vajutades.
VisualEditor - Section edit links-et.png

Sissejuhatus: VisualEditori tööriistariba

VisualEditori tööriistariba
VisualEditori tööriistariba ilmub lehe lehe ülaserva, sellega kui toimetama hakkad. See sisaldab mõningaid tuttavaid ikoone:

VisualEditor - Toolbar - Undo-redo.png
"Võta tagasi ja Tee uuesti" oma muudatused.

VisualEditor Toolbar Headings-et.png
Rippmenüü Pealkirjad: see võimaldab muuta pealkirja taset teksitis. Tavapärased alampealkirjad on tasemega "Pealkiri". Normaalne formaat teksti jaoks on "Lõik".

VisualEditor Toolbar Formatting-et.png

Formatting: Clicking the "A" opens a menu.

  • The "Rasvane kiri" item (B) bolds the selected text.
  • The "Kaldkiri" item (I) italicizes the selected text.
  • The "Ülaindeks" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly higher than the surrounding text.
  • AllindeksAllindeks
  • The "Läbikriipsutus" item (S) adds a solid bar through the selected text.
  • The "Arvutikood" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • The "Allakriipsutus" item (U) adds a solid line beneath the selected text.
  • The "Keel" item (Aあ) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "Vorminguta", removes all character formatting from the selected text, including links.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
Linking tool: The chain icon is the linking tool. Clicking on it (usually after selecting some text) opens the link dialog.

VisualEditor - Cite Pulldown.png
Viide menu: The "Viide" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to basic reference formatting and the ability to reuse citations by using this menu. It also gives users quick access to local citation templates, if these are enabled on their wiki.

(Instructions for adding local citation templates to the Viide menu at a specific wiki are available at VisualEditor/Citation toolVisualEditor/Citation tool.)


VisualEditor citoid Cite button.png
Viide button: If the citoid service is enabled on your wiki, then you will see a Viide button instead of a Viide menu.

The citoid service tries to fill out citation templates automatically.


VisualEditor Toolbar Lists and indentation-et.png
Loendid ja taane: Esimesed kaks ikooni on vastavalt number- ja täpploendi jaoks. Viimased kaks võimaldavad taanet kas suurendada või vähendada.

VisualEditor Insert Menu-et.png
Meediafailid, viited ja mallid: Iga ikoon avab vastava dialoogiakna:
  • The "Meediafail" icon (a picture of mountains) opens the media dialog.
  • The "Mall" icon (a puzzle piece) allows you to edit templates.
  • The "Table" item allows you to insert a table.
  • The "Kommentaar" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode, where they are indicated by an exclamation mark icon. In edit mode, clicking on the exclamation mark icon allows you to edit or delete the comment.
  • The "Hieroglüüfid" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • The "Galerii" icon (a set of photos) allows you to insert a gallery to the page.
  • The "⧼math-visualeditor-mwmathinspector-title⧽" icon (Σ) opens the formula inserter dialog.
  • The "Graph" item allows you to insert a graph.
  • The "Oma allkiri" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • * "⧼visualeditor-dialogbutton-referencelist-tooltip⧽" ikoon (kolm raamatut) avab dialoogiakna viidete näitamiseks.

Special character insertion: The "Erimärk" (Ω) icon is next to the "Lisa" menu. When clicked, it displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, diacritics, and mathematical symbols. (This list may be customized locally. See VisualEditor/Special charactersVisualEditor/Special characters for instructions.)
VisualEditor Toolbar SpecialCharacters-et.png

VisualEditor toolbar edit notices icon.png
The Edit notices button displays any notices for the page.

VisualEditor More Settings-et.png
Vali kas "Loobu või Salvesta lehekülg" oma muudatuste salvestamiseks.

VisualEditor bi-directional switching square brackets icon.png
The switch to source editing button is next to the Salvesta lehekülg button. It allows you to switch to the wikitext editor.

Muudatuste salvestamine

Kui oled toimetamisega valmis, vajuta rohelisele "Save page" nupule. Rohelisele nupule ei ole võimalik vajutada, kui ühtegi muudatust ei tehtud. To cancel all your editing changes, close your browser window, or click the "Vaata" tab above the edit toolbar.
VisualEditor toolbar actions-et.png

Peale rohelise nupu "Save page" vajutamist avaneb väike dialoogikaen, kuhu saad sisestada lühikokkuvõtte tehtud muudatustest, märkida oma muudatuse pisiparanduseks ja panna lehekülje tulevaste muudatuste jälgimiseks oma jälgimisloendisse.

Number näitab, palju ruumi on järel, et kirjeldada tehtud muudatusi. Saad oma muudatused ka üle vaadata veendumaks, et need toimivad just nii, nagu sa kavatsesid.

The "Jätka redigeerimist" button returns you to the page you were editing. You can save all of your changes later.

VisualEditor save dialog-et.png

Linkide toimetamine

VisualEditor - Toolbar - Linking.png

Linke saab lisada läbi "Linkide" ikooni (pilt ketilülidega) tööriistaribal või kiirklahve kasutades: Ctrl+K (või Command+K Mac'il).

Kui sa valid mingi teksti või asetad kursori ühe sõna peale, siis nupu Link" vajutamine lisab lingi sellele tekstile.


VisualEditor-link tool-search results-et.png
Ükskõik, kas kasutad ikooni või kiirklahve, igal juhul avaneb dialoogiaken, kuhu saad trükkida lingi. VisualEditor proovib sind siselinkide (lingid teistele Vikipeedia lehekülgedele) puhul aidata: peale trükkima hakkamist üritab ta leida tõenäolisi vasteid.

The link tool will try to help with internal links by searching for likely matches.


VisualEditor link tool 2015.png
Kui oled valitud lingi sisestanud või valinud, siis saad vajutada Enter, klikkata väljaspool kasti või vajutada "Sulge" ikoonil (<). Sisestatud link ilmub VisualEditori lehel, kuid salvestatakse alles siis, kui kogu leht salvestatakse.

VisualEditor-link tool-external link.png
Linkimine lehekülgedele väljaspool Vikipeediat on sama protsess: lihtsalt sisesta link dialoogiakna väljale ja see lisatakse kui "välislink".

VisualEditor link tool simple link.png
External links without labels look like this: [1]. You can add these by placing your cursor away from any word (e.g., after a space). Open the link tool by clicking on the button or pressing the shortcut keys. Type the URL in the box, and click the "Valmis" button to insert the link.

VisualEditor-context menu-link tool.png
Olemasoleva lingi muutmiseks või eemaldamiseks kliki tekstis oleval lingil ja vajuta selle läheduses ilmuval ikoonil "Link." Võid klikkida samal ikoonil tööriistaribal või kasutada kiirklahve Ctrl+K. When a link is selected, it appears as blue framed.

Võid redigeerida lingi sihtkohta või selle hoopis eemaldada vajutades ikooni "Eemalda" (prügikast) dialoogiakna ülemises parempoolses nurgas. You can also open the link's target in another window by clicking on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

Viidete toimetamine

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "Viide" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "Viide" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-FullHelp:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Olemasolevate viidete toimetamine

Olemasoleva viite redigeerimiseks vajuta sellele teksti sees ja kliki selle läheduses ilmuval ikoonil "Viide" (järjehoidja) või samale ikoonile tööriistaribal.
VisualEditor - Editing references 1.png

Viite ikoonile klikkimine avab dialoogiakna, mis sisaldab pisikest redigeerimisakent, kus saab redigeerida viite teksti.

Paljud vikid kasutavad malle, et viiteid teatud standardite järgi vormindada. Näed seda, kui redigeerid juba olemasolevat viidet, mille sisu muutub siniseks, kui selle valid.

If a template was used and you click on the reference information, then the Mall icon (puzzle piece) will appear with some information. Click on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Ikooni "Malli kasutamine" (pusletükk) vajutamine võimaldab sul muuta malli individuaalseid parameetreid.
VisualEditor - Editing references 5.png

Kui oled redigeerimisega valmis ja tahad lehekülje redigeerimise juurde naasta, vajuta nuppu "Rakenda muudatused".
VisualEditor Apply Changes-et.png

Olemasolevate viidete korduv kasutamine

Kui lehekülg sisaldab juba viiteid ja mõni neist kehtib ka muudetava teksti kohta võid seda uuesti kasutada.

Viite taaskasutamiseks aseta oma kursor sinna, kuhu soovid viidet lisada ja vajuta tööriistaribal ikoonil "Viidete loend."

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Viide" menu.)

VisualEditor Cite menu re-use.png

Kui viiteid on palju, võid kasutada otsingukasti (sildiga "Millisele allikale tahad viidata?"), et näha ainult tekstile vastavaid tulemusi.

Otsi nimekirjast viidet, mida soovid kasutada ja vali see.

VisualEditor - Editing references 18.png

Uute viidete lisamine

Uue viite lisamiseks aseta oma kursor sinna, kuhu soovid viidet lisada ja vajuta tööriistaribal ikoonil "Viide."
VisualEditor references more.png

Using the "Basic" citation

Shown here is what you will see if you select the basic references item. Viidete dialoogiaknas saad viiteid lisada, muuta ja vormindada.

Võid viiteid grupeerida: viidete gruppe näidatakse tööriistaga "Viidete loend."

VisualEditor - Editing references 20.png

Kui sa lisad uut viidet ja tahad sealjuures mõnda malli kasutada, vajuta viidete dialoogiaka tööriistaribal ikoonile Malli kasutamine (pusletükk).
VisualEditor Template Insert Menu-et.png

Siis vali välja mall, mida soovid kasutada ja muuda seda sama moodi nagu sa muudaksid juba olemasolevat malli.

Vajuta nupule "Rakenda muudatused" et naasta viidete dialoogiaknasse ja uuesti "Rakenda muudatused" et leheküljele naasta.

VisualEditor - Editing references 9.png

Kui lehel pole juba viidete nimekirja (näiteks kui lisad esimest viidet), pead selle lisama, et teksitis sinu viiteid näidataks.

Aseta kursor sinna, kus tahad oma viidete nimekirja näha (tavaliselt lehekülje lõpus) ja vajuta ikoonil "Viidete loend (kolm raamatut) selle lisamiseks.

VisualEditor References List Insert Menu-et.png

Kui sa lõid viidete gruppe, saad dialoogiaknas valida konkreetse grupi, millesse kuuluvaid viiteid näidata.

Et viidete nimekirja lisada vajuta dialoogiaknas "Rakenda muudatused".

VisualEditor references list-et.png

Using standard cite templates

Your local wiki may have added extra citation templates to the "Viide" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and click on the "Lisa veel teavet" option.

Click on "Lisa" when you're done.

VisualEditor - Editing references - Add parameter.png

Editing images and other media files

Editing images

Uue pildi (või muu meediafaili) lehele lisamiseks klikka tööriistaribal ikooni "Meediafail" (mägedega pilt).
VisualEditor Media Insert Menu-et.png

Ikoonile "Meediafail" klikkamine avab dialoogiakna, mis automaatselt otsib Wikimedia Commonsist meediafaile, mis on toimetatava leheküljega seotud.

Võid otsida ka teisi faile, muutes teksti dialoogiakna otsingukastis.

Faili valimiseks klikka pisipildile.

This places the image onto the page you are editing.

VisualEditor - Media editing 2.png

Meediafaili dialoogiaken võimaldab sul lisada (ja redigeerida) pildiallkirja, mis võib sisaldada vormindust ja linke.
VisualEditor - Media editing 6.png

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
VisualEditor - Media editing 7.png

You can also set various parameters for the image in the "Täpsemad sätted" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

Kui oled lõpetanud, siis klikka nupul "Rakenda muudatused" et dialoogiaken sulgeda ja redigeerimisleheküljele naasta.
VisualEditor Apply Changes-et.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "Meediafail" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3.png

Uploading images

You can upload images from a tab in the media dialog.
VisualEditor - Media upload 1.PNG

Click the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box.
VisualEditor - Media upload 1.PNG

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.PNG

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Editing media galleries

To add a new gallery, click the "Galerii" icon (a set of photos) on the "Lisa" menu. (If you don't see this icon on that menu, then your local wiki has decided to delay implementing this functionality in the visual editor.)
VisualEditor - Gallery1.png

To edit an existing gallery in the visual editor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you click the "Valmis" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using the visual editor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

Editing templates

Starting

Uue malli lisamiseks aseta oma kursor sinna, kuhu soovid malli lisada ja vajuta tööriistaribal ikoonil "Malli kasutamine" (pusletükk).
VisualEditor Template Insert Menu-et.png

Sisesta lisatava malli nimi ja vajuta nupule "Lisa mall".
VisualEditor - Template editing 4.png

Saad muuta ka juba lehel olemasolevaid malle neile klikkides (muutuvad siniseks) ja vajutades tekkinud ikoonil "Malli kasutamine" (pusletükk) või samale ikoonile tööriistaribal.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters

When you add a new template or open an existing one, the "Malli kasutamine" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateDataExtension:TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

Võid lisada parameetreid või muuta juba olemasolevaid.
VisualEditor - Template editing 3.png

Kui mall sisaldab teisi malle, siis ilmnevad viimased parameetritena. Neid saab muuta või eemaldada, kui klikkida alamtempli nimel.

Uusi alammalle lisatakse sama moodi nagu parameetrieid. Veendumaks, et alammall on toetatud pead võib-olla kontrollima malli dokumentatsiooni.

VisualEditor - Template editing 5.png

Finishing

Kui oled lõpetanud, siis klikka nupul "Rakenda muudatused" et dialoogiaken sulgeda ja redigeerimisleheküljele naasta.
VisualEditor Apply Changes-et.png

Mallide asendamine

Kui mall tuleb asendada, kirjuta malli nime ette subst: (koos kooloniga).

Automaatne lõpetamine ei tööta subst: puhul. Kui sul on vaja automaatset lõpetamist kasutada, lisa subst: alles peale otsitava malli leidmist.

Seejärel vajuta rohelisele nupule "Add template".

Lisa vajalikud parameetrid nagu tavaliselt ja "Rakenda muudatused".

VisualEditor - Template editing 7.png

Esimese faasi ajal pole malli laienemist lehel võimalik näha.
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-et.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Editing tables

VisualEditor insert table.png
You can use the visual editor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you click on "Table", in the "Lisa" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
You can add or delete a column or a row.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Kategooriate toimetamine

VisualEditor category item-et.png
To edit categories, on the "Lehekülje suvandid" menu, click the "Kategooriad" item.

VisualEditor category editing-et.png

"Options" nupp avab dialoogiakna, kus on loetletud juba olemasolevad kategooriad ja kuhu saab uusi lisada.

On võimalus seadistada sortimisvõtit, mille järgi lehekülge kategoorilehekülgedel sorditakse.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
Uue kategooria lisamiseks sisesta selle nimi väljale "Lisa kategooria". Võid luua uue kategooria või valida juba olemasoleva.

VisualEditor - Category editing 2.png

Kategooria eemaldamiseks vajuta sellele ja vajuta avanevas dialoogiaknas ikoonile "Eemalda" (prügikast).

Sinna saad kirjutada ka kategooria sortimisvõtme. Kui see on täpsustatud kasutatakse seda üldise sortimisvõtme asemel.


VisualEditor Apply Changes-et.png
Kui oled kategooriate redigeerimisega valmis ja tahad lehekülje redigeerimise juurde naasta, vajuta nuppu "Rakenda muudatused".

Editing page settings

VisualEditor page settings item-et.png
To edit a page's settings, click to open the "Lehekülje suvandid" menu, in the toolbar, and select the "Lehekülje sätted" button.

VisualEditor Page Settings-et.png
The "Lehekülje sätted" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-et.png
You can make a page a redirect to another page by checking the "Suuna see lehekülg ümber asukohta" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-et.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "Kui vaja", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-et.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-et.png
Click "Rakenda muudatused" when you're done editing the Lehekülje suvandid to return to the page editor.

Editing mathematical formulae

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "⧼math-visualeditor-mwmathinspector-title⧽" icon ("Σ") in the "Lisa" menu on the toolbar.
VisualEditor Formula Insert Menu-et.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "Valmis" button.
VisualEditor formula-et.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, click the "Musical notation" option.

To edit an existing musical notation on the page, double click on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, click the "Done" button to close the dialog and save your changes.
Musical.png

Matemaatiliste valemite ja teiste eriliste elementide toimetamine

Mõned elementide, nagu pildigaleriide, matemaatiliste valemite ja nootide toimetamine ei ole VisualEditoris veel toetatud. Kuniks tugi puudub, tuleb nende toimetamiseks või lisamiseks kasutada vikiteksti.

VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

Kiirklahvid

Paljud kasutajad on harjunud vikiteksti otse sisestama, eriti paksu- ja kaldkirja ning vikilinke. Sarnaselt sellele võimaldavad kiirklahvid teksti kiiresti vormindada ilma tööriistariba nuppe vajutamata. Üldlevinud, tavalised kiirklahvid, mis ka teistes tekstiredaktorites esinevad, toimivad ka VisualEditoris.

PC kiirklahvid Toime Maci kiirklahvid

Ctrl+B Rasvane kiri Cmd+B

Ctrl+I Kaldkiri Cmd+I

Ctrl+K Sisesta link Cmd+K

Ctrl+X Lõika Cmd+X

Ctrl+C Kopeeri Cmd+C

Ctrl+V Kleebi Cmd+V

Ctrl+Z Võta tagasi Cmd+Z