Hilfe:VisualEditor/Handbuch

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 93% complete.

Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎British English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD Hinweis: Wenn Du diese Seite bearbeitest, stimmst Du zu, dass Deine Bearbeitungen unter CC0 veröffentlicht werden. Siehe Projekt:PD Hilfe für nähere Informationen.
PD
Wenn du den VisualEditor ausprobieren möchtest, ohne einen bestehenden Artikel zu bearbeiten, kannst du ihn hier testen, ohne dass deine Tests als Artikel veröffentlicht werden. Du benötigst keinen Account um den VisualEditor auf dieser Seite zu benutzen.

Den VisualEditor öffnen

Um eine Seite mit dem VisualEditor zu bearbeiten, klicke auf den Reiter „Bearbeiten“ oben auf der Seite.

Manchmal dauert es etwas, bis die Seite bearbeitet werden kann, besonders wenn die Seite sehr lang ist.

Klickt man auf „Quelltext bearbeiten“ öffnet sich der klassische Wiki-Quelltexteditor.

VisualEditor edit tab-de.png

Du kannst den VisualEditor auch durch das Klicken auf den „Bearbeiten“-Link an jeder Abschnittsüberschrift öffnen.
VisualEditor - Section edit links-de.png

Erste Schritte: Die VisualEditor-Werkzeugleiste

Screenshot der VisualEditor-Werkzeugleiste
Die Werkzeugleiste erscheint ganz oben auf dem Bildschirm, wenn man mit VisualEditor bearbeitet. Die Leiste enthält einige bekannte Symbole:

VisualEditor - Toolbar - Undo-redo.png
Rückgängig machen und Wiederholen der vorgenommenen Änderungen.

VisualEditor Toolbar Headings-de.png
Überschriftenmenü: Du kannst das Format des Textes ändern. Um den Stil eines Abschnittes zu ändern fahre mit dem Cursor über den Abschnitt und wähle den passenden Stil im Menü aus (dazu musst du den Text nicht markieren). Abschnittsüberschriften formatiert man mit „Überschrift“, Unterabschnittstitel mit „Überschrift 2“, „Überschrift 3“ usw. Das normale Textformat ist „Absatz“.

VisualEditor Toolbar Formatting-de.png

Formatierung: Wenn man auf das „A“ klickt, öffnet sich ein Menü. Damit dieser formatiert wird musst du zunächst den zugehörigen Text markieren.

  • Die Fett-Schaltfläche (F) stellt den markierten Text fett dar.
  • Die Kursiv-Schaltfläche (K) setzt den Text kursiv.
  • Die Hochstellen-Schaltfläche (x2) lässt den ausgewählten Text kleiner und hochgestellt im Vergleich zum anderen Text werden.
  • Die Tiefstellen-Schaltfläche (x2) lässt den ausgewählten Text kleiner und tiefergestellt im Vergleich zum anderen Text werden.
  • Die Durchstreichen-Schaltfläche (S) streicht den gewählten Text durch.
  • Die Computercode-Schaltfläche (geschweifte Klammern: { }) verändert die Schriftart des gewählten Textes in eine nichtproportionale Schriftart, die den Text von dem umgebenden Text (in proportionaler Schrift) abhebt.
  • Die Unterstreichen-Schaltfläche (U) unterstreicht den gewählten Text.
  • Die Sprache-Schaltfläche (Aあ) ermöglicht es dir, die Sprache (zum Beispiel Japanisch) und Schriftrichtung (zum Beispiel rechts nach links) des gewählten Textes festzulegen.
  • Die letzte Schaltfläche (VisualEditor MediaWiki theme clear icon bitmap.png), genannt Gestaltung entfernen, entfernt jegliche Formatierung des gewählten Textes, inklusive Links.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
Verlinkungstool: Die Kette ist das Verlinkungstool. Wenn man darauf klickt (typischerweise nach Markieren eines Textausschnittes) öffnet sich der Verlinkungsdialog.

VisualEditor - Cite Pulldown.png
MediaWiki:Visualeditor-toolbar-cite-label/de-Menü: Das MediaWiki:Visualeditor-toolbar-cite-label/de-Menü wird genutzt um Verweise innerhalb des Textes (auch Einzelnachweise oder Fußnoten genannt) anzubringen. Alle Projekte haben Zugriff auf die MediaWiki:Visualeditor-dialogbutton-reference-tooltip/de-Einzelnachweisformatierung und machen eine Doppeltnutzung von Verweisen mithilfe dieses Menüs möglich. Außerdem kann man über das Menü einfach Zitationsvorlagen nutzen, sofern sie in dem jeweiligen Projekt existieren.

(Anleitungen um lokale Zitationsvorlagen für ein bestimmtes Wiki zum MediaWiki:Visualeditor-toolbar-cite-label/de-Menü hinzuzufügen finden sich unter VisualEditor/Citation tool.)


VisualEditor citoid Cite button.png
MediaWiki:Visualeditor-toolbar-cite-label/de button: Wenn der Citoid-Service in deinem Wiki aktiviert ist, wirst du eine "MediaWiki:Visualeditor-toolbar-cite-label/de"-Schaltfläche anstatt eines MediaWiki:Visualeditor-toolbar-cite-label/de-Menüs sehen.

Der Citoid-Service versucht Zitat-Vorlagen automatisch auszufüllen.


VisualEditor Toolbar Lists and indentation-de.png
Listen und Einrückungen: Die beiden ersten Schaltflächen erlauben dir, den Text entweder als Aufzählungszeichen oder Nummerierte Liste zu formatieren. Die letzten beiden Schaltflächen ermöglicht es dir die Einrückungsebene der Einträge zu verändern.

VisualEditor Insert Menu-de.png
Einfügen: Das Einfügen kann sich von Projekt zu Projekt unterscheiden. Hier findet sich eine Liste aller möglichen Optionen die auftauchen könnten.
  • Das Medien-Symbol (ein Bild mit Bergen) öffnet den Medien-Dialog.
  • Die Vorlage-Schaltfläche (ein Puzzleteil) ermöglicht das Bearbeiten von Vorlagen.
  • Die Kommentar-Schaltfläche (eine Sprechblase) ermöglicht es Kommentare einzufügen, die nur im Bearbeitungsmodus, nicht aber im Lesemodus zu sehen sind. Diese werden durch ein Ausrufezeichen-Symbol markiert.
  • The table item allows you to insert a table.
  • Die Galerie-Schaltfläche (einige Photos) ermöglicht das Einfügen einer Galerie von Bildern.
  • Die Schaltfläche Formel (Σ) öffnet den Dialog zum Einfügen von Formeln.
  • Die Hieroglyphen-Schaltfläche (ein Ankh-Symbol - ☥) ermöglicht das Einfügen von Hieroglyphen (siehe unten).
  • Die Schaltfläche MediaWiki:Visualeditor-dialogbutton-referenceslist-tooltip/de (drei Bücher) öffnet einen Dialog in dem man festlegen kannn, wo die Einzelnachweise angezeigt werden. Dies muss normalerweise nur einmal pro Seite getan werden.

Einfügen von Sonderzeichen und Symbolen: Beim Klicken auf die Sonderzeichen-Schaltfläche im Einfügen-Menü öffnet sich ein Dialog, der das Einfügen einer Vielzahl von Zeichen ermöglicht. Wenn man auf eines der Zeichen klickt, wird es in den Text eingefügt. Diese speziellen Zeichen enthalten einige Standardsymbole, Akzente und mathematische Symbole. (Diese Liste kann von Land zu Land variieren. Weitere Hinweise unter VisualEditor/Sonderzeichen)
VisualEditor Toolbar SpecialCharacters-de.png

VisualEditor toolbar edit notices icon.png
The Edit notices button displays any notices for the page.

VisualEditor More Settings-de.png
Das Seitenoptionen-Menü befindet sich links von Seite speichern. In diesem Menü kann man die Seite als Weiterleitung deklarieren, den Indizierungsmodus ändern, Kategorien bearbeiten, hinzufügen oder entfernen oder -- indem man die Sprache-Schaltfläche nutzt, eine Liste von Artikeln zum selben Thema in anderen Sprachen finden. Außerdem kann man hier vom VisualEditor zum normalen Quelltexteditor wechseln, ohne die bisherigen Änderungen zu verwerfen. Es ist jedoch nicht möglich, vom Quelltexteditor wieder zum VisualEditor zurückzukehren.

VisualEditor bi-directional switching square brackets icon.png
The Zur Quelltextbearbeitung wechseln button is next to the Seite speichern button. It allows you to switch to the wikitext editor.

Änderungen speichern

Wenn du mit dem Bearbeiten fertig bist, klicke auf die blaue Schaltfläche „Seite speichern“ in der Werkzeugleiste. Wenn du keine Änderungen vorgenommen hast wird der Button deaktiviert und grau angezeigt. Um deine Bearbeitungen zu verwerfen, reicht es lediglich das Browserfenster zu schließen.
VisualEditor toolbar actions-de.png

Wenn du den grünen Knopf „Seite speichern“ drückst, öffnet sich ein Dialog. Hier kannst du deine Änderung als klein markieren, die Seite zu deiner Beobachtungsliste hinzufügen und eine kurze Zusammenfassung angeben. Das Zusammenfassungsfeld gleicht dem Zusammenfassung:Feld im Quelltexteditor.

Wenn du auf „Überprüfe deine Änderungen“ drückst, kannst du den Unterschied zwischen deiner Version und der alten Version sehen. Diese Funktion gleicht dem „Änderungen zeigen“ des Quelltexteditors.

Der Bearbeitung fortsetzen-Button ermöglicht es dir zurück auf die Seite zu gelangen, die du gerade bearbeitest. Du kannst deine Bearbeitungen später speichern.

VisualEditor save dialog-de.png

Links bearbeiten

VisualEditor - Toolbar - Linking.png
Links können durch das Link-Symbol (Kettenglieder) in der Werkzeugleiste oder durch die Tastenkombination Strg+K (oder  Command+K auf einem Mac) hinzugefügt werden.

Wenn du Text markierst und dann auf „Link“ klickst, wird ein Link mit dem Text als Linktext eingefügt. Wenn du nur ein Wort als Linktext verwenden willst, reicht es, wenn sich der Cursor über dem Wort befindet.


VisualEditor - Link editing inline 2.png
Egal ob du die Schaltfläche oder die Tastenkombination genutzt hast, wird sich ein Dialog öffnen, in den du den Link eingeben kannst.

Der VisualEditor wird versuchen dich bei internen Links zu unterstützen, indem er nach ähnlichen Seitennamen sucht.


VisualEditor - Link editing inline box.png
Nachdem du einen Link eingegeben oder ausgewählt hast, beendest du die Verlinkung indem du  Enter klickst, durch Klicken die „Fertig“-Schaltfläche. Dein Link wird dann sofort auf der VisualEditor-Seite erscheinen, wird aber wie alle anderen Änderungen an einer Seite, erst gespeichert, wenn du die gesamte Seite speicherst.

VisualEditor - External link.png
Für das Verlinken einer externen Website außerhalb von Wikipedia ist es derselbe Ablauf; gib einfach die URL in das Feld ein und sie wird als „$externallink“ hinzugefügt.

VisualEditor link tool simple link.png
Externe Links ohne Titel sehen so aus: [1]. Diese können hinzugefügt werden indem man den Cursor weg von einem Wort setzt (z. B. nach einem Leerzeichen). Öffne das Verlinkungstool in dem du auf den Button klickst oder das Tastaturkürzel verwendest. Trage die URL in dem Eingabefeld ein und klicke auf „Fertig“ um den Link einzufügen.

VisualEditor-context menu-link tool.png
Um einen bestehenden Link zu ändern oder entfernen, klicke auf den Link und dann auf „Link“, das in der Nähe erscheint. Es öffnet sich ein Bearbeitungsfenster (Du kannst auch auf das gleiche Symbol in der Werkzeugleiste klicken oder die Tastenkombination Strg+K benutzen, während der Cursor im Linktext ist.) Wenn ein Link ausgewählt ist, erscheint er in einem blauen Rahmen.

Im Linkbearbeitungsdialog kannst du das Linkziel verändern. Es ist auch möglich, dass du den Link komplett entfernst. Und zwar durch einen Klick auf „Entfernen“, das sich in der unteren linken Ecke des Dialoges. Du kannst auch das Linkziel in einem anderen Fenster öffnen lassen in dem du auf „MediaWiki:Visualeditor-linkinspector-open/de“ klickst. (Dies ist nützlich um zu überprüfen ob ein externer Link noch gültig ist.)

Wenn du aus der Linkbearbeitung (oder dem Linktext) heraus möchtest oder nach dem Link weiterschreiben möchtest kannst du drücken.

  • Einmaliges Drücken wird den Linkbearbeitungsdialog schließen und den Cursor an das Ende des Linktextes setzen (blau eingerahmt und den Link zu bearbeiten)
  • Zweimaliges Drücken wird den Cursor hinter den Linktext setzten, so dass du den Rest deines Textes schreiben kannst.

To edit the link label of an existing link click within it and just do it. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

Einzelnachweise bearbeiten

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Dein Wiki kann eines von drei Fußnotensystemen benutzen. Rechts wird das einfachste System gezeigt, indem das "MediaWiki:Visualeditor-toolbar-cite-label/de"-Menü keine Zitatvorlagen enthält. Wenn dein Wiki dieses System verwendet, findest du alles, was du über Fußnoten wissen musst auf dieser Seite.
VisualEditor cite menu default.png

Das zweite System hat dasselbe "MediaWiki:Visualeditor-toolbar-cite-label/de"-Menü, aber enthält einige beliebte Zitatvorlagen für den Schnellzugriff. Wenn dein Wiki dieses System benutzt, dann kannst du weitere Einzelheiten auf Help:VisualEditor/User guide/Citations-Templates finden.
VisualEditor references more.png

VisualEditor citoid Cite button.png

In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Einen bestehenden Einzelnachweis bearbeiten

Um einen bestehenden Einzelnachweis zu bearbeiten, klicke auf die Stelle, wo er im Text auftaucht (meistens eine Zahl in eckigen Klammern). Du siehst dann entweder das Symbol „MediaWiki:Visualeditor-dialogbutton-reference-tooltip/de“ (Lesezeichen) oder ein Symbol (und Name) für die genutzte Vorlage. In jedem Fall öffnet sich durch Klicken auf das die "Bearbeiten"-Schaltfläche ein Bearbeitungsdialog.
VisualEditor - Editing references 1.png

Ein Klick auf „MediaWiki:Visualeditor-dialogbutton-reference-tooltip/de“ öffnet ein Fenster mit einem Mini-Editor, in dem du den Einzelnachweis bearbeiten kannst.

Viele Wikis benutzen Vorlagen, um Einzelnachweise einheitlich darzustellen. Wenn dein Einzelnachweis eine Vorlage benutzt, wird die gesamte Information in diesem Feld hervorgehoben wenn du deinen Mauszeiger über dieses Feld bewegst.

Wenn eine Vorlage verwendet wird und du die Einzelnachweise angeklickst, erscheint das Vorlage-Symbol (Puzzleteil) mit einigen Zusatzinformationen. Klicke auf "Bearbeiten" um den Inhalt der Vorlage in dem Vorlagen-Minieditor zu bearbeiten.

VisualEditor - Editing references 6.png

Wenn bei einem Klick auf einen Einzelnachweis das Symbol einer Standard-Zitationsvorlage erscheint (siehe Beispiel rechts), dann kann man mit einem Klick auf "Bearbeiten" den Vorlagen-Minieditor öffnen.
VisualEditor - Editing References - Cite Web.png

Im Vorlagen-Editor können Informationen oder Inhalte hinzugefügt, entfernt oder verändert werden. Am Anfang werden nur ausgefüllte Felder (Vorlagenparameter) angezeigt. Weitere Felder können mit einen Klick auf „Weitere Informationen hinzufügen“ unten im Vorlagen-Minieditor hinzugefügt werden.
VisualEditor - Editing references 5.png

Klicke auf "Änderungen speichern", wenn du fertig bist.
VisualEditor Apply Changes-de.png

Einen bestehenden Einzelnachweis wiederverwenden

Wenn die Seite bereits einen Einzelnachweis enthält der zu dem Textabschnitt passt, den du belegen willst, kannst du diesen erneut verwenden.

Um einen Einzelnachweis ein weiteres Mal zu benutzen, platziere den Cursor an der gewünschten Stelle im Text, wo du den neuen Einzelnachweis (Nummer) für die Referenzierung angeben willst. Daraufhin klicke auf den Punkt „MediaWiki:Visualeditor-dialog-reference-useexisting-tool/de“ auf dem Menü „MediaWiki:Visualeditor-toolbar-cite-label/de“ in der Werkzeugleiste.

(Bemerkung: Wenn dein Wiki das dritte Fußnoten-System hat, wie oben beschrieben, erscheint anstelle des Punktes "$re-using-reference" im Menü "MediaWiki:Visualeditor-toolbar-cite-label/de" ein "$re-using-reference"-Tab im Bearbeitungsfenster.)

VisualEditor Cite menu re-use.png

Im Dialog „MediaWiki:Visualeditor-dialog-reference-title/de“ kannst du den Einzelnachweise den du wiederverwenden willst auswählen. Bei vielen Einträgen, kannst in dem Suchfeld (genannt „MediaWiki:Visualeditor-reference-input-placeholder/de“) diese nach einem bestimmten Text durchsuchen lassen.
VisualEditor - Editing references 18.png

Einen neuen Einzelnachweis hinzufügen

Um einen neuen Einzelnachweis hinzuzufügen, positioniere den Cursor (die Eingabemarkierung) an die Stelle, wo du ihn hinzufügen möchtest, und klicke auf das Symbol „MediaWiki:Visualeditor-toolbar-cite-label/de“ (ein Lesezeichen) in der Werkzeugleiste.
VisualEditor references more.png

Einfaches Referenzieren verwenden

Im Einzelnachweiseditor kannst du den Einzelnachweistext hinzufügen, bearbeiten und formatieren.

Es ist möglich, die Referenz einer bestimmten Gruppe zuzuordnen, auch wenn dies normalerweise nicht getan wird. (Damit können Einzelnachweise gruppiert mit „MediaWiki:Visualeditor-dialogbutton-referenceslist-tooltip/de“ angezeigt werden.)

VisualEditor - Editing references 20.png

In the Reference dialog, if you want to include a citation template, or any other template, in your new reference, click the Vorlage icon (puzzle piece) in the "Einfügen" toolbar menu within the Reference editor.
VisualEditor Template Insert Menu-de.png

Danach kannst du die Vorlage wie im normalen Modus hinzufügen und anschließend bearbeiten wie jede andere Vorlage (Siehe den Abschnitt Vorlagen bearbeiten weiter unten, wenn du mehr Informationen über Vorlagen benötigst.)

Nachdem die Vorlage bearbeitet wurde, klicke auf „Änderungen speichern“ um zum Einzelnachweiseditor zurückzukehren, und dann nochmal auf „Änderungen speichern“ um zur Seite zu zurückzukommen.

VisualEditor - Editing references 9.png

Wenn noch keine Einzelnachweisliste auf der Seite vorhanden ist (beispielsweise, wenn du den ersten Einzelnachweis hinzufügst), musst du sie ergänzen, damit deine Einzelnachweise dem Leser angezeigt werden.

Wähle dir die Stelle aus, an der die Einzelnachweise angezeigt werden sollen (üblicherweise am Ende der Seite), und öffne dann das Einfügen-Menü und klicke anschließend auf das Symbol „MediaWiki:Visualeditor-dialogbutton-referenceslist-tooltip/de“ (drei Bücher), um die Liste hinzuzufügen.

VisualEditor References List Insert Menu-de.png

If you are using several groups of references, which is relatively rare, you can specify the group in this dialog. Only the references that belong to that group will be displayed on the page at the location where you are placing the group.

Klicke zuletzt auf „Einfügen“.

VisualEditor references list-de.png

Einfache Einzelnachweisvorlagen verwenden

Your local wiki may have added extra citation templates to the "MediaWiki:Visualeditor-toolbar-cite-label/de" menu. If so, you have quick access to the most-used citation templates for your wiki. (Eine Anleitung um weitere Zitationsvorlagen in deinem lokalen Wiki hinzuzufügen findet sich unter VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Wenn man auf ein Vorlagensymbol klickt, wie hier in der Abbildung „Cite book“, wird man zu einer Eingabemaske für diese Vorlage geführt. wichtige Felder sind dabei mit einem Sternchen markiert. Zudem werden zwar die üblichsten Felder aufgeführt, jedoch müssen nicht immer auch alle ausgefüllt werden.
VisualEditor - Editing references - Cite book required fields.png

Um weitere Parameter hinzuzufügen, scrolle ans Ende der Eingabemaske und klicke auf „Weitere Informationen hinzufügen“.

Klicke auf „Einfügen“, wenn du fertig bist.

VisualEditor - Editing references - Add parameter.png

Bilder und andere Mediendateien bearbeiten

Bilder bearbeiten

Zum Hinzufügen eines Bildes (oder einer anderen Mediendatei) zur Seite musst du auf „Medien“ in der Werkzeugleiste (ein Bild mit Bergen) klicken.
VisualEditor Media Insert Menu-de.png

Das Klicken auf „Medien“ öffnet ein Dialogfenster, das automatisch auf Wikimedia Commons nach Dateien sucht, die in Beziehung zur Seite stehen, die du gerade bearbeitest.

Durch das Ändern des Textes im Suchfeld kannst du nach anderen Mediadateien suchen.

Klicke auf ein Miniaturbild, um die Datei auszuwählen.

Dieses stellt das Bild auf die gerade bearbeitete Seite.

VisualEditor - Media editing 2.png

Nachdem das ausgewählte Bild auf der Seite eingefügt wurde, öffnet sich ein weiterer Dialog. Dieser Dialog erlaubt das Hinzufügen und die Veränderung der Bildunterschrift. Diese kann sowohl Formatierungen als auch Links enthalten.
VisualEditor - Media editing 6.png

Der Mediendialog erlaubt zudem das Hinzufügen von alternativen Unterschriften für Benutzer von Screenreadern oder Benutzern die die Anzeige von Bildern deaktiviert haben.
Media editing 7.png

Im Fenster „Erweiterte Einstellungen“ können zudem unterschiedliche Parameter des Bildes, wie Ausrichtung, Typ oder Größe, eingestellt werden.
VisualEditor - Media editing 8.png

Wenn du mit dem Bearbeiten fertig bist, klicke auf „Änderungen speichern“, um sie Seite weiter zu bearbeiten.
VisualEditor Apply Changes-de.png

Zu einem bereits vorhandenen Bild können eine Bildunterschrift oder andere Parameter ergänzt oder verändert werden, in dem man auf das Bild und dann auf das darunter erscheinende Medien-Symbol klickt.

Die Größe eines bereits vorhandenen Bildes kann verändert werden indem man auf dieses klickt und dann das Symbol mit dem Doppelpfeil (links unten) kleiner oder größer zieht.

Man kann auch ein Bild per Drag-und-Drop an eine andere Stelle ziehen.

VisualEditor - Media editing 3.png

Uploading images

Im Reiter "Hochladen" des "Medien"-Dialogs kannst du Bilder hochladen.
VisualEditor Media Insert Menu-en short.png

Klicke den Reiter "Hochladen" und wähle ein Bild von deinem Rechner aus. Du kannst den Dateinamen eintippen oder ein Bild in den Kasten ziehen.
VisualEditor - Media upload 1.PNG

Du musst das Bild beschreiben und Kategorien hinzufügen, damit andere es finden können.
VisualEditor - Media upload 2.PNG

Das Bild wird in die Seite eingefügt, wenn du fertig bist.
VisualEditor-logo.svg

Galerien bearbeiten


Eine bereits vorhandene Galerie kann bearbeitet werden, in dem man zuerst auf die Galerie klickt und dann unten auf das Galerie-Symbol (eine Gruppe von Photos). Dies öffnet den Galerie-Editor der alle Bilder in der Galerie auflistet.
VisualEditor - Gallery2.png
Der Galerie-Editor ist eine einfache Eingabebox um bestehende Galerien mittels Wikitext bearbeiten zu können. Um ein neues Bild hinzuzufügen, geben den Dateinamen gefolgt einem geraden Strich (|) und der Bildunterschrift ein. Jedes Bild muss in einer separaten Zeile stehen. Diese Liste kann bearbeitet werden um Bilder zu entfernen oder umzupositionieren, sowie die Bildunterschriften zu verändern.

Klicke auf „Fertig“ um den Galerie-Editor zu verlassen. Die Änderungen sollten nun sichtbar sein.

Denke daran, dass durch Verlassen des Galerie-Editors deine Änderungen nicht abschließend gespeichert werden. Wie bei allen Änderungen mit dem VisualEditor, musst du erst die komplette Seite speichern, damit die Änderungen aktiv werden.

VisualEditor - Gallery3.png

Vorlagen bearbeiten

Der Anfang

Um eine Vorlage auf der Seite einzufügen, kannst du den Cursor an die gewünschte Stelle setzen und anschließend auf „Vorlage“ (Puzzleteil) im Menü „Einfügen“ klicken.
VisualEditor Template Insert Menu-de.png

Gib den Namen der einzufügenden Vorlage ein, klicke dann auf deren Namen und schließlich auf „Vorlage hinzufügen“.
VisualEditor - Template editing 4.png

Es ist auch möglich, bereits in der Seite verwendete Vorlagen zu bearbeiten. Durch einen Klick auf die Vorlage wird es blau und ein Kasten mit der "Vorlage"-Schaltfläche (Puzzleteil) erscheint. Klicke nun auf Bearbeiten.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters

When you add a new template or open an existing one, the visual editor opens the "Vorlageneinbindung" dialog. What you see depends upon whether the visual editor knows extra information about that template, called TemplateDataExtension:TemplateData.

The template shown here has no TemplateData set up for it. The dialog shows a link to documentation for the template. You can read the documentation to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

For an existing template, you can edit the parameters shown in the dialog, and you can add parameters by clicking "Weitere Informationen hinzufügen", at the very bottom of the dialog.
VisualEditor - Template editing 3.png

Wenn eine Vorlage andere Vorlagen beinhaltet, dann werden diese eingebetteten Vorlagen innerhalb der Parameter angezeigt, die diese enthalten. Diese können im Parameterfeld entfernt und bearbeitet werden.

Neue eingebettete Vorlagen können hinzugefügt werden, indem den Schritten zur Hinzufügung von Parametern gefolgt wird. Möglicherweise musst du die Vorlagenbeschreibung überprüfen, um herauszufinden ob die eingebettete Vorlage unterstützt wird.

VisualEditor - Template editing 5.png

Finishing

Wenn du mit dem Bearbeiten einer Vorlage fertig bist, klicke auf „Änderungen speichern“ um den Dialog zu schließen und zum Seiteneditor zurückzukehren.
VisualEditor Apply Changes-de.png

Vorlagen austauschen

Wenn eine Vorlage substituiert werden muss, füge subst: (inklusive Doppelpunkt) vor den Vorlagennamen ein.

Die Autovervollständigung funktioniert nicht mit subst:; Wenn du die Autovervollständigung benutzten möchtest, suche zuerst die Vorlage und füge dann vor dem Namen der Vorlage subst: ein.

Klicke dann auf das grüne „Vorlage hinzufügen“.

Füge wie gehabt die gewünschten Parameter hinzu und klicke auf „Einfügen“.

VisualEditor - Template editing 7.png

You will see the template expand on the page after you click "Änderungen speichern".
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-de.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Tabellen bearbeiten

VisualEditor insert table.png
Du kannst den VisualEditor benutzen, um Tabellen einzufügen und zu bearbeiten.

Du kannst sogar eine Tabelle importieren, indem du eine .csv-Datei (Trennzeichen-getrennt) von deinem Rechner in das Hauptbearbeitungsfenster ziehst.


Wenn du auf "Tabelle" in dem "Einfügen"-Menü, fügt der VisualEditor eine leere Tabelle mit vier Zeilen und vier Spalten ein.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png
|-

VisualEditor table editing add and remove columns.png
Du kannst Spalten und Zeilen hinzufügen und entfernen.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Kategorien bearbeiten

VisualEditor category item-de.png
Um die Kategorien zu Bearbeiten klicke im Menü „Seitenoptionen“ auf „Kategorien“.

VisualEditor category editing-de.png
Ein Klick auf „Kategorien“ öffnet ein Fenster, in dem die vorhandenen Kategorien aufgelistet werden und es dir ermöglicht, neue hinzuzufügen und vorhandene zu löschen.

You also have the option of setting or changing the general (default) sorting key, which determines where the page appears when listed with other pages in the same category.

Beispielsweise ist beim Artikel „Konrad Adenauer“ die Standardsortierung „Adenauer, Konrad“ damit dieser in der Kategorie „Bundeskanzler (Deutschland)“ unter A und nicht unter K geführt wird.


VisualEditor - Category editing 3.png
Um eine neue Kategorie hinzuzufügen, gib ihren Namen in das Feld „Eine Kategorie hinzufügen“ ein. Während der Eingabe wird der VisualEditor passende Treffer auf vorhandene Kategorien anzeigen. Du kannst entweder eine eine bestehende Kategorie auswählen oder eine neue hinzufügen. (Solange die neue Kategorie noch keine eigene Kategorienseite besitzt, wird diese mit einem roten Link aufgeführt.)

VisualEditor - Category editing 2.png
Um eine bestehende Kategorie zu entfernen, klicke sie an und dann in dem sich öffnenden Dialog auf „Entfernen“ (einen Abfalleimer).

Durch einen Klick auf eine Kategorie kann der Sortierschlüssel für diese spezifische Kategorie festgelegt werden. Er überschreibt dann den allgemeinen Sortierschlüssel.


VisualEditor Apply Changes-de.png
Wenn du mit dem Bearbeiten der Kategorien fertig bist, klicke auf „Änderungen speichern“, um zum Seiteneditor zurückzukehren.

Seiteneinstellungen bearbeiten

VisualEditor page settings item-de.png
Um die Einstellungen einer Seite zu bearebieten öffne das „Seitenoptionen“ in der Werkzeugleiste und klicke auf „Seiteneinstellungen“.

VisualEditor Page Settings-de.png
„Seiteneinstellungen“ öffnet einen Dialog mit mehreren Optionen.

VisualEditor Page Settings Redirects-de.png
Um diese Seite auf eine andere weiterleiten zu lassen setzte ein Häkchen bei „Diese Seite weiterleiten nach“ und gebe dann den Namen der Zielseite ein auf die der Leser geführt werden soll, wenn er den Namen der Seite die gerade bearbeitet wird eingibt.

Am Ende ist ein Option um zu verhindern, dass Seitenumbenennungen diese Weiterleitung aktualisieren. Diese wird jedoch nur in den seltensten Fällen benötigt.


VisualEditor Page Settings TOC-de.png
Mit diesen drei Schaltflächen kann bestimmt werden, ob die Seite ein Inhaltsverzeichnis aufführt. Die Standardeinstellung ist „Falls nötig“ bei der das Inhaltsverzeichnis angezeigt wird, wenn mindestens drei Überschriften vorhanden sind.

VisualEditor Page Settings Edit Links-de.png
Um zu verhindern das Bearbeiten-Links neben den Überschriften angezeigt werden, wähle diese Schaltfläche an.

VisualEditor Apply Changes-de.png
Wenn du mit dem Bearbeiten von Seitenoptionen fertig bist, klicke auf „Änderungen speichern“, um zum Seiteneditor zurückzukehren.

Mathematische Formeln bearbeiten

Um eine Vorlage auf der Seite einzufügen, kannst du den Cursor an die gewünschte Stelle setzen und anschließend auf „Formel“ (Σ) im Menü „Einfügen“ klicken.
VisualEditor Formula Insert Menu-de.png

Es öffnet sich ein Fenster in dem die Formel im LaTeX-Satz eingegeben werden kann. Der VisualEditor wird die Formel während des Schreibens laufend aktualisieren, so dass man sofort das Endergebnis sehen kann. Ist die Formel fertig klick auf „Fertig“.
VisualEditor formula-de.png

Um eine bereits vorhandene mathematische Formel zu bearbeiten, klicke auf diese und dann auf das Σ-Symbol um das Formelfenster aufzurufen in dem die Änderungen vorgenommen werden können.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Gedichte und andere spezielle Elemente bearbeiten

Manche Elemente, wie zum Beispiel assoziative Listen, Gedichte und Musiknoten, werden vom VisualEditor derzeit noch nicht unterstützt.
VisualEditor editing poem 1.png

In den meisten Fällen können bereits vorhandene Elemente bearbeitet, jedoch keine neuen eingefügt werden.
VisualEditor editing poem 2.png

Du kannst im VisualEditor keine Signatur und keinen Zeitstempel zu einer Seite hinzufügen.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

Tastaturkürzel

Viele Benutzer sind es gewöhnt, Wikitextformatierungen direkt einzugeben, insbesondere Fett-/Kursivschrift und Wikilinks. Die Tastenkombinationen erlauben das schnelle Einfügen ähnlicher Formatierungen, ohne dafür die Werkzeugleistensymbole verwenden zu müssen. Hier sind einige Tastenkombinationen des VisualEditors gelistet:

Tastenkombination (PC) Funktion Tastenkombination (Mac)

 Ctrl+B Fett  Cmd+B

 Ctrl+I Kursiv  Cmd+I

 Ctrl+K Link einfügen  Cmd+K

 Ctrl+X Ausschneiden  Cmd+X

 Ctrl+C Kopieren  Cmd+C

 Ctrl+V Einfügen  Cmd+V

 Ctrl+Z Rückgängig machen  Cmd+Z