Help:VisualEditor/User guide

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 62% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD Note: When you edit this page, you agree to release your contribution under the CC0. See Public Domain Help Pages for more info.
PD
நீங்கள் கட்டுரையை தொகுக்காது காண்திரை தொகுப்பானை முயல எண்ணினால் இந்தப் பக்கத்தை தொகுத்துப் பழகலாம். அந்தப் பக்கத்தில் காண்திரை தொகுப்பானை பயன்படுத்த உங்களுக்கு பதிகை கணக்கு வேண்டியதில்லை.

Contents

காண்திரை தொகுப்பான் திறக்கிறது.

காண்திரை தொகுப்பானால் பக்கத்தைத் தொகுக்க, பக்கத்தின் தலைப்பிலுள்ள "தொகு" தத்தலை சொடுக்கவும்.

தொகுக்கும்பொருட்டு பக்கம் திறக்கப்பட சில வினாடிகள் ஆகலாம்; பக்கம் நீளமானதாக இருந்தால் நீண்ட நேரம் எடுக்கும்.

"மூலத்தைத் தொகு" தத்தலை சொடுக்கினால் பழைய விக்கியுரை மூல தொகுப்பான் திறக்கும்.

VisualEditor edit tab-en.png

ஒவ்வொரு பத்திக்கும் தலைப்பிலுள்ள "தொகு" இணைப்பை சொடுக்கியும் காண்திரை தொகுப்பானைத் திறக்கலாம்.
VisualEditor - Section edit links-en.png

தொடங்குதல்: காண்திரை தொகுப்பானின் கருவிப்பட்டை

காண்திரை தொகுப்பானின் கருவிப்பட்டையின் திரைக்காட்சி
தொகுத்தலை துவக்கும்போது காண்திரை தொகுப்பானின் கருவிப்பட்டை திரையின் மேற்பகுதியில் தோன்றுகின்றது. இதில் ஏற்கெனவே அறிமுகமான சில சின்னங்கள் உள்ளன:

VisualEditor - Toolbar - Undo-redo.png
உங்களது மாற்றங்களை செயல்தவிர்க்கவும் மீண்டும் செய்விக்கவும் பயன்படுகின்றன.

VisualEditor Toolbar Headings-ta.png
பத்தி கீழ்விரிப்பட்டி: பத்தி வடிவமைப்பை மாற்ற உதவுகின்றது. பத்தியின் வடிவமைப்பை மாற்ற பத்தியின் மீது திரைக்குறியை வைத்துக் கொண்டு இந்த விரிப்பட்டியிலிருந்து ஒரு தேர்வை தெரிந்தெடுக்கவும் (உரையை எடுப்பாய்க் காட்டத் தேவையில்லை). பகுதித் தலைப்புகள் "தலைப்பு" எனவும் துணைப்பகுதிகள் "தலைப்பு 2", "தலைப்பு 3", எனவும் வடிவமைக்கப்படுகின்றன. உரையை வழமையாக வடிவமைக்க "பத்தி".

VisualEditor Toolbar Formatting-ta.png

வடிவூட்டுதல்: "A" யைச் சொடுக்கினால் கீழ்விரிப்பட்டி விரியும்.

  • "தடித்த" உருப்படி (B) தெரிந்தெடுத்த உரையை தடிமனாக்குகின்றது.
  • "சாய்ந்த" உருப்படி (I) தெரிந்தெடுத்த உரையை சாய்வாக்குகின்றது.
  • "மேலொட்டு" உருப்படி (x2) தெரிந்தெடுத்த உரையை சூழ்ந்துள்ள உரையை விட சிறிய எழுத்துருவிலும் அவற்றை விட சற்றே உயர்ந்தும் அமைக்கின்றது.
  • "கீழொட்டு" உருப்படி (x2) தெரிந்தெடுத்த உரையை சூழ்ந்துள்ள உரையை விட சிறிய எழுத்துருவிலும் அவற்றை விட சற்றே தாழ்ந்தும் அமைக்கின்றது.
  • "குறுக்குக்கோடிட்டு மறை" உருப்படி (S) தெரிந்தெடுத்த உரையினூடே தடித்தக் கோட்டை இடுகின்றது.
  • "கணினிக் குறியீடு" உருப்படி (சோடியான நெளி அடைப்புகள்: {}) தெரிந்தெடுத்த உரையின் எழுத்துருவை சீரான இடைவெளி எழுத்துருவாக மாற்றுகின்றது; இதனால் சூழ்ந்துள்ள (விகிதசார் இடைவெளி எழுத்துருவிலுள்ள) உரையிலிருந்து தனித்துக் காட்டுகின்றது.
  • "அடிக்கோடிடு" உருப்படி (U) தெரிந்தெடுக்கப்பட்ட உரையின் அடியில் தடித்தக் கோடிடுகின்றது.
  • "மொழி" உருப்படி (Aあ) தெரிந்தெடுத்த உரையின் மொழியைக் குறிப்பிடவும் (காட்டாக, இடாய்ச்சு) படிக்கும் திசையைக் குறிப்பிடவும் (காட்டாக, வலதிலிருந்து -இடது) .
  • "இவ்வடிவமைத்தலை நீக்கு" எனப்படும் (VisualEditor MediaWiki theme clear icon bitmap.png) இறுதி உருப்படி தெரிந்தெடுக்கப்பட்ட உரையிலுள்ள அனைத்து வடிவூட்டல்களையும், இணைப்புகள் உட்பட, நீக்குகின்றது.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
இணைப்புக் கருவி: சங்கிலிச் சின்னம் இணைப்புக் கருவியாகும். இதனைச் சொடுக்கினால் (பொதுவாக ஏதேனும் உரையைத் தேர்ந்தெடுத்த பிறகு) இணைப்பு உரையாடல் பெட்டியைத் திறக்கும்.

VisualEditor - Cite Pulldown.png

Cite விரிபட்டி: "Cite" விரிபட்டி உரையினூடே குறிப்புக்கள் இடுவதற்குப் பயன்படுகின்றது (இவை "அடிக்குறிப்பு" அல்லது "மேற்சான்று" எனப்படும்). அனைத்து விக்கித் திட்டங்களிலும் இந்த விரிபட்டியைக் கொண்டு "$basic" வடிவூட்டுதலுக்கு வகை செய்யப்பட்டுள்ளது; குறிப்புக்களை "$re-use" செய்யவும் வழி செய்யப்பட்டுள்ளது. தவிரவும் உங்கள் விக்கியில் உள்ளக மேற்சான்று வார்ப்புருக்கள் செயலாக்கப்பட்டிருந்தால் அவற்றிற்கும் இது அணுக்கம் வழங்குகின்றது.

(குறிப்பிட்ட விக்கியில் Cite விரிபட்டிக்கு உள்ளக மேற்சான்று வார்ப்புருக்களை சேர்ப்பதற்கான அறிவுரைகள் VisualEditor/Citation tool இங்குள்ளன.)


VisualEditor citoid Cite button.png
குறிப்பிடு ஆழி: citoid எனப்படும் சேவை உங்கள் விக்கியில் செயலாக்கப்பட்டிருந்தால், Cite விரிபட்டிக்கு மாறாக குறிப்பிடு என்ற ஆழி தென்படும்.

citoid சேவை மேற்கோள் வார்ப்புருக்களை தானாகவே நிரப்ப முயலும்.


VisualEditor Toolbar Lists and indentation-ta.png
பட்டியல்களும் தள்ளி வைத்தலும்: முதலிரு உருப்படிகள் கொண்டு உரையை "குண்டுக்குறிப் பட்டியல்" அல்லது a "எண்களுடன் வரிசை"யில் அமைக்க முடியும் . கடைசி இரண்டு உருப்படிகள் மூலம் பட்டியல் உருப்படிகளைத் தள்ளி வைப்பதை கூட்டவோ குறைக்கவோ முடியும்.

VisualEditor Insert Menu-ta.png
செருகு: "செருகு" விரிபட்டி சில திட்டங்களில் வேறாக இருக்கலாம். காணக்கூடிய அனைத்துத் தேர்வுகளின் பட்டியல் கீழே தரப்பட்டுள்ளது.
  • "ஊடகம்" சின்னம் (மலைகளின் படம்) ஊடக உரையாடற் பெட்டியைத் திறக்கின்றது.
  • "Template" சின்னம் (புதிர் துண்டு) வார்ப்புருக்களை தொகுக்க உதவுகின்றது.
  • The "Table" item allows you to insert a table.
  • "கருத்துரை" சின்னம் (பேச்சுக் குமிழ்) வாசகர்களுக்கு புலப்படாத கருத்துரைகளை பதிக்க உதவுகின்றது; இந்தக் கருத்துரைகள் தொகுக்கும் போது மட்டுமே புலனாகும். இவை ஆச்சரியக் குறி சின்னம் மூலமாக குறிக்கப்படுகின்றன.
  • "Hieroglyphs" சின்னம் (an அங்க் சின்னம் - ☥) பழங்கால எகிப்திய சித்திர வடிவ எழுத்துக்களை சேர்க்க உதவுகின்றது. (கீழே பார்க்கவும்.)
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • "Gallery" சின்னம் (படத்தொகுதி) கட்டுரைப் பக்கத்தில் ஒளிப்படத் தொகுப்பை இணைக்க உதவுகின்றன.
  • "⧼math-visualeditor-mwmathinspector-title⧽" சின்னம் (Σ) கணித சூத்திரச் செருகு உரையாடற் பெட்டியைத்திறக்கின்றது.
  • The "Graph" item allows you to insert a graph.
  • The "Your signature" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • "References list" சின்னம் (மூன்று நூல்கள்) வாசகருக்கு மேற்கோள்கள் காட்டப்பட வேண்டிய இடத்தை நீங்கள் குறிப்பிடும் உரையாடற் பெட்டியைத் திறக்கின்றது; பொதுவாக இது ஒவ்வொரு பக்கத்திற்கும் ஒருமுறை செய்தால் போதுமானது.

சிறப்புக் குறியீடு சேர்க்கை: "செருகு" விரிபட்டியிலுள்ள "சிறப்புக் குறியீடு" (Ω) சின்னம் சொடுக்கப்படும்போது, பல சிறப்பு வரியுருக்களைக் காட்டும் உரையாடற்பெட்டி திறக்கும்; இங்கு சொடுக்கினால் இதிலிருந்து குறிப்பிட்ட வரியுருவை திரைக்குறியுள்ள இடத்தில் செருக முடியும். இந்த சிறப்பு குறியீடுகளில் சில சீர்தர சின்னங்கள், அழுத்தக் குறிகள், கணிதச் சின்னங்கள் அடங்கியுள்ளன. (இந்தப் பட்டியலை உள்ளகத் தேவைக்கேற்ப அமைத்துக் கொள்ளலாம். அறிவுரைகளுக்கு VisualEditor/Special characters காண்க.)
VisualEditor Toolbar SpecialCharacters-ta.png

VisualEditor toolbar edit notices icon.png
அறிவிப்புக்களைத் தொகு ஆழி பக்கத்திற்கான ஏதேனும் அறிவிப்புக்களை காட்டுகின்றது.

VisualEditor More Settings-ta.png
Page options விரிபட்டி பக்கத்தைச் சேமி ஆழிக்கு இடது புறத்தில் உள்ளது. இந்த விரிபட்டி பக்கத்திற்கான அமைப்புக்களை மாற்ற உதவுகின்றது; இந்த விரிபட்டியில் பக்கம் வழிமாற்றுப் பக்கமா, எவ்வாறு சுட்டப்பட வேண்டும் என்பனவற்றிற்கும் பகுப்புக்களை, சேர்க்க, மாற்ற,நீக்கவும் "மொழி" உருப்படியைப் பயன்படுத்தி மற்ற மொழிகளில் இதே பொருண்மையில் உள்ள கட்டுரைகளின் பட்டியலைக் காணவும் உருப்படிகள் உள்ளன. தவிரவும் இதுவரை தொகுத்ததை தவறவிடாது, காண்திரை தொகுப்பானிலிருந்து வழமையான விக்கியுரை மூலத் தொகுப்பானுக்கு (ஒரு-வழி மட்டுமே) மாறவும் முடியும்.

VisualEditor bi-directional switching square brackets icon.png
Switch to source editing ஆழி பக்கத்தைச் சேமி ஆழிக்கு அடுத்துள்ளது. இதன் மூலம் விக்கியுரை தொகுப்பானுக்கு மாறிக் கொள்ள முடியும்.

மாற்றங்களைச் சேமிக்க

உங்கள் திருத்தங்களை தொகுத்து முடித்த பிறகு, கருவிப்பட்டையிலுள்ள நீல வண்ண "பக்கத்தைச் சேமி" ஆழியை சொடுக்கவும். நீங்கள் மாற்றங்கள் எதுவும் செய்திராவிட்டால் இந்த ஆழி செயலற்று இருக்கும் (சாம்பல் வண்ணமாயிருக்கும்). உங்கள் தொகுத்தல் மாற்றங்களை நிராகரிக்க, உலாவி சாளரத்தை மூடினால் போதுமானது.
VisualEditor toolbar actions-ta.png

பச்சை வண்ண "பக்கத்தைச் சேமி" ஆழியை அழுத்தினால் உரையாடற் பெட்டி திறக்கும். இதில் உங்கள் செயற்பாடு குறித்த சிறு குறிப்பை வழங்கலாம்; உங்கள் தொகுப்பு சிறியது எனக் குறிப்பிடலாம்; உங்கள் கவனிப்புப் பட்டியல்க்கு பக்கத்தைச் சேர்க்கலாம். இந்த தொகுப்புச் சுருக்கப் பெட்டி விக்கியுரை தொகுப்பானிலுள்ள சுருக்கம்: புலத்திற்கு இணையானது.

உங்கள் மாற்றங்களை சேமிப்பதற்கு முன்னால், "Review your changes" ஆழியைப் பயன்படுத்தி அவை எதிர்பார்த்தபடி வந்துள்ளனவா என மீளாய்வு செய்யலாம். இது விக்கியுரை தொகுப்பானிலுள்ள "மாற்றங்களைக் காட்டு" ஆழிக்கு இணையானது.

"Resume editing" ஆழி நீங்கள் தொகுத்துக் கொண்டிருக்கும் பக்கத்திற்கு திரும்ப எடுத்துச் செல்கின்றது. நீங்கள் செய்த அனைத்து மாற்றங்களையும் பின்னர் சேமிக்க முடியும்.

VisualEditor save dialog-ta.png

இணைப்புகளைத் தொகுக்க

VisualEditor - Toolbar - Linking.png
கருவிப்பட்டையிலுள்ள "இணைப்பு" சின்னம் (சங்கிலிக் குண்டு) மூலம் இணைப்புகளை ஏற்படுத்தலாம்; அல்லது குறுவழி விசைகளைப் Ctrl+K (அல்லது மாக்கில் Command+K) பயன்படுத்தியும் ஏற்படுத்தலாம்.

உரையைத் தேர்ந்தெடுத்து (சிறப்பித்து) பின்னர் "இணைப்பு" ஆழியை அழுத்தினால், இணைப்பை உருவாக்க அந்த உரை பயன்படுத்தப்படும். ஒரு சொல்லிற்கு இணைப்புத் தர வேண்டியிருந்தால் அந்த சொல்லைத் தேர்ந்தெடுக்கலாம் அல்லது அச்சொல்லினுள் எங்காவது திரைக்குறியை வைக்கலாம்.


VisualEditor-link tool-search results.png
நீங்கள் ஆழியைப் பயன்படுத்தினாலோ குறுவழி விசையைப் பயன்படுத்தினாலோ உரையாடற் பெட்டி ஒன்று விரியும்; இதில் இணைப்பை தட்டச்சலாம்.

காண்திரை தொகுப்பான் உள்ளிணைப்புகளை இணைக்க உதவ முயலும்; பொருத்தமான கட்டுரைகளை கீழே காட்டும்.


VisualEditor link tool 2015.png
நீங்கள் இணைப்பைத் தட்டச்சிட்ட பிறகு அல்லது பொருத்தமான இணைப்பைத் தெரிந்தெடுத்த பிறகு இணைப்பு உருவாக்க Enter ஆழியை அல்லது "முடிந்தது" ஆழியை அழுத்தவும். உடனேயே உங்கள் இணைப்பு கட்டுரைப் பக்கத்தில் தோன்றும்; ஆனால் மற்ற மாற்றங்களைப் போலவே இதுவும் முழு பக்கத்தையும் சேமிக்கும் போதுதான் சேமிக்கப்படும்.

VisualEditor-link tool-external link.png
மற்றொரு வலைத்தளத்திலிருக்கும் இணையப் பக்கத்திற்கு இணைப்புத் தரவும் இதே செயல்முறையைப் பின்பற்றவும்: "External link" தத்தலைத் தேர்ந்தெடுத்து, பெட்டியில் அதன் உரலியை இடவும்.

VisualEditor link tool simple link.png
விவரச் சொல் இல்லாத வெளி வலைத்தள இணைப்புகள் இவ்வாறு தோன்றும்: [1]. ஏதாவது உரைச்சொல்லின் வெளியே (காட்டாக, இடைவெளியை அடுத்து) திரைக்குறியை வைத்துக் கொண்டு இந்த இணைப்பை ஏற்படுத்தலாம். இணைப்புக் கருவியை ஆழியை சொடுக்குவதன் மூலமோ குறுவழி விசைகளை பயன்படுத்தியோ திறக்கலாம். உரலியை பெட்டியில் இட்டு "முடிந்தது" ஆழியை அழுத்தினால் இணைப்பு உருவாகும்.

VisualEditor-context menu-link tool.png
ஓர் இணைப்பை மாற்றவோ நீக்கவோ அந்த இணைப்பிற்கான உரையில் சொடுக்குக, பின்னர் அதனருகே தோன்றும் "இணைப்பு" சின்னத்தை அழுத்துக. தொகுப்பதற்கான உரையாடற் பெட்டி தோன்றும். (Ctrl+K விசைபலகை குறுவழியைக் கொண்டும் உரையாடற் பெட்டியை பெறலாம்.) இணைப்பைத் தேர்ந்தெடுக்கும்போது அது நீல வண்ண பட்டையில் தோன்றும். இணைப்புத் தொகுப்பு உரையாடற் பெட்டியில் இணைப்பில் மாற்றங்களை ஏற்படுத்தலாம். இணைப்பை ஒரேயடியாக நீக்க, பெட்டியின் கீழ் இடது மூலையிலுள்ள "நீக்குக" ஆழியை அழுத்த வேண்டும்.

இணைப்புத் தரும் வலைத்தளத்தை வேறொரு சாளரத்தில் திறக்க இணைப்பை சொடுக்க வேண்டும். (வெளியிணைப்பு சரியாக வேலை செய்கிறதா எனப் பார்க்க இவ்வாறு செய்யலாம்.)

இணைப்பிற்கான சொல்லிலிருந்து (அல்லது இணைப்பைக் குறிக்கும் சொற்றொடர்) வெளியேற அல்லது இந்த இணைப்பிற்குப் பிறகு வேறேதேனும் எழுத விரும்பினால் அழுத்துக:

  • ஒருமுறை அழுத்தினால் இணைப்புத் தொகுப்பு உரையாடற்பெட்டியிலிருந்து வெளியேறி திரைக்குறியை இணைக்கப்பட்ட சொல்லின் முடிவில் வைக்கும் (நீலப் பட்டை, இந்த அங்கத்தை தொகுக்க)
  • இருமுறை அழுத்தினால் திரைக்குறியை இணைப்புச் சொல்லின் இறுதியில் வைக்கும்; உங்கள் அடுத்த உரையை எழுத தயாரான நிலையில் இருக்கும்.

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

உசாத்துணைகளைத் தொகுக்க

For further information, see மேற்கோள் வார்ப்புருக்களைப் பயன்படுத்த உதவி அல்லது சைட்டாய்டின் Cite ஆழியைப் பயன்படுத்த உதவி

Determining which system is in place

உங்கள் விக்கி மூன்று அடிக்குறிப்பு அமைப்புகளில் ஒன்றைப் பின்பற்றலாம். வலதுபுறம் காட்டப்பட்டுள்ளது மிகவும் எளிதானதாகும்; "Cite" தெரிவுப்பட்டியில் எந்த மேற்கோள் வார்ப்புருவும் இருக்காது. உங்கள் விக்கியில் இந்த அமைப்பு பின்பற்றப்பட்டிருந்தால் அடிக்குறிப்புகள் குறித்து நீங்கள் அறிந்து கொள்ள வேண்டிய அனைத்தும் இந்தப் பக்கத்தில் உள்ளன.
VisualEditor cite menu default.png

இரண்டாவது அமைப்பில் முன்பு போலவே "Cite" தெரிவுபட்டி இருக்கும்; ஆனால் இதில் கூடுதலாக விரைவான அணுக்கத்திற்காக பல புகழ்பெற்ற மேற்கோள் வார்ப்புருக்கள் இடப்பட்டிருக்கும். உங்கள் விக்கி இந்த அமைப்பை பின்பற்றினால், இவற்றைக் குறித்த மேல் விவரங்களுக்கு Help:VisualEditor/User guide/Citations-Templates பார்க்கவும்.
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-FullHelp:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

ஏற்கெனவே உள்ள மேற்கோளைத் திருத்த

ஏற்கெனவே உள்ள மேற்கோளைத் திருத்த, உரையினூடே இது தோன்றும் இடத்தில் சொடுக்குக (பொதுவாக அடைப்புக்குள்ளான எண்); "Referenceerence" சின்னத்தைக் காண்பீர்கள் (நூற்குறி) அல்லது இந்த மேற்கோளை உருவாக்க பயன்படுத்திய வார்ப்புருவின் சின்னம் (மற்றும் பெயர்) காண்பீர்கள். ஏதென்றாலும் "Edit" ஆழியை சொடுக்கினால் மேற்கோளைத் தொகுக்க உரையாடற் பெட்டி திறக்கும்.
VisualEditor - Editing references 1.png

"Referenceerence" சின்னத்திற்கு, "தொகு"வை சொடுக்கினால் மேற்கோள் உரையாடற்பெட்டி திறக்கும். மேற்கோள் தகவலை மாற்ற அதனைச் சொடுக்கவும்

பல விக்கிகளும் மேற்கோள்களை வடிவூட்ட வார்ப்புருக்களைப் பயன்படுத்துகின்றன. தெரிந்தெடுக்கப்பட்ட மேற்கோள் இத்தகைய வார்ப்புருவால் உருவாக்கப்பட்டிருந்தால் திரைக்குறியை மேற்கோள் மீது கொண்டு செல்லும்போது அனைத்துத் தகவல்களும் அழுந்த காட்டப்படும்.

வார்ப்புரு பயன்படுத்தப்பட்டிருந்து நீஙள் மேற்கோள் மீது சொடுக்கினால், சில தகவல்களுடன் Template சின்னம் (புதிர் துண்டு) தோன்றும். "தொகு" ஆழியை அழுத்தினால் வார்ப்புரு சிறு தொகுப்பான் உரையாடற்பெட்டியில் வார்ப்புருவின் உள்ளடக்கத்தை தொகுக்கலாம்.

VisualEditor - Editing references 6.png

மேற்கோளை சொடுகும்போது மேற்கோள்களுக்கான சீர்தர வார்ப்புரு சின்னம் தோன்றினால் (வலது புறம் எடுத்துக்காட்டு உள்ளது), "தொகு"வை அழுத்தினால் வார்ப்புரு சிறுதொகுப்பான் உரையாடற் பெட்டி திறக்கும்.
VisualEditor - Editing References - Cite Web.png

வார்ப்புரு சிறுதொகுப்பான் உரையாடற்பெட்டியினுள் தகவல் வகைகளை சேர்க்கலாம் அல்லது நீக்கலாம்; அல்லது தற்போதைய உள்ளடக்கத்தை மாற்றலாம். உரையுள்ள புலங்கள் (வார்ப்புரு கூறளவுகள்) மட்டுமே துவக்கத்தில் காட்டப்படும். புலங்களைச் சேர்க்கசிறு தொகுப்பானின் கீழேயுள்ள "Add more information" மீது சொடுக்குக.
VisualEditor - Editing references 5.png

தொகுத்தல் முடிந்த பின்னர் "மாற்றங்களை இடு"யைச் சொடுக்குக.
VisualEditor Apply Changes-en.png

ஏற்கெனவே உள்ள மேற்கோளை மீளவும் பயன்படுத்த

உங்களுரைக்குச் சான்றாக அளிக்கக் கூடிய மேற்கோள் ஏற்கெனவே கட்டுரைப் பக்கத்தில் இருந்தால் ஏற்கெனவே உள்ள மேற்கோளை மீளவும் பயன்படுத்துவதைத் தேர்ந்தெடுக்கலாம்.

ஏற்கெனவே உள்ள மேற்கோளை மீண்டும் பயன்படுத்த திரைக்குறியை மேற்கோளிட வேண்டிய உரையின் நடுவில் வைத்துக் கொண்டு "Cite" விரிபட்டியில் "$re-using-reference" உருப்படியைத் தேர்ந்தெடுக்கவும் .

(குறிப்பு: உங்கள் விக்கியில் மேலே விவரித்த மூன்றாம் வகை அடிக்குறிப்பு அமைப்பு செயற்பாட்டில் இருந்தால், "Cite" விரிபட்டிக்குப் பதிலாக "மீளவும்-பயன்படுத்து" தத்தல், உரையாடற்பெட்டியில் இருக்கும்.)

VisualEditor Cite menu re-use.png

மேற்கோள் உரையாடற்பெட்டியில், மீளவும் பயன்படுத்தபட விரும்பும் மேற்கோள்களை தேர்ந்தெடுங்கள். பல மேற்கோள்கள் இருந்தால் ("Search within current citations" எனப் பெயரிடப்பட்டுள்ள) தேடுதல் பெட்டியில் குறிப்பிட்ட தேடுசொல்லிட்டு தேவையான மேற்கோள்களை பட்டியலிட வைக்கலாம்.
VisualEditor - Editing references 18.png

புதிய மேற்கொளை சேர்ப்பது எப்படி ?

"Cite" விரிபட்டி கொண்டு மேற்கோளை சேர்க்க, உரையில் தேவைப்படும் இடத்தில் திரைக்குறியை வைக்கவும். பிறகு பொருத்தமான மேற்கோள் வகையைத் தேர்ந்தெடுக்கவும்.
VisualEditor references more.png

"மேற்கோள்" விருப்பத்தேர்வைப் பயன்படுத்துதல்

"$basic" உருப்படியை தேர்ந்தெடுத்தால் காட்டப்படும் திரைக்காட்சி இங்குள்ளது. மேற்கோள் தொகுப்பானில் உங்கள் மேற்கோளை, வடிவூட்டலுடன், இடவும்.

இந்த மேற்கோள் ஏதேனும் குழுவில் சேர்க்கலாம்; பொதுவாக இது வெறுமையாகவே விடப்படும். (இந்த தேர்கை மேற்கோள்களை References list கருவி கொண்டு குழுக்களாக காட்ட பயன்படுத்தப்படுகின்றது.)

VisualEditor - Editing references 20.png

மேற்கோள் உரையாடற்பெட்டியில் ஏதேனும் மேற்கோள் வார்ப்புருவையோ அல்லது வேறு வார்ப்புருவையோ புதிய மேற்கோளில் சேர்க்க விரும்பினால் மேற்கோள் தொகுப்பானிற்குள்ளேயே உள்ள செருகு கருவிப்பட்டையிலிருந்து Template சின்னத்தை (புதிர் துண்டு) தேர்ந்தெடுக்கவும்.
VisualEditor Template Insert Menu-ta.png

பிறகு, நீங்கள் விரும்பும் வார்ப்புரு உள்ளதா எனப் பாருங்கள்; இருந்தால் மற்ற வார்ப்புருக்களைப் போலவே அதனை சேர்க்கவும் தொகுக்கவும் செய்யலாம். (வார்ப்புருக்களைக் குறித்து மேலும் தகவல் தேவைப்பட்டால் வார்ப்புருக்களைத் தொகுத்தல் பகுதியைக் காண்க.)

புதிய வார்ப்புருவை தொகுத்து முடித்த பின்னர் "மாற்றங்களை இடு" சொடுக்கி மேற்கோள் தொகுப்பானுக்குத் திரும்பலாம்; மீண்டும் "மாற்றங்களை இடு" சொடுக்கி தொகுத்துக் கொண்டிருக்கும் கட்டுரைக்குத் திரும்பலாம்.

VisualEditor - Editing references 9.png

அந்தப் பக்கத்திற்கு ஏற்கெனவே மேற்கோள்கள் பட்டியல் இல்லாதிருந்தால் (காட்டாக, பக்கத்தின் முதல் மேற்கோளை சேர்க்கும் போது), மேற்கோள்களும் அவற்றின் உரைகளும் பட்டியலாக வாசகருக்கு எங்கு காட்டப்படும் என்பதை குறிப்பிடவேண்டும்.

மேற்கோள் பட்டியல் காட்டப்பட வேண்டிய இடத்தில் (பொதுவாக இது பக்கத்தின் கடைசியில் இருக்கும்) திரைக்குறியை வைத்துக் கொண்டு "செருகு" தேர்வுப்பட்டியைத் திறந்து "References list" சின்னத்தை (மூன்று நூல்கள்) அழுத்தவும்.

VisualEditor References List Insert Menu-ta.png

மேற்கோள்களை பல குழுக்களாகப் பயன்படுத்துவதாக இருந்தால், (இது மிகவும் அரிது), இந்த உரையாடற்பெட்டியில் அந்த குழுவைக் குறிப்பிடலாம். நீங்கள் குறிப்பிட இடத்தில் அந்தக் குழுவைச் சேர்ந்த மேற்கோள்கள் மட்டுமே காட்டப்படும்.

மேற்கோள் பட்டியல் உரையாடற்பெட்டியில் இறுதி செயல் "நுழை" சொடுக்குவதுதான்.

VisualEditor references list-ta.png

சீர்தர மேற்கோள் வார்ப்புருக்களைப் பயன்படுத்துதல்

உங்கள் மொழி விக்கி "Cite" தேர்வுப்பட்டியில் கூடுதலாக மேற்கோள் வார்ப்புருக்களை சேர்த்திருக்கலாம். அவ்வாறெனில், உங்கள் விக்கியில் மிகவும் பயன்படுத்தப்படும் மேற்கோள் வார்ப்புருவிற்கு எளிதான அணுக்கம் வழங்குகின்றது. (உங்கள் மொழி விக்கியில் கூடுதல் மேற்சான்று வார்ப்புருக்களை இணைப்பதற்கான அறிவுரைகள் இங்குள்ளன.)
VisualEditor - Editing References - Cite Pulldown.png

"Cite book" போன்ற வார்ப்புருச் சின்னத்தைச் சொடுக்கும்போது அந்த வார்ப்புருவிற்கான வார்ப்புரு குறு-தொகுப்பான் தோன்றுகின்றது. இதில் முக்கியமானத் தகவல்கள் உடுக்குறி கொண்டு குறிப்பிடப்படுகின்றன. பெரும்பான்மையான பொதுப் புலங்கள் காட்டப்பட்டாலும் அனைத்தையும் நிரப்ப வேண்டியதில்லை.
VisualEditor - Editing references - Cite book required fields.png

கூடுதல் கூறளவுகளைச் சேர்க்க, வார்ப்புரு குறு-தொகுப்பானில் கீழே சென்று "Add more information" தேர்வை சொடுக்கவும்.

தொகுத்தல் முடிந்த பின்னர் "நுழை"யைச் சொடுக்குக.

VisualEditor - Editing references - Add parameter.png

படிமங்களையும் பிற ஊடகக் கோப்புகளையும் தொகுத்தல்

படிமங்களைத் தொகுத்தல்

கட்டுரைப் பக்கத்தில் புதிய படிமம்மதை (அல்லது பிறவகை ஊடகக் கோப்பு) சேர்க்க, "செருகு" தேர்வுப் பட்டையில் "ஊடகம்" சின்னத்தை (மலைகள் உள்ள படம்) சொடுக்கவும். திரைக்குறி உள்ள இடத்தில் படிமம் சேர்க்கப்படும்.
VisualEditor Media Insert Menu-ta.png

"ஊடகம்" சின்னத்தை சொடுக்கினால் தோன்றும் உரையாடற்பெட்டி தானாகவே விக்கிமீடியா பொதுவகத்திலும் உங்கள் விக்கியிலும் உள்ள கட்டுரைப் பக்கத்திற்கு தொடர்புடைய ஊடகக் கோப்புகளைத் தேடும்.

உரையாடற்பெட்டியின் தேடுதல் பெட்டியில் உள்ள உரையை மாற்றுவதன் மூலம் தேடுதலை மாற்றலாம்.

கோப்பொன்றைத் தேர்வுசெய்ய, தேவைப்படும் படிமத்தின் வில்லைப்படத்தில் சொடுக்குக.

இது அப்படிமத்தை நீங்கள் தொகுக்கும் பக்கத்தில் சேர்க்கும்.

VisualEditor - Media editing 2.png

நீங்கள் தேர்ந்தெடுத்த படிமம் சேர்க்கப்பட்டபிறகு, மற்றுமொரு உரையாடற்பெட்டி தோன்றும். இதில் படிமத்திற்கான தலைப்பை சேர்க்கவும் தொகுக்கவும் இயலும். தலைப்பிற்கு வடிவூட்டவும் இணைப்புகள் தரவும் முடியும்.
VisualEditor - Media editing 6.png

மேலும் ஊடக உரையாற்பெட்டியில், திரைப் படிப்பான்களை பயன்படுத்துவோருக்கும் படிமக் காட்சிகளை விலக்கியுள்ளோருக்கும் காட்டுவதற்காக, மாற்று தலைப்புரைகளை வழங்கவும் வழி உள்ளது.
VisualEditor - Media editing 7.png

படிமத்திற்கு மேலும் பல கூறளவுகளை "நுட்பமான அமைப்புகள்" சாளரத்தில் அமைக்கலாம். இவற்றில் படிமத்தின் ஒழுங்கமைப்பு, வகை, அளவு ஆகியவை அடங்கும்.
VisualEditor - Media editing 8.png

முடிந்தவுடன் "மாற்றங்களை இடு" சொடுக்கி உரையாடற்பெட்டியை மூடி தொகுப்புப் பக்கத்திற்குத் திரும்பலாம்.
VisualEditor Apply Changes-en.png

படிமத்தைச் சொடுக்கி பின்னர் படிமத்தின் கீழே தோன்றும் "ஊடகம்" சின்னத்தைச் சொடுக்கினால் ஏற்கெனவே உள்ள படிமத்திற்குத் தலைப்பை இடலாம், தொகுக்கலாம் அல்லது மற்ற அமைப்புக்களை மாற்றலாம்.

ஏற்கெனவே உள்ள படிமத்தை சொடுக்கி அளவுமாற்று சின்னத்தை (கீழ் மூலைகளில், ஒன்று அல்லது இரண்டிலும், உள்ள இருதலையுள்ள அம்பு) நகர்த்தி அளவை மாற்றலாம்.

தவிரவும் படிமமொன்றை பக்கத்தின் மேற்பகுதிக்கோ கீழ்ப்பகுதிக்கோ "இழுத்து விடலாம்".

VisualEditor - Media editing 3.png

படிமங்களை தரவேற்றம் செய்வது எப்படி ?

ஊடக உரையாடற்பெட்டியில் உள்ள தத்தல் மூலம் படிமங்களை தரவேற்றலாம்.
VisualEditor - Media upload 1.PNG

"மேலேற்று" தத்தலைச் சொடுக்கி உங்கள் கணினியிலிருந்து படிமம் ஒன்றைத் தேர்ந்தெடுக்கவும். படிமக் கோப்பின் பெயரை தட்டச்சிடவும் செய்யலாம்; அல்லது படிமம் ஒன்றை இழுத்துவந்து பெட்டியிலிடலாம்.
VisualEditor - Media upload 1.PNG

மக்கள் எளிதாக கண்டறிய படிமத்தை குறித்த விவரணமும் பொருத்தமான பகுப்பில் இணைத்தலும் வேண்டும். [[File:VisualEditor_-_Media_upload_2.PNG|frameless|400px|center]]

முடித்ததும் கட்டுரைப் பக்கத்தில் உங்கள் படிமம் சேர்க்கப்பட்டிருக்கும்.
VisualEditor-logo.svg

ஊடகத் தொகுதிகளை தொகுத்தல்

புதிய படிமையை (படத்தொகுப்பு) சேர்க்க, "செருகு" பட்டையில் "Gallery" சின்னத்தை (படிமங்களின் தொகுப்பு) சொடுக்கவும். (கருவிப்பட்டையில் இந்தச் சின்னம் தெரியாவிட்டால் இந்த சிறப்பியல்பை காண்திரை தொகுப்பானில் செயலாக்குவதை உங்கள் விக்கி சமூகம் தாமதப்படுத்தியிருக்கலாம்.)
VisualEditor - Gallery1.png

காண்திரை தொகுப்பானில் ஏற்கெனவே உள்ள படிமையை தொகுக்க விரும்பினால், அந்தப் படிமையை சொடுக்கவும். பின்னர் படிமையின் கீழ்ப்பகுதியில் காணப்படும் படிமைச் சின்னத்தை (படிமங்களின் தொகுப்பு) சொடுக்கவும். இது படிமையிலுள்ள முழுமையான படிமைப் பட்டியலுடன், படிமை உரையாடற்பெட்டியைத் தோற்றுவிக்கும்.
VisualEditor - Gallery2.png
படிமை தொகுப்பான் தற்போதைய நிலையில் விக்கியுரை நிரல்மொழி கொண்டு தொகுக்க உதவும் ஓர் எளிய பெட்டியாக உள்ளது. இதில் ஏற்கெனவேயுள்ள படிமையில் புதிய படிமம் ஒன்றைச் சேர்க்க, கோப்புப் பெயரை தட்டச்சிட்டு அதன் பின்னர் நேர்கோட்டையும் (|) அந்தப் படிமத்திற்கான தலைப்பையும் இடவும். ஒவ்வொரு படிமத்தையும் ஒவ்வொரு வரியில் இட வேண்டும். படிமங்களை நீக்கவும், மீளமைக்கவும், ஒழுங்குபடுத்தவும் அல்லது படிமத் தலைப்புகளை மாற்றவும் இந்தப் பட்டியலைத் தொகுக்கலாம்.

முடிந்ததும் "முடிந்தது" ஆழியை அழுத்தி படிமைத் தொகுப்பானிலிருந்து வெளியேறலாம். உங்கள் மாற்றங்களை இப்போது நீங்கள் பயனர்கள் காணும் காட்சியாகக் காணலாம்

படிமைத் தொகுப்பான் உங்கள் மாற்றங்களைச் சேமிப்பதில்லை என்பதை நினைவில் நிறுத்துங்கள். காண்திரைத் தொகுப்பானில் மற்ற மாற்றங்களைப் போலவே இதற்கும் முழுமையான பக்கத்தை சேமிக்க வேண்டும்.

VisualEditor - Gallery3.png

வார்ப்புருக்களைத் தொகுத்தல்

துவக்கம்

தொகுக்கும் பக்கத்தில் புதிய வார்ப்புருவை இணைக்க, திரைக்குறியை வார்ப்புரு செருகப்படவேண்டிய இடத்தில் வைத்துக் கொண்டு "செருகு" விரிபட்டியிலுள்ள "Template" சின்னத்தை (புதிர்த் துண்டு) சொடுக்கவும்.
VisualEditor Template Insert Menu-ta.png

நீங்கள் இணைக்க விரும்பும் வார்ப்புருவின் பெயரைத் தட்டச்சிடத் தொடங்குங்கள்; தோன்றும் பட்டியலில் அந்த சொற்களில் துவங்கும் வார்ப்புருக்கள் காட்டப்படும். இதிலிலிருந்து விரும்பிய வார்ப்புருவை தேர்ந்தெடுக்கவும். பிறகு "வார்ப்புருவைச் சேர்" சொடுக்கவும்.
VisualEditor - Template editing 4.png

தொகுக்கும் பக்கத்தில் ஏற்கெனவே உள்ள வார்ப்புருவையும் தொகுக்கலாம். அந்த வார்ப்புருவை சொடுக்கினால் நீல வண்ணத்திற்கு மாறும்; "Template" சின்னத்துடன் (புதிர்த் துண்டு) கூடிய உரையாடற்பெட்டி தோன்றும். அதிலுள்ள "தொகு" இணைப்பைச் சொடுக்குக.
VisualEditor - Template editing 1.png

சில வார்ப்புருக்கள் பக்கத்தைப் படிப்பவர்களுக்குப் புலப்படாது. காண்திரை தொகுப்பானில் அத்தகைய மறைக்கப்பட்ட வார்ப்புருக்கள் புதிர் சின்னமாகக் காட்டப்படும். The name of the template will be shown next to the puzzle icon. [[File:VisualEditor template not visible.png|frameless|border|center|70px]]

சின்னத்தை தேர்ந்தெடுக்கும்போது தொடர்புள்ள தேர்வுப்பட்டி காட்டப்படும்; நீங்கள் வார்ப்புருவைத் தொகுக்கலாம். [[File:VisualEditor template not visible context menu.png|frameless|border|center|400px]]

வார்ப்புரு கூறளவுகள்

புதிய வார்ப்புருவைச் சேர்க்கும்போதோ அல்லது ஏற்கெனவே உள்ள ஒன்றை திறக்கும்போதோ காண்திரை தொகுப்பான் "Transclusion" உரையாடற்பெட்டியைத் திறக்கின்றது. காண்திரை தொகுப்பான் அறியும் கூடுதல் தகவல்களுக்கேற்ப, TemplateDataExtension:TemplateData, உங்களுக்குக் காட்டப்படும்.

காட்டப்பட்டுள்ள வார்ப்புருவில் TemplateData எதுவும் அமைக்கப்படவில்லை. உரையாடற்பெட்டியில் வார்ப்புருவிற்கான ஆவணப்பக்கத்திற்கு இணைப்பு தரப்பட்டுள்ளது. இந்த ஆவணப்பக்கத்தைப் படிக்கையில் வார்ப்புருவிற்கு ஏதேனும் கூறளவுகள் (புலங்கள்) அமைக்கப்பட்டுள்ளனவா, எந்தப் புலத்தில் என்ன இட வேண்டும் என்பன தெரியவரும். ஒவ்வொரு பெயரில்லா கூறளவுகளுக்கும் எண்கள் பெயராகப் பயன்படுத்தப்படுகின்றன. முதல் பெயரிடப்படாத கூறளவு 1 எனவும் இரண்டாவது, 2 எனவும் தொடர்ந்து இதே போலவும் பெயரிடப்படுகின்றன. [[File:VisualEditor template with no TemplateData.png|frameless|border|center|500px]]

வார்ப்புருவில் TemplateData தகவல்கள் இற்றைப் படுத்தப்பட்டிருந்தால், பின் உரையாடற்பெட்டியில் தனி (பெயரிட்ட) கூறளவுகளின் பட்டியல் காட்டப்படும். [[File:VisualEditor template with TemplateData.png|frameless|border|center|400px]]

ஏற்கெனவே உள்ள வார்ப்புருவில் உரையாடற்பெட்டியில் காட்டப்படும் கூறளவுகளை தொகுக்க முடியும். தவிரவும் கூடுதல் கூறளவுகளை உரையாடற்பெட்டியின் அடிக்கோடியில் காணப்படும் "Add more information" சொடுக்கி சேர்க்க முடியும்.
VisualEditor - Template editing 3.png

வார்ப்புருவில் வேற் வார்ப்புருக்களும் பதியப்பட்டிருந்தால் இந்த துணை-வார்ப்புருக்கள் அவற்றைக் காட்டும் கூறளவுகளின் உள்ளே தோன்றும். இவற்றை கூறளவின் உள்ளிருந்தே தொகுக்கவோ நீக்கவோ முடியும்.

புதிய துணை-வார்ப்புருக்களை சேர்க்க புதிய கூறளவை சேர்க்கும் செயல்முறையைப் பின்பற்ற வேண்டும். துணை-வார்ப்புருக்கள் ஆதரிக்கப்படுகின்றனவா என்பதை வார்ப்புரு ஆவணப்பக்கத்தை பார்த்துச் சரிபார்த்துக் கொள்ள வேண்டும்.

VisualEditor - Template editing 5.png

நிறைவாக்கம்

வார்ப்புருவைத் தொகுத்த பின்னர் "மாற்றங்களை இடு" சொடுக்கி உரையாடற்பெட்டியை மூடி முதன்மைப் பக்க தொகுப்பிற்குத் திரும்பலாம்.
VisualEditor Apply Changes-en.png

மாற்றீடு இடும் வார்ப்புருக்கள்

வார்ப்புரு ஒன்று மாற்றீடு செய்யப்பட வேண்டுமெனில் வார்ப்புருவிற்கு முன்பு subst: (விளக்கிசைக்குறி உட்பட) என தட்டச்சிட வேண்டும்.

தானேநிரப்புகை subst: உடன் வேலை செய்வதில்லை. தானே நிரப்புகை பயன்படுத்த வேண்டுமெனில், முதலில் உங்களுக்குத் தேவையான வார்ப்புருவை கண்டறிந்து பிறகு வார்ப்புருவின் பெயருக்கு முன்பு subst: சேர்க்கவும்.

பின்னர், பச்சை நிற "வார்ப்புருவைச் சேர்" ஆழியை சொடுக்கவும்.

வழக்கம்போல வேண்டிய கூறளவை சேர்த்து "நுழை" சொடுக்கவும்.

VisualEditor - Template editing 7.png

நீங்கள் "மாற்றங்களை இடு" சொடுக்கியபிறகு வார்ப்புரு, கட்டுரைப்பக்கத்தில் விரிவுபட்டுள்ளதைக் காண்பீர்கள்.
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-ta.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

அட்டவணைகளைத் தொகுத்தல்

VisualEditor insert table.png
காண்திரை தொகுப்பான் கொண்டு உங்களால் அட்டவணைகளை இடவும் மாற்றவும் இயலும்.

உங்கள் கணினியில் உள்ள காற்புள்ளியால் பிரிக்கப்பட்ட மதிப்புக்களுடை (.csv) கோப்பை முதன்மை தொகுப்புச் சாளரத்திற்கு இறக்கிக் கொள்ளவும் இயலும்.


"செருகு" தேர்வுப்பட்டியில் "பட்டியல்" என்றத் தேர்வை சொடுக்கினால் காண்திரைத் தொகுப்பான் நான்குக்கு-நான்கு அட்டவணையைச் செருகுகின்றது.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
நீங்கள் அட்டவணியின் ஒரு கிடக்கையையோ நெடுக்கையையோ சேர்க்கவோ நீக்கவோ இயலும்.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

பகுப்புகளைத் தொகுத்தல்

VisualEditor category item-ta.png
பகுப்புகளைத் தொகுக்க, "Page options" தேர்வுப்பட்டியில், "பகுப்புகள்" உருப்படியைச் சொடுக்கவும்.

VisualEditor category editing-en.png
Clicking on "பகுப்புகள்" சொடுக்கினால் தோன்றும் உரையாடற்பெட்டியில் ஏற்கெனவே உள்ள பகுப்புகள் பட்டியலிடப்பட்டுள்ளன; இதில் புதியதைச் சேர்க்கவும் பழையதை நீக்கவும் முடியும்.

இதில் உள்ள விருப்பத்தேர்வு மூலம் பொது (இயல்பிருப்பு) வரிசைப்படுத்தும் சொல்லை அமைக்கவோ மாற்றவோ முடியும்; இது அதே பகுப்பில் மற்ற பக்கங்களுடன் பட்டியலிடப்படும்போது இந்தப் பக்கம் எங்கு காட்டப்படும் என்பதைத் தீர்வு செய்கின்றது.

காட்டாக, "ஜார்ஜ் வாஷிங்டன்" கட்டுரைக்கு இயல்பிருப்பான வரிசைப்படுத்தும் சொல் "வாஷிங்டன், ஜார்ஜ்" ஆகும். "ஐக்கிய அமெரிக்க குடியரசுத் தலைவர்கள்" பகுப்பில் இக்கட்டுரை "வ" என்ற எழுத்தின் கீழ் காட்டப்படும், "ஜ" என்ற எழுத்தின் கீழல்ல.


VisualEditor - Category editing 3.png
பக்கத்திற்கு பகுப்பு சேர்க்க வேண்டுமானால், பகுப்பின் பெயரை "பகுப்பைச் சேர்" என் புலத்தில் இடவும். தட்டச்சத் தொடங்கியதுமே காண்திரை தொகுப்பான் வாய்ப்புள்ள, பொருந்துகின்ற ஏற்கெனவே உள்ள பகுப்புகளைத் தேடும். நீங்கள் ஏற்கெனவே உள்ள பகுப்பொன்றைத் தேர்ந்தெடுக்கலாம் அல்லது பகுப்புப் பக்கம் உருவாக்கப்படாத புதிய பகுப்பை சேர்க்கலாம். (நீங்கள் மாற்றங்களைச் சேமித்த பிறகு, அந்த பகுப்பிற்கு பக்கம் உருவாக்கப்படும் வரை உங்கள் புதிய பகுப்பு சிவப்பு வண்ண இணைப்பாகக் காட்டப்படும்.)

VisualEditor - Category editing 2.png
ஏற்கெனவே உள்ள பகுப்பை நீக்க அதன்மீது சொடுக்கவும்; தோன்றும் உரையாடற்பெட்டியில் "நீக்குக" சின்னதை (குப்பைத் தொட்டி) சொடுக்கவும்.

பகுப்பின் மீது சொடுக்கும்போது கூடவே வரிசைப்படுத்தும் சொல்லை குறிப்பிடவும் முடியும். இயல்பிருப்பான வரிசைப்படுத்து சொல்லை விட இது முன்னுரிமை பெற்றது.


VisualEditor Apply Changes-en.png
பகுப்புத் தொகுத்தல் நிறைவுற்றால் "மாற்றங்களை இடு" சொடுக்கி பக்கத் தொகுப்பானுக்குத் திரும்பலாம்.

பக்க அமைப்புக்களைத் தொகுத்தல்

VisualEditor page settings item-ta.png
பக்கத்தின் அமைப்புகளை மாற்ற கருவிப்பட்டையிலுள்ள "Page options" தேர்வுப்பட்டியை சொடுக்கி அதில் உள்ள "பக்க அமைப்புகள்" ஆழியை தேர்ந்தெடுக்கவும்.

VisualEditor Page Settings-en.png
"பக்க அமைப்புகள்" ஆழி பல விருப்பத்தேர்வுகள் அடங்கிய உரையாடற் பெட்டியைத் திறக்கும்.

VisualEditor Page Settings Redirects-en.png
பக்கத்தை மற்றொரு பக்கத்திற்கு வழிமாற்ற, "Redirect this page to" குறிப்பெட்டியில் குறியிட்டு பின்னர் தொகுத்துக்கொண்டிருக்கும் பக்கத்திற்கு வந்த வாசகரை அனுப்ப விரும்பும் பக்கத்தின் பெயரை தட்டச்சிடவும்.

இந்தத் தேர்வின் கீழே பக்க மறுபெயரிடல்கள் இந்த வழிமாற்றை இற்றைப்படுத்துவதை தடுக்கும் விருப்பத்தேர்வு உள்ளது. இது மிகவும் அரிதாகவே பயன்படுத்தபடுகின்றது.


VisualEditor Page Settings TOC-en.png
கட்டுரைப் பக்கத்தில் பொருளடக்கம் காட்டப்பட வேண்டுமா என்பதை மூன்று ஆழிகளில் ஒன்றைத் தேர்வு செய்வதன் மூலம் மாற்றலாம். இயல்பிருப்பாக "If needed" உள்ளது; இதன்படி மூன்று அல்லது அதற்கு மேற்பட்ட தலைப்புகள் இருந்தால் பொருளடக்கம் காட்டப்படும்.

VisualEditor Page Settings Edit Links-en.png
இந்தக் குறிப்பெட்டியில் குறியிடுவதன் மூலம் பக்கத்தின் ஒவ்வொரு பத்தித் தலைப்புகளுக்கும் அடுத்து தொகு இணைப்புகள் காட்டப்படாமலிருக்கும்.

VisualEditor Apply Changes-en.png
Page options வைத் தொகுத்த பிறகு மாற்றங்களை இடு யை சொடுக்கி பக்கத் தொகுப்பானிற்கு திரும்பலாம்.

கணித ஈடுகோள்களைத் தொகுத்தல்

கட்டுரைப் பக்கத்தில் புதிய கணித ஈடுகோளை சேர்க்க, வேண்டிய இடத்தில் திரைக்குறியை வைத்துக் கொண்டு கருவிப்பட்டையிலுள்ள "செருகு" தெரிவுப்பட்டையில் "⧼math-visualeditor-mwmathinspector-title⧽" சின்னத்தை ("Σ") அழுத்துக.
VisualEditor Formula Insert Menu-ta.png

திறக்கும் சாளரத்தில் LaTeX நிரல்தொடரியைப் பயன்படுத்தி ஈடுகோளை தட்டச்சலாம். காண்திரை தொகுப்பான் ஈடுகோளை இற்றைப்படுத்தும்; நீங்கள் மாற்றங்களை மேற்கொள்ளும்போதே எவ்வாறு காட்சியளிக்கும் எனத் தெரியும். ஈடுகோளை நிறைவாகச் செய்தபிறகு "முடிந்தது" ஆழியை அழுத்தவும்.
VisualEditor formula-ta.png

ஏற்கெனவே உள்ள கணிதச் சமன்பாட்டை தொகுக்க அதன் மீது சொடுக்கிய பிறகு தோன்றும் "Σ" சின்னத்தை சொடுக்கவும். இது ஈடுகோள் சாளரத்தைத் திறக்கும்; இங்கு மாற்றங்களை மேற்கொள்ளலாம்.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, click the "Musical notation" option.

To edit an existing musical notation on the page, double click on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, click the "Done" button to close the dialog and save your changes.
Musical.png

கவிதைகளையும் மற்ற பிற சிறப்பு உரைகளையும் தொகுத்தல்

சங்கப் பட்டியல்கள், கவிதைகள், இசை வரிவடிவங்கள் போன்ற சிலவற்றிற்கு காண்திரை தொகுப்பான் இன்னும் முழுமையாக தயாராகவில்லை.

VisualEditor editing poem 1.png

காண்திரை தொகுப்பான் கொண்டு பலவற்றில், ஏற்கெனவே உள்ள உருப்படிகளை தொகுக்கலாம்; ஆனால் புதியவற்றைச் சேர்க்க முடியாது.

இவை முழுமையாக செயலாக்கப்படும்வரை மற்றொரு பக்கத்திலிருந்து நகலெடுத்து ஒட்டலாம் அல்லது மூல விக்கியுரையை நேரடியாகத் தொகுக்கலாம்.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

விசைப்பலகை குறுவழிகள்

பல தொகுப்பாளர்களுக்கும் நேரடியாக விக்கியுரையில் தட்டச்சுவது பழகியிருக்கும்; குறிப்பாக தடிமனுக்கு, சாய்ந்தெழுத்துகளுக்கு மற்றும் விக்கியிணைப்புகளுக்கு நேரடியாக பயன்படுத்தியிருப்பர். இதைப் போன்று கருவிப்பட்டையை பயன்படுத்தாது விரைவாக வடிவூட்ட காண்திரை தொகுப்பானிலும் விசைப்பலகை குறுவழிகள் உள்ளன; சில பொதுவான அடிக்கடிப் பயன்படுத்தப்படும் குறுவழிகள் கீழே தரப்பட்டுள்ளன:

கணிப்பொறி சுருக்கவழி செயற்பாடு மாக் சுருக்கவழி

Ctrl+B தடித்த Cmd+B

Ctrl+I சாய்வெழுத்து Cmd+I

Ctrl+K இணைப்பிடுதல் Cmd+K

Ctrl+X வெட்டு Cmd+X

Ctrl+C படியெடு Cmd+C

Ctrl+V ஒட்டு Cmd+V

Ctrl+Z மீளமை Cmd+Z