مساعدة:المحرر المرئي/دليل المستخدم

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 25% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎Yorùbá • ‎中文
PD ملاحظة:بتحريرك هذه الصفحة فإنك توافق على وضع مساهمتك في الملك العام وفق CC0.راجع صفحات مساعدة الملكية العامة للمزيد من المعلومات.
PD
اذا رغبت بتجربة استخدام المحرر المرئي بدون تعديل مقالة، يمكنك تجريبه بهذه الصفحة لست بحاجة لانشاء حساب لاستخدام المحرر المرئي في تلك الصفحة.


فتح المحرر المرئي

لتحرير صفحة باستخدام المحرر المرئي إضغط على علامة التبويب "عدل" الموجودة في أعلى الصفحة.

فتح الصفحة للتحرير قد يأخد بضع ثواني، وقد يطول الوقت إذا كانت الصفحة طويلة جدا.

الضغط على علامة التبويب "عدل المصدر" سيفتح محرر مصدر الويكي الكلاسيكي

VisualEditor edit tab-ar.png

يمكنك أيضا فتح المحرر المرئي بالنقر على رابط "edit" في كل قسم
VisualEditor - Section edit links-en.png

البدء: شريط أدوات المحرر المرئي

اخذ لقطة شاشة من شريط أدوات المحرر المرئي
عندما تبدأ عملية التحرير بإستخدام المحرر المرئي سيظهر شريط الأدوات الخاص به أعلى الشاشة. وسيحتوي على العديد من الأيقونات المألوفة:

VisualEditor - Toolbar - Undo-redo.png
تراجع وأعد التغييرات التي قمت بها.

VisualEditor Toolbar Headings-ar.png
قائمة الترويسات المنسدلة: تتيح لك إختيار مستوى العنوان. لتغيير نمط الفقرة، ضع علامة الكتابة في الفقرة، ثم اختر عنصر من القائمة (لا يلزم تظليل النص). عناوين الأقسام تكون عناوين "عنوان"، وعناوين الأقسام الفرعية "عنوان 2" و"عنوان 3" وهكذا دواليك. التنسيق الافتراضي لنص هو "فقرة".

VisualEditor Toolbar Formatting-ar.png

"التنسيق:" الضغط على "A" يفتح قائمة. لاي عنصر لعمل تاثير عليه، في البداية يجب ان تختار (تعلم) بعض النصوص.

  • العنصر "غليظ" (B) يجعل النص المحدد بالخط العريض.
  • العنصر "مائل" (I) يجعل النص المحدد بالخط المائل.
  • العنصر "نص علوي" (x2) يسبب بجعل النص المحدد يبدو أصغر من باقي النص الغير محدد وكما يجعله يبدو اعلى منه كذلك.
  • العنصر "$superscript" (x2) يسبب ظهور النص المحدد بتنسيق أصغر من باقي النص غير المحدد، كما يجعله يبدو أدنى منه كذلك.
  • عنصر "سطر وسطي" (S) يضيف خطاً يقطع النص المحدد.
  • العنصر "كود برمجي" (مجموعة من الأقواس المعقوفة {}) يغيّر خط النص المظلل إلى خط أحادي المسافة، ما يميّزه عن النص الآخر الذي تكون كلماته متباعدة نسبياً.
  • العنصر "سطر تحتي" (U) يضيف خطاً تحت النص المظلل.
  • العنصر "لغة" (Aあ) يتيح لك اختيار اللغة (اليابانية على سبيل المثال) واتجاه الكتابة (مثلاً، من اليمين إلى اليسار) للنص المحدد.
  • العنصر الأخير (VisualEditor MediaWiki theme clear icon bitmap.png) ويسمى "أزل التنسيق"، يحذف تنسيق الأحرف من النص المحدد بما في ذلك الوصلات.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
أداة الربط: السلسلة linking tool. إن النقر على هذه الأداة بعد اختيار نص معين يفتح link dialog.

VisualEditor - Cite Pulldown.png

مرجع menu:' تستخدم لإضافة استشهادات ضمنية (وتعرف أيضاً بالحواشي أو المرجعيات). جميع المشاريع لها وصولية لتنسيق مرجعية "$basic" والقدرة على إعادة استخدام "$re-use" الاستشهادات باستخدام القائمة. كما تتيح لك هذه القائمة وصولية أسرع لقوالب الاستشهاد المحلية إذا كانت مفعلة في الويكي.

(يمكن مطالعة تعليمات حول إضافة قوالب الاستشهاد المحلية إلى قائمة مرجع في ويكي معينة هنا VisualEditor/Citation tool).


VisualEditor citoid Cite button.png
استشهد button: If the citoid service is enabled on your wiki, then you will see a استشهد button instead of a مرجع menu.

The citoid service tries to fill out citation templates automatically.


VisualEditor Toolbar Lists and indentation-ar.png
القوائم والهامش: أول أيقونتان تتيحان تكوين قائمة مرقمة أو نقطية. آخر أيقونتان تتيحان زيادة أو تقليل الهامش الخاص بالمحتوى.

VisualEditor Insert Menu-ar.png
الوسائط والمصادر والتضمينات: كل أيقونة تفتح نافذة خاصة بها:
  • أيقونة "ملفات" (صورة الجبال) تفتح نافذة الوسائط.
  • أيقونة "قالب" (قطعة أحجية) تتيح تحرير القوالب
  • The "Table" item allows you to insert a table.
  • The "تعليق مخفي" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode, where they are indicated by an exclamation mark icon. In edit mode, clicking on the exclamation mark icon allows you to edit or delete the comment.
  • The "هيرغليفية" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "Code block" item allows you to insert code.
  • شاب خالد
  • أيقونة "معرض" (مجموعة صور) تتيح إدراج معرض صور في الصفحة.
  • The "⧼math-visualeditor-mwmathinspector-title⧽" icon (Σ) opens the formula inserter dialog.
  • The "Graph" item allows you to insert a graph.
  • The "توقيعك" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • * أيقونة "⧼visualeditor-dialogbutton-referencelist-tooltip⧽" (ثلاثة كتب) تفتح حوار لعرض التفضيلات.

Special character insertion: The "رموز" (Ω) icon is next to the "إدراج" menu. When clicked, it displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, diacritics, and mathematical symbols. (This list may be customized locally. See VisualEditor/Special charactersVisualEditor/Special characters for instructions.)
VisualEditor Toolbar SpecialCharacters-ar.png

VisualEditor toolbar edit notices icon.png
The Edit notices button displays any notices for the page.

VisualEditor More Settings-ar.png
ألغِ أو احفظ تغييراتك.

VisualEditor bi-directional switching square brackets icon.png
The switch to source editing button is next to the احفظ الصفحة button. It allows you to switch to the wikitext editor.

==حفظ التغييرات==

عند الانتهاء من التحرير، إضغط زر "Save page" الأخضر الموجود في شريط الأدوات. لا يمكن النقر على الزر الأخضر إن لم يكن هناك تغييرات. To cancel all your editing changes, close your browser window, or click the "اقرأ" tab above the edit toolbar.
VisualEditor toolbar actions-ar.png

عند الضغط على زر "احفظ الصفحة" الأخضر سيتم توجيهك إلى صندوق حوار صغير يمكنك من خلاله إدخال ملخص عن تعديلك وتحديد المساهمة على أنها طفيفة واختيار مراقبة أي تعديلات تجرى على الصفحة لاحقاً.

الرقم يحدد المساحة المتبقية في ملخص التعديل الخاص بك. يمكنك أيضا مراجعة تعديلاتك للتأكد من أنها تعمل كما ينبغي قبل حفظها.

The "تابع التعديل" button returns you to the page you were editing. You can save all of your changes later.

VisualEditor save dialog-ar.png

تحرير الروابط

VisualEditor - Toolbar - Linking.png

يمكن إضافة الوصلات من خلال أيقونة "الوصلة" (وصلات في سلسلة) الموجودة في شريط الأدوات أو من خلال إستخدام المختصر Ctrl+K (or Command+K على ماك).

إذا قمت بإختيار نص أو وضع المؤشر فوق كلمة ومن ثم قمت بالضغط على زر "وصلة"، سيتم إضافة وصلة للنص المختار.


VisualEditor-link tool-search results-ar.png
سواء كنت تستخدم الزر أو مختصر لوحة المفاتيح، سيتم عرض حوار يمكنك من كتابة الوصلة (سواء داخلية أو خارجية). سيحاول المحرر المرئي مساعدتك في التعامل مع الوصلات الداخلية من خلال البحث عن الإحتمالات المحتملة بمجرد أن تبدأ بطباعة نص الوصلة.

The link tool will try to help with internal links by searching for likely matches.


VisualEditor link tool 2015.png
ما إن تكتب أو تختار الوصلة، إضغط Enter، إنقر خارج مربع الحوار أو إضغط على أيقونة الغلق (<). ستظهر وصلتك على صفحة المحرر المرئي ولكن لن يتم حفظها حتى تحفظ الصفحة.

VisualEditor - External link-ar.png
لإضافة وصلة لصفحة وب خارج ويكيبيديا، العملية هي نفسها؛ فقط أدخل الوصلة في الحقل وستضاف بصفة "وصلة خارجية".

VisualEditor link tool simple link.png
External links without labels look like this: [١]. You can add these by placing your cursor away from any word (e.g., after a space). Open the link tool by clicking on the button or pressing the shortcut keys. Type the URL in the box, and click the "نفذ" button to insert the link.

[[File:VisualEditor - Link editing inline-ar.png|frameless|border|400px|center]] لتغيير أو إزالة وصلة موجودة، أنقر على الوصلة في النص المكتوب ومن ثم إضغط على أيقونة "وصلة" التي ستتواجد بالقرب من الإختيار. يمكنك أيضا النقر على نفس الأيقونة في شريط الأدوات أو إستخدام مخنصر لوحة المفاتيح Ctrl+K بينما يكون المؤشر على الوصلة. When a link is selected, it appears as blue framed.

يمكنك حينئذا تحرير رابط الوصلة أو إزالتها كليا بالضغط على زر 'إزالة' (علامة سلة المهملات) الموجود في أعلى الركن الأيمن من مربع الحوار. You can also open the link's target in another window by clicking on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

تحرير المراجع

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "مرجع" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "مرجع" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-FullHelp:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

تحرير مرجع قائم

لتحرير مرجع قائم، قم بالنقر عليه في النص ومن ثم إنقر على أيقونة "مرجع" (علامة المؤشر) التي تظهر بالقرب منه، أو الموجودة في شريط الأدوات.
VisualEditor - Editing references 1-ar.png

النقر على أيقونة مراجع يفتح مربع حوار يحتوي على محرر مصغر حيث يمكنك من تحرير نص المرجع.

تستخدم الكثير من الويكيز قوالب لتنسيق المراجع وفقا لمعيار محدد. ستلاحظ هذا إذا قمت بتحرير مرجع قائم والذي سيتحول لونه إلى الأزرق عند إختياره.

If a template was used and you click on the reference information, then the قالب icon (puzzle piece) will appear with some information. Click on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6-ar.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

يسمح لك النقر على أيقونة الإضمان (علامة قطعة أحجية) بتعديل معطيات القالب.
VisualEditor - Editing references 5-ar.png

عند إنتهائك قم بالضغط على "إحفظ التغييرات" وسيتم حينئذا توجيهك إلل محرر المرجع.
VisualEditor Apply Changes-ar.png

إعادة إستخدام مرجع قائم

إذا كان هناك مرجع قائم ومستخدم قبلا في الصفحة، يمكنك إعادة إستخدامه لنص أخر بحاجة إلى مصدر في نفس الصفحة.

لإعادة إستخدام مرجع قائم، ضع مؤشرك في المكان الذي تود إضافته، وإنقر على أيقونة "مرجع" (صورة مؤشر أو علامة) في شريط الأدوات.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "مرجع" menu.)

VisualEditor Cite menu re-use.png

إذا كان هناك مراجع كثيرة، يمكنك إستخدام شريط البحث (معلم ب"ما الذي تود إضافة مصدر له؟") لإستعراض المصادر التي تحتوي على نص معين.

إبحث عن المصدر الذي تود إعادة إستخدامه وقم بإختياره.

VisualEditor - Editing references 18.png

إضافة مصدر جديد

لإضافة مرجع جديد، ضع مؤشرك في المكان الذي تود إضافته، وإنقر على أيقونة "مرجع" (صورة مؤشر أو علامة) في شريط الأدوات.
VisualEditor references more.png

Using the "Basic" citation

Shown here is what you will see if you select the basic references item. في محرر المرجع، يمكنك إضافة وتعديل وتنسيق مصدرك.

يمكنك إضافة مرجع إلى مجموعة معينة. تستخدم هذه الخاصية لعرض مجموعات المراجع عن طريق أداة "قائمة المراجع".

VisualEditor - Editing references 20.png

إذا قمت بإضافة مرجع جديد وتود أن تستخدم قالبا به، قم بالنقر على أيقونة الإضمان (صورة قطعة أحجية) في شريط الأدوات الخاص بمحرر المرجع.
VisualEditor Template Insert Menu-ar.png

ثم قم بالبحث عن القالب المراد إستخدامه وأدرجه. يمكنك الآن تعديله كما تقوم بتعديل مرجع قائم.

إضغط على "إحفظ التغييرات" وإرجع لمحرر المرجع. قم بالضغط مرة أخرى على نفس الزر للرجوع إلى الصفحة.

VisualEditor - Editing references 9.png

إذا لم يكن هناك قائمة مراجع في الصفحة (على سبيل المثال، المرجع الذي تقوم بإضافته هو أول مرجع في الصفحة) يجب عليك إضافة المرجع حسب ترتيب ظهوره في النص.

ضع المؤشر حيث تريد عرض المرجع (يكون هذا المكان غالبا في أسفل الصفحة) وأنقر على أيقونة "قائمة المراجع" (ثلاثة كتب) لإضافته.

VisualEditor References List Insert Menu-ar.png

إذا قمت بإنشاء مجموعات من المراجع، يمكنك تحديد مجموعة معينة في مربع الحوار، حتى تظهر المراجع المختصة بهذه المجموعة فقط.

لإضافة قائمة مراجع، كل ما عليك فعله هو الضغط على "أظهر التغييرات" في مربع الحوار.

VisualEditor references list-ar.png

Using standard cite templates

Your local wiki may have added extra citation templates to the "مرجع" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and click on the "إضافة معلومات أخرى" option.

Click on "إدراج" when you're done.

VisualEditor - Editing references - Add parameter.png

==تحرير الصور وملفات الوسائط المتعددة الاخرى==

تحرير صور

لإضافة صورة جديدة (أو ملف وسائط أخر) للصفحة، إضغط على أيقونة "ملفات" في "إدراج". الصورة سيتم اضافتها عند مكان المؤشر.
VisualEditor Media Insert Menu-ar.png

عند الضغط على أيقونة "ملفات" سيتم فتح مربع حوار يقوم تلقائيا بالبحث في مستودع ويكيميديا كومنز عن ملفات وسائط لها علاقة بالصفحة التي تقوم بتحريرها.

يمكنك أيضا البحث عن ملفات وسائط أخرى بتغيير النص الموجود في مربع البحث.

اضغط على التصغير لاختيار ملف. وأكد اختيارك بالنقر على "أدرج وسائط".

هذا يدرج الصورة في الصفحة التي تقوم بتعديلها.

VisualEditor - Media editing-ar.png

يمكنك مربع حوار الوسائط من إضافة (وتعديل) تعليق. ويمكن أن يحتوي التعليق على تنسيقات ووصلات.
VisualEditor - Media editing 6-ar.png

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
VisualEditor - Media editing 7.png

You can also set various parameters for the image in the "إعدادات متقدمة" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

عند إنتهائك، قم بالنقر على "طبق التعديلات" لغلق مربع الحوار والرجوع إلى محرر الصفحة.
VisualEditor Apply Changes-ar.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "ملفات" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

يمكنك ايضا سحب ثم افلات الصورة الى مكان اعلى او ادنى في الصفحة.

VisualEditor - Media editing 3-ar.png

Uploading images

You can upload images from a tab in the media dialog.
VisualEditor - Media upload 1.PNG

Click the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box.
VisualEditor - Media upload 1.PNG

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.PNG

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

تحرير معارض الوسائط المتعددة

To add a new gallery, click the "معرض" icon (a set of photos) on the "إدراج" menu. (If you don't see this icon on that menu, then your local wiki has decided to delay implementing this functionality in the visual editor.)
VisualEditor - Gallery1.png

To edit an existing gallery in the visual editor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. يمكنك ايضا تعديل هذه القائمة بحذف او اعادة تعيين الصور او تعديل العناوين.

When you click the "نفذ" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using the visual editor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

Editing templates

Starting

لإضافة قالب جديد، ضع مؤشرك في المكان الذي تود إضافته، وإنقر على أيقونة "قالب" (صورة قطعة أحجية) في قائمة إدراج".
VisualEditor Template Insert Menu-ar.png

أدخل على إسم القالب الذي تود إدراجه وإضغط على "أضف القالب".
VisualEditor - Template editing 4.png

يمكنك أيضا تحرير القوالب المدرجة في الصفحة بإختيارهم (يتحول لونهم للأزرق)، ومن ثم الضغط على أيقونة "تضمين" (صورة قطعة أحجية) التي تظهر عند الإختيار أو الموجودة في شريط الأدوات.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters

When you add a new template or open an existing one, the "تضمين" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateDataExtension:TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

يمكنك إضافة معاملات أو تعديل الموجود حاليا.
VisualEditor - Template editing 3.png

عندما يتم تضمين قالب في قوالب أخرى (القوالب المضمنة ستكون فرعية)، ستظهر القوالب الفرعية على أنها معاملات. يمكن تعديل أو إزالة القالب الفرعي بالضغط على إسمه.

إضافة القوالب الفرعية تتم كما تتم عملية إضافة معاملة إلى قالب. قد تحتاج إلى قراءة توثيق القالب لضمان أن القالب الفرعي المراد إستخدامه مدعوم.

VisualEditor - Template editing 5.png

Finishing

عند إنتهائك، قم بالنقر على "إحفظ التغييرات" لغلق مربع الحوار والرجوع إلى محرر الصفحة.
VisualEditor Apply Changes-ar.png

استبدال القوالب

عندما يجب أن يكون القالب substituted، إطبع subst: (النقطتان الرأسيتان محسوبة) قبل إسم القالب.

خاصية الإكمال التلقائي لا تعمل مع subst:. إذا أردت هذه الخاصية قم بإستخدام subst: وليكن هذا بعد العثور على القالب المراد إستخدامه.

ومن ثم، اضغط على زر "Add template" الأخضر.

أضف أي معاملات كما هو معتاد وإضغط على "إحفظ التغييرات".

VisualEditor - Template editing 7.png

في المرحلة الأولية، لن ترى القالب يتمدد ليشمل الصفحة كلها.
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-ar.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

تعديل الجداول

[[File:VisualEditor-logo.svg|frameless|border|center|200px]] You can use the visual editor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you click on "Table", in the "إدراج" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

[[File:VisualEditor-logo.svg|frameless|border|center|200px]] You can add or delete a column or a row.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

تحرير التصنيفات

VisualEditor category item-ar.png
To edit categories, on the "خيارات الصفحة" menu, click the "التصنيفات" item.

VisualEditor category editing-ar.png

زر "Options" يفتح مربع حوار يعرض التصنيفات القائمة للصفحة ويسمح لك بإضافة تصنيفات جديدة.

ليس من الإمكان ضبط مفتاح الترتيب المستخدم لعرض الصفحة على صفحات التصنيفات.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
لإضافة تصنيف جديد، أدخل إسمه في الحقل "أضف تصنيف". يمكنك أن تنشئ تصنيف جديد أو أن تختار تصنيف قائم.

VisualEditor - Category editing 2.png

لإزالة تصنيف قائم، إضغط عليه ومن ثم إنقر على أيقونة "أزل" (صورة سلة المهملات) في مربع الحوار الذي سوف يظهر.

يمكنك أيضا تحديد مفتاح الترتيب لتصنيف معين في مربع الحوار المفتوح. سيقوم هذا بإبطال المفتاح العام للتصنيف المعدل.


VisualEditor Apply Changes-ar.png
إضغط على "إحفظ التغييرات" عند إنتهائك من تحرير التصنيفات للرجوع إلى محرر الصفحة.

تعديل إعدادات الصفحة

VisualEditor page settings item-ar.png
To edit a page's settings, click to open the "خيارات الصفحة" menu, in the toolbar, and select the "إعدادات الصفحة" button.

VisualEditor Page Settings-ar.png
The "إعدادات الصفحة" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-ar.png
You can make a page a redirect to another page by checking the "حول الصفحة إلى" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.


VisualEditor Page Settings TOC-ar.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "أظهر إن لزم الأمر", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-ar.png
يمكنك أن تجعل الصفحة لا تظهر وصلات التعديل بجانب عنوان كل قسم بالنقر على مربع الاختيار هذا.

VisualEditor Apply Changes-ar.png
Click "طبق التعديلات" when you're done editing the خيارات الصفحة to return to the page editor.

تعديل الصيغ الرياضية

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "⧼math-visualeditor-mwmathinspector-title⧽" icon ("Σ") in the "إدراج" menu on the toolbar.
VisualEditor Formula Insert Menu-ar.png

A window will open in which you can type the formula, using LaTeX syntax. the visual editor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "نفذ" button.
VisualEditor formula-ar.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, click the "Musical notation" option.

To edit an existing musical notation on the page, double click on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, click the "Done" button to close the dialog and save your changes.
Musical.png

تحرير المعادلات الرياضية وعناصر خاصة أخرى

هناك عناصر مثل معارض الصور والمعادلات الرياضية والنوتات الموسيقية غير مدعومة بعد من قبل المحرر المرئي. إلى أن يتم دعمهم، ستضطر إلى إستخدام محرر المصدر الكلاسيكي.

VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

اختصارات لوحة المفاتيح

تعتمد الكثير من أدوات وبرامج التحرير على إدخال نص الويكي مباشرة، خصوصا عمليات تغليظ وإمالة النص وإضافة الوصلات. تسمح Keyboard shortcuts بسرعة إدراج تنسيقات مماثلة من غير الإضطرار إلى الضغط على أزرار شريط الأدوات. تعمل المختصرات العامة وتلك المستخدمة في أدوات التحرير الأخرى في المحرر المرئي.

وصلة كمبيوتر فعل وصلة كمبيوتر ماكنتوش

Ctrl+B غليظ Cmd+B

Ctrl+I مائل Cmd+I

Ctrl+K أدرج وصلة Cmd+K

Ctrl+X قص Cmd+X

Ctrl+C نسخ Cmd+C

Ctrl+V لصق Cmd+V

Ctrl+Z تراجع Cmd+Z