Βοήθεια:VisualEditor/Οδηγίες χρήσης

From mediawiki.org
Jump to navigation Jump to search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 81% complete.
Outdated translations are marked like this.
PD Σημείωση: Όταν επεξεργάζεστε αυτή τη σελίδα, συμφωνείτε να απελευθερώσετε τη συνεισφορά σας υπό την CC0. Δείτε τις Σελίδες Βοήθειας για το Κοινό Κτήμα για περισσότερες πληροφορίες.
PD
Αν θα θέλατε να δοκιμάσετε τον VisualEditor χωρίς να επεξεργαστείτε ένα λήμμα, εδώ είναι μια σελίδα όπου ελεύθερα μπορείτε να τον δοκιμάσετε. Δεν χρειάζεται να έχετε λογαριασμό για να χρησιμοποιήσετε τον VisualEditor σε αυτή τη σελίδα.


Άνοιγμα του VisualEditor

Για να επεξεργαστείτε μια σελίδα με τον οπτικό επεξεργαστή, πατήστε στην καρτέλα "Επεξεργασία", στην κορυφή της σελίδας.

Το άνοιγμα της σελίδας για επεξεργασία μπορεί να διαρκέσει μερικά δευτερόλεπτα ή και περισσότερο αν η σελίδα είναι πολύ μεγάλη.

Πατώντας στην καρτέλα "Επεξεργασία κώδικα" θα ανοίξει ο κλασικός επεξεργαστής κώδικα wiki.

VisualEditor edit tab-el.png

Μπορείτε επίσης να ανοίξετε τον οπτικό επεξεργαστή με πάτημα στον σύνδεσμο "επεξεργασία" σε οποιαδήποτε ενότητα.
VisualEditor - Section edit links-el.png

Ξεκινώντας: η μπάρα εργαλείων του VisualEditor

Στιγμιότυπο της μπάρας εργαλείων του οπτικού επεξεργαστή
Η μπάρα εργαλείων του VisualEditor εμφανίζεται στην κορυφή της οθόνης όταν ξεκινάτε την επεξεργασία με τον VisualEditor. Περιλαμβάνει μερικά γνώριμα εικονίδια:

VisualEditor - Toolbar - Undo-redo.png
Αναίρεση και Ακύρωση αναίρεσης των αλλαγών που έχετε κάνει.

VisualEditor Toolbar Headings-el.png
Το πτυσσόμενο μενού Επικεφαλίδες: επιτρέπει να αλλάξετε το πως μορφοποιείται η παράγραφος. Για να αλλάξετε τη μορφή μιας παραγράφου, πηγαίνετε τον δείκτη κειμένου στην παράγραφο και επιλέξτε ένα αντικείμενο από το μενού (δεν χρειάζεται να επισημάνετε κείμενο). Οι τίτλοι ενοτήτων είναι "Επικεφαλίδα", και οι υποενότητες είναι "Επίπεδο 2", "Επίπεδο 3" κ.ο.κ. Η κανονική μορφή για κείμενο είναι "Παράγραφος".

VisualEditor Toolbar Formatting-el.png

Μορφοποίηση: Πατώντας στο «A» ανοίγει ένα μενού.

  • Το αντικείμενο "Έντονα" (Α) κάνει έντονο το επιλεγμένο κείμενο.
  • Το αντικείμενο "Πλάγια" (Α) κάνει πλάγιο το επιλεγμένο κείμενο.
  • Το αντικείμενο "Εκθέτης" (x2) (εκθέτης) κάνει το επιλεγμένο κείμενο μικρότερο από το περιβάλλον κείμενο και είναι ελαφρώς ψηλότερα από το περιβάλλον κείμενο.
  • Το αντικείμενο "Δείκτης" (x2) (δείκτης) κάνει το επιλεγμένο κείμενο μικρότερο από το περιβάλλον κείμενο και το τοποθετεί ελαφρώς χαμηλότερα από το περιβάλλον κείμενο.
  • Το αντικείμενο Επιλογή προς διαγραφή" (Α) προσθέτει μια γραμμή μέσα από το επιλεγμένο κείμενο.
  • Το αντικείμενο "Κώδικας υπολογιστή" (ένα σύνολο από κυματιστές αγκύλες: {}) αλλάζει τη γραμματοσειρά του επιλεγμένου κειμένου σε γραμματοσειρά σταθερού πλάτους, που το ξεχωρίζει από το περιβάλλον κείμενο (το οποίο χρησιμοποιεί αναλογικά διαστήματα).
  • Το αντικείμενο "Υπογράμμιση" (Α) προσθέτει μια συμπαγή γραμμή κάτω από το επιλεγμένο κείμενο.
  • Το αντικείμενο "Γλώσσα" (文A) επιτρέπει να επισημάνετε την γλώσσα (για παράδειγμα, Ιαπωνικά) και την κατεύθυνση (για παράδειγμα, δεξιά-προς-αριστερά) του επιλεγμένου κειμένου.
  • Το τελικό αντικείμενο (VisualEditor MediaWiki theme clear icon bitmap.png), που καλείται "Αφαίρεση", αφαιρεί όλες τις μορφοποιήσεις χαρακτήρων από το επιλεγμένο κείμενο, συμπεριλαμβανομένων των συνδέσμων.

Αν δεν έχετε επιλέξει κανένα κείμενο, τότε όταν πατήσετε το «A» για να ανοίξετε το μενού, και μετά επιλέξετε ένα αντικείμενο, αυτή η μορφοποίηση θα εφαρμοστεί στο κείμενο που αρχίσατε να πληκτρολογείτε, από όπου ήταν τοποθετημένος ο δρομέας σας.


VisualEditor - Toolbar - Linking.png
Εργαλείο συνδέσμων: Το εικονίδιο αλυσίδα είναι το εργαλείο συνδέσμων. Πατώντας σε αυτό (συνήθως αφού πρώτα έχετε επιλέξει κάποιο κείμενο) ανοίγει τον διάλογο συνδέσμου.

VisualEditor - Cite Pulldown-el.png
Μενού Παραπομπή: Το μενού Παραπομπή χρησιμοποιείται για να προστεθούν εντός κειμένου παραπομπές (επίσης λέγονται "υποσημειώσεις" ή "αναφορές"). Όλα τα εγχειρήματα έχουν πρόσβαση σε βασική μορφοποίηση αναφορών και την δυνατότητα για επαναχρησιμοποίησης των παραπομπών, χρησιμοποιώντας αυτό το μενού. Αυτό το μενού επίσης δίνει γρήγορη πρόσβαση σε τοπικά πρότυπα παραπομπών, αν αυτά είναι ενεργοποιημένα στο wiki σας.

(Οδηγίες για την προσθήκη τοπικών προτύπων παραπομπών στο μενού Παραπομπή σε κάποιο συγκεκριμένο wiki είναι διαθέσιμες στην VisualEditor/Citation tool .)


VisualEditor citoid Cite button-el.png
Κουμπί Παραπομπή: Αν η υπηρεσία citoid είναι ενεργοποιημένη στο wiki σας, τότε θα δείτε ένα κουμπί Παραπομπή αντί το μενού Παραπομπή.

Η υπηρεσία citoid προσπαθεί να συμπληρώσει, αυτόματα, πρότυπα παραπομπών.


VisualEditor Toolbar Lists and indentation-el.png
Λίστες και εσοχή: Τα πρώτα δύο αντικείμενα σας επιτρέπουν να μορφοποιήσετε κείμενο είτε ως "Λίστα με κουκκίδες" είτε "Αριθμημένος κατάλογος". Τα τελευταία δύο αντικείμενα σας επιτρέπουν να μειώσετε ή αυξήσετε το επίπεδο εσοχής των αντικειμένων της λίστας.

VisualEditor Insert Menu-el.png
Εισαγωγή: Το μενού "Εισαγωγή" μπορεί να είναι διαφορετικό σε μερικά εγχειρήματα. Παρακάτω είναι μια λίστα με όλες τις επιλογές που μπορεί να εμφανίζονται.
  • Το εικονίδιο "Εικόνες και πολυμέσα" (μια εικόνα με βουνά) ανοίγει τον διάλογο πολυμέσων.
  • Το εικονίδιο "Πρότυπο" (ένα κομμάτι παζλ) σας επιτρέπει να επεξεργαστείτε πρότυπα.
  • Το αντικείμενο «Πίνακας» σας επιτρέπει να εισαγάγετε ένα πίνακα.
  • Το εικονίδιο "Σχόλιο" (ένα μπαλόνι ομιλίας) σας επιτρέπει να εισάγετε σχόλια που δεν είναι ορατά στους αναγνώστες. Αυτά τα σχόλια μπορούν να διαβαστούν μόνο σε λειτουργία επεξεργασίας, όπου επισημαίνονται από ένα εικονίδιο με θαυμαστικό. Στη λειτουργία επεξεργασίας, πατώντας στο εικονίδιο με θαυμαστικό σας επιτρέπει να επεξεργαστείτε ή να διαγράψετε το σχόλιο.
  • Το εικονίδιο "Ιερογλυφικά" (ένα σύμβολο ανκχ - ☥) σας επιτρέπει να εισάγετε ιερογλυφικά. (Δείτε παρακάτω.)
  • Το αντικείμενο «Code block» σας επιτρέπει να εισαγάγετε κώδικα.
  • Το αντικείμενο «Musical notation» σας επιτρέπει να εισαγάγετε μουσική σημειογραφία.
  • Το εικονίδιο "Γκαλερί" (ένα σύνολο φωτογραφιών) σας επιτρέπει να εισαγάγετε μια πινακοθήκη στη σελίδα.
  • Το εικονίδιο "Μαθηματικός τύπος" (Σ) ανοίγει τον διάλογο προσθήκης μαθηματικών τύπων.
  • Το αντικείμενο «Γράφημα» σας επιτρέπει να εισαγάγετε ένα γράφημα.
  • Το αντικείμενο «Η υπογραφή σας» σας επιτρέπει να εισαγάγετε την υπογραφή που χρησιμοποιείτε στο εγχείρημα. Θα είναι γκριζαρισμένο (μη επιλεγόμενο) όταν επεξεργάζεστε ένα τύπο σελίδας (ένα «namespace», «ομάδα σελίδων»), όπως ένα λήμμα, όπου δεν θα πρέπει να εισάγονται υπογραφές.
  • Το εικονίδιο "Κατάλογος παραπομπών" (τρία βιβλία) ανοίγει ένα διάλογο στον οποίο μπορείτε να ορίσετε το πού θα δει τις παραπομπές ο αναγνώστης. Συνήθως αυτό χρειάζεται να γίνει μόνο μια φορά σε μια σελίδα.

Εισαγωγή ειδικών χαρακτήρων: Το εικονίδιο "Ειδικοί χαρακτήρες" (Ω) είναι δίπλα στο μενού "Εισαγωγή". Όταν πατηθεί, εμφανίζει ένα διάλογο με πολλούς ειδικούς χαρακτήρες. Πατώντας σε κάποιο χαρακτήρα, τον προσθέτετε στο κείμενο. Αυτοί οι ειδικοί χαρακτήρες περιλαμβάνουν κάποια κοινά σύμβολα, διακριτικά, και μαθηματικά σύμβολα. (Αυτή η λίστα μπορεί να προσαρμοστεί τοπικά. Δείτε VisualEditor/Special characters για οδηγίες.)
VisualEditor Toolbar SpecialCharacters-el.png

VisualEditor toolbar edit notices icon.png
Το κουμπί "Ειδοποιήσεις επεξεργασίας" εμφανίζει οποιεσδήποτε ειδοποιήσεις για την σελίδα.

VisualEditor More Settings-el.png
Το μενού Επιλογές σελίδας βρίσκεται αριστερά από το κουμπί Δημοσίευση αλλαγών και το μενού Εναλλαγή επεξεργαστή. Σε αυτό το μενού υπάρχει ένα κουμπί για να ανοίξετε το διάλογο Επιλογές με τις ακόλουθες (αριστερά) καρτέλες:
  • Το Κατηγορίες σας επιτρέπει να προσθέσετε κατηγορίες σε αυτή τη σελίδα και να προσαρμόσετε το πως ταξινομείται η σελίδα, όταν εμφανίζεται εντός μιας κατηγορίας ορίζοντας ένα διαφορετικό κλειδί ταξινόμησης.
  • Το Ρυθμίσεις σελίδας σάς επιτρέπει να κάνετε τη σελίδα ανακατεύθυνση και να προσαρμόσετε τις επιλογές αυτής της ανακατεύθυνσης, να προσαρμόσετε τις ρυθμίσεις σχετικά με την εμφάνιση του Πίνακα Περιεχομένων, να απενεργοποιήσετε τους συνδέσμους επεξεργασίας δίπλα σε κάθε επικεφαλίδα και να ορίσετε τη σελίδα ως σελίδα αποσαφήνισης.
  • Το Προηγμένες ρυθμίσεις σας επιτρέπει να προσαρμόσετε τις ρυθμίσεις σχετικά με την ευρετηρίαση της σελίδας από τις μηχανές αναζήτησης, την εμφάνιση μιας καρτέλας για προσθήκη νέας ενότητας, και τον εμφανιζόμενο τίτλο.
  • Γλώσσες που εμφανίζει μια λίστα σελίδων σε άλλες γλώσσες που συνδέονται με αυτήν τη σελίδα.
  • Χρησιμοποιούμενα πρότυπα δείχνει μια λίστα συνδέσμων προς κάθε πρότυπο που χρησιμοποιείται σε αυτήν τη σελίδα.

Οι καρτέλες του διαλόγου Επιλογές εμφανίζονται επίσης στο μενού Επιλογές σελίδας και μπορούν να ανοίξουν κάνοντας κλικ σε αυτό. Επιπλέον, το μενού Επιλογές σελίδας περιέχει το κουμπί Προβολή ως δεξιά προς τα αριστερά και το κουμπί Εύρεση και αντικατάσταση που ανοίγει ένα παράθυρο διαλόγου όπου μπορείτε να εισαγάγετε χαρακτήρες, όρους ή regular expressions που αναζητάτε και αυτά που θα τα αντικαταστήσουν, μαζί με διάφορα κουμπιά για επιλογές.


VisualEditor bi-directional switching square brackets icon.png
Το κουμπί εναλλαγής σε επεξεργασία κώδικα είναι δίπλα στο κουμπί Δημοσίευση αλλαγών'. Επιτρέπει να αλλάξετε στον επεξεργαστή κώδικα wiki.

Δημοσίευση αλλαγών

Όταν έχετε τελειώσει την επεξεργασία, πατήστε στο μπλε κουμπί «Δημοσίευση αλλαγών» στη μπάρα εργαλείων. Αν δεν έχουν γίνει αλλαγές, το κουμπί θα είναι απενεργοποιημένο (γκριζαρισμένο). Για να ακυρώσετε όλες τις αλλαγές στην επεξεργασία σας, κλείστε το παράθυρο του φυλλομετρητή (browser) σας, ή πατήστε στην καρτέλα «Ανάγνωση» πάνω από τη μπάρα εργαλείων επεξεργασίας.
VisualEditor toolbar actions-el.png

Πατώντας το μπλε κουμπί «Δημοσίευση αλλαγών» ανοίγει ένας μικρός διάλογος. Μπορείτε να δώσετε σύντομη περιγραφή των ενεργειών σας, να σημάνετε την επεξεργασία σας ως μικρή, και να προσθέσετε τη σελίδα στην Λίστα παρακολούθησης σας. Το πλαίσιο για τη σύνοψη είναι το ισοδύναμο με το πεδίο Σύνοψη: στον επεξεργαστή κώδικα wiki.

Πριν αποθηκεύσετε τις αλλαγές σας, μπορείτε να επιθεωρήσετε τις αλλαγές σας χρησιμοποιώντας το κουμπί "Επανεξετάστε τις αλλαγές σας", για να σιγουρευτείτε ότι δουλεύουν όπως πρέπει. Αυτό είναι παρόμοιο με το κουμπί "Εμφάνιση αλλαγών" στον επεξεργαστή πηγαίου κώδικα.

Το κουμπί «Συνέχιση επεξεργασίας» σας επιστρέφει στην σελίδα που επεξεργάζεστε. Μπορείτε να δημοσιεύσετε όλες τις αλλαγές σας αργότερα.

VisualEditor save dialog-el.png

Επεξεργασία συνδέσμων

VisualEditor - Toolbar - Linking.png
Σύνδεσμοι μπορούν να προστίθενται μέσω του εικονιδίου "Σύνδεσμος" (αλυσίδα) στη μπάρα επεξεργασίας, ή χρησιμοποιώντας τη συντόμευση Ctrl+K (ή, σε Mac, την ⌘ Command+K).

Αν επιλέξετε (μαρκάρετε) κείμενο και πατήσετε το κουμπί "Σύνδεσμος", θα χρησιμοποιηθεί για τη δημιουργεία ενός συνδέσμου. Για σύνδεσμο που περιλαμβάνει μόνο μία λέξη, μπορείτε είτε να επιλέξετε εκείνη τη λέξη ή να τοποθετήσετε απλώς τον δείκτη εντός της λέξης.


VisualEditor-link tool-search results-el.png
Είτε χρησιμοποιήσετε το κουμπί είτε τη συντόμευση, θα ανοίξει ένας διάλογος στον οποίο μπορείτε να πληκτρολογήσετε τον σύνδεσμο.

Το εργαλείο συνδέσμων θα προσπαθήσει να βοηθήσει με εσωτερικούς συνδέσμους αναζητώντας για πιθανά ταιριάσματα. Όταν θα έχετε γράψει ή επιλέξει τον σύνδεσμο, ολοκληρώνετε την διαδικασία σύνδεσης με το να πατήσετε ↵ Enter, ή να πατήσετε το κουμπί "Έγινε". Ο σύνδεσμός σας τώρα θα εμφανίζεται στη σελίδα, αλλά όπως και με άλλες αλλαγές στην σελίδα, δεν θα έχει δημοσιευτεί μέχρι να δημοσιεύσετε ολόκληρη τη σελίδα.


VisualEditor-link tool-external link-el.png
Η διαδικασία για να εισάγετε σύνδεσμο προς σελίδα σε άλλο ιστότοπο είναι παρόμοια: Επιλέξτε την καρτέλα «Εξωτερικός ιστότοπος», και βάλτε το URL στο πεδίο.

VisualEditor link tool simple link-el.png
Εξωτερικοί σύνδεσμοι χωρίς τίτλους φαίνονται κάπως έτσι: [1]. Μπορείτε να προσθέσετε αυτούς τοποθετώντας τον κέρσορα έξω από οποιαδήποτε λέξη (π.χ. μετά από ένα διάστημα). Ανοίξτε το εργαλείο συνδέσμων πατώντας στο κουμπί ή πατώντας τα πλήκτρα συντόμευσης. Πληκτρολογήστε τη διεύθυνση (URL) στο κουτί, και πατήστε το κουμπί "Έγινε" για να εισαγάγετε τον σύνδεσμο.

VisualEditor-context menu-link tool-el.png
Για να αλλάξετε ή να αφαιρέσετε ένα υπάρχοντα σύνδεσμο, πατήστε στο κείμενο για αυτό το σύνδεσμο, μετά πατήστε το εικονίδιο "Σύνδεσμος" που εμφανίζεται κοντά του. Ο διάλογος θα εμφανιστεί, για επεξεργασία. (Μπορείτε επίσης να εμφανίσετε το διάλογο με τη συντόμευση πληκτρολογίου Ctrl+K.) Όταν ένας σύνδεσμος είναι επιλεγμένος, εμφανίζεται σε μπλε πλαίσιο.

Στον διάλογο επεξεργασίας συνδέσμου, μπορείτε μετά να αλλάξετε τον στόχο του συνδέσμου. Μπορείτε επίσης να αφαιρέσετε εντελώς τον σύνδεσμο, πατώντας το κουμπί "Αφαίρεση" στην πάνω δεξιά γωνία του διαλόγου. Μπορείτε επίσης να ανοίξετε τον στόχο του συνδέσμου σε άλλο παράθυρο, πατώντας στο αντίγραφο του συνδέσμου στο πλαίσιο διαλόγου. (Ίσως θέλετε να το κάνετε αυτό για να βεβαιωθείτε ότι ο εξωτερικός σύνδεσμος είναι σωστός).

Αν θέλετε να βγείτε από την ετικέτα συνδέσμου (το κείμενο εμφανίζεται ως σύνδεσμος) ή να συνεχίσετε να γράφετε μετά από αυτό το σύνδεσμο, μπορείτε να πατήσετε :

  • Πατώντας το μια φορά θα σας βγάλει από τον διάλογο επεξεργασίας συνδέσμου και θα βάλει τον κέρσορά σας στο τέλος του συνδεδεμένου στοιχείου (με μπλε πλαίσιο, για επεξεργασία του στοιχείου)
  • Πατώντας το δυο φορές θα σας θα τοποθετήσει τον δρομέα σας μετά το συνδεδεμένο στοιχείο, έτοιμο για να γράψετε το υπόλοιπο κείμενό σας

Για να επεξεργαστείτε την ετικέτα συνδέσμου ενός υπάρχοντος συνδέσμου, πατήστε μέσα στην ετικέτα συνδέσμου και γράψτε μια νέα. Αλλά αν θέλετε να αντικαταστήσετε ολόκληρη την ετικέτα, παρακαλούμε λάβετε υπόψη:

  • Αν έχετε επιλέξει (επισημάνατε) ολόκληρη την ετικέτα συνδέσμου, ο σύνδεσμος θα διαγραφεί πατώντας οποιοδήποτε πλήκτρο. Μπορείτε να το ξανασυνδέσετε από την αρχή.
  • Για να διατηρήσετε άμεσα το σύνδεσμο, μπορείτε να πατήσετε μέσα στην ετικέτα συνδέσμου, να χρησιμοποιήσετε τα πλήκτρα διαγραφής χωρίς να τα πατήσετε πέρα από όσο είναι απαραίτητο, και μια στενή μπλε περιοχή συνδέσμου θα παραμείνει εκεί. Τώρα μπορείτε να πληκτρολογήσετε μια νέα ετικέτα για τον διατηρηθέντα σύνδεσμο.
  • Μπορείτε επίσης να συνδέσετε σε κατηγορίες, αρχεία και περισσότερα.

Επεξεργασία παραπομπών

For further information, see Βοήθεια στη χρήση προτύπων παραπομπών ή Βοήθεια για τη χρήση του κουμπιού Παραπομπή του citoid

Διαπιστώνοντας ποιο σύστημα ισχύει

Το wiki σας μπορεί να χρησιμοποιεί ένα από τρία συστήματα υποσημειώσεων. Αυτό που φαίνεται δεξιά είναι το απλούστερο σύστημα, όπου το μενού "Παραπομπή" δεν περιλαμβάνει πρότυπα παραπομπών. Αν το wiki σας χρησιμοποιεί αυτό το σύστημα, τότε όλα όσα χρειάζεται να γνωρίζετε για υποσημειώσεις είναι σε αυτή τη σελίδα.
VisualEditor cite menu default.png

Το δεύτερο σύστημα έχει τον ίδιο τύπο μενού "Παραπομπή", αλλά με διάφορα δημοφιλή πρότυπα παραπομπών για γρήγορη πρόσβαση. Αν το wiki σας χρησιμοποιεί αυτό το σύστημα, τότε θα βρείτε περισσότερες πληροφορίες στο Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button-el.png
Στο τρίτο σύστημα, μπορείτε να ξεκινήσετε ξανά πατώντας στο κουμπί Παραπομπή. Τότε ανοίγει το πλαίσιο διαλόγου, που περιλαμβάνει τη διαδικασία αυτόματης παραπομπής με τη χρήση της υπηρεσίας citoid. Αν το wiki σας χρησιμοποιεί αυτό το σύστημα, θα βρείτε περισσότερες πληροφορίες στο Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-el.png

Διόρθωση υπάρχουσας παραπομπής

Για να διορθώσετε μια υπάρχουσα παραπομπή, πατήστε την στο σημείο που αυτή βρίσκεται στο κείμενο (συνήθως ως αριθμός σε αγκύλες). Θα δείτε είτε ένα εικονίδιο "Παραπομπή" (σελιδοδείκτη) ή ένα εικονίδιο (και όνομα) προτύπου το οποίο είχε χρησιμοποιηθεί για να δημιουργηθεί αυτή η παραπομπή. Σε οποιαδήποτε περίπτωση, πατώντας στο εικονίδιο "Επεξεργασία" θα ανοίξει ένας διάλογος που σας επιτρέπει να επεξεργαστείτε την παραπομπή.
VisualEditor - Editing references 1-el.png

Για το εικονίδιο "Παραπομπή", πατώντας "Επεξεργασία" ανοίγει ο διάλογος Παραπομπή. Για να αρχίσετε να αλλάζετε τις πληροφορίες παραπομπές, πατήστε επάνω του.

Πολλά wiki χρησιμοποιούν πρότυπα για να μορφοποιούν τις παραπομπές. Αν ένα πρότυπο χρησιμοποιείται στην παραπομπή σας, τότε όταν μετακινείτε τον δείκτη σας πάνω από τις πληροφορίες παραπομπής, όλες οι πληροφορίες σε εκείνο το πεδίο θα επισημανθούν.

Αν έχει χρησιμοποιηθεί πρότυπο και πατήσετε πάνω στις πληροφορίες παραπομπής, θα εμφανιστεί το εικονίδιο Πρότυπο (κομμάτι παζλ) με κάποιες πληροφορίες. Πατήστε το κουμπί "επεξεργασία" για να επεξεργαστείτε το περιεχόμενο του προτύπου στον μίνι επεξεργαστή προτύπων.

VisualEditor - Editing references 6-el.png

Αν αυτό που εμφανίζεται όταν πατήσετε στην παραπομπή είναι ένα από τα διάφορα εικονίδια προτύπων για παραπομπές (ένα παράδειγμα είναι δεξιά), τότε πατώντας "επεξεργασία" θα ανοίξει ο διάλογος μίνι επεξεργαστή προτύπων.
VisualEditor - Editing References - Cite Web.png

Μέσα στον μίνι-επεξεργαστή προτύπων, μπορείτε να προσθέσετε ή να αφαιρέσετε περιεχόμενο σε παραμέτρους που έχουν ήδη χρησιμοποιηθεί ή να προσθέσετε καινούριες παραμέτρους. Μόνο οι παράμετροι που έχουν περιεχόμενο θα εμφανιστούν, αρχικά. Για να προσθέσετε παραμέτρους, πατήστε το κουμπί "Προσθήκη περισσότερων πληροφοριών" στη βάση του παραθύρου του μίνι επεξεργαστή.
VisualEditor - Editing references 5-el.png

Πατήστε το "Εφαρμογή αλλαγών" όταν έχετε τελειώσει.
VisualEditor Apply Changes-el.png

Επαναχρησιμοποίηση υπάρχουσας παραπομπής

Αν η σελίδα περιέχει μια παραπομπή που ισχύει για το περιεχόμενο όπου θέλετε να βάλετε πηγή, τότε μπορείτε να επιλέξετε να επαναχρησιμοποιήσετε εκείνη την υπάρχουσα παραπομπή.

Για να επαναχρησιμοποιήσετε μια υπάρχουσα παραπομπή, τοποθετήστε τον δείκτη στο σημείο του κειμένου όπου θέλετε να την εισάγετε. Μετά πατήστε στο αντικείμενο «Εναχρησιμοποίηση παραπομπής» από το μενού «Παραπομπή».

(Σημείωση: Αν το wiki σας έχει το τρίτο σύστημα υποσημειώσεων που περιγράφεται παραπάνω, θα δείτε μια καρτέλα "Επαναχρησιμοποίηση", σε ένα διάλογο, αντί του αντικειμένου "Επαναχρησιμοποίηση" στο μενού "Παραπομπή".)

VisualEditor Cite menu re-use.png

Στον διάλογο Παραπομπή, βρείτε από τη λίστα την παραπομπή που θέλετε να επαναχρησιμοποιήσετε και επιλέξτε την. Αν υπάρχουν πολλές παραπομπές, μπορείτε να χρησιμοποιήσετε το πλαίσιο αναζήτησης (με ετικέτα «Αναζήτηση εντός των τρεχουσών παραπομπών») έτσι ώστε να απεικονιστούν μόνο οι παραπομπές που περιλαμβάνουν συγκεκριμένο κείμενο.
VisualEditor - Editing references 18-el.png

Προσθήκη νέας παραπομπής

Για να προσθέσετε παραπομπή χρησιμοποιώντας το μενού «Παραπομπή», τοποθετήστε τον κέρσορα εκεί που θέλετε να την προσθέσετε στο κείμενο. Μετά επιλέξτε τον κατάλληλο τύπο παραπομπής από το μενού.
VisualEditor references more.png

Χρήση της επιλογής "Βασικό" για παραπομπές

Εδώ εμφανίζεται αυτό που θα δείτε αν επιλέξετε το αντικείμενο βασικών παραπομπών. Στον επεξεργαστή παραπομπών, μπορείτε να προσθέσετε την παραπομπή σας μαζί με τη μορφοποίηση.

Μπορείτε να εντάξετε την παραπομπή σε κάποια ομάδα, αν και συνήθως αυτό το πεδίο παραμένει κενό.(Αυτή η δυνατότητα χρησιμεύει στην εμφάνιση ομάδων παραπομπών μέσω του εργαλείου "Κατάλογος παραπομπών".)

VisualEditor - Editing references 20-el.png

Στον διάλογο Παραπομπή, αν θελήσετε να περιλάβετε κάποιο πρότυπο παραπομπών, ή οποιοδήποτε άλλο πρότυπο, στη νέα παραπομπή σας πατήστε στο εικονίδιο Πρότυπο (κομμάτι παζλ) στο μενού "Εισαγωγή" της μπάρας εργαλείων του επεξεργαστή παραπομπών.
VisualEditor Template Insert Menu-el.png

Έπειτα, αναζητήστε το πρότυπο που θέλετε να χρησιμοποιήσετε, προσθέστε το και επεξεργαστείτε το όπως θα κάνατε με οποιοδήποτε άλλο πρότυπο. (Δείτε την ενότητα Επεξεργασία προτύπων, παρακάτω, αν χρειάζεστε πληροφορίες για τα πρότυπα.)

Αφού έχετε τελειώσει την επεξεργασία του νέου προτύπου, πατήστε το "Εφαρμογή αλλαγών" για να επιστρέψετε στον επεξεργαστή Παραπομπών και πατήστε ξανά το "Εφαρμογή αλλαγών" για να επιστρέψετε στη σελίδα που επεξεργάζεστε.

VisualEditor - Editing references 9-el.png

Αν δεν προϋπάρχει κατάλογος παραπομπών στη σελίδα (αυτό συμβαίνει π.χ. αν εισάγετε την πρώτη παραπομπή της σελίδας), τότε, προκειμενου να εμφανιστούν οι παραπομπές, θα ορίσετε εδώ σε ποιό σημείο της σελίδας θα εμφανιστεί αυτός ο κατάλογος.

Τοποθετήστε τον δείκτη εκεί που θέλετε να εμφανίζεται ο κατάλογος παραπομπών (συνήθως στο τέλος της σελίδας), ανοίξτε το μενού "Εισαγωγή" και πατήστε το εικονίδιο "Κατάλογος παραπομπών" (τρία βιβλία).

VisualEditor References List Insert Menu-el.png

Αν χρησιμοποιείτε διάφορες ομάδες παραπομπών, κάτι που είναι σχετικά σπάνιο, μπορείτε να ορίσετε μια ομάδα σε αυτό το διάλογο. Μόνο οι παραπομπές που ανήκουν σε αυτή την ομάδα θα εμφανίζονται στη σελίδα στην θέση όπου τοποθετείτε την ομάδα.

Το τελικό βήμα στον διάλογο καταλόγου παραπομπών είναι να πατήσετε στο "Εισαγωγή".

VisualEditor references list-el.png

Χρήση τυπικών προτύπων παραπομπών

Το τοπικό wiki σας μπορεί να έχει προσθέσει επιπλέον πρότυπα παραπομπών στο μενού "Παραπομπή". Αν είναι έτσι, έχετε γρήγορη πρόσβαση σε μερικά από τα περισσότερο χρήσιμα πρότυπα παραπομπών στο wiki σας. (Οδηγίες για την προσθήκη επιπλέον προτύπων παραπομπών στο τοπικό σας wiki είναι διαθέσιμες στην VisualEditor/Citation tool .)
VisualEditor - Editing References - Cite Pulldown.png

Πατώντας ένα εικονίδιο προτύπου, όπως το "Cite book", θα οδηγηθείτε στον μίνι-επεξεργαστή για το πρότυπο που έχετε επιλέξει. Οι σημαντικές παράμετροι είναι μαρκαρισμένες με αστερίσκο. Αν και θα εμφανιστούν οι περισσότερο συνηθισμένες παράμετροι, δεν απαιτούνται όλες.
VisualEditor - Editing references - Cite book required fields.png

Για να προσθέσετε πρόσθετες παραμέτρους, κυλήστε κάτω στον μίνι-επεξεργαστή προτύπων και πατήστε στην επιλογή "Προσθήκη περισσότερων πληροφοριών".

Πατήστε στο "Εισαγωγή" όταν έχετε τελειώσει.

VisualEditor - Editing references - Add parameter.png

Επεξεργασία εικόνων και άλλων αρχείων πολυμέσων

Επεξεργασία εικόνων

Για να προσθέσετε νέα εικόνα (ή άλλο τύπο αρχείου πολυμέσων) στη σελίδα, πατήστε στο εικονίδιο "Εικόνες και πολυμέσα" (εικόνα με βουνά) στο αναδυόμενο μενού "Εισαγωγή". Η εικόνα θα προστεθεί εκεί όπου βρίσκεται ο δρομέας.
VisualEditor Media Insert Menu-el.png

Πατώντας στο εικονίδιο "Εικόνες και πολυμέσα" ανοίγει ένας διαλόγος,ο οποίος κάνει αυτόματα αναζήτηση στα Wikimedia Commons και το τοπικό wiki για αρχεία πολυμέσων σχετιζόμενα με τη σελίδα που επεξεργάζεστε.

Μπορείτε να ψάξετε για άλλα αρχεία πολυμέσων αλλάζοντας το κείμενο στο κουτί αναζήτησης του διαλόγου.

Για να επιλέξετε ένα αρχείο πατήστε στη μικρογραφία του.

Αυτή η ενέργεια τοποθετεί την εικόνα στη σελίδα που επεξεργάζεστε.

VisualEditor - Media editing 2-el.png

Αφού η εικόνα που επιλέξατε εισαχθεί στην σελίδα, θα ανοίξει ένας άλλος διάλογος. Αυτός ο διάλογος σας επιτρέπει να προσθέσετε ή διορθώσετε την λεζάντα της εικόνας. Η λεζάντα μπορεί να περιέχει μορφοποίηση και συνδέσμους.
VisualEditor - Media editing 6-el.png

Ο διάλογος πολυμέσων σας επιτρέπει επίσης να προσθέσετε εναλλακτικές λεζάντες, οι οποίες βοηθούν χρήστες που χρησιμοποιούν αναγνώστες οθόνης, ή που έχουν απενεργοποιημένη την εμφάνιση εικόνων.
VisualEditor - Media editing 7.png

Μπορείτε επίσης να ορίσετε διάφορες παραμέτρους για την εικόνα, στο παράθυρο "Ρυθμίσεις για προχωρημένους". Αυτές περιλαμβάνουν τη στοίχιση, τον τύπο και το μέγεθός της.
VisualEditor - Media editing 8-el.png

Όταν τελειώσετε, πατήστε το "Εφαρμογή αλλαγών" για να κλείσετε τον διάλογο και να επιστρέψετε στον επεξεργαστή σελίδας.
VisualEditor Apply Changes-el.png

Σε υπάρχουσα εικόνα, μπορείτε να προσθέσετε ή να επεξεργαστείτε τη λεζάντα ή άλλες ρυθμίσεις αν πατήσετε στην εικόνα και έπειτα πατήσετε στο εικονίδιο "Εικόνες και πολυμέσα" που εμφανίζεται πιο κάτω από την εικόνα.

Μπορείτε να αλλάξετε το μέγεθος υπάρχουσας εικόνας πατώντας σε αυτή και κινώντας το εικονίδιο αλλαγής μεγέθους (το βέλος με τις δύο αιχμές σε μια ή και τις δυο κάτω γωνίες).

Μπορείτε επίσης να σύρετε και να αφήσετε μια εικόνα σε οποιοδήποτε θέση, κάτω ή πάνω, στη σελίδα.

VisualEditor - Media editing 3-el.png

Ανέβασμα εικόνων

Μπορείτε να ανεβάσετε εικόνες από μια καρτέλα στο διάλογο πολυμέσων, ή σέρνοντας και αφήνοντας ένα αρχείο στον επεξεργαστή, ή επικολλώντας μια εικόνα από το clipboard σας.
VisualEditor - Media upload 1.png

Πατήστε την καρτέλα "Επιφόρτωση" και επιλέξτε μια εικόνα από τον υπολογιστή σας. Μπορείτε να γράψετε το όνομα αρχείου ή να τραβήξετε μια εικόνα στο πλαίσιο. Αν τραβήξατε και ρίξατε μια εικόνα απευθείας στον επεξεργαστή, ή επικολλήσατε μια από το πρόχειρό σας, αυτή η ετικέτα θα ανοίξει αυτόματα.
VisualEditor - Media upload 1.5.png

Χρειάζετε να περιγράψετε την εικόνα και να προσθέσετε κατηγορίες ώστε να μπορούν να τη βρουν και άλλοι άνθρωποι.
VisualEditor - Media upload 2.png

Η εικόνα θα εισαχθεί στη σελίδα όταν τελειώσετε.
VisualEditor-logo.svg

Επεξεργασία πινακοθηκών

Για να προσθέσετε νέα πινακοθήκη, πατήστε στο εικονίδιο "Γκαλερί" (ένα σύνολο φωτογραφιών) στο μενού "Εισαγωγή" (αν δεν βλέπετε αυτό το εικονίδιο, τότε το wiki σας έχει αποφασίσει να καθυστερήσει την υλοποίηση αυτής της λειτουργίας στον οπτικό επεξεργαστή).
VisualEditor - Gallery1.png

Για να επεξεργαστείτε μια υπάρχουσα πινακοθήκη στον οπτικό επεξεργαστή, πατήστε σε αυτή την πινακοθήκη. Μετά, κοντά στη βάση της πινακοθήκης, πατήστε στο εικονίδιο πινακοθήκης (ένα σετ εικόνων). Θα εμφανιστεί ο επεξεργαστής πινακοθήκης με την πλήρη λίστα εικόνων που περιλαμβάνονται στην πινακοθήκη.
VisualEditor - Gallery2.png
O επεξεργαστήw πινακοθήκης, επί του παρόντος, είναι ένα απλό κουτί που δουλεύει παρόμοια με τη σήμανση κώδικα wiki. Για να προσθέσετε εικόνες σε υπάρχουσα πινακοθήκη, πληκτρολογήστε το όνομα του αρχείου, ακολουθούμενο από μια κάθετη (|) και την λεζάντα που θα θέλατε για την εικόνα. Κάθε εικόνα στην πινακοθήκη θα πρέπει να έχει την δική της γραμμή. Μπορείτε επίσης να επεξεργαστείτε αυτή τη λίστα για να αφαιρέσετε ή να αναδιατάξετε εικόνες ή να τροποποιήσετε λεζάντες.

Όταν πατάτε το κουμπί «Έγινε», βγαίνετε από τον επεξεργαστή πινακοθήκης. Τότε θα δείτε τις αλλαγές καθώς η πινακοθήκη θα απεικονίζεται με τον ίδιο τρόπο που θα τη βλέπουν οι αναγνώστες.

Να θυμάστε ότι βγαίνοντας από τον επεξεργαστή πινακοθήκης δεν δημοσιεύονται οι αλλαγές σας. Όπως και με άλλες αλλαγές που γίνονται με τον οπτικό επεξεργαστή, πρέπει να δημοσιεύσετε ολόκληρη τη σελίδα προκειμένου να δημοσιευτεί η εργασία σας.

VisualEditor - Gallery3.png

Επεξεργασία προτύπων

The powerful MediaWiki template system lets you insert dynamic content, text from other pages, and much more. For a detailed explanation and examples, see the Templates help page.

In the VisualEditor you can search for a relevant template, add an invocation or transclusion on the page you’re editing and, if needed, add custom content using parameters.

Insert new template

Για να προσθέσετε ένα νέο πρότυπο στη σελίδα, τοποθετήστε τον δείκτη στο σημείο όπου επιθυμείτε να εισάγετε το πρότυπο, και πατήστε το εικονίδιο "$template" (κομμάτι παζλ) στο μενού "$insert" Then open the Εισαγωγή menu and select "OOjs UI icon puzzle-ltr.svg Πρότυπο". Alternatively, type two curly brackets {{ to open the same dialog.
VisualEditor Template Insert Menu-el.png
Ξεκινήστε γράφοντας το όνομα του προτύπου που επιθυμείτε να προσθέσετε. Όταν το δείτε στην λίστα πατήστε στο όνομά του. Μετά πατήστε στο "Προσθήκη προτύπου".
Screenshot of the template search field in the Visual Editor

Μπορείτε επίσης να επεξεργαστείτε ένα πρότυπο που βρίσκεται ήδη στη σελίδα. Όταν πατάτε πάνω σε ένα πρότυπο για να το επιλέξετε, γίνεται μπλε, και εμφανίζεται ένα πλαίσιο με εικονίδιο "$template" (κομμάτι παζλ). Μετά πατήστε στο σύνδεσμο "$edit". When you select the template you want to edit, it turns blue, and a box appears displaying "OOjs UI icon puzzle-ltr.svg Πρότυπο". Then select the "Επεξεργασία" link or double click on the template itself to open the template.
Screenshot of the VisualEditor interface with a template selected

Ορισμένα πρότυπα δεν είναι ορατά όταν κάποιος διαβάζει μια σελίδα. Στον οπτικό επεξεργαστή, τέτοια κρυμμένα πρότυπα εμφανίζονται ως εικονίδια παζλ. Το όνομα του προτύπου θα εμφανίζεται δίπλα από το εικονίδιο παζλ.
Screenshot of hidden templates in the Visual Editor interface

Παράμετροι προτύπων

You’ll see this dialog box when you’re adding a new template or editing one already in place. What you see in the box depends on whether the template in question contains TemplateData , helpful metadata added by other editors to make it easier to edit templates in the Visual Editor.

When a template contains TemplateData, the VisualEditor can use it to present annotated fields for you to fill in.


For templates that have some community-provided TemplateData, the VisualEditor displays a list of the named parameters and, often, descriptions and instructions explaining the meaning and required format for each parameter’s values.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

Για ένα υπάρχον πρότυπο, μπορείτε να επεξεργαστείτε τις παραμέτρους που εμφανίζονται ήδη στο διάλογο, και μπορείτε να προσθέσετε παραμέτρους πατώντας στην επιλογή "Προσθήκη περισσότερων πληροφοριών", στο κάτω μέρος του διαλόγου.
Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Adding undocumented parameters

If you’re inserting or editing a template whose author hasn’t laid out its parameters in TemplateData, it has what we call “undocumented” or “unnamed parameters”. In these cases, you should consult the page for the template itself. There you can learn how to correctly employ and work with all of the template’s parameters. This includes learning the exact names of the parameters as written by the template author.

If you find in the documentation that the template expects parameters without have names, fill in numbers as placeholders for the parameter names using the undocumented parameter input, then add next to the values you want to provide as you normally would.

Example: * first unnamed parameter: “1” * first unnamed parameter’s value: “en_US” * second unnamed parameter: “2” * second unnamed parameter’s value: “yes”

If you accidentally include nonexistent, misspelled or erroneous parameters, the values you enter for those parameters won’t show up on the page you’re editing.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerated parameters

In this example, the template in question lacks TemplateData but it was possible to autogenerate the parameters. This means that the undocumented parameters have already been added for you, but the names may not be easily understandable and the dialog cannot display any directions or descriptions. As a result the dialog box provides a link to the template’s documentation, which should help you deduce and fill in the template’s various parameters.
Autogenerated parameters in the VisualEditor.png

Editing multi-part template content

During editing, you may open template content consisting of multiple templates or a single template linked to some wikitext. This differs from the nested templates described below. In this case, the templates are better visualized as being stacked or connected.

This content often contains “unbalanced templates,” templates which are incomplete on their own and need to be paired with some wikitext or another template in order to function.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Nested templates

Templates can include other templates as the value for parameters. You’ll recognize it when you see a parameter whose value contains the double curly braces ( {{ }} ) denoting a template.

The VisualEditor can’t present this template within a template (a nested template) using the editor’s easy-to-use interface, so if you want to nest a template yourself, you’ll need to understand how to add the template by hand in wikitext into the appropriate parameter field.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Completing your edit

Όταν έχετε τελειώσει με την επεξεργασία ενός προτύπου, πατήστε "Εφαρμογή αλλαγών" για να κλείσετε τον διάλογο και να επιστρέψετε στην επεξεργασία της κύριας σελίδας. Then you can preview your edit and make sure it looks the way you want and expect.

You may also see an error message, which (like the other TemplateData mentioned above) is community-provided content and may vary in usefulness. You may need to consult the template’s own documentation to get to the bottom of some errors. If you’re still having trouble, consider posting about your problem on the template’s talk page.

VisualEditor Apply Changes-el.png

Editing on mobile

When editing a template on a page using the VisualEditor on a mobile device, you’ll see that the sidebar starts out hidden. You can make it visible by pressing the “Show/hide options” button.
Screenshot of editing a template on a mobile device
Editing a template on mobile in the VisualEditor

Υποκατάσταση προτύπων

When you insert a template in a wiki page, its content and appearance are reevaluated every time the page loads, based on the template code and the values of its parameters. This means if someone updates the code of a template, then every page which uses that template will also get updated when they publish.

There’s another, much less common way to use templates, though, and that’s to substitute a template. Doing this permanently includes the template content just as it appears at the moment you insert it. It will not update if the template code is later changed.

Most users won’t ever need to resort to substitution. Substitution is typically only useful when you need to capture the exact appearance of one version of a template, such as when content is under development and needs evaluation.

To substitute a template in the VisualEditor, insert a template using the name syntax subst:<template name>. (Autocomplete doesn’t work in this case.) Then press the blue “Add template” button.

When you’re finished, press “Insert”, which will insert the template content as you see it.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Επεξεργασία καταλόγων

VisualEditor Toolbar Lists and indentation-el.png
Μπορείτε να χρησιμοποιήσετε τον οπτικό επεξεργαστή για να δημιουργήσετε καταλόγους/λίστες, ή να αλλάξετε τη μορφή μιας υπάρχουσας λίστας. Υπάρχουν δυο τύποι από λίστες: μη ταξινομημένες (κουκκίδες) και ταξινομημένες (αριθμημένες).

Για να ξεκινήσετε μια νέα λίστα, απλώς πατήστε σε ένα από τα δυο αντικείμενα μενού που εμφανίζονται εδώ. Ή, αν έχετε ήδη πληκτρολογήσει την λίστα (σε ξεχωριστές γραμμές), επιλέξτε (μαρκάρετε) τη λίστα που πληκτρολογήσατε, μετά πατήστε σε ένα από τα αντικείμενα του μενού.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Εμφανίζονται εδώ παραδείγματα από τα δύο είδη λιστών: αταξινόμητες (κουκκίδες) και ταξινομημένες (αριθμημένες).

VisualEditor lists 3 select to indent.png
Αν θέλετε να αλλάξετε το επίπεδο εσοχής ενός μέρους μιας υπάρχουσας λίστας, επιλέξτε εκείνο το μέρος της λίστας που θέλετε να αλλάξετε.

VisualEditor lists 4 indentation menu.png
Έπειτα χρησιμοποιήστε το μενού, ή πατήστε το πλήκτρο Tab. (Το πλήκτρο Tab αυξάνει την εσοχή. Χρησιμοποιήστε το πλήκτρο shift και Tab για να μειώσετε την εσοχή)

VisualEditor lists after indenting.png
Αυτό είναι το αποτέλεσμα αυξημένης εσοχής.

VisualEditor lists mixed.png
Μπορείτε ακόμη και να αναμείξετε ταξινομημένες (αριθμημένες) και αταξινόμητες (με κουκκίδες) λίστες, αν τα αντικείμενα της λίστας είναι σε διαφορετικές εσοχές.

Επεξεργασία πινάκων

VisualEditor insert table-el.png
Μπορείτε να χρησιμοποιήσετε τον VisualEditor για να εισάγετε και τροποποιείτε πίνακες.

Μπορείτε ακόμη και να εισαγάγετε ένα πίνακα τραβώντας ένα αρχείο με τιμές διαχωρισμένες με κόμμα (.csv) από τον υπολογιστή σας στο κύριο παράθυρο επεξεργασίας.


Όταν πατήσετε στο «Πίνακας», στο μενού «Εισαγωγή», ο οπτικός επεξεργαστής εισάγει ένα κενό πίνακα τέσσερα επί τέσσερα.

Το μενού "Πίνακας" είναι τώρα διαθέσιμο. Από αυτό το μενού, μπορείτε να προσθέστε τη λεζάντα στην κορυφή του πίνακα.

VisualEditor empty table.png

Για να επιλέξετε ένα κελί, πατήστε το μια φορά.
VisualEditor tables select one cell.png

Για να επεξεργαστείτε τα περιεχόμενα του κελιού (για παράδειγμα, για να προσθέστε περιεχόμενο ή να διορθώσετε ένα ορθογραφικό σφάλμα), διπλοπατήστε στο κελί. Ή μπορείτε να επιλέξετε το κελί και να πατήσετε Enter.

Για να τελειώσετε την επεξεργασία ενός κελιού, απλώς πατήστε κάπου αλλού.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns-el.png
Μπορείτε να προσθέσετε, μετακινήσετε ή αφαιρέσετε μια στήλη ή μια γραμμή.

Μπορείτε να συγχωνεύσετε κελιά: Επιλέξτε τα και μετά, από το μενού Πίνακας, πατήστε στο "Συγχώνευση κελιών".
VisualEditor tables merge cells.png

Αν συγχωνεύσετε κελιά, μόνο το κείμενο ενός κελιού θα διατηρηθεί. Οποιοδήποτε κείμενο σε άλλα κελιά θα διαγραφεί όταν συγχωνεύσετε τα κελιά. Αν αποφασίσετε ότι θέλατε κάποιο ή όλο το κείμενο που διαγράφηκε, χρησιμοποιήστε το κουμπί Αναίρεση, μετακινείστε ή αντιγράψτε το κείμενο που θέλετε, μετά συγχωνεύστε ξανά τα κελιά.
VisualEditor tables post-merge cell.png

Μπορείτε επίσης να διαχωρίσετε κελιά που προηγουμένως συγχωνεύσατε. Όλο το περιεχόμενο που βρισκόταν στο συγχωνευμένο κελί θα παραμείνει στο πρώτο κελί όταν κάνετε τον διαχωρισμό. Μπορείτε μετά να κάνετε αποκοπή και επικόλληση κειμένου σε άλλα κελιά, αν το θέλετε.
VisualEditor tables split cells.png

Επεξεργασία κατηγοριών

VisualEditor category item-el.png
Για να επεξεργαστείτε κατηγορίες, στο μενού "Επιλογές σελίδας", πατήστε στο αντικείμενο "Κατηγορίες".

VisualEditor category editing-el.png
Πατώντας στο "Κατηγορίες" ανοίγει διάλογος ο οποίος εμφανίζει τις υπάρχουσες κατηγορίες και επιτρέπει την προσθήκη νέων, και τη διαγραφεί υπαρχουσών κατηγοριών.

Έχετε επίσης την επιλογή της ρύθμισης ή την αλλαγής του γενικού (προεπιλογή) κλειδιού, το οποίο προσδιορίζει το που θα εμφανίζεται η σελίδα όταν θα είναι σε κατάλογο με άλλες σελίδες στην ίδια κατηγορία.

Για παράδειγμα, το προκαθορισμένο κλειδί ταξινόμησης για το λήμμα "Γεώργιος Σεφέρης" είναι το "Σεφέρης, Γεώργιος". Στην κατηγορία "Έλληνες ποιητές" το λήμμα αναφέρεται κάτω από το γράμμα "Σ" και όχι το "Γ".


VisualEditor - Category editing 3-el.png
Για να προσθέσετε μια νέα κατηγορία, γράψτε το όνομά της στο πεδίο «Προσθήκη κατηγορίας». Καθώς γράφετε, ο οπτικός επεξεργαστής θα ψάξει για πιθανές κατηγορίες που ταιριάζουν, από αυτές που υπάρχουν. Μπορείτε είτε να επιλέξετε μια ήδη υπάρχουσα κατηγορία ή να προσθέσετε μια κατηγορία που δεν έχει ακόμη δική της σελίδα κατηγορίας. (Μέχρι να δημιουργηθεί η σχετική σελίδα, η νέα κατηγορία θα απεικονίζεται ως κόκκινος σύνδεσμος μετά που θα δημοσιεύσετε τις αλλαγές σας).

VisualEditor - Category editing 2-el.png
Για να αφαιρέσετε μια υπάρχουσα κατηγορία, πατήστε επάνω της και μετά πατήστε στο εικονίδιο "Αφαίρεση" (κάδος απορριμάτων) στο μενού διαλόγου που ανοίγει.

Πατώντας στην κατηγορία σας επιτρέπει επίσης να ορίσετε το κλειδί ταξινόμησης για αυτή τη συγκεκριμένη κατηγορίας. Αυτό το κλειδί ταξινόμησης παρακάμπτει το γενικό κλειδί ταξινόμησης.


VisualEditor Apply Changes-el.png
Πατήστε στο "Εφαρμογή αλλαγών" όταν τελειώσετε την επεξεργασία των κατηγοριών, για να επιστρέψετε στον επεξεργαστή σελίδας.

Επεξεργασία ρυθμίσεων σελίδας

VisualEditor page settings item-el.png
Για να επεξεργαστείτε τις ρυθμίσεις μιας σελίδας, πατήστε για να ανοίξετε το μενού "Επιλογές σελίδας", στην μπάρα επεξεργασίας, και επιλέξτε το κουμπί "Ρυθμίσεις σελίδας".

VisualEditor Page Settings-el.png
Το κουμπί "Ρυθμίσεις σελίδας" ανοίγει ένα διάλογο που εμφανίζει διάφορες επιλογές.

VisualEditor Page Settings Redirects-el.png
Μπορείτε να κάνετε μια σελίδα να ανακατευθύνει σε μια άλλη σελίδα τσεκάροντας το κουτάκι "Ανακατεύθυνση αυτής της σελίδας σε", και έπειτα γράφοντας εκεί το όνομα της σελίδας στην οποία θέλετε να οδηγήσετε τον αναγνώστη που προσπαθεί να πάει στη σελίδα που επεξεργάζεστε.

Στο κάτω μέρος βρίσκεται η επιλογή με την οποία προλαμβάνεται η ενημέρωση αυτής της ανακατεύθυνσης, όταν μετονομάζεται η σχετική σελίδα. Αυτή η επιλογή χρησιμοποιείται εξαιρετικά σπάνια.


VisualEditor Page Settings TOC-el.png
Μπορείτε να επιλέξετε το αν η σελίδα εμφανίζει Πίνακα Περιεχομένων, επιλέγοντας ένα από τα τρία αυτά κουμπιά. Η προεπιλεγμένη επιλογή είναι "Εάν χρειάζεται", που εμφανίζει ένα πίνακα περιεχομένων αν υπάρχουν τρεις ή περισσότερες επικεφαλίδες.

VisualEditor Page Settings Edit Links-el.png
Τσεκάροντας αυτό το κουτάκι, μπορείτε να κάνετε μια σελίδα να μην δείχνει συνδέσμους επεξεργασίας δίπλα από την επικεφαλίδα κάθε ενότητας.

VisualEditor Apply Changes-el.png
Πατήστε στο "Εφαρμογή αλλαγών" όταν τελειώσετε την επεξεργασία στο Επιλογές σελίδας για να επιστρέψετε στον επεξεργαστή σελίδας.

Επεξεργασία χαρτών

Visual editor showing editing an existing map.jpg
Μπορείτε να προσθέσετε και να αλλάξετε χάρτες. Δείτε Help:VisualEditor/Maps .

Επεξεργασία μαθηματικών τύπων

Για να προσθέσετε καινούριο μαθηματικό τύπο στη σελίδα, τοποθετήστε τον κέρσορα εκεί που επιθυμείτε και πατήστε στο εικονίδιο «Μαθηματικός τύπος"» στο μενού «Εισαγωγή» στη μπάρα εργαλείων.
VisualEditor Formula Insert Menu-el.png

Θα ανοίξει ένα παράθυρο όπου μπορείτε να πληκτρολογήσετε τον τύπο, με χρήση σύνταξης LaTeX. Ο οπτικός επεξεργαστής θα ενημερώνει τον μαθηματικό τύπο καθώς πληκτρολογείτε, κι έτσι θα βλέπετε πως θα φαίνονται οι αλλαγές σας. Όταν είστε ευχαριστημένος με τον τύπο, πατήστε το κουμπί "Εισαγωγή".
VisualEditor formula-el.png

Για να βγείτε από υπάρχοντα μαθηματικό τύπο, πατήστε σε αυτόν και μετά πατήστε το εικονίδιο "Σ" που θα εμφανιστεί. Τότε θα ανοίξει το παράθυρο διόρθωσης μαθηματικών τύπων, όπου θα πραγματοποιήσετε τις αλλαγές που θέλετε.
VisualEditor - editing existing mathematical formula.png

Μαθηματικοί τύποι μπορούν να τοποθετηθούν εντός κειμένου ή κεντραρισμένοι ως αντικείμενο.
VisualEditor mathematic formula inline.png

Επεξεργασία μουσικών παρτιτούρων

Για να προσθέσετε νέα μουσική σημειογραφία σε μια σελίδα, τοποθετήσετε το δρομέα εκεί όπου θέλετε να εισαχθεί η μουσική σημειογραφία. Κατόπιν, από το μενού «Εισαγωγή» στην μπάρα επεξεργασίας, πατήστε την επιλογή «Μουσική σημειογραφία»

Για να επεξεργαστείτε μια μουσική σημειογραφία σε μια σελίδα, κάντε διπλό πάτημα επάνω της.

VisualEditor-Insert-Musical-Notation.png

Θα ανοίξει τον διάλογο "Μουσική σημειογραφία". Εδώ μπορείτε να διορθώσετε τη σημειογραφία κατά κλίμακα, σε μορφή ABC ή Lilypond. Μπορείτε επίσης να συνδέσετε την σημειογραφία με ένα αρχείο ήχου ή MIDI. Όταν έχετε τελειώσει, πατήστε το κουμπί «Έγινε» για να κλείσετε το διάλογο και να δημοσιεύσετε τις αλλαγές σας.
Musical.png

Επεξεργασία ποιημάτων και άλλων ειδικών αντικειμένων.

Κάποια αντικείμενα, όπως λίστες δεδομένων και ποιήματα, προς το παρόν δεν υποστηρίζονται από τον οπτικό επεξεργαστή.
VisualEditor editing poem 1.png

Στις περισσότερες περιπτώσεις, τα υπάρχοντα αντικείμενα μπορούν να τύχουν επεξεργασία, αλλά νέα δεν μπορούν να εισαχθούν στον οπτικό επεξεργαστεί.

Μέχρι να υποστηρίζεται πλήρως, μπορείτε να αντιγράψετε ένα υπάρχον από μια άλλη σελίδα, ή να επεξεργαστείτε απευθείας τον κώδικα wiki.

VisualEditor editing poem 2.png

Εναλλαγή μεταξύ οπτικού επεξεργαστή και επεξεργαστή κώδικα

Για να αλλάξετε από τον οπτικό επεξεργαστή στον επεξεργαστή κώδικα wiki, πατήστε το κουμπί [[ ]] πέρα δεξιά στην μπάρα εργαλείων.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

Θα δείτε μια διαφορά κειμένων (diff) (αν πατήσατε στο «Απόρριψη αλλαγών», θα δείτε απλά κώδικα wiki, έτοιμο για επεξεργασία στον επεξεργαστή κώδικα).

Κυλήστε κάτω, και θα δείτε την περιοχή επεξεργασίας κώδικα wiki.

VisualEditor bi-directional switching diff before wikitext.png

Μπορείτε επίσης να αλλάξετε από τον επεξεργαστή κώδικα wiki στον οπτικό επεξεργαστή. Για να το κάνετε αυτό, πατήστε το εικονίδιο με μολύβι πέρα δεξιά στην μπάρα εργαλείων.

VisualEditor bi-directional switching pencil icon in wikitext.png

Συντομεύσεις πληκτρολογίου

Πολλοί συντάκτες είναι συνηθισμένοι να γράφουν απευθείας κώδικα wiki, ειδικά έντονα, πλάγια, και συνδέσμους. Οι συντομεύσεις πληκτρολογίου επιτρέπουν την ταχεία εισαγωγή παρόμοιας μορφοποίησης χωρίς να χρειάζεται να χρησιμοποιήσετε τα αντικείμενα στη μπάρα εργαλείων. Αυτές είναι οι κοινές γενικές συντομεύσεις στον VisualEditor:

Συντόμευση PC Ενέργεια Συντόμευση Mac

Ctrl+B Έντονα ⌘ Cmd+B

Ctrl+I Πλάγια ⌘ Cmd+I

Ctrl+K Εισαγωγή συνδέσμου ⌘ Cmd+K

Ctrl+X Αποκοπή ⌘ Cmd+X

Ctrl+C Αντιγραφή ⌘ Cmd+C

Ctrl+V Επικόλληση ⌘ Cmd+V

Ctrl+Z Αναίρεση ⌘ Cmd+Z