Help:Визуальный редактор/Руководство пользователя

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 51% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎Yorùbá • ‎中文
PD Внимание: Когда вы редактируете эту страницу, вы соглашаетесь на передачу своего вклада по лицензии CC0. Узнать об этом подробнее можно на странице справки. Помощь на страницах пошаговая
PD
Если вы хотите проверить работу Визуального редактора без редактирования какой-либо статьи, вот страница, где вы можете спокойно попробовать его. Вам даже не нужно регистрироваться, чтобы пользоваться Визуальным редактором на этой странице.

Contents


Открытие Визуального редактора

Чтобы отредактировать страницу при помощи Визуального редактора, нажмите вкладку «Править» вверху страницы.

Открытие страницы для редактирования может занять несколько секунд или даже дольше, если страница очень длинная.

Нажатие на вкладку «Править код» откроет классический редактор викитекста.

VisualEditor edit tab-ru.png

Вы также можете открыть Визуальный редактор, кликнув по ссылке «править» в заголовке любого раздела.
VisualEditor - Section edit links-en.png

Начало работы: панель инструментов Визуального редактора

Вид панели инструментов Визуального редактора
Когда вы начинаете редактирование с помощью Визуального редактора, вверху страницы появляется его панель инструментов. Она содержит несколько знакомых иконок:

VisualEditor - Toolbar - Undo-redo.png
Отменить и Вернуть изменения, которые вы сделали.

VisualEditor Toolbar Headings-ru.png
Выпадающее меню Абзац: позволяет вам изменять форматирование абзаца. Чтобы изменить стиль абзаца, поместите курсор в абзац и выберите пункт в этом меню (вам не придется выделять какой-либо текст). Заголовки разделов формируются пунктом "Заголовок", подразделов - "Заголовок 2", "Заголовок 3", и так далее. Обычное форматирование текста — «Абзац».

VisualEditor Toolbar Formatting-ru.png

Форматирование: Нажатие на «A» откроет меню (чтобы команды меню подействовали, нужно предварительно выбрать (выделить) текст, к которому планируется применить форматирование).

  • Пункт «Полужирный» (B) делает выделенный текст полужирным.
  • Пункт «Курсив» (I) преобразовывает выделенный текст в курсив.
  • Пункт «Надстрочный индекс» (x2) делает выбранный текст меньше и несколько выше, чем окружающий текст.
  • Пункт «Подстрочный индекс» (x2) делает выбранный текст меньше и несколько ниже, чем окружающий текст.
  • Пункт «Зачёркнутый» (S) добавляет сплошную полосу через выделенный текст (зачеркивает выделенный текст).
  • Пункт "Программный код" (набор фигурных скобок: {}) изменяет шрифт выделенного текста на моноширинный, что сделает его отличающимся от окружающего (пропорционального) текста.
  • Пункт "Подчёркнутый" (U) добавляет сплошную линию под выделенный текст.
  • Пункт "Язык" (Aあ) позволяет маркировать язык (например, японский) и направление (например, справа налево) у выделенного текста.
  • Последний пункт (VisualEditor MediaWiki theme clear icon bitmap.png), называется "Очистить стиль", удаляет всё форматирование из выделенного текста, в том числе и ссылки.

Если вы предварительно не выделили никакой текст, то нажатие «A» для открытия меню и последующий выбор одной из команд форматирования применит его к тексту, который вы начнёте вводить сразу после этого, вне зависимости от того, где находился курсор.


VisualEditor - Toolbar - Linking.png
Инструмент ссылок: Иконка звена цепи открывает инструмент для вставки ссылок. Щелчок по нему (обычно после выделения некоторого текста) откроет диалог вставки ссылки

VisualEditor - Cite Pulldown Rus.png
Меню Источники: меню "Источники" используется для добавления внутристрочных цитат (также называемых "сноски" или "ссылки"). Все проекты имеют доступ к оформлению базовой ссылки и возможности её повторного упоминания, используя это меню. Также данное меню обеспечивает быстрый доступ к местным шаблонам цитирования, если они включены на вашей Вики.

(Инструкции по добавлению местных шаблонов цитирования в меню Источники на определенную вики, доступны на странице VisualEditor/Citation toolVisualEditor/Citation tool.)


VisualEditor citoid Cite button.png
кнопка Источник: Если в вашей вики активен сервис citoid, то вы увидите кнопку Источник вместо меню Источники.

Служба citoid постарается заполнить шаблоны цитат автоматически.


VisualEditor Toolbar Lists and indentation-ru.png
Списки и отступы: Первые два пункта позволяют форматировать текст как "Маркированный список" или "Нумерованный список". Последние два пункта позволяют уменьшить или увеличить уровень отступа у элементов списка.

VisualEditor Insert Menu-ru.png
Вставить: Меню «Вставить» в некоторых проектах может отличаться. Ниже представлен список всех опций, которые могут там появиться.
  • Иконка «Медиафайл» (картинка с горами) открывает диалог вставки медиа-файлов.
  • Иконка "Шаблон" (часть пазла) позволяет редактировать шаблоны.
  • The "Table" item allows you to insert a table.
  • Пункт "Комментарий" (облачко текста) позволяет вставить комментарий, который не видим для читателей; этот комментарий можно увидеть только в режиме редактирования и затем обозначаются восклицательным знаком.
  • Иконка «Иероглифы» (символ анкха — ☥) позволяет вставлять иероглифы. (См. ниже.)
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • Иконка «Галерея» (набор фотографий) позволяет поместить на страницу галерею изображений.
  • Иконка «⧼math-visualeditor-mwmathinspector-title⧽» (Σ) открывает диалог вставки формул.
  • The "Graph" item allows you to insert a graph.
  • The "Ваша подпись" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • Иконка «Список примечаний» (три книги) открывает диалог, в котором можно определить, в каком месте примечания будут показываться читателю. Обычно для каждой страницы это делается только один раз.

Вставка специальных символов: иконка «Специальный символ» в меню «Вставить» позволяет вызвать окно со специальными символами. При щелчке на отдельный символ вы помещяете его в текст. Сюда входят некоторые стандартные символы, надстрочные знаки и математические символы. (Этот список может быть изменён локально. См. инструкции на VisualEditor/Special charactersVisualEditor/Special characters.)
VisualEditor Toolbar SpecialCharacters-ru.png

VisualEditor toolbar edit notices icon.png
Кнопка Редактировать заметки отображает любые заметки для страницы.

VisualEditor More Settings-ru.png
Меню «Параметры страницы» находится слева от кнопки «Записать страницу». В этом меню есть опции для настройки параметров страницы, например, является ли страница перенаправлением, или то, как следует индексировать эту страницу в поисковиках, инструмент добавления, редактирования и удаления категорий, а также увидеть, при использовании пункта «Язык», список статей на ту же тему, только в других языках.

VisualEditor bi-directional switching square brackets icon.png

Кнопка $switch находится за кнопкой Записать страницу. Она позволяет переключиться в редактор исходного вики текста.

Сохранение изменений

Когда закончите редактировать, нажмите синюю кнопку "Записать страницу" на панели инструментов. Если Вы не сделали изменений, кнопка будет отключена (серого цвета). Чтобы отменить все изменения, просто закройте окно браузера, или перейдите на вкладку «Читать» над панелью команд редактора.
VisualEditor toolbar actions-ru.png

Нажатие голубой кнопки «Записать страницу» открывает окно-диалог. Затем Вы можете написать краткое описание своих действий, отметить правку как малое изменение, и/или добавить страницу в ваш Список наблюдения. Поле для описания внесенных изменений — это эквивалент полю «Описание изменений:» в редакторе вики-текста.

Вы можете также проверить внесённые вами изменения, используя кнопку «Проверить внесённые изменения», чтобы убедиться перед сохранением, что всё выглядит именно так, как Вы планировали. Подобна кнопке «Внесённые изменения» в редакторе вики-текста.

Кнопка Продолжить редактирование вернет вас на страницу, которую вы редактировали. Вы можете сохранить все ваши изменения позднее.

VisualEditor save dialog-ru.png

Редактирование ссылок

VisualEditor - Toolbar - Linking.png
Ссылки могут быть добавлены с помощью иконки «Ссылка» (звенья цепи) на панели инструментов или с помощью горячих клавиш Ctrl+K (или Command+K на Mac).

Если вы выбрали(выделили) текст и затем нажали кнопку «Ссылка», то ссылка добавится ко всему этому тексту. Для ссылки на одно слово достаточно просто поставить курсор в этом слове.


VisualEditor-link tool-search results-ru.png
Если использовать кнопку или горячие клавиши, откроется окно, в котором можно ввести ссылку (внутреннюю или внешнюю). Визуальный редактор попробует помочь с внутренними ссылками (ссылки на другие страницы той же вики), подыскивая наиболее похожие варианты в процессе набора.

Визуальный редактор старается помочь с "внутренними" ссылками в поиске, пытаясь найти совпадения по мере того, как Вы начинаете вводить текст.


VisualEditor link tool 2015.png
После того как вы ввели или выбрали ссылку, для завершения вставки ссылки вам необходимо нажать Enter, нажать на кнопку "Готово", или кликнуть мышкой за пределы диалогового окна. Ваша ссылка появится на странице Визуального редактора, но не будет сохранена, пока вы не сохраните страницу.

VisualEditor - External link Rus.png
Размещение ссылки на веб-страницу другого сайта выполняется аналогично: выберите вкладку "External link" и введите ссылку в поле.

VisualEditor link tool simple link.png
Внешние ссылки без меток выглядят следующим образом: [1]. Вы можете добавить их, поместив курсор за пределами любого слова (например, через пробел). Откройте инструмент ссылок нажатием кнопки или при помощи сочетаний клавиш. Введите URL в поле и нажмите кнопку "Готово" для вставки ссылки.

VisualEditor-context menu-link tool.png
Чтобы изменить или удалить существующую ссылку, кликните на неё внутри текста для этой ссылки, затем нажмите на иконку "Ссылка", которая появится рядом. Появится диалоговое окно для редактирования. (Вы можете также попасть в диалог при помощи горячих клавиш Ctrl+K. Когда ссылка выделена, она помечается голубой рамкой. В диалоговом окне вы можете изменить то, куда ведет ссылка. Вы также можете удалить ссылку совсем, нажав на кнопку «Убрать» (мусорное ведро) в нижнем левом углу диалогового окна.

Вы также можете открыть цель ссылки в другом окне, нажав на кнопку "$linkopen». (Вы, возможно, захотите сделать это, чтобы проверить правильная ли внешняя ссылка используется.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.
  • You can also link to categories, files and more.

Редактирование примечаний

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "Источники" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "Источники" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-FullHelp:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Редактирование существующего примечания

Чтобы отредактировать существующую ссылку, кликните на текст ссылки. Должна будет появиться иконка «Примечаниеerence» (закладка) или иконка шаблона. Нажатие иконки откроет мини-редактор, позволяющий редактировать текст примечания.
VisualEditor - Editing references 1 - ru.png

Если появилась иконка «Примечаниеerence», нажатие на неё откроет мини-редактор примечаний, где в большинстве случаев вы сможете отредактировать текст примечания.

Многие вики для форматирования примечаний согласно своим стандартам используют шаблоны. Если используемый в вики шаблон ещё не поддерживается инструментом визуального редактирования или не включён в число обычно используемых шаблонов, то при попытке изменить такой шаблон в редакторе шаблонов, его содержание окрасится в синий цвет.

Нажмите на иконку «Шаблон» (фрагмент паззла) для редактирования содержимого шаблона в мини-редакторе шаблонов.

VisualEditor - Editing references 6 - ru.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Внутри мини-редактора шаблонов вы можете добавить или удалить параметры шаблона, а также изменить значения уже используемых праметров.
VisualEditor - Editing references 5 - ru.png

Нажмите «Применить изменения», когда всё будет готово.
VisualEditor Apply Changes-ru.png

Повторное использование существующей сноски

Если на странице уже имеются примечания, вы можете воспользоваться функцией повторного использования существующего примечания, если оно подходит для текста, к которому вы хотите указать источник.

Для повторного использования сноски поместите курсор в том месте текста, куда вы хотите её добавить, и кликните на иконку «$reference» (закладка) из меню «$insert».

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Источники" menu.)

VisualEditor references more Rus.png

Если сносок много, Вы можете использовать поисковую строку (с текстом «Поиск в пределах текущей ссылки»), чтобы отобразить только те сноски, которые содержат заданный текст.

Найдите в списке сноску, которую хотите использовать, и выберите её.

VisualEditor - Editing references 18 - ru.png

Добавление нового примечания

Если в вашей вики используется меню примечаний, это может быть уместно и легче путь для добавления ссылок. (См. ниже раздел «Использование меню примечаний»). В противном случае, для добавления нового примечания поместите курсор в то место текста, где это требуется, и кликните на иконку «$reference» (закладка) в выпадающем меню «$toolbar» на панели инструментов.
VisualEditor references more Rus.png

Использование "основного" цитирования

Shown here is what you will see if you select the basic references item. В редакторе примечаний вы можете добавить, отредактировать и отформатировать содержание примечания.

Вы можете указать принадлежность примечания к заданной группе; это используется для отображения групп примечаний в разделе «Список примечаний».

VisualEditor - Editing references 20 - ru.png

Если вы добавляете новое примечание и хотите добавить в него шаблон, кликните на иконку «Шаблон» (кусочек паззла) в выпадающем меню «Вставить» на панели инструментов в редакторе примечаний.
VisualEditor Template Insert Menu-ru.png

Затем найдите шаблон, который хотите использовать, добавьте его и отредактируйте так, как вам нужно.

Нажмите на «Применить изменения», чтобы вернуться к списку примечаний, и ещё раз нажмите на «Применить изменения», чтобы вернуться на страницу.

VisualEditor - Editing references 9 - ru.png

Если на странице ещё нет списка примечаний (например, если вы добавили на страницу первое примечание), Вам надо будет добавить его, чтобы ваше примечание стало отображаться.

Разместите курсор там, где хотите отобразить примечания (обычно — в конце страницы), и кликните иконку «Список примечаний» (три книги), чтобы добавить список примечаний.

VisualEditor References List Insert Menu-ru.png

Если вы создали группы примечаний, то чтобы выборочно отобразить примечания, относящиеся к той или иной группе, можете задать группу в этом диалоге.

Чтобы просто добавить список примечаний, нажмите «$apply» в диалоге.

VisualEditor references list-ru.png

Использование стандартных шаблонов для источников

Your local wiki may have added extra citation templates to the "Источники" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown Rus.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

Чтобы добавить дополнительные параметры, прокрутите вниз страницы в шаблоне мини-редактора и нажмите клавишу "добавить еще информацию".

Нажмите на "Вставить", когда вы закончите.

VisualEditor - Editing references - Add parameter.png

Редактирование изображений и других медиа-файлов

Редактирование изображений

Чтобы добавить на страницу новое изображение (или другой медиафайл), нажмите иконку «Медиафайл» (картинка с горами) из выпадающего меню «Вставить». Изображения добавится там, где в этот момент находится курсор.
VisualEditor Media Insert Menu-ru.png

Иконка «Медиафайл» открывает диалог автоматического поиска на Викискладе медиафайлов, связанных с темой редактируемой вами страницы.

Вы можете поискать другие медиафайлы, изменив текст в поисковой строке диалога.

Кликните на превью, чтобы выбрать файл.

Это помещает изображение на страницу, которую вы редактируете.

VisualEditor - Media editing 2 - ru.png

Диалог мультимедиа позволяет вам добавить (и отредактировать) описание, которое может содержать форматирование и ссылки.
VisualEditor - Media editing 6 - ru.png

Диалоговое окно также позволяет добавить альтернативный текст для подписи изображений, который поможет пользователям, использующим программы для чтения с экрана, или отключившим показ изображений.
VisualEditor - Media editing 7.png

Вы можете также задать различные параметры изображения в окне «Дополнительные настройки». Сюда входит выравнивание, тип и размеры.
VisualEditor - Media editing 8 Rus.png

Когда всё будет готово, нажмите «Применить изменения», чтобы закрыть диалог и вернуться к редактированию страницы.
VisualEditor Apply Changes-ru.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "Медиафайл" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3 - ru.png

Загрузка изображений

You can upload images from a tab in the media dialog.
VisualEditor - Media upload 1.PNG

Click the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box.
VisualEditor - Media upload 1.PNG

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.PNG

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Редактирование галерей медиа-файлов

Чтобы добавить новую галерею, нажмите на иконку «Галерея» (несколько фотографий)
VisualEditor - Gallery1 Rus.png

Чтобы отредактировать в Визуальном редакторе существующую галерею, кликните по ней, чтобы отобразился значок галереи в верхнем правом углу. После нажатия на значок открытия галереи отобразится окно с полным списком изображений, включенных в галерею. Вы можете редактировать этот список: удалить, добавить или изменить изображения или изменить заголовки. К сожалению, в настоящее время нельзя увидеть сделанные вами изменения, пока не нажата кнопка со стрелкой влево (<), закрывающая диалог. По завершении изменения галереи, не забудьте сохранить всю страницу, т.к. при выходе из режима редактирования галереи изменения просто так не сохраняются.
VisualEditor - Gallery2.png
После этого откроется диалог вставки галереи, на данный момент — простое поле, которое работает аналогично вики-разметке. Для добавления фотографий в галерею, вам нужно будет указать имя файла, затем вертикальную черту (|) и подпись, который вы хотели бы видеть под изображением. Каждое изображение в галерее должно быть в отдельной строке. После того, как вы добавили в галерею все изображения, какие хотели, нажмите кнопку со стрелкой влево (<), чтобы выйти из диалога. Вы увидите свою галерею такой, какой она будет после сохранения. Обратите внимание, что ваша галерея не сохранится, пока вы не сохраните страницу. You can also edit this list to remove or rearrange images or to change captions.

When you click the "Готово" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using the visual editor, you must save the entire page in order to save your work.

VisualEditor - Gallery3 Rus.png

Редактирование шаблонов

Начало

Чтобы добавить на страницу новый шаблон, разместите курсор там, где хотите его вставить, и нажмите на иконку «Шаблон» (кусочек пазла) в выпадающем меню «Вставить» на панели инструментов.
VisualEditor Template Insert Menu-ru.png

Введите имя шаблона, который хотите вставить, и нажмите «Добавить шаблон».
VisualEditor - Template editing 4 - ru.png

Вы также можете отредактировать шаблоны, которые уже есть на странице, выделив их (они станут синими) и нажав на иконку «Шаблон» (кусочек паззла), которая появится на панели инструментов.
VisualEditor - Template editing 1 - ru.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Параметры шаблона

When you add a new template or open an existing one, the "Включение" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateDataExtension:TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

Вы можете добавить параметры или отредактировать уже перечисленные.
VisualEditor - Template editing 3 ru.png

Когда шаблон включает другие шаблоны, эти подшаблоны отображаются внутри параметров, которые их используют. Они могут быть отредактированы или удалены в поле параметра.

Новые подшаблоны добавляются в следующей стадии добавления параметра. Возможно, вам придется проверить документацию шаблона, чтобы убедиться, что подшаблон поддерживается.

VisualEditor - Template editing 5.png

Finishing

Когда всё будет готово, нажмите «Применить изменения», чтобы закрыть диалоговое окно и вернуться к редактированию страницы.
VisualEditor Apply Changes-ru.png

Подстановка шаблонов

Когда шаблон надо подставить, наберите subst: или подст: (включая двоеточие) перед названием шаблона.

Автодополнение не работает с subst: или подст:; если вам нужно автодополнение, добавьте subst: или подст: только после того, как найдёте нужный вам шаблон.

Затем нажмите на синюю кнопку «Добавить шаблон».

Добавьте любые параметры, как обычно, и нажмите «Вставить».

VisualEditor - Template editing 7.png

Вы увидите шаблон на странице после того, как нажмёте на «Применить изменения».
VisualEditor - Template editing 8.png

Редактирование списков

VisualEditor Toolbar Lists and indentation-ru.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Редактирование таблиц

VisualEditor insert table.png

Вы можете использовать Визуальный редактор для вставки и изменения таблиц. Это новая функция и детали будут быстро меняться.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you click on "Table", in the "Вставить" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

[[File:VisualEditor_table_editing_add_and_remove_columns.png|frameless|border|center|200px]] Вы можете добавлять или удалять строки или столбцы.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Редактирование категорий

VisualEditor category item-ru.png
Для редактирования категорий в меню "Параметры страницы" кликните на кнопку "Категории".

VisualEditor category editing-ru.png

Кнопка "Категории" открывает диалоговое окно, которое отображает список существующих категорий и позволяет добавлять новые.

Есть возможность настроить ключ, используемый для сортировки списка страниц на страницах категорий.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3 ru.png
Чтобы добавить новую категорию, введите её название в поле «Add a category». Вы можете как создать новую категорию, так и выбрать уже существующую.

VisualEditor - Category editing 2 - ru.png
Чтобы убрать существующую категорию, кликните на неё и затем кликните на иконку «Убрать» (мусорный бак) в открывшемся диалоге.

Вы можете также задать ключ сортировки для определённой категории. Это переопределит основной ключ сортировки.


VisualEditor Apply Changes-ru.png
Когда закончите редактировать категории, кликните «Применить изменения», чтобы вернуться к редактору страницы.

Параметры редактирования страницы

VisualEditor page settings item-ru.png
Для изменения параметров страницы необходимо раскрыть выпадающее меню «Параметры страницы» в панели инструментов, а затем выбрать кнопку «Параметры страницы».

VisualEditor Page Settings-ru.png
Кнопка «Параметры страницы» открывает панель, которая показывает несколько параметров.

VisualEditor Page Settings Redirects-ru.png

Вы можете сделать страницу перенаправления на другую страницу с помощью выбора флажка напротив "Перенаправить эту страницу на", а затем выбрать в поле снизу страницу, на которую Вы хотите переправить.

В нижней части находится параметр, который предотвращает обновление этого перенаправления при переименовании целевой страницы, которая очень редко используется.


VisualEditor Page Settings TOC-ru.png
Вы можете указать, должна ли страница показывать оглавление, выбрав одну из этих трех кнопок. По умолчанию установлена опция "При необходимости", которая показывает содержание, если три или более заголовков на странице.

VisualEditor Page Settings Edit Links-ru.png
Вы можете создать страницу и отключить ссылки на редактирование рядом с каждым заголовком на этой странице, установив этот флажок.

VisualEditor Apply Changes-ru.png
Нажмите «Применить изменения», когда закончите редактировать Параметры страницы, чтобы вернуться к редактированию страницы.

Редактирования математических формул

Чтобы добавить на страницу новую математическую формулу, поместите курсор мыши в место, куда хотели бы вставить формулу, и нажмите на иконку «⧼math-visualeditor-mwmathinspector-title⧽» («Σ») в выпадающем меню «Вставить» на панели инструментов.
VisualEditor Formula Insert Menu-ru.png

Откроется окно, в котором вы можете ввести формулу, с помощью LaTeX синтаксиса. Визуальный редактор произведет обновление формулы, после того, как Вы напечатаете ее, так что Вы сможете увидеть как это будет выглядеть, когда Вы вносите изменения. После того как Вы закончите формулу, просто нажмите курсором за пределы окна, и формула сохранится.
VisualEditor formula-ru.png

Чтобы изменить существующие математические формулы на странице, необходимо нажать на нужную формулу и потом нажать на появившуюся иконку «Σ». Эти действия откроют окно для ввода формул, которое позволит внести необходимые изменения.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, click the "Musical notation" option.

To edit an existing musical notation on the page, double click on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, click the "Done" button to close the dialog and save your changes.
Musical.png

Редактирование стихов и других специальных элементов

Некоторые элементы, такие как стихи и музыкальные ноты еще не поддерживаются Визуальным редактором. Пока это так, Вам нужно будет редактировать непосредственно исходный вики-текст, если Вы захотите их добавить или изменить.
VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Пока они не будут полностью поддерживаться, вы можете скопировать существующий файл с другой страницы или напрямую отредактировать исходный вики-текст.

VisualEditor editing poem 2.png

Переключение между визуальным редактором и редактором вики-текста

Чтобы переключиться с визуального редактора на редактор вики-текста, нажмите кнопку [[]] в правом углу панели инструментов.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

Сочетания клавиш

Многие редакторы используются для ввода вики-текста непосредственно, особенно для жирного шрифта, курсива и вики-ссылок. Сочетания клавиш позволяют быстро вставлять подобное форматирование без использования кнопок панели инструментов. Вот общие сочетания клавиш, используемые в визуальном редакторе:

Сочетание для PC Действие Сочетание для Mac

Ctrl+B Полужирный Cmd+B

Ctrl+I Курсив Cmd+I

Ctrl+K Вставить ссылку Cmd+K

Ctrl+X Вырезать Cmd+X

Ctrl+C Копировать Cmd+C

Ctrl+V Вставить Cmd+V

Ctrl+Z Отменить Cmd+Z