Help:Görsel Düzenleyici/Kullanıcı kılavuzu

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 100% complete.
PD Not: Bu sayfayı düzenlerken katkınızı CC0 altında yayınlamayı kabul edersiniz. Daha fazla bilgi için Kamu Malı Yardım Sayfalarına bakın.
PD


Görsel düzenleyiciyi açma

Görsel düzenleyiciyi kullanarak bir sayfayı düzenlemek için sayfanın üst kısmındaki "Düzenle" sekmesine basın.

Sayfanın düzenlemeye açılması birkaç saniye, sayfa çok uzunsa daha uzun sürebilir.

"Kaynağı değiştir" sekmesine tıklamak, klasik vikimetin kaynak düzenleyicisini açacaktır.

VisualEditor edit tab-tr.png

Ayrıca her bölümdeki "düzenle" bağlantısına tıklayarak görsel düzenleyiciyi açabilirsiniz.
VisualEditor - Section edit links-en.png

Başlangıç: görsel düzenleyicinin araç çubuğu

Görsel düzenleyicinin araç çubuğunun ekran görüntüsü
Görsel düzenleyicinin araç çubuğu, düzenlemeye başladığınızda ekranın üst kısmında görünür. Bazı tanıdık simgeleri içerir:

VisualEditor - Toolbar - Undo-redo.png
Yaptığınız değişiklikleri Geri al ve Yinele yapın.

VisualEditor Toolbar Headings-tr.png
Başlıklar açılır menüsü: paragrafın nasıl biçimlendirileceğini değiştirmenize olanak verir. Bir paragrafın stilini değiştirmek için, imlecinizi paragrafın üzerine getirin ve bu menüden bir öğe seçin (herhangi bir metni vurgulamanıza gerek yoktur). Bölüm başlıkları "Başlık" olarak biçimlendirilir ve alt bölümler "Alt başlık 1", "Alt başlık 2" vb. şeklindedir. Normal metin biçimi "Paragraf" biçimidir.

VisualEditor Toolbar Formatting-tr.png

Biçimlendirme: "A" tuşuna tıklamak bir menü açılır.

  • "Kalın" öğesi (B') seçili metni kalınlaştırır.
  • "Eğik" seçeneği (I) seçilen metni eğikleştirir.
  • "Üst simge" öğesi (x2), seçilen metnin çevresindeki metinden daha küçük görünmesine ve çevresindeki metinden biraz daha yüksek olmasına neden olur.
  • "Alt simge" öğesi (x2), seçilen metnin çevreleyen metinden daha küçük görünmesine ve çevresindeki metinden biraz daha düşük olmasına neden olur.
  • "Üstü çizili" öğesi (S), seçili metne düz bir çubuk ekler.
  • "Bilgisayar kodu" öğesi (bir küme parantez: {}), seçilen metnin yazı tipini, onu çevreleyen (orantılı olarak aralıklı) metinden ayıran tek aralıklı bir yazı tipine dönüştürür.
  • "Altı çizili" öğesi (u), seçilen metne altındaki bir katı çizgi ekler.
  • "Dil" öğesi (文A), seçili metnin (örneğin, Japonca) ve örneğe (örneğin, sağa soldan sol) örnek etiketlemenize izin verir.
  • "$clearButton" denilen son madde (VisualEditor MediaWiki theme clear icon bitmap.png), bağlantılar da dahil olmak üzere seçilen metinden tüm karakter biçimlendirmesini kaldırır.

Herhangi bir metin seçmediyseniz, menüyü açmak için "A" düğmesine bastığınızda ve ardından bir öğe seçtiğinizde, bu biçimlendirme imlecinizin bulunduğu her yerden yazmaya başladığınız metin.


VisualEditor - Toolbar - Linking.png
Bağlama aracı: Zincir simgesi bağlama aracıdır. Üzerine basmak (genellikle bir metin seçtikten sonra) bağlantı diyalogunu açar.

VisualEditor - Cite Pulldown.png
Kaynak ekle menüsü: "Kaynak ekle" menüsü, satır içi kaynakça eklemek için kullanılır ("dipnotlar" olarak da adlandırılır). Tüm projelerin temel kaynak biçimlendirmesine erişimi ve bu menüyü kullanarak kaynakçayı yeniden kullanma yeteneği vardır. Ayrıca, vikilerinde etkinleştirilmişse, kullanıcılara yerel alıntı şablonlarına hızlı erişim sağlar.

(Belirli bir vikideki Kaynak ekle menüsüne yerel alıntı şablonlarını eklemek için talimatlar VisualEditor/Citation tool sayfasında mevcuttur.)


VisualEditor citoid Cite button-tr.png
Kaynak ekle düğmesi: Vikinizde citoid hizmeti etkinleştirilmişse, Kaynak ekle menüsü yerine bir Kaynak ekle düğmesi göreceksiniz.

Citoid hizmeti, kaynak şablonlarını otomatik olarak doldurmaya çalışır.


VisualEditor Toolbar Lists and indentation-tr.png
Listeler ve girinti: İlk iki öğe, metni "Madde imli liste" veya "Numaralı liste" olarak biçimlendirmenize izin verir. Son iki öğe, liste öğelerinin girinti düzeyini azaltmanıza veya artırmanıza olanak tanır.

VisualEditor Insert Menu-tr.png
Ekle: "Ekle" menüsü bazı projelerde farklı olabilir. Aşağıda görünebilecek tüm seçeneklerinin bir listesi bulunmaktadır.
  • "Resimler ve medya" simgesi (dağların resmi) medya diyalog öğesini açar.
  • "Şablon" simgesi (bir yapboz parçası) şablonları düzenleme yapmanıza olanak sağlar.
  • "Tablo" öğesi bir tablo eklemenize izin verir.
  • "Yorum" öğesi (bir konuşma balonu) okuyucular tarafından görülemeyen yorumlar eklemenize izin verir; bu yorumlar yalnızca bir ünlem işareti simgesiyle gösterildikleri düzenleme modundayken görülebilir. Düzenleme modunda, ünlem işareti simgesine basmak, yorumu düzenlemenizi veya silmenizi sağlar.
  • "Hiyeroglifler" simgesi (bir ankh sembolü - ☥) hiyeroglif ekleyiciye girmenize izin verir. (Aşağıya bakınız.)
  • "Kod bloğu" öğesi, kodu girmenize izin verir.
  • "Müzik notasyonu" öğesi, bir müzik notasyonu eklemenize olanak tanır.
  • "Galeri" simgesi (bir dizi fotoğraf) sayfaya bir galeri eklemenizi sağlar.
  • "Matematik formülü" simgesi (Σ) formül yerleştirici diyalog kutusunu açar.
  • "Grafik" öğesi bir grafik eklemenize izin verir.
  • "İmzanız" öğesi, projede kullandığınız bir imzayı eklemenize izin verir. İmzaların eklenmemesi gereken bir madde gibi bir sayfa türünü ("ad alanı") düzenlerken gri renkte görünür (seçilemez).
  • "Kaynakça listesi" simgesi (üç kitap), okuyucuya kaynakların nerede görüntüleneceğini belirleyebileceğiniz bir diyalog kutusu açar. Genellikle bunun bir sayfada yalnızca bir kez yapılması gerekir.

Özel karakter eklemesi: "Özel karakter" (Ω) simgesi, "Ekle" menüsünün yanında bulunur. Basıldığında, birçok özel karakteri gösteren bir diyalog kutusu görüntüler. Belirli bir karaktere basarak onu metne yerleştirirsiniz. Bu özel karakterler, bazı standart semboller, aksan işaretleri ve matematiksel semboller içerir. (Bu liste yerel olarak özelleştirilebilir. Talimatlar için VisualEditor/Special characters sayfasına bakın.)
VisualEditor Toolbar SpecialCharacters-tr.png

VisualEditor toolbar edit notices icon.png
Bildirimleri düzenle düğmesi, sayfaya ilişkin tüm bildirimleri görüntüler.

VisualEditor More Settings-tr.png
Sayfa seçenekleri menüsü, Değişiklikleri yayımla düğmesinin ve Düzenleyiciyi değiştir menüsünün solundadır. Bu menüde, aşağıdaki (sol taraf) sekmelerle bir Seçenekler diyalog kutusunu açmak için bir düğme vardır:
  • Kategoriler, bu sayfaya kategoriler eklemenize ve bir kategori içinde görüntülendiğinde, sıralama için farklı bir dizin ayarlayarak sayfanın nasıl sıralanacağını ayarlamanıza olanak tanır.
  • Sayfa ayarları, sayfayı bir yönlendirme yapmanıza ve bu yönlendirmenin seçeneklerini ayarlamanıza, İçindekiler Tablosunun görüntülenmesiyle ilgili ayarları yapmanıza, her başlığın yanındaki düzenleme bağlantılarını devre dışı bırakmanıza ve sayfayı bir belirsizlik giderme sayfası olarak tanımlamanıza olanak tanır.
  • Gelişmiş ayarlar, sayfanın arama motorları tarafından endekslenmesi, yeni bir bölüm eklemek için bir sekme ve görüntülenen başlık ile ilgili ayarları yapmanıza olanak tanır.
  • Dil, o sayfaya bağlanan diğer dillerdeki sayfaların bir listesini gösterir.
  • Kullanılan şablonlar, bu sayfada kullanılan her bir şablona yönelik bağlantıların bir listesini gösterir.

Seçenekler diyalog kutusunun sekmeleri de Sayfa seçenekleri menüsünde görüntülenir ve tıklanarak açılabilir. Ayrıca Sayfa seçenekleri menüsünde sağdan sola görünüm düğmesi ve aradığınız karakterleri, terimleri veya normal ifadeleri ekleyebileceğiniz bir iletişim kutusu açan Bul ve değiştir düğmesi bulunur. Seçenekler için çeşitli düğmelerle birlikte bunları değiştirecekler.


VisualEditor bi-directional switching square brackets icon.png
Kaynak düzenlemeye geç düğmesi, Değişiklikleri yayımla düğmesinin yanındadır. Vikimetin düzenleyiciye geçmenizi sağlar.

Değişiklikleri yayımlama

Düzenlemeyi bitirdiğinizde, araç çubuğundaki mavi "Değişiklikleri yayımla" düğmesine basın. Hiçbir değişiklik yapmadıysanız, düğme devre dışı bırakılır (gri renkte görünür). Tüm düzenleme değişikliklerinizi iptal etmek için, tarayıcı pencerenizi kapatın veya düzenleme araç çubuğunun üzerindeki "Oku" sekmesine basın.
VisualEditor toolbar actions-tr.png

Mavi "Değişiklikleri yayımla" düğmesine basıldığında bir iletişim kutusu açılır. Daha sonra eylemlerinizin kısa bir özetini girebilir, düzenlemenizi küçük olarak işaretleyebilir ve/veya sayfayı İzleme listesi sayfasında ekleyebilirsiniz. Özet kutusu, vikimetin düzenleyicisindeki Özet: alanının eşdeğeridir.

Değişikliklerinizi kaydetmeden önce amaçlandığı gibi çalışacaklarını onaylamak için "Değişikliklerinizi gözden geçirin" düğmesini kullanarak da değişikliklerinizi inceleyebilirsiniz. Bu, vikimetin düzenleyicisindeki "Değişiklikleri göster" düğmesine benzer.

"Düzenlemeye devam et" düğmesi sizi düzenlemekte olduğunuz sayfaya döndürür. Tüm değişikliklerinizi daha sonra yayımlayabilirsiniz.

VisualEditor save dialog-tr.png

Bağlantı düzenleme

VisualEditor - Toolbar - Linking.png
Bağlantılar, araç çubuğundaki "Bağlantı" simgesiyle (bir zincirdeki bağlantılar) veya Ctrl+K (veya Mac'ta ⌘ Command+K) kısayolu kullanılarak eklenebilir.

Metni seçer (vurgular) ve ardından "Bağlantı" düğmesine basarsanız, bu metin bağlantı oluşturulurken kullanılacaktır. Yalnızca bir kelime içeren bir bağlantı için, o kelimeyi seçebilir veya imleci o kelimenin içine koyabilirsiniz.


VisualEditor-link tool-search results-tr.png
Düğmeyi veya kısayolu kullandığınızda, bağlantıyı yazabileceğiniz bir iletişim kutusu açılır.

Bağlantı aracı, olası eşleşmeleri arayarak dahili bağlantılara yardımcı olmaya çalışacaktır. Bağlantıyı girdikten veya seçtikten sonra, ↵ Enter veya "Yapıldı" düğmesine basarak bağlantı sürecini tamamlarsınız. Bağlantınız hemen sayfada görünecek, ancak sayfadaki diğer değişikliklerde olduğu gibi, siz tüm sayfayı yayımlayana kadar yayımlanmayacaktır.


VisualEditor-link tool-external link-tr.png
Başka bir web sitesindeki bir web sayfasına bağlanmak için işlem benzerdir: "Harici site" sekmesini seçin ve kutuya bir URL girin.

VisualEditor link tool simple link.png
Etiketsiz harici bağlantılar şuna benzer: [1]. İmlecinizi herhangi bir kelimeden uzağa yerleştirerek bunları ekleyebilirsiniz (örneğin boşluktan sonra). Düğmeye basarak veya kısayol tuşlarına basarak bağlantı aracını açın. Kutuya URL'yi yazın ve bağlantıyı eklemek için "Yapıldı" düğmesine basın.

VisualEditor-context menu-link tool.png
Mevcut bir bağlantıyı değiştirmek veya kaldırmak için, o bağlantının metnine basın, ardından yanında görünen "Bağlantı" simgesine basın. İletişim kutusu düzenleme için görünecektir. Ayrıca diyaloga Ctrl+K klavye kısayoluyla da alabilirsiniz. Bir bağlantı seçildiğinde, mavi çerçeveli olarak görünür.

Bağlantı düzenleme diyalogda, bağlantının gideceği yeri değiştirebilirsiniz. Ayrıca, diyalogun sağ üst köşesindeki "Kaldır" düğmesine basarak bağlantıyı tamamen kaldırabilirsiniz. Ayrıca, diyalogdski bağlantının kopyasına tıklayarak bağlantının hedefini başka bir pencerede açabilirsiniz. (Harici bir bağlantının geçerli olup olmadığını kontrol etmek için bunu yapmak isteyebilirsiniz.)

Bağlantı etiketinden (bağlantı olarak görüntülenen metin) çıkmak veya bu bağlantıdan sonra yazmaya devam etmek istiyorsanız, tuşuna basabilirsiniz:

  • Bir kez basıldığında, bağlantı düzenleme diyalogdan çıkılır ve imleciniz bağlı öğenin sonuna yerleştirilir (bu öğeyi düzenlemek için mavi çerçeveli)
  • İki kez basmak, imleci metninizin geri kalanını yazmaya hazır olacak şekilde bağlantılı öğenin sonrasına yerleştirir.

Mevcut bir bağlantının bağlantı etiketini düzenlemek için, bağlantı etiketinin içine basın ve yenisini yazın. Ancak tüm etiketi değiştirmek istiyorsanız, lütfen şunlara dikkat edin:

  • Tüm bağlantı etiketini seçtiyseniz (vurguladıysanız), bağlantı herhangi bir tuş girilerek silinecektir. Başlangıçtan bağlantı verebilirsiniz.
  • Bağlantıyı doğrudan korumak için, o bağlantı etiketine tıklayabikir, geri ve delete tuşuna gerekenden daha fazla basmadan kullanabilirsiniz, burada dar bir mavi bağlantı alanı kalacaktır. Şimdi saklanan bağlantı için yeni etiketi yazabilirsiniz.
  • Ayrıca kategorilere, dosyalara ve daha fazlasına bağlantı da yapabilirsiniz.

Kaynak düzenleme

Daha fazla bilgi için Kaynak şablonlarını kullanma konusunda yardım veya Citoid'in Kaynak düğmesini kullanma konusunda yardım sayfasına bakın

Hangi sistemin yerinde olduğunu belirleme

Vikiniz üç dipnot sisteminden birini kullanabilir. Sağda gösterilen, "Kaynak ekle" menüsünün herhangi bir kaynak şablonu içermediği en basit sistemdir. Eğer vikiniz bu sistemi kullanıyorsa, dipnotlar hakkında bilmeniz gereken her şey bu sayfadadır.
VisualEditor cite menu default.png

İkinci sistem aynı tür "Kaynak ekle" menüsüne sahiptir, ancak hızlı erişim için ayarlanmış birkaç popüler kaynak şablonu vardır. Vikiniz bu sistemi kullanıyorsa, daha fazla ayrıntıyı Help:VisualEditor/User guide/Citations-Templates sayfasında bulabilirsiniz.
VisualEditor references more.png

VisualEditor citoid Cite button-tr.png
Üçüncü sistemde, tekrar Kaynak düğmesine basarak başlıyorsunuz. Ardından, citoid hizmetini kullanan otomatik bir kaynak işlemini içeren bir diyalog açılır. Vikiniz bu sistemi kullanıyorsa, daha fazla ayrıntıyı Help:VisualEditor/User guide/Citations-Full sayfasında bulabilirsiniz
VisualEditor Citoid Inspector-tr.png

Mevcut bir kaynağı düzenleme

Mevcut bir kaynağı düzenlemek için, metinde göründüğü yere basın (genellikle parantez içine alınmış bir sayı olarak). Bu kaynağı oluşturmak için kullanılan şablon için bir "Kaynakça" simgesi (yer imi) veya bir simge (ve ad) göreceksiniz. Her iki durumda da, "Düzenle" düğmesine basıldığında kaynağı düzenleyebileceğiniz bir diyalog açılır.
VisualEditor - Editing references 1.png

"Kaynakça" simgesi için, "Düzenle" seçeneğine basıldığında Kaynak diyalogu açılır. Kaynak bilgilerini değiştirmeye başlamak için üzerine basın.

Birçok viki, kaynakçayı biçimlendirmek için şablonlar kullanır. Kaynağınızda bir şablon kullanılıyorsa, işaretçinizi kaynak bilgisinin üzerine getirdiğinizde, o alandaki tüm bilgiler vurgulanacaktır.

Bir şablon kullanılmışsa ve kaynak bilgisine basarsanız, bazı bilgilerle birlikte Şablon simgesi (yapboz parçası) görünecektir. Şablon mini düzenleyici diyalogda şablonun içeriğini düzenlemek için "düzenle" düğmesine basın.

VisualEditor - Editing references 6.png

Bir kaynağa tıkladığınızda görünen şey, kaynakça için standart bir şablonun simgesiyse (bir örnek sağdadır), o zaman "Düzenle" seçeneğine tıklamak şablon mini editör diyalogunu açacaktır.
VisualEditor - Editing References - Cite Web-tr.png

Şablon mini düzenleyicinin içinde bilgi türlerini ekleyebilir veya kaldırabilir ya da mevcut içeriği değiştirebilirsiniz. Başlangıçta yalnızca içeriğe sahip alanlar (şablon parametreleri) gösterilecektir. Alan eklemek için mini düzenleyicinin altındaki "Daha fazla bilgi ekleyin" seçeneğine tıklayın.
VisualEditor - Editing references 5.png

Düzenlemeniz bittiğinizde "Değişiklikleri uygula" düğmesine tıklayınız.
VisualEditor Apply Changes-tr.png

Varolan bir kaynağı yeniden kullanma

Sayfa zaten kaynak yapmak istediğiniz metne uygulanan bir kaynak içeriyorsa, mevcut kaynağı yeniden kullanmayı seçebilirsiniz.

Mevcut bir kaynağa yeniden kullanmak için, imlecinizi o kaynağı için yeni bir kaynak (numara) eklemek istediğiniz metnin gövdesine yerleştirin. Ardından "Kaynak ekle" menüsünden "Kaynağı yeniden kullan" seçeneğine tıklayın.

(Not: Vikiniz yukarıda açıklanan üçüncü dipnot sistemine sahipse, "Kaynak ekle" menüsündeki "Yeniden kullan" öğesi yerine bir diyalogda "Yeniden kullan" sekmesi görürsünüz.)

VisualEditor Cite menu re-use.png

Kaynakça diyalogda, yeniden kullanmak istediğiniz kaynağın listesine bakın ve onu seçin. Çok sayıda kaynak varsa, yalnızca belirli bir metni içeren kaynakçayı listelemek için arama kutusunu ("Mevcut kaynaklar içinde ara" etiketli) kullanabilirsiniz.
VisualEditor - Editing references 18.png

Yeni bir kaynak ekleme

"Kaynak ekle" menüsünü kullanarak bir kaynak eklemek için, imlecinizi metinde eklemek istediğiniz yere getirin. Ardından menüden uygun kaynak türünü seçin.
VisualEditor references more.png

"Temel" kaynağı kullanma

Burada gösterilen, temel kaynakça öğesini seçerseniz göreceğiniz şeydir. Kaynak düzenleyicide, biçimlendirme dahil kaynakçanızı ekleyebilirsiniz.

Kaynağı belirli bir gruba ait yapabilirsiniz, ancak normalde bu boş bırakılır. (Bu seçenek, "Kaynakça listesi" aracıyla kaynak gruplarını görüntülemek için kullanılır.)

VisualEditor - Editing references 20.png

Kaynak diyalogda, yeni kaynağınıza bir kaynak şablonu veya başka bir şablon eklemek isterseniz, Kaynak düzenleyicideki "Ekle" araç çubuğu menüsünde Şablon simgesine (yapboz parçası) tıklayın.
VisualEditor Template Insert Menu-tr.png

Ardından, kullanmak istediğiniz şablonu arayın, ekleyin ve diğer şablonlarda yaptığınız gibi düzenleyin. (Şablonlar hakkında daha fazla bilgiye ihtiyacınız varsa aşağıdaki Şablon düzenleme bölümüne bakın.)

Yeni şablonunuzu düzenlemeyi bitirdikten sonra, Kaynak düzenleyiciye dönmek için "Değişiklikleri uygula" düğmesine ve düzenlemekte olduğunuz sayfaya dönmek için tekrar "Değişiklikleri uygula" düğmesine tıklayın.

VisualEditor - Editing references 9.png

Sayfada halihazırda bir kaynak listesi yoksa (örneğin, sayfa için ilk kaynağı ekliyorsanız), kaynak listesinin ve metinlerinin okuyucuya nerede görüntüleneceğini belirtmeniz gerekir.

İmleci kaynak listesini görüntülemek istediğiniz yere (genellikle sayfanın altındadır) yerleştirin, "Ekle" menüsünü açın ve "Kaynakça listesi" simgesine (üç kitap) tıklayın.

VisualEditor References List Insert Menu-tr.png

Nispeten nadir görülen birkaç kaynak grubu kullanıyorsanız, grubu bu diyalogda belirtebilirsiniz. Yalnızca o gruba ait olan kaynakça, grubu yerleştirdiğiniz konumda sayfada görüntülenecektir.

Kaynakça listesi diyalogdaki son adım "Ekle" düğmesine basmaktır.

VisualEditor references list-tr.png

Standart kaynak şablonu kullanma

Yerel vikiniz "Kaynak ekle" menüsüne fazladan kaynak şablonları eklemiş olabilir. Öyleyse, vikiniz için en çok kullanılan kaynak şablonlarına hızlı erişiminiz vardır. (Yerel vikinize fazladan kaynak şablonları ekleme talimatları VisualEditor/Citation tool sayfasında n edinilebilir.)
VisualEditor - Editing References - Cite Pulldown.png

"Kaynak kitabı" gibi bir şablon simgesine tıklamak sizi o şablon için şablon mini düzenleyicisine götürecektir. Önemli bilgi alanları bir yıldız işaretiyle işaretlenebilir. En yaygın alanlar gösterilecek olsa da, tümü gerekli değildir.
VisualEditor - Editing references - Cite book required fields.png

Daha fazla parametre eklemek için, şablon mini düzenleyicide aşağı kaydırın ve "Daha fazla bilgi ekleyin" seçeneğine tıklayın.

Bitirdiğinizde "Ekle" düğmesine tıklayın.

VisualEditor - Editing references - Add parameter.png

Resimleri ve diğer medya dosyalarını düzenleme

Resim düzenleme

Sayfaya yeni bir resim (veya başka türde bir medya dosyası) eklemek için, "Ekle" menüsündeki "Resimler ve medya" simgesine (dağların bir resmi) tıklayın. Resim, imlecinizin olduğu yere eklenecektir.
VisualEditor Media Insert Menu-tr.png

"Resimler ve medya" simgesine basıldığında, düzenlediğiniz sayfanın başlığıyla ilgili medya dosyalarını Wikimedia Commons ve yerel vikide otomatik olarak arayan bir diyalog açılır.

Diyalogun arama kutusundaki metni değiştirerek aramayı değiştirebilirsiniz.

Bir dosya seçmek için, küçük resmine basın.

Bu, resmi düzenlemekte olduğunuz sayfaya yerleştirir.

VisualEditor - Media editing 2-tr.png

Seçtiğiniz resim sayfaya eklendikten sonra başka bir diyalog açılacaktır. Bu diyalog, resminin başlığını eklemenize ve düzenlemenize olanak tanır. Başlık, biçimlendirme ve bağlantılar içerebilir.
VisualEditor - Media editing 6-tr.png

Medya diyalogu, ekran okuyucu kullanan veya resim gösterimini devre dışı bırakan kullanıcılara yardımcı olmak için alternatif metin başlıkları eklemenize de olanak tanır.
VisualEditor - Media editing 7.png

Ayrıca "Gelişmiş ayarlar" penceresinde resim için çeşitli parametreler ayarlayabilirsiniz. Bunlar, resminin hizalamasını, türünü ve boyutunu içerir.
VisualEditor - Media editing 8-tr.png

Düzenlemeniz bittiğinde diyalogunu kapatmak ve sayfa düzenleyicisine geri dönmek için "Değişiklikleri uygula" düğmesine tıklayın.
VisualEditor Apply Changes-tr.png

Mevcut bir resim için, resme tıklayarak ve ardından resmin altında görünen "Resimler ve medya" simgesine tıklayarak bir başlık veya diğer ayarları ekleyebilir veya düzenleyebilirsiniz.

Mevcut bir resmi üzerine tıklayarak ve ardından yeniden boyutlandırma simgesini (alt köşelerden birinde veya her ikisinde bulunan iki başlı ok) hareket ettirerek yeniden boyutlandırabilirsiniz.

Ayrıca, bir resmi sayfada daha yüksek veya daha alçak bir yere sürükleyip bırakabilirsiniz.

VisualEditor - Media editing 3-tr.png

Resim yükleme

Resimleri, medya diyalogdaki bir sekmeden veya bir dosyayı düzenleyiciye sürükleyip bırakarak veya panonuzdan bir resim yapıştırarak yükleyebilirsiniz.
VisualEditor - Media upload 1.png

"Yükle" sekmesine basın ve bilgisayarınızdan bir resim seçin. Dosya adını yazabilir veya kutuya bir resim sürükleyebilirsiniz. Bir görseli doğrudan düzenleyiciye sürükleyip bıraktıysanız veya panonuzdan yapıştırdıysanız, bu sekme otomatik olarak açılacaktır.
VisualEditor - Media upload 1.5.png

Başkalarının bulabilmesi için görseli tanımlamanız ve ona kategoriler eklemeniz gerekir.
VisualEditor - Media upload 2-tr.png

İşiniz bittiğinde resim sayfaya eklenecektir.
VisualEditor-logo.svg

Medya galerileri düzenleme

Yeni bir galeri eklemek için, "Ekle" menüsündeki "Galeri" simgesine (bir dizi fotoğraf) tıklayın. (Bu simgeyi o menüde görmüyorsanız, yerel vikiniz bu işlevi görsel düzenleyicide uygulamayı ertelemeye karar vermiştir.)
VisualEditor - Gallery1.png

Görsel düzenleyicide mevcut bir galeriyi düzenlemek için o galeriye tıklayın. Ardından, galerinin altına yakın bir yerde, galeri simgesine (bir dizi fotoğraf) tıklayın. Bu, galeride bulunan resimlerin tam listesi ile galeri düzenleyicisini getirir.
VisualEditor - Gallery2.png
Galeri düzenleyicisi şu anda, vikimetin işaretlemesini kullanarak mevcut galerileri düzenlemenize izin veren basit bir kutudur. Mevcut bir galeriye yeni bir resim eklemek için, dosya adını ve ardından bir çubuk (|) ve o resmin başlığını yazın. Galerideki her resmi kendi satırına koymalısınız. Resimleri kaldırmak veya yeniden düzenlemek ya da başlıkları değiştirmek için bu listeyi de düzenleyebilirsiniz.

"Yapıldı" düğmesine bastığınızda, galeri düzenleyicisinden çıkacaksınız. Ardından, şimdi okuyuculara görüneceği şekliyle galeriyle birlikte değişikliklerinizi görmelisiniz.

Galeri düzenleyiciden çıkmanın değişikliklerinizi yayınlamadığını unutmayın. Görsel düzenleyici kullanılarak yapılan diğer değişikliklerde olduğu gibi, çalışmanızı yayımlamak için sayfanın tamamını yayımlamalısınız.

VisualEditor - Gallery3-tr.png

Şablon düzenleme

Güçlü MediaWiki şablon sistemi, dinamik içerik, diğer sayfalardan metin ve çok daha fazlasını eklemenize olanak tanır. Ayrıntılı açıklama ve örnekler için Şablonlar yardım sayfasına bakın.

Görsel Düzenleyici'de ilgili bir şablon arayabilir, düzenlediğiniz sayfaya bir çağrı veya yansıtma ekleyebilir ve gerekirse parametreler kullanarak özel içerik ekleyebilirsiniz.

Yeni şablon ekle

Bir sayfaya şablon eklemek için imlecinizi sayfada şablonun eklenmesini istediğiniz konuma getirin. Ardından Ekle menüsünü açın ve "OOjs UI icon puzzle-ltr.svg Şablon" öğesini seçin. Alternatif olarak, aynı diyalogu açmak için iki süslü parantez {{ yazın.
VisualEditor Template Insert Menu-tr.png
Eklemek istediğiniz şablonu, adını veya alakalı bir anahtar kelime yazarak bulun. Adında veya açıklamasında arama terimini içeren sonuçlar bir açılır menüde görüntülenecektir. Bu, tam adını bilmeseniz bile alakalı bir şablon bulmanıza yardımcı olacaktır.

Anahtar kelimeleri kullanarak istediğiniz şablon türünü bulmakta sorun yaşıyorsanız, benzer içeriğe sahip diğer viki sayfalarına bakabilir ve hangi şablonların kullanımda olduğunu görmek için sayfa kaynağını görüntüleyebilir veya düzenleyebilirsiniz. İstediğiniz şablonun adını bulduğunuzda, buraya eklemek için bu alana yazabilirsiniz.

Görsel Düzenleyici'deki şablon arama alanının ekran görüntüsü

Hâlihazırda bir sayfada bulunan bir şablonu da düzenleyebilirsiniz. Düzenlemek istediğiniz şablonu seçtiğinizde maviye döner ve "OOjs UI icon puzzle-ltr.svg Şablon" yazan bir kutu görünür. Ardından "Düzenle" bağlantısını seçin veya şablonu açmak için şablonun kendisine çift tıklayın.
Screenshot of the VisualEditor interface with a template selected

Bazı şablonlar, bir sayfayı okuyan biri tarafından görülemez. Görsel düzenleyicide, bu tür gizli şablonlar gösterilmeye devam eder, böylece onları tıklayıp düzenleyebilir veya silebilirsiniz. Şablonun adı yapboz simgesinin yanında gösterilecek ve her ikisi de gri olacaktır.
Screenshot of hidden templates in the Visual Editor interface

Şablon parametreleri

Yeni bir şablon eklerken veya hâlihazırda yerinde olan bir şablonu düzenlerken bu iletişim kutusunu göreceksiniz. Kutuda gördükleriniz, söz konusu şablonun, Görsel Düzenleyici'de şablonları düzenlemeyi kolaylaştırmak için diğer düzenleyiciler tarafından eklenen yararlı meta veriler olan TemplateData içerip içermediğine bağlıdır.

Bir şablon TemplateData içerdiğinde, Görsel Düzenleyici bunu sizin doldurmanız için açıklamalı alanlar sunmak için kullanabilir.


Topluluk tarafından sağlanan TemplateData'ya sahip şablonlar için Görsel Düzenleyici, adlandırılmış parametrelerin bir listesini ve genellikle her parametrenin değerleri için anlamı ve gerekli formatı açıklayan açıklamaları ve talimatları görüntüler.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

Herhangi bir isteğe bağlı parametreyi (sol tarafta mavi onay kutuları olan) devre dışı bırakabilirsiniz. Bir parametrenin onay kutusu griyse ve tıklanabilir değilse, şablon o parametreyi gerektirir, dolayısıyla devre dışı bırakılamaz.

Yeni bir şablon eklediğinizde, bazı isteğe bağlı parametrelerin önceden seçilmiş olduğunu görebilirsiniz. Bu, şablonun yazar(lar)ının bu parametrelerin kullanılmasını önerdiği anlamına gelir. Kullanımlarını anladığınızdan emin olmak için bir şablonda kullanılacak tüm parametreleri gözden geçirmek en iyisidir.

İşaretlenmemiş bir parametreye tıklamak, onu şablona ekler. Hâlihazırda eklenmiş bir parametreye tıklamak sizi parametrenin giriş alanına götürür.

Bazı şablon parametreleri "kullanımdan kaldırıldı" olarak görünecektir. Şablon eklerken kullanımdan kaldırılmış parametreler kullanmayın; bu parametreler, bu şablonun eklendiği eski sayfalarda kullanımda olduğundan yalnızca size görünürler.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Belgelenmemiş parametreler ekleme

Yazarı parametrelerini TemplateData'da düzenlememiş bir şablonu ekliyor veya düzenliyorsanız, "belgelenmemiş" veya "adsız parametreler" dediğimiz şeye sahiptir. Bu durumlarda, şablonun kendisi için sayfaya bakmalısınız. Orada tüm şablon parametrelerini nasıl doğru şekilde kullanacağınızı ve bunlarla nasıl çalışacağınızı öğrenebilirsiniz. Bu, şablon yazarı tarafından yazıldığı şekliyle parametrelerin tam adlarının öğrenilmesini içerir.

Belgede şablonun adları olmayan parametreleri beklediğini görürseniz, belgelenmemiş parametre girişini kullanarak parametre adları için sayıları yer tutucu olarak doldurun, ardından normalde yaptığınız gibi sağlamak istediğiniz değerlerin yanına ekleyin.

Örnek:

  • ilk adsız parametre: “1”
  • ilk adsız parametrenin değeri: “en_US”
  • ikinci adsız parametre: “2”
  • ikinci adsız parametrenin değeri: “yes”

Yanlışlıkla var olmayan, yanlış yazılmış veya hatalı parametreler eklerseniz, bu parametreler için girdiğiniz değerler düzenlediğiniz sayfada görünmez.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Otomatik oluşturulmuş parametreler

Bu örnekte, söz konusu şablon TemplateData'dan yoksundur ancak parametreleri otomatik olarak oluşturmak mümkün olmuştur. Bu, belgelenmemiş parametrelerin sizin için zaten eklenmiş olduğu, ancak adların kolayca anlaşılmayabileceği ve diyalogunun herhangi bir yön veya açıklama görüntüleyemediği anlamına gelir. Sonuç olarak diyalog, şablonun çeşitli parametrelerini anlamanıza ve doldurmanıza yardımcı olacak şablonun belgelerine bir bağlantı sağlar.
Autogenerated parameters in the VisualEditor.png

Çok parçalı şablon içeriğini düzenleme

Düzenleme sırasında, birden çok şablondan oluşan şablon içeriğini veya bir vikimetine bağlı tek bir şablonu açabilirsiniz. Bu, aşağıda açıklanan iç içe şablonlardan farklıdır. Bu durumda, şablonlar yığılmış veya bağlı olarak daha iyi görselleştirilir.

Bu içerik genellikle "dengesiz şablonlar", kendi başlarına tamamlanmamış şablonlar içerir ve çalışması için bir vikimetin veya başka bir şablonla eşleştirilmesi gerekir.

Bu ilgili şablon içeriği parçaları vikimetinde oluşturulmalıdır, ancak Görsel Düzenleyici'de düzenlenebilir. Bu durumlarda, durumu bildirmek için diyalogunun üst kısmında bir bildirim göreceksiniz ve kenar çubuğunun altında özel bir araç çubuğu görünecektir. Burada ek şablonlar, ek vikimetin eklemek, ögeleri silmek veya sıralarını değiştirmek için simge düğmelerini kullanabilirsiniz.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

İç içe şablonlar

Şablonlar, parametre değeri olarak başka şablonlar içerebilir. Değeri bir şablonu ifade eden ( {{ }} ) çift kaşlı ayraçları içeren bir parametre gördüğünüzde bunu fark edeceksiniz.

Görsel Düzenleyici, bu şablonu düzenleyicinin kullanımı kolay arayüzünü kullanarak bir şablon (iç içe şablon) içinde sunamaz, bu nedenle bir şablonu kendiniz yerleştirmek istiyorsanız, şablonu elle nasıl ekleyeceğinizi anlamanız gerekir.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Düzenlemenizi tamamlama

Bir şablonu düzenlemeyi bitirdiğinizde, "Değişiklikleri uygula" düğmesine tıklayabilirsiniz. Ardından düzenlemenizi önizleyebilir ve istediğiniz ve beklediğiniz gibi göründüğünden emin olabilirsiniz.

Ayrıca (yukarıda bahsedilen diğer TemplateData gibi) topluluk tarafından sağlanan içerik olan ve kullanışlılığı değişebilen bir hata mesajı da görebilirsiniz. Bazı hataların temeline inmek için şablonun kendi belgelerine bakmanız gerekebilir. Hâlâ sorun yaşıyorsanız, sorununuz hakkında şablonun tartışma sayfasında göndermeyi düşünün.

VisualEditor Apply Changes-tr.png

Bir şablon kaldırma

Görsel Düzenleyici'de bir şablonu kaldırmak için şablon kutusuna tıklayın. Klavyenizdeki "Delete" veya "Backspace" tuşuna basın. Şablon sayfadan kaybolacaktır.
Screenshot of the button to remove a template
Görsel Düzenleyici'de bir şablonu kaldırma

Mobilde düzenleme

Bir mobil cihazda Görsel Düzenleyici kullanarak bir sayfada bir şablonu düzenlerken, kenar çubuğunun gizli başladığını göreceksiniz. “Seçenekleri göster/gizle” düğmesine basarak görünür hâle getirebilirsiniz.
Screenshot of editing a template on a mobile device
Görsel Düzenleyici'de mobilde bir şablonu düzenleme

Şablon değiştirme

Bir viki sayfasına bir şablon eklediğinizde, şablon koduna ve parametrelerinin değerlerine göre sayfa her yüklendiğinde içeriği ve görünümü yeniden değerlendirilir. Bu, birisi bir şablonun kodunu güncellerse, o şablonu kullanan her sayfa yayımlandıklarında da güncelleneceği anlamına gelir.

Bununla birlikte, şablonları kullanmanın çok daha az yaygın olan başka bir yolu daha vardır ve bu, bir şablonu yerine koymaktır. Bunu kalıcı olarak yapmak, şablon içeriğini eklediğiniz anda göründüğü gibi içerir. Şablon kodu daha sonra değiştirilirse güncellenmez.

Çoğu kullanıcının şablonu yerine koymaya gerekmeyecek. Yerine koyma, genellikle yalnızca bir şablonun bir sürümünün tam görünümünü yakalamanız gerektiğinde, örneğin içeriğin geliştirilmekte olduğu ve değerlendirilmeye ihtiyaç duyulduğu durumlarda kullanışlıdır.

Görsel Düzenleyici'de bir şablonu yerine koymak için, subst:<şablon adı> ad sözdizimini kullanarak bir şablon ekleyin. (Bu durumda otomatik tamamlama çalışmaz.) Ardından mavi "Şablon ekle" düğmesine basın.

Bitirdiğinizde, şablon içeriğini gördüğünüz gibi ekleyecek olan “Ekle” düğmesine basın.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Liste düzenleme

VisualEditor Toolbar Lists and indentation-tr.png
Listelendirmek için görsel düzenleyiciyi kullanabilir veya mevcut bir listenin biçimini değiştirmek için. İki tür liste vardır: Oluşuk (mermi) ve sıralama (numaralandırılmış).

Yeni bir liste başlatmak için, burada gösterilen iki menü öğesinden birine tıklamanız yeterlidir. Veya listeyi zaten yazdıysanız (ayrı satırlarda), yazdığınız listeyi seçin (vurgulayın) ve ardından menü öğelerinden birine tıklayın.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Burada iki tür liste örneği gösterilmektedir: sırasız (madde işaretli) ve sıralı (numaralı).

VisualEditor lists 3 select to indent.png
Mevcut bir listenin bir kısmının girinti düzeyini değiştirmek istiyorsanız, listenin değiştirmek istediğiniz bölümünü seçin.

VisualEditor lists 4 indentation menu.png
Ardından menüyü kullanın veya Tab tuşuna tıklayın. (Sekme tuşu girintiyi artırır; girintiyi azaltmak için üst karakter tuşu ile Tab tuşunu kullanın)

VisualEditor lists after indenting.png
İşte artan girintinin sonucudur.

VisualEditor lists mixed.png
Liste öğeleri farklı girintilere sahipse, sıralı (numaralı) ve sırasız (madde işaretli) listeleri bile karıştırabilirsiniz.

Tablo düzenleme

VisualEditor insert table-tr.png
Tablo eklemek ve değiştirmek için görsel düzenleyiciyi kullanabilirsiniz.

Bir virgülle ayrılmış değer (.csv) dosyasını bilgisayarınızdan ana düzenleme penceresine sürükleyerek bile bir tabloyu içe aktarabilirsiniz.


"Ekle" menüsünde "Tablo" üzerine bastığınızda, görsel düzenleyici boş bir dörde dört tablo ekler.

Artık "Tablo" menüsü mevcuttur. Bu menüden tablonun üst kısmına bir başlık ekleyebilirsiniz.

VisualEditor empty table.png

Bir hücre seçmek için bir kez basın.
VisualEditor tables select one cell-tr.png

Hücrenin içeriğini düzenlemek için (örneğin, içerik eklemek veya bir yazım hatasını düzeltmek için) hücreye iki kez basın. Veya hücreyi seçip Return tuşuna basabilirsiniz.

Hücre düzenlemenizi bitirmek için başka bir yere basmanız yeterlidir.

VisualEditor tables type inside a cell-tr.png

VisualEditor table editing add and remove columns-tr.png
Bir sütun veya bir satır ekleyebilir, taşıyabilir veya silebilirsiniz.

Hücreleri birleştirebilirsiniz: Onları seçin, ardından Tablo menüsünden "Hücreleri birleştir" seçeneğine tıklayın.
VisualEditor tables merge cells.png

Hücreleri birleştirirseniz, yalnızca bir hücrenin metni tutulur; Diğer hücrelerdeki herhangi bir metin, hücreleri birleştirirken silindiğinde silinir. Silinen metnin bazı veya tümünü istediğinizi kararlaştırırsanız, Geri al düğmesini kullanın, istediğiniz metni taşıyın veya kopyalayın, daha sonra hücreleri birleştirin.
VisualEditor tables post-merge cell-tr.png

Daha önce birleştirilmiş hücreleri de bölebilirsiniz. Birleştirilmiş hücrede bulunan tüm içerik, bölmeyi yaptığınızda ilk hücrede kalacaktır. Ardından, isterseniz metni kesip diğer hücrelere yapıştırabilirsiniz.
VisualEditor tables split cells.png

Kategori düzenleme

VisualEditor category item-tr.png
Kategorileri düzenlemek için, "Sayfa seçenekleri" menüsünde "Kategoriler" düğmesine tıklayın.

VisualEditor category editing-tr.png
"Kategoriler" üzerine tıklandığında, mevcut kategorileri listeleyen ve yenilerini eklemenize ve mevcut kategorileri silmenize izin veren bir diyalog açılır.

Aynı kategorideki diğer sayfalarla birlikte listelendiğinde sayfanın nerede görüneceğini belirleyen genel (varsayılan) sıralama anahtarı ayarlama veya değiştirme seçeneğiniz de vardır.

Örneğin, "George Washington" maddesi için varsayılan sıralama anahtarı "Washington, George" dur. "Amerika Birleşik Devletleri Başkanları" kategorisinde, madde "G" harfinin altında değil "W" harfinin altında listelenmiştir.


VisualEditor - Category editing 3.png
Bir sayfaya kategori eklemek için, kategorinin adını "Bir kategori ekle" alanına yazın. Siz yazarken, görsel düzenleyici olası eşleşen mevcut kategorileri arayacaktır. Mevcut bir kategoriyi seçebilir veya henüz kendi kategori sayfası olmayan bir kategori ekleyebilirsiniz. (Bu kategori sayfası oluşturulana kadar, tüm düzenleme değişikliklerinizi yayımladıktan sonra yeni kategoriniz kırmızı bir bağlantı olarak görünecektir.)

VisualEditor - Category editing 2.png
Varolan bir kategoriyi kaldırmak için üzerine tıklayın ve açılan diyalogu "Kaldır" simgesine (çöp kutusu) tıklayın.

Bir kategoriye tıklamanız, o kategori için bir sıralama anahtarı belirlemenize de olanak tanır. Böyle bir sıralama anahtarı, varsayılan sıralama anahtarını geçersiz kılar.


VisualEditor Apply Changes-tr.png
Sayfa düzenleyicisine dönmek için kategorileri düzenlemeyi bitirdiğinizde "Değişiklikleri uygula" düğmesine basın.

Sayfa ayarı düzenleme

VisualEditor page settings item-tr.png
Bir sayfanın ayarlarını düzenlemek için, araç çubuğundaki "$pagmenu" menüsünü açmak için düğmesine basın ve "Sayfa ayarları" düğmesini seçin.

VisualEditor Page Settings-tr.png
"Sayfa ayarları" düğmesi, birkaç seçeneği gösteren bir diyalog açar.

VisualEditor Page Settings Redirects-tr.png
"Bu sayfaya yönlendirir" onay kutusunu işaretleyerek ve ardından düzenlemekte olduğunuz sayfaya gitmeye çalışan okuyucuyu göndermek istediğiniz sayfanın adını yazarak bir sayfayı başka bir sayfaya yönlendirme yapabilirsiniz.

En altta, sayfa yeniden adlarının bu yönlendirmeyi güncellemesini önleme seçeneği vardır. Bu çok nadiren kullanılır.


VisualEditor Page Settings TOC-tr.png
Bu üç düğmeden birini seçerek sayfanın bir İçindekiler Tablosu gösterip göstermediğini değiştirebilirsiniz. Varsayılan seçenek, üç veya daha fazla başlık varsa İçindekiler'i gösteren "Gerekirse" seçeneğidir.

VisualEditor Page Settings Edit Links-tr.png
Bu onay kutusunu işaretleyerek bir sayfanın her bölüm başlığının yanında düzenleme bağlantılarını göstermemesini sağlayabilirsiniz.

VisualEditor Apply Changes-tr.png
Sayfa düzenleyicisine dönmek için Sayfa seçenekleri ile düzenlemeyi bitirdiğinizde "Değişiklikleri uygula" düğmesine tıklayın.

Harita düzenleme

Visual editor showing editing an existing map.jpg
Haritaları ekleyebilir ve değiştirebilirsiniz. Help:Görsel Düzenleyici/Haritalar sayfasına bakın.

Matematiksel formülleri düzenleme

Sayfaya yeni bir matematiksel formül eklemek için, imlecinizi eklenmesini istediğiniz yere getirin ve araç çubuğundaki "Ekle" menüsündeki "Matematik formülü" simgesine ("Σ") tıklayın.
VisualEditor Formula Insert Menu-tr.png

LaTeX sözdizimini kullanarak formülü yazabileceğiniz bir pencere açılacaktır. Görsel düzenleyici, siz yazarken formülü günceller, böylece siz değişiklikleri yaparken nasıl görüneceğini görebilirsiniz. Formülden memnun olduğunuzda, "Ekle" düğmesine tıklayın.
VisualEditor formula-tr.png

Sayfadaki mevcut bir matematik formülü düzenlemek için, üzerine tıklayınız ve ardından beliren "Σ" simgesine tıklayın. Bu, değişiklik yaptığınız formül penceresini açacaktır.
VisualEditor - editing existing mathematical formula.png

Matematiksel formüller satır içi olarak yerleştirilebilir veya bir blok olarak ortalanabilir.
VisualEditor mathematic formula inline.png

Müzik notaları düzenleme

Bir sayfaya yeni bir müzik notasyonu eklemek için, imlecinizi müzik notasyonunun eklenmesini istediğiniz yere yerleştirin. Ardından, araç çubuğundaki "Ekle" menüsünden "Müzikal gösterim" seçeneğine tıklayın.

Sayfadaki mevcut bir müzik notasını düzenlemek için üzerine iki kez tıklayın.

VisualEditor-Insert-Musical-Notation.png

Bu, "Müzikal gösterim" diyalogu açacaktır. Burada gösterim, ABC veya Lilypond formatında ölçeğe göre düzenlenebilir. Notasyonu bir ses veya MIDI dosyasına da bağlayabilirsiniz. Bitirdiğinizde, diyalogu kapatmak ve değişikliklerinizi yayımlamak için "Yapıldı" düğmesine tıklayın.
Musical.png

Şiir ve diğer özel öğe düzenleme

İlişkilendirme listeleri ve şiirler gibi bazı öğeler, görsel düzenleyici tarafından henüz tam olarak desteklenmemektedir.
VisualEditor editing poem 1.png

Çoğu durumda, mevcut öğeler düzenlenebilir ancak görsel düzenleyiciye yenileri eklenemez.

Tamamen desteklenene kadar, var olanı başka bir sayfadan kopyalayabilir veya kaynak vikimetin dosyasını doğrudan düzenleyebilirsiniz.

VisualEditor editing poem 2.png

Görsel ve vikimetin düzenleyicileri arasında geçiş yapma

Görsel düzenleyiciden vikimetin düzenleyicisine geçmek için, araç çubuğunun en sağındaki [[ ]] düğmesine tıklayın.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

Bir fark göreceksiniz. ("Değişiklikleri iptal et" düğmesine tıkladıysanız, yalnızca vikimetin düzenleyicisiyle düzenlemeye hazır vikimetin görürsünüz.)

Aşağı kaydırın ve vikimetin düzenleme alanını göreceksiniz.

VisualEditor bi-directional switching diff before wikitext.png

Ayrıca vikimetin düzenleyiciden görsel düzenleyiciye de geçebilirsiniz. Bunu yapmak için araç çubuğunun en sağındaki kalem simgesine tıklayın.

VisualEditor bi-directional switching pencil icon in wikitext.png

Klavye kısayolları

Birçok editör, vikimetini doğrudan girmek için kullanılır, özellikle kalın, italik ve vikibağlantılar. Klavye kısayolları, araç çubuğu öğelerini kullanmak zorunda kalmadan benzer biçimlendirmeyi hızla eklemeye izin verir. Görsel düzenleyicideki yaygın genel kısayollar şunlardır:

Bilgisayar kısayolu Eylem Mac kısayolu

Ctrl+B Kalın ⌘ Cmd+B

Ctrl+I Eğikler ⌘ Cmd+I

Ctrl+K Bağlantı ekle ⌘ Cmd+K

Ctrl+X Kes ⌘ Cmd+X

Ctrl+C Kopyala ⌘ Cmd+C

Ctrl+V Yapıştır ⌘ Cmd+V

Ctrl+Z Geri al ⌘ Cmd+Z