Ajuda:Editor Visual/Guia do usuário

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 100% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎Yorùbá • ‎中文
PD Nota: Ao editar esta página, você concorda em publicar a sua contribuição no âmbito da licença CC0. Veja as páginas de ajuda do domínio público para mais informações.
PD
Caso queira experimentar o editor visual sem editar um artigo, clique aqui para testá-lo livremente. Não é necessário ter uma conta para utilizar o editor visual nessa página.


Abrindo o editor visual

Para editar uma página com o editor visual, clique na aba “Editar” no topo da página.

Pode levar alguns segundos até que a página abra em modo de edição, e demorará mais se a página for muito longa.

Um clique na aba “Editar código-fonte” abrirá o editor clássico de wikitexto.

VisualEditor edit tab-en.png

Você também pode abrir o editor visual clicando em “editar”, presente em cada seção.
VisualEditor - Section edit links-en.png

Primeiros passos: a barra de ferramentas do editor visual

Captura de tela da barra de ferramentas do editor visual
A barra de ferramentas do editor visual aparece no topo da tela quando você começa a editar. Ela inclui alguns ícones familiares:

VisualEditor - Toolbar - Undo-redo.png
Desfazer e Refazer as alterações que você fez.

VisualEditor Toolbar Headings-pt-br.png
Menu suspenso Títulos: permite a alteração da formatação do parágrafo. Para alterar o estilo de um parágrafo, posicione seu cursor no parágrafo e selecione um item neste menu (você não precisa selecionar o texto). Títulos de seção são formatados como “Cabeçalho”, e subseções como “Nível 2”, “Nível 3”, e assim por diante. A formatação normal para texto é o “Parágrafo”.

VisualEditor Toolbar Formatting-pt-br.png

Formatação: Ao clicar no “A”, um menu é aberto.

  • O item “Negrito” (B) destaca em negrito o texto selecionado.
  • O item “Itálico” (I) destaca em itálico o texto selecionado.
  • O item “Sobrescrito” (x2) faz com que o texto selecionado seja menor do que o texto não selecionado e um pouco acima dele.
  • O item “Subscrito” (x2) faz com que o texto selecionado seja menor do que o texto não selecionado e um pouco abaixo dele.
  • O item “Tachado” (S) adiciona uma barra horizontal no meio do texto selecionado.
  • O item “Código de computador” (um conjunto de chaves: {}) altera a fonte do texto selecionado para uma fonte mono-espaçada, que o diferencia do texto (proporcionalmente espaçado) não selecionado.
  • O item “Sublinhado” (U) adiciona uma barra horizontal abaixo do texto selecionado.
  • O item “Idioma” (Aあ) permite a rotulação do idioma (por exemplo, japonês) e a direção (por exemplo, da direita para a esquerda) do texto selecionado.
  • O último item (VisualEditor MediaWiki theme clear icon bitmap.png), denominado “Limpar formatação”, remove toda a formatação de caracteres do texto selecionado, incluindo ligações.

Se nenhum texto estiver selecionado, ao clicar no “A” para abrir o menu, e selecionar um item, a formatação será aplicada para o texto que for escrito após o cursor.


VisualEditor - Toolbar - Linking.png
Ferramenta de ligação: O ícone de corrente representa a ferramenta de ligação. Clicar nela (geralmente após selecionar algum texto) abre a caixa de diálogo de ligações.

VisualEditor - Cite Pulldown.png
Menu Citar: O menu “Citar” é usado para adicionar citações em linha (também chamadas de “notas de rodapé” ou “referências”). Todos os projetos têm acesso à formatação básica de referências e à habilidade de reusar citações com este menu. Este menu também dá um acesso rápido às predefinições de citação locais, caso estejam ativas na sua wiki.

(Instruções para adicionar predefinições de citação locais ao menu Citar em uma wiki específica estão disponíveis em VisualEditor/Ferramenta de citaçõesVisualEditor/Citation tool.)


Editor Visual - Menu Citar.png
Botão Citar: Se o serviço citoid estiver habilitado na sua wiki, você verá o botão Citar ao invés do menu Citar.

O serviço citoid tenta preencher predefinições de citação automaticamente.


VisualEditor Toolbar Lists and indentation-pt-br.png
Listas e indentação: Os dois primeiros itens permitem a formatação do texto em uma “Lista com marcadores” ou em uma “Lista numerada”. Os últimos dois itens permitem o aumento ou a diminuição do nível de indentação das listas.

VisualEditor Insert Menu-pt-br.png
Inserir: O menu “Inserir” pode ser mostrado diferentemente dependendo do projeto. Aqui está uma lista de todas as opções que poderão ser mostradas.
  • O ícone “Mídia” (uma imagem de montanhas) abre a caixa de diálogo de mídia.
  • O ícone “Predefinição” (uma peça de quebra-cabeças) permite a edição de predefinições.
  • O item “Tabela” permite que você insira uma tabela.
  • O item “Comentário” (uma balão de fala) permite a inserção de comentários ocultos aos leitores; estes comentários podem ser vistos apenas no modo de edição, quando estiverem sendo indicados por um ícone de ponto de exclamação. No modo edição, clique no ícone para editar ou apagar o comentário.
  • O ícone “Hieróglifos” (um símbolo ankh - ☥) permite a inserção de hieróglifos. (Veja abaixo.)
  • O item “Bloco de código” permite a inserção de código.
  • O item “Nota musical” permite a inserção de notas musicais.
  • O ícone “Galeria” (um conjunto de fotos) permite a inserção de uma galeria na página.
  • O ícone “⧼math-visualeditor-mwmathinspector-title⧽” (Σ) abre a caixa de diálogo de inserção de fórmula.
  • O item “Gráfico” permite a inserção de um gráfico.
  • O item “Sua assinatura” permite a inserção da sua assinatura da Wikipédia. Ele estará cinza (não selecionável) quando você estiver editando um espaço nominal, como uma artigo, onde assinaturas não devem ser inseridas.
  • O ícone “Lista de referências” (três livros) abre uma caixa de diálogo para especificação de onde as referências serão exibidas ao leitor. Geralmente, isto só precisa ser feito uma vez em cada página.

Inserção de caractere especial: O ícone “Caractere especial” (Ω) está próximo ao menu “Inserir”. Quando clicado, exibe uma caixa de diálogo mostrando vários caracteres especiais. Ao clicar em um caractere específico, ele será inserido no texto. Estes caracteres especiais incluem alguns símbolos, acentos, e símbolos matemáticos padrões. (Esta lista pode ser personalizada localmente. Veja VisualEditor/Special charactersVisualEditor/Special characters para instruções.)
VisualEditor Toolbar SpecialCharacters-pt-br.png

VisualEditor toolbar edit notices icon.png
O botão Avisos de edição exibe quaisquer avisos sobre a página.

VisualEditor More Settings-pt-br.png
O menu Opções da página está à esquerda do botão Salvar página. Neste menu, há opções para ajustar as configurações da página, como se a página é um redirecionamento ou não, ou como ela é indexada; para adicionar, editar, ou eliminar categorias; e para ver, usando o item “Idioma”, a lista de artigos do mesmo assunto em outros idiomas.

VisualEditor bi-directional switching square brackets icon.png
O botão alternar para edição do código-fonte está próximo do botão Salvar página. Ele permite que você alterne para o editor de wikitexto.

Salvando alterações

Ao término da edição, clique no botão azul “Salvar página” na barra de ferramentas. Se nenhuma alteração for feita, o botão permanecerá desabilitado (cinza). Para descartar todas as suas alterações, apenas feche a janela do seu navegador ou clique no separador “Ler”, acima da barra de edição.
VisualEditor toolbar actions-pt-br.png

Pressionar o botão azul “Salvar página” abre uma caixa de diálogo. Você pode inserir um breve sumário das suas ações, marcar sua edição como menor, e adicionar a página a sua Páginas vigiadas. A caixa para o sumário é equivalente ao campo Resumo da edição: no editor de código-fonte.

Você também pode revisar suas alterações usando o botão “Revisar suas alterações” para certificar-se de que elas funcionarão corretamente antes de salvá-las. Isto é semelhante ao botão “Mostrar alterações” no editor de código-fonte.

O botão “Continuar edição” retorna à página editada. Você pode salvar todas as suas alterações mais tarde.

VisualEditor save dialog-pt-br.png

Editando ligações

VisualEditor - Toolbar - Linking.png
Ligações podem ser adicionadas através do ícone “Link” (uma corrente) na barra de ferramentas, ou usando o atalho Ctrl+K (ou Command+K no Mac).

Se você selecionar um texto e então pressionar o botão “Link”, este será usado na criação da ligação. Para uma ligação que envolva apenas uma palavra, selecione esta palavra ou apenas posicione o cursor sobre ela.


VisualEditor-link tool-search results-pt-br.png
Ao usar o botão ou o atalho, uma caixa de diálogo abrirá, onde você poderá digitar a ligação.

A ferramenta de ligação tentará ajudar você com ligações internas procurando por prováveis correspondências.


Editor Visual ferramenta de ligação 2015.png
Uma vez inserido ou selecionado o link, complete o processo de ligação pressionando Enter ou o botão “Concluído”. A ligação imediatamente aparecerá na página do editor visual, mas assim como outras alterações na página, não será salva até que a página inteira seja salva.

Editor Visual-ferramenta de ligação-ligação externa.png
Para criar uma ligação a uma página da web em outro site, o processo é o mesmo: Escolha a aba “External link” e insira um URL na caixa.

Editor Visual – Ferramenta de ligação – Ligação simples.png
Ligações externas sem rótulos ficarão assim: [1]. Você pode adicioná-las colocando seu cursor longe de palavras (por exemplo, depois de um espaço). Abra a ferramenta de ligação clicando no botão ou pressionando o atalho de teclado. Digite o URL na caixa e clique no botão “Concluído” para inserir a ligação.

Editor Visual-menu contextual-ferramenta de ligação.png
Para alterar ou remover uma ligação existente, clique no texto da ligação e em seguida pressione o ícone “Link” que aparece próximo dele. A caixa de diálogo aparecerá, para edição. (Você também pode abrir a caixa de diálogo com o atalho de teclado Ctrl+K.) Quando uma ligação for selecionada, ela aparece destacada em azul.

Na caixa de diálogo da edição da ligação, você pode então alterar o destino da ligação. Você também pode removê-la por completo pressionando o botão “Remover” no canto superior direito da caixa. Você também pode abrir o destino da ligação em outra janela clicando na cópia dela na caixa de diálogo. (Você poderá usar isto para verificar se uma ligação externa está funcionando.)

Caso queira sair do rótulo da ligação (o texto exibido como ligação) ou continuar a escrever após esta ligação, pressione :

  • Pressione-a uma vez para sair da caixa de diálogo de edição da ligação e posicionar seu cursor no final do elemento ligado (destacado em azul, para editar este elemento);
  • Pressione-a duas vezes para posicionar o cursor após o elemento ligado, preparado para digitar o resto do texto.

Para editar o rótulo de uma ligação existente, clique nele e escreva um novo rótulo. Caso você deseje substituir o rótulo inteiro, note que:

  • Se o rótulo inteiro estiver selecionado (destacado), a ligação será apagada ao pressionar qualquer tecla. É possível ligar do começo.
  • Para manter a ligação, clique no rótulo, pressione ou Del uma vez, e apenas o URL restará. Então, será possível inserir um novo rótulo para a ligação mantida.

Editando referências

Para mais informações, veja ajuda para predefinições de citação ou ajuda para o botão Citar

Determinando qual sistema está em vigor

Sua wiki pode usar um dos três sistemas de notas de rodapé. O exibido à direita é o sistema mais simples, onde o menu “Citar” não inclui nenhuma predefinição de citação. Caso sua wiki use este sistema, tudo que você precisará saber sobre notas de rodapé está nesta página.
VisualEditor cite menu default.png

O segundo sistema tem o mesmo tipo do menu “Citar”, mas com várias predefinições populares de citação para acesso rápido. Caso sua wiki use este sistema, você poderá encontrar mais detalhes em Ajuda:Editor Visual/Guia do usuário/Citações-Predefinições.
VisualEditor references more.png

Editor Visual – Botão Citar.png
No terceiro sistema, comece clicando novamente no botão Citar. Em seguida, é aberta uma caixa de diálogo que possui um processo de citação automática que usa o serviço citoid. Se sua wiki usar esse sistema, mais detalhes serão encontrados em Ajuda:Editor Visual/Guia do usuário/Citações-CompletoHelp:VisualEditor/User guide/Citations-Full.
Editor Visual – Aba automática do Citoid.png

Editando uma referência existente

Para editar uma referência existente, clique onde ela aparece no texto (geralmente como um número entre colchetes). Você verá um ícone “Referência” (marcador) ou um ícone (e nome) para a predefinição usada para criar esta referência. Em ambos os casos, clicar no botão “Editar” abrirá uma caixa de diálogo onde você poderá editar a referência.
Editor Visual - Editando referências 1.png

Para o ícone “Referência”, clicar em “Editar” abrirá a caixa de diálogo Referência. Para começar a alterar as informações da referência, clique.

Muitas wikis usam predefinições para formatar referências. Se uma predefinição for usada na sua referência, ao mover o cursor sobre informações da referência, todas as informações naquele campo estarão destacadas.

Se uma predefinição for usada e você clicar nas informações da referência, o ícone Predefinição (peça de quebra-cabeças) aparecerá com algumas delas. Clique no botão “Editar” para editar o conteúdo da predefinição na caixa de diálogo do mini-editor da predefinição.

Editor Visual - Editando referências 6.PNG

Se o que aparecer ao clicar em uma referência for um ícone para a predefinição padrão para citações (exemplo à direita), clicar no botão “Editar” abrirá a caixa de diálogo do mini-editor da predefinição.
VisualEditor - Editing References - Cite Web.png

Dentro do mini-editor da predefinição, você poderá adicionar ou remover tipos de informação ou alterar o conteúdo atual. Apenas campos (parâmetros da predefinição) que têm conteúdo serão mostrados inicialmente. Para adicionar campos, clique em “Adicionar mais informações” na parte inferior do mini-editor.
VisualEditor - Editing references 5.png

Ao terminar, clique em “Aplicar mudanças”.
VisualEditor Apply Changes-en.png

Reutilizando uma referência existente

Se a página já possuir uma citação que se aplica ao texto, você poderá reutilizar aquela citação existente.

Para reutilizar uma referência existente, posicione o cursor no corpo do texto onde você deseja adicionar uma nova referência (número) para esta citação. Em seguida, clique no item “Reusar referência” no menu “Citar”.

(Nota: Caso sua wiki use o terceiro sistema de notas de rodapé descrito acima, você verá a guia “Reusar” numa caixa de diálogo ao invés de estar no menu “Citar”.)

VisualEditor Cite menu re-use.png

Na caixa de diálogo Referência, ache na lista a referência que você quer reutilizar e selecione-a. Se há muitas referências, use a caixa de pesquisa (rotulada “Buscar dentro das citações atuais”) para listar apenas referências que incluam certo texto.
VisualEditor - Editing references 18.png

Adicionando uma nova referência

Para adicionar uma citação usando o menu “Citar”, posicione seu cursor onde deseja adiciona-la no texto. Em seguida, selecione o tipo apropriado de citação no menu.
VisualEditor references more.png

Usando a citação “Básica”

O exibido aqui é o que você verá caso selecionar o item de referência básica. No editor Referência, você pode adicionar e formatar sua citação.

Você pode fazer com que a sua referência pertença a um certo grupo, apesar de geralmente não ser especificado nenhum. (Esta opção é usada para exibir grupos de referências com a ferramenta “Lista de referências”.)

VisualEditor - Editing references 20.png

Na caixa de diálogo Referência, caso queira incluir uma predefinição de citação (ou qualquer outra) na sua nova referência, clique no ícone Predefinição (peça de quebra-cabeças) no menu “Inserir” da barra de ferramentas do editor Referência.
VisualEditor Template Insert Menu-pt-br.png

Em seguida, ache a predefinição que quer usar, adicione-a e edite-a como faria com qualquer outra. (Veja a seção Editando predefinições abaixo se necessitar de mais informações sobre elas.)

Após o término da edição da nova predefinição, clique em “Aplicar mudanças” para retornar ao editor Referência, e novamente clique em “Aplicar mudanças” para retornar à página que você está editando.

VisualEditor - Editing references 9.png

Se ainda não há uma lista de referências na página (por exemplo, se você está inserindo a primeira referência para a página), você precisa especificar onde ela e seu texto serão exibidos ao leitor.

Posicione o cursor onde você deseja exibir a lista de referências (geralmente no final da página), abra o menu “Inserir” e clique no ícone “Lista de referências” (três livros).

VisualEditor References List Insert Menu-pt-br.png

Caso esteja usando vários grupos de referências, o que é geralmente raro, você poderá especificar o grupo nesta caixa de diálogo. Apenas as referências pertencentes àquele grupo serão exibidas no local onde está localizado o grupo.

O último passo na caixa de diálogo da Lista de referências é clicar em “Inserir”.

VisualEditor references list-pt-br.png

Usando predefinições de citação padrões

Sua wiki local pode ter adicionado predefinições de citação extras ao menu “Citar”. Caso isto tenha ocorrido, você terá acesso rápido às predefinições de citação mais usadas na sua wiki. (Instruções para adicionar predefinições de citação extras à sua wiki local estão disponíveis em VisualEditor/Citation tool/pt-br.)
VisualEditor - Editing References - Cite Pulldown.png

Clicar em um ícone de predefinição como “Citar livro” lhe levará ao mini-editor de predefinições para a mesma. Campos de informação importantes poderão estar marcados com um asterisco. Embora sejam mostrados os campos mais comuns, nem todos serão necessários.
VisualEditor - Editing references - Cite book required fields.png

Para adicionar mais parâmetros, vá para o fim do mini-editor de predefinições e clique na opção “Adicionar mais informações”.

Ao terminar, clique em “Inserir”.

VisualEditor - Editing references - Add parameter.png

Editando imagens e outros arquivos de mídia

Editando imagens

Para adicionar uma nova imagem (ou outro tipo de arquivo de mídia) na página, clique no ícone “Mídia” (uma imagem de montanhas) no menu “Inserir”. A imagem será inserida onde quer que o cursor esteja.
VisualEditor Media Insert Menu-pt-br.png

Clicar no ícone “Mídia” abrirá uma caixa de diálogo que pesquisa automaticamente no Wikimedia Commons e na sua wiki local arquivos de mídia relacionados à página que você está editando.

Você pode alterar a pesquisa alterando o texto na caixa de pesquisa da caixa de diálogo.

Para escolher um arquivo, clique em sua miniatura.

Isto colocará a imagem na página que você está editando.

VisualEditor - Media editing 2.png

Após a inserção da imagem selecionada na página, outra caixa de diálogo se abrirá. Esta caixa permitirá que você adicione e edite a legenda da imagem, que poderá conter formatação e ligações.
VisualEditor - Media editing 6.png

A caixa de diálogo de mídia também permitirá que você adicione legendas alternativas, para ajudar usuários com leitores de tela ou com a exibição de imagens desabilitada.
VisualEditor - Media editing 7.png

Você também pode definir vários parâmetros para a imagem na janela "Configurações avançadas", que incluem o alinhamento, o tipo e o tamanho da imagem.
VisualEditor - Media editing 8.png

Ao terminar, clique em "Aplicar mudanças" para fechar a caixa de diálogo e retornar a editar a página.
VisualEditor Apply Changes-en.png

Para uma imagem existente, você pode adicionar ou editar uma legenda ou outras configurações clicando na imagem e em seguida no ícone "Mídia" que aparece abaixo da imagem.

Você pode redimensionar uma imagem existente clicando nela e em seguida movendo o ícone de redimensionamento (a seta de duas pontas no(s) canto(s) inferior(es)).

Você também pode arrastar e soltar uma imagem para qualquer outro local da página.

VisualEditor - Media editing 3.png

Enviando imagens

Você pode enviar imagens a partir de uma aba na caixa de diálogo de mídia.
VisualEditor - Media upload 1.PNG

Clique na aba “Enviar” e selecione uma imagem de seu computador. Você pode digitar o nome do arquivo ou arrastar uma imagem à caixa.
VisualEditor - Media upload 1.PNG

Você deve descrever a imagem e adicionar categorias à ela para que outras pessoas possam encontrá-la.
VisualEditor - Media upload 1.PNG

A imagem será inserida na página ao terminar.
VisualEditor-logo.svg

Editando galerias de mídia

Para adicionar uma nova galeria, clique no ícone “Galeria” (um conjunto de fotos) no menu “Inserir”. (Caso não ver este ícone neste menu, então sua wiki local decidiu adiar a implementação desta funcionalidade no editor visual.)
VisualEditor - Gallery1.png

Para editar uma galeria no Editor Visual, clique nela. Em seguida, próximo ao fim da mesma, clique no ícone galeria (um conjunto de fotos) para abrir o editor dela, com a lista completa de imagens incluídas na galeria.
VisualEditor - Gallery2.png
Atualmente, o editor da galeria é uma caixa simples que permite a edição de galerias existentes usando a marcação de wikitexto. Para adicionar uma nova imagem a uma galeria existente, digite o nome do arquivo, seguido por uma barra vertical (|) e pela legenda da imagem. Você deve colocar cada imagem na galeria em sua própria linha. Você também pode editar esta lista para remover ou reorganizar imagens, ou para alterar legendas.

Ao clicar no botão “Concluído”, você sairá do editor da galeria. Em seguida, você verá suas alterações, uma vez que a galeria será mostrada para leitores.

Lembre-se que sair do editor da galeria não salva suas alterações. Assim como em outras alterações feitas usando o editor visual, você deve salvar a página inteira para salvar seu trabalho.

VisualEditor - Gallery3.png

Editando predefinições

Começando

Para adicionar uma nova predefinição à página, posicione o cursor onde você quer que sua predefinição seja inserida e clique no ícone "Predefinição" (peça de quebra-cabeças) no menu "Inserir".
VisualEditor Template Insert Menu-pt-br.png

Digite o nome da predefinição que você quer inserir. Ao vê-la na lista, clique em seu nome. Em seguida, clique em "Adicionar predefinição".
VisualEditor - Template editing 4.png

Você também pode editar uma predefinição que já esteja na página. Ao clicar na predefinição para selecioná-la, ela se tornará azul, e uma caixa aparecerá com o ícone “Predefinição” (peça de quebra-cabeças). Então, clique na ligação “Editar”.
VisualEditor - Template editing 1.png

Algumas predefinições não são visíveis para quem lê uma página. No editor visual, estas predefinições ocultas são mostradas como ícones de quebra-cabeça. O nome da predefinição é mostrado ao lado do ícone de quebra-cabeça.
VisualEditor template not visible.png

Ao selecionar o ícone, o menu de contexto é exibido, onde você pode editar a predefinição.
VisualEditor template not visible context menu.png

Parâmetros da predefinição

Ao adicionar uma nova predefinição ou abrir uma já existente, a caixa de diálogo “Transclusão” é aberta. O conteúdo mostrado depende se a predefinição foi ou não documentada no sistema TemplateDataExtension:TemplateData.

O template mostrado aqui não possui dados TemplateData definidos para ela. O diálogo, portanto, fornece um link para a documentação do template. Ao visitar a documentação você deve ser capaz de compreender se o template tem quaisquer parâmetros (campos) e o que vai em cada campo. Use números como o nome para cada parâmetro sem nome. O primeiro parâmetro sem nome é denominado 1, o segundo é denominado 2, e assim por diante.
VisualEditor template with no TemplateData.png

Se um template foi atualizado para conter informação TemplateData, então o diálogo mostrará uma lista de parâmetros individuais (nomeados).
VisualEditor template with TemplateData.png

Para uma predefinição existente, você pode editar os parâmetros mostrados na caixa de diálogo e adicionar parâmetros adicionais clicando em “Adicionar mais informações”, na parte inferior da caixa.
VisualEditor - Template editing 3.png

Quando uma predefinição inclui outras predefinições, estas sub-predefinições aparecerão como parâmetros. Estas podem ser editadas ou removidas clicando no nome da sub-predefinição.

Novas sub-predefinições são adicionadas seguindo os passos de adicionar um parâmetro. Você deve verificar a documentação da predefinição para se assegurar que a sub-predefinição é compatível.

VisualEditor - Template editing 5.png

Terminando

Ao concluir a edição da predefinição, clique em “Aplicar mudanças” para fechar a caixa de diálogo e retornar à edição da página principal.
VisualEditor Apply Changes-en.png

Substituindo predefinições

Quando uma predefinição têm que ser substituída, digite subst: (incluindo os dois pontos) antes do nome da predefinição.

Autocomplemento não funciona com subst:. Se quiser usar o autocomplemento, primeiro encontre a predefinição que procura e então adicione subst: na frente do nome dela.

Em seguida, clique no botão azul “Adicionar predefinição”.

Como sempre, adicione os parâmetros e clique em “Inserir”.

VisualEditor - Template editing 7.png

Você verá a predefinição expandir na página após clicar em “Aplicar mudanças”.
VisualEditor - Template editing 8.png

Editando listas

VisualEditor Toolbar Lists and indentation-pt-br.png
Você pode usar o editor visual para criar listas ou para mudar o formato de uma lista existente. Há dois tipos de lista: não-ordenadas (pontuadas) e ordenadas (enumeradas).

Para começar uma nova lista, apenas clique em um dos dois itens do menu mostrados aqui. Ou, se você já digitou a lista (em linhas separadas), selecione (marque) a lista que você digitou e então clique em um dos itens do menu.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Aqui são mostrados exemplos dos dois tipos de listas: não-ordenadas (pontuadas) e ordenadas (enumeradas).

VisualEditor lists 3 select to indent.png
Se você quiser mudar o nível de indentação de parte de uma lista existente, selecione a parte da lista que você deseja modificar.

VisualEditor lists 4 indentation menu.png
Então use o menu ou pressione a tecla Tab. (A tecla Tab aumenta a indentação; use a tecla shift junto à tecla Tab para diminuir a indentação).

VisualEditor lists after indenting.png
Aqui está o resultado do aumento de indentação:

VisualEditor lists mixed.png
Você pode até misturar listas ordenadas (enumeradas) e não-ordenadas (pontuadas), se os itens da lista tiverem indentações diferentes.

Editando tabelas

VisualEditor insert table.png
Você pode usar o Editor Visual para inserir e alterar tabelas.

Pode, inclusive, importar uma tabela movendo um arquivo de valores separados por vírgula (.csv) de seu computador à janela de edição principal.


Ao clicar em “Tabela”, no menu “Inserir”, o Editor Visual insere uma tabela quatro-por-quatro em branco.

Agora o menu "Tabela" está disponível. Deste menu, você pode adicionar uma legenda ao topo da tabela.

VisualEditor empty table.png

Para selecionar uma célula, clique nela uma vez.
VisualEditor tables select one cell.png

Para editar o conteúdo da célula (por exemplo, para adicionar conteúdo ou corrigir um erro de ortografia), clique duas vezes na célula. Ou você pode selecionar a célular e pressionar Return.

Para terminar a sua edição de uma célula, apenas clique em outro lugar.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Você pode adicionar e remover uma coluna ou linha.

Você pode juntar células: selecione-as, e então do menu Tabela, clique em "Juntar células".
VisualEditor tables merge cells.png

Se você juntar células, apenas um texto em uma célula é mantido; qualquer texto em outras células é excluído quando você junta as células. Se você decidir que você deseja algum ou todo o texto que foi excluído, use o botão Desfazer, mova ou copie o texto que você quer, e então junte as células novamente.
VisualEditor tables post-merge cell.png

Você pode também separar células que foram juntadas anteriormente. Todo o conteúdo que estava na célula unida permanecerá na primeira célula quando você fizer a separação. Você pode então cortar e copiar texto de outras células, se você quiser.
VisualEditor tables split cells.png

Editando categorias

VisualEditor category item-pt-br.png
Para editar categorias, no menu “Opções da página”, clique no item “Categorias”.

VisualEditor category editing-en.png
Clicar em "Categorias" abrirá uma caixa de diálogo que lista categorias existentes e permite que você adicione novas ou remova as existentes.

Você também tem a opção de configurar ou alterar a chave de ordenamento geral (padrão), que determina onde a página aparece quando listada com outras páginas na mesma categoria.

Por exemplo, a chave de ordenamento padrão para o artigo “George Washington” é “Washington, George”. Na categoria “Presidentes dos Estados Unidos”, o artigo é listado abaixo da letra “W”, não “G”.


VisualEditor - Category editing 3.png
Para adicionar uma categoria para uma página, digite o nome da categoria no campo "Adicionar uma categoria". Enquanto digita, o Editor Visual pesquisará por possíveis categorias existentes. Você pode tanto selecionar uma categoria existente quanto adicionar uma que ainda não tem página própria. (Até que essa categoria for criada, a nova será mostrada como uma ligação em vermelho após salvar suas alterações.)

VisualEditor - Category editing 2.png
Para remover uma categoria existente, clique nela e no ícone "Remover" (lata de lixo) na caixa de diálogo que aparecerá.

Clicar em uma categoria também lhe permite especificar uma chave de ordenamento para aquela categoria específica. Tal chave substitui a padrão.


VisualEditor Apply Changes-en.png
Clique em "Aplicar mudanças" ao terminar de editar categorias para retornar ao editor.

Editando configurações da página

VisualEditor page settings item-pt-br.png
Para editar as configurações de uma página, clique para abrir o menu "Configurações da página", na barra de ferramentas, e selecione o botão "Configurações da página".

VisualEditor Page Settings-en.png
O botão "Configurações da página" abre uma caixa de diálogo que mostra várias opções.

VisualEditor Page Settings Redirects-en.png
Você pode fazer com que uma página se torne uma página de redirecionamento marcando a caixa de seleção "Redirecionar essa página para", e em seguida digitando o nome da página onde você deseja redirecionar o usuário para.

Na parte inferior está a opção para evitar a atualização do redirecionamento. Isto não é muito utilizado.


VisualEditor Page Settings TOC-en.png
Você pode alterar se a página exibirá ou não um Índice selecionando um desses três botões. A opção padrão é "Se necessário", que mostra um Índice se houver três ou mais seções.

VisualEditor Page Settings Edit Links-en.png
Você pode fazer com que uma não mostre links de edição ao lado de cada título de seção marcando esta caixa de seleção.

VisualEditor Apply Changes-en.png
Clique em "Aplicar mudanças" ao término da edição das Opções da página para retornar ao editor.

Editando fórmulas matemáticas

Para adicionar uma nova fórmula matemática à página, posicione o cursor onde deseja que ela seja inserida e clique no ícone "⧼math-visualeditor-mwmathinspector-title⧽" ("Σ") no menu "Inserir" na barra de ferramentas.
VisualEditor Formula Insert Menu-pt-br.png

Uma janela se abrirá, onde você poderá digitar a fórmula, usando a sintaxe LaTeX. O Editor Visual atualizará a fórmula enquanto você a escreve para que você possa ver como ela se parecerá na medida que você faz alterações. Uma vez satisfeito com a fórmula, clique no botão "Concluído".
VisualEditor formula-pt-br.png

Para editar uma fórmula matemática existente na página, clique nela e em seguida clique no ícone "Σ" que aparecerá. Isto abrirá a janela de fórmula, onde é possível fazer alterações.
VisualEditor - editing existing mathematical formula.png

Fórmulas matemáticas podem ser posicionadas alinhadas ou centralizadas como um bloco.
VisualEditor mathematic formula inline.png

Editando partituras musicais

Para adicionar uma nova notação musical a uma página, posicione o seu cursor onde você quer que a notação musical seja inserida. Então, do menu "Inserir" na barra de ferramentas, clique na opção "Notação musical".

Para editar uma notação musical existente na página, clique duas vezes nela.

VisualEditor-Insert-Musical-Notation.png

Isso irá abrir o diálogo de "Notação musical". Aqui a notação pode ser editada por escala, ou no formato ABC ou no formato Lilypond. Você também pode ligar a notação a um áudio ou arquivo MIDI. Uma vez que você terminou, clique no botão "Pronto" para fechar o diálogo e salvar as suas mudanças.
Musical.png

Editar poemas e outros itens especiais

Alguns itens, tais como listas de associação e poemas, ainda não são totalmente compatíveis com o editor visual.
VisualEditor editing poem 1.png

Na maioria dos casos, os itens existentes podem ser editados, mas novos não podem ser inseridos no Editor Visual.

Até que sejam totalmente compatíveis, você pode copiar um já existente de outra página, ou editar diretamente do editor de código-fonte.

VisualEditor editing poem 2.png

Mudando entre os editores visual e de wikitexto

Para mudar do editor visual para o editor de wikitexto, clique no botão [[ ]] na extrema direita da barra de ferramentas.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

Se você já fez qualquer edição, você será questionado se quer manter as suas mudanças. Normalmente, você clicará em "Manter mudanças".

VisualEditor bi-directional switching to wikitext.png

Você verá uma diferença. (Se você clicou em "Descartar mudanças", você verá apenas wikitexto, pronto para edição com o seu editor de wikitexto.)

Avance para baixo e você verá a área de edição de wikitexto.

VisualEditor bi-directional switching diff before wikitext.png

Você também pode mudar do editor de wikitexto para o editor visual. Para fazer isso, clique no ícone de lápis na extrema direita da barra de ferramentas.

VisualEditor bi-directional switching pencil icon in wikitext.png

Depois de você clicar no ícone de lápis, se você tiver feito qualquer edição você será questionado se quer manter as suas mudanças. Se você clicar em "Manter mudanças", você irá para o editor visual. Se você clicar em "Descartar mudanças", você será solicitado a confirmar que é o que você quer fazer (clique em "Sair da página" para confirmar) antes que o editor visual se inicie.

VisualEditor bi-directional switching to visual editing.png

Atalhos de teclado

Muitos editores estão acostumados a inserir wikitexto diretamente, especialmente negrito, itálico e ligações internas. Atalhos de teclado permitem rapidamente inserir formatações similares sem ter de usar itens da barra de ferramentas. Aqui estão os atalhos mais comuns no Editor Visual:

Atalho para PC Ação Atalho para Mac

Ctrl+B Negrito Cmd+B

Ctrl+I Itálico Cmd+I

Ctrl+K Inserir link Cmd+K

Ctrl+X Recortar Cmd+X

Ctrl+C Copiar Cmd+C

Ctrl+V Colar Cmd+V

Ctrl+Z Desfazer Cmd+Z