Help:Visuele tekstverwerker/Gebruikershandleiding

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 95% complete.

Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Bahasa Melayu • ‎Basa Jawa • ‎Basa Sunda • ‎Bikol Central • ‎Cebuano • ‎Cymraeg • ‎Deutsch • ‎English • ‎Esperanto • ‎Fiji Hindi • ‎Frysk • ‎Ilokano • ‎Interlingue • ‎Lëtzebuergesch • ‎Malagasy • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Napulitano • ‎Nederlands • ‎Oromoo • ‎Picard • ‎Scots • ‎Tagalog • ‎Tiếng Việt • ‎Tûnsî • ‎Türkçe • ‎Yorùbá • ‎Zazaki • ‎asturianu • ‎azərbaycanca • ‎be-tarask • ‎bosanski • ‎català • ‎dansk • ‎eesti • ‎emiliàn e rumagnòl • ‎español • ‎euskara • ‎français • ‎furlan • ‎føroyskt • ‎galego • ‎hrvatski • ‎isiXhosa • ‎italiano • ‎latviešu • ‎lietuvių • ‎magyar • ‎norsk bokmål • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎shqip • ‎slovenčina • ‎slovenščina • ‎suomi • ‎svenska • ‎čeština • ‎Ελληνικά • ‎български • ‎македонски • ‎русский • ‎саха тыла • ‎српски / srpski • ‎татарча/tatarça • ‎українська • ‎հայերեն • ‎ייִדיש • ‎עברית • ‎العربية • ‎تۆرکجه • ‎سنڌي • ‎فارسی • ‎پښتو • ‎मराठी • ‎मैथिली • ‎संस्कृतम् • ‎हिन्दी • ‎অসমীয়া • ‎বাংলা • ‎মেইতেই লোন্ • ‎ਪੰਜਾਬੀ • ‎ଓଡ଼ିଆ • ‎தமிழ் • ‎తెలుగు • ‎ಕನ್ನಡ • ‎മലയാളം • ‎ไทย • ‎မြန်မာဘာသာ • ‎ქართული • ‎ភាសាខ្មែរ • ‎中文 • ‎日本語 • ‎한국어
PD Let op: Als u deze pagina bewerkt, gaat u akkoord met het vrijgeven van uw bijdragen onder de CC0. Zie Publiek Domein Helppagina's voor meer informatie.
PD
Voor het geval u de visuele tekstverwerker wilt uitproberen zonder een artikel te bewerken is hier in een zandbakpagina voorzien. U heeft geen account nodig om de visuele tekstverwerker op die pagina te gebruiken.


De visuele tekstverwerker openen

Om een pagina met de visuele tekstverwerker te bewerken klikt u op "Bewerken" bovenaan de pagina.

Het openen van de pagina om deze te bewerken kan enkele seconden duren, of langer wanneer de pagina erg groot is.

Klikken op het tabblad "Brontekst bewerken" opent de klassieke wikitekstverwerker.

VisualEditor edit tab-nl.png

U kunt de visuele tekstverwerker ook openen door naast een paragraafkop op "bewerken" te klikken.
VisualEditor - Section edit links-en.png

Aan de slag: de werkbalk van de visuele tekstverwerker

Schermafbeelding van de werkbalk van de visuele tekstverwerker
De werkbalk van de visuele tekstverwerker verschijnt bovenaan uw scherm zodra u met deze tekstverwerker aan de slag gaat. De werkbalk bevat enkele bekende pictogrammen:

VisualEditor - Toolbar - Undo-redo.png
Ongedaan maken en Opnieuw uitvoeren van de wijzigingen die u hebt aangebracht.

VisualEditor Toolbar Headings-nl.png
De keuzelijst Koppen: Maakt het mogelijk het kopniveau te wijzigen. De standaardsectiekop is "Kopje". Subsectiekoppen zijn "Onderkop 1", "Onderkop 2", enzovoort. Het normale tekstformaat is "Paragraaf".

VisualEditor Toolbar Formatting-nl.png

Opmaak: Door op "A" te klikken opent u een menu.

  • "Vet" (V) maakt de geselecteerde tekst vetgedrukt.
  • "Cursief" (C) maakt de geselecteerde tekst cursief.
  • "Superscript" (x2) maakt de geselecteerde tekst kleiner en plaatst deze iets hoger dan de rest van de tekst.
  • "Subscript" (x2) maakt de geselecteerde tekst kleiner en plaatst deze iets lager dan de rest van de tekst.
  • "Doorhalen" (S) plaatst een volle lijn door de geselecteerde tekst.
  • "Computercode" (twee accolades: {}) verandert het lettertype van de geselecteerde tekst in monospace. Dit onderscheidt het van de rest van de tekst.
  • "Onderstrepen" (U) onderstreept de geselecteerde tekst.
  • "Taal" (文A) wordt gebruikt om de taal (bijvoorbeeld Japans) en de schrijfrichting (bijvoorbeeld rechts naar links) van de geselecteerde tekst te labelen.
  • Verwijderen (VisualEditor MediaWiki theme clear icon bitmap.png) verwijdert alle opmaak in de geselecteerde tekst, inclusief links.

Wanneer u geen tekst geselecteerd heeft en u op de knop "A" klikt om het menu te openen en een item selecteert, zal die opmaak worden toegepast wanneer u begint met typen.


VisualEditor - Toolbar - Linking.png
Linkhulpmiddel: de 'kettingschakel' is het linkhulpmiddel. Als u hierop klikt (meestal nadat u een tekst geselecteerd heeft) wordt een dialoogvenster geopend.

VisualEditor - Cite Pulldown.png
Citeren menu: Het menu "Citeren" wordt gebruikt om voetnoten en referenties in de lopende tekst in te voegen. Op elk project bestaat de mogelijkheid om via dit menu een "$basic" aan referenties toe te voegen en om citaten te hergebruiken. Het menu bevat ook snelkoppelingen naar lokale referentiesjablonen, als deze geactiveerd zijn op uw wiki.

(Instructies voor het toevoegen van lokale referentiesjablonen aan het menu Citeren zijn te vinden op VisualEditor/Citation tool .)


VisualEditor citoid Cite button-nl.png
Citeren knop: Als de Citoid service is ingeschakeld op uw wiki, dan ziet u een Citeren knop, in plaats van een Citeren menu

De Citoid service zal proberen om referentiesjablonen automatisch in te vullen.


VisualEditor Toolbar Lists and indentation-nl.png
Lijsten en inspringen: De eerste twee pictogrammen maken het mogelijk respectievelijk een "Ongenummerde lijst" of "Genummerde lijst" te maken. De laatste twee dienen om de inspringing te verkleinen of vergroten.

VisualEditor Insert Menu-nl.png
Invoegen: dit menu kan verschillen tussen de projecten. Hieronder staat een lijst van alle mogelijke opties die er kunnen verschijnen.
  • "Media" (een afbeelding van een berglandschap) opent het media-dialoogvenster.
  • "Sjabloon" (een puzzelstuk) wordt gebruikt om sjablonen te bewerken
  • Met "Tabel" kunt u een tabel invoegen.
  • "Opmerking" (een tekstballon) wordt gebruikt om onzichtbare commentaren op de pagina in te voegen; deze zijn enkel zichtbaar in de bewerkingsmodus, waar ze worden aangegeven met een uitroepteken. In de bewerkingsmodus kan men op het uitroepteken klikken om de opmerking aan te passen of te verwijderen.
  • "Hiërogliefen" (een ankh - ☥) opent de hiërogliefenbewerker (zie onder).
  • Met "Codeblok" kunt u code invoegen.
  • "Muzieknotatie" stelt u in staat om bladmuziek toe te voegen.
  • "Galerij" (een reeks foto's) creëert een galerij van foto's op de pagina.
  • "Wiskundige formule" (Σ) opent het dialoogvenster voor wiskundige formules.
  • Met "Grafiek" kunt u een grafiek invoegen.
  • Met "Uw handtekening" kunt u uw bijdragen ondertekenen. Deze knop wordt grijs gemaakt wanneer u een pagina bewerkt waar handtekeningen niet zouden moeten worden toegevoegd, bijvoorbeeld een artikel.
  • "Referentielijst" (drie boeken) opent een dialoogvenster waarin u kunt aangeven op welke plaats de bronvermelding komt te staan. Dit hoeft meestal maar een keer per pagina te worden gedaan.

Invoegen van speciale tekens: de knop "Speciaal teken" in het menu "Invoegen" opent een dialoogvenster met verschillende speciale tekens. Door op een van de tekens te klikken wordt dat teken in de tekst ingevoegd. Deze lijst bevat standaardsymbolen, accenten en wiskundige symbolen. (Deze lijst kan lokaal worden aangepast. Zie VisualEditor/Special characters voor meer informatie.)
VisualEditor Toolbar SpecialCharacters-nl.png

VisualEditor toolbar edit notices icon.png
De "Meldingen"-knop toont eventuele meldingen voor de pagina.

VisualEditor More Settings-nl.png

Het menu Pagina-instellingen bevindt zich links van de knop Wijzigingen publiceren. Dit menu bevat opties om pagina-instellingen (zoals een eventuele doorverwijzing of indexering) te veranderen; om categorieën toe te voegen, te bewerken of te verwijderen; en om, via "$language", een lijst te krijgen van dezelfde artikels in andere talen.

  • Categorieën allows you to add categories to this page and to adjust how the page is sorted, when displayed within a category by setting a different index to sort with.
  • Pagina-instellingen allows you to make the page a redirect and adjust options of this redirect, to adjust settings regarding the displaying of the Table of Contents, to disable the edit links next to each heading, and to define the page as a disambiguation page.
  • Advanced settings allows you to adjust the settings regarding indexation of the page by search engines, showing a tab to add a new section, and the displayed title.
  • Taals which shows a list of pages in other languages that are linked to that page.
  • Templates used shows a list of links to each template used on this page.

The tabs of the Options dialog are also displayed in the Pagina-instellingen menu and can be opened by clicking on it. Furthermore the Pagina-instellingen menu contains the button View as right-to-left and the button Find and replace which opens a dialog where you can insert characters, terms or Regular expressions you are searching for and those to replace them with, together with several buttons for options.


VisualEditor bi-directional switching square brackets icon.png
De knop overschakelen op broncode bewerken zit naast de knop Wijzigingen publiceren. Hiermee kunt u overschakelen op de wikitekstverwerker.

Wijzigingen publiceren

Wanneer u klaar bent met bewerken klikt u op de blauwe knop "Wijzigingen publiceren". Zolang u geen wijzigingen heeft aangebracht is deze knop grijs gemaakt. Om alle wijzigingen te annuleren kunt u gewoon uw browservenster sluiten. U kunt ook boven de werkbalk op de knop "Lezen" klikken.
VisualEditor toolbar actions-nl.png

Wanneer u op de blauwe knop "Wijzigingen publiceren" klikt wordt er een dialoogvenster geopend. Hierin kunt u uw bewerking samenvatten, de bewerking markeren als kleine wijziging, en/of de pagina aan uw Volglijst toevoegen. Het veld voor de samenvatting is het equivalent van het veld "Samenvatting:" in de normale wikitextverwerker.

Alvorens uw wijzigingen op te slaan kunt u de knop "Wijzigingen controleren" gebruiken om te bevestigen dat ze het gewenste resultaat geven. Dit is het equivalent van de knop "Wijzigingen bekijken" in de wikitextverwerker.

"Doorgaan met bewerken" brengt u terug naar de bewerkingspagina. U kunt uw wijzigingen later opslaan.

VisualEditor save dialog-nl.png

Links bewerken

VisualEditor - Toolbar - Linking.png
Links kunnen worden toegevoegd door te klikken op het "Koppeling"-pictogram (kettingschakels) op de werkbalk of door de sneltoets Ctrl+K (of Command+K op een Mac) te gebruiken.

U kunt bestaande tekst gebruiken om een link te maken door deze te selecteren en op "Koppeling" te klikken. Voor een link die slechts uit een enkel woord bestaat kunt u dat woord selecteren of uw cursor in dat woord plaatsen.


VisualEditor-link tool-search results-nl.png
Met de knop of sneltoets wordt een dialoogvenster geopend waarin u de link kunt typen.

Het linkhulpmiddel zal waar mogelijk helpen met interne links door suggesties te doen terwijl u typt.


VisualEditor link tool 2015.png
Wanneer u een link heeft ingevoerd of geselecteerd kunt u op Enter drukken, buiten het dialoogvenster klikken of op de knop "Afgerond" drukken. De link zal dan op de pagina verschijnen, maar pas worden opgeslagen wanneer u de volledige pagina opslaat.

VisualEditor-link tool-external link.png
Linken naar een webpagina buiten Wikipedia gaat op ongeveer dezelfde manier: kies het tabblad "Externe koppeling" en geef de URL in het tekstvak in.

VisualEditor link tool simple link.png
Externe links zonder labels zien er als volgt uit: [1] Deze kunnen worden toegevoegd door uw cursor buiten een woord te plaatsen (bijvoorbeeld na een spatie). Open het linkhulpmiddel door op de knop te klikken of de sneltoets te gebruiken. Typ de URL in in het veld en klik op "Afgerond" om de link in te voegen.

VisualEditor-context menu-link tool.png
Om een bestaande link te bewerken of te verwijderen klikt u eerst op de link in de tekst en daarna op de knop "Bewerken". Er verschijnt een dialoogvenster. (U kunt het dialoogvenster ook openen met de sneltoets Ctrl+K.) Wanneer u een link selecteert krijgt deze een blauwe achtergrond.

U kunt vervolgens in het dialoogvenster het doel van de link aanpassen. U kunt ook de link in zijn geheel verwijderen door te klikken op het pictogram "Verwijderen" (prullenbak) in de linkerbenedenhoek van het dialoogvenster. U kunt ook het doel van de link in een apart venster openen door in het dialoogvenster op de kopie van de link te klikken. (Dit kan van pas komen als u wilt controleren of een externe link correct werkt.)

Als u het dialoogvenster wilt verlaten of verder wilt typen na de link drukt op de toets :

  • Door eenmaal op de toets te drukken verdwijnt het linkdialoogvenster en verschijnt uw cursor aan het einde van het gelinkte element.
  • Tweemaal op de toets drukken plaatst uw cursor achter het gelinkte element. U kunt nu de rest van uw tekst typen.

Om het label van een bestaande link aan te passen klikt u op "Label wijzigen" en typt u het nieuwe label. Maar let op als u het label in zijn geheel wilt vervangen:

  • Als u het hele linklabel geselecteerd heeft verdwijnt de link door op een toets te drukken. U kunt opnieuw een koppeling aanleggen.
  • Om de link te behouden klikt u in het linklabel en gebruikt u de ← Backspace- en delete-toetsen om het bestaande label te verwijderen. U houdt een dunne blauwe lijn over. Nu kunt u een nieuw label ingeven, met behoud van de oorspronkelijke link.
  • Het is ook mogelijk te linken naar categorieën, bestanden en meer.

Referenties bewerken

<translate>

For further information, see <tvar|1>Hulp bij het gebruik van referentiesjablonen of Hulp bij het gebruik van citoids Citeer-knop</></translate>

Bepalen welk systeem gebruikt wordt

Uw wiki kan gebruikmaken van een van drie voetnootsystemen. Het systeem rechts is het simpelste, waar het menu "Citeren" geen citeersjablonen bevat. Als uw wiki dit systeem gebruikt vindt u alles wat u moet weten over voetnoten op deze pagina.
VisualEditor cite menu default.png

Het tweede systeem heeft eenzelfde soort "Citeren"-menu, aangevuld met een aantal veelgebruikte citeersjablonen voor snelle toegankelijkheid. Als uw wiki dit systeem gebruikt vindt u meer informatie op Help:VisualEditor/User guide/Citations-Templates .
VisualEditor references more.png

VisualEditor citoid Cite button-nl.png
In het derde systeem begint u ook door te klikken op de "$cite"-knop. Vervolgens opent een dialoogvenster met een automatisch citeerproces dat gebruikmaakt van citoid. Als uw wiki dit systeem gebruikt vindt u meer informatie op Help:VisualEditor/User guide/Citations-Full .
VisualEditor Citoid Automatic tab.png

Een bestaande referentie bewerken

Om een bestaande referentie te bewerken klikt u op de referentie in de tekst (vaak een getal tussen vierkante haken). Vervolgens ziet u ofwel een "Referentie"-pictogram (bladwijzer) of het icoon en de naam van het sjabloon dat gebruikt werd om deze referentie in te voegen. Door op "Bewerken" te klikken opent u een dialoogvenster waarin u de referentie kunt bewerken.
VisualEditor - Editing references 1.png

Als u in het "Referentie"-pictogram op "Bewerken" klikt opent het referentiedialoogvenster. Klik erop om de referentie aan te passen.

Veel wiki's gebruiken sjablonen om referenties volgens een bepaalde standaard op te maken. Als een sjabloon werd gebruikt bij een bepaalde referentie zal alle informatie in dat veld gemarkeerd worden wanneer u uw muis over de referentie-informatie beweegt.

Indien er een sjabloon werd gebruikt en u de referentie-informatie bekijkt binnen dat sjabloon, zal het Sjabloon-pictogram (puzzelstuk) verschijnen. Klik hierop om de inhoud van de referentie in de minibewerker te bewerken.

VisualEditor - Editing references 6.png

Als er, in plaats van het "$ref"-pictogram (bladwijzer), een pictogram voor een standaard citeersjabloon wordt getoond, kunt u naar het sjabloondialoogvenster gaan door op "Bewerken" te klikken.
VisualEditor - Editing References - Cite Web.png

In de minibewerker kunt u nieuwe soorten informatie toevoegen en verwijderen of de bestaande inhoud veranderen. Enkel velden (sjabloonparameters) die inhoud bevatten worden getoond. Om velden toe te voegen klikt u op "Meer informatie toevoegen" onderaan het dialoogvenster.
VisualEditor - Editing references 5.png

Klik op "Wijzigingen toepassen" als u klaar bent.
VisualEditor Apply Changes-nl.png

Een bestaande referentie hergebruiken

Als de pagina al een geschikte referentie bevat kan u deze hergebruiken.

Om een bestaande referentie te hergebruiken plaatst u de cursor daar waar u de referentie in de tekst wilt invoegen. Klik vervolgens op "Citeren" en daarna op het tabblad "Hergebruiken".

(Let op: als uw wiki het derde voetnootsysteem gebruikt, zoals hierboven beschreven, dan ziet u een tabblad "Hergebruiken" in een dialoogvenster in plaats van een knop "Hergebruiken" in het menu "Citeren".)

VisualEditor Cite menu re-use.png

In het dialoogvenster Referentie kan u de betreffende referentie opzoeken en selecteren. Indien er gebruik wordt gemaakt van veel referenties, kan u het zoekvak ("Zoeken in huidige citaten") gebruiken om alleen die referenties weer te geven die met een bepaalde tekst overeenkomen.
VisualEditor - Editing references 18.png

Een nieuwe referentie toevoegen

Om een nieuwe referentie toe te voegen via het menu "Citeren", plaatst u de cursor daar waar u de referentie in de tekst wilt invoegen, en klikt u op het betreffende pictogram in het menu.
VisualEditor references more.png

Een "basis"-referentie gebruiken

Rechts ziet u het dialoogvenster dat verschijnt wanneer u voor een standaardreferentie kiest. In het referentiedialoogvenster kunt u uw referentie toevoegen, inclusief opmaak.

U kunt de referentie indelen in een bepaalde groep, hoewel dit veld vaak blanco wordt gelaten. (Deze optie wordt gebruikt om groepen referenties weer te geven met de "Referentielijst"-tool.)

VisualEditor - Editing references 20.png

Als u een nieuwe referentie toevoegt en daarbij een sjabloon wilt gebruiken, klikt u op het "Sjabloon"-pictogram (puzzelstukje) in het menu "Invoegen" binnen het referentiedialoogvenster.
VisualEditor Template Insert Menu-nl.png

Zoek vervolgens het sjabloon dat u wilt gebruiken, voeg het toe en bewerk het zoals een normaal sjabloon. (Zie de sectie over het bewerken van sjablonen hieronder voor meer informatie over sjablonen.)

Als u klaar bent klikt u op "Wijzigingen toepassen" om terug te keren naar het referentiedialoogvenster. Klik nogmaals op "Wijzigingen toepassen" om terug te keren naar de pagina die u aan het bewerken bent.

VisualEditor - Editing references 9.png

Wanneer de pagina nog geen referentielijst bevat (bijvoorbeeld wanneer u de eerste referentie aan het toevoegen bent), moet u deze lijst eerst toevoegen om uw referentie te kunnen weergeven.

Plaats de cursor op de plek waar u wilt dat de referenties komen te staan (meestal onderaan de pagina), open het menu "Invoegen" en klik op "Referentielijst" (drie boeken) om de lijst toe te voegen.

VisualEditor References List Insert Menu-nl.png

Wanneer u verschillende groepen referenties heeft gemaakt (hetgeen niet zo vaak voorkomt) kunt u in dit dialoogvenster de groep specificeren. Enkel die referenties die tot die groep behoren worden dan op die plek weergegeven.

Ten slotte klikt u op "Invoegen".

VisualEditor references list-nl.png

Standaard referentiesjablonen gebruiken

Op uw lokale wiki kunnen er bijkomstige referentiesjablonen aan het menu "Citeren" zijn toegevoegd. Zo krijgt u snel toegang tot de meestgebruikte referentiesjablonen. (Instructies voor het toevoegen van bijkomstige referentiesjablonen aan uw wiki zijn te vinden op VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Door te klikken op een sjabloonpictogram zoals "Citeer boek" komt u terecht in een minibewerker voor dat sjabloon. Belangrijke informatievelden zijn aangeduid met een asterisk. De meestgebruikte velden worden getoond, maar deze hoeft u niet allemaal verplicht in te vullen.
VisualEditor - Editing references - Cite book required fields.png

Om meer velden toe te voegen scrolt u naar beneden en klikt u op "Meer informatie toevoegen".

Klik op "Invoegen" als u klaar bent.

VisualEditor - Editing references - Add parameter.png

Afbeeldingen en andere mediabestanden bewerken

Afbeeldingen bewerken

Om een nieuwe afbeelding (of een ander mediabestand) aan de pagina toe te voegen klikt u op het "Media"-pictogram (een afbeelding van een berglandschap) in het menu "Invoegen". De foto zal worden toegevoegd op de plaats waar uw cursor zich op dat moment bevindt.
VisualEditor Media Insert Menu-nl.png

Door te klikken op het "Media"-pictogram opent u een dialoogvenster dat automatisch Wikimedia Commons en uw lokale wiki doorzoekt om bestanden te vinden die overeenkomsten vertonen met de naam van de pagina die u aan het bewerken bent.

U kunt andere mediabestanden zoeken door de tekst in het zoekvak van het dialoogvenster aan te passen.

Klik op een miniatuur om een bestand te kiezen.

Hiermee plaatst u de afbeelding op de pagina die u aan het bewerken bent.

VisualEditor - Media editing 2.png

Nadat de door u gekozen afbeelding toegevoegd is aan de pagina zal er een ander dialoogvenster openen. Hier kan u een onderschrift aan de afbeelding toevoegen of het bestaande onderschrift aanpassen. Het onderschrift mag opmaak en links bevatten.
VisualEditor - Media editing 6.png

Het mediadialoogvenster kan ook worden gebruikt om een alternatieve tekst aan te bieden voor gebruikers die een screenreader gebruiken of die afbeeldingen hebben uitgeschakeld.
VisualEditor - Media editing 7.png

U kan verschillende afbeeldingsparameters gebruiken in het venster "Geavanceerde instellingen". Het gaat hier onderandere om de uitlijning, het type afbeelding en de grootte.
VisualEditor - Media editing 8.png

Wanneer u klaar bent klikt u op "Wijzigingen toepassen" om het dialoogvenster te sluiten en terug te keren naar de tekstverwerker.
VisualEditor Apply Changes-nl.png

U kunt een onderschrift aan een bestaande afbeelding toevoegen of een bestaand onderschrift aanpassen door op de afbeelding te klikken en daarna voor "Bewerken" te kiezen.

U kunt het formaat van een bestaande afbeelding aanpassen door op de afbeelding te klikken en vervolgens met de bijbehorende knop (de tweezijdige pijl linksbeneden) de afbeelding te vergroten of verkleinen.

U kan ook een afbeelding verplaatsen (hoger of lager op de pagina) door deze te verslepen.

VisualEditor - Media editing 3.png

Afbeeldingen uploaden

U kunt afbeeldingen uploaden vanaf een tabblad in het media-dialoogvenster.
VisualEditor - Media upload 1.png

Klik op het tabblad "Uploaden" en selecteer een afbeelding vanaf uw computer. U kunt de bestandsnaam intypen, of de afbeelding naar het hokje slepen. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.
VisualEditor - Media upload 1.png

U wordt gevraagd de afbeelding van een beschrijving te voorzien en categorieën toe te voegen, zodat anderen het bestand kunnen vinden.
VisualEditor - Media upload 2.png

Wanneer u klaar bent wordt de afbeelding aan de pagina toegevoegd.
VisualEditor-logo.svg

Mediagalerijen bewerken

Om een nieuwe galerij toe te voegen klikt u op "Galerij" (een reeks foto's) in het menu "Invoegen". (Als deze optie niet zichtbaar is heeft uw lokale wiki besloten om deze functie nog niet te implementeren in de visuele tekstverwerker.)
VisualEditor - Gallery1.png

Om een bestaande galerij te bewerken klikt u op die galerij. Daarna vindt u onderaan de galerij het galerij-icoon (een reeks foto's). Hiermee opent u de galerijbewerker met een lijst van alle afbeeldingen die reeds in de galerij te vinden zijn.
VisualEditor - Gallery2.png
De galerijbewerker is een simpel venster waarmee u bestaande galerijen kunt aanpassen met wikitekstopmaak. Om een nieuwe afbeelding aan een bestaande galerij toe te voegen typt u de naam van de afbeelding, gevolgd door een sluisteken (|) en het onderschrift voor de afbeelding. Elke afbeelding moet op een aparte regel staan. U kunt deze lijst ook bewerken om afbeeldingen te herschikken, te verwijderen of om onderschriften aan te passen.

Wanneer u op "Afgerond" klikt wordt de galerijbewerker gesloten. De veranderingen zouden meteen zichtbaar moeten zijn.

Let erop dat - door de galerijbewerker te sluiten - uw wijzigingen nog niet worden opgeslagen. Net zoals met andere bewerkingen in de visuele tekstverwerker worden uw wijzigingen pas doorgevoerd nadat de hele pagina opgeslagen wordt.

VisualEditor - Gallery3.png

Sjablonen bewerken

Aan de slag

Om een nieuw sjabloon aan de pagina toe te voegen plaatst u de cursor daar waar u het sjabloon wilt invoegen, en klikt u op het "Sjabloon"-pictogram (puzzelstukje) in het menu "Invoegen".
VisualEditor Template Insert Menu-nl.png

Vul de naam in van het sjabloon dat u wilt invoegen. Wanneer het sjabloon in de lijst verschijnt klikt u erop. Klik daarna op "Sjabloon toevoegen".
VisualEditor - Template editing 4.png

Het is mogelijk reeds ingevoegde sjablonen te bewerken door erop te klikken (het sjabloon wordt blauw en er verschijnt een venster met een "Sjabloon"-pictogram) en vervolgens te kiezen voor "Bewerken".
VisualEditor - Template editing 1.png

Sommige sjablonen zijn niet zichtbaar voor de lezer. Zulke verborgen sjablonen worden in de visuele tekstverwerker aangegeven met puzzel-iconen. De naam van het sjabloon staat naast het puzzel-icoon.
VisualEditor template not visible.png

Wanneer u op het icoon klikt verschijnt een contextmenu en kunt u het sjabloon bewerken.
VisualEditor template not visible context menu.png

Sjabloonparameters

Wanneer u een nieuw sjabloon toevoegt of een bestaand sjabloon opent verschijnt het dialoogvenster "Transclusie". De precieze inhoud hangt af van de vraag of het sjabloon gebruikmaakt van het nieuwe TemplateData -systeem of niet.

Het sjabloon dat hiernaast wordt weergegeven maakt geen gebruik van TemplateData. Het dialoogvenster linkt daarom naar de sjabloonpagina. Door de sjabloonpagina te bezoeken zou u moeten kunnen achterhalen welke parameters (velden) het sjabloon gebruikt en welke informatie bij welke parameter hoort. Gebruik getallen voor de naam van elke naamloze parameter. De eerste naamloze parameter heet 1, de tweede 2, enzovoorts.
VisualEditor template with no TemplateData.png

Als het sjabloon gebruikmaakt van TemplateData toont het dialoogvenster een lijst van individuele parameters.
VisualEditor template with TemplateData.png

Bij een bestaand sjabloon kunt u de reeds bestaande parameters bewerken, of parameters toevoegen door onderaan het venster op "Meer informatie toevoegen" te klikken.
VisualEditor - Template editing 3.png

Wanneer een sjabloon andere sjablonen bevat, worden deze ingebedde sjablonen als parameter weergegeven. Op deze manier kunnen ze worden bewerkt of verwijderd.

Nieuwe ingebedde sjablonen worden op dezelfde manier toegevoegd als parameters. Mogelijk moet u in de sjabloondocumentatie nagaan of het ingebedde sjabloon wordt ondersteund.

VisualEditor - Template editing 5.png

Afronden

Wanneer u klaar bent met het bewerken van het sjabloon klikt u op "Wijzigingen toepassen" om het dialoogvenster te sluiten en terug te keren naar de tekstverwerker.
VisualEditor Apply Changes-nl.png

Sjablonen substitueren

Wanneer een sjabloon gesubstitueerd moet worden, typt u subst: (inclusief dubbelepunt) voor de naam van het sjabloon.

"Automatisch aanvullen" werkt niet met subst:. Als u deze functie nodig heeft voegt u subst: pas toe nadat u het gezochte sjabloon heeft gevonden.

Klik daarna op de blauwe knop "Sjabloon toevoegen".

Voeg op de gebruikelijke wijze parameters toe en klik op "Invoegen".

VisualEditor - Template editing 7.png

Nadat u op "Wijzigingen toepassen" heeft geklikt wordt het sjabloon zichtbaar op de pagina.
VisualEditor - Template editing 8.png

Lijsten bewerken

VisualEditor Toolbar Lists and indentation-nl.png
Met de visuele tekstverwerker kunt u nieuwe lijsten maken of bestaande lijsten bewerken. Er zijn twee soorten lijsten: ongeordende (ongenummerd) en geordende (genummerd).

Om een nieuwe lijst te maken klikt u op een van de twee menu-opties die links staan afgebeeld. Als u al een lijst getypt heeft (met de items op aparte regels) kunt u die ook selecteren en vervolgens op een van de menu-opties klikken.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Hiernaast ziet u voorbeelden van de twee lijstsoorten: ongeordend (ongenummerd) en geordend (genummerd).

VisualEditor lists 3 select to indent.png
Om de mate van inspringing van een deel van een bestaande lijst aan te passen selecteert u dat deel van de lijst dat u wilt aanpassen.

VisualEditor lists 4 indentation menu.png
Vervolgens kiest u in het menu voor 'Inspringing verkleinen' of 'Inspringen vergroten'. U kunt ook op de Tab-toets op uw toetsenbord drukken. (Met Tab vergroot u de inspringing. Met Shift + Tab verkleint u de inspringing.)

VisualEditor lists after indenting.png
Hier ziet u het resultaat van een vergrote inspringing.

VisualEditor lists mixed.png
Het is zelfs mogelijk om geordende en ongeordende lijsten door elkaar te gebruiken, op voorwaarde dat de lijstitems verschillend zijn ingesprongen.

Tabellen bewerken

VisualEditor insert table-nl.png
U kunt de visuele tekstverwerker gebruiken om tabellen in te voegen en te bewerken.

Het is zelfs mogelijk om een tabel te importeren door een .csv-bestand van uw computer naar het bewerkingsscherm te slepen.


Wanneer u in het menu "Invoegen" op "Tabel" klikt voegt de visuele tekstverwerker een tabel met vier kolommen en vier rijen toe.

Nu verschijnt het menu "Tabel". Vanuit dat menu kunt u een bijschrift boven de tabel invoegen.

VisualEditor empty table.png

Om een cel te selecteren klikt u er eenmaal op.
VisualEditor tables select one cell.png

Om de inhoud van de cel te bewerken (bijvoorbeeld om inhoud toe te voegen of een spelfout te verbeteren) klikt u tweemaal op die cel. U kunt de cel ook selecteren en op Enter drukken.

Om te stoppen met het bewerken van de cel klikt u op een willekeurige andere plek op de pagina.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
U kunt kolommen en rijen toevoegen en verwijderen.

U kunt cellen samenvoegen: selecteer ze en klik dan in het menu Tabel op "Cellen samenvoegen".
VisualEditor tables merge cells.png

Als u cellen samenvoegt behoudt u slechts de tekst in een van de cellen; tekst in andere cellen wordt verwijderd wanneer u cellen samenvoegt. Als u besluit dat u de verwijderde tekst toch wilt gebruiken, gebruik dan de knop Ongedaan maken en verplaats of kopieer de tekst alvorens de cellen opnieuw samen te voegen.
VisualEditor tables post-merge cell.png

Het is ook mogelijk om eerder samengevoegde cellen te splitsen. Wanneer u een cel splitst komt de inhoud daarvan in de eerste cel te staan. Desgewenst kunt u deze tekst daarna knippen en in andere cellen plakken.
VisualEditor tables split cells.png

Categorieën bewerken

VisualEditor category item-nl.png
Om categorieën te bewerken klikt u op "Categorieën" in het menu "Pagina-instellingen".

VisualEditor category editing-nl.png
De knop "Categorieën" opent een dialoogvenster dat de huidige categorieën weergeeft en het mogelijk maakt nieuwe toe te voegen en bestaande categorieën te verwijderen.

Het is ook mogelijk om de naam in te stellen waarop de pagina in categorieën moet worden gesorteerd.

Een voorbeeld: de standaard sorteernaam voor het artikel "George Washington" is "Washington, George", waardoor het artikel in de categorie "Presidenten van de Verenigde Staten van Amerika" onder de letter "W" wordt gesorteerd (en niet onder "G").


VisualEditor - Category editing 3.png
Om een nieuwe categorie toe te voegen vult u in het tekstvak "Categorie toevoegen" de naam van de categorie in. Terwijl u typt zal de visuele tekstverwerker mogelijke overeenkomsten zoeken in bestaande categorieën. U kunt een bestaande categorie kiezen of u kunt een nieuwe, onbestaande categorie toevoegen. (Tot deze categoriepagina is aangemaakt zal de nieuwe categorie als een rode link getoond worden.)

VisualEditor - Category editing 2.png
Om een bestaande categorie te verwijderen klikt u erop en daarna op het pictogram "Verwijderen" (prullenbak) in het dialoogvenster dat verschijnt.

Door op een categorie te klikken kunt u ook een sorteernaam voor die specifieke categorie opgeven. Hierdoor wordt de normale sorteervolgorde genegeerd.


VisualEditor Apply Changes-nl.png
Wanneer u klaar bent met categorieën bewerken klikt u op "Wijzigingen toepassen" om terug te keren naar de tekstverwerker.

Pagina-instellingen bewerken

VisualEditor page settings item-nl.png
Om de instellingen van een pagina te bewerken klikt u in het menu "Pagina-instellingen" op het pictogram "Pagina-instellingen".

VisualEditor Page Settings-nl.png
Het pictogram "Pagina-instellingen" opent een dialoogvenster met verschillende opties.

VisualEditor Page Settings Redirects-nl.png
U kunt gemakkelijk een pagina als doorverwijzing instellen door "Pagina doorsturen naar" aan te vinken en vervolgens de pagina waarnaar u de lezer wilt verwijzen in te typen.

Onderaan het venster is er de mogelijkheid om ervoor te zorgen dat paginahernoemingen niet automatisch deze doorverwijzing updaten. Deze functie wordt zeer zelden gebruikt.


VisualEditor Page Settings TOC-nl.png
Het wel of niet tonen van de inhoudstafel op een pagina kan worden aangeduid met een van deze drie knoppen. De standaardwaarde is "Als nodig", waarmee een inhoudstafel wordt getoond van zodra er drie of meer koppen in het artikel staan.

VisualEditor Page Settings Edit Links-nl.png
Door dit kadertje aan te vinken zorgt u ervoor dat er geen "bewerk"-knop verschijnt naast elke kop.

VisualEditor Apply Changes-nl.png
Klik op "Wijzigingen toepassen" wanneer u klaar bent met het bewerken van de pagina-instellingen om terug te keren naar de tekstverwerker.

Editing maps

Visual editor showing editing an existing map.jpg
You can add and change maps. See Help:VisualEditor/Maps .

Wiskunde formules bewerken

Om een nieuwe wiskundige formule in te voegen plaatst u uw cursor op de plaats waar u deze wilt toevoegen en klikt u op het "Wiskundige formule"-pictogram("Σ") in het menu "Invoegen".
VisualEditor Formula Insert Menu-nl.png

Hierna wordt er een venster geopend waarin u de formule kunt ingeven met behulp van LaTeX-syntax. De visuele tekstverwerker zal de formule tijdens het typen updaten, zodat u uw wijzigingen meteen kunt zien. Wanneer u klaar bent klikt u op "Afgerond".
VisualEditor formula-nl.png

Om een bestaande wiskundige formule aan te passen klikt u op deze formule en klikt u op het "Σ"-pictogram dat verschijnt. Hierna wordt het dialoogvenster voor formules geopend, waar u uw wijzigingen kunt doorvoeren.
VisualEditor - editing existing mathematical formula.png

Wiskundige formules kunnen in de tekst zelf geplaatst worden of als een blok gecentreerd worden.
VisualEditor mathematic formula inline.png

Bladmuziek bewerken

Om bladmuziek toe te voegen plaatst u uw cursor waar u wilt dat de bladmuziek wordt ingevoegd. Klik vervolgens in de werkbalk op het menu "Invoegen" en daarna op "Muzieknotatie".

Klik twee keer achter elkaar op bestaande bladmuziek om deze te bewerken.

VisualEditor-Insert-Musical-Notation.png

Hiermee opent u het dialoogvenster "Muzieknotatie". De muzieknotatie kan op toonladder bewerkt worden, in ABC of in LilyPond. Het is ook mogelijk de notatie te koppelen aan een audio- of MIDI-bestand. Wanneer u klaar bent klikt u op "Invoegen" om het dialoogvenster te sluiten en uw wijzigingen te publiceren.
Musical.png

Gedichten en andere bijzondere onderdelen bewerken

Sommige onderdelen, zoals association lists en gedichten, worden nog niet volledig door de visuele tekstverwerker ondersteund.
VisualEditor editing poem 1.png

In de meeste gevallen kunnen bestaande items wel bewerkt worden, maar kunnen met de visuele tekstverwerker geen nieuwe items worden ingevoegd.

Tot ze volledig ondersteund worden kunt u een bestaande van een andere pagina kopiëren, of direct de broncode bewerken.

VisualEditor editing poem 2.png

Schakelen tussen de visuele tekstverwerker en de wikitekstverwerker

Om van de visuele tekstverwerker over te schakelen op de wikitekstverwerker klikt u op de [[ ]]-knop helemaal rechts op de werkbalk.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

Als u al wijzigingen heeft aangebracht wordt u gevraagd of u deze wilt bewaren. In de meeste gevallen kiest u voor "Wijzigingen bewaren".

VisualEditor bi-directional switching to wikitext.png

U ziet een diff. (Als u op "Wijzigingen niet opslaan" heeft geklikt ziet u slechts wikitekst, klaar om te bewerken met de wikitekstverwerker.)

Als u naar beneden scrolt ziet u het wikitekstbewerkingsvenster.

VisualEditor bi-directional switching diff before wikitext.png

Het is ook mogelijk om van de wikitekstverwerker over te schakelen naar de visuele tekstverwerker. Klik daarvoor op het potlood-icoon helemaal rechts op de werkbalk.

VisualEditor bi-directional switching pencil icon in wikitext.png

Als u al wijzigingen heeft aangebracht wordt u gevraagd of u deze wilt behouden. Als u op "Wijzigingen behouden" klikt wordt overgeschakeld naar de visuele tekstverwerker. Als u op "Wijzigingen niet opslaan" klikt wordt u gevraagd dit te bevestigen (klik op "Pagina verlaten" om te bevestigen) voor de visuele tekstverwerker geopend wordt.

VisualEditor bi-directional switching to visual editing.png

Sneltoetsen

Veel bijdragers aan de encyclopedie zijn eraan gewend geraakt om wikitekst rechtstreeks toe te voegen, vooral vet, cursief en interne links. Sneltoetsen maken het mogelijk om dergelijke opmaak vlug toe te voegen zonder de werkbalkknoppen te moeten gebruiken. De volgende vaakgebruikte sneltoetsen worden door de visuele tekstverwerker ondersteund:

Sneltoetsen op pc Actie Sneltoetsen op Mac

Ctrl+B Vet Cmd+B

Ctrl+I Cursief Cmd+I

Ctrl+K Link invoegen Cmd+K

Ctrl+X Knippen Cmd+X

Ctrl+C Kopiëren Cmd+C

Ctrl+V Plakken Cmd+V

Ctrl+Z Ongedaan maken Cmd+Z