Ajuda:Editor Visual/Manual do Utilizador

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 64% complete.
Outdated translations are marked like this.
PD Nota: quando edita esta página, concorda em publicar a sua contribuição conforme CC0. Consulte as «Páginas de Ajuda de Domínio Público» para mais informação.
PD


Abrir o editor visual

Para editar uma página com o editor visual, clique no separador "Editar" no topo da página.

Pode levar alguns segundos até que a página abra para edição, e demorará mais se a página for muito longa.

Ao clicar no separador "Editar código-fonte" irá abrir o editor clássico do texto da wiki.

VisualEditor edit tab-pt.png

Também pode abrir o editor visual ao clicar na hiperligação "editar" em cada secção.
VisualEditor - Section edit links-en.png

Começar: a barra de ferramentas do editor visual

Captura de ecrã da barra de ferramentas do editor visual
A barra de ferramentas do editor visual aparece no topo do ecrã quando começa a editar. Esta inclui alguns ícones familiares:

VisualEditor - Toolbar - Undo-redo.png
Desfazer e Refazer as alterações que efetuou.

VisualEditor Toolbar Headings-pt.png
O menu suspenso Cabeçalho: permite definir como o texto será formatado. Para alterar o estilo de um parágrafo, posicione o cursor do rato sobre o parágrafo e seleccione um item neste menu (não é necessário destacar qualquer texto). Os títulos das secções são formatados como "Cabeçalho", e as subsecções são "Sub-título 1", "Sub-título 2", e assim por diante. A formatação normal para texto é "Parágrafo".

VisualEditor Toolbar Formatting-pt.png

Formatação: Ao clicar no botão "A" surgirá um menu.

  • O item "Negrito" (B) destaca a negrito o texto selecionado.
  • O item "Itálico" (I) destaca em itálico o texto selecionado.
  • O item "Sobrescrito" (x2) torna o texto seleccionado menor do que o texto circundante e um pouco acima da linha de escrita.
  • O item "Subscrito" (x2) torna o texto seleccionado menor do que o texto circundante e um pouco abaixo da linha de escrita.
  • O item "Rasurado" (S) torna o texto seleccionado menor do que o texto circundante e um pouco acima da linha de escrita.
  • O item "Código" (um conjunto de chavetas: {}) altera a fonte do texto seleccionado para uma fonte monoespaçada, o que o diferencia do texto (proporcionalmente espaçado) circundante.
  • O item "Sublinhado" (U) adiciona uma barra sólida horizontal abaixo do texto selecionado.
  • O item "Língua" (文A) permite-lhe identificar o idioma (por exemplo, japonês) e direção (por exemplo, da direita para a esquerda) do texto selecionado.
  • O último item (VisualEditor MediaWiki theme clear icon bitmap.png), denominado "Remover", remove toda a formatação de caracteres do texto selecionado, incluindo hiperligações.

Se não selecionou nenhum texto, então ao clicar em "A" para abrir o menu e selecionar um item, essa formatação será aplicada ao texto que está a escrever, a partir de onde está localizado o cursor.


VisualEditor - Toolbar - Linking.png
Ferramenta de hiperligação: o ícone de uma corrente representa a ferramenta de hiperligação. Ao clicar nela (normalmente quando seleciona algum texto), abre a janela de hiperligações.

VisualEditor - Cite Pulldown-pt.png
Menu Citar: este é utilizado para adicionar citações em linha (também chamadas de "referências" ou "notas de rodapé"). Todos os projetos têm acesso à formatação básica de referências e possuem a capacidade de reutilização de citações com este menu. Este menu também dá-lhe acesso rápido aos modelos de citação local, se estes estiverem ativados na sua wiki.

(Instruções para adicionar modelos de citação local ao menu Citar, numa wiki específica estão disponíveis em VisualEditor/Ferramenta de citação .)


VisualEditor citoid Cite button-pt.png
Botão Citar: Se o serviço citoid está habilitado em sua wiki, verá um botão Citar em vez de um menu Citar.

O serviço de citação tenta preencher predefinições de citação automaticamente.


VisualEditor Toolbar Lists and indentation-pt.png
Listas e indentação: Os dois primeiros itens permitem que formate o texto em Lista numerada ou Lista com marcadorescom, respectivamente. Os dois últimos permitem que aumente ou diminua o nível de indentação do conteúdo.

VisualEditor Insert Menu-pt.png
Inserir: O menu "Inserir" pode ser mostrado de maneira diferente em alguns projectos. Aqui está uma lista de todas as opções que podem aparecer.
  • O ícone "Imagens e multimédia" (uma imagem de montanhas) abre a janela de multimédia.
  • O ícone "Predefinição" (uma peça de puzzle) permite-lhe editar os modelos.
  • O item "Tabela" permite-lhe inserir uma tabela.
  • O item "Comentário" (um balão de conversação) permite-lhe inserir comentários ocultos aos leitores; estes comentários são visualizados apenas no modo de edição, onde são indicados por um ícone com uma marca de exclamação. No modo de edição, clicar no ícone com marca de exclamação permite editar ou eliminar o comentário.
  • O ícone "Hieróglifos" (um símbolo ankh - ☥) permite-lhe introduzir hieróglifos. (Veja abaixo.)
  • O item "Bloco de código" permite inserir código.
  • O item "Notação musical" permite inserir uma notação musical.
  • O ícone "Galeria" (uma série de fotografias) permite inserir uma galeria de imagens à página.
  • O ícone "Fórmula matemática" (Σ) abre a janela de inserção de fórmulas.
  • O item "Gráfico" permite-lhe inserir um gráfico.
  • O item "A sua assinatura" permite-lhe inserir uma assinatura que pode utilizar no projeto. Ele estará acizentado (não selecionável) quando estiver editando um espaço nominal, como um artigo, onde assinaturas não devem ser inseridas.
  • O ícone "Lista de referências" (três livros) abre um diálogo onde poderá especificar onde as referências serão mostradas ao leitor. Normalmente, isto apenas precisa de ser efetuado uma vez em cada página.

Inserção de carateres especiais: O ícone Carácter especial (Ω) está ao lado do menu "Inserir". Quando clicado, faz aparecer um diálogo que mostra muitos caracteres especiais. Ao clicar um carácter específico, insere-o no texto. Estes caracteres especiais incluem alguns símbolos padrão, acentos e símbolos matemáticos. (Esta lista pode ser personalizada localmente. Consulte Editor Visual/Caracteres especiais para instruções.)
VisualEditor Toolbar SpecialCharacters-pt.png

VisualEditor toolbar edit notices icon.png
O botão Avisos de edição exibe quaisquer avisos para a página.

VisualEditor More Settings-pt.png
O menu Opções da página fica à esquerda do botão Publicar alterações e do menu Alterar modo de edição. Neste menu, existe um botão para abrir uma caixa de diálogo Opções com as seguintes guias (lado esquerdo):
  • Categorias permite adicionar categorias a esta página e ajustar como a página é ordenada, quando exibida em uma categoria, definindo um índice diferente para a ordenação.
  • Configurações da página permite que você faça da página um redirecionamento e ajusta as opções desse redirecionamento, ajusta as configurações relacionadas à exibição do Índice, desabilita as ligações de edição próximas a cada título e define a página como uma página de desambiguação.
  • Configurações avançadas permite ajustar as configurações relacionadas à indexação da página pelos mecanismos de pesquisa, exibindo uma guia para adicionar uma nova secção e o título exibido.
  • Línguas que mostra uma lista de páginas em outros idiomas que estão ligadas a essa página.
  • Templates used mostra uma lista de ligações para cada predefinição utilizada nesta página.

As abas da caixa de diálogo Opções também são exibidas no menu Opções da página e podem ser abertas clicando nelas. Além disso, o menu Opções da página contém o botão Ver da direita para a esquerda e o botão Localizar e substituir que abre uma caixa de diálogo onde você pode inserir caracteres, termos ou expressões regulares pelos quais você está pesquisando e aqueles para substituí-los, juntamente com vários botões para opções.


VisualEditor bi-directional switching square brackets icon.png
O botão $switch está localizado ao lado do botão Publicar alterações. Ele permite alternar para o editor de código-fonte.

Publicar alterações

Ao terminar de editar, clique no botão azul "Publicar alterações" na barra de ferramentas. Caso não tenha feito quaisquer mudanças, o botão azul estará desactivado (acinzentado). Para cancelar todas as alterações que realizou, feche apenas a janela do seu navegador, ou clique na guia "Ler" acima da barra de ferramentas de edição.
VisualEditor toolbar actions-pt.png

Ao pressionar o botão azul "Publicar alterações", abre-se uma pequena caixa de diálogo no qual é possível inserir um breve resumo das suas ações, marcar a sua edição como menor e optar por adicionar a página à sua Páginas vigiadas. A caixa para o resumo é equivalente ao campo Resumo: mostrado no editor clássico de wikitexto.

Pode também rever as mudanças que fez, ao usar o botão "Rever as suas mudanças", para ter a certeza de que funcionam como desejado antes de gravar as suas alterações. Isto é semelhante ao botão "Mostrar alterações" no editor clássico de wikitexto.

O botão "Retomar edição" faz o editor regressar à página que estava a editar. Pode gravar as suas alterações mais tarde.

VisualEditor save dialog-pt.png

Editar hiperligações

VisualEditor - Toolbar - Linking.png
Hiperligações podem ser adicionadas através do ícone "Hiperligação" (elos de uma corrente) na barra de ferramentas, ou usando o atalho Ctrl+K (ou ⌘ Command+K em um Mac).

Se seleccionar (destacar) um texto e clicar no botão "Hiperligação", esse texto será utilizado na criação da hiperligação. Para uma hiperligação que envolva uma única palavra, pode seleccionar essa palavra ou simplesmente posicione o cursor por sobre essa palavra.


VisualEditor-link tool-search results-pt.png
Quando utilizar o botão ou o atalho, aparecerá uma janela em que poderá digitar a ligação.

A ferramenta de ligação tentará ajudá-lo com as ligações internas ao procurar por prováveis correspondências. Assim que tiver inserido ou selecionado uma hiperligação, pode completar o processo de hiperligação pressionando em ↵ Enter, ou clicando no botão "Concluído". A sua hiperligação irá aparecer imediatamente na página, mas assim como nas outras alterações à página, ela não será publicada até que publique a página "completa".


VisualEditor-link tool-external link.png
Para interligar a uma página da Web ou outro site da Web, o processo é similar: escolha "Site externo", e insira um URL na caixa.

VisualEditor link tool simple link.png
Hiperligações externas sem etiquetas parecem-se como isto: [1]. Pode adicionar um ao colocar o cursor longe de qualquer palavra (por exemplo, depois de um espaço). Abra a ferramenta de ligação ao clicar no botão ou pressionar o atalho de teclado. Digite a URL na caixa e clique no botão "Concluído" para inserir a ligação.

VisualEditor-context menu-link tool.png
Para alterar ou remover uma hiperligação existente, clique no texto com a hiperligação, depois pressione o ícone "Hiperligação" que aparece próximo a ele. A caixa de diálogo irá surgir, para edição. (Pode também utilizar o atalho do teclado Ctrl+K.) Quando uma ligação for seleccionada, esta surgirá destacada em azul.

Na caixa de diálogo para edição da ligação, pode então editar o destino da ligação. Poderá também removê-la por completo ao clicar no botão "Remover" no canto superior direito da janela de diálogo. Pode também abrir a página de destino da ligação noutra janela ao clicar na cópia dela na caixa de diálogo. (Poderá querer fazer isto para verificar se uma ligação externa é válida).

Se quer sair do rótulo de ligação (o texto exibido como uma ligação) ou continuar a escrever após esta ligação, pode clicar em :

  • Pressione-a uma vez para sair da caixa de diálogo de edição da ligação e posicione o cursor no final do elemento ligado (destacado em azul, para editar este elemento)
  • Pressione-a duas vezes para posicionar o cursor no final do elemento ligado, preparado para digitar o restante de seu texto

Para editar o rótulo em uma ligação existente, clique no rótulo da ligação e escreva o novo. Mas se deseja substituir todo o rótulo, por favor note:

  • Se selecionou (destacou) toda a etiqueta da hiperligação, esta será eliminada ao pressionar qualquer tecla. Poderá interligá-la desde o início.
  • To keep the link directly, you may press within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Agora você pode digitar a nova etiqueta para a hiperligação mantida.
  • Você também pode ligar a categorias, arquivos e mais.

Editar referências

Para obter mais informações, consulte Ajuda para utilizar predefinições de ligação ou Ajuda para utilizar o botão Citar.

Determinar qual sistema está em vigor

Sua wiki pode utilizar um dos três sistemas de notas de rodapé. A opção mostrada à direita é o sistema mais simples, onde o menu "Citar" não inclui nenhuma predefinição de citação. Se a sua wiki utiliza este sistema, então tudo o que precisa saber acerca das notas de rodapé está nesta página.
VisualEditor cite menu default.png

O segundo sistema possui o mesmo tipo de menu "Citar", mas com várias predefinições populares de citação configuradas para acesso rápido. Se a sua wiki utiliza este sistema, poderá encontrar mais detalhes em Help:VisualEditor/User guide/Citations-Templates .
VisualEditor references more.png

VisualEditor citoid Cite button-pt.png
No terceiro sistema, comece clicando novamente no botão Citar. Em seguida, é aberta uma caixa de diálogo que possui um processo de citação automática que utiliza o serviço citoid. Se a sua wiki utiliza este sistema, encontrará mais detalhes em Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-pt.png

Editar uma referência existente

Para editar uma referência existente, clique nela onde estiver ao longo do texto (geralmente, são indicadas por um número entre parênteses retos). Verá ou o ícone "Referência" (marcador) ou um ícone (e o nome) para a predefinição utilizada para criar esta referência. Em qualquer caso, ao clicar no botão "Editar" surgirá uma caixa de diálogo onde pode editar a referência.
VisualEditor - Editing references 1.png

Para o ícone "Referência", clique em "Editar" para abrir a caixa de diálogo Referência. Para iniciar a alteração das informações da referência, clique sobre ela.

Muitas wikis utilizam predefinições para formatar as referências de acordo com um padrão específico. Se uma predefinição é usada na sua referência, após posicionar o ponteiro do mouse sobre as informações da referência, todas as informações nesse campo serão destacadas.

Se uma predefinição foi utilizada e clicaste nas informações da referência, o ícone Predefinição (peça de puzzle) surgirá com algumas informações. Clique no botão "editar" para editar o conteúdo da predefinição na mini-caixa de diálogo.

VisualEditor - Editing references 6.png

Se, ao clicar numa referência, for mostrado um ícone para uma predefinição padrão para citações (um exemplo é mostrado à direita), clique a seguir em "Editar" para abrir a caixa de diálogo com o mini-editor de predefinições.
VisualEditor - Editing References - Cite Web-pt.png

No mini-editor de predefinições, poderá adicionar ou remover quaisquer tipos de informação ou alterar o conteúdo atual. Serão mostrados, inicialmente, apenas os campos (parâmetros de predefinição) que têm conteúdo. Para adicionar campos, clique em "Adicionar mais informações" na parte inferior do mini-editor.
VisualEditor - Editing references 5-pt.png

Clique em "Aplicar alterações" quando terminar.
VisualEditor Apply Changes-pt.png

Reutilizar uma referência existente

Se a página já possui referências que se apliquem ao texto, pode reutilizar uma citação existente, se esta se aplicar ao texto que deseja referenciar.

Para reutilizar uma referência existente, posicione o cursor na parte do texto onde deseja adicionar uma nova referência (número) para esta citação. Depois clique no item "Reutilizar", no menu "Citar".

(Nota: Se a sua wiki possui o terceiro sistema de notas de rodapé descrito acima, verá uma guia "Reutilizar" em uma caixa de diálogo, em vez de um item "Reutilizar" no menu "Citar".)

VisualEditor Cite menu re-use.png

Na caixa de diálogo Referência, procure na lista pela referência que gostaria de reutilizar e seleccione-a. Se houver muitas referências, pode utilizar a caixa de pesquisa (rotulada com "Procurar nas citações atuais") para mostrar apenas as referências que incluam um determinado texto.
VisualEditor - Editing references 18-pt.png

Adicionar uma nova referência

Para adicionar uma nova referência com o menu "Citar", posicione o cursor onde deseja adicioná-la no texto. De seguida, selecione o tipo apropriado de citação no menu.
VisualEditor references more.png

Usar a citação "Básica"

O que se mostra aqui é o que verá caso selecione o item de referência básica. No editor Referência, pode adicionar a sua citação, incluindo a sua formatação.

Pode fazer com que a sua referência pertença a um certo grupo, apesar de normalmente não ser especificado nenhum. (Esta opção é utilizada para mostrar grupos de referências com a ferramenta "Lista de referências".)

VisualEditor - Editing references 20-pt.png

Na caixa de diálogo Referência, se quiser incluir uma predefinição de citação, ou qualquer nova predefinição, na sua nova referência, clique no ícone Predefinição (peça de puzzle) no menu "Inserir" da barra de ferramentas do editor de referências.
VisualEditor Template Insert Menu-pt.png

Depois, procure pela predefinição que gostaria de usar, inclua-a e edite-a como faria com uma já existente. (Veja a seção Editar predefinições abaixo se necessitar de mais informações.)

Se já terminou de editar a sua nova predefinição, clique em "Aplicar alterações" para regressar ao editor de referências, e "Aplicar alterações" novamente para retornar à página que está a editar.

VisualEditor - Editing references 9-pt.png

Se ainda não há uma lista de referências na página (por exemplo, se está a inserir a primeira referência na página), precisa de especificar onde a lista de referências, e o seu texto, será apresentada ao leitor.

Coloque o cursor no local em que lista de referências devem aparecer (geralmente no final da página), abra o menu "Inserir", e clique no ícone "Lista de referências" (três livros).

VisualEditor References List Insert Menu-pt.png

Se criou grupos de referências, o que é normalmente raro, pode especificá-los nesta janela. Apenas as referências que pertencem a esse grupo serão exibidas no local onde está localizado o grupo.

O último passo final é clicar em "Inserir" na janela.

VisualEditor references list-pt.png

Usar predefinições padrão de citação

A sua wiki local poderá ter adicionado predefinições de citação extra no menu "Citar". Se assim for, terá fácil acesso às predefinições de referências mais utilizadas na sua wiki. (Instruções para adicionar predefinições de citação extra à sua wiki local estão disponíveis na página VisualEditor/Ferramenta de citação .)
VisualEditor - Editing References - Cite Pulldown.png

Ao clicar no ícone de uma predefinição como "Citar livro", será direcionado o mini-editor para essa mesma predefinição. Os campos de informação importantes podem ser marcados com um asterisco. Embora sejam mostrados os campos mais comuns, nem todos eles são necessários.
VisualEditor - Editing references - Cite book required fields-pt.png

Para acrescentar mais parâmetros, clique na opção "Adicionar mais informações" que se encontra na parte inferior do mini-editor.

Clique em "Inserir" quando terminar.

VisualEditor - Editing references - Add parameter-pt.png

Editar imagens e outros ficheiro multimédia

Editar imagens

Para inserir uma nova imagem (ou outro tipo de ficheiro multimédia), clique no ícone "Imagens e multimédia" (uma imagem de montanhas) no menu "Inserir". A imagem será incluída onde o rato estiver.
VisualEditor Media Insert Menu-pt.png

Ao clicar no ícone "Imagens e multimédia", é aberta uma janela que procura automaticamente ficheiros multimédia relacionados com o título da página que está a editar no Wikimedia Commons.

Pode procurar por outros ficheiros multimédia ao alterar o texto no campo de pesquisa da janela.

Para escolher um ficheiro, clique na sua respetiva miniatura.

Desta forma, colocará a imagem na página que está a editar.

VisualEditor - Media editing 2.png

Depois da imagem que selecionou ser inserida na página, será aberta outra caixa de diálogo. A janela de média permite que insira e edite uma legenda, que pode conter formatação e hiperligações.
VisualEditor - Media editing 6.png

O diálogo "Média" também permite a inserção de legendas e/ou textos alternativos, para ajudarem utilizadores com leitores de ecrã, ou que possuem desabilitada a exibição de imagens nos seus navegadores.
VisualEditor - Media editing 7.png

Pode-se também definir vários parâmetros para a imagem na janela "Configurações avançadas". Estes incluem o alinhamento, tipo e tamanho da imagem.
VisualEditor - Media editing 8.png

Quando terminar, clique "Aplicar alterações" para fechar a janela e voltar à edição da página.
VisualEditor Apply Changes-pt.png

Ao clicar numa imagem existente, pode adicionar ou editar a sua legenda ao clicar no ícone "Imagens e multimédia" que aparece abaixo da fotografia.

Pode redimensionar uma imagem existente, clicando sobre nela, e em seguida, movendo o ícone de redimensionamento (a seta de duas pontas em um ou em ambos os cantos inferiores).

Também pode arrastar e soltar uma imagem para um outro local (acima ou abaixo) da página.

VisualEditor - Media editing 3.png

Carregar uma imagem

Pode carregar imagens a partir de uma guia na caixa de diálogo de média.
VisualEditor - Media upload 1-pt.png

Clique na guia "Carregar" e seleccione uma imagem de seu computador. Pode digitar o nome do ficheiro, ou arrastar uma imagem até a caixa. Se você arrastou e soltou uma imagem diretamente para o editor ou colou uma da sua área de transferência, essa guia será aberta automaticamente.
VisualEditor - Media upload 1.5.png

Precisa de descrever a imagem e adicionar categorias à ela e para que outras pessoas possam encontrá-la.
VisualEditor - Media upload 2.png

A imagem será inserida na página ao terminar.
VisualEditor-logo.svg

Editar galerias multimédia

Para adicionar uma nova galeria, clique no ícone "Galeria" (um conjunto de fotografias) no menu "Inserir". (Caso este ícone não seja mostrado no menu, significa que a sua wiki local decidiu adiar a implementação desta funcionalidade no Editor Visual.)
VisualEditor - Gallery1.png

Para editar uma galeria existente com o Editor Visual, clique na mesma. De seguida, na parte inferior da galeria, clique no ícone (um conjunto de fotos) para abrir o editor da galeria e mostrar a lista completa de imagens incluídas na mesma.
VisualEditor - Gallery2.png
Isto fará abrir a janela de inserção da galeria, que é actualmente uma simples caixa que funciona de forma semelhante à marcação de wiki-texto. Para adicionar novas imagens à sua galeria, deve incluir o nome do ficheiro, seguido de uma barra (|) e da legenda que deseja inserir à imagem. Cada imagem na galeria deve estar na sua própria linha. Pode ainda editar esta lista para remover e/ou reorganizar imagens ou para alterar as legendas.

Quando clicar no botão "Concluído", sairá do editor de galerias. Depois, pode visualizar as mudanças, uma vez que a galeria será agora mostrada aos leitores.

Lembre-se que sair do editor não grava as alterações. Tal como acontece com outras alterações feitas com o Editor Visual, deve gravar a página inteira para guardar o seu trabalho.

VisualEditor - Gallery3.png

Editando predefinições

The powerful MediaWiki template system lets you insert dynamic content, text from other pages, and much more. For a detailed explanation and examples, see the Templates help page.

In the VisualEditor you can search for a relevant template, add an invocation or transclusion on the page you’re editing and, if needed, add custom content using parameters.

Insert new template

Para adicionar uma nova predefinição na página, coloque o rato onde gostaria que a predefinição fosse inserida e clique no ícone "$template" (peça de puzzle) do menu "$insert". Then open the Inserir menu and select "OOjs UI icon puzzle-ltr.svg Predefinição". Alternatively, type two curly brackets {{ to open the same dialog.
VisualEditor Template Insert Menu-pt.png
Find the template you want to insert by typing either its name or a relevant keyword. Results containing the search term in either the name or description will display in a dropdown. This should help you find a relevant template, even if you don’t know its exact name.

If you’re having trouble finding the kind of template you want by using keywords, you can look on other wiki pages with similar content and view or edit the page source to see which templates are in use. When you find the desired template’s name, you can type it into this field to insert it here.

Screenshot of the template search field in the Visual Editor

Pode também editar uma predefinição que já se encontra na página. Ao clicar na predefinição para seleccioná-la, ela é exibida a azul e surge uma caixa com um ícone "$template" (peça de puzzle). A seguir, clique na ligação "$edit". When you select the template you want to edit, it turns blue, and a box appears displaying "OOjs UI icon puzzle-ltr.svg Predefinição". Then select the "Editar" link or double click on the template itself to open the template.
Screenshot of the VisualEditor interface with a template selected

Algumas predefinições não são visíveis para quem lê uma página. No Editor Visual, estas predefinições ocultas são mostradas como ícones de quebra-cabeça. O nome da predefinição será mostrado ao lado do ícone de quebra-cabeça.
Screenshot of hidden templates in the Visual Editor interface

Parâmetros da predefinição

You’ll see this dialog box when you’re adding a new template or editing one already in place. What you see in the box depends on whether the template in question contains TemplateData , helpful metadata added by other editors to make it easier to edit templates in the Visual Editor.

When a template contains TemplateData, the VisualEditor can use it to present annotated fields for you to fill in.


For templates that have some community-provided TemplateData, the VisualEditor displays a list of the named parameters and, often, descriptions and instructions explaining the meaning and required format for each parameter’s values.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

You can disable any optional parameter (which have blue checkboxes on the left side). If a parameter’s checkbox is grayed out and not clickable, the template requires that parameter, so it can’t be disabled.

When you insert a new template, you may find that some optional parameters are pre-selected. That means the author(s) of the template recommends the use of those parameters. It’s best to review all parameters that will be used in a template to ensure you understand their use.

Clicking an unchecked parameter adds it to the template. Clicking a parameter that’s already been added takes you to the parameter’s input field.

Some template parameters will show as “deprecated”. Don’t use deprecated parameters when inserting a template; they’re only visible to you because those parameters are in use on older pages where this template was included.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Adding undocumented parameters

If you’re inserting or editing a template whose author hasn’t laid out its parameters in TemplateData, it has what we call “undocumented” or “unnamed parameters”. In these cases, you should consult the page for the template itself. There you can learn how to correctly employ and work with all of the template’s parameters. This includes learning the exact names of the parameters as written by the template author.

If you find in the documentation that the template expects parameters without have names, fill in numbers as placeholders for the parameter names using the undocumented parameter input, then add next to the values you want to provide as you normally would.

Example:

  • first unnamed parameter: “1”
  • first unnamed parameter’s value: “en_US”
  • second unnamed parameter: “2”
  • second unnamed parameter’s value: “yes”

If you accidentally include nonexistent, misspelled or erroneous parameters, the values you enter for those parameters won’t show up on the page you’re editing.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerated parameters

In this example, the template in question lacks TemplateData but it was possible to autogenerate the parameters. This means that the undocumented parameters have already been added for you, but the names may not be easily understandable and the dialog cannot display any directions or descriptions. As a result the dialog box provides a link to the template’s documentation, which should help you deduce and fill in the template’s various parameters.
Autogenerated parameters in the VisualEditor.png

Editing multi-part template content

During editing, you may open template content consisting of multiple templates or a single template linked to some wikitext. This differs from the nested templates described below. In this case, the templates are better visualized as being stacked or connected.

This content often contains “unbalanced templates,” templates which are incomplete on their own and need to be paired with some wikitext or another template in order to function.

These related pieces of template content must be created in wikitext, but can be edited in the VisualEditor. In these cases you will see a notice at the top of the dialog to signal the situation and a specialized toolbar will be visible at the bottom of the sidebar. There you can use the icon buttons to add additional templates, additional wikitext, delete elements or change their order.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Nested templates

Templates can include other templates as the value for parameters. You’ll recognize it when you see a parameter whose value contains the double curly braces ( {{ }} ) denoting a template.

The VisualEditor can’t present this template within a template (a nested template) using the editor’s easy-to-use interface, so if you want to nest a template yourself, you’ll need to understand how to add the template by hand in wikitext into the appropriate parameter field.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Completing your edit

Quando terminar a edição de uma predefinição, clique em "Aplicar alterações" para fechar a janela e voltar à edição da página principal. Then you can preview your edit and make sure it looks the way you want and expect.

You may also see an error message, which (like the other TemplateData mentioned above) is community-provided content and may vary in usefulness. You may need to consult the template’s own documentation to get to the bottom of some errors. If you’re still having trouble, consider posting about your problem on the template’s talk page.

VisualEditor Apply Changes-pt.png

Removing a template

To remove a template in the VisualEditor, click the template box. Press the "Delete" or "Backspace" key on your keyboard. The template will disappear from the page.
Screenshot of the button to remove a template
Removing a template in the VisualEditor

Editing on mobile

When editing a template on a page using the VisualEditor on a mobile device, you’ll see that the sidebar starts out hidden. You can make it visible by pressing the “Show/hide options” button.
Screenshot of editing a template on a mobile device
Editing a template on mobile in the VisualEditor

Substituição de predefinições

When you insert a template in a wiki page, its content and appearance are reevaluated every time the page loads, based on the template code and the values of its parameters. This means if someone updates the code of a template, then every page which uses that template will also get updated when they publish.

There’s another, much less common way to use templates, though, and that’s to substitute a template. Doing this permanently includes the template content just as it appears at the moment you insert it. It will not update if the template code is later changed.

Most users won’t ever need to resort to substitution. Substitution is typically only useful when you need to capture the exact appearance of one version of a template, such as when content is under development and needs evaluation.

To substitute a template in the VisualEditor, insert a template using the name syntax subst:<template name>. (Autocomplete doesn’t work in this case.) Then press the blue “Add template” button.

When you’re finished, press “Insert”, which will insert the template content as you see it.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Editar listas

VisualEditor Toolbar Lists and indentation-pt.png
Você pode usar o editor visual para criar listas ou para mudar o formato de uma lista existente. Há dois tipos de lista: as não-ordenadas (pontuadas) e as ordenadas (enumeradas).

To start a new list, just press on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then press on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Editar tabelas

VisualEditor insert table-pt.png
Pode usar o Editor Visual para inserir e alterar tabelas.

Pode, inclusive, importar uma tabela ao mover um ficheiro de valor separado por vírgula (.csv) do seu computador para a janela de edição principal.


Ao clicar em "Tabela", no menu "Inserir", o Editor Visual insere uma tabela em branco de quatro-por-quatro.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, press it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double press in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just press elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Pode adicionar, mover ou remover uma coluna ou uma linha.

You can merge cells: Select them, then from the Table menu, press on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Editar categorias

VisualEditor category item-pt.png
Para editar categorias, no menu "Opções da página", clique no item "Categorias".

VisualEditor category editing-pt.png
Ao clicar no item "Categorias", abre-se uma caixa que lista categorias existentes e permite que adicione novas categorias, ou eliminar as categorias existentes.

Tem também a opção de configurar ou alterar a chave geral (padrão) de ordenamento, que determina em que ordem a página aparece quando listada com outras páginas da mesma categoria.

Por exemplo, se a chave de ordenamento padrão para o artigo "George Washington" é "Washington, George". Este artigo será listado na categoria "Presidentes dos Estados Unidos" com a letra "W", e não com a "G".


VisualEditor - Category editing 3.png
Para adicionar uma nova categoria a uma página, escreva o seu nome no campo "Adicionar uma categoria". À medida que vai escrevendo, o Editor Visual procurará uma correspondência nas categorias existentes. Pode selecionar uma categoria existente ou criar uma nova que não tenha página própria. (Até que a página dessa nova categoria seja criada, o seu nome será mostrado a vermelho após gravar as suas alterações.)

VisualEditor - Category editing 2.png
Para remover uma categoria existente, clique nela e depois no ícone "Remover" (caixote do lixo) na janela que abrirá.

Pode também especificar aí a chave de ordenamento para uma categoria específica. Esta sobrepõe-se à chave de ordenamento geral.


VisualEditor Apply Changes-pt.png
Clique em "Aplicar alterações" quando terminar de editar as categorias para regressar à edição da página.

Editar configurações de página

VisualEditor page settings item-pt.png
Para editar as configurações de página, clique para abrir o menu "Opções da página", na barra de ferramentas", e pressione "Configurações da página".

VisualEditor Page Settings-pt.png
O botão "Configurações da página" abre uma caixa de diálogo que mostra várias opções.

VisualEditor Page Settings Redirects-pt.png
Pode fazer da página um redirecionamento para outra, marcando a caixa de seleção "Redirecionar esta página para" e digitando o título da página para a qual quer que o leitor seja enviado quando tentar consultar a página que está a editar.

Abaixo surge a opção para evitar a atualização do redirecionamento. Isto não é muito utilizado.


VisualEditor Page Settings TOC-pt.png
Pode mudar a definição da página sobre a exibição do Índice ao clicar num desses três botões. A opção padrão é "Se necessário", que mostra um índice se houver três ou mais seções.

VisualEditor Page Settings Edit Links-pt.png
Pode desativar as ligações de edição ao lado de cada título de seção ao marcar esta caixa de seleção.

VisualEditor Apply Changes-pt.png
Clique em "Aplicar alterações" ao terminar de editar as Opções da página, a fim de regressar à edição da página.

Editing maps

Visual editor showing editing an existing map.jpg
You can add and change maps. See Help:VisualEditor/Maps .

Editar fórmulas matemáticas

Para adicionar uma nova fórmula matemática à página, posicione o rato no local onde deseja inseri-la e clique no ícone "Fórmula matemática" ("Σ") do menu "Inserir" da barra de ferramentas.
VisualEditor Formula Insert Menu-pt.png

Será aberta uma nova janela para que escreva a fórmula, utilizando a sintaxe LaTeX. O Editor Visual irá atualizar a fórmula à medida que a vá digitando, de forma a que consiga visualizá-la após as mudanças que for efetuando. Depois de terminar a fórmula, clique no botão "Inserir".
VisualEditor formula-pt.png

Para editar uma fórmula matemática existente na página, clique na mesma e depois no ícone "Σ" que aparece. Isto abrirá a janela da fórmula, onde poderá fazer alterações.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, press the "Musical notation" option.

To edit an existing musical notation on the page, double press on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, press the "Done" button to close the dialog and publish your changes.
Musical.png

Editar poemas e outros itens especiais

Alguns itens, tais como listas de associação, poemas e partituras musicais, não são ainda totalmente suportados pelo Editor Visual.
VisualEditor editing poem 1.png

Na maioria dos casos, os itens existentes podem ser editados, mas novos itens não podem ser inseridos no Editor Visual.

Até que sejam totalmente suportados, pode copiar um item já existente de outra página, ou editar o código de wikitexto directamente.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, press the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

You'll see a diff. (If you pressed on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, press the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

Teclas de atalho do teclado

Muitos editores estão acostumados a inserir wikitexto diretamente, especialmente negrito, itálico e ligações internas. Teclas de atalho permitem inserir rapidamente formatações similares sem ser necessário clicar nos botões da barra de ferramentas de edição. Alguns atalhos gerais funcionam no Editor Visual.

Atalho para PC Ação Atalho para Mac

Ctrl+B Negrito ⌘ Cmd+B

Ctrl+I Itálico ⌘ Cmd+I

Ctrl+K Inserir ligação ⌘ Cmd+K

Ctrl+X Cortar ⌘ Cmd+X

Ctrl+C Copiar ⌘ Cmd+C

Ctrl+V Colar ⌘ Cmd+V

Ctrl+Z Desfazer ⌘ Cmd+Z