העורך החזותי: מדריך למשתמש

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 60% complete.

Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎British English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD הערה: כאשר אתם עורכים דף זה, אתם מסכימים לשחרר את תרומתכם תחת רישיון CC0. ראו את דפי העזרה בנושא נחלת הכלל למידע נוסף.
PD
אם ברצונכם לנסות את העורך החזותי מבלי לערוך ערך או דף תוכן, כאן יש דף שבו אפשר להתנסות בעורך החזותי באופן חופשי. אין צורך בחשבון כדי להשתמש בעורך החזותי בדף הזה.

פתיחת העורך החזותי

כדי לערוך דף באמצעות העורך החזותי, לחצו על הלשונית "עריכה" שמופיעה בראש הדף.

פתיחת הדף לעריכה עשויה לקחת מספר שניות, ואף יותר אם הדף שאתם עורכים ארוך מאוד.

לחיצה על הלשונית "עריכת קוד מקור" תפתח את עורך קוד המקור הקלאסי.

VisualEditor edit tab-he.png

ניתן לפתוח את העורך החזותי גם באמצעות לחיצה על הקישור "עריכה" ליד הכותרות של הפסקאות.
VisualEditor - Section edit links-he.png

בואו נתחיל: סרגל הכלים של העורך החזותי

צילום מסך של סרגל הכלים של העורך החזותי
סרגל הכלים של העורך החזותי יופיע בראש המסך ברגע שתתחילו לערוך. הסרגל כולל מספר כפתורים מוכרים:

VisualEditor - Toolbar - Undo-redo.png
לחצו על הכפתור "ביטול" כדי לבטל את הפעולה האחרונה שנעשתה, ועל הכפתור "חזרה על פעולה" כדי לבצע מחדש את הפעולה שבוטלה.

VisualEditor Toolbar Headings-he.png
התפריט הנפתח כותרות מאפשר לשנות את עיצוב הכותרת. כדי לשנות עיצוב של כותרת, מקמו את הסמן בכותרת הרצויה, ולאחר מכן בחרו פריט מהתפריט הזה (אין צורך לסמן שום טקסט). בחרו באפשרות "כותרת" עבור עיצוב לכותרת של פסקה ראשית, או באפשרויות "כותרת רמה 2", "כותרת רמה 3" (וכן הלאה) עבור עיצוב לכותרות משנה של תתי־פסקאות. העיצוב הרגיל עבור טקסט הוא "פסקה".

VisualEditor Toolbar Formatting-he.png

עיצוב: לחיצה על "A" פותחת תפריט.

  • האפשרות "בולט" (B) הופכת את הטקסט שנבחר למודגש.
  • האפשרות "נטוי" (I) הופכת את הטקסט שנבחר לנטוי.
  • האפשרות "כתב עילי" (x2) גורמת לטקסט שנבחר להופיע קטן יותר מהטקסט שסביבו, ולהיות מעט מוגבה ממנו.
  • The "כתב תחתי" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly lower than the surrounding text.
  • האפשרות "קו חוצה" (S) מוסיפה קו רציף העובר דרך הטקסט שנבחר.
  • האפשרות "קוד בשפת תכנות" (צמד סוגריים מסולסלים: {}) משנה את הגופן של הטקסט הנבחר לגופן ברוחב קבוע (monospace), וזה מבדיל אותו מהטקסט שסביבו (שהוא בעל גופן ברוחב יחסי).
  • האפשרות "קו תחתי" (U) מוסיפה קו רציף העובר מתחת לטקסט שנבחר.
  • האפשרות "שפה" (Aあ) מאפשרת לבחור את השפה (למשל, יפנית) והכיוון (למשל, משמאל לימין) של הטקסט שנבחר.
  • האפשרות האחרונה (VisualEditor MediaWiki theme clear icon bitmap.png), שנקראת "ניקוי עיצוב", מסירה את כל העיצוב מהטקסט שנבחר, כולל קישורים.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
כלי קישור: הסמל של השרשרת הוא כלי הקישור. לחיצה עליו (בדרך־כלל לאחר סימון טקסט מסוים) פותחת את חלונית הקישור.

VisualEditor - Cite Pulldown-he.png
ציטוט menu: The "ציטוט" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to basic reference formatting and the ability to re-use citations, using this menu. This menu also gives you quick access to local citation templates, if these are enabled on your wiki.

(Instructions for adding local citation templates to the ציטוט menu at a specific wiki are available at VisualEditor/Citation tool.)


VisualEditor citoid Cite button-he.png
Cite button:

If the citoid service is enabled on your wiki, then you will see a ציטוט button instead of a ציטוט menu.

מטרת שירות ה־citoid היא למלא תבניות ציטוט באופן אוטומטי.


VisualEditor Toolbar Lists and indentation-he.png
רשימות והזחה: שתי האפשרויות הראשונות מאפשרות ליצור רשימת תבליטים או רשימה ממוספרת. שתי האפשרויות האחרונות מאפשרים להקטין או להגדיל את רמת ההזחה של פריט הרשימה המסומן.

VisualEditor Insert Menu-he.png
הוספה: התפריט "הוספה" עלול להשתנות ממיזם למיזם (למשל, ייתכן שהוא לא יהיה זהה באתר ויקיפדיה ובאתר ויקימילון). להלן רשימה של כל האפשרויות שיכולות להופיע בתפריט.
  • האפשרות "מדיה" פותחת את תיבת הדו־שיח להוספת מדיה.
  • האפשרות "תבנית" מאפשרת להוסיף ולערוך תבניות.
  • The "Table" item allows you to insert a table.
  • The "הערה מוסתרת" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode, where they are indicated by an exclamation mark icon. In edit mode, clicking on the exclamation mark icon allows you to edit or delete the comment.
  • האפשרות "היירוגליפים" פותחת את הכלי להוספת היירוגליפים.
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • האפשרות "גלריה" מאפשרת להוסיף גלריה לדף.
  • האפשרות "נוסחה" פותחת את תיבת הדו־שיח להוספת נוסחה מתמטית.
  • The "Graph" item allows you to insert a table.
  • The "Your signature" item allows you to insert your Wikipedia user signature. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • The "רשימת הערות שוליים" icon (three books) opens a dialog in which you can specify where references will be displayed to the reader. Usually this needs to be done only once on a page.

Special character insertion: The "תו מיוחד" (Ω) icon is next to the "הוספה" menu. When clicked, it displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (ניתן לשנות את הרשימה הזאת באופן מקומי עבור כל מיזם. ראו הוראות בדף זה.)
VisualEditor Toolbar SpecialCharacters-he.png

VisualEditor toolbar edit notices icon.png
הכפתור Edit notices מציג הודעות ואזהרות שעשויות להיות רלוונטיות עבור עורכי הדף.

VisualEditor More Settings-he.png
The אפשרויות דף menu is to the left of the שמירת הדף button. On this menu there are options to adjust page settings, such as whether the page is a redirect, or how it is indexed; to add, edit, or delete categories; and to see, using the "שפה" item, the list of articles on the same subject that are in other languages.

VisualEditor bi-directional switching square brackets icon.png
הכפתור מעבר לעריכת קוד מקור מופיע ליד הכפתור שמירת הדף. הוא מאפשר לעבור לעורך קוד המקור.

שמירת שינויים

לאחר שסיימתם לערוך, לחצו על הכפתור הכחול "שמירת הדף" שמופיע בצדו השמאלי של סרגל הכלים. אם לא ביצעתם שינויים בדף, הכפתור יהיה מבוטל (כלומר אפור). To cancel all your editing changes, just close your browser window, or click the "Read" tab above the edit toolbar.
VisualEditor toolbar actions-he.png

Pressing the blue "שמירת הדף" button opens a dialog. You can then enter a brief summary of your actions, mark your edit as minor, and add the page to your רשימת המעקב. The box for the summary is the equivalent of the תקציר: field in the wikitext editor.

באפשרותכם גם לבדוק מהם השינויים שביצעתם בדף באמצעות לחיצה על הכפתור "סקירת שינויים". זה שימושי כדי לבדוק שאתם אכן מתכוונים לשמור ולפרסם את כל השינויים שביצעתם. פעולה זו זהה לכפתור "הצגת שינויים" שבעורך קוד המקור.

לחיצה על הכפתור "המשך עריכה" תחזיר אתכם לדף שערכתם. תוכלו לבצע בדף שינויים נוספים ולאחר מכן לשמור את כל העריכה.

VisualEditor save dialog-he.png

עריכת קישורים

VisualEditor - Toolbar - Linking.png
ניתן להוסיף קישורים באמצעות לחיצה על הכפתור "קישור" בסרגל הכלים (סמל של שרשרת), או באמצעות הקשה על צירוף המקשים Ctrl+K (במחשב מק: K+).

אם תסמנו טקסט ולאחר מכן תלחצו על הכפתור "קישור", הקישור יתווסף לטקסט שנבחר. אם הקישור מכיל מילה אחת בלבד, אפשר פשוט למקם את סמן העכבר בתוך המילה (אין צורך לסמן את כל המילה).


VisualEditor - Link editing inline 2-he.png
לאחר שתלחצו על כפתור הקישור או תקישו על צירוף המקשים, תיפתח תיבת דו־שיח שבה תוכלו להזין את הקישור.

The link tool will try to help with internal links by searching for likely matches.


לאחר שכתבת או בחרת את יעד קישור, יש לסיים את תהליך הקישור באמצעות לחיצה על Enter, לחיצה על הכפתור "סיום" או פשוט לחיצה מחוץ לתיבה. הקישור יופיע מיד בעורך, אך כמו שינויים אחרים בדף, זה לא יישמר עד לשמירת הדף.

VisualEditor - External link-he.png
כדי להוסיף קישור לדף באתר אחר, התהליך דומה: עליך לבחור בלשונית "External link" ולהזין את הכתובת בתיבה.

VisualEditor link tool simple link.png
קישור חיצוני ללא תווית נראה ככה: [1]. ניתן להוסיף את אלו על ידי מיקום הסמן במרחק מכל מילה שהיא (למשל - אחרי רווח). פתחו את כלי הקישורים על ידי לחיצה על הכפתור או הקשה על מקשי הקיצור. הקלד את הכתובת בתיבה, ולחץ על הכפתור "סיום" כדי להכניס את הקישור.

VisualEditor-context menu-link tool.png
כדי לשנות או להסיר קישור קיים יש ללחוץ על הקישור, ואז ללחוץ על הסמל קישור שמופיע לידו. ניתן גם ללחוץ על סימון הקישור בסרגל הכלים, או להשתמש בקיצור Ctrl+K במקלדת כאשר הסמן נמצא על הקישור. When a link is selected, it appears as blue framed.

In the link editing dialog, you can then change where the link goes. You can also remove the link altogether by pressing the "הסרה" button in the upper right corner of the dialog. You can also open the link's target in another window by clicking on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text

To edit the link label of an existing link, click within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may click within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.

עריכת מקורות

למידע נוסף, ראה Help using citation templates or Help using citoid's Cite button

Determining which system is in place

הויקי שלך יכול להשתמש בתצורה אחת מתוך שלוש תצורות של מערכת הערת שוליים. The one shown on the right is the simplest system, where the "ציטוט" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "ציטוט" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png
In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Editing an existing reference

To edit an existing reference, click on it where it appears in the text (usually as a bracketed number). You will see either a "הערת שוליים" icon (bookmark) or an icon (and name) for the template that was used to create this reference. In either case, clicking on the "Edit" button will open a dialog where you can edit the reference.
VisualEditor - Editing references 1-he.png

For the "הערת שוליים" icon, clicking "Edit" opens the Reference dialog. To start changing the reference information, click on it.

אתרי ויקי רבים משתמשים בתבניות כדי לעצב רשימות סימוכין. אם הסימוכין שלך נעזר בתבנית, כל הטקסט בתבנית יהיה מסומן בעת לחיצה על המידע שבסימוכין.

אם הערת השוליים היא תבנית ולחצת על מידע התבנית הזאת, יופיע הסמל תבנית (חלק של תצרף). לחיצה על הסמל הזה תפתח את עורך התבניות הקטן.

VisualEditor - Editing references 6-he.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web-he.png

Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content will show, initially. To add fields, click on "הוספת מידע" at the bottom of the mini-editor.
VisualEditor - Editing references 5-he.png

יש ללחוץ על "החלת שינויים" בסיום העריכה.
VisualEditor Apply Changes-he.png

שימוש חוזר בהערת שוליים קיימת

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

To re-use an existing reference, place your cursor in the body of the text where you want to add a new reference (number) for that citation. Then click on the "Re-use reference" item from the "ציטוט" menu.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "ציטוט" menu.)

VisualEditor Cite menu re-use-he.png

In the הערת שוליים dialog, look at the list for the reference you want to reuse, and select it. If there are many references, you can use the search box (labeled "חיפוש בין הערות השוליים הקיימות") to list only those references that include certain text.
VisualEditor - Editing references 18-he.png

הוספת הערת שוליים חדשה

To add a citation using the "ציטוט" menu, place your cursor where you want to add it in the text. Then select the appropriate citation type in the menu.
VisualEditor references more-he.png

שימוש בציטוט בסיסי

Shown here is what you will see if you select the basic references item. In the Reference editor, you can add your citation, including formatting.

You can make the reference belong to a given group, although normally this is left blank. (This option is used to display groups of references with the "רשימת הערות שוליים" tool.)

VisualEditor - Editing references 20-he.png

In the Reference dialog, if you want to include a citation template, or any other template, in your new reference, click the תבנית icon (puzzle piece) in the "הוספה" toolbar menu within the Reference editor.
VisualEditor Template Insert Menu-he.png

לאחר מכן יש לחפש את התבנית שרצית להשתמש בה, להוסיף אותה ולערוך אותה כפי שעורכים כל תבנית אחרת. (ר' את הסעיף עריכת תבניות בהמשך אם נחוץ מידע נוסף על תבניות.)

אחרי שסיימת לערוך את התבנית, יש ללחוץ על "החלת שינויים" כדי לחזור לחלון עורך הערות השוליים ושוב על "החלת שינויים" על מנת לחזור לחלון העורך הראשי.

VisualEditor - Editing references 9.png

אם עדיין לא קיימת רשימת מראי מקום בדף הנוכחי (למשל, אם מדובר בהוספת מראה המקום הראשון בערך) , יש צורך לציין היכן רשימת מראי המקום והטקסט שלהם יוצגו לקורא.

Place the cursor where you want to display the references list (usually at the bottom of the page), open the "הוספה" menu and click the "רשימת הערות שוליים" icon (three books).

VisualEditor References List Insert Menu-he.png

If you are using several groups of references, which is relatively rare, you can specify the group in this dialog. Only the references that belong to that group will be displayed on the page at the location where you are placing the group.

הצעד האחרון בתיבת-שיח רשימת מראי מקום הוא לחיצה על "הוספה".

VisualEditor references list-he.png

שימוש בתבניות ציטוט תקניות

Your local wiki may have added extra citation templates to the "ציטוט" menu. If so, you have quick access to the most-used citation templates for your wiki. (הוראות על הוספת תבניות לוויקי שלכם זמינות בדף VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown-he.png

לחיצה על סמל תבנית, כגון "צ-ספר" תיקח אותך לעורך התבניות עבור אותה התבנית. שדות מידע חשובים יסומנו בכוכבית. השדות הנפוצים ביותר יוצגו, אבל אין חובה למלא את כולם. frameless|border|430px|center

כדי להוסיף עוד פרמטרים, יש לגלול עד הסוף בעורך התבניות וללחוץ על האפשרות "הוספת מידע".

בסיום יש ללחוץ על "הוספה".

VisualEditor - Editing references - Add parameter.png

הוספת תמונות וקובצי מדיה אחרים

עריכת תמונות

כדי להוסיף לדף תמונה חדשה (או סוג אחר של קובץ מדיה), יש ללחוץ על סמל "מדיה" (תמונה של הרים) בתפריט הוספה. התמונה תתווסף במקום בו נמצא הסמן.
VisualEditor Media Insert Menu-he.png

לחיצה על כפתור ה"מדיה" פותחת תיבת-שיח שמחפשת אוטומטית בוויקישיתוף ובוויקי שלכם קובצי מדיה המתאימים לכותרת של הדף אותו אתם עורכים.

ניתן לחפש קובצי מדיה אחרים על ידי שינוי הכיתוב בתיבת החיפוש.

יש ללחוץ על התמונה הממוזערת כדי לבחור קובץ.

זה ממקם את התמונה לתוך הדף אותו אתם עורכים.

VisualEditor - Media editing 2.png

אחרי שהתמונה שבחרתם מוקמה בתוך הדף, תיפתח תיבת־שיח אחרת. התיבה הזאת מאפשרת לכם להוסיף ולערוך את כותרת התמונה. הכותרת יכולה להכיל עיצוב וקישורים.
VisualEditor - Media editing 6.png

תיבת המדיה מאפשרת גם להוסיף לתמונה כיתוב חלופי, שמקל על קוראים שמשתמשים בקוראי מסך או שביטלו את האפשרות להצגת תמונה.
Media editing 7.png

ניתן להגדיר פרמטרים מגוונים לתמונה בחלון "הגדרות מתקדמות". זה כולל יישור, סוג וגודל התמונה.
VisualEditor - Media editing 8.png

בסיום עריכת המדיה, לחצו על "החלת שינויים" כדי לסגור את החלון ולחזור לעריכת הדף.
VisualEditor Apply Changes-he.png

עבור תמונה קיימת, ניתן להוסיף או לערוך את כיתוב התמונה ואת ההגדרות האחרות באמצעות לחיצה על התמונה, ואז לחיצה על צלמית "מדיה" שמופיעה מתחתיה.

ניתן לשנות את גודל התמונה הקיימת באמצעות גרירת צלמית שינוי הגודל (החץ הדו־כיווני בפינות התמונה).

ניתן גם לגרור את התמונה למיקום גבוה או נמוך יותר בדף.

VisualEditor - Media editing 3.png

Uploading images

You can upload images from a tab in the media dialog.

Click the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box.
VisualEditor - Media upload 1.PNG

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.PNG

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

עריכת גלריות מדיה

To add a new gallery, click the "גלריה" icon (a set of photos) on the "הוספה" menu. (If you don't see this icon on that menu, then your local wiki has decided to delay implementing this functionality in the visual editor.)
VisualEditor - Gallery1.png

כדי לערוך גלריה קיימת בעורך החזותי, ליחצו על הגלריה. קרוב לתחתית הגלריה ליחצו על צלמית הגלריה (חפיסת תמונות). זה מעלה את עורך הגלריות, עם רשימה מלאה של תמונות המשויכות לגלריה הזאת.
VisualEditor - Gallery2.png
עורך הגלריות הוא תיבה פשוטה שמאפשרת לך לערוך גלריות קיימות בקוד ויקי. כדי להוסיף תמונה לגלריה הקלידו את שם הקובץ ולאחריו פס אופקי (|) ואת הכיתוב לתמונה. כל תמונה צריכה להיות בשורה נפרדת. ניתן לערוך את הרשימה הזאת כדי להסיר או לסדר מחדש את התמונות או כדי לשנות את הכיתובים.

לחיצה על כפתור "סיום" תוציא אתכם מעורך הגלריה. לאחר מכן יוצגו השינויים שלכם בגלריה כפי שהיא תופיע עכשיו לקוראים.

זכרו שיציאה מעורך הגלריה אינה שומרת את השינויים שלכם. כמו במקרה של כל שינוי אחר בעורך החזותי, יש לשמור את כל הדף כדי שהעבודה תישמר.

VisualEditor - Gallery3.png

עריכת תבניות

Starting

כדי להוסיף תבנית חדשה לדף, יש להציב את הסמן במקום שבו ברצונכם להוסיף את התבנית וללחוץ על הצלמית "תבנית" (פיסת פאזל) בתפריט "הוספה".
VisualEditor Template Insert Menu-he.png

יש להכניס את שם התבנית שברצונך להוסיף. כשהיא תופיע ברשימה, יש ללחוץ על שמה. לאחר מכן יש ללחוץ על "הוספת תבנית".
VisualEditor - Template editing 4.png

ניתן גם לערוך תבניות שכבר נמצאות בדף על־ידי סימון התבנית הרצויה ולחיצה על כפתור "תבנית" (פיסת פאזל) המופיע ליד התבנית, ואז לחץ על עריכה.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are shown as puzzle icons. The name of the template will be shown next to the puzzle icon.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

הפרמטרים של התבניות

When you add a new template or open an existing one, the "הכללה" dialog is shown. The contents depends upon whether the template has been documented using the new TemplateDataExtension:TemplateData system or not.

The template shown here has no TemplateData set up for it. The dialog therefore provides a link to documentation for the template. By visiting the documentation you should be able to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

בתבנית קיימת, עורכים את הפרמטרים הרשומים בתיבת-השיח, וניתן להוסיף פרמטרים נוספים באמצעות כפתור "הוספת מידע" הממוקם בתחתית תיבת-השיח.
VisualEditor - Template editing 3.png

כאשר תבנית משתמשת בתבנית נוספת, תבניות־המשנה האלו תופענה בתוך פרמטרים שמציגים אותם. ניתן לערוך אותן או להסירן בתוך שדה הפרמטר.

ניתן להוסיף תת־תבניות חדשות באותה הצורה שבה מוסיפים פרמטרים. ייתכן שיהיה צורך לבדוק את תיעוד התבנית כדי לוודא שתת־התבנית הרצויה נתמכת.

VisualEditor - Template editing 5.png

לסיום

כאשר מסיימים לערוך תבנית, יש ללחוץ על "החלת שינויים" על מנת לסגור את תיבת-השיח ולחזורלעריכת הדף.
VisualEditor Apply Changes-he.png

החלפת תבניות

כאשר צריכים להחליף תבנית יש להקליד subst: (כולל הנקודתיים) לפני שם התבנית.

Autocompletion doesn't work with subst:. If you want to use autocompletion, first find the template you are looking for, and then add subst: in front of the template name.

Then, click the blue "הוספת תבנית" button.

יש להוסיף פרמטרים כרגיל וללחוץ על "הוספה".

VisualEditor - Template editing 7.png

התבנית תתפרש על הדף אחרי הקשת "החלת שינויים".
VisualEditor - Template editing 8.png

Editing lists

VisualEditor Toolbar Lists and indentation-he.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

עריכת טבלאות

VisualEditor insert table.png
אפשר להשתמש בעורך החזותי כדי להוסיף ולשנות טבלאות.

אפשר אפילו לייבא טבלה בעזרת גרירית קובץ המופרד הפסיקים (.csv) ממחשבך לחלון העריכה הראשי.


When you click on "Table", in the "הוספה" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
ניתן להוסיף ולמחוק עמודות ו/או שורות.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

עריכת קטגוריות

VisualEditor category item-he.png
כדי לערוך קטגוריות, יש ללחוץ בתפריט "אפשרויות דף" על הכפתור "קטגוריות".

VisualEditor category editing-he.png
הכפתור "קטגוריות" פותח רשימת קטגוריות קיימות ומאפשר להוסיף חדשות, ולמחוק קטגוריות קיימות.

You also have the option of setting or changing the general (default) sorting key, which determines where the page appears when listed with other pages in the same category.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".


VisualEditor - Category editing 3.png
בשביל להוסיף קטגוריה חדשה לעמוד, יש להזין את שמה בשדה "הוספת קטגוריה". בעת ההקלדה העורך החזותי יחפש שמות מתאימים של קטגוריות קיימות. אפשר לבחור קטגוריה קיימת או להוסיף קטגוריה שעדיין אין לה דף קטגוריה משלה. (עד שהקטגוריה תיווצר, הקטגוריה החדשה שלך תוצג בתור קישור אדום אחרי השמירה.)

VisualEditor - Category editing 2.png
כדי להסיר קטגוריה קיימת יש להקיש על הצלמית "הסרה" (פח אשפה) בתיבת הדו־שיח.

לחיצה על קטגוריה מאפשרת גם לקבוע גם את מפתח המיון לאותה הקטגוריה. מפתח זה ידרוס את מפתח המיון הכללי.


VisualEditor Apply Changes-he.png
יש ללחוץ על "החלת שינויים" כשתסיים לערוך את הקטגוריות בכדי לחזור לדף העריכה.

עריכת הגדרות דף

VisualEditor page settings item-he.png
כדי לערוך את אפשרויות הדף יש להקיש על התפריט הנפתח "אפשרויות דף" בסרגל הכלים ולבחור ב"הגדרות דף".

VisualEditor Page Settings-he.png
הכפתור "הגדרות דף" פותח תיבת-שיח שמציגה מספר אפשרויות.

VisualEditor Page Settings Redirects-he.png
ניתן לגרום לדף להפנות לדף אחר באמצעות תיבת הסימון "להפנות את הדף הזה אל הדף" והקלדת שם הדף שברצונך לשלוח אליו את מי שינסה להיכנס לדף הזה.

בתחתית נמצאת האפשרות שמונעת מפעולת שינוי שם הדף לעדכן את ההפניה. זה משמש לעתים רחוקות מאוד.


VisualEditor Page Settings TOC-he.png
ניתן לקבוע אם הדף יציג תוכן עניינים באמצעות בחירה באחד משלושת הכפתורים האלה. בררת מחדל היא "אם צריך", שתציג את תוכן העניינים אם יש שלוש כותרות או יותר.

VisualEditor Page Settings Edit Links-he.png
ניתן לגרום לדף לא להראות קישורי עריכת פסקה באמצעות סימון התיבה הזאת.

VisualEditor Apply Changes-he.png
עם סיום עריכת אפשרויות דף יש להקיש על "החלת שינויים" כדי לחזור לעורך הדף.

עריכת נוסחאות מתמטיות

כדי להוסיף נוסחה מתמטית חדשה לדף יש למקם את הסמן בנקודה שבה הנוסחה אמורה להופיע ולהקיש על הצלמית "נוסחה" ("Σ") בתפריט הנפתח "הוספה" בסרגל הכלים.
VisualEditor Formula Insert Menu-he.png

נפתח חלון שבו ניתן להקליד את הנוסחה בתחביר LaTeX. העורך החזותי מעדכן את הנוסחה תוך כדי הקלדתה, וכך ניתן לראות כיצד היא תיראה לאחר השינויים. כשהנוסחה נראית לך טוב, ניתן לצאת מחלון הנוסחאות באמצעות הכפתור "סיום".
VisualEditor formula-he.png

כדי לערוך נוסחה מתמטית שקיימת בדף, יש ללחוץ עליה, ואז ללחוץ על הצלמית "Σ" שתופיע עם הלחיצה. פעולה זו תפתח את חלון הנוסחאות ותאפשר לכם לעשות שינויים.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

עריכת שירים ופריטים מיוחדים אחרים

פריטים מסוימים, כגון שירה ויצירות מוזיקליות, אינם נתמכים עדיין בעורך החזותי.
VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.
VisualEditor editing poem 2.png

You can not add an automatic signature or datestamp to a page in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, click the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

If you've done any editing, you'll be asked whether you want to keep your changes. Normally you'll click on "Keep changes".

VisualEditor bi-directional switching to wikitext.png

You'll see a diff. (If you clicked on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, click the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

קיצורי מקלדת

עורכים רבים רגילים להשתמש בקוד ויקי, בייחוד להדגשה, כתב נטוי, וקישורים פנימיים. קיצורי מקשים מאפשרים ביצוע פעולה דומה מבלי להזדקק ללחיצות על פריטים בסרגל הכלים. להלן קיצורי המקלדת הנפוצים בעורך החזותי:

קיצור מקלדת ב־PC פעולה קיצור מקלדת במק

Ctrl+B מודגש Cmd+B

Ctrl+I נטוי Cmd+I

Ctrl+K הכנסת קישור Cmd+K

Ctrl+X חיתוך Cmd+X

Ctrl+C העתקה Cmd+C

Ctrl+V הדבקה Cmd+V

Ctrl+Z ביטול Cmd+Z