Nápověda:VisualEditor/Uživatelská příručka

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 93% complete.
Outdated translations are marked like this.
PD Poznámka: Editací této stránky souhlasíte s uvolněním svého příspěvku pod licencí CC0. Více informací se dočtete na stránce Public Domain Help Pages.
PD


Otevření vizuálního editoru

Editaci stránky pomocí vizuálního editoru spustíte klepnutím na záložku "Editovat" v horní části stránky.

Otevření editoru může trvat pár sekund. U velmi rozsáhlých stránek i déle.

Klepnutím na záložku "Editovat zdroj" se otevře klasický editor zdrojového wikitextu.

VisualEditor edit tab-cs.png

Vizuální editor můžete otevřít také klepnutím na "editovat" u každé sekce.
VisualEditor - Section edit links-cs.png

Začínáme: panel nástrojů Vizuálního editoru

Snímek obrazovky s panelem nástrojů Vizuálního editoru
Jakmile začnete editovat pomocí vizuálního editoru, objeví se v horní části stránky panel nástrojů. Obsahuje některé známé ikonky:

VisualEditor - Toolbar - Undo-redo.png
Zpět a Znovu pro vrácení a obnovení provedených změn.

VisualEditor Toolbar Headings-cs.png
Rozbalovací menu Nadpisy vám umožní změnit formátování odstavce. Styl odstavce změníte tak, že do něj umístíte kurzor a vyberete v tomto menu položku (text nemusíte zvýraznit výběrem). Nadpisy sekcí jsou "Nadpis" a pododdíly jsou "Podnadpis 1", "Podnadpis 2" a tak dále. Normální formát textu je "Odstavec".

VisualEditor Toolbar Formatting-cs.png

Formátování: Klepnutím na "A" se rozbalí menu.

  • Položka "Tučné" (B) vybraný text ztuční.
  • Položka "Kurzíva" (I) změní vybraný text na kurzívu.
  • Položka "Horní index" (x2) způsobí, že se vybraný text oproti okolnímu textu zmenší a posune o trochu výše.
  • Položka "Dolní index" (x2) způsobí, že se vybraný text oproti okolnímu textu zmenší a posune o trochu níže.
  • Položka "Přeškrtnuté" (S) přes vybraný text přidá plnou čáru.
  • Položka "Počítačový kód" (složené závorky: {}) změní písmo vybraného textu na neproporcionální, které ho odliší od okolního (proporcionálního) textu.
  • Položka "Podtržené" (U) přidá plnou čáru pod vybraný text.
  • Položka "Jazyk" (文A) vám umožní označit jazyk (např. japonština) a směr (např. zprava doleva) vybraného textu.
  • Poslední položka (VisualEditor MediaWiki theme clear icon bitmap.png), označená "Vymazat formátování", odebere z vybraného textu veškeré formátování znaků, včetně odkazů.

Pokud nevyberete žádný text, tak v případě, že klepnete na "A", otevřete příslušné menu a vyberete položku, bude formátování textu aplikováno od místa, kde se nachází kurzor.


VisualEditor - Toolbar - Linking.png
Nástroj pro odkazy: Ikonka řetězu je nástroj pro tvorbu odkazů. Klepnutím na ni se (obvykle po vybrání nějakého textu) otevře dialog pro editaci odkazů.

VisualEditor - Cite Pulldown.png
Citační menu: ("Citace") Se používá pro vložení citací do textu (také nazývaných "poznámky" či "reference"). Všechny projekty mají pomocí tohoto menu přístup k základnímu formátování referencí a možnost nového použití. Pokud jsou na vaší wiki zprovozněny citační šablony, nabízí toto menu rychlý přístup také k nim.

(Instrukce ke zprovoznění místních citačních šablon do citačního menu na konkrétní wiki jsou dostupné na stránce VisualEditor/Citation tool .)


VisualEditor citoid Cite button-cs.png
Tlačítko Citace: Pokud je na vaší wiki zapnuta služba citoid, uvidíte místo nabídky Citace tlačítko Citace.

Služba citoid se pokusí vyplnit citační šablony automaticky.


VisualEditor Toolbar Lists and indentation-cs.png
Seznamy a odsazení: Pomocí prvních dvou položek můžete text formátovat buď jako "Seznam s odrážkami" nebo jako "Číslovaný seznam". Zbylé dvě snižují, resp. zvyšují úroveň odsazení položek seznamů.

VisualEditor Insert Menu-cs.png
Vložit: Menu "Vložit" se může na některých projektech lišit. Níže je uveden seznam všech funkcí, které se mohou objevit.
  • Ikonka "Obrázky a média" (obrázek pohoří) otvírá dialog médií.
  • Ikonka "Šablona" (dílek skládačky) umožňuje editovat šablony.
  • Nástroj "Tabulka" umožní vložit tabulku.
  • Položka "Komentář" (bublina) umožňuje vkládat komentáře, které čtenáři nevidí. Tyto komentáře jsou vidět jen při editování a jsou označeny ikonou vykřičníku. V módu editace můžete klepnutím na ikonu vykřičníku komentář editovat či případně smazat.
  • Ikonka "Hieroglyfy" (symbol anch – ☥) zobrazí dialog pro vložení hieroglyfů. (Podívejte se dolů.)
  • Nástroj "Blok kódu" umožní vložit kus zdrojového kódu.
  • Nástroj "Hudební notace" umožní vložit hudební notaci.
  • Ikonka "Galerie" (sada fotografií) umožňuje do stránky vložit galerii.
  • Ikonka "Matematický vzorec" (Σ) zobrazí dialog pro vložení vzorců.
  • Nástroj "Graf" umožní vložit graf.
  • Nástroj "Váš podpis" umožní vložit podpis, který používáte na projektu. Nástroj může být zašedlý (neaktivní) v případě, že editujete typ stránky (jmenný prostor), jako je článek. To jsou jmenné prostory, kde podpisy nesmí být vkládány.
  • Ikonka "Seznam referencí" (tři knihy) otvírá dialog, ve kterém můžete určit, kde se mají čtenáři zobrazit reference. To je zpravidla potřeba udělat na každé stránce jen jednou.

Vložení speciálních znaků: Ikonka "Zvláštní znak" (Ω) v menu "Vložit" vám po klepnutí zobrazí dialog s mnoha speciálními znaky. Klepnutím na určitý znak jej vložíte do textu. Mezi nimi jsou některé standardní značky, znaky s diakritikou nebo matematické symboly. (Tento seznam si lze místně přizpůsobit. Instrukce najdete na stránce Vizuální editor/Speciální znaky .)
VisualEditor Toolbar SpecialCharacters-cs.png

VisualEditor toolbar edit notices icon.png
Tlačítko Oznámení zobrazuje jakákoliv oznámení k dané stránce.

VisualEditor More Settings-cs.png
Menu Možnosti stránky se nachází nalevo od tlačítka Zveřejnit změny a menu s volbou editoru. Kliknutím na tlačítko se zobrazí menu s následujícími záložkami (na obrázku vlevo):
  • Kategorie umožňuje spravovat přiřazené kategorie a nastavit, jakým způsobem bude stránka v kategoricích řazena.
  • Nastavení stránky umožní nastavit přesměrování stránky, upravit způsob zobrazení obsahu, skrýt odkazy pro editaci u jednotlivých sekcí a nastavit stránku jako rozcestník.
  • Pokročilá nastavení umožňují nastavit indexaci stránky webovými vyhledávači, zobrazit záložku pro přidání nové sekce a zobrazeného jména.
  • Jazyky zobrazují seznam stránek v ostatních jazycích spojených s aktuálně editovanou stránkou.
  • Použité šablony slouží k zobrazení seznamu odkazů na každou použitou šablonu.

Karty dialogového okna Možnosti jsou také zobrazeny v nabídce Možnosti stránky a lze je otevřít kliknutím na něj. Kromě toho nabídka Možnosti stránky obsahuje tlačítko Zobrazit jako zprava doleva a tlačítko Najít a nahradit, které otevírá dialog, do kterého můžete vkládat hledané znaky, výrazy nebo regulární výrazy a ty, které je mají nahradit, spolu s několika tlačítky pro další možnosti.


VisualEditor bi-directional switching square brackets icon.png
Tlačítko přepnout na editaci zdrojového kódu je vedle tlačítka Zveřejnit změny. Umožňuje přepnout editor do úprav zdrojového kódu.

Zveřejňování změn

Jakmile budete s editací hotovi, klepněte na modré tlačítko "Zveřejnit změny" na panelu nástrojů. Pokud jste na stránce neučinili žádné změny, tlačítko bude neaktivní (zašedlé). Pro zrušení všech editačních změn lze zavřít okno vašeho prohlížeče nebo lze klepnout na záložku "Číst" nad editační lištou.
VisualEditor toolbar actions-cs.png

Stisknutím modrého tlačítka "Zveřejnit změny" se otevře dialogové okno, ve kterém můžete zadat stručné shrnutí provedených změn, označit svou editaci jako malou a nebo si zvolit, zda chcete sledovat budoucí změny této stránky. Políčko pro shrnutí je ekvivalentem políčka Shrnutí editace: z editoru wikitextu.

Také si můžete pomocí tlačítka "Zkontrolujte si změny" překontrolovat provedené změny, abyste se před jejich uložením ujistili, že budou fungovat podle očekávání. Je to obdoba tlačítka "Ukázat změny" v editoru wikitextu.

Tlačítko "Návrat k editaci" vás vrátí na stránku, kterou jste editovali. Všechny změny budete moci zveřejnit později.

VisualEditor save dialog-cs.png

Editace odkazů

VisualEditor - Toolbar - Linking.png
Odkazy můžete přidat pomocí ikonky "Odkaz" (články řetězu) na panelu nástrojů nebo pomocí klávesové zkratky Ctrl+K (nebo ⌘ Command+K na Macu).

Když vyberete (zvýrazníte) text a kliknete na tlačítko "Odkaz", tento text se použije pro vytvoření odkazu. U jednoslovných odkazů můžete slovo buď označit nebo stačí na příslušné slovo umístit kurzor.


VisualEditor-link tool-search results-cs.png
Ať už použijete tlačítko nebo klávesovou zkratku, otevře se dialogové okno, ve kterém můžete zadat odkaz.

Nástroj pro tvorbu odkazů se vám pokusí pomoci s interními odkazy hledáním možných výsledků. Jakmile jste zadali nebo zvolili cíl odkazu, můžete odkaz dokončit stisknutím klávesy ↵ Enter nebo kliknutím na tlačítko "Hotovo". Váš odkaz se okamžitě objeví na stránce, ale změny se, stejně jako u všech ostatních změn, zveřejní až zveřejněním celé stránky.


VisualEditor-link tool-external link.png
Odkazy na webové stránky mimo aktuální projekt se vkládají obdobně: Klikněte na záložku "Externí web" a do pole vložte URL.

VisualEditor link tool simple link-cs.png
Externí odkazy bez popisku vypadají takto: [1]. Můžete je přidat tím, že kurzor umístíte mimo jakékoli slovo (např. za mezeru). Otevřete nástroj pro tvorbu odkazů klepnutím na tlačítko nebo stiskem klávesové zkratky. Do rámečku napište URL a klepnutím na tlačítko "Hotovo" odkaz vložíte.

VisualEditor-context menu-link tool.png
Pokud chcete odstranit nebo změnit existující odkaz, klikněte na něj v textu a pak klepněte na ikonku "Odkaz", která se vedle něj objeví. Zobrazí se vám dialog pro editaci. Do dialogu se můžete také dostat klávesovou zkratkou Ctrl+K. Jakmile na odkaz kliknete, objeví se v modrém rámečku.

V dialogu pro úpravu odkazů můžete změnit cíl odkazu. Nebo můžete odkaz úplně zrušit kliknutím na tlačítko "Odebrat" v pravém horním rohu dialogového okénka. Také si můžete cíl odkazu otevřít v jiném okně klepnutím na kopii odkazu v dialogu. (Můžete si tak zkontrolovat platnost externího odkazu.)

V případě, že chcete zrušit popisek odkazu (text zobrazovaný místo samotné adresy odkazu) nebo pokračovat v psaní textu za odkazem, můžete stisknout klávesu :

  • V případě, že ji stisknete jednou, opustíte dialog s editací odkazu a váš kurzor bude umístěn na konec prvku s odkazem (modře orámován)
  • V případě, že ji stisknete dvakrát, bude kurzor umístěn za odkaz tak, že můžete ihned pokračovat ve psaní dalšího textu.

Pro úpravu popisku existujícího odkazu na něj klikněte a přepište jej. Pokud však chcete změnit celý popisek odkazu, uvědomte si, že:

  • Pokud vyberete (označíte) celý popisek odkazu, odkaz bude po napsání jakéhokoliv textu smazán. Můžete tak začít vytvářet odkaz od počátku.
  • V případě, že chcete odkaz zachovat, můžete kliknout na popisek odkazu, použít klávesy backspace či delete pouze jednou a úzký modrý rám okolo textu zůstane přítomen. Nyní můžete pokračovat v psaní nového popisku (textu) odkazu a odkaz se zachová.
  • Odkazovat můžete také na kategorie, soubory a další.

Editace referencí

For further information, see Pomoc s citačními šablonami nebo Pomoc s citačním tlačítkem citoidu

Systémy referencí

Na vaší wiki se může používat jeden ze tří systémů poznámek pod čarou. Vpravo je zobrazen nejjednodušší systém, ve kterém nabídka "Citace" neobsahuje žádné citační šablony. Pokud vaše wiki používá tento systém, najdete na této stránce všechno, co potřebujete o poznámkách pod čarou vědět.
VisualEditor cite menu default-cs.png

Druhý systém používá stejný typ nabídky "Citace", ale s několika populárními citačními šablonami připravenými k rychlému použití. Pokud vaše wiki používá tento systém, najdete více podrobností na stránce Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button-cs.png
Ve třetím systému opět začnete editaci pomocí klepnutí na tlačítko Citace. Poté se otevře dialogové okno, které zahrnuje i automatický citační nástroj, který využívá službu citoid. Pokud vaše wiki používá tento systém, více informací naleznete na Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-cs.png

Editace existující reference

Pokud chcete editovat existující referenci, klepněte na její zobrazení v textu (typicky jako číslo v hranatých závorkách). Buď se objeví ikonka "Reference" (záložka) nebo ikonka (a název) šablony, která byla použita pro vytvoření této reference. Tak či tak se klepnutím na tlačítko "Editovat" otevře dialog, ve kterém budete moci referenci upravit.
VisualEditor - Editing references 1.png

Pokud se objeví ikonka "Reference", klepnutím na ni se otevře dialogové okno Reference, kde budete moci editovat obsah reference.

Na mnoha wiki se pro formátování referencí používají šablony. Pokud se ve vaší referenci používá šablona, bude veškerý obsah šablony po kliknutí na referenci zvýrazněn.

Pokud byla použita šablona a vy jste klepli na informace v této šabloně, objeví se ikonka "Šablona" (dílek skládačky). Klepnutím na tuto ikonku můžete obsah šablony editovat v dialogu s minieditorem šablon.

VisualEditor - Editing references 6.png

Pokud se po stisknutí odkazu zobrazí ikona standardní šablony pro citace (příklad je vpravo), stisknutím tlačítka "Edit" otevřete dialogové okno minieditoru šablony.
VisualEditor - Editing References - Cite Web.png

V minieditoru šablony můžete přidávat nebo odebírat parametry nebo měnit obsah těch stávajících. Nejprve by se měly zobrazit jen vyplněné položky (parametry šablony). Pole můžete přidat klepnutím na "Přidat více údajů" v dolní části minieditoru.
VisualEditor - Editing references 5.png

Jakmile budete hotovi, klepněte na „Použít změny“.
VisualEditor Apply Changes-cs.png

Použití existující reference

Pokud již stránka reference obsahuje, můžete znovu použít existující citaci, pokud se také týká textu, ke kterému chcete doplnit zdroj.

Opětovně můžete použít existující referenci umístěním kurzoru na místo, kam ji v textu chcete přidat a klepnutím na záložku "Re-use" (použít existující) referenci v menu "Citace" (cite).

(Poznámka: Pokud vaše wiki používá třetí systém citací popsaný výše, tak dialog "Re-use" (použít existující) uvidíte až v citačním dialogu a ne v horním menu.)

VisualEditor Cite menu re-use.png

V seznamu v dialogu Reference si najděte referenci, kterou chcete opětovně použít, a vyberte ji. Pokud je referencí mnoho, můžete použít vyhledávací políčko (označené "Hledat ve stávajících referencích"), aby se zobrazily jen reference obsahující daný text.
VisualEditor - Editing references 18.png

Přidání nové reference

Pokud chcete pomocí menu "Citace" vložit novou referenci, umístěte kurzor na místo, kam ji do textu chcete přidat. Pak v menu vyberte příslušný typ citace.
VisualEditor references more.png

Použití "základních" citací

Na obrázku je základní editace citace. V editoru referencí můžete svou citaci přidat, upravovat a formátovat.

Referenci můžete přiřadit do určité skupiny. Zpravidla se však nechává prázdná. (Používá se to pro zobrazení skupin referencí pomocí nástroje "Seznam referencí".)

VisualEditor - Editing references 20.png

Pokud přidáváte novou referenci a chcete v ní použít šablonu, klepněte na panelu nástrojů editoru referencí na ikonku "Šablona" (dílek skládačky) v rozbalovacím menu "Vložit" na panelu nástrojů editoru referencí.
VisualEditor Template Insert Menu-cs.png

Poté najděte šablonu, kterou chcete použít, přidejte ji a editujte jako jakoukoli jinou. (Pokud potřebujete více informací o šablonách, podívejte se na sekci Editace šablon níže.)

Jakmile budete s editací vaší nové šablony hotovi, klepnutím na "Použít změny" se vrátíte do editoru referencí a dalším kliknutím na "Použít změny" se vrátíte na editovanou stránku.

VisualEditor - Editing references 9.png

Pokud na stránce zatím není seznam referencí (například na stránku přidáváte úplně první referenci), musíte určit, kde se jejich seznam, stejně jako jejich text, zobrazí čtenáři.

Umístěte kurzor na místo, kde chcete reference zobrazovat (zpravidla dole na stránce), otevřete menu "Vložit" a klepněte na ikonku "Seznam referencí" (tři knihy).

VisualEditor References List Insert Menu-cs.png

Pokud používáte více skupin referencí, což je relativně vzácné, můžete skupinu v tomto okně zadat. Zobrazí se zde pak jen ty reference, které do této skupiny patří.

Závěrečným krokem v dialogu referencí je klepnout na tlačítko "Vložit".

VisualEditor references list-cs.png

Použití standardních citačních šablon

Na vaší wiki mohou být v menu "Citace" i další citační šablony. To umožňuje rychlý přístup k nejpoužívanějším citačním šablonám. (Instrukce k přidání dalších citačních šablon na konkrétní wiki jsou dostupné na stránce VisualEditor/Citation tool .)
VisualEditor - Editing References - Cite Pulldown.png

Klepnutím na ikonku šablony, například "Citovat knihu" (cite book), se dostanete do minieditoru šablony pro tuto šablonu. Pole důležitých informací mohou být označena hvězdičkou. I když budou zobrazena nejběžnější pole, ne všechna jsou povinná.
VisualEditor - Editing references - Cite book required fields.png

Další parametry můžete přidat tak, že se posunete v minieditoru dolů a klepnete na možnost "Přidat více údajů".

Až budete hotovi, stiskněte "Vložit".

VisualEditor - Editing references - Add parameter.png

Editace obrázků a dalších mediálních souborů

Editace obrázků

Nový obrázek (nebo jiný typ mediálního souboru) do stránky přidáte klepnutím na ikonku "Obrázky a média" (obrázek pohoří) v menu "Vložit". Obrázek se přidá na místo, kde je momentálně kurzor.
VisualEditor Media Insert Menu-cs.png

Klepnutím na ikonku "Obrázky a média" otevřete dialogové okno, které automaticky vyhledá na Wikimedia Commons a na vaší místní wiki mediální soubory související s názvem stránky, kterou upravujete.

Vyhledávání můžete změnit změnou textu ve vyhledávacím poli dialogového okna.

Chcete-li vybrat soubor, klikněnte na jeho miniaturu.

Tím vložíte obrázek na editovanou stránku.

VisualEditor - Media editing 2.png

Jakmile je vybraný obrázek vložen na stránku, otevře se další dialogové okno. To vám umožňuje přidat a editovat titulek obrázku, který může obsahovat formátování a odkazy.
VisualEditor - Media editing 6.png

Dialogové okno médií vám také umožňuje přidat popisek s alternativním textem, což pomáhá uživatelům se zrakovým postižením nebo těm s vypnutým zobrazováním obrázků.
VisualEditor - Media editing 7.png

Různé volby k obrázku můžete nastavit v okně "Pokročilá nastavení". Jsou zde zarovnání obrázku, jeho typ a velikost.
VisualEditor - Media editing 8.png

Jakmile jste hotovi, klepnutím na "Použít změny" dialogové okno zavřete a vrátíte se do editace stránky.
VisualEditor Apply Changes-cs.png

U existujícího obrázků můžete přidat či editovat titulek nebo jiná nastavení tím, že na obrázek klepnete a poté klepnete na ikonku "Obrázky a média", která se pod obrázkem objeví.

U existujícího obrázku můžete změnit velikost tím, že na něj klepnete a poté přetáhnete zvětšovací ikonku (oboustranná šipka v dolních rozích).

Obrázek můžete také chytit a přetáhnout na stránce výše nebo níže.

VisualEditor - Media editing 3.png

Nahrávání obrázků

Obrázky můžete načíst ze záložky dialogového okna médií nebo výběrem a přesunem obrázku do editoru nebo vložením obrázku ze schránky.
VisualEditor - Media upload 1-cs.png

Klepněte na záložku "Načíst" (upload) a vyberte obrázek z vašeho počítače. Můžete změnit jeho jméno a případě přetáhnout obrázek přímo do dialogu. V případě výběru a přesunu obrázku do editoru nebo vložení obrázku ze schránky se tato záložka otevře automaticky.
VisualEditor - Media upload 1.5.png

Musíte popsat obrázek a přidat mu kategorie, to z toho důvodu, aby jej mohli nalézt i ostatní lidé.
VisualEditor - Media upload 2-cs.png

Jakmile obrázek uložíte, bude vložen do stránky.
VisualEditor-logo-cs.svg

Editace galerií souborů

Novou galerii můžete přidat klepnutím na ikonku "Galerie" (sada fotografií) v menu "Vložit". (V případě, že tuto ikonku nevidíte, tak se vaše wiki rozhodla spustit tuto funkcionalitu později.)
VisualEditor - Gallery1.png

Existující galerii můžete Vizuálním editorem editovat tak, že na galerii klepnete. Poté klepněte na ikonku galerie (sada fotografií) poblíž dolního okraje galerie. Tím se otevře editor galerií s úplným seznamem obrázků obsažených v galerii.
VisualEditor - Gallery2.png
Editor galerií momentálně vypadá jako jednoduchý rámeček, který vám umožňuje upravovat existující galerie ve formátu wikitextu. Obrázky do galerie přidáte tím, že uvedete jméno souboru následované svislítkem (|) a titulkem, který má obrázek mít. Každý obrázek v galerii patří na vlastní řádku. Editací seznamu také můžete obrázky odstranit nebo přerovnat nebo změnit jejich titulky.

Když klepnete na tlačítko "Hotovo", opustíte editor galerií. Poté byste měli vidět vaše změny tak, jak se bude galerie zobrazovat čtenářům.

Uvědomte si, že uzavřením editoru galerií se vaše změny nezveřejní. Stejně jako u ostatních změn provedených vizuálním editorem své změny zveřejníte až zveřejněním celé stránky.

VisualEditor - Gallery3.png

Editace šablon

Výkonný systém šablon MediaWiki umožňuje vkládat dynamický obsah, text z jiných stránek a mnoho dalšího. Podrobné vysvětlení a příklady naleznete na stránce nápovědy k šablonám.

Ve VisualEditoru můžete vyhledat vhodnou šablonu, přidat vyvoláním nebo vložit na stránku, kterou upravujete, a v případě potřeby přidat vlastní obsah pomocí parametrů.

Vložení nové šablony

Chcete-li přidat šablonu na stránku, umístěte kurzor na místo na stránce, kam chcete šablonu vložit. Poté otevřete nabídku Vložit a vyberte "OOjs UI icon puzzle-ltr.svg Šablona". Případně zadejte dvě složené závorky {{ pro otevření stejného dialogu.
VisualEditor Template Insert Menu-cs.png
Find the template you want to insert by typing either its name or a relevant keyword. Results containing the search term in either the name or description will display in a dropdown. This should help you find a relevant template, even if you don’t know its exact name.

If you’re having trouble finding the kind of template you want by using keywords, you can look on other wiki pages with similar content and view or edit the page source to see which templates are in use. When you find the desired template’s name, you can type it into this field to insert it here.

Screenshot of the template search field in the Visual Editor

Můžete také editovat šablonu, která již na stránce je. Když vyberete šablonu, kterou chcete upravit, změní se na modrou a zobrazí se pole s "OOjs UI icon puzzle-ltr.svg Šablona". Poté vyberte odkaz "Editovat" nebo dvakrát klikněte na samotnou šablonu a otevřete ji.
Screenshot of the VisualEditor interface with a template selected

Některé šablony nejsou při čtení stránky viditelné. Ve visual editoru se takové skryté šablony stále zobrazují, takže na ně můžete kliknout a upravit je nebo je odstranit. Název šablony se zobrazí vedle ikony puzzle a obě budou zašedlé.
Screenshot of hidden templates in the Visual Editor interface

Parametry šablon

Toto dialogové okno se zobrazí, když přidáváte novou šablonu nebo upravujete již existující. Co vidíte v poli, závisí na tom, zda daná šablona obsahuje TemplateData , užitečná metadata přidaná jinými editory, aby bylo snazší upravovat šablony ve Visual Editoru.

Když šablona obsahuje TemplateData, VisualEditor ji může použít k zobrazení popisných polí, která můžete vyplnit.


U šablon, které mají nějaká komunitou poskytovaná TemplateData, VisualEditor zobrazí seznam pojmenovaných parametrů a často i popisy a pokyny vysvětlující význam a požadovaný formát pro hodnoty každého parametru.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

You can disable any optional parameter (which have blue checkboxes on the left side). If a parameter’s checkbox is grayed out and not clickable, the template requires that parameter, so it can’t be disabled.

When you insert a new template, you may find that some optional parameters are pre-selected. That means the author(s) of the template recommends the use of those parameters. It’s best to review all parameters that will be used in a template to ensure you understand their use.

Clicking an unchecked parameter adds it to the template. Clicking a parameter that’s already been added takes you to the parameter’s input field.

Some template parameters will show as “deprecated”. Don’t use deprecated parameters when inserting a template; they’re only visible to you because those parameters are in use on older pages where this template was included.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Přidání nezdokumentovaných parametrů

Pokud vkládáte nebo upravujete šablonu, jejíž autor neuvedl její parametry v TemplateData, označujeme tyto parametry jako "nedokumentované" nebo "nepojmenované". V těchto případech byste se měli podívat na stránku pro samotnou šablonu. Zde se můžete naučit, jak správně používat a pracovat se všemi parametry šablony. To zahrnuje učení přesných názvů parametrů, jak je napsal autor šablony.

Pokud v dokumentaci zjistíte, že šablona očekává parametry bez názvů, vyplňte čísla jako zástupné symboly pro názvy parametrů pomocí nezdokumentovaného vstupu parametrů a poté je přidejte vedle hodnot, které chcete zadat. Jako obvykle.

Příklad:

  • první nepojmenovaný parametr: "1"
  • hodnota prvního nepojmenovaného parametru: "en_US"
  • druhý nepojmenovaný parametr: "2"
  • hodnota druhého nepojmenovaného parametru: "ano"

Pokud omylem zadáte neexistující, chybně napsané nebo chybné parametry, hodnoty, které pro tyto parametry zadáte, se na stránce, kterou upravujete, nezobrazí.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Automaticky generované parametry

V tomto příkladu dotyčná šablona postrádá TemplateData, ale bylo možné automaticky vygenerovat parametry. To znamená, že nezdokumentované parametry pro vás již byly přidány, ale názvy nemusí být snadno srozumitelné a dialog nemůže zobrazovat žádné pokyny nebo popisy. Výsledkem je, že dialogové okno poskytuje odkaz na dokumentaci šablony, která by vám měla pomoci odvodit a vyplnit různé parametry šablony.
Autogenerated parameters in the VisualEditor.png

Úprava obsahu vícedílné šablony

Během úprav můžete otevřít obsah šablony sestávající z více šablon nebo jedné šablony propojené s nějakým wikitextem. To se liší od vnořených šablon popsaných níže. V tomto případě jsou šablony lépe vizualizovány jako naskládané nebo spojené.

Tento obsah často obsahuje "nevyvážené šablony", šablony, které jsou samy o sobě neúplné a musí být spárovány s nějakým wikitextem nebo jinou šablonou, aby fungovaly.

These related pieces of template content must be created in wikitext, but can be edited in the VisualEditor. In these cases you will see a notice at the top of the dialog to signal the situation and a specialized toolbar will be visible at the bottom of the sidebar. There you can use the icon buttons to add additional templates, additional wikitext, delete elements or change their order.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Vnořené šablony

Šablony mohou obsahovat další šablony jako hodnotu parametrů. Poznáte to, když uvidíte parametr, jehož hodnota obsahuje dvojité složené závorky ( {{ }} ) označující šablonu.

VisualEditor nemůže prezentovat tuto šablonu v šabloně (vnořená šablona) pomocí snadno použitelného rozhraní editoru, takže pokud chcete šablonu vnořit sami, musíte pochopit, jak šablonu přidat ručně. wikitext do příslušného pole parametru.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Dokončení vaší úpravy

Jakmile dokončíte editaci šablony, klepněte na "Použít změny". Poté si můžete prohlédnout náhled své úpravy a ujistit se, že vypadá tak, jak chcete a očekáváte.

Může se také zobrazit chybová zpráva, která (stejně jako ostatní TemplateData uvedená výše) je obsah poskytovaný komunitou a může se lišit v užitečnosti. Možná budete muset nahlédnout do vlastní dokumentace šablony, abyste se dostali k jádru některých chyb. Pokud máte stále potíže, zvažte zveřejnění svého problému na diskusní stránce šablony.

VisualEditor Apply Changes-cs.png

Odebrání šablony

Chcete-li ve VisualEditoru odstranit šablonu, klikněte na pole šablony. Press the "Delete" or "Backspace" key on your keyboard. The template will disappear from the page.
Screenshot of the button to remove a template
Odebrání šablony ve VisualEditoru

Úprava na mobilu

Když upravujete šablonu na stránce pomocí VisualEditoru na mobilním zařízení, uvidíte, že postranní panel je skrytý. Můžete jej zviditelnit stisknutím tlačítka "Zobrazit/skrýt možnosti" (show/hide options).
Screenshot of editing a template on a mobile device
Úprava šablony na mobilu ve VisualEditoru

Nahrazení šablon

Když vložíte šablonu na stránku wiki, její obsah a vzhled se přehodnotí pokaždé, když se stránka načte, na základě kódu šablony a hodnot jejích parametrů. To znamená, že pokud někdo aktualizuje kód šablony, pak se při publikování aktualizuje také každá stránka, která tuto šablonu používá.

Existuje však další, mnohem méně běžný způsob použití šablon, a to nahrazení šablony. Tím trvale uložíte obsah šablony tak, jak se zobrazuje v okamžiku, kdy ji vložíte. Pokud se kód šablony později změní, nebude aktualizován.

Většina uživatelů se nikdy nebude muset uchýlit k nahrazování. Náhrada je obvykle užitečná pouze tehdy, když potřebujete zachytit přesný vzhled jedné verze šablony, například když je obsah ve vývoji a potřebuje vyhodnocení.

Chcete-li nahradit šablonu ve VisualEditoru, vložte šablonu pomocí syntaxe názvu subst:<název šablony>. (Automatické doplňování v tomto případě nefunguje.) Poté stiskněte modré tlačítko "Přidat šablonu". (add template)

Až budete hotovi, stiskněte "Vložit", (insert) čímž se obsah šablony vloží tak, jak jej vidíte.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Editace seznamů

VisualEditor Toolbar Lists and indentation-cs.png
Vizuální editor můžete použít pro vytvoření seznamů či pro změnu formátování existujících seznamů. Existují dva druhy seznamů: neřazený (odrážky) a řazený (číslování).

K započetí editace nového seznamu stačí klepnout na jeden ze dvou nástrojů v menu, které jsou zde zobrazeny. Nebo, v případě, že jste již někdy psali seznam (na oddělené řádky), vyberte (označte) seznam, který jste vytvořili, a pak klepněte na jednu z těchto položek v menu.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Zde jsou zobrazeny příklady dvou typů seznamů: neřazený (odrážky) a řazený (číslování).

VisualEditor lists 3 select to indent.png
V případě, že chcete změnit odsazení části existujícího seznamu, vyberte část seznamu, kterou chcete posunout.

VisualEditor lists 4 indentation menu.png
Poté použijte menu nebo klikněte na tlačítko Tab. (Tlačítko Tab zvětšuje odsazení; pokud použijete kombinaci kláves Shift a Tab, tak dojde ke zmenšení odsazení.)

VisualEditor lists after indenting.png
Zde je výsledek zvětšení odsazení.

VisualEditor lists mixed.png
Můžete používat oba typy seznamů současně, jak řazený (číslování), tak i neřazený (odrážky). To v případě, že seznam má různá odsazení.

Editace tabulek

VisualEditor insert table-cs.png
Pomocí vizuálního editoru můžete vkládat a měnit tabulky.

Můžete dokonce naimportovat tabulku přetažením souboru typu .csv ze svého počítače do hlavního editačního okna.


V případě, že klepnete na ikonku „Tabulka“ v menu "Vložit", visual editor vloží prázdnou tabulku se čtyřmi sloupci a čtyřmi řádky.

V ten okamžik je zpřístupněno menu "Tabulka". V tomto menu můžete upravit popisek tabulky.

VisualEditor empty table-cs.png

Pro vybrání buňky tabulky na ni jednou klepněte.
VisualEditor tables select one cell.png

Pro editaci obsahu buňky (například pro přidání obsahu či úpravu textu) klepněte dvakrát na buňku tabulky. Nebo prostě vyberte buňku a zmáčkněte Enter.

Pro ukončení editace buňky tabulky stačí klepnout kamkoliv jinam.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns-cs.png
Můžete přidat, přesunout nebo odebrat sloupec či řádek.

Můžete také slučovat buňky tabulky: Vyberte ty, které chcete sloužit, a poté z menu Tabulka klepněte na položku: "Sloučit buňky" (merge cells).
VisualEditor tables merge cells.png

V případě, že sloučíte buňky tabulky, je zachován pouze obsah první buňky. Jakýkoliv text, který se nachází v ostatních buňkách tabulky bude smazán. V případě, že se rozhodnete zachovat některý z textů, použijte tlačítko "Zpět" a zkopírujte či přesuňte obsah ostatních buněk tabulky a posléze znovu proveďte sloučení.
VisualEditor tables post-merge cell.png

Můžete také rozdělit dříve sloučené buňky tabulky. Všechen obsah rozdělených buněk bude vložen do první buňky po rozdělení. Můžete pak rozdělit text do nových buněk tabulky.
VisualEditor tables split cells.png

Editace kategorií

VisualEditor category item-cs.png
Pro editování kategorií klepněte v rozbalovacím menu "Možnosti stránky" na položku "Kategorie".

VisualEditor category editing-cs.png
Klepnutím na "Kategorie" se otevře dialogové okno, ve kterém jsou vypsány existující kategorie a ve kterém můžete přidat nové či stávající smazat.

Také máte možnost nastavit nebo změnit obecný (implicitní) klíč řazení, který určuje, kde se stránka objeví na výpisu vedle ostatních stránek ve stejné kategorii.

Například výchozím klíčem řazení pro článek "George Washington" je "Washington, George". V kategorii "Prezidenti Spojených států amerických" je tak uveden pod písmenem "W" místo pod písmenem "G".


VisualEditor - Category editing 3-cs.png
Novou kategorii do stránky přidáte tak, že její název napíšete do políčka "Přidat kategorii". Při psaní vizuální editor vyhledává možné existující odpovídající kategorie. Můžete buď vybrat existující kategorii nebo přidat kategorii, která ještě nemá svou vlastní stránku. (Dokud není vytvořena, bude se po zveřejnění vašich změn zobrazovat jako červený odkaz.)

VisualEditor - Category editing 2-cs.png
Existující kategorii můžete odebrat tím, že na ni klepnete a klepnete na ikonku "Odebrat" (popelnice) v okénku, které se zobrazí.

Klepnutí na kategorii vám také umožní zadat klíč řazení pro tuto konkrétní kategorii. Takový klíč má přednost před obecným klíčem řazení.


VisualEditor Apply Changes-cs.png
Jakmile budete s editací kategorií hotovi, vraťte se do editoru stránky klepnutím na "Použít změny".

Úpravy nastavení stránky

VisualEditor page settings item-cs.png
Pro změnu nastavení stránky klepněte na menu "Možnosti stránky" na panelu nástrojů a vyberte položku "Nastavení stránky".

VisualEditor Page Settings-cs.png
Tlačítko "Nastavení stránky" otvírá dialog, ve kterém jsou různá nastavení.

VisualEditor Page Settings Redirects-cs.png
Stránku můžete přesměrovat na jinou stránku zaškrtnutím políčka "Přesměrovat tuto stránku na" a poté zadáním názvu stránky, na kterou chcete poslat čtenáře, který se pokusí přejít na stránku, kterou upravujete.

Dole je možnost pro zabránění aktualizacím tohoto přesměrování při přejmenování stránky. Používá se velmi zřídka.


VisualEditor Page Settings TOC-cs.png
Výběrem jednoho z těchto tří tlačítek můžete ovlivnit, zda se na stránce zobrazuje tabulka s obsahem. Implicitním nastavením je "V případě potřeby", které zobrazí obsah v případě, že má stránka tři nebo více nadpisů.

VisualEditor Page Settings Edit Links-cs.png
Zaškrtnutím tohoto políčka můžete zajistit, aby se na stránce nezobrazovaly odkazy pro editaci jednotlivých sekcí u jejich nadpisů.

VisualEditor Apply Changes-cs.png
Po dokončení úprav Možnosti stránky stiskněte "Použít změny" pro návrat do editoru stránek.

Editace map

Visual editor showing editing an existing map.jpg
Můžete přidat a změnit mapy. Viz Help:VisualEditor/Maps .

Editace matematických vzorců

Pro přidání nového vzorce do stránky umístěte kurzor tam, kam chcete vzorec vložit, a klepněte na ikonku "Matematický vzorec" (Σ) v menu "Vložit" v panelu nástrojů.
VisualEditor Formula Insert Menu-cs.png

Otevře se okno, do kterého můžete zadat vzorec v syntaxi LaTeX. Vizuální editor bude vzorec v průběhu psaní zobrazovat, takže uvidíte, jak bude vypadat. Jakmile jste se vzorcem spokojeni, klepněte na tlačítko "Vložit".
VisualEditor formula-cs.png

Existující matematický vzorec můžete ve stránce editovat tak, že na něj klepnete, načež klepnete na ikonku "Σ", která se objeví. Tím se otevře okno se vzorcem, ve kterém můžete provést změny.
VisualEditor - editing existing mathematical formula-cs.png

Matematické vzorce mohou být vloženy v řádku nebo vystředěny jako samostatný blok.
VisualEditor mathematic formula inline.png

Editace hudebních notací

K přidání nové hudební notace do stránky umístěte kurzor na místo, kam se má vaše notace vložit. Poté, z menu "Vložit" (insert), klepněte na volbu "Hudební notace" (musical notation).

Pro editaci existující hudební notace na stránce na ni poklepejte.

VisualEditor-Insert-Musical-Notation.png

Toto tlačítko otevře dialog "Hudební notace". V něm lze editovat notaci ve formátu ABC nebo Lilypond. Také můžete k notaci připojit audio nebo MIDI soubor. Jakmile jste hotov(a), klepnutím na tlačítko "Hotovo" (done) zavřete okénko a zveřejněte své změny.
Musical.png

Editace básní a dalších speciálních věcí

Některé funkce, například asociativní seznamy či básně, dosud vizuální editor plně nepodporuje.
VisualEditor editing poem 1.png

Ve většině případů lze existující prvky editovat, ale nové nelze pomocí vizuálního editoru vložit.

Dokud nebudou zcela podporovány, můžete zkopírovat existující z jiné stránky nebo editovat přímo zdrojový wikitext.

VisualEditor editing poem 2.png

Přepínání mezi visual editorem a editorem wikitextu.

Pro přepnutí z visual editoru do editoru wikitextu klepněte na ikonku [[ ]] úplně vpravo na nástrojové liště.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

Uvidíte rozdíl mezi verzemi. (v případě, že klepnete na odkaz "zahodit změny" (discard changes), uvidíte pouhý wikitext, který můžete upravit dále v editoru wikitextu.)

Pod změnami uvidíte editor wikitextu.

VisualEditor bi-directional switching diff before wikitext.png

Můžete také přepnout z editoru wikitextu do visual editoru. K tomu je potřeba klepnout na ikonu tužky úplně napravo na nástrojové liště.

VisualEditor bi-directional switching pencil icon in wikitext.png

Klávesové zkratky

Mnoho editorů je zvyklých zadávat přímo wikitext, zejména tučné písmo, kurzívu a wikiodkazy. Klávesové zkratky vám umožní rychle vložit odpovídající formátování bez potřeby používat panel nástrojů. Zde jsou běžné obecné zkratky ve Vizuálním editoru:

Zkratka na PC Akce Zkratka na Macu

Ctrl+B Tučné ⌘ Cmd+B

Ctrl+I Kurzíva ⌘ Cmd+I

Ctrl+K Vložení odkazu ⌘ Cmd+K

Ctrl+X Vyjmout ⌘ Cmd+X

Ctrl+C Kopírovat ⌘ Cmd+C

Ctrl+V Vložit ⌘ Cmd+V

Ctrl+Z Zpět ⌘ Cmd+Z