Pomoc:VisualEditor/Instrukcja

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 99% complete.

Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎تۆرکجه • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Mìng-dĕ̤ng-ngṳ̄ • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎furlan • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎संस्कृतम् • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎తెలుగు • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD Uwaga: Jeśli edytujesz tę stronę, wyrażasz nieodwołalną zgodę na udostępnianie Twojego materiału na podstawie wolnej licencji CC0. Zobacz Strony Pomocy w Domenie Publicznej, aby uzyskać więcej informacji.
PD
Edytor wizualny można wypróbować nie zmieniając artykułu - tu można swobodnie go testować. Nie jest konieczne posiadanie konta aby zmienić tamtą stronę za pomocą edytora wizualnego.


Uruchamianie edytora wizualnego

Aby zmienić stronę za pomocą edytora wizualnego, należy kliknąć w zakładkę „Edytuj” u góry strony.

Może potrwać kilka sekund, zanim otworzy się strona edycji lub dłużej, jeżeli strona jest bardzo długa.

Kliknięcie w zakładkę „Edytuj kod źródłowy” otworzy klasyczny edytor kodu źródłowego.

VisualEditor edit tab-pl.png

Edytor wizualny można także uruchomić, klikając link „edytuj”, znajdujący się przy nagłówku każdej sekcji.
VisualEditor - Section edit links-en.png

Na początek: pasek narzędzi edytora wizualnego

Zrzut ekranu: pasek narzędzi edytora wizualnego
Po uruchomieniu edytora wizualnego na górze ekranu pojawi się pasek narzędzi. Zawiera on znajome ikony:

VisualEditor - Toolbar - Undo-redo.png
Cofnij lub Ponów wykonane zmiany.

VisualEditor Toolbar Headings-pl.png
Nagłówki (menu rozwijane): pozwala zmienić formatowanie tekstu. Aby zmienić styl akapitu należy umieścić kursor w tekście (nie ma potrzeby zaznaczania czegokolwiek). Tytuły sekcji są formatowane jako „Podstawowy nagłówek rozdziału”, a podsekcji jako „Nagłówek 2”, „Nagłówek 3” itd. Zwykłe formatowanie tekstu to „Akapit”.

VisualEditor Toolbar Formatting-pl.png

Formatowanie: Kliknięcie na „A” otwiera menu.

  • „Pogrubienie” (B) wytłuszcza zaznaczony tekst.
  • „Kursywa” (I) pochyla zaznaczony tekst.
  • „Indeks górny” (x2) umieszcza zaznaczony tekst we frakcji górnej.
  • „Indeks dolny” (x2) umieszcza zaznaczony tekst w indeksie dolnym, tj. będzie mniejszy i niżej niż reszta tekstu.
  • "Przekreślenie" (S) dodaje przekreślenie do zaznaczonego tekstu.
  • Element „Kod programu” (para nawiasów klamrowych: {}) ustawia czcionkę zaznaczonego tekstu na czcionkę o stałej szerokości; nie wpływa to na pozostały tekst w akapicie.
  • Element „Podkreślenie” (A) dodaje linię ciągłą pod zaznaczonym tekstem.
  • „Język” (Aあ) pozwala ustawić język zaznaczonego tekstu (np. na japoński) i kierunek pisania (np. od prawej do lewej).
  • Ostatni element („VisualEditor MediaWiki theme clear icon bitmap.png”), zwany „Wyczyść styl”, usuwa formatowanie zaznaczonego tekstu, w tym linkowanie.

Jeżeli nie zaznaczono żadnego tekstu, po kliknięciu "A" i otwarciu menu, z którego zostanie wybrana pozycja, wybrane formatowanie zostanie zastosowane do następnie wpisywanego tekstu, w miejscu, gdzie zlokalizowany jest kursor.


VisualEditor - Toolbar - Linking.png
Linkowanie: ikona łańcucha symbolizuje narzędzie wstawiania odnośników (linków). Kliknięcie w nią (zazwyczaj po zaznaczeniu tekstu) otwiera okno linku.

VisualEditor - Cite Pulldown.png
Menu „Przypis” używamy do dodania przypisów. Jest możliwość dodania zwykłych przypisów i wykorzystania istniejących, wcześniej już zdefiniowanych. W tym menu dostępne jest także wstawianie szablonów cytowania dostępnych lokalnie na edytowanej wiki.

(Instrukcje dodawania lokalnych szablonów cytowania do menu „Przypis” są opisane na VisualEditor/Citation toolVisualEditor/Citation tool)


Edytor Wizualny - przycisk Przypis.png
Przycisk Przypis: Jeżeli na polskiej wiki jest włączony Citoid, to dostępny będzie przycisk „Przypis” zamiast menu „Przypis”.

Citoid spróbuje samodzielnie wypełnić szablon cytowania.


VisualEditor Toolbar Lists and indentation-pl.png
Listy i wcięcia: pierwsze dwa elementy pozwalają formatować tekst jako „Lista wypunktowana” albo „Lista numerowana”. Kolejne dwa służą do powiększania lub zmniejszania wcięcia listy elementów.

VisualEditor Insert Menu-pl.png
Wstaw: menu „Wstaw” może się różnić na różnych wiki. Poniżej zamieszczono listę wszystkich możliwych opcji.
  • Ikona „Multimedia” (obrazek przedstawiający góry) otwiera okno multimediów.
  • Ikona „Szablon” (puzel) otwiera okno zmieniania szablonów.
  • Element "Tabela" pozwala na wstawienie tabeli.
  • „Komentarz” (dymek) otwiera okno dodawania komentarzy, które są niewidoczne dla czytelników; są widoczne tylko w trybie edycji jako ikonka wykrzyknika w kółku, której kliknięcie pozwala na edycje lub usunięcie komentarza.
  • Ikona „Hieroglify” (symbol anch - ☥) otwiera okno wstawiania hieroglifów (patrz niżej).
  • Element "Blok kodu" pozwala na wstawienie kodu.
  • Element "Notacja muzyczna" pozwala na wstawianie zapisu nut.
  • Ikona „Galeria” (zbiór zdjęć) otwiera okno wstawiania galerii.
  • Ikona „⧼math-visualeditor-mwmathinspector-title⧽” (Σ) otwiera okno wstawiania wzorów matematycznych.
  • Element "Wykres" pozwala na wstawianie wykresów.
  • Element "Twój podpis" pozwala na wstawienie podpisu użytkownika Wikipedii. Element będzie wyświetlony w kolorze szarym (czyli nie można go wybrać), jeżeli będziesz edytować stronę takiego typu (w przestrzeni nazw), w którym nie powinno się wstawiać podpisów.
  • Ikona „Lista przypisów” (trzy książki) otwiera okno dialogowe, w którym możesz określić, gdzie przypisy zostaną wyświetlone czytelnikowi. Zazwyczaj na stronie potrzeba użyć tego tylko raz.

Wstawianie znaków specjalnych: kliknięcie na ikonę „Znak specjalny” (Ω) obok menu „Wstaw” otwiera okno z wieloma znakami specjalnymi. Kliknięcie na znak umieszcza go w tekście. Zbiór znaków specjalnych zawiera niektóre standardowe symbole, litery diakrytyzowane i symbole matematyczne. (Tę listę można lokalnie dostosowywać, zobacz instrukcję: VisualEditor/Znaki specjalneVisualEditor/Special characters)
VisualEditor Toolbar SpecialCharacters-pl.png

VisualEditor toolbar edit notices icon.png
Okno komunikatów wyświetla komunikaty kierowane do użytkownika dotyczące edytowanej strony.

VisualEditor More Settings-pl.png
Menu „Opcje strony” znajduje się na lewo od przycisku „Zapisz”. W tym menu znajdują się opcje strony, takie jak ustawienie strony jako przekierowanie do innej strony czy ustalenie reguł jej indeksowania. Można też dodawać, zmieniać czy usunąć kategorie oraz zobaczyć listę artykułów na ten sam temat napisanych w innych językach, za pomocą elementu „Język”.

VisualEditor bi-directional switching square brackets icon.png
Przycisk ⧼visualeditor-mweditmodesource-tool⧽ znajduje się obok przycisku Zapisz. Umożliwia przełączanie do edytora kodu źródłowego.

Zapisywanie zmian

Po zakończeniu edycji należy kliknąć na niebieski przycisk „Zapisz” na pasku narzędzi. Nie jest to możliwe, jeśli nie dokonano żadnych zmian (przycisk jest szary). Aby anulować wszystkie zmiany edycyjne, wystarczy zamknąć okno przeglądarki albo kliknąć zakładkę „Czytaj” nad paskiem narzędzi edycji.
VisualEditor toolbar actions-pl.png

Naciśnięcie niebiekiego przycisku „Zapisz” otwiera okno, w którym można wprowadzić krótkie podsumowanie swoich działań, oznaczyć edycję jako drobną czy zdecydować się na obserwowanie przyszłych zmian na stronie. To okno odpowiada polu opisu zmian w edytorze kodu źródłowego.

Można też przejrzeć swoje zmiany, używając przycisku „Skontroluj swoje zmiany”. W ten sposób można upewnić się jeszcze przed zapisaniem edycji, że zmiany są zgodne z ich intencjami. Ta opcja odpowiada przyciskowi „Podgląd zmian” w edytorze kodu źródłowego.

Klikając na przycisk „Kontynuuj edycję”, wracasz do edytowanej strony. Później możesz zapisać wszystkie swoje zmiany.

VisualEditor save dialog-pl.png

Edycja linków

VisualEditor - Toolbar - Linking.png
Można dodać link za pomocą ikony „Link” w pasku narzędzi lub używając skrótu klawiszowego Ctrl+K (lub Command+K na Mac-u).

Po zaznaczeniu (podświetleniu) tekstu naciśnięcie na „Link” spowoduje użycie tego tekstu do tworzenia linku. W przypadku linku obejmującego jeden wyraz można albo zaznaczyć wyraz, albo umieścić kursor w środku tego wyrazu.


VisualEditor - menu kontekstowe linku.png
Niezależnie od tego, czy użyto ikonki czy skrótu, to otworzy się okno dialogowe, w którym można wpisać adres linku.

Edytor linków będzie wyszukał proponowane linki wewnętrzne pasujące do tego, co wpiszesz.


VisualEditor link tool 2015.png
Po wpisaniu lub wybraniu linku, można wcisnąć Enter albo kliknąć „Gotowe”. Link pojawi się na zmienianej stronie, ale, jak pozostałe zmiany, nie będzie zapisany, dopóki strona nie zostanie zapisana.

VisualEditor-link tool-external link.png
Aby dodać link spoza Wikipedii, proces jest podobny: należy wybrać zakładkę „External link” i wpisać URL.

VisualEditor link tool simple link.png
Linki zewnętrzne bez etykiet wyglądają tak: [1]. Można je dodać, klikając gdziekolwiek indziej (np. po spacji). Należy otwórzyć narzędzie do edycji linków, klikając na przycisk lub używając skrótu klawiszowego. Należy wpisać URL i kliknąć przycisk „Gotowe”, by wstawić link.

VisualEditor-context menu-link tool.png
Aby zmienić lub usunąć istniejący link, należy kliknąć na niego, a następnie na ikonę „Link” widoczną obok. Pojawi się okno do zmieniania linku. (Można też kliknąć na taką samą ikonę na pasku narzędzi lub użyć skrótu klawiszowego Ctrl+K). Jeżeli link zostanie zaznaczony, to wyświetli się na niebieskim tle.

W oknie zmieniania linku można zmienić stronę do której ma prowadzić link, albo usunąć link, klikając na ikonę „Usuń”, znajdującą się w prawym górnym rogu okna. Można także otworzyć link w osobnym oknie, klikając na wyświetlany w oknie dialogowym podgląd linku. (Do sprawdzenia, czy link zewnętrzny jest poprawny).

Aby wyjść z okna edycji linku (tekstu wyświetlonego jako link) lub kontynuować pisanie po tym linku, można nacisnąć :

  • Pojedyncze naciśnięcie spowoduje wyjście z okna edycji linku i umieści kursor na końcu linkowanego elementu (który będzie wyróżniony w niebieskiej ramce podczas edycji)
  • Dwukrotne naciśnięcie umieści kursor za linkiem, w miejscu, gdzie można kontynuować pisanie.

Aby zmienić etykietę linku (wyświetlany tekst), kliknij na etykietę i wpisz nową. Jeżeli chcesz całkowicie zmienić etykietę, uważaj na:

  • Jeżeli zaznaczyłeś (podświetliłeś) całą etykietę linku, link do zostanie usunięty po wciśnięciu jakiegokolwiek klawisza. Będzie trzeba dodać od nowa ten link.
  • Aby sam link był zachowany podczas zmiany, używaj klawiszy backspace i delete i nie wciskaj ich więcej razy niż to konieczne, pozostanie wtedy wąski niebieski obszar linka. Teraz możesz wpisać nowy tekst pozostawionego linka.

Edycja przypisów

Po więcej informacji zobacz Pomoc w używaniu szablonów cytowania i pomoc w używaniu Citoida

Ustalanie który system obowiązuje

Wiki, na której edytujesz może używać jednego z trzech sposobów wstawiania przypisów. Po prawej wyświetlany jest najprostszy sposób, w którym menu „Przypis” nie zawiera zdefiniowanych dla wiki szablonów cytowania. Jeżeli twoja wiki używa tego systemu, to wszystko co należy wiedzieć o wstawianiu przypisów, jest na tej stronie.
VisualEditor cite menu default.png

Drugi system ma takie samo menu „Przypis”, ale zawierające kilka szablonów cytowania do szybkiego wstawiania. Jeżeli twoja wiki używa tego systemu, to szczegóły można znaleźć na Help:VisualEditor/User guide/Citations-Templates.
VisualEditor references more.png

VisualEditor citoid Cite button.png
W trzecim systemie również zaczynasz przez kliknięcie przycisku Przypis. Pojawi się okienko, które oferuje automatyczny proces wstawiania przypisu przy użyciu usługi Citoid. Jeżeli wiki, na której działasz korzysta z tego systemu to więcej informacji zdobędziesz na stronie Help:VisualEditor/User guide/Citations-FullHelp:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Edycja istniejącego przypisu

Aby zmienić istniejący przypis, należy kliknąć na niego w tekście, w którym się on znajduje (zazwyczaj to liczba w nawiasie). Pojawi się ikona „Przypis” (obrazek zakładki w książce) albo ikona i nazwa szablonu, którego użyto do utworzenia przypisu. W obu przypadkach, kliknięcie na "Edytuj" otworzy okno, w którym można zmienić ten przypis.
VisualEditor - ikona przypisu.png

Kliknięcie na „Edytuj” obok ikony „Przypis” otwiera okno dialogowe. Aby zmienić tekst przypisu należy kliknąć na niego.

Wiele serwisów wiki używa szablonów formatujących przypisy do właściwego standardu. Jeżeli w przypisie użyto szablonu, przesunięcie kursora na tekście spowoduje podświetlenie się tekstu.

Jeżeli użyto szablonu, to kliknięcie na tekst formatowany za pomocą szablonu spowoduje pojawienie się ikony „Szablon”. Należy kliknąć przycisk „Edytuj”, by edytować zawartość szablonu.

VisualEditor - treść przypisu.png

Jeżeli pojawia się wtedy standardowa ikona przypisu (przykład po prawej), kliknięcie „Edytuj” otworzy okno edytowania szablonu.
VisualEditor - Editing References - Cite Web.png

Kliknięcie na ikonę Dołączony szablon pozwala dodać i usuwać rodzaje informacji oraz zmieniać wpisane informacje. Na początku pojawią się tylko te pola (parametry), które zawierają treść. By dodać pola, należy kliknąć na „Dodaj więcej informacji” na dole okna dialogowego.
VisualEditor - edycja szablonu w przypisie.png

Po zakończeniu należy kliknąć "Zastosuj".
VisualEditor Apply Changes-pl.png

Używanie istniejącego przypisu

Jeżeli strona zawiera już przypisy, to można wybrać jeden z nich, o ile dotyczy on informacji do której należy go dodać.

Aby użyć istniejącego przypisu, należy umieścić kursor w miejscu, w którym ma być on dodany i kliknąć na ikonę „Użyj istniejącego” (obrazek zakładki w książce) z menu „Przypis”.

(Uwaga: Jeżeli twoja wiki ma trzeci system wstawiania przypisów opisany powyżej, to będzie dostępna zakładka „Użyj istniejącego” w oknie dialogowym, zamiast ikonki „Użyj istniejącego” widniejącej w menu „Przypis”).

VisualEditor Cite menu re-use.png

W oknie „Przypis” dostępna będzie lista istniejących przypisów, które można wybrać i wstawić ponownie. Jeżeli jest ich wiele, to można użyć wyszukiwarki (podpowiadającej „Wyszukiwanie spośród użytych przypisów”) i otrzymać listę tylko tych przypisów, które zawierają tekst wpisany do wyszukiwarki.
VisualEditor - wyszukiwarka przypisów.png

Tworzenie nowego przypisu

Aby utworzyć nowy przypis używając menu „Przypis”, należy umieścić kursor w miejscu, w którym ma być wstawiony, a następnie wybrać odpowiedni typ przypisu z menu.
VisualEditor - wstaw przypis.png

Użycie „zwykłego wyglądu”

Obok pokazano, co wyświetli się po wybraniu opcji "zwykły przypis". W tym oknie dialogowym można dodać, edytować i formatować swój przypis.

Można określić przynależność przypisu do danej grupy (zwykle do żadnej nie należy). Ta opcja jest używana do wyświetlania grup przypisów za pomocą narzędzia „Lista przypisów”.

VisualEditor - treść przypisu.png

Jeżeli dodawany jest nowy przypis i ma być w nim zawarty szablon przypisu albo jakiś inny, to należy kliknąć na ikonę „Szablon” (obrazek puzzla) w menu „Wstaw” w pasku narzędziowym okna tworzenia nowego przypisu.
VisualEditor Template Insert Menu-pl.png

Należy wybrać szablon, który ma być użyty, dodać i zmienić tak samo, jak zmienia się istniejący. (Zobacz sekcję Edycja szablonów dla uzyskania dodatkowych informacji o szablonach).

Po zakończeniu edytowania nowego szablonu należy kliknąć na „Zastosuj”, by wrócić do edytora przypisów i powtórnie „Zastosuj”, by wrócić do edytowanej strony.

VisualEditor - wybierz szablon w przypisie.png

Jeżeli strona nie zawiera jeszcze listy przypisów (np. tworzony jest właśnie pierwszy przypis), to tę listę dodać, aby treść przypisów wyświetlała się na stronie.

Należy umieścić kursor w miejscu, w którym ma wyświetlać się lista przypisów (zwykle na dole strony) i otworzyć menu „Wstaw”, po czym kliknąć na ikonę „Lista przypisów” (obrazek trzech książek).

VisualEditor References List Insert Menu-pl.png

Gdy używa się kilku grup przypisów, co jest rzadkie, to można wybrać jedną z nich w tym oknie. Tylko te przypisy, które należą do niej, wyświetlą się w miejscu, w którym umieszcza się daną grupę.

Ostatnim krokiem w oknie edycji grup przypisów jest kliknięcie na „Wstaw”.

VisualEditor references list-pl.png

Użycie standardowych szablonów cytowań

Na lokalnej wiki mogą być podane inne szablony w menu „Przypis”. Jeżeli tak jest, to jest szybki dostęp do najczęściej używanych szablonów przypisów na waszej wiki. (Instrukcje takiego dodawania szablonów przypisów do menu są opisane na VisualEditor/Citation tool).
VisualEditor - Editing References - Cite Pulldown.png

Kliknięcie na ikonę szablonu taką jak „Cytuj książkę” zaprowadzi do edytora tego szablonu. Ważne pola informacji mogą być oznaczone gwiazdką. Domyślnie wyświetlają się najczęściej używane pola, ale być może nie będzie potrzeby wypełniania wszystkich.
VisualEditor - Editing references - Cite book required fields.png

By dodać więcej parametrów należy przewinąć okno edycji szablonu i kliknąć na „Dodaj więcej informacji”.

Po zakończeniu należy kliknąć na „Wstaw”.

VisualEditor - Editing references - Add parameter.png

Edycja obrazków i innych plików multimedialnych

Edycja obrazków

Aby dodać nowe zdjęcie (lub inny plik multimedialny) do strony, należy kliknąć ikonę „Media” (obrazek gór) w rozwijanym menu „Insert”. Zdjęcie zostanie wstawione w miejscu, gdzie znajduje się kursor.
VisualEditor Media Insert Menu-pl.png

Kliknięcie na ikonę „Multimedia” otwiera okno dialogowe, które automatycznie wyszukuje w Wikimedia Commons i w polskiej wiki pliki multimedialne związane z tytułem edytowanej strony.

Można szukać innych plików multimedialnych, zmieniając tekst w oknie dialogowym w polu wyszukiwania.

Należy kliknąć na miniaturę, aby wybrać plik.

To umieszcza plik na stronie, która jest edytowana.

VisualEditor - wybieranie pliku.png

Kiedy wybierany jest i wstawiany plik na stronę, to pojawi się nowe okno dialogowe, w którym można dodać (lub zmienić) opis, który może zawierać sformatowany tekst i linki.
VisualEditor - opis pliku.png

Okno edycji multimediów pozwala na dodawanie alternatywnych opisów używanych przez osoby, które używają czytników ekranowych oraz przez tych, którzy wyłączyli wyświetlanie plików.
Edytor Wizualny - ustawienia multimediów - ustawienia podstawowe - alt.png

Można także skorzystać z różnych ustawień plików w oknie „Zaawansowane”. Znajdują się tam opcje wyrównania, rodzaju wyświetlania i rozmiaru pliku.
VisualEditor - Media editing 8.png

Po zakończeniu należy kliknąć Apply changes by zamknąć okno i wrócić do edycji strony.
VisualEditor Apply Changes-pl.png

Można zmieniać opis lub ustawienia istniejącej grafiki poprzez kliknięcie tej grafiki, a następnie kliknięcia ikony "Multimedia" umieszczonej poniżej grafiki.

Można zmienić rozmiar istniejącego pliku, klikając na niego i przesuwając ikony zmieniania rozmiaru (dwukierunkowe strzałki na jednym albo dwóch dolnych rogach pliku).

Można także przeciągać i upuszczać plik, by umieścić go wyżej albo niżej.

VisualEditor - zaznaczony plik.png

Przesyłanie plików

Można ładować nowe pliki, używając zakładki w menu edycji plików.
Edytor Wizualny - ustawienia multimediów - przesyłanie pliku.png

Należy kliknąć przycisk "Załaduj" i wybrać plik grafiki na komputerze lokalnym - można wpisać nazwę lub zaczepić i przeciągnąć do okna.
VisualEditor - Media upload 1.PNG

Należy opisać grafikę i zdefiniować jej kategorię, co pozwoli innym ją odnaleźć.
Edytor Wizualny - ustawienia multimediów - przesyłanie pliku szczegóły.png

Po zakończeniu grafika zostanie wstawiona na stronę.
VisualEditor-logo.svg

Edycja i wstawianie galerii zdjęć

Aby dodać nową galerię, należ kliknąć ikonę „Galeria” (zbiór zdjęć) w menu „Wstaw”. (Jeżeli nie widzisz tej ikony w tym menu to oznacza, że na lokalnej wiki zdecydowano, że zostanie odłożone zaimplementowanie tej funkcji w edytorze wizualnym.)
VisualEditor - Gallery1.png

Aby edytować w edytorze wizualnym istniejącą galerię należy ją kliknąć. Następnie na dole galerii należy kliknąć ikonę galerii (zestaw grafik). Spowoduje to wywołanie edytora galerii z pełnym wykazem grafik w galerii.
VisualEditor - Gallery2.png
Edytor galerii obecnie to zwykłe okno w którym można edytować istniejące galerie w wikikodzie. Aby do galerii dodać nową grafikę, to należy wpisać nazwę pliku, następnie kreskę (|) i opis tej grafiki, przy czym każda grafiki musi być wpisana w oddzielnym wierszu. Można również edytować daną listę - usuwając lub przemieszczając grafiki lub zmieniając ich opisy.

Kliknięcie przycisku "Gotowe" powoduje wyjście z edytora galerii i zostaną pokazane wprowadzane zmiany tak jak są one widoczne dla czytelników.

Należ pamiętać, że wyjście z okna edycji galerii nie zapisze zmian. Tak jak w przypadku innych zmian dokonanych za pomocą edytora wizualnego, trzeba zapisać całą stronę, aby zmiany zostały zachowane.

VisualEditor - Gallery3.png

Edycja szablonów

Pierwsze kroki

Aby dodać nowy szablon, należ umieścić kursor w miejscu, w którym należygo dodać, i kliknąć na ikonę „Szablon” (obrazek puzzla) umieszczoną w menu „Wstaw”.
VisualEditor Template Insert Menu-pl.png

Należy wpisać nazwę szablonu, który należy dodać. Kiedy pojawi się na liście, to należy kliknąć jego nazwę, a następnie kliknąć „Dodaj szablon”.
VisualEditor - wyszukiwarka szablonów.png

Można także edytować szablony, które znajdują się na stronie, poprzez kliknięcie na nie (zaznaczą się na niebiesko) i kliknięcie na ikonę „Szablon”. Następnie należy kliknąć „Edytuj”.
VisualEditor - zaznaczony szablon.png

Niektóre szablony są niewidoczne dla czytelników. W edytorze wizualnym takim ukrytym szablonom towarzyszy ikona puzzla. Obok tej ikony zostanie wyświetlona nazwa szablonu.
VisualEditor template not visible.png

Po wybraniu ikony pojawia się menu kontekstowe i można rozpocząć edycję szablonu.
VisualEditor template not visible context menu.png

Parametry szablonu

Jeśli dodawany jest nowy lub otwierany istniejący szablon, pokazywane jest okno dialogowe "Dołączony szablon". Zawartość tego okna zależy od tego, czy szablon ma dokumentację w nowym systemie, zwanym TemplateDataExtension:TemplateData.

Przykładowy szablon pokazany obok nie ma ustawionego TemplateData. Okno zawiera link do dokumentacji szablonu. Odwiedzając dokumentację dowiesz się czy szablon przyjmuje jakieś parametry (pola) i jak je należy uzupełnić. Jeżeli wprowadzasz parametr nienazwany to jak nazwę wpisz numer kolejności. Pierwszy nienazwany parametr określa się w nazwie 1, drugi jako 2, i tak dalej.
VisualEditor template with no TemplateData.png

Jeżeli do szablonu dodano informacje TemplateData to w okienku zostanie pokazana lista wszystkich parametrów wraz z nazwami.
VisualEditor template with TemplateData.png

Można edytować parametry wyświetlające się w oknie edycji szablonu. Można także dodawać parametry, klikając na „Dodaj więcej informacji” na samym dole okna.
VisualEditor - TemplateData są 2.png

Jeżeli szablon zawiera inne szablony, pojawią się one jako parametry. Mogą być edytowane i usuwane poprzez kliknięcie na nazwę podszablonu.

Nowe podszablony są dodawane analogicznie jak nowe parametry. Można sprawdzić dokumentację szablonu by upewnić się, czy szablon zawiera podszablony.

VisualEditor - Template editing 5.png

Zakończenie

Po zakończeniu należy kliknąć „Zastosuj” by zamknąć okno i wrócić do edycji strony.
VisualEditor Apply Changes-pl.png

Wklejanie szablonów

Kiedy trzeba wkleić szablon, należy wpisać subst: (łącznie z dwukropkiem) przed nazwą szablonu.

Autouzupełnianie nie działa z kodem subst:. Jeżeli potrzebne jest autouzupełnianie, to należy wyszukać szablon i następnie dodać subst: na początku nazwy szablonu.

Następnie należy kliknąć na niebieski przycisk „Dodaj szablon”.

Należy dodać parametry i kliknąć „Wstaw”.

VisualEditor - tworzenie subst2.png

Po kliknięciu „Zastosuj” będzie widoczne rozwinięcie szablonu.
VisualEditor - dołączony subst.png

Edytowanie list

VisualEditor Toolbar Lists and indentation-pl.png
W edytorze wizualnym można tworzyć listy lub zmieniać format istniejących list. Są dwa typy list: nienumerowana (wypunktowana) i uporządkowana (numerowana).

Aby dodać nową listę, kliknij na jedną z dwóch pozycji z menu pokazanego obok. Jeżeli już masz wpisany tekst listy, zaznacz go i kliknij jeden z wspomnianych wcześniej przycisków, aby sformatować wiersze jako listę.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Oto przykłady dwóch typów list: nienumerowana (wypunktowana) i uporządkowana (numerowana).

VisualEditor lists 3 select to indent.png
Jeżeli chcesz zmienić poziom wcięcia części istniejącej listy, zaznacz ją.

VisualEditor lists 4 indentation menu.png
Następnie skorzystaj z odpowiedniej opcji w menu lub wciśnij przycisk Tab. Przycisk Tab zwiększa wcięcie, a kombinacja Shift+Tab zmniejsza je.

VisualEditor lists after indenting.png
Oto przykład dodania wcięcia w liście.

VisualEditor lists mixed.png
Jest możliwość mieszania rodzajów list jeżeli są one na innych poziomach wcięć.

Edycja tabel

VisualEditor insert table.png
Edytor wizualny może być używany do wstawiania i edytowania tabel.

Można również używać go do stosowania metody przeciągnij i upuść wartości w formacie .csv z komputera lokalnego.


Po kliknięciu przycisku "Tabela" w menu "Wstaw" edytor wizualny wstawi pustą tabelę 4x4.

Dostępne będzie menu "Tabela", z którego można dodać tytuł tabeli.

VisualEditor empty table.png

Aby wybrać komórkę, należy ją raz kliknąć.
VisualEditor tables select one cell.png

Aby edytować zawartość komórki (na przykład dodać zawartość lub poprawić błąd), kliknij dwukrotnie tę komórkę. Można też wybrać komórkę i wcisnąć Enter.

Aby zakończyć wprowadzanie zmian do komórki, kliknij w dowolne miejsce poza nią.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Można dodawać i usuwać kolumny i wiersze.

Komórki można scalić: Wybierz je, a następnie z menu Tabela wybierz "Scal komórki".
VisualEditor tables merge cells.png

Podczas łączenia komórek zachowywany jest tekst tylko z jednej z nich; tekst z pozostałych łączonych komórek jest usuwany. Jeżeli potrzebujesz zawartości komórek, która zostanie usunięta, Cofnij operację, skopiuj lub przenieś potrzebny tekst, a następnie ponownie dokonaj łączenia komórek.
VisualEditor tables post-merge cell.png

Można także rozdzielać komórki wcześniej połączone. Cała zawartość takiej komórki znajdzie się w pierwszej z poowstałych w wyniku podziału.
VisualEditor tables split cells.png

Edycja kategorii

VisualEditor category item-pl.png
Edytowanie kategorii wykonuje się po kliknięciu pozycji "Kategorie" w menu "Opcje strony".

VisualEditor category editing-pl.png
Przycisk "Categories" otwiera okno, w którym wymienione są kategorie oraz pozwala dodać nowe.

Istnieje możliwość skonfigurowania klucza sortowania używanego do wstawiania danej strony na stronach kategorii.

Na przykład domyślnym kluczem sortowania hasło "Gabriel Narutowicz" jest ono samo i w kategorii "Prezydenci Polski" byłoby wykazane pod literą "G", a nie "N" (faktycznie ten artykuł ma jawnie ustawiony klucz sortowania "Narutowicz, Gabriel" i jest wykazany pod literą "N").


VisualEditor - dodawanie kategorii 2.png
Aby dodać nową kategorię, należy wpisać jej nazwę w pole „Dodaj kategorię”. Po wpisaniu nazwy kategorii edytor wizualny odszuka możliwe dopasowania istniejących kategorii. Można zarówno wybrać istniejącą kategorię, albo dodać nową. (Dopóki strona kategorii nie zostanie utworzona, nowa kategoria będzie pokazana jako czerwony link po zachowaniu zmian).

VisualEditor - usuwanie kategorii.png
Aby usunąć dołączoną kategorię, należy kliknąć na nią, a następnie na ikonę „Remove” (obrazek kosza) w oknie, które się pojawi.

Można także określić klucz sortowania dla poszczególnych kategorii. Zastępuje on w danym przypadku ogólny klucz sortowania.


VisualEditor Apply Changes-pl.png
Po zakończeniu nalezy klikniąć Apply changes by zamknąć okno i wrócić do edycji strony.

Edycja ustawień strony

VisualEditor page settings item-pl.png
Aby wejść do edycji ustawień strony, należy kliknąć przycisk "Opcje strony" na belce narzędziowej i wybrać pozycję "Ustawienia strony".

VisualEditor Page Settings-pl.png
Kliknięcie przycisku "Ustawienia strony" otwiera okno dialogowe pokazujące kilka opcji.

VisualEditor Page Settings Redirects-pl.png
Można zdefiniować przekierowanie do innej strony za pomocą zaznaczenia pola wyboru "Przekieruj tę stronę do", a następnie wpisania nazwy strony do której ma być przeniesiony czytelnik, który wejdzie na stronę która jest edytowana.

Na dole jest opcja chroniąca przed aktualizacją danego przekierowania w przypadku przeniesienia strony będącej aktualnie celem przekierowania (standardowo takie przeniesienie powoduje powstanie na tej stronie kolejnego przekierowania). Używane jest bardzo rzadko.


VisualEditor Page Settings TOC-pl.png
Poprzez kliknięcie jednego z tych trzech przycisków można wskazać czy na stronie jest wstawiany spis treści. Domyślnym wyborem jest "W razie potrzeby", czyli wstawianie spisu treści w przypadku gdy hasło ma trzy sekcje lub więcej.

VisualEditor Page Settings Edit Links-pl.png
Zaznaczenie tego pola wyboru powoduje, że obok tytułu sekcji nie będzie pokazywany przycisk "Edytuj".

VisualEditor Apply Changes-pl.png
Po zakończeniu edytowania menu "Opcje strony" należy kliknąć przycisk "Zastosuj" aby powrócić do edycji strony..

Edycja wzorów matematycznych

Aby dodać nowy wzór matematyczny należy ustawić wskaźnik kursora w miejscu zamierzonego wstawienia i kliknąć ikonę „⧼math-visualeditor-mwmathinspector-title⧽” („Σ”) w przycisk „Wstaw” paska narzędziowego.
VisualEditor Formula Insert Menu-pl.png

Zostanie otwarte okno do wpisania wzoru z użyciem składni LaTeX-u. Edytor wizualny uaktualni wzór i pokaże wygląd wzoru po zakończeniu zmian. Gdy jesteśmy uszczęśliwieni zmianami, to należy je zatwierdzić klikając przycisk „Gotowe”.
VisualEditor formula-pl.png

Aby edytować wzory matematyczne na stronie należy kliknąć występującą tu ikonę „Σ”. Spowoduje to otwarcie okna wzorów, w którym można wprowadzić zmiany.
VisualEditor - editing existing mathematical formula.png

Wzory matematyczne można umieszczać w linii lub wyśrodkowane blokowo.
VisualEditor mathematic formula inline.png

Edytowanie zapisu nut

Aby wstawić notację muzyczną na stronie, umieść kursor, gdzie ma się pojawić. Następnie z menu "Wstaw" wybierz "Notacja muzyczna".

Aby edytować wcześniej wstawiony na stronie zapis nut, kliknij w niego dwukrotnie.

VisualEditor-Insert-Musical-Notation.png

Zostanie otwarte okno dialogowe "Notacja muzyczna". Tutaj notacja może być edytowana według skali, w formacie ABC lub w LilyPond. Można również powiązać notację z plikiem audio lub MIDI. Kiedy skończysz, kliknij przycisk "Gotowe", aby zamknąć okienko i zachować zmiany.
Musical.png

Edycja fragmentów liryki i innych specjalnych elementów

Niektóre elementy, jak np. listy powiązań i poematy nie są jeszcze w pełni obsługiwane przez edytor wizualny. Aby je dodać lub edytować, należy edytować kod źródłowy.
VisualEditor editing poem 1.png

W większości przypadków istniejące elementy mogą być wstawiane, ale wstawienie niektórych nowych elementów może nie być obsługiwane przez edytor wizualny.

Dopóki nie będzie to w pełni obsługiwane, można to skopiować z innej strony albo przejść do edycji kodu źródłowego.

VisualEditor editing poem 2.png

Przełączanie między edytorem wizualnym i wikitekstu

Aby przełączyć się z edytora wizualnego na edytor wikitekstu, kliknij przycisk [[ ]] znajdujący na pasku narzędzi po prawej stronie.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

Jeżeli wprowadzałeś już jakieś zmiany, zostaniesz zapytany o to, czy chcesz przełączyć się na edytor kodu źródłowego.

VisualEditor bi-directional switching to wikitext.png

Nad oknem edycji zostanie wyświetlone porównanie dotychczas wprowadzonych zmian z ostatnią wersja strony.

Przewiń w dół, aby zobaczyć pole edycji wikitekstu.

VisualEditor bi-directional switching diff before wikitext.png

Możesz także przełączyć się z edytora kodu źródłowego do edytora wizualnego. Aby to zrobić, należy kliknąć ikonę ołówka po prawej stronie paska narzędziowego.

VisualEditor bi-directional switching pencil icon in wikitext.png

After you click the pencil icon, if you've done any editing you'll be asked whether you want to keep your changes. If you click "Keep changes", you'll go to the visual editor. If you click "Discard changes", you'll be asked to confirm that is what you want to do (click on "Leave Page" to confirm) before the visual editor will start.

VisualEditor bi-directional switching to visual editing.png

Skróty klawiszowe

Wielu użytkowników jest przyzwyczajonych do wpisywania wikikodu wprost, w szczególności wytłuszczenia, pochylenia i linków. Skróty klawiszowe pozwalają szybko zastosować podobne formatowanie bez konieczności klikania w pasek narzędzi. VisualEditor zna popularne ogólne skróty oraz skróty stosowane przez niektórych użytkowników.

Skrót PC Akcja Skrót Maca

Ctrl+B Pogrubienie Cmd+B

Ctrl+I Kursywa Cmd+I

Ctrl+K Wstaw link Cmd+K

Ctrl+X Wytnij Cmd+X

Ctrl+C Kopiuj Cmd+C

Ctrl+V Wklej Cmd+V

Ctrl+Z Cofnij Cmd+Z