Madat:VisualEditor/User guide

Jump to: navigation, search
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 1% complete.

Other languages:
العربية • ‎অসমীয়া • ‎asturianu • ‎azərbaycanca • ‎Bikol Central • ‎беларуская (тарашкевіца)‎ • ‎български • ‎বাংলা • ‎bosanski • ‎català • ‎Cebuano • ‎čeština • ‎Cymraeg • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Emiliàn • ‎Ελληνικά • ‎emiliàn e rumagnòl • ‎English • ‎British English • ‎Esperanto • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎føroyskt • ‎français • ‎Frysk • ‎galego • ‎עברית • ‎हिन्दी • ‎Fiji Hindi • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎Interlingue • ‎Ilokano • ‎italiano • ‎日本語 • ‎Basa Jawa • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎latviešu • ‎मैथिली • ‎Malagasy • ‎македонски • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎Napulitano • ‎norsk bokmål • ‎Nederlands • ‎Oromoo • ‎ଓଡ଼ିଆ • ‎ਪੰਜਾਬੀ • ‎Picard • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎саха тыла • ‎Scots • ‎سنڌي • ‎slovenčina • ‎slovenščina • ‎shqip • ‎српски / srpski • ‎Basa Sunda • ‎svenska • ‎தமிழ் • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎українська • ‎Tiếng Việt • ‎isiXhosa • ‎ייִדיש • ‎中文
PD Note: When you edit this page, you agree to release your contribution under the CC0. See Public Domain Help Pages for more info.
If you would like to try VisualEditor without editing an article, here is a page where you can freely test it. You don't need an account to use VisualEditor on that page.

Opening VisualEditor[edit | edit source]

To edit a page using VisualEditor, click on the "Badlo" tab at the top of the page.

Panna ke badle ke khatir khole me kuchh time lagii, aur jaada time bhi lagii agar ii panna lamba hae.

Clicking on the "Edit source" tab will open the classic wikitext source editor.

VisualEditor edit tab-en.png

You can also open VisualEditor by clicking on the "badlo" link on each section.
VisualEditor - Section edit links-en.png

Getting started: the VisualEditor toolbar[edit | edit source]

Screenshot of the VisualEditor toolbar
The VisualEditor toolbar appears at the top of the screen when you begin editing. It includes some familiar icons:

VisualEditor - Toolbar - Undo-redo.png
Undo and Redo the changes you have made.

VisualEditor Toolbar Headings-en.png
Headings pull-down menu: allows you to change how the paragraph is formatted. To change the style of a paragraph, put your cursor in the paragraph and select an item in this menu (you don't have to highlight any text). Section titles are formatted "Heading", and subsections are "Heading 2", "Heading 3", and so on. The normal format for text is "Paragraph".

VisualEditor Toolbar Formatting-en.png

Formatting: Clicking the "A" opens a menu.

  • The "Bold" item (B) bolds the selected text.
  • The "Italic" item (I) italicizes the selected text.
  • The "Superscript" item (x2) causes the selected text to appear smaller than surrounding text and to be slightly higher than the surrounding text.
  • The "Subscript" item (x2) causes the selected text to appear smaller than surrounding text and slightly lower than the surrounding text.
  • The "Strikethrough" item (S) adds a solid bar through the selected text.
  • The "Computer code" item (a set of curly brackets: {}) changes the font of the selected text to a monospaced font, which sets it apart from surrounding (proportionally spaced) text.
  • The "Underline" item (U) adds a solid line beneath the selected text.
  • The "Language" item (Aあ) allows you to label the language (for example, Japanese) and direction (for example, right-to-left) of the selected text.
  • The final item (VisualEditor MediaWiki theme clear icon bitmap.png), called "Clear styling", removes all character formatting from the selected text, including links.

If you have not selected any text, then when you click the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.

VisualEditor - Toolbar - Linking.png
Linking tool: The chain icon is the linking tool. Clicking on it (usually after selecting some text) opens the link dialog.

VisualEditor - Cite Pulldown.png
Cite menu: The "Cite" menu is used to add inline citations (also called "footnotes" or "references"). All projects have access to "Basic" reference formatting and the ability to "Re-use" citations, using this menu. This menu also gives you quick access to local citation templates, if these are enabled on your wiki.

(Instructions for adding local citation templates to the Cite menu at a specific wiki are available at VisualEditor/Citation tool.)

VisualEditor citoid Cite button.png
Cite button: If the citoid service is enabled on your wiki, then you will see a "Cite" button instead of a Cite menu.

The citoid service tries to fill out citation templates automatically.

VisualEditor Toolbar Lists and indentation-en.png
Lists and indentation: The first two items allow you to format text as either a "Bullet list" or a "Numbered list". The last two items allow you to decrease or increase the indentation level of list items.

VisualEditor Insert Menu-en.png
Insert: The "Insert" menu may be different on some projects. Below is a list of all options that may appear.
  • The "Media" icon (a picture of mountains) opens the media dialog.
  • The "Template" icon (a puzzle piece) allows you to edit templates.
  • The "Comment" item (a speech balloon) allows you to insert comments that are not visible to readers; these comments can be seen only when in edit mode and are then indicated by an exclamation mark icon.
  • The table item allows you to insert a table.
  • The "Gallery" icon (a set of photos) allows you to insert a gallery to the page.
  • The "Formula" icon (Σ) opens the formula inserter dialog.
  • The "Hieroglyphs" icon (an ankh symbol - ☥) allows you to enter the hieroglyphics inserter. (See below.)
  • The "References list" icon (three books) opens a dialog in which you can specify where will references be displayed to the reader. Usually this only needs to be done once on every page.

Special character insertion: The "Special character" (Ω) icon on the "Insert" menu, when clicked, displays a dialog showing many special characters. By clicking on a specific character, you place it into the text. These special characters include some standard symbols, accents, and mathematical symbols. (This list may be customized locally. See VisualEditor/Special characters for instructions.)
VisualEditor Toolbar SpecialCharacters-en.png

VisualEditor More Settings-en.png
The Page options menu is to the left of the Save page button. On this menu there are options to adjust page settings, such as whether the page is a redirect, or how it is indexed; to add, edit, or delete categories; and to see, using the "Language" item, the list of articles on the same subject that are in other languages. You can also switch (one-way only) from VisualEditor to the classic wikitext source editor without losing the editing work you've done.

Saving changes[edit | edit source]

When you're done editing, click the blue "Save page" button in the toolbar. If you have made no changes, the button will be disabled (grayed out). To cancel all your editing changes, just close your browser window.
VisualEditor toolbar actions-en.png

Pressing the green "Save page" button opens a dialog. You can then enter a brief summary of your actions, mark your edit as minor, and add the page to your Dhyaan suchi. The box for the summary is the equivalent of the Sanchhipt: field in the wikitext editor.

You can also review your changes using the "Review your changes" button to be sure they will work as intended before saving your changes. This is similar to the "Badlao dekhao" button in the wikitext editor.

The "Cancel" button returns you to the page you were editing. You can save all of your changes later.

VisualEditor save dialog-en.png

Editing links[edit | edit source]

VisualEditor - Toolbar - Linking.png
Links can be added through the "Link" icon (links in a chain) in the toolbar, or by using the shortcut  Ctrl+K (or  Command+K on a Mac).

If you select (highlight) text and then press the "Link" button, that text will be used in creating the link. For a link that involves just one word, you can either select that word or just put the cursor within that word.

VisualEditor-link tool-search results.png
When you use either the button or the shortcut, a dialog will open in which you may type the link.

VisualEditor will try to help with internal links by looking for likely matches.

VisualEditor link tool 2015.png
Once you have entered or selected the link, you complete the linking process by pressing  Enter or by pressing the "Done" button. Your link will immediately appear on the VisualEditor page, but as with other changes to the page, it will not be saved until you save the entire page.

VisualEditor-link tool-external link.png
To link to a web page on another website, the process is the similar: Choose the "External link" tab, and enter a URL in the box.

VisualEditor link tool simple link.png
External links without labels look like this: [1]. You can add these by placing your cursor away from any word (e.g., after a space). Open the link tool by clicking on the button or pressing the shortcut keys. Type the URL in the box, and click the "Done" button to insert the link.

VisualEditor-context menu-link tool.png
To change or remove an existing link, click within the text for that link, then press the "Link" icon that appears near it. The dialog will appear, for editing. (You can also get to the dialog with the  Ctrl+K keyboard shortcut.)

In the link editing dialog, you can then change where the link goes. You can also remove the link altogether by pressing the "Remove" button in the lower left corner of the dialog. You can also open the link's target in another window by clicking on the "MediaWiki:Visualeditor-linkinspector-open/hif" button. (You might want do this to check if an external link is valid.)

Editing references[edit | edit source]

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place[edit | edit source]

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "Cite" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "Cite" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button.png

In the third system, you again start by clicking the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Automatic tab.png

Editing an existing reference[edit | edit source]

To edit an existing reference, click on it where it appears in the text (usually as a bracketed number). You will see either a "Basic" icon (bookmark) or an icon (and name) for the template that was used to create this reference. In either case, clicking on the "Edit" button will open a dialog where you can edit the reference.
VisualEditor - Editing references 1.png

For the "Basic" icon, clicking "Edit" opens the Reference dialog. To start changing the reference information, click on it.

Many wikis use templates to format references. If a template is used in your reference, then when you move your pointer over the reference information, all the information in that field will be highlighted .

If a template was used and you click on the reference information, then the Template icon (puzzle piece) will appear with some information. Click on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6.png

If what appears when you click on a reference is an icon for a standard template for citations (an example is at right), then clicking "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content will show, initially. To add fields, click on "Add more information" at the bottom of the mini-editor.
VisualEditor - Editing references 5.png

Click on "Apply changes" when you're done.
VisualEditor Apply Changes-en.png

Re-using an existing reference[edit | edit source]

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

To re-use an existing reference, place your cursor in the body of the text where you want to add a new reference (number) for that citation. Then click on the "Re-use" item from the "Cite" menu.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Cite" menu.)

VisualEditor Cite menu re-use.png

In the Reference dialog, look at the list for the reference you want to reuse, and select it. If there are many references, you can use the search box (labeled "Search within current citations") to list only those references that include certain text.
VisualEditor - Editing references 18.png

Adding a new reference[edit | edit source]

To add a citation using the "Cite" menu, place your cursor where you want to add it in the text. Then select the appropriate citation type in the menu.
VisualEditor references more.png

Using the "Basic" citation[edit | edit source]

Shown here is what you will see if you select the "Basic" item. In the Reference editor, you can add your citation, including formatting.

You can make the reference belong to a given group, although normally this is left blank. (This option is used to display groups of references with the "References list" tool.)

VisualEditor - Editing references 20.png

In the Reference dialog, if you want to include a citation template, or any other template, in your new reference, click the Template icon (puzzle piece) in the "Insert" toolbar menu within the Reference editor.
VisualEditor Template Insert Menu-en.png

Then, look for the template you want to use, add it and edit it as you would any other template. (See the Editing templates section, below, if you need more information about templates.)

After you're done editing your new template, click on "Apply changes" to return to the Reference editor, and "Apply changes" again to return to the page you're editing.

VisualEditor - Editing references 9.png

If there isn't already a list of references on the page (for example, if you're adding the first reference for the page), you need to specify where the list of references, and their text, will be displayed to the reader.

Place the cursor where you want to display the references list (usually at the bottom of the page), open the "Insert" menu and click the "References list" icon (three books).

VisualEditor References List Insert Menu-en.png

If you are using several groups of references, which is relatively rare, you can specify the group in this dialog. Only the references that belong to that group will be displayed on the page at the location where you are placing the group.

The final step in the References list dialog is to click "Insert".

VisualEditor references list-en.png

Using standard cite templates[edit | edit source]

Your local wiki may have added extra citation templates to the "Cite" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at VisualEditor/Citation tool.)
VisualEditor - Editing References - Cite Pulldown.png

Clicking on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and click on the "Add more information" option.

Click on "Insert" when you're done.

VisualEditor - Editing references - Add parameter.png

Editing images and other media files[edit | edit source]

Editing images[edit | edit source]

To add a new image (or another type of media file) to the page, click the "Media" icon (a picture of mountains) in the "Insert" menu. The image will be added wherever your cursor is.
VisualEditor Media Insert Menu-en.png

Clicking the "Media" icon opens a dialog that automatically searches Wikimedia Commons and your local wiki for media files related to the title of the page you're editing.

You can change the search by changing the text in the dialog's search box.

To choose a file, click on its thumbnail image.

This places the image onto the page you are editing.

VisualEditor - Media editing 2.png

After the image you selected is inserted into the page, another dialog will open. This dialog allows you to add and edit the caption of the image. The caption can contain formatting and links.
VisualEditor - Media editing 6.png

The media dialog also allows you to add alternative text captions, to help users who use screen readers, or who have disabled image display.
Media editing 7.png

You can also set various parameters for the image in the "Advanced settings" window. These include the alignment, the type, and size of the image.
VisualEditor - Media editing 8.png

When you're done, click "Apply changes" to close the dialog and return to editing the page.
VisualEditor Apply Changes-en.png

For an existing image, you can add or edit a caption or other settings by clicking on the image, then clicking on the "Media" icon that appears below the picture.

You can resize an existing image by clicking on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

You can also drag and drop an image to a place higher or lower on the page.

VisualEditor - Media editing 3.png

Editing media galleries[edit | edit source]

To edit an existing gallery in VisualEditor, click that gallery. Then, near the bottom of the gallery, click the gallery icon (a set of photos). This brings up the gallery editor, with the full list of images included in the gallery.
VisualEditor - Gallery2.png
The gallery editor is currently a simple box that allows you to edit existing galleries using wikitext markup. To add a new image to an existing gallery, type the file name, followed by a bar (|) and the caption for that image. You must put each image in the gallery on its own line. You can also edit this list to remove or rearrange images or to change captions.

When you click the "Done" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not save your changes. As with other changes made using VisualEditor, you must save the entire page in order to save your work.

VisualEditor - Gallery3.png

Editing templates[edit | edit source]

Starting[edit | edit source]

To add a new template to a page, place your cursor where you want the template to be inserted, and click on the "Template" icon (puzzle piece) in the "Insert" menu.
VisualEditor Template Insert Menu-en.png

Start typing the name of the template you want to insert. When you see it on the list, click on its name. Then click "Add template".
VisualEditor - Template editing 4.png

You can also edit a template that is already on the page. When you click on the template to select it, it turns blue, and a box appears with an "Template" icon (puzzle piece). Then click on the "Badlo" link.
VisualEditor - Template editing 1.png

Some templates are not visible to someone reading a page. In VisualEditor, such hidden templates are shown as puzzle icons.
VisualEditor template not visible.png

When you select the icon, the context menu is displayed, and you can edit the template.
VisualEditor template not visible context menu.png

Template parameters[edit | edit source]

When you add a new template or open an existing one, VisualEditor opens the "Transclusion" dialog. What you see depends upon whether there is TemplateData for that template.

The template shown here has no TemplateData set up for it. The dialog shows a link to documentation for the template. You can read the documentation to figure out if the template has any parameters (fields), and what goes in each field. Use numbers as the name for each nameless parameter. The first un-named parameter is named 1, the second is named 2, and so forth.
VisualEditor template with no TemplateData.png

If a template has been updated to contain TemplateData information, then the dialog will show a list of individual (named) parameters.
VisualEditor template with TemplateData.png

For an existing template, you can edit the parameters shown in the dialog, and you can add parameters by clicking "Add more information", at the very bottom of the dialog.
VisualEditor - Template editing 3.png

When a template embeds other templates, these sub-templates will appear inside the parameters that display them. They can be edited or removed inside the parameter field.

New sub-templates are added by following the steps for adding a parameter. You may need to check the template documentation to make sure that the sub-template is supported.

VisualEditor - Template editing 5.png

Finishing[edit | edit source]

When you have finished editing a template, click "Apply changes" to close the dialog and return to editing the main page.
VisualEditor Apply Changes-en.png

Substituting templates[edit | edit source]

When a template must be substituted, type subst: (colon included) before the template's name.

Autocompletion doesn't work with subst:. If you want to use autocompletion, first find the template you are looking for, and then add subst: in front of the template name.

Then, click the green "Add template" button.

Add any parameters as usual and click "Insert".

VisualEditor - Template editing 7.png

You will see the template expand on the page after you click "Apply changes".
VisualEditor - Template editing 8.png

Editing lists[edit | edit source]

VisualEditor Toolbar Lists and indentation-en.png
You can use VisualEditor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just click on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then click on one of the menu items.

VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Editing tables[edit | edit source]

VisualEditor insert table.png
You can use VisualEditor to insert and change tables.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.

toolbar>Insert</>" menu, VisualEditor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, click it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double click in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just click elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
You can add or delete a column or a row.

You can merge cells: Select them, then from the Table menu, click on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Editing categories[edit | edit source]

VisualEditor category item-en.png
To edit categories, on the "Page options" menu, click the "Categories" item.

VisualEditor category editing-en.png
Clicking on "Categories" opens a dialog that lists existing categories and allows you to add new ones, and to delete existing categories.

You also have the option of setting or changing the general (default) sorting key, which determines where the page appears when listed with other pages in the same category.

For example, the default sorting key for the article "George Washington" is "Washington, George". In the category "Presidents of the United States", the article is listed under the letter "W", not the letter "G".

VisualEditor - Category editing 3.png
To add a category for a page, type the name of the category into the field "Add a category". As you type, VisualEditor will search for possible matching, existing categories. You can either select an existing category, or you can add a category that doesn't yet have its own category page. (Until that category page is created, your new category will show as a red link after you save all your editing changes.)

VisualEditor - Category editing 2.png
To remove an existing category, click on it and click on the "Remove" icon (trash can) in the dialog that opens.

Clicking on a category also allows you to specify a sorting key for that specific category. Such a sorting key overrides the default sorting key.

VisualEditor Apply Changes-en.png
Click "Apply changes" when you're done editing categories to return to the page editor.

Editing page settings[edit | edit source]

VisualEditor page settings item-en.png
To edit a page's settings, click to open the "Page options" menu, in the toolbar, and select the "Page settings" button.

VisualEditor Page Settings-en.png
The "Page settings" button opens a dialog that shows several options.

VisualEditor Page Settings Redirects-en.png
You can make a page a redirect to another page by checking the "Redirect this page to" checkbox, and then typing the name of the page to which you want to send the reader who tries to go to the page that you're editing.

At the bottom is the option to prevent page renames from updating this redirect. This is very rarely used.

VisualEditor Page Settings TOC-en.png
You can change whether the page shows a Table of Contents by selecting one of these three buttons. The default option is "If needed", which shows a Table of Contents if there are three or more headings.

VisualEditor Page Settings Edit Links-en.png
You can make a page not show edit links next to each section header by checking this checkbox.

VisualEditor Apply Changes-en.png
Click "Apply changes" when you're done editing the Page options to return to the page editor.

Editing mathematical formulae[edit | edit source]

To add a new mathematical formula to the page, place your cursor where you want it to be inserted, and click on the "Formula" icon ("Σ") in the "Insert" menu on the toolbar.
VisualEditor Formula Insert Menu-en.png

A window will open in which you can type the formula, using LaTeX syntax. VisualEditor will update the formula as you type it, so you can see how it will look as you make changes. Once you are happy with the formula, click the "Done" button.
VisualEditor formula-en.png

To edit an existing mathematical formula on the page, click on it and then click on the "Σ" icon that appears. This will open up the formula window, where you make changes.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing poems and other special items[edit | edit source]

Some items, such as association lists, poems, and musical scores, are not yet fully supported by VisualEditor.
VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in VisualEditor.
VisualEditor editing poem 2.png

You can not add an automatic signature or datestamp to a page in VisualEditor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

Keyboard shortcuts[edit | edit source]

Many editors are used to entering wikitext directly, especially bold, italics and wikilinks. Keyboard shortcuts allow to quickly insert similar formatting without having to use toolbar items. Here are the common general shortcuts in VisualEditor:

PC shortcut Action Mac shortcut

 Ctrl+B Bold  Cmd+B

 Ctrl+I Italics  Cmd+I

 Ctrl+K Insert link  Cmd+K

 Ctrl+X Cut  Cmd+X

 Ctrl+C Copy  Cmd+C

 Ctrl+V Paste  Cmd+V

 Ctrl+Z Undo  Cmd+Z