Aiuto:VisualEditor/Guida utente

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 38% complete.
Outdated translations are marked like this.
PD Nota: Quando modifichi questa pagina, acconsenti a pubblicare il tuo contributo con licenza CC0. Vedi le pagine di aiuto sul dominio pubblico per maggiori informazioni.
PD


Aprire VisualEditor

Per modificare una pagina usando VisualEditor, clicca sulla linguetta "Modifica" in alto nella pagina.

L'apertura della pagina per effettuare modifiche può richiedere alcuni secondi, o anche di più se la pagina è molto lunga.

Cliccando sulla linguetta "Modifica sorgente" comparirà l'editor normale di wikitesto.

VisualEditor edit tab-it.png

Si può anche aprire VisualEditor cliccando sul link "modifica" in ogni sezione.
VisualEditor - Section edit links-en.png

Introduzione: la barra degli strumenti di VisualEditor

La barra degli strumenti di VisualEditor
La barra degli strumenti di VisualEditor appare nella parte superiore dello schermo quando inizi a effettuare modifiche con VisualEditor. Include delle icone comuni:

VisualEditor - Toolbar - Undo-redo.png
Annulla e Ripeti le modifiche effettuate.

VisualEditor Toolbar Headings-it.png
Menù a tendina dei titoli di sezione: permette di cambiare la formattazione del paragrafo. Per cambiare lo stile di un paragrafo, poni il cursore nel paragrafo e seleziona un elemento dal menù (non è necessario evidenziare alcun testo). I titoli di sezione sono formattati "Intestazione" e le sottosezioni sono "Sottotitolo 1", "Sottotitolo 2", ecc. Il formato normale per il testo è "Paragrafo".

VisualEditor Toolbar Formatting-it.png

Formattazione: Cliccando sulla "A" si apre un menù.

  • "Grassetto" (G) formatta il testo selezionato in grassetto.
  • "Corsivo" (C) formatta il testo selezionato in corsivo.
  • "Apice" (x2) formatta il testo selezionato più piccolo e leggermente spostato in alto.
  • "Pedice" (x2) formatta il testo selezionato più piccolo e leggermente spostato in basso.
  • "Barrato" (S) formatta il testo selezionato con una linea sul testo.
  • L'elemento "Codice di computer" (una coppia di parentesi graffe {}) cambia il font del testo selezionato, cambiandolo in un font monospazio, che lo distingue dal testo circostante.
  • L'elemento "Sottolineato" (U) aggiunge una sottolineatura al testo selezionato.
  • L'elemento "Lingua" (文A) permette di indicare la lingua (per esempio, Giapponese) e la direzione di lettura/scrittura (ad esempio, da destra a sinistra) del testo selezionato.
  • L'elemento (VisualEditor MediaWiki theme clear icon bitmap.png), chiamato "Rimuovi" rimuove tutta la formattazione del testo selezionato, inclusi i link.

If you have not selected any text, then when you press the "A" to open the menu, and then select an item, that formatting will apply to the text that you start typing, from wherever your cursor is located.


VisualEditor - Toolbar - Linking.png
Linking tool: The chain icon is the linking tool. Pressing on it (usually after selecting some text) opens the link dialog.

VisualEditor - Cite Pulldown.png
Cita: il menù serve a inserire una citazione nel punto indicato (chiamate anche note a pié pagina o note di testo). Tutti i progetti hanno accesso alla formattazione "base" delle note e all'abilità di "riusare" le note, utilizzando questo menù. Questo menù, inoltre, da la possibilità di accedere ai Template:Cita (Cita Web, Cita Libro, Cita News, ecc.), se sono attivi sulla tua wiki.

(Le istruzioni per aggiungere il menù Cita a una specifica wiki sono disponibili alla pagina VisualEditor/Strumenti citazioni .)


VisualEditor citoid Cite button-it.png
pulsante Cita: Se il servizio Citoid è abilitato sulla tua wiki, vedrai il pulsante Cita al posto del menù Cita.

Il servizio Citoid tenta di compilare un template di citazione automaticamente.


VisualEditor Toolbar Lists and indentation-it.png
Elenchi e capoversi: le prime due icone permettono di formattare il testo sia come "Elenco puntato" che come "Elenco numerato". Le ultime due icone permettono di incrementare o diminuire il livello di indentazione degli elementi della lista.

VisualEditor Insert Menu-it.png
Inserisci: il menù "Inserisci" potrebbe essere differente in alcuni progetti. Qui sotto è presente una lista di tutte le opzioni che possono essere mostrate.
  • L'icona "Immagini e file multimediali" (un'immagine di montagne) apre la finestra di dialogo dei media.
  • L'icona "Template" (la tessera di un puzzle) permette di modificare i template.
  • The "Table" item allows you to insert a table.
  • L'icona "Commento" (un fumetto) permette di inserire commenti che non sono visibili ai lettori; questi commenti sono visibili sono durante la modifica della pagina e dove sono segnalati da un'icona con un punto esclamativo. In modalità di modifica, cliccando sull'icona con il punto esclamativo è possibile modificare o cancellare il commento.
  • L'icona "Geroglifici" (il simbolo ankh ☥) permette di inserire geroglifici (vedi sotto).
  • The "Code block" item allows you to insert code.
  • The "Musical notation" item allows you to insert a musical notation.
  • L'icona "Galleria" (un set di foto) permette di inserire una galleria alla pagina.
  • L'icona "Formula" (Σ) apre l'editor per le formule matematiche.
  • The "Graph" item allows you to insert a graph.
  • The "La tua firma" item allows you to insert a signature that you use on the project. It will be greyed out (not selectable) when you are editing a type of page (a "namespace"), such as an article, where signatures should not be inserted.
  • L' icona "Elenco note" (tre libri) apre una finestra di dialogo in cui si può specificare dove verranno mostrate le note al lettore. Normalmente, la lista dei riferimenti va inserita solo una volta in una pagina.

Inserimento dei caratteri speciali: L'icona "Carattere speciale" (Ω) è a fianco del menù "Inserisci". Quando cliccato, mostra una finestra di dialogo che mostra alcuni caratteri speciali. Cliccando su uno specifico carattere, questo viene inserito nel testo. I caratteri speciali includono simboli standard, accenti e simboli matematici. (Questa lista può essere modificata localmente. Vedi VisualEditor/Caratteri speciali per le istruzioni.)
VisualEditor Toolbar SpecialCharacters-it.png

VisualEditor toolbar edit notices icon.png
The Edit notices button displays any notices for the page.

VisualEditor More Settings-it.png
The Opzioni pagina menu is to the left of the Pubblica le modifiche button and the Switch editor menu. On this menu there is a button to open an Options dialog with the following (left side) tabs:
  • Categorie allows you to add categories to this page and to adjust how the page is sorted, when displayed within a category by setting a different index to sort with.
  • Impostazioni pagina allows you to make the page a redirect and adjust options of this redirect, to adjust settings regarding the displaying of the Table of Contents, to disable the edit links next to each heading, and to define the page as a disambiguation page.
  • Advanced settings allows you to adjust the settings regarding indexation of the page by search engines, showing a tab to add a new section, and the displayed title.
  • Lingue which shows a list of pages in other languages that are linked to that page.
  • Templates used shows a list of links to each template used on this page.

The tabs of the Options dialog are also displayed in the Opzioni pagina menu and can be opened by clicking on it.

Furthermore the Opzioni pagina menu contains the button View as right-to-left and the button Find and replace which opens a dialog where you can insert characters, terms or Regular expressions you are searching for and those to replace them with, together with several buttons for options.

VisualEditor bi-directional switching square brackets icon.png
The switch to source editing button is next to the Pubblica le modifiche button. It allows you to switch to the wikitext editor.

Salvare le modifiche

Quando la modifica è stata effettuata, cliccare il pulsante verde "Pubblica le modifiche" nella barra degli strumenti. Se non hai effettuato modifiche, il pulsante è disabilitato (mostrato in grigio). To cancel all your editing changes, close your browser window, or press the "Leggi" tab above the edit toolbar.
VisualEditor toolbar actions-it.png

Premendo il pulsante verde "Salva" si apre una finestra di dialogo. Puoi inserire un breve sunto delle tue modifiche, indicare la tua modifica come minore e aggiungere la pagina nei tuoi Osservati speciali. Il box per il sommario delle modifiche è equivalente al campo Oggetto: nella modifica sorgente.

Puoi anche rivedere le tue modifiche premendo il pulsante "Rivedi le modifiche" per essere sicuro che siano corrette prima di salvare la pagina. È simile al pulsante "Mostra modifiche" della modifica sorgente.

Il pulsante "Riprendi a modificare" ti riporta alla pagina che stavi modificando. Puoi salvare tutte le modifiche in seguito.

VisualEditor save dialog-it.png

Modificare i collegamenti

VisualEditor - Toolbar - Linking.png
Si possono aggiungere i collegamenti attraverso l'icona "Collegamento" (che raffigura una catena) nella barra degli strumenti, oppure usando i tasti rapidi Ctrl+K (o ⌘ Command+K su un Mac).

If you select (highlight) text and then press the "Collegamento" button, that text will be used in creating the link. For a link that involves only one word, you can either select that word or just put the cursor within that word.


VisualEditor-link tool-search results-it.png
Sia che si usi il pulsante o i tasti rapidi, si aprirà una finestra di dialogo dove poter digitare il collegamento (interno o esterno a Wikipedia). Iniziando a digitare, VisualEditor proporrà dei collegamenti interni cercando tra le occorrenze più frequenti.

VisualEditor ti aiuterà con i link interni cercando risultati che corrispondano a quanto stai scrivendo nel box. Una volta inserito o selezionato il link, puoi completare il processo di collegamento premendo ↵ Enter, premendo il pulsante "Fatto" o cliccando all'esterno del box. Il link verrà mostrato immediatamente, ma non sarà salvato finché non salvi l'intera pagina.


VisualEditor-link tool-external link.png
Per creare un collegamento a una pagina web su un altro sito web, il processo è simile: scegli la scheda "Sito esterno" e inserisci un URL nella casella.

VisualEditor link tool simple link.png
Link esterni senza etichetta vengono mostrati così: [1]. Puoi aggiungerli ponendo il cursore lontano da ogni parola (per esempio dopo uno spazio). Apri lo strumento link cliccando sul pulsante o utilizzando la scorciatoia da tastiera. Scrivi l'URL nel box e clicca il pulsante "Fatto" per inserire il link.

VisualEditor-context menu-link tool.png
Per cambiare o rimuovere un collegamento esistente, cliccare sopra il collegamento nel testo, quindi premere l'icona "Collegamento" che appare. Si aprirà una finestra di dialogo che consente la modifica. (Puoi anche far apparire la finestra di dialogo utilizzando la scorciatoia da tastiera Ctrl+K) When a link is selected, it appears as blue framed.

Nella finestra di dialogo, puoi cambiare la destinazione del collegamento. Puoi anche rimuovere l'intero link premendo il pulsante "Elimina" nell'angolo in basso a sinistra della finestra. You can also open the link's target in another window by pressing on the copy of the link in the dialog box. (You might want do this to check if an external link is valid.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, press within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may press within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.
  • You can also link to categories, files and more.

Modificare le note

For further information, see Help using citation templates or Help using citoid's Cite button

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "Cita" menu does not include any citation templates. If your wiki uses this system, then everything you need to know about footnotes is on this page.
VisualEditor cite menu default.png

The second system has the same type of "Cita" menu, but with several popular citation templates set up for quick access. If your wiki uses this system, then you will find more details at Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more.png

VisualEditor citoid Cite button-it.png
In the third system, you again start by pressing the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-it.png

Modificare una nota esistente

To edit an existing reference, press on it where it appears in the text (usually as a bracketed number). You will see either a "Riferimento" icon (bookmark) or an icon (and name) for the template that was used to create this reference. In either case, pressing on the "Edit" button will open a dialog where you can edit the reference.
VisualEditor - Editing references 1.png

For the "Riferimento" icon, pressing "Edit" opens the Reference dialog. To start changing the reference information, press on it.

Molte wiki usano template per formattare le note. Se nella nota viene utilizzato un template, tutto il testo presente nel template verrà evidenziato quando premi sulla nota.

Se viene utilizzato un template e clicchi sulle informazioni di quel template, apparirà l'icona Template (pezzo di puzzle). Clicca sull'icona per modificare il contenuto del template nella finestra di dialogo.

VisualEditor - Editing references 6.png

If what appears when you press on a reference is an icon for a standard template for citations (an example is at right), then pressing "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Nel mini-editor per template, puoi aggiungere o rimuovere informazioni o cambiare il contenuto attuale. Solo i campi (parametri del template) che hanno un contenuto dovrebbero essere visibili all'inizio. Per aggiungere nuovi campi, clicca sul pulsante "Aggiungi ulteriori informazioni" in basso alla finestra.
VisualEditor - Editing references 5.png

Premi su "Applica modifiche" quando hai finito.
VisualEditor Apply Changes-it.png

Riutilizzare una nota esistente

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

Per riutilizzare una nota esistente, posizionare il cursore nel punto in cui si vuole aggiungerla nel testo, e cliccare sull'icona "⧼visualeditor-dialogbutton-reference-tooltip⧽" (segnalibro) dal menu "Insert".

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Cita" menu.)

VisualEditor Cite menu re-use.png

Nella finestra di dialogo $reference-title, cerca nella lista la nota che vuoi utilizzare. Se ci sono molte note, puoi utilizzare il box di ricerca (indicato con "$input") per vedere le note che includono un determinato testo.
VisualEditor - Editing references 18.png

Aggiungere una nuova nota

Per aggiungere una nota utilizzando il menù "$cite", poni il cursore dove vuoi aggiungerla nel testo. Quindi, seleziona il tipo appropriato di citazione nel menù.
VisualEditor references more.png

Utilizzare la citazione "base"

Shown here is what you will see if you select the basic references item. Nell'editor di note è possibile aggiungere, modificare e formattare le note.

Puoi far si che la nota faccia parte di un determinato gruppo, altrimenti di norma questo campo viene lasciato bianco (questa opzione è utilizzata per mostrare gruppi di note con lo strumento "Elenco note").

VisualEditor - Editing references 20.png

Se si sta aggiungendo una nuova nota e si desidera includervi un template, cliccare l'icona Template (tessera di puzzle) nella barra degli strumenti "Insert" dell'editor di note.
VisualEditor Template Insert Menu-it.png

Quindi, cerca il template che vuoi utilizzare, aggiungilo e modificalo come ogni altro template (vedi la sezione Modificare i template più sotto se ti servono più informazioni sui template).

Dopo aver aggiunto un nuovo template, clicca su "Applica modifiche" per ritornare all'editor Note e nuovamente su "Applica modifiche" per tornare alla modifica della voce.

VisualEditor - Editing references 9.png

Se nella pagina non è ancora presente un elenco di note (per esempio quando si sta aggiungendo la prima nota della pagina), è necessario aggiungerlo affinché il testo della nota venga visualizzato.

Posiziona il cursore nel punto in cui si vuole che siano visualizzate le note (di norma a piè di pagina) e clicca il menù "Inserisci" e clicca sull'icona "Elenco note" (tre libri).

VisualEditor References List Insert Menu-it.png

Se sono stati utilizzati più di un gruppo di note, cosa rara, puoi specificare il gruppo in questa finestra di dialogo. Verranno mostrate solo le note che appartengono al gruppo indicato.

Il passaggio finale nella finestra della lista note è cliccare "Inserisci".

VisualEditor references list-it.png

Usare il menù Cita

La tua wiki potrebbe avere più template per le citazioni. Questo ti offre un accesso veloce ai template di citazione più utilizzati. (Istruzioni per aggiungere il menù cita a una specifica wiki sono disponibili in VisualEditor/Strumenti citazioni .)
VisualEditor - Editing References - Cite Pulldown.png

Selezionando l'icona template ti porterà nel mini-editor template scelto. I parametri fortemente raccomandati saranno indicati con un asterisco. Mentre i più comuni parametri saranno mostrati, non sono tutti richiesti. Parametri non usati non dovrebbero apparire.
VisualEditor - Editing references - Cite book required fields.png

Per aggiungere ulteriori parametri, scorri il mini-editor template fino alla fine e clicca sull'opzione "Aggiungi ulteriori informazioni".

Clicca "Inserisci" quando hai finito.

VisualEditor - Editing references - Add parameter.png

Modificare le immagini e altri file multimediali

Modificare le immagini

Per aggiungere una nuova immagine (o un altro tipo di file multimediale) alla pagina, cliccare l'icona "Immagini e file multimediali" (un'immagine di montagne) nel menu "Inserisci". L'immagine verrà aggiunta nel punto in cui si trova il cursore.
VisualEditor Media Insert Menu-it.png

Cliccare l'icona "Immagini e file multimediali" apre una finestra di dialogo che scansiona Wikimedia Commons e la wiki per file multimediali collegati al titolo della pagina che stai modificando.

È possibile cercare altri file multimediali cambiando il testo nella casella di ricerca della finestra di dialogo.

Cliccare su una miniatura per scegliere un file.

Questo posiziona l'immagine nella pagina che stai modificando.

VisualEditor - Media editing 2.png

Dopo che l'immagine che hai selezionato è stata inserita in una pagina, si aprirà un'altra finestra di dialogo. Questa finestra permette di aggiungere e modificare la didascalia dell'immagine. La didascalia può contenere formattazione e collegamenti.
VisualEditor - Media editing 6.png

La finestra permette anche di aggiungere didascalie alternative, che aiutano utenti con screen reader o con immagini disabilitate.
VisualEditor - Media editing 7.png

Puoi impostare molti parametri per l'immagine nella finestra "Impostazioni avanzate". Questi includono allineamento, tipo e dimensione dell'immagine.
VisualEditor - Media editing 8.png

Una volta effettuate le modifiche, cliccare "Applica modifiche" per chiudere la finestra di dialogo e tornare alla pagina di modifica.
VisualEditor Apply Changes-it.png

Per un'immagine esistente, puoi aggiungere o modificare la didascalia cliccando sull'immagine, quindi cliccando sull'icona "Immagini e file multimediali" che appare sotto l'immagine.

Puoi ridimensionare un'immagine esistente cliccando su essa e muovere l'icona "ridimensiona" (la doppia freccia negli angoli).

Puoi anche trascinare un immagine per porla in un punto differente della pagina.

VisualEditor - Media editing 3.png

Uploading images

You can upload images from a tab in the media dialog, or by dragging and dropping a file into the editor, or by pasting an image from your clipboard.
VisualEditor - Media upload 1.png

Press the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.
VisualEditor - Media upload 1.5.png

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.png

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Modificare le gallerie

Per aggiungere una nuova galleria, clicca l'icona "Galleria" (un set di foto).
VisualEditor - Gallery1.png

Per modificare una galleria con VisualEditor, clicca sulla galleria. Poi, vicino al bordo inferiore della galleria, clicca l'icona galleria (una serie di immagini). Questo apre l'editor delle gallerie, con una lista completa di immagini incluse nella galleria.
VisualEditor - Gallery2.png
L'editor galleria è, al momento, un semplice box che permette di modificare le gallerie utilizzando il wikitesto. Per aggiungere una nuova immagine a una galleria esistente, scrivi il nome del file, seguito da una barra (|) e la didascalia per l'immagine. È necessario porre una sola immagine per ogni linea di testo. Puoi anche modificare questa lista per rimuovere o riposizionare le immagini o per cambiare le didascalie.

Quando clicci il pulsante "$dialogdone", uscirai dall'editor galleria. Dovresti vedere le tue modifiche, con la galleria come apparirebbe ai lettori.

Ricorda che uscire dall'editor galleria non salva i tuoi cambiamenti. Come nelle altre modalità di modifica di VisualEditor, devi salvare l'intera pagina per salvare il tuo lavoro.

VisualEditor - Gallery3.png

Editing templates

The powerful MediaWiki template system lets you insert dynamic content, text from other pages, and much more. For a detailed explanation and examples, see the Templates help page.

In the VisualEditor you can search for a relevant template, add an invocation or transclusion on the page you’re editing and, if needed, add custom content using parameters.

Insert new template

Per aggiungere un nuovo template in una pagina, poni il cursore dove vuoi inserire il template e clicca l'icona "$template" (pezzo di puzzle) nel menù "$insert". Then open the Inserisci menu and select "OOjs UI icon puzzle-ltr.svg Template". Alternatively, type two curly brackets {{ to open the same dialog.
VisualEditor Template Insert Menu-it.png
Find the template you want to insert by typing either its name or a relevant keyword. Results containing the search term in either the name or description will display in a dropdown. This should help you find a relevant template, even if you don’t know its exact name.

If you’re having trouble finding the kind of template you want by using keywords, you can look on other wiki pages with similar content and view or edit the page source to see which templates are in use. When you find the desired template’s name, you can type it into this field to insert it here.

Screenshot of the template search field in the Visual Editor

You can also edit a template that’s already on a page. When you select the template you want to edit, it turns blue, and a box appears displaying "OOjs UI icon puzzle-ltr.svg Template". Then select the "Modifica" link or double click on the template itself to open the template.
Screenshot of the VisualEditor interface with a template selected

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are still shown so that you can click and edit or delete them. The name of the template will be shown next to the puzzle icon and both will be grayed out.
Screenshot of hidden templates in the Visual Editor interface

Template parameters

You’ll see this dialog box when you’re adding a new template or editing one already in place. What you see in the box depends on whether the template in question contains TemplateData , helpful metadata added by other editors to make it easier to edit templates in the Visual Editor.

When a template contains TemplateData, the VisualEditor can use it to present annotated fields for you to fill in.


For templates that have some community-provided TemplateData, the VisualEditor displays a list of the named parameters and, often, descriptions and instructions explaining the meaning and required format for each parameter’s values.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

You can disable any optional parameter (which have blue checkboxes on the left side). If a parameter’s checkbox is grayed out and not clickable, the template requires that parameter, so it can’t be disabled.

When you insert a new template, you may find that some optional parameters are pre-selected. That means the author(s) of the template recommends the use of those parameters. It’s best to review all parameters that will be used in a template to ensure you understand their use.

Clicking an unchecked parameter adds it to the template. Clicking a parameter that’s already been added takes you to the parameter’s input field.

Some template parameters will show as “deprecated”. Don’t use deprecated parameters when inserting a template; they’re only visible to you because those parameters are in use on older pages where this template was included.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Adding undocumented parameters

If you’re inserting or editing a template whose author hasn’t laid out its parameters in TemplateData, it has what we call “undocumented” or “unnamed parameters”. In these cases, you should consult the page for the template itself. There you can learn how to correctly employ and work with all of the template’s parameters. This includes learning the exact names of the parameters as written by the template author.

If you find in the documentation that the template expects parameters without have names, fill in numbers as placeholders for the parameter names using the undocumented parameter input, then add next to the values you want to provide as you normally would.

Example:

  • first unnamed parameter: “1”
  • first unnamed parameter’s value: “en_US”
  • second unnamed parameter: “2”
  • second unnamed parameter’s value: “yes”

If you accidentally include nonexistent, misspelled or erroneous parameters, the values you enter for those parameters won’t show up on the page you’re editing.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerated parameters

In this example, the template in question lacks TemplateData but it was possible to autogenerate the parameters. This means that the undocumented parameters have already been added for you, but the names may not be easily understandable and the dialog cannot display any directions or descriptions. As a result the dialog box provides a link to the template’s documentation, which should help you deduce and fill in the template’s various parameters.
Autogenerated parameters in the VisualEditor.png

Editing multi-part template content

During editing, you may open template content consisting of multiple templates or a single template linked to some wikitext. This differs from the nested templates described below. In this case, the templates are better visualized as being stacked or connected.

This content often contains “unbalanced templates,” templates which are incomplete on their own and need to be paired with some wikitext or another template in order to function.

These related pieces of template content must be created in wikitext, but can be edited in the VisualEditor. In these cases you will see a notice at the top of the dialog to signal the situation and a specialized toolbar will be visible at the bottom of the sidebar. There you can use the icon buttons to add additional templates, additional wikitext, delete elements or change their order.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Nested templates

Templates can include other templates as the value for parameters. You’ll recognize it when you see a parameter whose value contains the double curly braces ( {{ }} ) denoting a template.

The VisualEditor can’t present this template within a template (a nested template) using the editor’s easy-to-use interface, so if you want to nest a template yourself, you’ll need to understand how to add the template by hand in wikitext into the appropriate parameter field.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Completing your edit

When you have finished editing a template, you can click "Applica modifiche". Then you can preview your edit and make sure it looks the way you want and expect.

You may also see an error message, which (like the other TemplateData mentioned above) is community-provided content and may vary in usefulness. You may need to consult the template’s own documentation to get to the bottom of some errors. If you’re still having trouble, consider posting about your problem on the template’s talk page.

VisualEditor Apply Changes-it.png

Removing a template

To remove a template in the VisualEditor, click the template box. Press the "Delete" or "Backspace" key on your keyboard. The template will disappear from the page.
Screenshot of the button to remove a template
Removing a template in the VisualEditor

Editing on mobile

When editing a template on a page using the VisualEditor on a mobile device, you’ll see that the sidebar starts out hidden. You can make it visible by pressing the “Show/hide options” button.
Screenshot of editing a template on a mobile device
Editing a template on mobile in the VisualEditor

Sostituire i template

When you insert a template in a wiki page, its content and appearance are reevaluated every time the page loads, based on the template code and the values of its parameters. This means if someone updates the code of a template, then every page which uses that template will also get updated when they publish.

There’s another, much less common way to use templates, though, and that’s to substitute a template. Doing this permanently includes the template content just as it appears at the moment you insert it. It will not update if the template code is later changed.

Most users won’t ever need to resort to substitution. Substitution is typically only useful when you need to capture the exact appearance of one version of a template, such as when content is under development and needs evaluation.

To substitute a template in the VisualEditor, insert a template using the name syntax subst:<template name>. (Autocomplete doesn’t work in this case.) Then press the blue “Add template” button.

When you’re finished, press “Insert”, which will insert the template content as you see it.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Editing lists

VisualEditor Toolbar Lists and indentation-it.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just press on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then press on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Modificare le tabelle

VisualEditor insert table-it.png
Puoi utilizzare VisualEditor per inserire e cambiare le tabelle.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you press on "Table", in the "Inserisci" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, press it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double press in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just press elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Puoi aggiungere o rimuovere colonne e righe.

You can merge cells: Select them, then from the Table menu, press on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Modificare le categorie

VisualEditor category item-it.png
Per modificare le categorie, dal menu "Opzioni pagina" fare clic sul pulsante "Categorie".

VisualEditor category editing-it.png
Il pulsante "Categorie" apre una finestra di dialogo che elenca le categorie esistenti e permette di aggiungerne una.

Hai l'opzione di indicare o cambiare la chiave di ordinamento generale (di default), che viene utilizzata per determinare in quale punto apparirà la pagina quando verrà inserita in una lista con altre pagine della stessa categoria.

Per esempio, la chiave di ordinamento di base dell'articolo "George Washington" è "Washington, George" e, quindi, nella categoria "Presidenti degli Stati Uniti d'America", l'articolo è inserito sotto la lettera "W" e non sotto la lettera "G".


VisualEditor - Category editing 3.png
Per aggiungere una categoria ad una pagina, inserisci il nome della categoria nel campo "Aggiungi una categoria". Mentre scrivi, VisualEditor cercherà possibili risultati tra le categorie esistenti. Puoi selezionare una categoria esistente o puoi aggiungere una categoria non esistente (fino alla creazione della categoria, questa verrà mostrata come link rosso dopo il salvataggio).

VisualEditor - Category editing 2.png
Per rimuovere una categoria esistente, clicca su di essa e clicca l'icona "Rimuovi" (cestino) nella finestra di dialogo che si apre.

Cliccando una categoria permette anche di specificare una chiave di ordinamento specifica per quella categoria. Questa chiave prevale sulla chiave di ordinamento standard.


VisualEditor Apply Changes-it.png
Cliccare "Applica modifiche" dopo avere modificato le categorie per tornare alla pagina di modifica.

Cambiare le impostazioni di una pagina

VisualEditor page settings item-it.png
Per modificare le impostazioni di una pagina, clicca sul menù "Opzioni pagina" nella barra strumenti e seleziona il pulsante "Impostazioni pagina".

VisualEditor Page Settings-it.png
Il pulsante "Impostazioni pagina" apre una finestra di dialogo che mostra diverse opzioni.

VisualEditor Page Settings Redirects-it.png
Puoi fare in modo che una pagina reindirizzi a un'altra pagina attivando il checkbox "Reindirizza questa pagina verso" e, quindi, inserendo il nome della pagina di destinazione.

Alla fine della finestra, è presente l'opzione per impedire che si rinomini la pagina aggiornando il redirect. Questa opzione viene utilizzata molto raramente.


VisualEditor Page Settings TOC-it.png
Puoi cambiare se la pagina mostra un Indice cliccando uno di questi tre bottoni. Di default le pagine mostreranno l'Indice se ci sono tre o più sezioni, che è ciò che "Se necessario" fa.

VisualEditor Page Settings Edit Links-it.png
Puoi nascondere i link di modifica di ogni sezione spuntando questa casella.

VisualEditor Apply Changes-it.png
Clicca "Applica modifiche" quando hai finito di modificare le Opzioni pagina per tornare alla pagina di modifica.

Editing maps

Visual editor showing editing an existing map.jpg
You can add and change maps. See Help:VisualEditor/Maps .

Modificare le formule matematiche

Per aggiungere una nuova formula alla pagina, posiziona il cursore dove vuoi che venga inserita, e clicca "Formula" ("Σ") nel menù "Inserisci" della barra degli strumenti.
VisualEditor Formula Insert Menu-it.png

Si aprirà una finestra in cui puoi inserire la formula matematica, utilizzando la sintassi LaTeX. VisualEditor aggiorna la formula mentre scrivi, così puoi vedere come verrà visualizzata mentre la modifichi. Quando sei soddisfatto della formula, clicca il pulsante "Inserisci".
VisualEditor formula-it.png

Puoi modificare una formula esistente cliccandoci sopra e cliccare l'icona "Σ" che appare. Questo aprirà la finestra di modifica dove puoi fare le modifiche.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, press the "Musical notation" option.

To edit an existing musical notation on the page, double press on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, press the "Done" button to close the dialog and publish your changes.
Musical.png

Modificare poesie e altri elementi speciali

Alcuni elementi, come poesie e partiture musicali, non sono ancora supportati da VisualEditor. Finché non lo saranno, per utilizzarli è necessario modificare direttamente il wikicodice se vuoi aggiungerli o modificarli.
VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, press the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

You'll see a diff. (If you pressed on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, press the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

Scorciatoie da tastiera

Molti utenti sono abituati a inserire il wikitesto direttamente, specialmente grassetto, corsivo e wikilink. Le scorciatoie da tastiera permettono di inserire la formattazione senza utilizzare gli elementi della barra strumenti. Ecco le scorciatoie presenti in VIsualEditor:

Tasti rapidi per PC Azione Tasti rapidi per Mac

Ctrl+B Grassetto ⌘ Cmd+B

Ctrl+I Corsivo ⌘ Cmd+I

Ctrl+K Inserire wikilink ⌘ Cmd+K

Ctrl+X Taglia ⌘ Cmd+X

Ctrl+C Copia ⌘ Cmd+C

Ctrl+V Incolla ⌘ Cmd+V

Ctrl+Z Annulla ⌘ Cmd+Z