Axuda:Editor visual/Guía de usuario

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 57% complete.
Outdated translations are marked like this.
PD Nota: Ao editar esta páxina, acepta liberar a súa contribución baixo a licenza CC0. Consulte as páxinas de axuda sobre o dominio público para obter máis información.
PD


Abrir o editor visual

Para editar unha páxina mediante o editor visual, prema na lapela "Editar" que hai na parte superior da páxina.

Abrir a páxina no modo de edición pode levar uns segundos; tardará máis tempo se a páxina é moi longa.

Se preme na lapela "Editar a fonte", abrirá o editor de texto wiki fonte clásico.


Tamén pode abrir o editor visual premendo na ligazón "editar" que hai en cada sección.

Primeiros pasos: a barra de ferramentas do editor visual

Imaxe da barra de ferramentas do editor visual.
A barra de ferramentas do editor visual aparece no canto superior da pantalla ao facer uso do editor visual. Inclúe algunhas iconas familiares:

Desfacer e Refacer as modificacións que teña feitas.

Menú despregable de cabeceiras: permite cambiar o formato do parágrafo. Para cambiar o estilo dun parágrafo, poña o cursor no parágrafo e seleccione un obxecto neste menú (non ten que seleccionar ningún texto). Aos títulos de sección dáselles formato con "Cabeceira", e ás subseccións con "Subcabeceira 1", "Subcabeceira 2" e así sucesivamente. O formato normal para o texto é "Parágrafo".

Formato: Ao premer en "A", ábrese un menú.

  • A icona "Negra" (N) pon en negras o texto seleccionado.
  • A icona "Cursiva" (I) pon en cursivas o texto seleccionado.
  • A icona "Superíndice" (x2) fai que o texto seleccionado apareza máis pequeno que o texto darredor e un pouco máis alto.
  • A icona "Subíndice" (x2) fai que o texto seleccionado apareza máis pequeno que o texto darredor e un pouco máis baixo.
  • A icona "Riscar" (A) engade unha barra sólida riscando o texto seleccionado.
  • A icona "Código máquina" (un par de chaves: {}) cambia a fonte do texto seleccionado a un tipo de letra monoespazada, o que o diferencia do texto darredor (proporcionalmente espazado).
  • A icona "Subliñado" (A) engade unha liña sólida debaixo do texto seleccionado.
  • A icona "Lingua" (文A) permítelle etiquetar o idioma (por exemplo, xaponés) e a dirección de escritura (por exemplo, da dereita á esquerda) do texto seleccionado.
  • A icona final (), chamada "Eliminar", elimina todo o formato dos caracteres do texto seleccionado, incluíndo as ligazóns.

Se non seleccionou ningún texto, ó premer en A para abrir o menú e seleccionar un obxecto, ese formato será aplicado ó texto que está a escribir, a partir de onde estea situado o cursor.


Ferramenta de ligazóns: A icona da cadea é a ferramenta de ligazóns. Premendo nela (normalmente despois de seleccionar algo de texto) ábrese a caixa de diálogo de ligazóns.

Menú de citas: O menú "Citar" úsase para engadir citas en liña (tamén chamadas "referencias" ou "notas"). Todos os proxectos teñen acceso ao formato de referencias básico e a capacidade de reusar as citas usando este menú. Este menú tamén dá acceso rápido ós modelos de cita locais, se estes están activados na súa wiki.

Botón Citar: Se o servizo citoid está activado na súa wiki, verá entón un botón Citar en lugar dun menú Citar.

(As instrucións para engadir modelos de cita locais ao menú Manual nun wiki específico están dispoñibles en VisualEditor/Citation tool .)

Instructions for enabling the Automático tab are available at Enabling Citoid on your wiki

O servizo citoid intenta encher modelos de citas de xeito automático.


Listas e sangría: As primeiras dúas iconas permiten dar formato ao texto a modo de "Lista con asteriscos" ou "Lista numerada". As últimas dúas iconas permiten aumentar ou diminuír o nivel de sangría dos elementos da lista.

Inserir: O menú "Inserir" pode ser diferente nalgúns proxectos. A continuación hai unha lista con todas as opcións que poden aparecer.
  • A icona "Imaxes e ficheiros multimedia" (un debuxo de montañas) abre a caixa de diálogo de multimedia.
  • A icona "Modelo" (unha peza de crebacabezas) permite editar os modelos.
  • O obxecto "Táboa" permite inserir unha táboa.
  • A icona "Comentario" (unha burbulla de diálogo) permite inserir comentarios que non serán visibles para os lectores; estes comentarios só se ven no modo de edición, onde están indicados cunha icona de exclamación. No modo de edición, premendo na icona de exclamación poderá editar ou borrar o comentario.
  • A icona "Xeróglifos" (un símbolo ankh - ☥) permite inserir xeróglifos. (Véxase máis abaixo.)
  • A opción de "Bloque de código" permítelle inserir código.
  • A opción "Notación musical" permítelle inserir as notas musicais.
  • A icona "Galería" (un conxunto de fotografías) permite inserir unha galería de imaxes á páxina.
  • A icona "Fórmula matemática" (Σ) abre a caixa de diálogo de inserción de fórmulas.
  • A opción "Gráfico" permítelle inserir un gráfico.
  • A opción "A súa sinatura" permítelle inserir a súa sinatura de usuario. Estará de cor gris (non seleccionable) cando estea a editar un tipo de páxina (nun "espazo de nomes"), como un artigo, onde as sinaturas non deben inserirse.
  • A icona "Lista de referencias" (tres libros) abre unha caixa de diálogo na que pode especificar onde se mostrarán as referencias ao lector. Normalmente só é necesario facer isto unha única vez nunha páxina.

Inserción de caracteres especiais: A icona "Carácter especial" (Ω) está ó lado do menú "Inserir". Ao premer ela, móstrase unha caixa de diálogo con algúns caracteres especiais. Ao premer sobre un carácter en concreto, insírese no texto. Entre estes caracteres especiais atópanse algúns símbolos estándar, diacríticos e símbolos matemáticos. (Esta lista pode personalizarse localmente. Consulte VisualEditor/Special characters para obter máis instrucións.)

O botón Avisos de edición amosa calquera aviso para a páxina.

The Opcións da páxina menu is to the left of the Publicar os cambios button and the Cambiar de editor menu. On this menu there is a button to open an Opcións dialog with the following (left side) tabs:
  • Categorías allows you to add categories to this page and to adjust how the page is sorted, when displayed within a category by setting a different index to sort with.
  • Configuración da páxina allows you to make the page a redirect and adjust options of this redirect, to adjust settings regarding the displaying of the Table of Contents, to disable the edit links next to each heading, and to define the page as a disambiguation page.
  • Configuración avanzada allows you to adjust the settings regarding indexation of the page by search engines, showing a tab to add a new section, and the displayed title.
  • Linguas shows a list of pages in other languages that are linked to that page.
  • Modelos usados shows a list of links to each template used on this page.

The tabs of the Opcións dialog are also displayed in the Opcións da páxina menu and can be opened by clicking on it. Furthermore the Opcións da páxina menu contains the items Ver de esquerda a dereita or Ver de dereita a esquerda and the item Procurar e substituír, which opens a bar, where you can insert words or regular expressions you are searching for and those to replace them with, together with several buttons for options.


O botón cambiar a edición da fonte está localizado ó lado do botón $save. Permítelle cambiar ó editor de código fonte, o wikitexto.

Gardar os cambios

Cando remate as súas modificacións, prema no botón azul "Publicar os cambios" da barra de ferramentas. Se non fixo cambios, o botón non estará activo (aparecerá cun ton gris). Para cancelar todas as modificacións que realizou, peche a xanela do seu navegador, ou prema na lapela "Ler" que están enriba da barra de ferramentas de edición.

Ao premer no botón azul "Publicar os cambios…" ábrese unha caixa de diálogo. Nesa xanela pode engadir un pequeno resumo das súas modificacións, marcar a edición como pequena e/ou engadir a páxina á súa $watchlist. A caixa para o resumo é equivalente ao campo Resumo: mostrado no editor clásico de texto wiki.

Tamén pode revisar as modificacións que fixo mediante o botón "Revisar os seus cambios", para ter a certeza de que funcionan como desexa antes de gravalas. Esta opción é similar ao botón "Amosar os cambios" do editor clásico de texto wiki.

O botón "Continuar a edición" fai que o editor regrese á páxina que estaba a editar. Pode gravar as súas modificacións máis tarde.

Editar as ligazóns

As ligazóns poden engadirse usando a icona "Ligazón" (os elos dunha cadea) da caixa de ferramentas ou mediante o atallo de teclado Ctrl+K (ou ⌘ Command+K nun Mac).

Se selecciona (resalta) texto e logo preme no botón "Ligazón", ese texto será usado na creación da ligazón. Para unha ligazón que use só unha palabra, pode seleccionar esa palabra ou simplemente poñer o cursor nela.


Tanto empregando o botón coma o atallo ábrese unha caixa de diálogo na que pode inserir a ligazón. O editor visual ha axudar coas ligazóns internas (as ligazóns cara a outras páxinas da Wikipedia) buscando coincidencias mentres escribe.

A ferramenta de ligazón intentará axudar coas ligazóns internas, procurando correspondencias probables. Así que teña tecleada ou seleccionada a ligazón, pode premer ↵ Enter ou premer no botón "Feito" para rematar o proceso. A súa ligazón aparecerá inmediatamente na páxina do editor visual, pero coma nos outros cambios na páxina, non se gardará ata que grave toda a páxina.


Para crear unha ligazón cara a unha páxina web ou a outro sitio web, o proceso é similar: escolla a lapela «Sitio externo» e insera o enderezo URL na caixa.

As ligazóns externas sen etiqueta son así: [1]. Pode engadir unha poñendo o cursor lonxe de calquera palabra (por exemplo, despois dun espazo). Abra a ferramenta de ligazóns premendo no botón ou premendo as teclas do atallo de teclado. Escriba o enderezo URL na caixa e prema no botón "Feito" para inserir a ligazón.

Para cambiar ou eliminar unha ligazón existente, prema dentro do texto desa ligazón e logo na icona "Ligazón" que aparece ao seu carón. Así aparecerá unha caixa de diálogo para editar a ligazón. (Tamén pode abrir ese diálogo co atallo de teclado Ctrl+K.) Cando se selecciona unha ligazón, aparece destacada en azul.

Na caixa de diálogo de edición de ligazóns, pode entón editar o destino da ligazón. Poderá tamén borrala por completo premendo no botón "Eliminar" que hai no recuncho superior dereito da xanela. Pode tamén abrir a páxina de destino da ligazón noutra xanela premendo na copia da ligazón na xanela de diálogo. (Pode querer facer isto para verificar se unha ligazón externa é válida.)

Se desexa sair da etiqueta da ligazón (o texto que se mostra como ligazón) ou continuar escribindo despois da ligazón, pode seleccionar :

  • preméndoo unha vez sae da pantalla de diálogo de edición da ligazón e coloca o seu cursor ó final do elemento ligado (enmarcado en azul, para editar este elemento)
  • preméndoo dúas veces pon o cursor despois do elemento ligado, listo para escribir o resto do seu texto.

Para editar o texto dunha ligazón xa existente, prema no texto da ligazón e escriba un novo. Pero se quere substituír todo o texto, por favor, teña en conta:

  • Se seleccionou (resaltando) todo o texto da ligazón, a ligazón será borrada ó premer calquera tecla.
  • Para manter a ligazón directamente, pode premer dentro da etiqueta da ligazón, usar as teclas de retroceso e suprimir sen presionalo de novo, e unha área azul de ligazón aparecerá alí. Agora pode escribir na nova etiqueta para crear a ligazón.
  • You can also link to categories, files and more.

Editar as referencias

For further information, see Axuda para usar os modelos de cita ou Axuda para usar o botón de citoid's Automático

Determinar que sistema está en vigor

A súa wiki pode usar un dos tres sistema de notas ó pé. A opción mostrada á dereita é o sistema máis simple, onde o menú "Citar" non inclúe ningún modelo de cita. Se a súa wiki usa este sistema, entón todo o que precisa saber sobre as notas está nesta páxina.

In the second system, you again start by pressing the Citar button. Then a dialog box opens, which includes several popular citation templates set up for quick access in the "Manual" tab. Se a súa wiki utiliza este sistema, entón atopará máis detalles en Help:VisualEditor/User guide/Citations-Templates

No terceiro sistema, de novo comeza premendo no botón de Citar. Entón ábrese unha xanela de diálogo, o cal inclúe un proceso automático de citas usando o servizo citoid. Se a súa wiki usa este sistema, atopará máis detalles en Help:VisualEditor/User guide/Citations-Full

Editar unha referencia existente

Para editar unha referencia existente, prema onde aparece no texto (normalmente como un número entre corchetes). Aparecerá unha icona "$ref" (marcapáxinas) ou unha icona (e un nome) para o modelo que se usou para crear esa referencia. En calquera caso, premendo no botón "Editar" abrirá unha xanela de diálogo onde pode editar a referencia.

Para a icona "$ref", premendo en "Editar" abre a xanela de diálogo de Referencias. Para comezar a modificar a información da referencia, prema sobre ela.

Moitos wikis utilizan modelos para formatar referencias. Se na súa referencia está a usarse un modelo, entón cando move o seu punteiro sobre a información da referencia, toda a información dese campo será destacada.

Se se estaba a usar un modelo e vostede preme na información da referencia, entón aparecerá a icona $template (a peza de crebacabezas) con algunha información. Prema no botón "Editar" para editar o contido do modelo na mini-xanela de edición.


Se, ó premer nunha referencia, aparece unha icona dun modelo estándar para citas (móstrase un exemplo á dereita), entón premendo en "Editar" abrirá á mini-xanela de edición do modelo.

Na xanela de edición do modelo, pode engadir ou quitar calquera tipo de información ou cambiar o contido actual. Inicialmente só se mostrarán os campos (parámetros do modelo) que teñan contido. Para engadir campos, prema en "Engadir" na parte inferior da mini-xanela.

Prema en "Aplicar os cambios" cando remate.

Reutilizar unha referencia existente

Se a páxina xa contén unha referencia que se aplica ó texto que quere referenciar, entón pode escoller reutilizar esa cita existente.

Para reutilizar unha referencia existente, poña o seu cursor no corpo do texto no que a quere engadir unha referencia nova (número) para esa cita. Logo prema no elemento "Reutilizar referencia" do menú "$cite".

(Nota: Se a súa wiki posúe o terceiro sistema de notas descrito arriba, verá unha pestana "Reutilizar", nunha caixa de diálogo, no canto dun elemento "Reutilizar" no menú "$cite".)


Na caixa de diálogo $reference-title, busque na lista pola referencia que quere reutilizar e selecciónea. Se hai varias referencias, pode utilizar a caixa de busca (nomeada "$input") para listar só as referencias que inclúan un texto determinado.

Engadir unha nova referencia

Para engadir unha nova referencia usando o menú "$cite", posicione o cursor onde a quere engadir no texto. De seguida, seleccione o tipo apropiado de cita do menú. Then click "Básico".

Usar a cita "Básica"

Amósase aquí o que verá se selecciona o elemento de referencia básica. No editor de Referencias, pode engadir a súa cita, incluíndo o formato.

Pode facer que a súa referencia pertenza a un certo grupo, aínda que normalmente non se especificada ningún. (Esta opción úsase para mostrar grupos de referencias coa ferramenta "Lista de referencias".)


Na caixa de diálogo Referencia, se quere incluír unha predefinição de citação, ou qualquer nova predefinición, na súa nova referencia, prema na icona Modelo (peza de crebacabezas) no menú "Inserir" da barra de ferramentas do editor de referencias.

Despois, busque o modelo que quere usar, inclúao e edíteo como faría con un xa existente. (Vexa a sección Editar modelos abaixo se necesita de máis información.)

Así que remate de editar o se novo modelo, prema en "Aplicar os cambios" para voltar ó editor de Referencia, e prema de novo "Aplicar os cambios" para voltar á páxina que estaba editando.


Se aínda non hai unha lista de referencias na páxina (por exemplo, se está engadindo a primeira referencia á páxina), cómpre engadila para mostrar o texto da referencia no lugar que corresponda.

Coloque o cursor no sitio no que queira que aparezan as referencias (xeralmente ó final da páxina), abra o menú "Inserir", e prema na icona "Lista de referencias" (tres libros) para engadila.


Se creou grupos de referencias, o que normalmente é raro, pode especificalos nesta xanela. Só se mostrarán as referencias que pertencen a ese grupo na páxina no lugar no que está a colocar o grupo.

O último paso é premer "Inserir" na xanela.

Usar os modelos de cita estándar

A súa wiki local pode ter definidos modelos de citas adicionais no menú "Citar". Se é así, vostede terá un acceso rápido ós modelos de cita máis usados na súa wiki. (Instruccións para engadir modelos de cita locais ó menú $cite, nunha wiki específica, poden consultarse na páxina VisualEditor/Citation tool .)

Ó premer na icona dun modelo como "Citar libro", será enviado ó mini-editor dese mesmo modelo. Os campos de información importantes poden marcarse cun asterisco. Aínda que se mostran os campos máis comúns, é posible que non se necesiten todos.

Para engadir máis parámetros, baixe na xanela do modelo e prema na opción de "Engadir".

Prema en "Inserir" cando remate.

Editar as imaxes e outros ficheiros multimedia

Editar as imaxes

Para engadir unha nova imaxe (ou outro ficheiro multimedia) á páxina, prema na icona "Ficheiros multimedia" da barra de ferramentas (un debuxo de montañas).

Ó premer na icona "Imaxes e ficheiros multimedia" ábrese unha xanela que busca automaticamente ficheiros multimedia na Wikimedia Commons relacionados co título da páxina que está a editar.

Pode buscar outros ficheiros multimedia cambiando o texto na caixa de procuras do diálogo.

Prema nunha miniatura para elixir ese ficheiro.

Desta forma, colocará a imaxe na páxina que está a editar.


Despois de que se insira na páxina a imaxe que seleccionou, abrirase outra caixa de diálogo. A xanela permítelle que insira e edite unha lenda, que pode conter formato e ligazóns.

A xanela de ficheiros tamén permite a inserción de lendas e/ou textos alternativos, para axudar ós usuarios con lectores de pantalla, ou ós que teñen deshabilitada a visualización de imaxes nos seus navegadores.

Tamén pode definir varios parámetros da imaxe na xanela "Configuración avanzada". Estes inclúen o aliñamento, tipo e tamaño da imaxe.

Cando remate, prema en "Aplicar os cambios" para pechar a caixa de diálogo e volver ao editor da páxina.

Ó premer nunha imaxe existente, pode engadir ou editar a súa lenda ó premer na icona "Imaxes e ficheiros multimedia" que aparece debaixo da imaxe.

Pode redimensionar unha imaxe existente, premendo sobre ela, e en seguida, movendo a icona de redimensionamento (a frecha de dúas puntas nun ou nos dous cantos inferiores).

Tamén pode arrastrar e soltar unha imaxe para cambiala de sitio na páxina.

Subindo imaxes

Pode subir imaxes dende unha pestana da caixa de diálogo de ficheiros multimedia.

Prema na lapela "Subir" e seleccione unha imaxe do seu ordenador. Pode teclear o nome do ficheiro, ou arrastar unha imaxe na caixa. You can type the file name, or drag an image into the box. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.

Ten que describir a imaxe e engadirlle categorías para que outras persoas poidan atopala.

A imaxe será inserida na páxina cando remate.

Editar as galerías de imaxes

Para engadir unha nova galería, prema na icona "Galería" (un conxunto de fotografías) no menú "Inserir". (En caso de que non se mostre esta icona no menú, significa que a súa wiki local decidiu atrasar a aplicación desta funcionalidade no editor visual.)

Para editar unha galería existente co Editor Visual, prema na mesma. De seguida, na parte inferior da galería, prema na icona (un conxunto de fotos) para abrir o editor da galería e mostrar a lista completa de imaxes incluídas na mesma.
O editor de galerías é unha simple caixa que lle permite editar as galerías existentes usando wiki-texto. Para engadir novas imaxes á súa galería, debe incluír o nome do ficheiro, seguido dunha barra (|) e da lenda que desexa engadir á imaxe. Cada imaxe da galería debe estar na súa propia liña. Tamén pode editar esta lista para eliminar e/ou reorganizar imaxes ou para alterar as lendas.

Cando prema no botón "$dialogdone", sairá do editor de galerías. Despois xa verá os seus cambios, coa galería co aspecto que se lle mostrará ós lectores.

Lémbrese que saír do editor de galerías non grava as súas modificacións. Igual que sucede con outras modificacións feitas co Editor Visual, debe gravar a páxina enteira para gardar o seu traballo.

Edición de modelos

The powerful MediaWiki template system lets you insert dynamic content, text from other pages, and much more. For a detailed explanation and examples, see the Templates help page.

In the VisualEditor you can search for a relevant template, add an invocation or transclusion on the page you’re editing and, if needed, add custom content using parameters.

Insert new template

Para engadir un novo modelo á páxina, poña o cursor no sitio onde queira inserir o modelo e prema na icona "$template" (a peza de crebacabezas) no menú "$insert". Then open the Inserir menu and select " Modelo". Alternatively, type two curly brackets {{ to open the same dialog.
Find the template you want to insert by typing either its name or a relevant keyword. Results containing the search term in either the name or description will display in a dropdown. This should help you find a relevant template, even if you don’t know its exact name.

If you’re having trouble finding the kind of template you want by using keywords, you can look on other wiki pages with similar content and view or edit the page source to see which templates are in use. When you find the desired template’s name, you can type it into this field to insert it here.

Screenshot of the template search field in the Visual Editor

Pode tamén editar un modelo que xa se atopa na páxina. Ao premer no modelo para seleccionalo, ponse azul e aparece unha caixa con unha icona "$template" (peza de crebacabezas). Logo prema na ligazón "$edit". When you select the template you want to edit, it turns blue, and a box appears displaying " Modelo". Then select the "Editar" link or double click on the template itself to open the template.
Screenshot of the VisualEditor interface with a template selected

Algúns modelos non son visibles para os lectores da páxina. No editor visual, estes modelos ocultos móstranse coma iconas de crebacabezas. O nome do modelo aparecerá ó lado da icona de crebacabezas.
Screenshot of hidden templates in the Visual Editor interface

Parámetros de modelo

You’ll see this dialog box when you’re adding a new template or editing one already in place. What you see in the box depends on whether the template in question contains TemplateData , helpful metadata added by other editors to make it easier to edit templates in the Visual Editor.

When a template contains TemplateData, the VisualEditor can use it to present annotated fields for you to fill in.


For templates that have some community-provided TemplateData, the VisualEditor displays a list of the named parameters and, often, descriptions and instructions explaining the meaning and required format for each parameter’s values.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

You can disable any optional parameter (which have blue checkboxes on the left side). If a parameter’s checkbox is grayed out and not clickable, the template requires that parameter, so it can’t be disabled.

When you insert a new template, you may find that some optional parameters are pre-selected. That means the author(s) of the template recommends the use of those parameters. It’s best to review all parameters that will be used in a template to ensure you understand their use.

Clicking an unchecked parameter adds it to the template. Clicking a parameter that’s already been added takes you to the parameter’s input field.

Some template parameters will show as “deprecated”. Don’t use deprecated parameters when inserting a template; they’re only visible to you because those parameters are in use on older pages where this template was included.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Adding undocumented parameters

If you’re inserting or editing a template whose author hasn’t laid out its parameters in TemplateData, it has what we call “undocumented” or “unnamed parameters”. In these cases, you should consult the page for the template itself. There you can learn how to correctly employ and work with all of the template’s parameters. This includes learning the exact names of the parameters as written by the template author.

If you find in the documentation that the template expects parameters without names, fill in numbers as placeholders for the parameter names using the undocumented parameter input, then add text to the values you want to provide as you normally would.

Example:

  • first unnamed parameter: “1”
  • first unnamed parameter’s value: “en_US”
  • second unnamed parameter: “2”
  • second unnamed parameter’s value: “yes”

If you accidentally include nonexistent, misspelled or erroneous parameters, the values you enter for those parameters won’t show up on the page you’re editing.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerated parameters

In this example, the template in question lacks TemplateData but it was possible to autogenerate the parameters. This means that the undocumented parameters have already been added for you, but the names may not be easily understandable and the dialog cannot display any directions or descriptions. As a result the dialog box provides a link to the template’s documentation, which should help you deduce and fill in the template’s various parameters.

Editing multi-part template content

During editing, you may open template content consisting of multiple templates or a single template linked to some wikitext. This differs from the nested templates described below. In this case, the templates are better visualized as being stacked or connected.

This content often contains “unbalanced templates,” templates which are incomplete on their own and need to be paired with some wikitext or another template in order to function.

These related pieces of template content must be created in wikitext, but can be edited in the VisualEditor. In these cases you will see a notice at the top of the dialog to signal the situation and a specialized toolbar will be visible at the bottom of the sidebar. There you can use the icon buttons to add additional templates, additional wikitext, delete elements or change their order.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Nested templates

Templates can include other templates as the value for parameters. You’ll recognize it when you see a parameter whose value contains the double curly braces ( {{ }} ) denoting a template.

The VisualEditor can’t present this template within a template (a nested template) using the editor’s easy-to-use interface, so if you want to nest a template yourself, you’ll need to understand how to add the template by hand in wikitext into the appropriate parameter field.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Completing your edit

Cando remate a edición dun modelo, prema en "Aplicar os cambios" para pechar a xanela e voltar á edición da páxina principal. Then you can preview your edit and make sure it looks the way you want and expect.

You may also see an error message, which (like the other TemplateData mentioned above) is community-provided content and may vary in usefulness. You may need to consult the template’s own documentation to get to the bottom of some errors. If you’re still having trouble, consider posting about your problem on the template’s talk page.


Removing a template

To remove a template in the VisualEditor, click the template box. Press the "Delete" or "Backspace" key on your keyboard. The template will disappear from the page.
Screenshot of the button to remove a template
Removing a template in the VisualEditor

Editing on mobile

When editing a template on a page using the VisualEditor on a mobile device, you’ll see that the sidebar starts out hidden. You can make it visible by pressing the “Show/hide options” button.
Screenshot of editing a template on a mobile device
Editing a template on mobile in the VisualEditor

Substituír os modelos

When you insert a template in a wiki page, its content and appearance are reevaluated every time the page loads, based on the template code and the values of its parameters. This means if someone updates the code of a template, then every page which uses that template will also get updated when they publish.

There’s another, much less common way to use templates, though, and that’s to substitute a template. Doing this permanently includes the template content just as it appears at the moment you insert it. It will not update if the template code is later changed.

Most users won’t ever need to resort to substitution. Substitution is typically only useful when you need to capture the exact appearance of one version of a template, such as when content is under development and needs evaluation.

To substitute a template in the VisualEditor, insert a template using the name syntax subst:<template name>. Then press the blue “Engadir” button.

When you’re finished, press “Inserir”, which will insert the template content as you see it.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Editando listas

Pode usar o editor visual para crear listas, ou para cambiar o formato dunha lista existente. Hai dous tipos de listas: non ordenadas e ordenadas (numeradas).

Para comezar unha nova lista, prema nun dos dous elementos do menú mostrados aquí. Ou, se xa ten tecleada a lista (en liñas separadas), seleccione (resalte) a lista que tecleou, e logo prema nun dos elementos do menú.


Aquí amósanse exemplos dos dous tipos de listas: non ordenadas e ordenadas (numeradas).

Se quere cambiar o nivel identación de parte dunha lista, seleccione a parte que quere cambiar.

Logo use o menú, ou prema a tecla Tab. (A tecla Tab aumenta a identación, use a tecla Shift xunto coa tecla Tab para diminuír a identación).

Este é o resultado dunha identación aumentada.

Pode mesturar listas ordenadas (numeradas) e non ordenadas, se os elementos da lista teñen identacións diferentes.

Editar as táboas

Pode usar o Editor visual para inserir e cambiar táboas.

Pode, incluso, importar unha táboa arrastrando un ficheiro de valores separados por coma (.csv) dende o seu ordenador ata a xanela de edición principal.


Cando preme en "Táboa", no menú "Inserir", o Editor Visual insire unha táboa de catro por catro en branco.

Agora o menú "Táboa" está dispoñible. Dende este menú, pode engadir un título na parte superior da táboa.


Para seleccionar unha cela, presiónea unha vez.

Para editar os contidos dunha cela (por exemplo, para engadir contido ou corrixir un erro ortográfico), prema dúas veces na cela. Ou pode seleccionar a cela e despois premer Return.

Para rematar de editar unha cela, só prema en calquera outro lado.


Pode engadir ou borrar unha columna ou unha fila.

Pode fusionar celas: seleccióneas, logo no menú Táboa, prema en "Fusionar celas".

Se fusiona celas, só se mantén o texto nunha das celas, o texto nas outras celas bórrase cando fusiona as celas. Se decide que quere algún ou todo o texto que foi borrado, use o botón de Desfacer, mova ou copie o texto que quere, e logo fusione as celas de novo.

Tamén pode dividir celas que foron fusionadas previamente. Todo o contido que estaba na cela fusionada pasarase á primeira cela cando faga a fusión. Logo pode cortar e pegar texto a outras celas, se quere.

Editar as categorías

Para editar categorías, no menú "Opcións da páxina", prema no elemento "Categorías".

Premendo en "Categorías" abre unha xanela que lista as categorías existentes e permite que engada outras novas, e que borre as existentes.

Ten tamén a opción de configurar ou cambiar a chave xeral (predeterminada) de ordenamento, que determina onde aparece a páxina cando se lista con outras páxinas na mesma categoría.

Por exemplo, a chave de ordenamento por defecto para o artigo "George Washington" é "Washington, George". Na categoría "Presidentes dos Estados Unidos", o artigo aparecerá listado na letra "W", non na "G".


Para engadir unha categoría a unha páxina, escriba o nome da categoría e prema en "Engada unha categoría". A medida que vai escribindo, o Editor Visual buscará unha correspondencia nas categorías existentes. Pode seleccionar unha categoría existente ou crear unha nova que aínda non teña a súa propia páxina de categoría. (Ata que a páxina desa nova categoría sexa creada, o seu nome mostrarase en vermello despois de que grave as súas modificacións.)

Para eliminar unha categoría existente, prema nela e na icona "Eliminar" (caldeiro de lixo) na xanela que se abre.

Premendo nunha categoría tamén lle permite especificar a clave de ordenación para esa categoría específica. Esta clave de ordenación sobreponse á clave de ordenación por defecto.


Prema en "Aplicar os cambios" ao rematar de editar as categorías e volverá ao editor da páxina.

Editar a configuración da páxina

Para editar a configuración dunha páxina, prema para abrir o "Opcións da páxina" menú, na barra de ferramentas, e seleccione o botón "Configuración da páxina".

O botón "Configuración da páxina" abre unha xanela que mostra varias opcións.

Pode facer que unha páxina redirixa a outra marcando a caixa "Redirixir esta páxina cara a", e despois escribindo o nome da páxina á que quere que se reenvíe ó usuario que quere ir á páxina que vostede está editando.

Na parte de abaixo está a opción de previr renomeados de páxina de actualizacións desta redireción. Esta opción utilízase raras veces.


Pode cambiar se a páxina mostra unha Táboa de contidos seleccionando un destes tres botóns. A opción por defecto é "Se fose necesario", que mostra unha Táboa de contidos se hai tres ou máis seccións.

Pode facer unha páxina que non mostre as ligazóns de editar ó lado de cada título de sección marcando esta opción.

Prema "Aplicar os cambios" cando remate de editar o Opcións da páxina para volver ó editor da páxina.

Editing maps

You can add and change maps. See Help:VisualEditor/Maps .

Editar as fórmulas matemáticas

Para engadir fórmulas matemáticas a unha páxina, poña o cursor onde quera insertala, e prema na icona "Fórmula matemática" ("Σ") no menú "Inserir" da barra de ferramentas.

Abrirase unha xanela na cal pode escribir a fórmula, usando sintaxe LaTeX. O Editor visual actualizará a fórmula ó tempo que a escribe, así vostede poderá ver como queda ó mesmo tempo que fai os cambios. Así que teña a fórmula correctamente escrita, prema no botón "Inserir".

Para editar unha fórmula que xa está na páxina, prema nela e logo prema na icona "Σ" que aparece. Isto abrirá a xanela das fórmulas, onde poderá facer os cambios.

As fórmulas matemáticas poden engadirse dentro do texto ou centradas como un bloque.

Editando partituras musicais

Para engadir unha nova partitura a unha páxina, poña o cursor no sitio onde quere inserila. Logo, dende o menú "Insert" na barra de ferramentas, prema na opción "Notación musical".

Para editar unha partitura xa existente na páxina, prema dúas veces nela.


Isto abrirá a pantalla de "Notación musical". Aquí a notación pode editarse por escala, tanto en formato ABC como en Lilypond. Tamén pode ligar a notación a un ficheiro de son ou MIDI. Así que teña rematado, prema o botón "Feito" para pechar a xanela e gardar os seus cambios.

Editar os poemas e outros elementos especiais

Algúns elementos, como as listas de asociación e poemas, aínda non están soportados completamente no editor visual.

Na maioría dos casos, os elementos existentes poden editarse, pero os novos non se poden inserir no editor visual.

Ata que sexan soportados completamente, pode copiar un existente doutra páxina, ou editar o texto wiki fonte directamente.


Cambiar de modo de edición

Para cambiar do editor visual ó editor de wikitexto, prema no botón [[ ]] na parte dereita máis afastada da barra de ferramentas.


Verá un diff. (Se preme en "Descartar cambios", vostede simplemente verá o wikitexto, listo para modificar co editor de wikitexto.)

Desprácese á parte de abaixo e verá a área de edición de wikitexto.


Tamén pode cambiar entre o editor de wikitexto e o editor visual. Para facer isto, prema na icona do lapis na parte da dereita máis alonxada.

Atallos de teclado

Moitos editores insiren texto wiki directamente, especialmente negras, cursivas e ligazóns internas. Os atallos de teclado permiten inserir rapidamente formatos similares sen ter que premer nos botóns da barra de ferramentas. Aquí están os atallos de teclado de uso xeral do Editor visual.

Atallos para PC Acción Atallo para Mac

Ctrl+B Negra ⌘ Cmd+B

Ctrl+I Cursiva ⌘ Cmd+I

Ctrl+K Inserir unha ligazón ⌘ Cmd+K

Ctrl+X Cortar ⌘ Cmd+X

Ctrl+C Copiar ⌘ Cmd+C

Ctrl+V Pegar ⌘ Cmd+V

Ctrl+Z Desfacer ⌘ Cmd+Z

Also see the full list of all keyboard shortcuts .