Help:ビジュアルエディター/利用者ガイド

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 94% complete.
PD 注意: このページを編集すると、編集内容が CC0 のもとで公開されることに同意したと見なされます。詳細はパブリック・ドメインのヘルプ ページを参照してください。
PD


ビジュアルエディターを開く

ビジュアルエディターでページを編集するには、ページ上部の「編集」タブを押してください。

場合によっては、編集画面を開くのに数秒かかり、ページサイズが非常に大きい場合は少し待たされることがあります。

「ソースを編集」タブをクリックすると、従来のソースエディターが開き、ウィキテキストを編集できます。

VisualEditor edit tab-ja.png

ビジュアルエディターを開くには、各節にある「編集」リンクを押すという方法もあります。
VisualEditor - Section edit links-en.png

編集を始める: ビジュアルエディターのツールバー

ビジュアルエディターのツールバーのスクリーンショット
編集を始めると、編集画面上部にビジュアルエディターのツールバーが表示されます。このツールバーにはおなじみのアイコンもいくつか並んでいます:

VisualEditor - Toolbar - Undo-redo.png
編集内容に対して「取り消し」や「やり直し」(元に戻す、やり直し) の操作ができます。

VisualEditor Toolbar Headings-ja.png
見出し」プルダウン メニュー: 段落書式を変更できます。カーソルを段落内に置き、このメニュー内のアイテムを選択して段落書式を変更します(テキストを選択する必要はありません)。セクション見出しは「見出し」、下位のセクションは「小見出し 1」「小見出し 2」と表示します。 「段落」はページ本文の標準書式です。

VisualEditor Toolbar Formatting-ja.png

書式:A」を押すとメニューが開きます。

  • 「太字」(B) は選択したテキストを太字化。
  • 「斜体」(I) は選択したテキストを斜体化。
  • 「上付き」(x2) は、選択した文字を前後の文字列より小さくしてやや上寄りに表示。
  • 「下付き」(x2) は、選択した文字を前後の文字列より小さくしてやや下寄りに表示。
  • 「取り消し線」(S) は選択した文字列に取り消し線を追加。
  • 「コンピューターのコード」(波カッコの組み合わせ: {}) は、選択した文字列のフォントを等幅フォントに変更して、まわりのプロポーショナルフォントによる文字列と区別。
  • 「下線」(U) は、選択した文字列に下線を追加。
  • 「言語」(文A) は、選択した文字列について、言語 (例えば「日本語」) と書字方向 (例えば、右から左へ) を指定。
  • 最後のアイコン (VisualEditor MediaWiki theme clear icon bitmap.png)「装飾解除」は、選択したテキストからリンクを含むすべての書式設定を除去。

文字列を選択せずに「A」を押してメニューを開き特定の項目を有効にすると、その書式は、それ以降にカーソルを動かして新しく入力する文字列に適用されます。


VisualEditor - Toolbar - Linking.png
リンクツール: 鎖の輪アイコンはリンクツールです。通常はどこかのテキストを選択した後でこれを押すと、リンク画面が開きます。

VisualEditor - Cite Pulldown.png
引用 メニュー: 「引用」メニューはインラインでの参照 (「脚注」や「参考文献」とも呼ばれます) を追加するためのものです。このメニューを使うと、どのプロジェクトでも基本的な参照の追加や再利用ができます。ご使用のウィキ固有の参照テンプレートが有効な場合、このメニューからすばやく開くこともできます。

(「引用」メニューに特定のウィキ固有の参照テンプレートを追加する方法については ビジュアルエディター/参照ツール をご覧ください。)


VisualEditor citoid Cite button-ja.png
引用 ボタン: あなたのウィキで典拠管理サービス (citoid service) が有効な場合、引用 メニューの代わりに 引用 ボタンが表示されます。

citoidサービスは自動的に参照テンプレートへの記入を試みます。


VisualEditor Toolbar Lists and indentation-ja.png
箇条書きとインデント: 最初の2つの選択肢はテキストをそれぞれ「番号なし箇条書き」または「番号付き箇条書き」に設定する方法です。あとの2つで、箇条書きのインデントの階層を増減できます。

VisualEditor Insert Menu-ja.png
挿入:「挿入」のメニューはプロジェクトによって異なる場合があります。下は現れうるすべてのオプションの一覧です。
  • 「画像とメディア」(山の絵) のアイコンは、メディアを挿入するダイアログを開く。
  • 「テンプレート」(パズルのピース) は、テンプレートを編集
  • 「表」のアイコンは表組みを挿入。
  • 「コメント」 (ふきだし) は、読者には見えないコメントを挿入(コメントアウト)。編集モードに切り替えると、コメントがあるときは感嘆符アイコン (黒丸に「!」) が表示される。このアイコンを押すとコメントの編集や削除ができる。
  • 「象形文字」 (☥ - アンク (エジプト十字)) のアイコンは、ヒエログリフを挿入 (後述)。
  • 「コード」アイコンでコードを記入。
  • 「楽譜」のアイコンを押すと楽譜を挿入。
  • 「ギャラリー」(一組の写真) は、ページにギャラリーを追加。
  • 「数式」(Σ) は、数式の挿入画面を開く。
  • 「表」アイコンで図表を挿入。
  • 「あなたの署名」を押すとウィキペディアで使っている署名を追加。 署名を付けてはいけない種類のページつまり「名前空間」だと、例えば記事の場合、グレーで表示されて押せない。
  • 「情報源一覧」(3冊の本) はダイアログを表示、出典 (脚注) 一覧を表示する場所を指定する。通常は各ページで指定は1回だけ。

特殊文字の挿入: 「挿入」メニューに表示される「特殊文字」(Ω) のアイコンを押すと欄が展開して、多数の特殊文字を表示します。テキストに挿入するには、使いたい記号や特殊文字を1文字ずつ選んで押します。表示されるのは良く使う記号や数学記号、発音区別符号(ダイアクリティカルマーク)も含まれます。 (この一覧はローカルでカスタマイズできます。説明は ビジュアルエディター/特殊文字 を参照してください。)
VisualEditor Toolbar SpecialCharacters-ja.png

VisualEditor toolbar edit notices icon.png
編集警告 (黒い三角) ボタンはそのページに何かの警告があることを表示しています。

VisualEditor More Settings-ja.png
ページ設定メニューは変更を公開エディターを切り替えるボタンの左にあります。メニューを開くと(表示の左半分に)次のようなオプションを選ぶボタンがあります。
  • カテゴリ で表示中のページにカテゴリを追加すると、カテゴリごとの表示で別のカテゴリの索引に拾われるように指定できます。
  • ページの設定 を使うとそのページをリダイレクト化してそのオプションを調整したり、目次の表示方法や節見出し単位の「編集」ボタンを非表示に設定したり、あるいはそのページを曖昧さ回避ページに指定できます。
  • 高度な設定を使うと、検索エンジンがそのページに付ける索引項目の指定、新しい節を追加して小見出しを記入するタブの表示を設定します。
  • 言語 はその記事がある他言語版のリストを表示してリンクさせます。
  • 使用するテンプレートボタンを押すとそのページで使用しているテンプレートへのリンクを一覧できます。

オプション設定のタブ類はページ設定メニューにもあり、クリックすると設定画面が開きます。 ページ設定メニューにはほかにも左方向書記式で表示ボタン (文字入力領域を開く) があり、検索して置換ボタンを押すと検索対象の文字列や標準の表現と何と置換するか指定する領域とオプション選択ボタンが選べます。


VisualEditor bi-directional switching square brackets icon.png
ソース編集への切り替えボタンは 変更を公開ボタンの隣にあり、ウィキテキストエディターに切り替えます。

変更の公開

編集が終わったら、ツールバーにある青色の「変更を公開」ボタンを押します。変更を加えないと、ボタンは押せません (グレー表示)。 編集を全キャンセルする場合は、単にブラウザのウィンドウを閉じるか、もしくは編集ツールバーの「閲覧」タブを押します。
VisualEditor toolbar actions-ja.png

青い「変更を公開」ボタンを押して開くダイアログボックスで行う操作は次の3つです。編集内容の要約を入力、「細部の編集」に指定、記事を ウォッチリスト に追加。「編集内容の要約」欄は、従来のウィキテキスト エディターの「編集内容の要約:」欄と同等です。

編集内容を保存する前に「変更内容を確認」ボタンをクリックして、意図したとおりに表示するかどうか確認できます。これは、従来のウィキテキスト エディターの「差分を表示」ボタンと同等です。

「編集を再開」ボタンをクリックすると編集中のページに戻ります。変更の内容はまだ保存されておらず、あとで保存できます。

VisualEditor save dialog-ja.png

リンクの編集

VisualEditor - Toolbar - Linking.png
リンクの追加は、ツールバーの「リンク」 (鎖マーク) アイコンで行います。ショートカットキー(WindowsではCtrl+K、 Macintoshでは⌘ Command+K) でもリンクを追加できます。

テキストを選択 (強調表示) して「リンク」ボタンを押すと、そのテキストを取り込みます。リンクを付けたい単語の上にカーソルを置いて同じボタンを押すと、取り込んだテキストがリンクの内容に使われます。リンクの内容が単語1つの場合、その単語を選ぶか、カーソルをその単語の中に入れる (上に置く) かします。


VisualEditor-link tool-search results-ja.png
リンクを手入力するには、ボタンを押すかショートカットを使ってダイアログを開き、そこに入力します。

リンク ツールは、一致しそうな内部リンクを検索して補助しようとします。 リンクを記入または選択したら、Enter キーもしくは「完了」ボタンを押すと、リンク付けが完了します。リンクは VisualEditor のページにすぐ表示されるものの、実際には「ページそのもの」を公開するまで変更されません。


VisualEditor-link tool-external link.png
外部サイトのウェブページにリンクするのも、同じ手順です。「外部サイト」タブを選び、URL を記入します。

VisualEditor link tool simple link.png
ラベルを付けない外部リンクは文中に「[1]」のように表示します。 これらを追加するには、カーソルを文章の単語以外の場所 (たとえばスペースのあと) に置きます。 リンクツールを開くには、メニューバーの鎖マークか文中に大カッコと数字 (例:[1]) で示されたショートカットを押します。 リンクを挿入するには、ボックスに URL を入力してから「完了」ボタンを押します。

VisualEditor-context menu-link tool.png
既存のリンクの変更や削除ができます。文中のリンク (大カッコと数字) をクリックしてからツールバーの「リンク」アイコン(鎖マーク)を押し、ダイアログボックスを開けて編集してください(キーボードショートカット Ctrl+K でもダイアログボックスが開きます。) リンクを選択すると、文字列の背景が青くなります。

リンク先は、リンク編集ダイアログボックスから変えます。またリンクの削除はボックス右上にある「除去」ボタンを押します。 ダイアログボックスに表示されたリンクのコピーを押すと、リンク先が別のウィンドウで開きます。 (外部リンクが切れていないか確認するためにも使えます。)

リンクラベルを終了するか (文字列はリンクとして表示)、あるいはこのリンクの後に書き込みを続ける場合は、を押します。

  • 1回押すと、カーソルはリンク編集ダイアログボックスから出て、リンクした要素、つまり背景が青い文字列の末尾に移動 (この文字列を編集するため)。
  • 2回押すと、カーソルはリンクした要素の外に移動。文章の続きが入力できる。

既存のリンクラベルを編集するには、リンクラベル内を押してから新しく入力します。 ラベルの文字をすべて書き換えるときの注意点です。

  • リンクのラベル全文を選択 (色を反転) すると、文字を入力したとたん、そのリンクは消去される。 リンクは新しく作り直す。
  • リンクは残してラベルだけ修正するには、リンクラベルの中を押し、次にbackspaceもしくはdeleteキーで文字を消す。このとき最後の1文字を慎重に消し、青色の細長いラベル入力の領域を残す。 そこに修正後のラベル名を入力。
  • またカテゴリやファイルその他へのリンクもここで書きます

出典の編集

詳細については 脚注テンプレートのヘルプ 又は、Help using citoid's Cite button を参照してください

導入されているシステムの見分け方

3つある脚注のしくみのうち、どれか1つが利用可能になっています。 右の挿絵に示したものは一番シンプルで、「引用」メニューには引用テンプレートがひとつもありません。 もしご利用のウィキがこのシステムを使用しているなら、脚注についての説明は以上でおしまいです。
VisualEditor cite menu default.png

2番目のシステムも引用メニューは同じタイプですが、すぐにアクセスできるようによく使う引用テンプレートが用意されています。 もしご使用のウィキがこのシステムを導入しているなら、詳細な説明はHelp:VisualEditor/User guide/Citations-Templates にあります。
VisualEditor references more.png

VisualEditor citoid Cite button-ja.png
3番目のシステムでは、まず Cite ボタンを押します。 するとボックスが開き、citoid サービスを使って自動的に出典作成の手順が示されます。 このシステムを採用しているウィキでは、Help:VisualEditor/User guide/Citations-Full (出典の示し方) に詳しい説明があります。
VisualEditor Citoid Inspector-ja.png

既存の出典の編集

既存の脚注を編集するには、テキスト内のマーク (ふつうは大カッコと数字のセット) を押します。すると「脚注」アイコン (しおりマーク) または、その脚注を作ったテンプレートのアイコン (とその名前) が現われます。いずれにしろ「編集」ボタンを押すとダイアログボックスが開き、脚注を編集できます。
VisualEditor - Editing references 1.png

「脚注」アイコンと対応する「編集」ボタンを押すと、脚注のダイアログボックスが開き、そこで内容を編集できます。

多くのウィキでは、脚注を整形するテンプレートを用いています。テンプレートを利用して脚注を付けた場合、脚注情報にカーソルを当てると、脚注フィールド内の情報が強調表示になります。

使用してあるテンプレートの出典の情報を押すと、テンプレートアイコン (ジグソーパズルのかけら) とともに情報を表示します。「編集」ボタンを押してテンプレート編集欄を開き、テンプレートの内容を編集します。

VisualEditor - Editing references 6.png

もし出典を押して標準の出典テンプレートが表示されたら (右のサンプルを参照) 「編集」ボタンを押して編集欄を開きます。
VisualEditor - Editing References - Cite Web.png

テンプレートの編集欄では、情報のタイプを加減したり、内容を編集したりします。記述されたフィールド (テンプレートの変数) だけが表示されます。フィールドを追加するには、編集欄のいちばん下にある「詳細情報を追加」を押します。
VisualEditor - Editing references 5.png

完了したら、「変更内容を適用」を押します。
VisualEditor Apply Changes-ja.png

既存の出典の再使用

ページに既存の出典がある場合、あなたが出典を示したい文章にそれを再利用できます。

既存の出典を再利用するには、文中の出典 (と出典番号) を追加したい場所にカーソルを置いて「引用」メニューの「再利用」アイコンを押します。

(注記: 上記の3番目の脚注システムを採用するウィキでは、「引用」メニューに「再利用」アイコンが出る代わりに、編集欄に「再利用」のタブが表示されます。)

VisualEditor Cite menu re-use.png

脚注を再利用するには 脚注 ダイヤログボックスを開き、一覧からもう一度使うものを選びます。多数ある場合には、検索バー (「現在の引用内を検索」と表示) に特定のテキストを入力すると、しぼりこんだ結果のみ一覧できます。
VisualEditor - Editing references 18.png

新しい出典の追加

「引用」メニューを使って脚注を新たに追加するには、文中の脚注をつけたい位置をクリックします。そしてメニューから適した出典のタイプを選びます。
VisualEditor references more.png

「基本」の引用を使用

基本の出典アイコンを押したときの画面表示はこうなります。 出典エディターでは、出典の追加と、既存の出典の整形ができます。

脚注を既存のグループに含めることもできますが、通常は空欄のままにします。 (これは「情報源一覧」ツールを使ってグループ化した脚注を表示させるオプションを説明しています)

VisualEditor - Editing references 20.png

出典エディターのドロップダウンボックスを使い、新しい出典に出典あるいはその他のテンプレートを含めるには、出典エディターの「挿入」ツールバー メニューにあるテンプレート アイコン (パズルのピース) を押します。
VisualEditor Template Insert Menu-ja.png

それから、他のテンプレートの操作と同じように、使いたいテンプレートを探して追加してから望む通りに編集します。 (テンプレートの詳しい解説は、以下に テンプレートの編集のセクションがありますので参照してください。)

新しいテンプレートの編集が終わったら、「変更内容を適用」を押して引用エディターに戻り、もう一度「変更内容を適用」を押して元の編集していたページに戻ります。

VisualEditor - Editing references 9.png

ページにまだ「出典の一覧」がない場合(例: そのページで初の出典を追加するとき)、閲覧者に対して、どこに出典一覧および出典情報を表示するか、決める必要があります。

脚注の一覧を表示させたい場所 (通常はページ下部) にカーソルを置き、「挿入」メニューを開いてから「情報源一覧」アイコン (3冊の本) を押します。

VisualEditor References List Insert Menu-ja.png

ごくまれなケースとして、複数の出典グループを用いる場合は、このダイアログでグループを特定します。そのグループを作ったページの利用者が指定した箇所に、特定のグループに属する脚注のみ表示します。

脚注一覧ダイアログを終えるには「挿入」を押します。

VisualEditor references list-ja.png

標準の引用テンプレートの使用

もしご使用のウィキで独自の出典テンプレートを用意していると、「引用」メニューに表示します。よく使われる出典テンプレートにすばやくアクセスできます。 (ご使用のウィキで出典テンプレートの追加は、ビジュアルエディター/参照ツール で方法を説明しています。)
VisualEditor - Editing References - Cite Pulldown.png

テンプレートの例えば「Cite book」アイコンを押すとテンプレートのミニ エディターが開き、必ず記入するべきフィールドに「*」(アスタリスク) が付いています。もっともよく使われるフィールドが表示されますが、すべてに記入する必要はありません。
VisualEditor - Editing references - Cite book required fields.png

変数を追加するには、ミニエディターのいちばん下までスクロールし、「詳細情報を追加」を押します。

完了したら、「挿入」を押します。

VisualEditor - Editing references - Add parameter.png

画像などメディアファイルの編集

画像の編集

新しい画像 (または別種のメディア) を挿入するには、「挿入」メニューの「画像とメディア」 (山の絵) を押してください。カーソルがどこにあっても画像が追加されます。
VisualEditor Media Insert Menu-ja.png

「画像とメディア」アイコンを押すとダイアログが開き、編集中のページの名前と関連するメディア ファイルを自動的に検索します。探す範囲は、ウィキメディア・コモンズやローカル ウィキです。

ダイアログの検索枠にあるテキストを変更すれば、また別のメディアファイルを探すことができます。

サムネイルを押してファイルを選択してください。

こうするとあなたが編集中のページに画像が配置されます。

VisualEditor - Media editing 2.png

選んだ画像がページに追加されると、続いて新しいダイアログが開きます。このメディア ダイアログで、画像のキャプションの追加および編集ができます。キャプションでは書式設定やリンクもできます。
VisualEditor - Media editing 6.png

メディアダイアログでは、スクリーンリーダーを用いているユーザや画像表示をオフにしているユーザの助けになる代替テキストの追加もできます。
VisualEditor - Media editing 7.png

「詳細な設定」のウィンドウで様々なパラメータを設定できます。パラメータには画像の配置位置、タイプ、大きさなどがあります。
VisualEditor - Media editing 8.png

キャプションを編集したら「変更内容を適用」を押します。すると、ダイアログが閉じ、通常の編集画面に戻ります。
VisualEditor Apply Changes-ja.png

すでに配置済みの画像に対しては、画像を押してキャプションを追加または編集したり、設定を変更したりして、それから「画像とメディア」を押します。

既存の画像のサイズを変更するには、画像を押してサイズ変更アイコン(画像の隅に表示される両端がとがった矢印)を動かします。

画像をドラッグ&ドロップすることにより、画像を上または下に移動することができます。

VisualEditor - Media editing 3.png

画像のアップロード

画像をアップロードする方法は3つあり、メディアダイアログのタブで処理するか、表示用画面で画像を選択しエディタにドラッグ&ドロップするか、画像をクリップボードに複写してからエディタに貼り付ける(コピー&ペースト)ことができます。
VisualEditor - Media upload 1.png

「アップロード」タブを押してご利用のPCから画像を選択します。ファイル名をタイプするのでも、画像を枠内にドラッグするのでもかまいません。 このタブは、画像表示ソフトから直接、ドラッグ&ドロップしたり、画像をクリップボード経由でコピー&ペーストしたときに自動的に開きます。
VisualEditor - Media upload 1.5.png

画像に説明とカテゴリを加えて、ほかの人がその画像を見つけられるようにしてください。
VisualEditor - Media upload 2.png

完了すると画像はページに挿入されます。
VisualEditor-logo.svg

メディアギャラリーの編集

新しくギャラリーを追加するには、ツールバーの「挿入」→「ギャラリー」(2枚重なった写真) を押します。(もしメニューに表示されない場合は、ご利用のウィキがこの機能の導入を先送りしていると考えられます。)
VisualEditor - Gallery1.png

ビジュアルエディターを使い、既存のギャラリーを編集するには、対象のギャラリーを押します。次に「ギャラリー」と表示されたボックス内の青い「編集」ボタンを押します。するとエディターが開き、ギャラリー内の画像すべてがリストされます。
VisualEditor - Gallery2.png
ギャラリーのエディターは現在、構造が単純なボックスで、ギャラリーの編集にウィキテキスト形式のマークアップを採用しています。青い「新しく画像を追加」ボタンを押すと、画像を選択してキャプションを記入するダイアログが開きます。選択した画像はエディターの左側の画像一覧に加わります。 一覧にある画像は、キャプションを編集したり、あるいは「削除」ボタンで削除したり、ドラッグ&ドロップで順番を変えたりできます。

「完了」ボタンを押すとギャラリーエディターが閉じます。必ず画面でギャラリーの変更内容を見て、閲覧者にどう表示されるか確認してください。

ギャラリーエディターを閉じただけでは、変更は公開されません。ビジュアルエディターを使った他の変更同様、ページそのものを公開すると作業結果が公開になります。

VisualEditor - Gallery3.png

テンプレートの編集

MediaWiki のテンプレートシステムは強力であり、複雑なコンテンツを挿入したり、他のページから引用したりなど、さまざまな操作ができます。詳細な説明と事例集は、テンプレートのヘルプページをご参照ください。

ビジュアルエディタを使うと、適切なテンプレートを探したり、編集しているページに関数の呼び出し (invocation) つまり参照読み込みのテンプレートを書き込んだりでき、必要に応じてパラメータを利用して特製のコンテンツを追加することもできます。

新しいテンプレートの追加

ページにテンプレートを追加したい場合、ページ内のテンプレートを挿入したい箇所にカーソルを置きます。<-- 「$insert」メニューにある「$template」アイコン (パズルのピース) を押します。 --> 次に挿入メニューを開き、「OOjs UI icon puzzle-ltr.svg テンプレート」アイコンを押します (訳注:パズルのピース)。 代わりの方法として、希望の箇所に波カッコ2個{{を記入します。
VisualEditor Template Insert Menu-ja.png
Find the template you want to insert by typing either its name or a relevant keyword. Results containing the search term in either the name or description will display in a dropdown. This should help you find a relevant template, even if you don’t know its exact name.

If you’re having trouble finding the kind of template you want by using keywords, you can look on other wiki pages with similar content and view or edit the page source to see which templates are in use. When you find the desired template’s name, you can type it into this field to insert it here.

Screenshot of the template search field in the Visual Editor

既存のテンプレートを編集する方法もあります。 変更するテンプレートを押すと青みがかった色に変わり、ボックス内に「$」アイコン (訳注:パズルのピース形) が現れます。 次に「編集」を押すか、テンプレート自体をダブルクリックし、開きます。
Screenshot of the VisualEditor interface with a template selected

テンプレートにはページの閲覧者によって表示されないものがあります。 ビジュアルエディターでは、そのようなテンプレートは可視化してあり、直接、クリックして編集したり除去したりできます。 パズルのアイコンと、その脇にテンプレートの名称が現れ、どちらも文字の色はグレーです。
Screenshot of hidden templates in the Visual Editor interface

テンプレートの引数

このダイアログボックスは、テンプレートを追加したり既存のものを編集するときに表示されます。 ダイアログボックス内の項目は、対象のテンプレートにTemplateData があるか、他の編集者が記入した有用なメタデータがあるなら、ヴィジュアルエディタでのテンプレート編集が楽になります。

テンプレート内にTemplateDataが書いてあると、ビジュアルエディタは記入するべき欄を表示して説明を添えます。


コミュニティが合意して書き込んだTemplateDataを含む場合、ヴィジュアルエディタは名前付きパラメータの一覧を表示し、しばしば値ごとに意味の説明や必要な書式の指示が添えられます。

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

You can disable any optional parameter (which have blue checkboxes on the left side). If a parameter’s checkbox is grayed out and not clickable, the template requires that parameter, so it can’t be disabled.

When you insert a new template, you may find that some optional parameters are pre-selected. That means the author(s) of the template recommends the use of those parameters. It’s best to review all parameters that will be used in a template to ensure you understand their use.

Clicking an unchecked parameter adds it to the template. Clicking a parameter that’s already been added takes you to the parameter’s input field.

Some template parameters will show as “deprecated”. Don’t use deprecated parameters when inserting a template; they’re only visible to you because those parameters are in use on older pages where this template was included.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

説明のないパラメータを追加する

テンプレートの追加もしくは編集をするとき、テンプレート執筆者がTemplateDataにパラメータの解説を述べていない場合、「説明なし」「名前なし」のパラメータという状態です。 このような場合、テンプレートの解説ページを確認してください。 するとテンプレートのそれぞれのパラメータをどう正しく使うか、操作するか理解できます。 これは、パラメータ執筆者が与えた個々のパラメータの正しい名称を覚えることでもあります。

もしテンプレート解説文書の中に、パラメータの name 要素は無しにすると書いてあったら、無名のパラメータを入力する方法でパラメータのプレースホルダに数字を記入し、通常どおりに編集対象の値の次に記入します。

例:

  • 1番目の名前なしパラメータ: “1”
  • 1番目の名前なしパラメータの値:“en_US”
  • 2番目の名前なしパラメータ:“2”
  • 2番目の名前なしパラメータの値:“yes”

もし実在しない、スペルが間違っている、またはエラーになるパラメータを書き込んだ場合は、それらのパラメータに値を入力しても、編集中の文の中に表示されません。

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

自動生成のパラメーター

この例では対象とするテンプレートには TemplateData が足りませんがパラメータの自動生成ができました。これはシステムが解説のないパタメータを利用者の代わりに入力したからで、その場合もパラメータの名前は簡単に理解できなかったり、ダイアログに指示や説明が表示できなかったりします。 結果として、ダイアログボックスにテンプレートの解説文書へのリンクが表示され、これはテンプレートのさまざまなパラメータを推測して入力するのに役立ちます。
Autogenerated parameters in the VisualEditor.png

複雑な構成のテンプレートのコンテンツを編集する

編集作業中に開いたテンプレートが、複数のテンプレートの組み合わせの場合、あるいは単体のテンプレートから複数のウィキテキストにリンクが張ってある場合に出会うかもしれません。 これは、以下に説明する入れ子のテンプレート類とは異質なものです。 この事例では、テンプレートはまとまりとして、あるいは連携した形で資格化する方が良いです。

このコンテンツにはしばしば「バランスの取れていないテンプレート」が含まれ、それは単体では不完全で、ウィキテキストとの組み合わせ、もしくは他のテンプレートと連携しないと作動しません。

These related pieces of template content must be created in wikitext, but can be edited in the VisualEditor. In these cases you will see a notice at the top of the dialog to signal the situation and a specialized toolbar will be visible at the bottom of the sidebar. There you can use the icon buttons to add additional templates, additional wikitext, delete elements or change their order.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

入れ子のテンプレート

テンプレートのパラメータに、別のテンプレートを組み込むことができます。 テンプレートの書式を読むと、波カッコ2個で囲んだ値を見かけますが( {{ }} )、それが入れ子のテンプレートの箇所です。

ビジュアルエディタは、編集者の利便性を優先するために、この別のテンプレートに埋め込まれたもの (入れ子のテンプレート) を表示できません。そこで、入れ子のテンプレートをに書きたい場合は、ウィキテキストでテンプレートのどこに何を書くか、正しい方法を覚える必要があります。

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

編集を完了する

テンプレートの編集が完了したら、「変更内容を適用」を押します。 次に編集をプレビューし、希望したとおりの見た目になっているかどうか、確認してください。

このときエラ〜メッセージが表示される場合があり、それは (前述の他の TemplateData 同様に) コミュニティが提供したコンテンツであり、便利さには差があります。 特定のエラーを解消するには、そのテンプレートの開設文書までたどっておく必要があるかもしれません。 まだトラブルが解決しない場合は、問題点をテンプレートのトークページに投稿することもご検討ください。

VisualEditor Apply Changes-ja.png

テンプレートの除去

ビジュアルエディターから特定のテンプレートを除去するには、テンプレートボックス内でクリックします。 Press the "Delete" or "Backspace" key on your keyboard. The template will disappear from the page.
Screenshot of the button to remove a template
ビジュアルエディターで特定のテンプレートを除去する

モバイル機器で編集する

モバイル端末の利用者が、ビジュアルエディタを使ってページにあるテンプレートを編集する場合は、最初はサイドバーが非表示になっています。「表示/非表示」ボタンを押して切り替えてください。
Screenshot of editing a template on a mobile device
モバイル機器でビジュアルエディターを使いテンプレートを編集

テンプレートをsubst展開する

ウィキページにテンプレートを挿入するには、その内容と見た目はそのページが読み込まれるときに毎回、評価され、その基準はテンプレートに含まれるパラメータのコードと値です。 これはつまり、誰かがテンプレートのコードを更新すると、そのテンプレートを使用するすべてのページでも、そのページが表示されたときに更新されます。

それに加え、テンプレートの利用にはあまり浸透していない方法があり、それはテンプレートのサブスティチュート subsitution と呼びます。 これを永久的に実行するには、特定のテンプレートを挿入した瞬間に表示された見た目そのままに、その内容も対象になります。テンプレートのコードが後日、変更されたとしても、見た目は変わりません。

ほとんどの利用者にとって、サブスティチュートは必要ありません。 サブスティチュートが有効な場合は限定され、特定のテンプレートの特定のバージョンそのままの見た目を捉えたい場面のみであり、例えばコンテンツが開発途中とか、査読を受ける必要があるなどの場合が該当します。

ビジュアルエディタを使ってテンプレートをサブスティチュート (代入) するには、名前構文 subst:<template name>を記入します。 (自動補完機能はこの事例では無効にしてあります。) 次に青色の「テンプレートを追加」ボタンを押します。

完了したら「挿入」を押すと、テンプレートの内容を見たまま挿入します。

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

箇条書きの編集

VisualEditor Toolbar Lists and indentation-ja.png
ビジュアルエディターを使って箇条書きにしたり、編集したりできます。番号付きと番号なしの2種類の書式から選べます。

箇条書きを作るには、ここに示した2つのメニュー項目のどちらかを押すだけです。あるいは既にある箇条書きを選択 (色を反転)してから、次にメニュー項目のどちらかを押します。


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
番号なしと番号付きの箇条書きのサンプルを示します。

VisualEditor lists 3 select to indent.png
箇条書きの途中でインデントの深さを帰るには、まず変更したい範囲を選択。

VisualEditor lists 4 indentation menu.png
次にメニューもしくはタブ (TAB) キーを押します。タブキーを押すとインデントが深くなります。インデントを浅くするには、タブキーとシフトキーを同時に押します。

VisualEditor lists after indenting.png
インデントの深さを変更した結果はこうなりました。

VisualEditor lists mixed.png
番号付き箇条書きと番号なし箇条書きを混合することもできます。その場合は、種類の違いをインデントの深さで区切ります。

表の編集

VisualEditor insert table-ja.png
ビジュアルエディターで、表を挿入したり編集したりできます。

利用者のコンピューターからカンマ区切りのテキストデータ (.csv) を、メインの編集ウィンドウにインポートすることまでできます。


ツールバーの「挿入」→「表」を押すと、アプリにより4×4の空欄の表が挿入されます。

ここで「表」メニューが表示されるので、表の題名を付けます。

VisualEditor empty table.png

1回押して、セルを選択。
VisualEditor tables select one cell.png

セルの内容の編集をするには (例:内容の追加や修正) 、セルを2回押すか、もしくはセルを選択してから Enter キーを押します。

編集を終了するには、セルの外を押します。

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
行や列の追加、移動もしくは削除ができます(訳注:表メニューから操作を選択)。

セルの統合は、セルを選択し、表メニューから「統合」を選択。
VisualEditor tables merge cells.png

セルを統合すると、特定のセル1個だけの内容が保存され、その他のセルの内容は上書きされます。消えてしまった内容をすべてもしくは一部使いたいときは、「統合解除」を押して操作を取り消し、まず保存もしくは移動したい内容のあるセルをひとつずつ開きます。外部のエディターソフトなどに、保存もしくは移動したい内容を移動もしくはコピーします。これを必要なだけ繰り返した後、セルを統合します。
VisualEditor tables post-merge cell.png

以前に統合したセルを分割できます。分割する前のセルの内容は、分割後の最初のセルに入ります。必要に応じて、その内容をカット&ペーストして、分割したほかのセルに移動できます。
VisualEditor tables split cells.png

カテゴリの編集

VisualEditor category item-ja.png
カテゴリを編集するには、「ページ設定」メニューから「カテゴリ」ボタンを押します。

VisualEditor category editing-ja.png
「カテゴリ」ボタンを押すとダイアログが開きます。カテゴリ一覧が表示され、新しいカテゴリを追加したり既存のものを削除したりできます。

カテゴリページでその記事のソート順を決定するためのデフォルトソートキーを設定・変更するオプションもあります。

たとえば「テイラー・スウィフト」の記事を検索するには基本的に「スウィフト、テイラー」の語順で実行します。「グラミー賞受賞者」のカテゴリでは、「テ」ではなく「ス」の項目に分類されるのです。


VisualEditor - Category editing 3.png
ページに新しいカテゴリを追加するには、"追加するカテゴリ" フィールドに新カテゴリの名前を記入します。すると同時に VisualEditor が既存のカテゴリから候補を検索し始めます。既存のカテゴリを選択できるし、 まだカテゴリページを割り振っていない新しいカテゴリの追加もできます。(編集結果をすべて公開すると、赤リンクとして表示されます。その新しいカテゴリページが作られると青リンクに変わります。)

VisualEditor - Category editing 2.png
既存のカテゴリを除去するには、そのカテゴリを押して、開いたダイアログにある「除去」アイコン(ごみ箱)を押します。

特定のカテゴリを押すと、やはりそれにソートキーを設定できます。これで既定のソートキーを上書きします。


VisualEditor Apply Changes-ja.png
カテゴリの編集を完了し「変更内容を適用」を押すと、通常の編集画面に戻ります。

ページ設定の編集

VisualEditor page settings item-ja.png
ページの設定を編集するには、ツールバーの「ページ設定」(横棒3本のアイコン) を押して開き、「ページの設定」ボタンを押します。

VisualEditor Page Settings-ja.png
「ページの設定」ボタンでオプションが並んだボックスが開きます。

VisualEditor Page Settings Redirects-ja.png
「このページを以下のページにリダイレクト」のチェックボックスを押すと、その下の「リダイレクト先のページ」欄が青から白に変わります。ここにページ名を入力すると、編集中のページから、別のページにリダイレクトを設定できます。あなたが編集しているページを、今後、閲覧者が開こうとすると、記入したページへ移ります。

同じボックスのいちばん下には、あまり使うことのないオプションがあります。ページの改名機能が、このリダイレクト・ページを更新することを防止するオプションです。


VisualEditor Page Settings TOC-ja.png
これら3つのボタンのいずれかを選択することにより、ページに目次を表示するかどうか変更できます。既定の「必要であれば表示」では、見出しが3つ以上あると目次を表示します。

VisualEditor Page Settings Edit Links-ja.png
このチェックボックスをオンにすると、各節見出しの横の「編集」リンクを非表示にできます。

VisualEditor Apply Changes-ja.png
ページ設定の編集が完了したら「変更内容を適用」を押して通常の編集画面に戻ります。

地図の編集

Visual editor showing editing an existing map.jpg
地図を追加して変更できます。参照先はHelp:VisualEditor/Maps です。

数式の編集

ページに数式を新たに追加するには、挿入したい場所にカーソルを置き、ツールバーの「挿入」メニュー上の「数式」アイコン(「Σ」)を押します。
VisualEditor Formula Insert Menu-ja.png

するとウィンドウが開くので、数式をLaTeX構文で記入します。文字入力を始めるとビジュアルエディターが数式を更新し、画面で内容を確認できます。数式を書き終えたら、「挿入」ボタンを押します。
VisualEditor formula-ja.png

ページ内の既存の数式を編集するには、それを押して選択し、表示された「Σ」アイコンを押します。開いた数式ウィンドウで数式を変更します。
VisualEditor - editing existing mathematical formula.png

数式はインラインもしくは中央寄せに配置できます。
VisualEditor mathematic formula inline.png

楽譜の編集

ページに楽譜を追加するには、挿入する場所にカーソルを起きます。 次にツールバーの「挿入」メニューから「楽譜」のアイコンを押します。

既にある楽譜を編集するには、それを2回押します。

VisualEditor-Insert-Musical-Notation.png

すると「楽譜」ダイアログが開き、楽譜を「コード」 (ABC) もしくは「音符」 (Lilypond) のどちらかの形式で編集できます。 また既存の録音ファイルとのリンクは「オーディオ」もしくは「高等」(MIDI) の項目を選んでから手順に従います。 編集が終了したら、「完了」ボタンを押してダイアログを閉じ、変更を公開します。
Musical.png

詩その他の特殊な項目の編集

ビジュアルエディターでは、連想リストや詩など特殊なアイテムの編集はまだ部分的にしかサポートしていません。
VisualEditor editing poem 1.png

多くの場合、既存の項目は編集できるものの、新しい項目はビジュアルエディターに追加できません。

ビジュアルエディターのサポート態勢が完全に整うまでは、直接、wikitext ソースを編集したり、ほかの記事からコピーしたりしましょう。

VisualEditor editing poem 2.png

エディターの切り替え―ビジュアルとwikitext

ビジュアルエディターからウィキテキストエディターに切り替えるには、ツールバーの右端にある[[ ]]のアイコンを押します。

VisualEditor toolbar Page options - Switch to wikitext - Save.png

差分が表示されます。(直前に「変更を破棄」を押した場合はウィキテキストのみ表示されるので、ウィキテキストエディターで編集をします。)

画面をスクロールすると、下のほうにウィきテキストの編集領域があります。

VisualEditor bi-directional switching diff before wikitext.png

あるいはウィキテキストエディターからビジュアルエディターに切り替えができます。ツールバーの右端にある、鉛筆形のアイコンを押してください。

VisualEditor bi-directional switching pencil icon in wikitext.png

キーボード ショートカット

多くの編集者はウィキテキストを直接記入するのに慣れています。とりわけ、太字、斜体、ウィキリンクなど。 キーボードショートカットを使えば、ツールバーをクリックしなくても、同様な書式追加を迅速に行うことができます。ビジュアルエディターでも機能するショートカットがあります。

PC ショートカット 操作 Mac ショートカット

Ctrl+B 太字 ⌘ Cmd+B

Ctrl+I 斜体 ⌘ Cmd+I

Ctrl+K リンクを挿入 ⌘ Cmd+K

Ctrl+X 切り取り ⌘ Cmd+X

Ctrl+C コピー ⌘ Cmd+C

Ctrl+V 貼り付け ⌘ Cmd+V

Ctrl+Z 元に戻す ⌘ Cmd+Z