Ohje:Visuaalinen muokkain/Käyttöopas

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/User guide and the translation is 47% complete.
Outdated translations are marked like this.
PD Huomautus: Muokkaamalla tätä sivua hyväksyt, että tuottamasi sisältö julkaistaan CC0 -lisenssillä. Katso lisätietoja Public Domain -ohjesivulta.
PD


Visuaalisen muokkaimen avaaminen

Muokataksesi sivua visuaalisella muokkaimella klikkaa sivun yläosassa olevaa Muokkaa-välilehteä.

Sivun avautuminen muokkaustilaan saattaa kestää muutaman sekunnin tai pidempäänkin, jos sivu on erittäin pitkä.

Klikkaamalla Muokkaa wikitekstiä -välilehteä sivu avautuu perinteisessä wikitekstin muokkausnäkymässä.

VisualEditor edit tab-fi.png

Voit avata visuaalisen muokkaimen myös klikkaamalla muokkaa-linkkiä jonkin osion otsikon vieressä.
VisualEditor - Section edit links-fi.png

Aloittaminen: visuaalisen muokkaimen työkalurivi

Näyttökuva visuaalisen muokkaimen työkalurivistä
Visuaalisen muokkaimen työkalurivi näkyy sivun yläosassa, kun aloitat muokkaamisen. Se sisältää joitakin tuttuja symboleja:

VisualEditor - Toolbar - Undo-redo.png
Kumoa ja Tee uudelleen suorittamiasi muutoksia.

VisualEditor Toolbar Headings-fi.png
Otsikot-pudotusvalikko: voit valita kappaleelle tyylin. Muuta tyyliä napsauttamalla hiiren osoitin kappaleeseen (sinun ei tarvitse korostaa tekstiä) ja valitsemalla tyyli listasta. Osioiden otsikot ovat muodoltaan "Otsikko", ja alaosiot "Alaotsikko 1", "Alaotsikko 2" ja niin edelleen. Normaalifontti tekstille on "Kappale".

VisualEditor Toolbar Formatting-fi.png

Muotoilu: Valikko avautuu painamalla "A"-painiketta.

  • "Lihavointi" (L) lihavoi valitun tekstin.
  • "Kursivointi" (K) kursivoi valitun tekstin.
  • "Yläindeksi" (x2) muuttaa valitun tekstin sitä ympäröivää tekstiä pienemmäksi ja siirtää sen hieman korkeammalle.
  • "Alaindeksi" (x2) muuttaa valitun tekstin sitä ympäröivää tekstiä pienemmäksi ja siirtää sen hieman alemmaksi.
  • "Yliviivaus" (Y) yliviivaa valitun tekstin.
  • "Tietokonekoodi" (kaarisulut: {}) muuttaa valitun tekstin fontin kiinteäväliseksi fontiksi, joka saa sen erottumaan ympärillä olevasta tekstistä.
  • "Alleviivaus" (A) lisää yhtenäisen viivan valitun tekstin alapuolelle.
  • "Kieli"-toiminnolla (文A) voi määrittää valitulle tekstille kielen (esim. japani) ja suunnan (esim. oikealta vasemmalle).
  • Viimeinen toiminto "VisualEditor MediaWiki theme clear icon bitmap.png Poista" poistaa kaikki merkkimuotoilut valitusta tekstistä, myös linkit.

Jos et ole valinnut mitään tekstiä ja avaat valikon "A"-painikkeesta, tulee sieltä valitsemasi tyyli automaattisesti tekstiin, jota alat kirjoittaa.


VisualEditor - Toolbar - Linking.png
Linkitystyökalu: Ketjukuvake on linkitystyökalu. Sitä painamalla (yleesä tekstin valinnan jälkeen) avautuu linkki-ikkuna.

VisualEditor - Cite Pulldown.png
Viite-valikko: "Viite"-valikkoa käytetään lähdeviittausten lisäämiseen. Kaikissa projekteissa on mahdollisuus hyödyntää yksinkertaista lähdemuotoilua sekä käyttää viitteitä uudelleen tämän valikon avulla. Se antaa käyttäjille myös nopean pääsyn paikallisiin viitemallineisiin, jos ne ovat kyseisessä wikissä käytössä.

(Ohjeet paikallisten viittausmallineiden lisäämiseksi Viite-valikkoon tietyssä wikissä löytyvät sivulta Visuaalinen muokkain/Viittaustyökalu .)


VisualEditor citoid Cite button-fi.png
Viittaa-painike: Jos wikissäsi on otettu käyttöön citoid-palvelu, näet Viite-valikon sijaan Viittaa-painikkeen.

Citoid-palvelu yrittää täyttää viitemallineet automaattisesti.


VisualEditor Toolbar Lists and indentation-fi.png
Listat ja sisennys: kaksi ensimmäistä kohdetta mahdollistavat tekstin muotoilun joko "Luettelo"- tai "Numeroitu luettelo" -muotoon. Kahden viimeisen kohteen avulla voit vähentää tai lisätä luettelokohteiden sisennystasoa.

VisualEditor Insert Menu-fi.png
Lisää: "Lisää"-valikko voi olla erilainen joissakin projekteissa. Alla on lista kaikista vaihtoehdoista, joita siinä saattaa olla.
  • "Kuvat ja media"-kuvake (kuva vuorista) avaa media-ikkunan.
  • "Malline"-kuvake (palapelin pala) mahdollistaa mallineiden muokkaamisen.
  • "Taulukko"-kohteella voi lisätä taulukon.
  • Kommentti-kohde (puhekupla) mahdollistaa kommentit, jotka eivät näy lukijoille; nämä kommentit voi nähdä vain muokkaustilassa, jossa ne on merkitty huutomerkillä. Kommenttia voi muokata tai sen voi poistaa painamalla muokkaustilassa huutomerkkiä.
  • "Hieroglyfit"-kuvake (ankh-symboli - ☥) avaa hieroglyfin lisäämistyökalun. (Katso alla.)
  • "Koodipätkä"-kohteella voi lisätä koodia.
  • "Musiikkinuotti"-kohteella voi lisätä nuotteja.
  • "Galleria"-kuvakkeella (kuvasarja) voi lisätä sivulle gallerian.
  • "Matemaattinen kaava"-kuvake (Σ) avaa kaavamuokkaimen.
  • "Kaavio"-kohteella voi lisätä kaavion.
  • "Allekirjoituksesi"-kohteella voit lisätä sen allekirjoituksesi, joka sinulla on kyseisessä projektissa. Se on harmaana (ei valittavissa), kun muokkaat sellaista sivutyyppiä (”nimiavaruus”), missä allekirjoituksia ei pitäisi lisätä.
  • "Lähdeluettelo"-kuvake (kolme kirjaa) avaa ikkunan, jossa voit määritellä, missä kohtaa lähteet näytetään lukijalle. Yleensä tämän tarvitsee tehdä sivulla vain kerran.

Erikoismerkin lisääminen: "Erikoismerkit" (Ω) -kuvake on "Lisää" -valikon vieressä. Siitä avautuvassa ikkunassa on paljon erikoismerkkejä, joita voit lisätä tekstiin merkkiä klikkaamalla. Tarjolla on muun muassa joitain vakiosymboleja, tarkkeita ja matemaattisia symboleja. (Tätä listaa on mahdollista muokata paikallisesti. Katso ohjeet sivulta Visuaalinen muokkain/Erikoismerkit .)
VisualEditor Toolbar SpecialCharacters-fi.png

VisualEditor toolbar edit notices icon.png
Painike muokkausilmoitukset näyttää sivun mahdolliset ilmoitukset.

VisualEditor More Settings-fi.png
Sivun valinnat -valikko on painikkeiden Julkaise muutokset ja Vaihda muokkainta vasemmalla puolella. Valikkolistan valinnat-vaihtoehdosta avautuu valintaikkuna, jossa on seuraavat (vasemmalla olevat) välilehdet:
  • Luokat mahdollistaa luokkien lisääminen kyseiselle sivulle, ja lisäksi sen avulla voi määritellä miten sivu järjestyy luokan sisällä.
  • Sivun asetukset-valikon avulla sivusta voi tehdä ohjauksen ja asettaa sille ominaisuuksia, muuttaa sisällysluettelon asetuksia, estää osioiden muokkaamisen tai tehdä sivusta täsmennyssivun.
  • Lisäasetukset-kohdasta voi muuttaa sivun indeksoimista hakukoneissa, uuden osion lisäyslinkin asetuksia ja sivun näkyvää otsikkoa.
  • Kielet näyttää listan sivuun linkitetyistä muunkielisistä sivuista.
  • Käytetyt mallineet näyttää linkkilistan mallineista, joita sivulla on käytössä.

Valinnat-kohdan välilehdet näkyvät myös Sivun valinnat-listassa, ja ne voi avata klikkaamalla. Lisäksi Sivun valinnat-valikossa on painike Näytä oikealta vasemmalle sekä Etsi ja korvaa, josta avautuvassa ikkunassa voit erilaisin asetuksin hakea merkkejä, termejä tai säännöllisiä lausekkeita, joita voit korvata.


VisualEditor bi-directional switching square brackets icon.png
Wikitekstin muokkaustila-painike on Julkaise muutokset-painikkeen vieressä. Sen avulla voit vaihtaa wikitekstin muokkaimeen.

Muokkausten julkaiseminen

Kun olet tehnyt muokkauksesi, klikkaa työkalurivillä olevaa sinistä "Julkaise muutokset" -painiketta. Painiketta ei voi klikata, jos muutoksia ei ole tehty (painike on harmaa). Peruuttaaksesi kaikki tekemäsi muutokset, sulje selainikkunasi tai paina muokkausvalikon yllä olevaa ”Lue”-välilehteä.
VisualEditor toolbar actions-fi.png

Painamalla sinistä "Julkaise muutokset" -painiketta avautuu pieni ikkuna. Siihen voit kirjoittaa lyhyen kuvauksen tekemistäsi muutoksista, merkitä muokkauksesi pieneksi ja/tai lisätä sivun tarkkailulistallesi. Yhteenveto:-laatikko on vastaava kuin Yhteenveto:-tekstikenttä wikiteksti-muokkaimessa.

Ennen tallentamista voit myös tarkistaa muutoksesi käyttämällä "Tarkista muutoksesi" -painiketta varmistaaksesi, että muutokset olivat sellaisia kuin piti. Tämä on samantapainen kuin "Näytä muutokset" -painike wikiteksti-muokkaimessa.

X-painike palauttaa sinut sivulle, jota olit muokkaamassa. Voit julkaista kaikki muokkauksesi myöhemmin.

VisualEditor save dialog-fi.png

Linkkien muokkaaminen

VisualEditor - Toolbar - Linking.png
Linkkejä voi lisätä työkalurivillä olevalla "Linkki"-kuvakkeella (ketju) tai käyttämällä pikanäppäintä Ctrl+K (tai ⌘ Command+K Macissa).

Jos valitset (maalaat) tekstiä ja painat sitten ”Linkki”-painiketta, käytetään tätä tekstiä linkin luomisessa. Jos linkissä on vain yksi sana, voit joko valita sanan tai laittaa osoittimen sanan sisälle.


VisualEditor-link tool-search results-fi.png
Painikkeesta tai oikotietä käyttämällä avautuu ikkuna, johon voit kirjoittaa linkin.

Linkkityökalu yrittää auttaa sisäisten linkkien lisäämisessä hakemalla todennäköisiä vastaavuuksia. Kun olet kirjoittanut tai valinnut linkin, viimeistele linkittämisprosessi painamalla ↵ Enter tai napsauttamalla "Valmis"-painiketta. Linkkisi ilmestyy välittömästi sivulle, mutta kuten muutkin muutokset, sitä ei julkaista ennen kuin julkaiset koko sivun.


VisualEditor-link tool-external link.png
Muun verkkosivuston sivulle linkittämisessä prosessi on samanlainen: Valitse "Ulkoinen sivusto"-välilehti ja kirjoita URL-osoite ruutuun.

VisualEditor link tool simple link.png
Ulkoiset linkit ilman selitettä näyttävät tältä: [1]. Voit lisätä niitä sijoittamalla kursorisi sanojen ulkopuolelle (esim. välilyönnin jälkeen). Avaa linkkityökalu painamalla painiketta tai pikanäppäimiä. Kirjoita URL-osoite laatikkoon ja paina ”Valmis”-painiketta lisätäksesi linkin.

VisualEditor-context menu-link tool.png
Kun haluat muuttaa tai poistaa olemassa olevan linkin, klikkaa linkin tekstiä, jolloin sen lähelle ilmestyy "Linkki"-valintaikkuna. (Pääset valintaikkunaan myös Ctrl+K -näppäinyhdistelmällä.) Kun linkki on valittu, se näkyy sinisellä taustalla.

Linkin muokkaus -valintaikkunassa voit muuttaa sitä, mihin linkki vie. Voit myös poistaa linkin kokonaan painamalla oikeassa yläkulmassa olevaa punaista "Poista"-painiketta (renkaat, joiden yli menee viiva). Voit myös avata linkin kohteen toisessa ikkunassa painamalla valintaikkunassa näkyvää linkin kopiota. (Voit haluta tehdä tämän tarkistaaksesi onko ulkoinen linkki kelvollinen.)

If you want to exit the link label (the text displayed as a link) or continue to write after this link, you can press :

  • Pressing it once will escape the link editing dialog and put your cursor at the end of the element linked (blue framed, to edit this element)
  • Pressing it twice will put the cursor after the element linked, ready to type the rest of your text.

To edit the link label of an existing link, press within the link label and type the new one. But if you want to replace the entire label, please note:

  • If you have selected (highlighted) the entire link label, the link will be deleted by typing any key. You may link it from start.
  • To keep the link directly, you may press within that link label, use backspace and delete key without pressing it once more than necessary, and a narrow blue link area will remain there. Now you may type in the new label for the kept link.
  • You can also link to categories, files and more.

Lähteiden muokkaaminen

For further information, see Ohjeita viitemallineiden käyttämiseen tai Ohjeita citoidin Viittaa-painikkeen käyttämiseen

Determining which system is in place

Your wiki may use one of three footnote systems. The one shown on the right is the simplest system, where the "Viite" menu does not include any citation templates. Jos wikisi käyttää tätä systeemiä, kaikki tarvitsemasi tieto lähdeviitteistä on tällä sivulla.
VisualEditor cite menu default.png

Toisessa systeemissä on samanlainen "Viite"-valikko, mutta siinä on useita paljon käytettyjä vittemallineita, joita on nopea siitä käyttää. Jos wikisi käyttää tätä systeemiä, löydät lisätietoa sivulta Help:VisualEditor/User guide/Citations-Templates
VisualEditor references more-fi.png

VisualEditor citoid Cite button-fi.png
In the third system, you again start by pressing the Cite button. Then a dialog box opens, which includes an automatic citation process using the citoid service. If your wiki uses this system, you will find more details at Help:VisualEditor/User guide/Citations-Full
VisualEditor Citoid Inspector-fi.png

Jo löytyvän lähteen muokkaaminen

To edit an existing reference, press on it where it appears in the text (usually as a bracketed number). You will see either a "Lähde" icon (bookmark) or an icon (and name) for the template that was used to create this reference. In either case, pressing on the "Edit" button will open a dialog where you can edit the reference.
VisualEditor - Editing references 1-fi.png

For the "Lähde" icon, pressing "Edit" opens the Reference dialog. To start changing the reference information, press on it.

Monet wikit käyttävät mallineita lähteiden muotoilemiseen. Jos lähteessäsi käytetään mallinetta, sitten kaikki mallineen tekstit korostetaan napsauttaessasi lähteen tietoja.

If a template was used and you press on the reference information, then the Malline icon (puzzle piece) will appear with some information. Press on the "edit" button to edit the content of the template in the template mini-editor dialog.

VisualEditor - Editing references 6-fi.png

If what appears when you press on a reference is an icon for a standard template for citations (an example is at right), then pressing "Edit" will open the template mini-editor dialog.
VisualEditor - Editing References - Cite Web.png

Inside the template mini-editor, you can add or remove types of information or change current content. Only fields (template parameters) that have content will show, initially. To add fields, press on "Lisää enemmän tietoa" at the bottom of the mini-editor.
VisualEditor - Editing references 5-fi.png

Kun olet valmis, paina "Hyväksy muutokset".
VisualEditor Apply Changes-fi.png

Jo löytyvän lähteen uudelleenkäyttäminen

If the page already contains a citation that applies to the text you want to source, then you can choose to re-use that existing citation.

Uudelleenkäyttääksesi jo olemassaolevaa lähdettä, laita kursorisi sinne, johon haluat lisätä lähteen tekstissä, ja napsauta "⧼visualeditor-dialogbutton-reference-tooltip⧽"-kuvaketta (kirjanmerkki) "Insert"-valikossa.

(Note: If your wiki has the third footnote system described above, you'll see a "Re-use" tab, in a dialog, instead of a "Re-use" item on the "Viite" menu.)

VisualEditor Cite menu re-use.png

Jos sivu sisältää useita lähteitä, voit käyttää hakupalkkia (otsikoitu "Lähde") nähdäksesi vain lähteet, jotka vastaavat annetun tekstin kanssa.
VisualEditor - Editing references 18-fi.png

Uuden lähteen lisääminen

Lisätäksesi uuden lähteen, laita kursori sinne minne haluat sen lisätä tekstiin, ja napsauta työkaluriviltä "Insert"-painikkeesta aukeavaa "⧼visualeditor-dialogbutton-reference-tooltip⧽"-kuvaketta (kirjanmerkki).
VisualEditor references more-fi.png

"Perus"-viitteen käyttäminen

Shown here is what you will see if you select the basic references item. Lähdemuokkaimessa voit lisätä viitteen sekä muotoilla sitä.

Voit valita lähteen kuulumaan tiettyyn ryhmään, vaikka normaalisti tämä jätetään tyhjäksi. (Tätä vaihtoehtoa käytetään lähderyhmien näyttämiseksi "Lähdeluettelo"-työkalulla.)

VisualEditor - Editing references 20-fi.png

Jos olet lisäämässä uutta lähdettä ja haluat lisätä sen mallineella, napsauta työkaluvalikossa olevaa "Insert"-painiketta, ja valitse sieltä "Malline"-kuvake (palapelin pala).
VisualEditor Template Insert Menu-fi.png

Sitten etsi malline, jota haluat käyttää, lisää se ja muokkaa sitä kuten tekisit jo sivulla olevalle mallineelle.

Kun olet saanut uuden mallineen muokkaamisen tehtyä, paina "Hyväksy muutokset" palataksesi viitemuokkaimeen, ja "Hyväksy muutokset" uudelleen palataksesi sivulle, jota olet muokkaamassa.

VisualEditor - Editing references 9-fi.png

Jos sivulla ei ole vielä luetteloa lähteistä (esimerkiksi jos olet lisäämässä sivulle ensimmäistä lähdettä), sinun täytyy lisätä se, jotta lähteeseen lisäämäsi teksti näkyy sivulla.

Laita kursori sinne missä haluat näyttää lähdeluettelon (yleensä sivun alaosassa), avaa "Lisää"-valikko ja paina kuvaketta "Lähdeluettelo" (kolme kirjaa).

VisualEditor References List Insert Menu-fi.png

Jos loit ryhmän lähteitä, voit määrittää ryhmän tässä valintaikkunassa, näyttäen valikoivasti lähteet jotka kuuluvat siihen.

The final step in the References list dialog is to press "Lisää".

VisualEditor references list-fi.png

Vakioviitemallineiden käyttäminen

Your local wiki may have added extra citation templates to the "Viite" menu. If so, you have quick access to the most-used citation templates for your wiki. (Instructions for adding extra citation templates to your local wiki are available at Visuaalinen muokkain/Viittaustyökalu .)
VisualEditor - Editing References - Cite Pulldown.png

Pressing on a template icon such as "Cite book" will take you into the template mini-editor for that template. Important information fields may be marked with an asterisk. While the most common fields will be shown, not all of them are required.
VisualEditor - Editing references - Cite book required fields.png

To add more parameters, scroll down in the template mini-editor and press on the "Lisää enemmän tietoa" option.

Kun olet valmis, paina "Lisää".

VisualEditor - Editing references - Add parameter.png

Kuvien ja muiden mediatiedostojen muokkaaminen

Kuvien muokkaaminen

Lisätäksesi uuden kuvan (tai muuntyyppisen mediatiedoston) sivulle, napsauta avattavasta "Lisää"-valikosta aukeavaa "Kuvat ja media"-kuvaketta (kuva vuorista). Kuva lisätään sinne missä kursori on.
VisualEditor Media Insert Menu-fi.png

Napsauttamalla "Kuvat ja media"-kuvaketta aukeaa valintaikkuna, joka etsii automaattisesti Wikimedia Commonsista ja paikallisesta wikistäsi mediatiedostoja, jotka liittyvät sivun otsikkoon, jota olet muokkaamassa.

Voit vaihtaa hakua vaihtamalla valintaikkunassa olevan hakulaatikon tekstiä.

Valitaksesi tiedoston, napsauta sen pienoiskuvaa.

Tämä asettaa kuvan sivulle, jota olet muokkaamassa.

VisualEditor - Media editing 2.png

Media-valintaikkunan avulla voit lisätä (ja muokata) kuvatekstiä, joka voi sisältää muotoilua ja linkkejä.
VisualEditor - Media editing 6-fi.png

Media-valintaikkunassa voit myös lisätä vaihtoehtoisen kuvatekstin, joka auttaa käyttäjiä, jotka käyttävät näytönlukijoita, tai joilla on kuvat estettynä.
VisualEditor - Media editing 7.png

Voit myös asettaa eri parametreja kuvalle "Lisäasetukset"-ikkunassa. Näihin sisältyvät sijainti, tyyppi sekä kuvan koko.
VisualEditor - Media editing 8-fi.png

Kun olet valmis, napsauta "Hyväksy muutokset" sulkeaksesi valintaikkunan ja palataksesi sivun muokkaustilaan.
VisualEditor Apply Changes-fi.png

For an existing image, you can add or edit a caption or other settings by pressing on the image, then pressing on the "Kuvat ja media" icon that appears below the picture.

You can resize an existing image by pressing on it, then moving the resize icon (the two-headed arrow on one or both bottom corners).

Voit myös vetää ja pudottaa kuvan haluamallesi paikalle sivulla.

VisualEditor - Media editing 3.png

Uploading images

You can upload images from a tab in the media dialog, or by dragging and dropping a file into the editor, or by pasting an image from your clipboard.
VisualEditor - Media upload 1.png

Press the "Upload" tab and select an image from your computer. You can type the file name, or drag an image into the box. If you dragged and dropped an image directly into the editor, or pasted one from your clipboard, this tab will open automatically.
VisualEditor - Media upload 1.5.png

You need to describe the image and add categories to it so that other people can find it.
VisualEditor - Media upload 2.png

The image will be inserted into the page when you are done.
VisualEditor-logo.svg

Gallerioiden muokkaaminen

Lisätäksesi uuden gallerian, napsauta "Galleria"-kuvaketta (kuvasarja).
VisualEditor - Gallery1-fi.png

Muokataksesi jo löytyvää galleriaa Visuaalisella muokkaimella, napsauta galleriaa, jotta galleria-kuvake tulee näkyviin oikeaan yläkulmaan. Napsauttamalla kuvaketta pääset galleria-asetinlaatikkoon, joka sisältää täyden listan kuvista, jotka galleriassa ovat.
VisualEditor - Gallery2.png
Galleria-asetin on tällä hetkellä yksinkertainen laatikko, jonka avulla voit muokata jo löytyviä kuvia ja mediagallerioita käyttäen wikiteksti-merkintätapaa. Lisätäksesi uusia kuvia galleriaan, anna tiedoston nimi, pystyviiva (|) sekä kuvateksti, jonka haluat kuvalle. Jokaisella galleriassa olevalla kuvalla pitäisi olla oma rivinsä. You can also edit this list to remove or rearrange images or to change captions.

When you press the "Valmis" button, you will exit the gallery editor. You should then see your changes, with the gallery as it will now appear to readers.

Remember that exiting the gallery editor does not publish your changes. As with other changes made using the visual editor, you must publish the entire page in order to publish your work.

VisualEditor - Gallery3.png

Mallineiden muokkaaminen

The powerful MediaWiki template system lets you insert dynamic content, text from other pages, and much more. For a detailed explanation and examples, see the Templates help page.

In the VisualEditor you can search for a relevant template, add an invocation or transclusion on the page you’re editing and, if needed, add custom content using parameters.

Insert new template

Lisätäksesi uuden mallineen sivulle, aseta kursori sinne, johon haluat mallineen tulevan, ja napsauta työkaluvalikossa olevasta "$insert"-painikkeesta aukeavaa "$template"-kuvaketta (palapelin pala). Then open the Lisää menu and select "OOjs UI icon puzzle-ltr.svg Malline". Alternatively, type two curly brackets {{ to open the same dialog.
VisualEditor Template Insert Menu-fi.png
Find the template you want to insert by typing either its name or a relevant keyword. Results containing the search term in either the name or description will display in a dropdown. This should help you find a relevant template, even if you don’t know its exact name.

If you’re having trouble finding the kind of template you want by using keywords, you can look on other wiki pages with similar content and view or edit the page source to see which templates are in use. When you find the desired template’s name, you can type it into this field to insert it here.

Screenshot of the template search field in the Visual Editor

You can also edit a template that’s already on a page. When you select the template you want to edit, it turns blue, and a box appears displaying "OOjs UI icon puzzle-ltr.svg Malline". Then select the "Muokkaa" link or double click on the template itself to open the template.
Screenshot of the VisualEditor interface with a template selected

Some templates are not visible to someone reading a page. In the visual editor, such hidden templates are still shown so that you can click and edit or delete them. The name of the template will be shown next to the puzzle icon and both will be grayed out.
Screenshot of hidden templates in the Visual Editor interface

Mallineen parametrit

You’ll see this dialog box when you’re adding a new template or editing one already in place. What you see in the box depends on whether the template in question contains TemplateData , helpful metadata added by other editors to make it easier to edit templates in the Visual Editor.

When a template contains TemplateData, the VisualEditor can use it to present annotated fields for you to fill in.


For templates that have some community-provided TemplateData, the VisualEditor displays a list of the named parameters and, often, descriptions and instructions explaining the meaning and required format for each parameter’s values.

Screenshot of template parameters in the Visual Editor interface
Template parameters in the Visual Editor interface

You can disable any optional parameter (which have blue checkboxes on the left side). If a parameter’s checkbox is grayed out and not clickable, the template requires that parameter, so it can’t be disabled.

When you insert a new template, you may find that some optional parameters are pre-selected. That means the author(s) of the template recommends the use of those parameters. It’s best to review all parameters that will be used in a template to ensure you understand their use.

Clicking an unchecked parameter adds it to the template. Clicking a parameter that’s already been added takes you to the parameter’s input field.

Some template parameters will show as “deprecated”. Don’t use deprecated parameters when inserting a template; they’re only visible to you because those parameters are in use on older pages where this template was included.

Screenshot of template parameters in the Visual Editor interface
Interface for adding more parameters to a template in the VisualEditor

Adding undocumented parameters

If you’re inserting or editing a template whose author hasn’t laid out its parameters in TemplateData, it has what we call “undocumented” or “unnamed parameters”. In these cases, you should consult the page for the template itself. There you can learn how to correctly employ and work with all of the template’s parameters. This includes learning the exact names of the parameters as written by the template author.

If you find in the documentation that the template expects parameters without have names, fill in numbers as placeholders for the parameter names using the undocumented parameter input, then add next to the values you want to provide as you normally would.

Example:

  • first unnamed parameter: “1”
  • first unnamed parameter’s value: “en_US”
  • second unnamed parameter: “2”
  • second unnamed parameter’s value: “yes”

If you accidentally include nonexistent, misspelled or erroneous parameters, the values you enter for those parameters won’t show up on the page you’re editing.

Screenshot of a template missing TemplateData
Template without TemplateData in the Visual Editor

Autogenerated parameters

In this example, the template in question lacks TemplateData but it was possible to autogenerate the parameters. This means that the undocumented parameters have already been added for you, but the names may not be easily understandable and the dialog cannot display any directions or descriptions. As a result the dialog box provides a link to the template’s documentation, which should help you deduce and fill in the template’s various parameters.
Autogenerated parameters in the VisualEditor.png

Editing multi-part template content

During editing, you may open template content consisting of multiple templates or a single template linked to some wikitext. This differs from the nested templates described below. In this case, the templates are better visualized as being stacked or connected.

This content often contains “unbalanced templates,” templates which are incomplete on their own and need to be paired with some wikitext or another template in order to function.

These related pieces of template content must be created in wikitext, but can be edited in the VisualEditor. In these cases you will see a notice at the top of the dialog to signal the situation and a specialized toolbar will be visible at the bottom of the sidebar. There you can use the icon buttons to add additional templates, additional wikitext, delete elements or change their order.

Screenshot of the interface to edit multi-part template content in the VisualEditor
Editing multi-part template content in the VisualEditor

Nested templates

Templates can include other templates as the value for parameters. You’ll recognize it when you see a parameter whose value contains the double curly braces ( {{ }} ) denoting a template.

The VisualEditor can’t present this template within a template (a nested template) using the editor’s easy-to-use interface, so if you want to nest a template yourself, you’ll need to understand how to add the template by hand in wikitext into the appropriate parameter field.

Screenshot of the VisualEditor template interface showing an embedded template
Embedded template in the VisualEditor

Completing your edit

When you have finished editing a template, you can click "Hyväksy muutokset". Then you can preview your edit and make sure it looks the way you want and expect.

You may also see an error message, which (like the other TemplateData mentioned above) is community-provided content and may vary in usefulness. You may need to consult the template’s own documentation to get to the bottom of some errors. If you’re still having trouble, consider posting about your problem on the template’s talk page.

VisualEditor Apply Changes-fi.png

Removing a template

To remove a template in the VisualEditor, click the template box. Press the "Delete" or "Backspace" key on your keyboard. The template will disappear from the page.
Screenshot of the button to remove a template
Removing a template in the VisualEditor

Editing on mobile

When editing a template on a page using the VisualEditor on a mobile device, you’ll see that the sidebar starts out hidden. You can make it visible by pressing the “Show/hide options” button.
Screenshot of editing a template on a mobile device
Editing a template on mobile in the VisualEditor

Mallineiden substaaminen

When you insert a template in a wiki page, its content and appearance are reevaluated every time the page loads, based on the template code and the values of its parameters. This means if someone updates the code of a template, then every page which uses that template will also get updated when they publish.

There’s another, much less common way to use templates, though, and that’s to substitute a template. Doing this permanently includes the template content just as it appears at the moment you insert it. It will not update if the template code is later changed.

Most users won’t ever need to resort to substitution. Substitution is typically only useful when you need to capture the exact appearance of one version of a template, such as when content is under development and needs evaluation.

To substitute a template in the VisualEditor, insert a template using the name syntax subst:<template name>. (Autocomplete doesn’t work in this case.) Then press the blue “Add template” button.

When you’re finished, press “Insert”, which will insert the template content as you see it.

Screenshot of editor using SUBST to add a template
Adding a template using SUBST in the VisualEditor

Listojen muokkaaminen

VisualEditor Toolbar Lists and indentation-fi.png
You can use the visual editor to create lists, or to change the format of an existing list. There are two types of lists: unordered (bullet) and ordered (numbered).

To start a new list, just press on one of the two menu items shown here. Or, if you already have typed the list (on separate lines), select (highlight) the list you have typed, then press on one of the menu items.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Shown here are examples of the two types of lists: unordered (bullet) and ordered (numbered).

VisualEditor lists 3 select to indent.png
If you want to change the indentation level of part of an existing list, select the part of the list that you want to change.

VisualEditor lists 4 indentation menu.png
Then use the menu, or press the Tab key. (The Tab key increases indentation; use the shift key plus the Tab key to decrease indentation)

VisualEditor lists after indenting.png
Here is the result of increased indentation.

VisualEditor lists mixed.png
You can even mix ordered (numbered) and unordered (bullet) lists, if the list items have different indentations.

Taulukoiden muokkaaminen

VisualEditor insert table-fi.png
Voit käyttää visuaalista muokkainta taulukoiden lisäämisen ja muokkaamiseen.

You can even import a table by dragging a comma-separated value (.csv) file from your computer into the main editing window.


When you press on "Table", in the "Lisää" menu, the visual editor inserts a blank four-by-four table.

Now the "Table" menu is available. From that menu, you can add a caption to the top of the table.

VisualEditor empty table.png

To select a cell, press it once.
VisualEditor tables select one cell.png

To edit the contents of the cell (for example, to add content or to correct a spelling error), double press in the cell. Or you can select the cell and then press Return.

To end your editing of a cell, just press elsewhere.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Voit lisätä, siirtää tai poistaa sarakkeen tai rivin.

You can merge cells: Select them, then from the Table menu, press on "Merge cells".
VisualEditor tables merge cells.png

If you merge cells, only the text in one cell is kept; any text in the other cells is deleted when you merge the cells. If you decide that you wanted some or all of the text that was deleted, use the Undo button, move or copy the text you want, then merge the cells again.
VisualEditor tables post-merge cell.png

You can also split cells that were previously merged. All the content that was in the merged cell will remain in the first cell when you do the split. You can then cut and paste text to other cells, if you want.
VisualEditor tables split cells.png

Luokkien muokkaaminen

VisualEditor category item-fi.png
Muokataksesi luokkia, paina "Sivun valinnat" -valikossa kohtaa "Luokat".

VisualEditor category editing-fi.png
"Luokat" -painike avaa uuden ikkunan, joka luetteloi sivulla olevat luokat, ja mahdollistaa sinun lisätä uusia tai poistaa jo lisättyjä luokkia.

Voit myös asettaa tai muuttaa yleistä (oletus) aakkostusavainta, joka määrittää, missä kohtaa luokkaa sivu näkyy, kun samassa luokassa on useita sivuja.

Esimerkiksi oletusaakkostus artikkelille "Kimi Räikkönen" on "Räikkönen, Kimi". Se näkyy luokassa "Suomalaiset Formula 1 -kuljettajat" kirjaimen "R" kohdalla, ei kirjaimen "K" kohdalla.


VisualEditor - Category editing 3.png
Lisätäksesi luokan sivulle, anna luokan nimi kenttään "Lisää luokka". Kirjoittaessasi visuaalinen muokkain etsii mahdollisia vastaavia, jo luotuja luokkia. Voit joko valita jo luodun luokan, tai lisätä luokan, jota ei ole vielä olemassa. (Siihen asti, kun luokkaa ei ole olemassa, luokkaan osoittava linkki näkyy punaisena julkaistuasi muutokset.)

VisualEditor - Category editing 2.png
Poistaaksesi sivulla jo valmiina olevan luokan, paina sitä, ja sen jälkeen paina aukeavassa valintaikkunassa olevaa "Poista"-kuvaketta (roskakori).

Voit myös määrittää siellä aakkostusavaimen tälle tietylle luokalle. Tällainen aakkostusavain korvaa oletuksena olevan aakkostusavaimen.


VisualEditor Apply Changes-fi.png
Suoritettuasi luokkien muokkaamisen, paina "Hyväksy muutokset" palataksesi sivun muokkaustilaan.

Sivun asetusten muokkaaminen

VisualEditor page settings item-fi.png
Muokataksesi sivun asetuksia, paina työkalurivillä olevaa "Sivun valinnat" -valikkoa ja valitse "Sivun asetukset" -painike.

VisualEditor Page Settings-fi.png
"Sivun asetukset" -painike avaa valikon, joka näyttää useita toimintoja.

VisualEditor Page Settings Redirects-fi.png
Voit tehdä sivusta ohjauksen toiselle sivulle valitsemalla "Ohjaa tämä sivu kohteeseen" -valinnan, ja sen jälkeen kirjoittamalla valintakenttään sivun, johon haluat lukijan menevän, kun hän yrittää mennä sivulle, jota olet muokkaamassa.

Alaosassa on valinta, jolla voit estää sivujen uudeelleennimeämisten päivittämästä tätä ohjausta. Tätä käytetään erittäin harvoin.


VisualEditor Page Settings TOC-fi.png
Voit valita näytetäänkö sivulla sisällysluettelo valitsemalla yhden näistä kolmesta painikkeesta. Oletuksena ("tarvittaessa") sivut näyttävät sisällysluettelon, jos sivulla on yli kolme otsikkoa.

VisualEditor Page Settings Edit Links-fi.png
Voit valita, ettei sivu näytä muokkauslinkkejä jokaisen alaotsikon kohdalla valitsemalla tämän valintaruudun.

VisualEditor Apply Changes-fi.png
Suoritettuasi sivun asetusten muokkaamisen, napsauta "Hyväksy muutokset" palataksesi sivun muokkaimeen.

Karttojen muokkaaminen

Visual editor showing editing an existing map.jpg
Voit lisätä ja muokata karttoja. Katso Help:VisualEditor/Maps .

Matemaattisen kaavan muokkaaminen

Lisätäksesi uuden matemaattisen kaavan sivulle, aseta kursori sinne, johon haluat sen tulevan, ja paina työkaluvalikossa olevasta "Lisää"-painikkeesta aukeavaa "Matemaattinen kaava"-kuvaketta ("Σ").
VisualEditor Formula Insert Menu-fi.png

Ikkuna aukeaa, johon voit kirjoittaa kaavan, käyttäen LaTeX-syntaksia. Visuaalinen muokkain päivittää kaavan sitä kirjoittaessasi, joten voit nähdä miltä se näyttää muutoksia tehdessäsi. Kun olet tyytyväinen kaavaan, paina "Lisää"-painiketta.
VisualEditor formula-fi.png

Muokataksesi sivulta jo löytyvää matemaattista kaavaa, paina sitä, ja sen jälkeen paina kuvaketta "Σ". Tämä avaa kaavamuokkaimen, jonne voit tehdä muutoksesi.
VisualEditor - editing existing mathematical formula.png

Mathematical formulae can be placed inline or centered as a block.
VisualEditor mathematic formula inline.png

Editing musical scores

To add a new musical notation to a page, place your cursor where you want the musical notation to be inserted. Then, from the "Insert" menu on the toolbar, press the "Musical notation" option.

To edit an existing musical notation on the page, double press on it.

VisualEditor-Insert-Musical-Notation.png

This will open the "Musical notation" dialog. Here the notation can be edited by scale, either in ABC or in Lilypond format. You can also link the notation to an audio or MIDI file. Once you are finished, press the "Done" button to close the dialog and publish your changes.
Musical.png

Runojen ja muiden erikoisten kohteiden muokkaaminen

Visuaalinen muokkain ei tue vielä kaikkia kohteita, kuten runoja ja musiikkinuotteja. Siihen asti voit halutessasi muokata ja lisätä näitä wikitekstitilassa.
VisualEditor editing poem 1.png

In most cases, the existing items can be edited, but new ones cannot be inserted in the visual editor.

Until they are fully supported, you can copy an existing one from another page, or edit the source wikitext directly.

VisualEditor editing poem 2.png

Switching between the visual and wikitext editors

To switch from the visual editor to the wikitext editor, press the [[ ]] button on the far right of the toolbar.

VisualEditor toolbar Page options - Switch to wikitext - Save.png

You'll see a diff. (If you pressed on "Discard changes", you'll just see wikitext, ready to edit with the wikitext editor.)

Scroll down, and you'll see the wikitext editing area.

VisualEditor bi-directional switching diff before wikitext.png

You can also switch from the wikitext editor to the visual editor. To do that, press the pencil icon on the far right of the toolbar.

VisualEditor bi-directional switching pencil icon in wikitext.png

Pikanäppäimet

Monet muokkaajat ovat tottuneet syöttämään wikitekstiä suoraan, erityisesti lihavoidakseen, kursivoidakseen ja lisätäkseen wikilinkkejä. Pikanäppäinten avulla voit nopeasti asettaa vastaavia muotoiluja, ilman että tarvitsee napsauttaa työkalurivin kohteita. Tässä ovat yleiset pikanäppäimet Visuaalisessa muokkaimessa:

PC:n pikanäppäin Toiminto Macin pikanäppäin

Ctrl+B Lihavointi ⌘ Cmd+B

Ctrl+I Kursivointi ⌘ Cmd+I

Ctrl+K Aseta linkki ⌘ Cmd+K

Ctrl+X Leikkaa ⌘ Cmd+X

Ctrl+C Kopioi ⌘ Cmd+C

Ctrl+V Liitä ⌘ Cmd+V

Ctrl+Z Kumoa ⌘ Cmd+Z