下載

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Download and the translation is 100% complete.

Other languages:
aragonés • ‎अङ्गिका • ‎العربية • ‎جهلسری بلوچی • ‎беларуская • ‎български • ‎বাংলা • ‎brezhoneg • ‎bosanski • ‎català • ‎کوردیی ناوەندی • ‎čeština • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Ελληνικά • ‎English • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎français • ‎galego • ‎עברית • ‎हिन्दी • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎मैथिली • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎नेपाली • ‎Nederlands • ‎occitan • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎русский • ‎Scots • ‎سنڌي • ‎සිංහල • ‎српски / srpski • ‎svenska • ‎தமிழ் • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎ئۇيغۇرچە / Uyghurche • ‎українська • ‎Tiếng Việt • ‎吴语 • ‎粵語 • ‎中文

最新版本

MediaWiki 之花
MediaWiki 簡介

授權條款

MediaWiki 是一套以GNU 通用共公授權條款第二版授權的自由軟體。由於 MediaWiki 授權免費使用,因此在適用法律允許的範圍內,不作任何保證。請閱讀 GNU GPL 第二版的全文來了解詳細資訊

系统需求

MediaWiki 需要使用 PHP5.5.9 以上版本與 MySQLManual:MySQL 5.0.2+、MariaDB 或另外三種資料庫。要取得更多資訊,請閱讀系統需求相容性頁面。

其他下載方式

改自 Git 下載

MediaWiki 開發人員應改自 Git 下載來取得最新版本的 MediaWiki 軟體。 Git 檔案庫中也有此軟體較先前的版本,因此切換 ("check out") 到您指定的發行版本。

注意

MediaWiki 1.24MediaWiki 1.24 開始已移除對 PHP register_globals 設定的支援。若您在您的伺服器上安裝的是 PHP 5.4 或之後的版本您不需要擔心此問題。若您是使用 PHP 5.3 或較早期的版本,就要確定已經把這個設定設為 (off)。若您無法在您的系統將 register_globals 關閉,您可以改使用 MediaWiki 1.23.9 (下載)

MediaWiki 1.19MediaWiki 1.19 起需要有 MySQL/MariaDB 5 – 若您是使用舊版的 MySQL 且無法升級,您可以改使用 MediaWiki 1.18.6 (下載)。注意,該版本已 不再提供任何支援

改用手動安裝

部份使用者可能偏好跳過手動安裝改使用已預先整合好的 MediaWiki 套裝軟體代管服務,部份 Linux 發行版(例 Debian, Ubuntu, Fedora, Gentoo) 的檔案庫有提供不同程度與擴充套件的 MediaWiki。

接下來要做什麼?

訂閱我們的發行公告郵遞清單

持續跟上最新發佈的版本來確保您的伺服器安全!

舊版

若您的 MediaWiki 的修改非常頻繁,可能會較難套用最新的官方變更/更新到 MediaWiki。為了要提供對這類使用者的支援,我們會對舊版本的程式碼至少一年的維護,對長期支援版本提供最多三年的維護。

開發版本

若您想使用最新的開發版本 (即 alpha 版),您可以下載 Nightlies自 Git 下載

自 Git 您可以選擇下載 "完整的檔案庫" (大約 528 MB)

git clone https://gerrit.wikimedia.org/r/p/mediawiki/core.git

或 "只下載最新的修訂" (大約 85MB,這通常又稱為 'shallow clone:較省時間、較小的下載)[1]

git clone --depth 1 https://gerrit.wikimedia.org/r/p/mediawiki/core.git

您也用您的瀏覽器來檢視最新的原始碼

舊的發行版

您可以在 MediaWiki 下載封存中找到所有的 MediaWiki 版本,最早自 2005 年三月 (MediaWiki 1.3.11) 到現在的 Tarball。

要瀏覽所有版本可請檢視 Git 檔案庫的 tags

安裝協助

參考文獻

  1. 但使用 "git pull" 來升級您的 shallow clone 可能會造成引用問題,新修訂引用了其他未下載至您系統的舊修訂檔案。在這種情況您只需要在稍後下載多一點 - 增加深度值 (Depth) - 或完整的修訂,或是重新下載 shallow clone 來解決這個問題。

參見