Downloaden

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of the page Download and the translation is 100% complete.

Other languages:
aragonés • ‎अङ्गिका • ‎العربية • ‎جهلسری بلوچی • ‎беларуская • ‎български • ‎বাংলা • ‎brezhoneg • ‎bosanski • ‎català • ‎کوردیی ناوەندی • ‎čeština • ‎dansk • ‎Deutsch • ‎Zazaki • ‎Ελληνικά • ‎English • ‎español • ‎eesti • ‎euskara • ‎فارسی • ‎suomi • ‎français • ‎galego • ‎עברית • ‎हिन्दी • ‎hrvatski • ‎magyar • ‎Հայերեն • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎ქართული • ‎ភាសាខ្មែរ • ‎ಕನ್ನಡ • ‎한국어 • ‎Lëtzebuergesch • ‎lietuvių • ‎मैथिली • ‎മലയാളം • ‎मराठी • ‎Bahasa Melayu • ‎नेपाली • ‎Nederlands • ‎occitan • ‎polski • ‎پښتو • ‎português • ‎português do Brasil • ‎русский • ‎Scots • ‎سنڌي • ‎සිංහල • ‎српски / srpski • ‎svenska • ‎தமிழ் • ‎ไทย • ‎Tagalog • ‎Türkçe • ‎татарча/tatarça • ‎ئۇيغۇرچە / Uyghurche • ‎українська • ‎Tiếng Việt • ‎吴语 • ‎粵語 • ‎中文

Laatste versie

MediaWiki Flower
Fundamental Introduction to MediaWiki

Licentie

MediaWiki is vrije software die gelicenseerd is onder versie 2 van de GNU General Public License. Omdat een licentie voor MediaWiki kosteloos is, is er geen garantie, voor zover dat wettelijk mogelijk is. Lees de volledige tekst van de GNU GPL versie 2 voor details.

Systeemeisen

MediaWiki vereist PHP 5.5.9+ en MySQLManual:MySQL 5.0.2+, MariaDB, of een van de andere drie mogelijke databasesystemen. Voor meer informatie kunt u de pagina's over systeemeisen en compatibiliteit raadplegen.

Andere downloads

Downloaden uit Git

Actieve ontwikkelaars van MediaWiki moeten de laatste versie van de MediaWikisoftware downloaden uit Git. De gitrepository bevat ook eerdere versie van de software, waardoor het mogelijk is om te schakelen naar een bepaalde versie.

Opmerkingen

  • Ondersteuning voor PHP 5 is vereist sinds MediaWiki 1.7. Als u nog PHP 4 gebruikt, werk dan zo snel mogelijk bij! PHP 4 wordt niet langer ondersteund door de PHP-groep en kent veel bugs en kwetsbaarheden. Veel gedeelde omgevingen bieden de mogelijkheid om PHP 4 en PHP 5 naast elkaar te draaien. Als u de versie niet kunt bijwerken, dan kunt u MediaWiki 1.6.12 (downloaden) gebruiken. Let op: deze versie wordt niet meer ondersteund.

MySQL/MariaDB 5 is vereist sinds MediaWiki 1.19MediaWiki 1.19. Als u een oudere versie van MySQL gebruikt en niet bij kunt werken, dan kunt u MediaWiki 1.18.6 (downloaden) gebruiken. Let op: deze versie wordt niet meer ondersteund.

Alternatieven voor handmatige installatie

Sommige gebruikers willen de handmatige installatie liver overslaan en kiezen voor een voorgeinstalleerde mediaWiki software-appliance. Installatiebronnen van Linux-distributies bieden ook steeds vaker installatiepakketten van MediaWiki aan, met verschillende updatefrequenties en wisselende ondersteuning voor extensies. (Bijv. Debian, Ubuntu, Fedora, Gentoo).

Hoe verder?

Abonneer u op de e-maillijst voor aankondigingen van nieuwe versies

Blijf bij met nieuwe versies en houd uw server veilig!

Oude versies

Als uw MediaWiki-installatie vergaand is aangepast, kan het moeilijk zijn om de nieuwste officiële wijzigingen / updates in uw MediaWiki-installatie te integreren. Om deze gebruikers tegemoet te komen, ondersteunen we oude branches van onze code tot een jaar vanaf een normale release en tot drie jaar vanaf een long-term-support-release.

Ontwikkelversies

Als u de laatste ontwikkelversie (alpha) wilt draaien, dan kunt u de Nightlies downloaden, of uit Git downloaden.

U kunt uit Git de complete repository downloaden (ongeveer 528 MB)

git clone https://gerrit.wikimedia.org/r/p/mediawiki/core.git

of alleen de laatste versie (ongeveer 85 MB; dit wordt vaak een oppervlakkige kloon (shallow clone) genoemd: minder tijdrovend en kleinere downloads).[1]

git clone --depth 1 https://gerrit.wikimedia.org/r/p/mediawiki/core.git

U kunt ook de laatste broncode in uw browser bekijken.

Oude versies

Er zijn downloads beschikbaar (met de extensie *.tar.gz) voor alle versies van MediaWiki vanaf maart 2005 (de oudst beschikbare versie is MediaWiki 1.3.11) in de downloadarchieven van MediaWiki.

Voor nog oudere versies kunt u de tags van de Git repository raadplegen.

Hulp bij installatie

Referenties

  1. Dit kan referentie-conflicten veroorzaken als u later "git pull" gebruikt om uw "schaduwkopie" te updaten terwijl de nieuwere versie verwijst naar oudere versies die nog niet op uw systeem zijn gedownload. In zo'n geval kunt u simpelweg meer (verhoogt de volledigheid van uw gedeeltelijke kopie) of alle versies downloaden, of een nieuwe schaduwkopie maken.

Zie ook