Pobierz

From mediawiki.org
This page is a translated version of the page Download and the translation is 100% complete.

Najnowsza wersja

Pobierz MediaWiki 1.37.2 (.zip)

Pobierz zamiast .tar.gz

Pomoc z pobieraniem

Może być rozpakowany na większości systemów operacyjnych bez instalowania dodatkowego oprogramowania i jest ogólnie zalecane dla użytkowników Windowsa.

Jeśli używasz 7-Zip, zalecana jest aktualizacja do najnowszej wersji w celu dekompresji tarballa (pliku .tar.gz) z powodu buga z formatem PAX we wcześniejszych wersjach.

Użytkownicy macOS powinni zwrócić uwagę na to, że The Unarchiver ma buga, który uszkadza nazwy plików w tarballach. Zamiast tego można użyć Archive Utility.

Wszystkie wersje

Do użytkowników wersji MediaWiki 1.34 oraz wcześniejszych: Te wersje nie są już wspierane. Proszę zaktualizować do najnowszej wersji MediaWiki:

Licencja

MediaWiki jest darmowym oprogramowaniem z licencją GNU General Public License w wersji 2. Ponieważ MediaWiki jest licencjonowane bez opłat, nie ma gwarancji, w zakresie dozwolonym przez obowiązujące prawo. Przeczytaj pełny tekst GNU GPL version 2 dla szczegółów.

Wymagania systemowe

MediaWiki wymaga PHP 7.3.19/7.4.3+ oraz oprogramowanie bazy danych $mariadb, $mysql, SQLite lub PostgreSQL . Po więcej informacji przeczytaj wymagania systemowe i kompatybilność. For more information, please read the pages on system requirements and compatibility.

MediaWiki nie jest kompatybilne z PHP w wersjach od 7.3.0 - 7.3.18 oraz 7.4.0 - 7.4.2 w związku z błędem w oprogramowaniu przetwarzającym język PHP. Zamiast tego użyj PHP 7.3.19+ lub 7.4.3+. Zobacz zadanie T246594, aby uzyskać więcej informacji.
Uwaga Uwaga: MediaWiki nie jest jeszcze kompatybilne z PHP 8. Zobacz zadanie T248925, aby uzyskać więcej informacji.
Uwaga Uwaga: MediaWiki w wersji od 1.32 do 1.35.4, 1.36.2 i 1.37.0 zawiera problem w zabezpieczeniach, który pozwala na nieuprzywilejowane edytowanie dowolnej strony i wykonywanie dowolnych skryptów JavaScript. Jeśli używasz jednej z tych wersji i nie możesz zaktualizować do nowszej wersji, zobacz 2021-12 security release/FAQ , jak to rozwiązać.

Pobierz z Git

Aktywni twórcy MediaWiki powinni wybrać możliwość pobrania z repozytorium Git, aby otrzymać najnowszą wersję oprogramowania MediaWiki. Repozytorium Git ma wcześniejsze wersje oprogramowania, więc jest możliwe, żeby przełączać na ("sprawdzić") określone wydanie.

Podpisy plików do pobrania

Uwagi

Obsługa Microsoft SQL Server and Oracle Database, HHVM oraz PHP 7.0 i 7.1 została usunięta w MediaWiki 1.34 .

Alternatywy zamiast ręcznej instalacji

Niektórzy użytkownicy wolą pominąć ręczną instalację używając wbudowanego w MediaWiki oprogramowania lub usług hostingowych; repozytoria niektórych dystrybucji Linuxa coraz częściej oferują pakiety MediaWiki, z różnymi stopniami częstotliwości oraz dostępności rozszerzeń (np. Debian, Ubuntu, Fedora, Gentoo).

Co dalej?

Bądź na bieżąco z nowymi wydaniami i utrzymaj serwer bezpiecznie!

Poprzednie wersje

Jeśli Twoja instancja MediaWiki jest mocno zmodyfikowana możesz mieć trudność z aplikacją najnowszych zmian lub uaktualnień. Aby wspierać takich użytkowników utrzymujemy stare gałęzie kodu przez rok dla archiwalnych wersji i przez 3 lata dla archiwalnych wersji z długim wsparciem.

Wersje rozwojowe

Jeśli chcesz działać na najnowszej wersji rozwojowej (tzw. alfa), możesz pobrac ją w postaci pliku mediawiki-master.tar.gz lub pobrać kod źródłowy z repozytorium Git.

Z Gita możesz pobrać zarówno kompletne repozytorium (około 528 MiB)

git clone https://gerrit.wikimedia.org/r/mediawiki/core.git

lub tylko najnowszą wersję (około 85 MiB; często nazywa się to shallow clone: mniej do pobrania i szybsza operacja).[1]

git clone --depth 1 https://gerrit.wikimedia.org/r/mediawiki/core.git

Możesz też zobaczyć najnowszy kod źródłowy w swojej przeglądarce.

Poprzednie wydania

Możesz pobrać paczki (z rozszerzeniem **.tar.gz) wszystkich wersji MediaWiki, począwszy od marca 2005 (najwcześniejsza to MediaWiki 1.3.11) z archiwum wersji MediaWiki.

Pomoc w instalacji

Przypisy

  1. Może to wywołać problemy z późniejszym używaniem „git pull” w celu aktualizacji twojego shallow clone oraz nowszych wersji odnoszących się do starych, które nie zostały jeszcze pobrane na twój system. W takim wypadku możesz pobrać więcej wersji – zwiększyć wartość depth – lub wszystkie wcześniejsze wersje, lub tworzyć odtworzonego shallow clone.

Zobacz też