Manual:Installation requirements/pl

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Manual:Installation requirements and the translation is 60% complete.

Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Nederlands • ‎català • ‎dansk • ‎español • ‎français • ‎italiano • ‎magyar • ‎polski • ‎português • ‎português do Brasil • ‎русский • ‎українська • ‎اردو • ‎فارسی • ‎বাংলা • ‎中文 • ‎日本語 • ‎한국어
Mediawiki-logo.png Podręcznik:Przewodnik instalacji | O MediaWiki
Help-browser.svg Cechy | Wymagania
Preferences-system.svg Pobieranie | Instalacja | Konfiguracja


Wymagania Wymagania w skrócie

Make sure to also check the RELEASE NOTES shipped with MediaWiki for requirements.

Tworzenie miniaturek i TeX wymaga dodatkowych programów. Parsoid (wymagany przez VisualEditor), a inne usługi mają własne wymagania.

Oprócz konieczności pobrania oprogramowania, instalacja MediaWiki ma następujące wymagania:

  • serwer WWW, jest wymagany do wysyłania wygenerowanych przez MediaWiki stron do przeglądarek;
  • Język skryptowy PHP, jest wymagany do uruchomienia oprogramowania;
  • serwer baz danych, jest wymagany do przechowywania zawartości stron i danych serwisu.

Dodatkowo, istnieje szereg opcjonalnych zależności, które stawiają dodatkowe wymagania w sytuacjach, gdy serwis ma być wyposażony w zaawansowane cechy – patrz poniżej.

Jeśli serwis internetowy jest hostowany, tzn. nie masz nad nim bezpośredniej kontroli, należy zapytać administratora serwera lub firmę hostującą o poszczególne elementy wymagane przez MediaWiki.

Prosta instalacja za jednym pobraniem

Jeżeli używasz Linuxa, najlepiej jest zainstalować Apache'a, PHP oraz MariaDB używając menadżera pakietów. Na Debianie oraz Ubuntu użyj polecenia $code.

sudo apt-get install php php-apcu php-intl php-mbstring php-xml mariadb-server apache2

Na innych systemach operacyjnych, użyj XAMPP od https://www.apachefriends.org aby zainstalować wszystkie ważne pakiety – Apache, PHP i MariaDB – z tylko jednym pobraniem. Dostępny jest dla systemów operacyjnych: Linux, Windows, Mac i Solaris. Stan na sierpień 2016: najnowsza wersja XAMPP zawiera PHP w wersji 7.0 (MediaWiki wymaga co najmniej 7.0.13).

Alternatywnie, jeśli używasz komputera od Apple, możesz użyć MAMP, który jest taki sam w działaniu do XAMPP MAMP currently includes the ability to run the Apache web server and a MySQL database. It is available for both Windows and Mac, but is generally used on Mac instead of Windows. It is currently running the latest versions of php and MySQL.

Serwer WWW

By przekazywać generowane przez oprogramowanie MediaWIki strony do przeglądarki, wymagane jest oprogramowanie serwera WWW. Często nie ma wyboru co do używanego oprogramowania – korzysta się z tego, które dostarcza podmiot hostujący nasz serwis.

Większość instalacji korzysta z serwera Apache, dostępnego z oficjalnej strony pobierania.

Oprogramowanie MediaWiki przetestowano również na serwerach IIS 7.0, Cherokee, Hiawatha, LiteSpeed, nginx (przykład konfiguracji), oraz lighttpd.

PHP

PHP jest językiem programowania, w którym stworzono oprogramowanie MediaWiki i jest on wymagany do uruchomienia MediaWiki.

Oprogramowanie MediaWiki dostarczane jest ze skryptem instalacyjnym pozwalającym na zainstalowane z wykorzystaniem przeglądarki WWW najważniejszych elementów, lecz do zaawansowanych ustawień wymagana jest znajomość języka PHP.

  • Dla najnowszych wydań oprogramowania MediaWiki wymagany jest interpreter PHP w wersji 5.3.2 lub nowszej. Wersja PHP 5.3.1 zawiera błąd 50394, wskutek czego oprogramowanie MediaWiki nie działa pod kontrolą tej wersji PHP.

See the page on Zgodność for further information.

  • Na Ubuntu wymagana jest zainstalowana paczka php5-mysql jeżeli chcesz korzystać z bazy MySQL.
  • Some features of MediaWiki may require PHP functions that execute external processes, like image thumbnailing, that some cheap hosts usually disable. This has surfaced specially in MediaWiki 1.23 on file uploads (zadanie T68467). Please take this into consideration if you plan to install MediaWiki on a shared host.
  • MediaWiki extensions may require additional PHP features, e.g. VisualEditor requires libcurl support (php-curl on Debian/Ubuntu-based distros).

Osoby samodzielnie kompilujące PHP powinny zajrzeć do dokumentu PHP configuration/pl, opisującego opcje kompilacji mające wpływ na działanie oprogramowania MediaWiki.

  • Niektóre serwery wymagają też instalacji modułu bazy danych i modułu zarządzania sesją. Szczegółowe informacje znajdują się w dokumentacji poszczególnych systemów operacyjnych.
  • Podczas instalowania PHP w systemie Microsoft Windows z użyciem standardowego instalatora, należy dodać rozszerzenie wykorzystywanej bazy danych (MySQL/MariaDB lub PostgreSQL) do instalowanych komponentów.

Serwer baz danych

Uwaga Uwaga: Oracle and Microsoft SQL Server support are unmaintained and will be dropped in MediaWiki 1.34. You are strongly advised against using them.

Oprogramowanie MediaWiki przechowuje dane tekstowe i inne (zawartości stron, szczegóły dotyczące kont użytkowników, komunikaty systemowe, itd.) w bazie danych. Istnieje możliwość współdzielenia bazy danych przechowującej dane MediaWiki z innymi aplikacjami (np. phpBB). Chcąc uruchomić oprogramowanie MediaWiki należy dysponować oprogramowaniem do obsługi baz danych w jednej z niżej wymienionych wersji:

Wcześniej obsługiwany, ale teraz nie:

  • Oracle (nie wspiera najnowszych wersji MediaWiki z powodu otwartych zgłoszeń błędów)
  • Microsoft SQL Server 2008 R2 or later is supported for LTS releases and is not guaranteed to work for non-LTS releases (requires Microsoft Windows as Operating System because it uses the SQLSRV driver).

Make sure the Full-Text module is installed.

Niektórzy użytkownicy instalują dodatkowe oprogramowanie wspomagające pracę z bazami danych, np. phpMyAdmin (MySQL/MariaDB) lub phpPgAdmin (Postgres) służące do zarządzania bazami danych.

MySQL w wersji 5 jest wymagany od MediaWiki 1.19. Wersja MySQL 4 stała się wersją wymaganą w MediaWiki 1.6 – osoby używające starszych wersji MySQL i niemogące uaktualnić oprogramowania powinny korzystać z MediaWiki 1.5.8. Należy zwrócić uwagę na to, że wersja ta nie ma już wsparcia technicznego.

Wymagania sprzętowe

Zalecane minimalne wymagania to 256 MB RAM dla instalacji jednostanowiskowej i co najmniej 85 MB przestrzeni dyskowej, choć w przypadku serwisów publicznych o dużej ilości odwiedzin lub serwisów z włączoną możliwością przesyłania plików wartości te będą niewystarczające. Z drugiej strony znane są przypadki instalacji MediaWiki działających na komputerach wyposażonych w 48 MB RAM.

Rozmiar instalacji może zostać zmniejszony do około 50Mb dla instalacji dla developerów i do około 26Mb dla instalacji dla zwykłych użytkowników.

Zależności opcjonalne

Inne oprogramowanie

  • TeX: wymagany dla wyświetlania w tekście wzorów matematycznych; W większości dystrybucji Debian/Ubuntu znajduje się w pakiecie texlive.
  • Sendmail: wymagany do umożliwienia wysyłania wiadomości e-mail;
  • GNU diff3 can be provided to automatically resolve conflicts.

Więcej informacji na temat wyżej wymienionych kwestii znajduje się w dokumencie Manual:Installing third-party tools/pl.

Edytor wizualny

Rozszerzenie VisualEditor (a także rozszerzenie Flow) wymagają zainstalowanej usługi Parsoid web service, która jest zaimplementowana w Node.js. Node.js nie jest dostępny na większości hostingów współdzielonych (HostGator, Bluehost, Dreamhost, itd.). Ze względów bezpieczeństwa i wydajności, lepsze jest wykorzystanie dedykowanego rozwiązania hostingowego, takiego jak Wirtualny serwer prywtany ("VPS").

Scribunto

Jeżeli chcesz używać modułów Lua (przykładowe można zobaczyć na tej wiki) w szablonach i na stronach wiki, należy zainstalować Scribunto.

Zobacz też

  • Zgodność , for information about how MediaWiki's installation requirements are likely to change in the future
Zestawy oprogramowania