Help:VisualEditor/Maps/ko

From mediawiki.org
This page is a translated version of the page Help:VisualEditor/Maps and the translation is 0% complete.
Outdated translations are marked like this.

Main help pages:

시각 편집기로 지도 추가하기

Inserting a map

Screenshot of the insert menu in the VisualEditor interface with the Map option highlighted
VisualEditor "Insert" menu showing map item

To add a new map to the page, select "Insert" in the VisualEditor tool menu. Click "More" to show the entire menu, then select "Map". This will add a map at the current location of your cursor on the page.


VisualEditor modal showing default map settings

Setting map center point, size and proportions

The dialog window displays an interactive map with three tabs below it: "Map area" (selected by default), "Map contents" and "Options". To set a location, drag the center and corners of the interactive map and use the "+" and "-" buttons on the bottom of the map to change the zoom level until the interactive map displays the area you want. You can also manually enter latitude, longitude, zoom level and size in the fields below the map.


Adding markers and shapes

To add shapes and markers to the map, click the "Map contents" tab to display a toolbar. You can add lines, rectangles, polygons and markers.

After adding an element, use the pencil-and-paper icon VisualEditor-maps-edit-icon.png in the map toolbar to modify it. Note that adding elements to the map automatically expresses each element as GeoJSON in the text field at the bottom of the window. You can also paste valid GeoJSON into the text field. To remove an element, select the trash can icon followed by the element you wish to delete. Then click "Save". You can also delete the element from the GeoJSON field below.


VisualEditor modal showing options tab

Formatting options

In the "Options" tab, you can change the map's alignment on the page and select a language for map labels. Note: Not all labels are available in every language. (More information on map languages.)

Saving a map

When you're done, click "Insert" (the button at the window's top corner) to create your map on the page. This closes the dialog.


Editing an existing map

Editing an existing map

To edit an existing map's properties, select the map and then click the "Edit" button that appears.

To resize an existing map, select the map in the VisualEditor and then move the resizing arrows that appear on the bottom corner of the map. Note that this only changes the size of the map's frame on the page, not the zoom level nor any other of the map's properties.

To change a map's position on the page, select the map and then drag the map to its new location.

Removing maps with the VisualEditor

To remove a map, select it and, on your keyboard, press the Delete key or the CTRL-X key combination. You can also select "Cut" from your browser's "Edit" menu.

Advanced map settings

For advanced options in editing and marking up Kartographer maps, please see 도움말:확장기능:Kartographer .