Template:DownloadMediaWiki

From mediawiki.org
This page is a translated version of the page Template:DownloadMediaWiki and the translation is 89% complete.
Outdated translations are marked like this.

Télécharger MediaWiki 1.38.4 (.zip)

Télécharger .tar.gz à la place

Aide au téléchargement

Il peut être extrait sur la plupart des systèmes d'exploitation sans installer de logiciel supplémentaire, il est généralement recommandé pour les utilisateurs de Windows.

Si vous utilisez 7-Zip, il est conseillé de le mettre à jour avec la dernière version pour décompresser l'archive tar (fichier .tar.gz), en raison d'un bogue avec le format PAX dans les versions précédentes.

Les utilisateurs de macOS doivent noter que Unarchiver ne sait pas extraire correctement les fichiers .tar.gz (T258716). Archive Utility peut être utilisé en remplacement.

Toutes les versions

Aux utilisateurs des versions MediaWiki 1.36 ou antérieures à 1.34 : Ces versions ne sont plus prises en charge. Veuillez télécharger une version plus récente de MediaWiki :

Licence

MediaWiki est un Logiciel libre licencié sour la version 2 de la Licence publique générale GNU (GNU General Public License). Étant donné que MediaWiki est diffusé gratuitement, il n'existe aucune garantie, à l'exception de celle permise par la loi applicable. Lisez [$link le texte complet en anglais de la GNU GPL version 2 pour plus de détails] Because MediaWiki is licensed free of charge, there is no warranty, to the extent permitted by applicable law. Read the full text of the GNU GPL version 2 for details.

Exigences pour le système

MediaWiki nécessite PHP 7.3.19/7.4.3+, un logiciel serveur web, et soit MariaDB 10.1.0+, MySQL 5.5.8+, SQLite 3.8+ ou PostgreSQL 9.4+. Using MariaDB or MySQL is recommended as Wikimedia uses MariaDB. Any other database servers are less tested and you may likely run into some bugs.

Pour plus d'informations, veuillez lire les pages sur les contraintes du système et sur la compatibilité.

MediaWiki n'est pas compatible avec le PHP des versions de 7.4.0 - 7.4.2 dû à un bogue upstream. Use PHP 7.4.3+ instead. Voir tâche T246594 pour plus d'informations.
Support for PHP 8.0 in MediaWiki is experimental. We are not aware of any issues, but it is not as well tested as PHP 7. PHP 8.1 is not supported. Voir tâche T248925 pour plus d'informations.