Yardım:Eklenti:Çeviri/Kurma

From mediawiki.org
Jump to navigation Jump to search
This page is a translated version of the page Help:Extension:Translate/Installation and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎Deutsch (Sie-Form) • ‎English • ‎Kiswahili • ‎Lëtzebuergesch • ‎Nederlands • ‎Türkçe • ‎Zazaki • ‎català • ‎dansk • ‎español • ‎français • ‎italiano • ‎lietuvių • ‎polski • ‎português • ‎português do Brasil • ‎slovenčina • ‎svenska • ‎čeština • ‎русский • ‎українська • ‎العربية • ‎हिन्दी • ‎বাংলা • ‎中文 • ‎日本語 • ‎한국어

Translate uzantısı, hızlı geliştirme niteliği nedeniyle, çalışmak için MediaWiki'nin nispeten yeni bir sürümünü gerektirir. Amaç, MediaWiki'nin geliştirme sürümünü ve en son iki kararlı sürümünü desteklemektir. Paket yöneticilerinde sürüm, gereksinimleri karşılayamayacak kadar eski olabilir. Bu durumda mediawiki.org'dan veya Wikimedia'nın Git deposundan daha yeni bir sürüm indirmeniz gerekir.

Translate uzantısı sürekli bir geliştirme modeli kullanır; bu, en son sürümün hiçbir zaman tamamen bozulmaması gerektiği anlamına gelir, çünkü Translate uzantısına yönelik tüm taahhütler meslektaş incelemesinden geçer ve birim testlerini geçer. Temel işlevsellik oldukça kararlıdır, ancak zaman zaman daha büyük değişiklikler olabilir.

Gereksinimler

Bu eklentiyi yüklemek için aşağıdaki yazılım gereklidir:

  1. MediaWiki'nin son sürümü
  2. MySQL veritabanı – SQLite (deneysel)
  3. Universal Language Selector uzantısı (included in MediaWiki Language Extension Bundle içinde dahildir)
  4. (isteğe bağlı - MLEB 2020.10'dan beri artık gerekli değil) İstatistik grafikleri için PHPlot.
  5. (isteğe bağlı) Daha hızlı ve daha iyi YAML ayrıştırma ve oluşturma için Syck veya phpyaml
  6. (isteğe bağlı) Gelişmiş arama özellikleri ve çeviri belleği için ElasticSearch
  7. (isteğe bağlı) Makine çevirisi hizmetleri için sunucuda internet erişimi
PHP, çevirme önerisi özelliğine izin vermek için kıvırma modülüyle birlikte kurulmalıdır.

MediaWiki'nin iş kuyruğu kurulumu doğru şekilde olması gerekir. İş sıranız işlenmezse Translate'de hiçbir şey çalışmaz.

Buna ek olarak, bakım komut dosyalarını çalıştırmak için kabuk erişimi gerekir.

Bir üretim ortamında önbelleğe alma için memcached ve örneğin APC PHP hızlandırıcısının kullanılması önerilir.

Kurulum Yardımı

İndirme bağlantıları ve talimatlar için MediaWiki Dil Uzantı Paketi gidin. Paket, Translate uzantısıyla birlikte yaygın olarak kullanılan ek uzantıları içerir. Ayrıca, başlamanız için çalışan bir varsayılan yapılandırma içerir. Ayarların açıklaması için Help:Extension:Translate/Configuration sayfasına bakın.