Manual:Update.php

From mediawiki.org
Jump to navigation Jump to search
This page is a translated version of the page Manual:Update.php and the translation is 79% complete.
Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎magyar • ‎polski • ‎português • ‎português do Brasil • ‎čeština • ‎русский • ‎中文 • ‎日本語

Detalhes

O arquivo update.php verifica se o esquema de banco de dados do MediaWiki precisa ser atualizado, a fim de trabalhar com a versão atual do MediaWiki. Você deve executar o update.php após cada atualização do MediaWiki ou após a atualização ou instalação de uma extensão que requer uma atualização do esquema. A maioria das extensões que precisam de atualizações de esquema terá isso em sua documentação.

A partir do navegador

Se você não tem acesso à linha de comando do seu servidor, em seguida, use o atualizador web para executar o script de atualização.

Atualizador web

Da linha de comando

Da linha de comando, ou um shell SSH ou similar:

  • Mude para o diretório manutenção
  • Execute o script de atualização:
$ php update.php
Atenção Atenção: update.php pode sair com erros, deixando o banco de dados em um estado inconsistente. Sempre backup de banco de dados antes de executar o script!
Este script de manutenção pode ser desabilitado via $allow (no 1.18.0 por $miser). Pessoas com wikis extremamente grandes e ocupados podem precisar fazer atualizações com cuidado, mas se você não tem certeza se isso se aplica a você, então provavelmente não. People with extremely large and busy wikis may need to do upgrades with care, but if you're not sure if that applies to you, then it probably doesn't.
Use o seguinte instâncias de Vagrant (do seu vagrant ssh).
$ mwscript update.php

Parâmetros

Este script oferece vários parâmetros (genéricos, dependentes do script e específicos do script) que podem ser necessários em alguns ambientes wiki.

Parâmetros de manutenção genéricos
--help
costumava obter um prompt de todos os parâmetros de script disponíveis (genérico, dependente do script e script específico), juntamente com breves explicações sobre o uso deles. Estes são parâmetros menos utilizados.
--wiki wikiId
update wiki family if database name depends on virtual host, where wikiId - database name (e.g. enwiki, dewiki ...)
Parâmetros específicos do script
--quick
pular a sequência de contagem regressiva
--nopurge
não remova a tabela objectcache. Normalmente update.php purga o cache de objetos (geralmente contém o cache do analisador e o cache das mensagens), msg_resource e msg_resource_links (estas são usadas para armazenamento de mensagens de $loader e são desmarcadas em 1.21 e posteriores) no banco de dados, se você não quiser purgar esta tabela, use a opção $nopurge. Normally update.php purges the objectcache table (generally contains the parser cache and the messages cache), msg_resource and msg_resource_links (these are used for ResourceLoader message caching and are cleared in 1.21 and later) tables in the database, if you don't want to purge this table, use the --nopurge option.
--doshared
Atualizar tabelas compartilhadas também.
--force
Execute esse script mesmo que seja desativado por opções de configuração.
--conf
Especifica o arquivo de configuração (o arquivo LocalSettings.php para o wiki específico). Usado para famílias wiki.
--noschema
All changes to the table structure or table additions are skipped. Only data changes are made.
--schema
No schema changes are made to the database, but the schema changes are saved to a separate SQL file that can be run.
Allows "update.php" to be run when $wgAllowSchemaUpdates is set to false. This is useful for non-WMF environments where strict DB permissions allow database updates (which "update.php" performs), but no schema changes (such as adding or dropping tables or indices which "update.php" also performs).
--skip-compat-checks
Ignora as verificações de compatibilidade
--skip-external-dependencies
when using composer.local.json to let Composer install extensions and their dependencies, you may see an error message saying that there is a mismatch between the installed and required version (e.g. "mediawiki/semantic-breadcrumb-links: 1.3.0 installed, ~1.3 required"). You can use this parameter to ignore the message and run update.php regardless.
Atenção Atenção: Apenas recomendado para uso pelos desenvolvedores.

As extensões podem instalar/atualizar seus esquemas usando o gancho LoadExtensionSchemaUpdates .

Ver também