Manual:update.php

From mediawiki.org
This page is a translated version of the page Manual:Update.php and the translation is 91% complete.


詳細

update.phpMediaWiki データベース スキーマが新しいバージョンの MediaWiki に対応させるためのアップデートが必要かどうかを確認します。 MediaWiki のアップグレードや、スキーマのアップデートを必要とする拡張機能のインストールまたはアップデートを行った際には、update.php を実行すべきです。 スキーマのアップデートを必要とする拡張機能のほとんどは説明文書の中でそのことに言及しています。

ブラウザーで

自分のサーバーのコマンド ラインへのアクセス権がない場合は、更新スクリプトを実行するためにウェブ アップデーターを使用してください。

ウェブ アップデーター

コマンドラインで

コマンドラインや SSH シェルなどから:

  • 現在のディレクトリを maintenance に変更します
  • 更新スクリプトを実行します:
$ php update.php
警告 警告: アップデートがエラーで終了し、データベースが不安定な状態になることがあります。 スクリプトを実行する前に、必ずデータベースをバックアップしてください。
このメンテナンススクリプトは、$wgAllowSchemaUpdates で無効にすることができます。 極めて大規模なWikiを持つ人は、アップグレードを慎重に行う必要があるかもしれませんが、それが自分に当てはまるかどうかわからないという人は、おそらく当てはまりません。
以下を Vagrant インスタンスで使用します (vagrant ssh 内から)。
$ mwscript update.php

パラメーター

このスクリプトは、いくつかのパラメータ(汎用、スクリプト依存、スクリプト固有)を提供し、これらはいくつかのWiki環境で必要となる場合があります。

汎用保守パラメータ
--help
利用可能なすべてのスクリプトパラメータ (汎用、スクリプト依存、スクリプト固有) とその使い方の簡単な説明が表示されます。 これらはあまり使われないパラメータです。
--wiki wikiId
データベース名がバーチャルホストに依存する場合、wikiファミリーを更新します。ここで、wikiId - データベース名 (例: enwiki、dewiki ...)
スクリプト固有のパラメーター
--quick
カウントダウンシーケンスをスキップ
--nopurge
do not purge objectcache table. 通常 update.php は、データベース内の objectcache テーブル (一般にパーサキャッシュとメッセージキャッシュを含む)、 msg_resource および msg_resource_links テーブル (これらは ResourceLoader メッセージキャッシュに使われ、 1.21 以降ではクリアされる) を消去しますが、このテーブルを消去しない場合は --nopurge オプションを使ってください。
--doshared
同様に共有テーブルも更新してください。
--force
このスクリプトは、設定オプションで無効にされている場合でも実行します。
--conf
設定ファイル(特定のWikiのLocalSettings.phpファイル)を指定します。 wiki familiesで使用されています。
--noschema
テーブル構造の変更やテーブルの追加はすべてスキップされます。データの変更のみが行われます。
--schema
データベースへのスキーマの変更は行われませんが、スキーマの変更は別のSQLファイルに保存され、実行することができます。
「update.php」の実行を、$wgAllowSchemaUpdates が false に設定されている場合に許可します。 これは、WMF 以外の環境において、厳格な DB パーミッションによってデータベースの更新 (「update.php」が実行します) は許可されているがスキーマの変更 (テーブルやインデックスの追加や削除など、「update.php」が実行します) は許可されていないという場合に有用です。
--skip-compat-checks
互換性チェックをスキップします。
--skip-external-dependencies
when using composer.local.json to let Composer install extensions and their dependencies, you may see an error message saying that there is a mismatch between the installed and required version (e.g. "mediawiki/semantic-breadcrumb-links: 1.3.0 installed, ~1.3 required"). このパラメータを使用すると、メッセージを無視して、関係なくupdate.phpを実行することができます。
警告 警告: 開発者のみが使用することを推奨します。

Extensions can install/update their schemas using LoadExtensionSchemaUpdates hook.

関連項目