Manuel:Update.php

From mediawiki.org
Jump to navigation Jump to search
This page is a translated version of the page Manual:Update.php and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎magyar • ‎polski • ‎português • ‎português do Brasil • ‎čeština • ‎русский • ‎中文 • ‎日本語 • ‎한국어


Détails

update.php vérifie si le schéma de la base de MediaWiki doit être mis à jour pour fonctionner avec la version actuelle de MediaWiki. Vous devez exécuter update.php après chaque mise à niveau de MediaWiki ou après la mise à jour ou l'installation d'une extension qui nécessite une mise à jour du schéma. La plupart des extensions qui nécessitent des mises à jour du schéma l'indiquent dans leur documentation.

Depuis le navigateur

Si vous n'avez pas accès à la ligne de commande de votre serveur, utilisez la mise à jour Web pour exécuter le script de mise à jour.

→ voir la mise à jour Web

Depuis la ligne de commande

Depuis la ligne de commande, un shell SSH ou similaire :

  • Placez-vous dans le répertoire maintenance
  • Exécuter le script de mise à jour :
$ php update.php
Avertissement Avertissement : update.php peut sortir en erreur laissant la base de données dans un état incohérent. Sauvegardez toujours la base de données avant d'exécuter le script !


Ce script de maintenance peut être désactivé via $wgAllowSchemaUpdates . Les personnes ayant de gros wikis très actifs doivent faire les mises à niveau avec précaution, mais si vous n'êtes pas sûr que ce soit votre cas, alors c'est que vous n'êtes probablement pas concerné.
Utilisez les instances suivantes sur Vagrant (à partir de votre ssh vagrant ).
$ mwscript update.php

Paramètres

Ce script offre plusieurs paramètres (génériques, dépendants du script, et spécifiques au script) qui peuvent être nécessaires dans certains environnements wiki.

Paramètres génériques de maintenance
--help
utilisé pour obtenir une invite de tous les paramètres de script disponibles (générique, dépendant du script et spécifique au script) avec des explications courtes sur leur utilisation. Ce sont les paramètres les moins utilisés.
--wiki wikiId
mettre à jour la famille de wiki si le nom de la base de données dépend de l'hôte virtuel, où wikiId est le nom de la base de données (par exemple enwiki, dewiki ...)
Paramètres spécifiques au script
--quick
Sauter la séquence de compte à rebours
--nopurge
Ne pas purger la table objectcache. Normalement update.php purge le cache objectcache (contient généralement le cache de l'analyseur syntaxique et le cache des messages), les tables msg_resource et msg_resource_links (celles-ci sont utilisées pour la mise en cache des messages de ResourceLoader et sont effacées en version 1.21 et ultérieures) dans la base de données, si vous ne voulez pas purger cette table, utilisez l'option --nopurge.
--doshared
Mettre à jour les tables partagées aussi.
--force
Exécutez ce script même s'il est désactivé par les options de configuration.
--conf
Spécifie le fichier de configuration (le fichier LocalSettings.php du wiki spécifique). Utilisé pour les familles de wikis.
--noschema
Toutes les modifications faites sur la structure de la table ou les ajouts apportés sont ignorés. Seules les modifications des données sont réalisées.
--schema
Aucune modification du schéma n'est appliquée à la base de données, mais les modifications du schéma sont enregistrées dans un fichier SQL séparé qui peut être exécuté.
Permet d'exécuter update.php lorsque $wgAllowSchemaUpdates est à false. Ceci est utile pour les environnements non-WMF où les autorisations strictes d'accès à la base de données permettent des mises à jour de celle-ci (réalisées par update.php), mais pas les modifications du schéma (telles que l'ajout ou la suppression de tables ou d'indexes que update.php réalise aussi).
--skip-compat-checks
Ignore les contrôles de compatibilité
--skip-external-dependencies
si vous utilisez composer.local.json pour laisser Composer installer les extensions et leurs dépendances, vous pourrez voir un message d'erreur disant que la version installée ne correspond pas à la version requise (par exemple « mediawiki/semantic-breadcrumb-links: 1.3.0 installed, ~1.3 required »). Vous pouvez utiliser ce paramètre pour ignorer le message et exécuter directement update.php.
Avertissement Avertissement : Recommandé pour les développeurs uniquement.


Les extensions peuvent installer/mettre à jour leurs schémas à l'aide de l'accroche LoadExtensionSchemaUpdates .

Voir aussi