مدیاویکی ۱.۳۵

From mediawiki.org
Jump to navigation Jump to search
This page is a translated version of the page MediaWiki 1.35 and the translation is 25% complete.
Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎lietuvių • ‎magyar • ‎oʻzbekcha • ‎português do Brasil • ‎slovenčina • ‎čeština • ‎русский • ‎العربية • ‎فارسی • ‎বাংলা • ‎മലയാളം • ‎中文 • ‎日本語

مدیاویکی ۱٫۳۵ نگارش پشتیبانی درازمدت (LTS) آیندهٔ مدیاویکی است. برای دیدن فهرست کامل تغییرات، پروندهٔ RELEASE NOTES را بررسی کنید. از طریق شاخه‌های افزایشی wmf از ۲۶ سپتامبر ۲۰۱۷ در ویکی‌های بنیاد ویکی‌مدیا مستقر شد. انتظار می رود نسخه پایدار 1.35.0 در اواسط سپتامبر سال 2020 منتشر شود تأخیر در MediaWiki 1.35 Release and Branch Cut و l / 2020-ژوئن / 048402.html MediaWiki 1.35 Branch Branch and Release Download mediawiki-1.35.1.tar.gz or checkout the REL1_35 branch in Git to follow this release. It will go end-of-life in September 2023.

هشدار هشدار: مدیاویکی ۱٫۳۵ دیگر از پی‌اچ‌پی ۷٫۲ پشتیبانی نمی‌کند. پی‌اچ‌پی ۷٫۳٫۱۹ یا بالاتر لازم است.
هشدار هشدار: MediaWiki is not yet compatible with PHP 8. See task T248925 for more information.
Red Hat 8 and CentOS 7 users should ensure Software Collections (SCL) is enabled. Red Hat updated PHP-7.3 to version 7.3.20 to support MediaWiki 1.35. See Issue 0017826, CentOS 7 with SCL enabled only provides PHP 7.3.11.

New features

  • Special pages Special:EditPage, Special:PageHistory, Special:PageInfo, and Special:Purge have been created as shortcuts for each action. Special:EditPage/Foo redirects to title=foo&action=edit, with PageHistory, PageInfo, and Purge corresponding to &action= history, info, and purge respectively. When linked to, its subpage is used as the target. Otherwise, it displays a basic interface to allow the end user to specify the target manually (see task T13456).
  • The form at "?action=watch" has a new dropdown list to support expiry dates for watchlist items (if $wgWatchlistExpiry is true).

افزونه‌های همراه تازه

مدیاویکی ۱.۳۵ با افزونهٔ VisualEditor همراه خواهد بود که تجربهٔ ویرایش دیداری را به‌عنوان جایگزینی برای ویرایشگر متنی سنتی فراهم می‌کند. لازم نیست که Parsoid جداگانه نصب شود، زیرا در هستهٔ مدیاویکی تعبیه شده است.

افزون بر این SecureLinkFixer و TemplateData را در بر خواهد داشت. SecureLinkFixer داشتن https را در ویکی شما ملزم می‌کند و TemplateData یک برچسب و API را نیز اضافه می‌کند تا به ویراستاران اجازه دهد شیوهٔ فراخوانی الگوها را مشخص کنند.

زیربرگه‌ها