Talk:Gerrit/Troubleshooting

About this board

Ivi104 (talkcontribs)

Hi! I'm attempting to add a change to languages/i18n/en.json to https://gerrit.wikimedia.org/r/c/mediawiki/core/+/714448 via the web interface (part of phab:T151682), but I keep getting this error:

An error occurred
Error 502 (Bad Gateway): <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>502 Bad Gateway</title>
</head><body>
<h1>Bad Gateway</h1>
<p>The proxy server received an invalid
response from an upstream server.<br />
</p>
</body></html>

Endpoint: /changes/*~*/edit/*

Could someone help?

Saper (talkcontribs)

Are you using patch uploader for that? Pushing directly via SSH from the command line?

Ivi104 (talkcontribs)

I'm fairly new to git and didn't realize I could patch multiple files with a single diff. I uploaded a single file through PatchUploader (resulting in the linked patch), and then tried to add the others by editing through the web interface, which invariably resulted in the error above. I cannot change the uploaded file, nor add additional files. I would upload a new patch with the three files all in one, but there also isn't an option to abandon the current patch (presumably because Gerrit Patch Uploader is set as the owner).

Ivi104 (talkcontribs)
Reply to "502 Bad Gateway"

authenticity of host can't be established

5
Qdinar (talkcontribs)

when i run git clone ssh://qdinar@gerrit.wikimedia.org:29418/mediawiki/core.git mediawiki i get : " The authenticity of host ... can't be established. RSA key fingerprint is ....". i asked about this in irc and i got this answer: " this is the right fingerprint https://wikitech.wikimedia.org/wiki/Help:SSH_Fingerprints/gerrit.wikimedia.org:29418 " " https://wikitech.wikimedia.org/w/index.php?title=Help%3ASSH_Fingerprints%2Fgerrit.wikimedia.org%3A29418&type=revision&diff=1908069&oldid=1872718 ". then i compared fingerpints and typed yes, enter. i think this may help somebody. (copied from https://www.mediawiki.org/wiki/Topic:Wba935o4h49w537z ).

Qdinar (talkcontribs)

now, i think, i needed not to copy this here. editors of this page probably review discussions of gerrit tutorials and add topics from there to this page.

Saper (talkcontribs)
Qdinar (talkcontribs)

yes, it seems clear to me, but it may be not clear to somebody

178.200.245.164 (talkcontribs)

If you have some ideas how to improve the text, please feel free to edit it... don't worry if you make mistakes!

"Permission denied (publickey)" error

5
Фәрһад (talkcontribs)

Good day! In the first steps I have written "yes" after $ssh -p 29418 gerrituser@gerrit.wikimedia.org but then it haven't been continued. So the next time I have had an error like this "debug1: No more authentication methods to try. ...@gerrit.wikimedia.org: Permission denied (publickey)." and I cannot find on your page how this problem may be solved. Two variants mentioned here are not devoted to this case.

AKlapper (WMF) (talkcontribs)

@Фәрһад What is your user name for your Wikitech developer account, and which exact complete command did you enter (copy and paste, please)?

Фәрһад (talkcontribs)

user:AKlapper (WMF), in wikipedia and other neighbouring projects my name is written in cyrillic script "Фәрһад". For gerrit it passed not, so I create another account with only latin letters "Faerhad". As it was written here I have made all the steps before this in step "$ssh -p 29418 gerrituser@gerrit.wikimedia.org". it always write "Identity added: .ssh/id_rsa (Фәрһад@F▒rhad)" but the next step don't pass.

AKlapper (WMF) (talkcontribs)
Фәрһад (talkcontribs)

I have found a mistake in previous steps... So now it has been improved. Thanks!

Reply to ""Permission denied (publickey)" error"
GeoffreyT2000 (talkcontribs)

I tried cloning the "REL1_31" core branch and then submitting a change for review, but while doing so, got several lines that say "remote: ERROR: Implicit Merge of" as well as one line that says "! [remote rejected] HEAD -> refs/publish/master/(branch name) (implicit merges detected)" and another line that says "error: failed to push some refs to 'ssh://geoffreytrang@gerrit.wikimedia.org:29418/mediawiki/core.git'". Perhaps, a new subsection about the "implicit merge" issue should be added under the "Miscellaneous" section.

Saper (talkcontribs)

1. Can you post the exact command used to publish the change?

2. Can you post the output of the command

   git log HEAD ^REL1_31

while you are on the branch containing your changes?

Saper (talkcontribs)

From the Gerrit documentation:

https://gerrit.googlesource.com/homepage/+show/030d29524d8a10bd534ecf41979d87731fef425d/releases/2.13.md#321

 * New project option to reject implicit merge commits.
 The 'Reject Implicit Merges' option can be enabled to prevent non-merge commits
 from implicitly bringing unwanted changes into a branch. This can happen for
 example when a commit is made based on one branch but is mistakenly pushed to
 another, for example based on refs/heads/master but pushed to refs/for/stable.

Most probably you are trying to push your commits to master (git push <gerrit> HEAD:refs/for/master) instead of submitting them to REL1_31 (git push <gerrit> HEAD:refs/for/REL1_31).

Reply to "Implicit merge errors"

! [remote rejected] HEAD -> refs/changes/79/550379/2 (cannot add patch set to 550379.)

2
Summary by Kizule

Amending patches from other users requires you to be added to the Trusted-Contributors gerrit group, or be in privileged gerrit groups.

Saper (talkcontribs)

Who can amend other's changes? How to deal with the message above the best way?  « Saper // talk »  09:35, 12 November 2019 (UTC)

AKlapper (WMF) (talkcontribs)

git review: Authentication failed

6
Syced (talkcontribs)

I want to modify the file https://phabricator.wikimedia.org/diffusion/GTWN/browse/master/groups/Wikimedia/CommonsAndroid.yaml

So I cloned using the URL https://gerrit.wikimedia.org/r/p/translatewiki

Following the instructions at Gerrit/Tutorial#Prepare to work with Gerrit I uploaded my SSH public key, modified and added/committed the file. Then whenI ran git review -R I got prompted for a a username and password. Despite entering the name that appears near Username at https://gerrit.wikimedia.org/r/#/settings/ and the password I use successfully to log into https://gerrit.wikimedia.org, it failed:

~/src/translatewiki$ git review -R

Username for 'https://gerrit.wikimedia.org': nicolas-raoul

Password for 'https://nicolas-raoul@gerrit.wikimedia.org':

remote: Unauthorized

fatal: Authentication failed for 'https://gerrit.wikimedia.org/r/p/translatewiki/'

What am I doing wrong?

AKlapper (WMF) (talkcontribs)

Which exact full complete command did you use for cloning?

Legoktm (talkcontribs)
Nikerabbit (talkcontribs)

Don't people usually clone using the ssh:// protocol and not https?

AKlapper (WMF) (talkcontribs)

That's why I asked for the full complete command, indeed :)

Syced (talkcontribs)
Reply to "git review: Authentication failed"
There are no older topics