Topic on 2017 wikitext editor/Feedback

Jump to navigation Jump to search

Text and selection are shifted

6
Summary by Elitre (WMF)
Debenben (talkcontribs)

I just tried the new wikitext editor. The first article I tried to edit was [https://de.wikipedia.org/w/index.php?title=Schwarzschild-Metrik&diff=170902272&oldid=170628851]. Unfortunately the text seemed to be not in the right place, so when I selected and typed something it appeared approximately two lines below (I took some screenshots which I can upload in case they help). Also it did not tell me that I deleted the first line of the table, neither in the editor nor in the preview, I could only see it the diff-view In general it feels very bad, because in this particular case which happened to be my first test for a while, the editor was unusable, the preview was not what it looks like afterwards in the article and the only way to tell is to save it and revert it afterwards in case it broke something. Apart from that it is terribly slow, one always has to klick again on something before being able to edit the edit-summary or something in the text. While I like the idea of being able to switch to the visual editor and autocompletion for the citation templates, it seems to be very far away from being able to replace the old editor.

Elitre (WMF) (talkcontribs)

HI @Debenben. I'd be glad to take a closer look at your issue. Can you say which browser, operating system and skin you have? Also, more specific steps to reproduce would be very welcome. Have you tried using keyboard shortcuts? They do wonders for people who are annoyed by extra clicks.

Debenben (talkcontribs)

debian stretch + firefox + vector skin

I tried it again and it is reproducible. The steps are

  • enable new wikitext-modus
  • go to Schwarzschild-Metrik
  • click on "Quelltext bearbeiten" (edit source)
  • press ctrl+f
  • search for "mit dem Term"

and you will see that the selection is already two lines above the actual text

Debenben (talkcontribs)

I had a closer look at the problem again and it appears only in combination with the new syntax-highlighting beta feature. Apart from a few glitches (e.g. w:de:Wikipedia:Umfragen/Konzept für mathematische Formeln the escaped chem tag inside the template) it always worked well in the old editor and I like the more discrete and consistent choice of colors, but does not seem to work together with the new one. One can notice a wrong positioning of the cursor with respect to the text starting from about the first ref tag and the red spell-checking marks are completely off.

Elitre (WMF) (talkcontribs)

I have also had some issues and also suspected it was tied to syntax-highlighting, but I still can't reproduce (also, one of my browsers is not up to date and I thought that could be the real reason). I can file a task anyway. What's the FF version? Thanks.

Debenben (talkcontribs)

It was version 52.4.0, I just updated to 52.5.0 deactivated all addons, went to the Italian Wikipedia where I did not change any settings and appended the &safemode=1 and it is still not working.