Topic on Project:Support desk (talkcontribs)

Media Wiki: 1.16.0 PHP: 5.2.12 MySQL: 5.0.67-log

Hey, I installed the wiki on a local server and configured all settings, but when i wanted to log in with my admin account, i got this error message: "There seems to be a problem with your login session; this action has been canceled as a precaution against session hijacking. Go back to the previous page, reload that page and then try again" I tried it again and again, but the result was equal, the same problem when I try to register a new account. (talkcontribs)

I get the same error as thread starter..anyone pls can help us? Im using 1.16 + wamp. (talkcontribs)

I'm having the same problem on the new clean installation when trying login or create a new account - any solution for it?..

Bryan (talkcontribs)

Probably something is wrong with your sessions; most likely PHP is not able to write to your sessions directory. Check your php.ini for the sessions directory and if PHP can write to those files.

Lamidesbetes (talkcontribs)

I got the same problem since soon, but not for all the installations on the same server (same version). Apparently the cookies are not good. It seems to come from the repertory of installation...

Lamidesbetes (talkcontribs)

The connection to the database seems also be examined in this problem ! (talkcontribs)

Looks like this has to do with setting a DNS CNAME.. it's only happening in IE8 for me... anyone have a fix?

Bawolff (talkcontribs)

Only happening in IE8 makes it sound as if you disabled cookies in that browser. Check to make sure cookies are enabled.

Why do you think this has something to do with a DNS CNAME? (talkcontribs)

The same thing just started to happening to me, after i renewed my hosting and domain (talkcontribs) (talkcontribs)

Hi, Did anyone found a solution for this? I got the exact same problem.

it occurs with: IE7, IE8 but NOT with FireFox.

thanks, Jr (talkcontribs)

I have the exact same issue now, fresh install. Anyone going to help with this?? (talkcontribs)

I found this solution:

go in your LocalSettings.php and at the end add the following code of line :


Create a folder "tmp" in your wiki installation directory. give rights 777 (permissions)

Which worked for me.... also, check to make sure your disk has space (talkcontribs)

This worked perfectly for me on a new install. Thanks, you're the first person to actually give a usable answer to those that don't have access to the server's PHP.ini files that I could find.

MaxSem (talkcontribs)

Eh?! Don't put it in web-accessible directories, or your user accounts will be easily hackable.

Cojoilustrado (talkcontribs)

This worked for me. I had this problem with MW 1.18.1 after I upgraded my hosting with godaddy and they changed my ip and dedicated ip. Mediawiki kept asking for cookies to be enabled (they were enabled) on all types of browsers and platforms including the iphone. Problem solved for now, even though I'd like to know if it will come back after an upgrade. (talkcontribs)

what is meant by give rights 777? (talkcontribs)

Same problem, can't even register or login as admin. Enough space is present.

Beznogim (talkcontribs)

Looks like it was caused by using $wgMainCacheType two times in LocalSettings.php, now it's solved. (talkcontribs)

Hi also have the same problem where the IP address work perfectly yet the hostname fails.

Would love some kind of explanation? (talkcontribs)

The problem i'm experiencing just seems to be Internet Explorer only. Firefox and chrome are un-affected either by the hostname or IP address.

Although I can login using IE6/IE8 with the IP address,
The problem occurs using the hostname.
Example: http://myserver/mediawiki

If I goto the login page a 'sess_xxxx' in the /tmp folder is created. If I attempt to login, or just refresh the login page this seems to set brand new a sess_xxxx everytime.

I have checked the apache logs and the client IP address is always the same regardless if i used the hostname of IP address.

Its not a permission issue.

I have also tried the following which was suggested with no success. $wgUseSquid = true;

Some suggestion would be greatly appreciated.

[SOLVED: My issue was caused by having an 'underscore' in the hostname example http://my_server - IE looks though it doesn't handle the underscore in the hostname as well as FF or Chrome does. Hope this helps anyone else using Mediawiki within their local intranet] (talkcontribs)

had this error and the problem is that the facility lacked a standard memcached adding correct configuration

$wgSessionsInMemcached = true; # optional (talkcontribs)

had the same problem and adding this fixed it for me. Looks like the utility I used to install mediawiki (the utility was called simple script) forgot to plug this guy in when configuring.

Salquint (talkcontribs)

... a little more resolved. This can also be a symptom of being short on disk space. (talkcontribs)

hi please upgrade to 1.19.0 or higher please

Salquint (talkcontribs)

Nothing would please me more (at least regarding mediawiki), but I require WYSIWYG working on a Semantic Form for my users, so I'm stuck with what I've got. Anyone similarly stuck can heed the diskspace problem as a possible reason for this problem. (talkcontribs)

I have the same issue right now. I am able to login as the administrator but any new account is not able to login.