Skin:MonoBook

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Skin:MonoBook and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎Nederlands • ‎català • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎suomi • ‎български • ‎русский • ‎中文 • ‎日本語 • ‎한국어
Esta skin acompanha o MediaWiki 1.1 e superiores. Assim, não é necessário baixá-la novamente. No entanto, você ainda precisa seguir as outras instruções fornecidas.
MediaWiki skins manual - category
Crystal Clear device blockdevice.png
MonoBook
Release status: stable
Dantman-Skin-monobook.png
License GPLv2+
Download
Example https://en.wikipedia.org/w/index.php?useskin=monobook
Translate the MonoBook skin if it is available at translatewiki.net
Check usage and version matrix;
Issues : Open tasks · Report a bug

O MonoBook é uma skin. Era a skin padrão anterior dos sites da Fundação Wikimedia desde o MediaWiki 1.3, como substituta da antiga skin Standard. Tornou-se a pele mais popular e mais amplamente suportada no ecossistema MediaWiki até que foi finalmente substituída pela skin Vector como padrão em 13 de maio de 2010 (MediaWiki 1.17, git #2833b07a), como resultado dos esforços da Iniciativa de Usabilidade da Wikipédia para melhorar as experiências dos usuários da Wikipédia e potencialmente atrair mais participação dos colaboradores. Ele serviu como um backup comum para o Vector e ainda está presente em muitos wikis usando versões mais antigas do software MediaWiki.

Instalação

Esta skin está incluída no depósito de downloads do MediaWiki. Você só precisa instalá-la separadamente, se você instalou o MediaWiki usando um método diferente.


  • Baixe e coloque o(s) arquivo(s) em uma pasta chamada MonoBook dentro da sua pasta skins/.
  • Adicione o seguinte código no final do arquivo LocalSettings.php:
wfLoadSkin( 'MonoBook' );
  • Yes Pronto - Vá até Special:Version em sua wiki para se certificar que a instalação da skin foi bem-sucedida.

Para usuários utilizando MediaWiki 1.24 ou anteriores:

As instruções acima descrevem a nova forma de instalar skins utilizando wfLoadSkin(), a partir do MediaWiki 1.25. Para instalar esta skin em versões anteriores, em vez de wfLoadSkin( 'MonoBook' );, você precisa usar:

require_once "$IP/skins/MonoBook/MonoBook.php";

(Para utilizar uma skin em uma versão anterior, pode ser necessário baixar a versão marcada para a versão específica em Special:SkinDistributor.)