Phabricator のプロジェクト名 #MediaWiki-skins-MonoBook

Skin:モノブック

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page Skin:MonoBook and the translation is 71% complete.

Other languages:
български • ‎català • ‎Deutsch • ‎English • ‎español • ‎suomi • ‎français • ‎italiano • ‎日本語 • ‎한국어 • ‎Nederlands • ‎polski • ‎português • ‎português do Brasil • ‎русский • ‎中文
このskinは MediaWiki 1.1 以降に同梱されています。 そのため再度ダウンロードする必要はありません。 しかし、提供されているその他の手順に従う必要はあります。
MediaWiki 外装マニュアルManual:Skins - カテゴリ
Crystal Clear device blockdevice.png
MonoBook

リリースの状態: 安定

Dantman-Skin-monobook.png
ライセンス GPLv2+
ダウンロードTemplate:Skin#download
Template:Skin#example https://en.wikipedia.org/w/index.php?useskin=monobook

translatewiki.net で翻訳を利用できる場合は、MonoBook 外装の翻訳にご協力ください

Check usage and version matrix;

Issues:

Open tasks · Report a bug

モノブックという外装は、ウィキメディア財団MediaWiki 1.3以降、ウェブサイトで既定として使ってきました。それ以前の 標準外装に代わるものです。 It became the most popular and most widely supported skin in the MediaWiki ecosystem until it was finally superseded by the Vector skin as the default on May 13, 2010 (MediaWiki 1.17, git #2833b07a), as a result of the efforts of the Wikipedia Usability Initiative to improve Wikipedia user experiences and potentially draw in more contributor participation. It served as a common backup for Vector and is still present on many wikis using older versions of MediaWiki software.

インストール

この外装は、MediaWiki のダウンロード tarball に含まれています。 MediaWiki を異なる方法でインストールした場合、この外装を別途インストールする必要があります。


  • ファイルをダウンロードして、フォルダー skins/ 内の MonoBook という名前のディレクトリに配置してください。
  • LocalSettings.php の末尾に以下のコードを追加してください:
wfLoadSkin( 'MonoBook' );
  • YesY 完了 - 自分のウィキの Special:Version (特別:バージョン情報) に移動して、外装が正しくインストールされたことを確認してください。

MediaWiki 1.24 以前を稼働させている利用者へ:

上記の手順では、wfLoadSkin() を使用して外装をインストールする MediaWiki 1.25 以降の新しい方法を記載しています。 この外装を過去のバージョンにインストールする必要がある場合は、wfLoadSkin( 'MonoBook' ); の代わりに以下を使用する必要があります:

require_once "$IP/skins/MonoBook/MonoBook.php";

(過去のリリースで外装を動作させるには、Special:SkinDistributor より、そのリリース向けのタグが付けられたバージョンをダウンロードする必要があるかもしれません。)