Manual talk:Upgrading

Jump to navigation Jump to search

About this board

Please do not post support questions here.

Instead, use one of these channels:

Further options for contacting appropriate people can be found at Communication .

The warning "change the name of the .htaccess file back" is confusing

2
31.21.117.242 (talkcontribs)

The warning ''change the name of the .htaccess file back" under web browser instructions to run the update script is confusing to me. As a user running the web upgrade script I don't know 1) what .htaccess this is talking about or 2) what I would name it back to. If someone has more of an understanding, it might be worth adding points 1 & 2 to the warning. Thanks :)

AlisonW (talkcontribs)

sidebar: Some of us don't permit use of .htaccess on our systems, making use of the sites-enabled/--.conf file mandatory for security purposes.

Reply to "The warning "change the name of the .htaccess file back" is confusing"
2A02:AB04:1BB:7700:922B:34FF:FE13:6429 (talkcontribs)

In older versions, namespaces were defined only in database (as far as i know... maybe i had bad implementation).

All pages under namespaces stopped working after upgrade - solution was add all namespaces from DB table to LocalSettings. Worth mentioning.

Ciencia Al Poder (talkcontribs)

Namespaces have never been configured in database. Maybe you had an extension that was adding those, and then you didn't install it on upgrade?

Reply to "Namespaces"
BSCwebmaster (talkcontribs)

Possibly a stupid question, but... latest stable version (right now) is 1.34 according to the sidebar. The answer to the frequently asked question "How do I upgrade from a really old version? In one step, or in several steps?" is "It depends: If you are upgrading from MediaWiki 1.4 or older, you should upgrade to MediaWiki 1.5 first." These are the current alpha and beta versions of mediawiki, right? Would it be better to give instructions that make sense for the current stable release? Is it ok to upgrade from 1.30.2 to 1.34, for instance.

Jdforrester (WMF) (talkcontribs)

These are the current alpha and beta versions of mediawiki, right?

No. MediaWiki 1.4.0 came out on 2005-03-20. It is very much not the alpha branch of MediaWiki, which is MediaWiki 1.35.

BSCwebmaster (talkcontribs)

Thanks for the quick reply! Your answer is smart and my question was dumb, as I suspected it would be.

Jdforrester (WMF) (talkcontribs)

There are no dumb questions, worry not. :-)

Pppery (talkcontribs)

The run the update script section makes several references to explicitly running PHP5, even though all supported versions of MediaWiki now require PHP 7. Could someone please update this?

MarkAHershberger (talkcontribs)
Jdforrester (WMF) (talkcontribs)

Upgrading from e.g. 1.10 to 1.27 on PHP5 is still supported.

Reply to "Outdated"

Update.php error updating MW 1.34.1

4
Rom2cu (talkcontribs)

I'm trying to update an installation of MW 1.34.1 and get the following error

PHP Parse error:  syntax error, unexpected '?' in .../w/maintenance/Maintenance.php on line 376


星耀晨曦 (talkcontribs)

Which PHP version do you use?

Rom2cu (talkcontribs)

PHP 7.3 FastCGI


Ciencia Al Poder (talkcontribs)

The "??" operator was introduced in PHP 7.0. Looks like your server is not using PHP 7.3 but an older version, at least from the command line.

You should check if the php binary for 7.3 is installed somewhere else and you need to run scripts with the full path to that binary, like /usr/bin/php73 or similar

Reply to "Update.php error updating MW 1.34.1"

PHP Fatal error: Uncaught ExtensionDependencyError: VisualEditor is not compatible with the current MediaWiki core (version 1.34.0), it requires: >= 1.35.0

2
Summary by Ciencia Al Poder
109.230.45.242 (talkcontribs)

bump during install

星耀晨曦 (talkcontribs)

Where did you download VisualEditor?

the upgrade process should be as simple as WordPress IMO

1
Michael Ten (talkcontribs)

the upgrade process for MediaWiki should be as simple as WordPress IMO awesome project. serenity and limitless peace. Michael Ten (talk) 07:48, 27 March 2020 (UTC)

Reply to "the upgrade process should be as simple as WordPress IMO"
Huwmanbeing (talkcontribs)

I'm seeing a discrepancy between what my Ubuntu server reports as the current installed version of PHP (7.4.1) and what my MediaWiki Special:Version page says is the current installed version of PHP (7.0.33).

The instructions say that the versions of PHP used at the command line and by MediaWiki can be different, but I'm not sure how to resolve it (and the instructions just say to "ask your hoster"). Any suggestions, or could someone point me to instructions? Thanks! Huwmanbeing (talk) 10:57, 21 December 2019 (UTC)

星耀晨曦 (talkcontribs)

It's likely that you have multiple PHP versions installed on your server. Do you use an software bundle, such as XAMPP?

The software management mechanism in these software bundle is not the same as the software management mechanism of the operating system. The operating system does not automatically recognize software bundle. So when you install PHP using yum or apt, it will still install, even if the package bundle already has PHP.

Reply to "PHP version discrepancy"

chmod 755 of images folder

2
118.127.121.174 (talkcontribs)

Sorry I am new to this. Should this command apply to all folders and files within the images folder or just to the folders? I checked the permissions on my site and all the files under images are 644. Thanks in advance.

Ciencia Al Poder (talkcontribs)

Only to folders. Folders need to have the executable bit to be accessed. However, files shouldn't have the executable bit (otherwise could lead to a security risk)

Reply to "chmod 755 of images folder"
Wladek92 (talkcontribs)
Ciencia Al Poder (talkcontribs)

Ok, didn't noticed Shirayuki marked your version for translation. Now fixed.

There are no older topics