Descarga

From MediaWiki.org
Jump to: navigation, search
This page is a translated version of a page Download and the translation is 97% complete.

Other languages:
العربية 6% • ‎বাংলা 15% • ‎brezhoneg 3% • ‎català 3% • ‎čeština 82% • ‎dansk 48% • ‎Deutsch 100% • ‎Zazaki 0% • ‎Ελληνικά 9% • ‎English 100% • ‎español 97% • ‎suomi 24% • ‎français 64% • ‎galego 52% • ‎עברית 9% • ‎हिन्दी 9% • ‎Հայերեն 39% • ‎Bahasa Indonesia 61% • ‎italiano 33% • ‎日本語 100% • ‎ქართული 21% • ‎ಕನ್ನಡ 24% • ‎한국어 79% • ‎Lëtzebuergesch 6% • ‎മലയാളം 3% • ‎Bahasa Melayu 42% • ‎Nederlands 82% • ‎occitan 55% • ‎polski 52% • ‎پښتو 24% • ‎português 36% • ‎português do Brasil 82% • ‎русский 100% • ‎svenska 6% • ‎ไทย 48% • ‎Türkçe 21% • ‎ئۇيغۇرچە / Uyghurche 82% • ‎українська 0% • ‎Tiếng Việt 3% • ‎吴语 33% • ‎粵語 39% • ‎中文 45% • ‎中文(简体)‎ 0% • ‎中文(繁體)‎ 0% • ‎中文(台灣)‎ 0%

Último lanzamiento[edit | edit source]

La Flor de MediaWiki
Introducción a MediaWiki

Contenido


Otros temas

  • Vea la barra de navegación a la izquierda

Licencia[edit | edit source]

MediaWiki es Software libre licenciado bajola versión 2 de la GNU General Public License. Dado que MediaWiki está licenciado libre de costes, no tiene ninguna garantía, hasta el extremo permitido por la ley aplicable. Lee el texto completo de la licencia GNU GPL versión 2 para detalles.

Requisitos del sistema[edit | edit source]

MediaWiki requiere PHP 5.3.2+ y MySQL 5.0.2+, PostgreSQL, o SQLite. Para más información, lee los requisitos del sistema y compatibilidad.

Otras descargas[edit | edit source]

Descarga con Git[edit | edit source]

Los desarrolladores activos de MediaWiki deberían en su lugar descargar con Git para obtener la última versión del software MediaWiki. El repositorio git contiene versiones antiguas del software, así que es posible cambiar (checkout) a una versión en concreto.

Notas[edit | edit source]

  • Se requiere PHP 5 desde MediaWiki 1.7 – Si estás usando PHP 4, ¡debes actualizar ahora! PHP 4 ya no está soportado por el grupo PHP y tiene muchos fallos y vulnerabilidades. Muchos proveedores de hosting compartido ofrecen tanto PHP 4 como PHP 5, simultáneamente. Si no puedes actualizar, puedes usar MediaWiki 1.6.12 (descargar). Ten en cuenta que ya no damos soporte a esta versión.
  • Se requere MySQL 5 desde MediaWiki 1.19 – Si estás usando una versión anterior de MySQL y no puedes actualizar, puedes usar MediaWiki 1.18.6 (descargar). Ten en cuenta que ya no damos soporte a esta versión.

Alternativas a la instalación manual[edit | edit source]

Algunos usuarios prefieren saltarse la instalación manual usando un MediaWiki pre integrado en dispositivos de programas de aplicaciones o servicios de hospedaje; cada vez más distribuidores Linux ofrecen en sus repositorios paquetes para MediaWiki, con diferentes grados de frecuencia y cobertura de las extensiones (Debian, Ubuntu, Fedora y Gentoo entre otros).

Próximos pasos[edit | edit source]

Suscríbete a nuestra lista de correo de comunicados

¡Mantente informado sobre nuevas actualizaciones y mantén tu servidor seguro!

Lanzamientos previos[edit | edit source]

Si has modificado mucho tu instalación MediaWiki, puede ser difícil incorporar los últimos cambios y actualizaciones oficiales en MediaWiki. Para dar soporte a estos usuarios, mantenemos ramas previas de nuestro código durante 1 año para el lanzamiento previo (1.21.8) y hasta 3 años para el lanzamiento previo de soporte a largo plazo (1.19.15).

Lanzamiento de desarrollo[edit | edit source]

Si deseas usar la última versión en desarrollo (p.ej alpla), puedes bajarte Nightlies, o bajar desde Git.

Desde Git puedes bajarte el repositorio completo (unos 528 MB)

git clone https://gerrit.wikimedia.org/r/p/mediawiki/core.git

o solo la última versión del repositorio (unos 85 MB, lo que se conoce normalmente como un clonado superficial: tamaño y tiempo de descarga menor).[1]

git clone --depth 1 https://gerrit.wikimedia.org/r/p/mediawiki/core.git

También puedes ver el último código fuente en tu navegador.

Lanzamientos antiguos[edit | edit source]

Puedes encontrar paquetes (*.tar.gz) de todas las versiones de MediaWiki hasta marzo de 2005 (el más antiguo es MediaWiki 1.3.11) en los archivos de descarga de MediaWiki

Para navegar por el código, incluyendo versiones antiguas, véase etiquetas, del repositorio Git.

Asistencia de instalación[edit | edit source]

Referencias[edit | edit source]

  1. Esto puede causar problemas de referencias si después intentas usar "git pull" para actualizar tu clonado superficial y la nueva versión hace referencia a revisiones antiguas que no has descargado todavía en tu sistema. En estos casos puedes simplemente bajarte más - aumentando el valor de profundidad - o todas las revisiones después, o hacer una clonado superficial limpio.

Véase también[edit | edit source]