Topic on Extension talk:StructuredDiscussions

HTML to Wikitext Conversion Issue

Knomanii (talkcontribs)

I just did a fresh install of Mediawiki 1.35 with Flow-REL1_35.

When I click "Save" on any Flow comment with VisualEditor, I get this HTML to Wikitext conversion error.

What caused this error?

I did only the basic setup for VisualEditor and Flow with MW-1.35 — are any special Parsoid settings needed?

Any help would be appreciated.

Error message
Knomanii (talkcontribs)

Bump. Anyone able to help?

This extension does not work with a fresh install of 1.35.0. Is a RESTBase required or something?

Knomanii (talkcontribs)

Alternatively, if there's not a way to fix Visual Editing, can I disable it? Is it possible to only allow Source Editing?

Any help would be appreciated!

Sophivorus (talkcontribs)

I'm experiencing the same issue, only that I just upgraded from 1.34 to 1.35. On regular pages, the visual editor is working fine.

For now I 'fixed' it by disabling visual editing on talk pages, by setting $wgFlowContentFormat = 'wikitext';

I reported the issue at

Msnhinet8 (talkcontribs)

Me too, how can i do?

Spas.Z.Spasov (talkcontribs)


I'm experiencing the same problem. Recently I've switched from MW 1.34 to 1.35. Visual Editor works fine everywhere except Flow. I'm using the autoconfigure mode, so $wgVirtualRestConfig is not set. At the moment I found three different error messages:

Somme errors occurred with mw:Extension:Flow REL1_35, 07.11.2020

(1) When I'm tring to edit an old existing comment:

An error occurred. The error message received was: internal_api_error_Flow\Exception\WikitextException

(2) When I'm tring to save a comment in visual mode:

[X6akA72QQzSDKWPFYEuVSAAAAAU] Exception caught: Conversion from 'html' to 'wikitext' was requested, but core's Parser only supports 'wikitext' to 'html' conversion

(3) When I'm trying to switch from visual to text mode (the other direction works):

Unable to transfer content: Error contacting the server for conversion between wikitext and HTML. Please check your Internet connection or try again later if the problem persists. If you still get this error please file a bug

Here is my current Setup:

wfLoadExtension( 'VisualEditor' );
$wgGroupPermissions['user']['writeapi'] = true;
$wgSessionsInObjectCache = true;
$wgVisualEditorAvailableNamespaces = array(
        NS_USER => true,
        NS_HELP => true,
        NS_PROJECT => true,
        NS_TEMPLATE => true,
        NS_LINK => true

wfLoadExtension( 'Flow' );
$wgFlowContentFormat = 'html';
$wgFlowEditorList = array( 'visualeditor', 'none' );
$wgFlowParsoidTimeout = 100;
$wgFlowParsoidForwardCookies = true;

My additional research:

  1. I can switch between the visual and text mode only when I'm creating a new comment. Or sometimes when I save the post after 3rd message occurs, bot not every time.
  2. 1st problem appear when I'm in a text mode. If I'm in visual mode I can open an existing comment for edit, but of course I can't save it because of the 2nd issue.
  3. I can't say using $wgFlowContentFormat = 'wikitext'; solve any of the issues.
  4. Using $wgFlowEditorList = array( 'wikitext' ); in order to force the usage only of the wikitext editor doesn't work.
  5. $wgFlowContentFormat and $wgFlowEditorList doesn't change anything at all.

Does we need something like $wgGroupPermissions['flow']['writeapi'] = true;?

Cloudcell (talkcontribs)

bump. I'm experiencing the same issue. Tried everything.

Knomanii (talkcontribs)

Anyone know if this will be patched in MW-1.35.1?

Per phab:T267407, phab:T260648#6645078 seems to be the patch but I can't tell if it will be included in 1.35.1 or if it will resolve this issue downstream. (talkcontribs)

Running into the same issue. Tried switching flow content formats as well, no luck. Has anybody figured this out?

Cloudcell (talkcontribs)
2001:E60:B00C:A4BF:553D:8BF:6BB4:7CEC (talkcontribs)

Bump. Same issue using MW 1.35.1

Spas.Z.Spasov (talkcontribs)

I can't confirm the issue disappear with MW 1.35.1, but I can confirm the patch (phab:T260648#6645078) provided above works!

Knomanii (talkcontribs)

I just upgraded to MW 1.35.1 and encountered the same issue. I checked and the patch you mentioned (phab:T260648#6645078) was not included in 1.35.1. :(

But I was able to apply the patch, and it worked! Though I do hope WMF includes it in the next upgrade… I'm afraid it'll get overwritten when our staff upgrades our wiki next. They may not know how to fix this issue and ditch mediawiki altogether. It's somewhat frustrating that out-of-the-box fresh installs are this difficult to get working.

Anyhoo, thanks for mentioning the patch! I'm really glad it worked.

Beginneruser (talkcontribs)


I have same top error when use following config:

wfLoadExtension( 'VisualEditor' );
wfLoadExtension( 'Flow' );
$wgFlowContentFormat = 'html';

But when change config by remove the wfLoadExtension( 'VisualEditor' );

wfLoadExtension( 'Flow' );
$wgFlowContentFormat = 'html';

Error solve in Flow, But Visual Editor is disable

How use Visual Editor + Flow without error in Mediawiki 1.35.1 LTS version

Please help me!

Tinss (talkcontribs)
Beginneruser (talkcontribs)
MarkAHershberger (talkcontribs)

I'm not sure why I'm pinged here, but looking at the patch in gerrit, it looks like it has been forgotten about.

Reply to "HTML to Wikitext Conversion Issue"