Topic on Help talk:Paragraph-based Edit Conflict Interface

Jump to navigation Jump to search

Getting it on every talk page

17
Summary by Thiemo Kreuz (WMDE)

Fixed, see phab:T208840.

Cymru.lass (talkcontribs)

I'm getting the edit conflict viewer on every talk page I post on. Just got an edit conflict viewer on wikipedia:Template talk:Edit fully-protected, even though the last edit to the page was three days before mine. And then somehow it both posted my edit and did a null edit afterwards, even though I only clicked "Submit" once. Not sure what's going on here.

Michael Schönitzer (WMDE) (talkcontribs)

Hey, that seems like a important bug! but we will replace the current version of the extension with a totally new version anyway this week (depending on the wiki and your timezone it will go live between Tuesday and Friday).

Should this bug still occur with the new version, please write us or ping me, then I will hand this to the developers!

Cymru.lass (talkcontribs)

Cool beans! Thanks for the quick reply. :)

Thiemo Kreuz (WMDE) (talkcontribs)

I tried to reproduce the issue but wasn't successful. @Cymru.lass, can you try to explain how exactly you did the edit in your example? I mean, do you use the "Add topic" feature on top of the page? Do you use VisualEditor? Do you click "edit source" on the last paragraph and add your own wikitext?

Cymru.lass (talkcontribs)

Hello! I use edit source, not VE. The error is happening on Wikipedia, so no threaded conversations there. I'm trying to remember if it was when I was editing a section or full talk page but I'm coming up blank.

Thiemo Kreuz (WMDE) (talkcontribs)

Ok, thanks! Unfortunately this was my test setup, and I couldn't reproduce it. Can you share a few more details about your setup, e.g. your browser, possible browser plugins (e.g. NoScript), Gadgets enabled in your Wikipedia settings, user scripts you are using? Can you try to delete all cookies that contain the wikipedia.org domain, login again, and tell us if the error still happens?

Draceane (talkcontribs)

Hi, using Wiki Editor 2010, I have probably same issue while editing Commons. I doesn't occur while editing other wikis. Regards.

Peter Bowman (talkcontribs)

Since 1.33.0-wmf.3, I am getting a conflict on every single page, even those in which I submitted the latest change. WikiEditor 2010.

Erutuon (talkcontribs)

I just had the edit conflict show up when I clicked "edit" on a section in the entry for "luna" on English Wiktionary. I think I'll disable the gadget. I'm using Firefox Quantum 64 if that helps. I always use the wikitext editor (not Visual Editor) and have lots of user scripts and gadgets enabled.

Eirikr (talkcontribs)

This very broken edit conflict view started appearing for me today. I edited earlier this afternoon (I always use the wikitext editor), and no edit conflict -- I got the normal desired behavior. I log in this evening (US eastern time), and now I get this broken gadget interfering.

Basic symptoms:

  • Make sure you're logged in.
  • Edit any page or section of a page using the wikitext editor.
  • Click the Show preview button.
  • Observe that the gadget claims an edit conflict with the last edit, even if that was days ago.
  • Observe also that the gadget seems to claim that edits to subsections will replace the content of the entire page, not just the intended subsection.

Does not happen if not logged in.

Happens in both Chrome and Firefox.

Highly undesirable behavior -- I saw no notification that this was going to be suddenly enabled, no explanation of what it was, and I see no clear way of disabling it. Not only is the unexplained and substantial change in UI both confusing and unwanted, but the basic edit conflict feature itself appears to be fundamentally broken.

Eirikr (talkcontribs)

PS: I'm getting it on every Wiktionary page -- mainspace, Talk, Wiktionary, Category, everything I've tried so far.

Jc86035 (talkcontribs)

I would also like to report that the new one is not working and thinks I want to overwrite Wikidata's project chat.

Lea Voget (WMDE) (talkcontribs)

Hi everyone, thanks for reporting the issue! We are disabling the feature until we found the bug, this really does not sound good. If you are NOT a beta feature user of TwoColConflict, and still had these issues, please let us know!

93.243.194.191 (talkcontribs)

We believe we fixed the bug yesterday and cannot reproduce the issue anymore. Can you please tell us if this is still happening to anyone of you? If not, I will mark this as resolved. Thanks again for reporting in the first place!

Lea Voget (WMDE) (talkcontribs)

(and I forgot to log in - this was me, Lea)

Peter Bowman (talkcontribs)

It does not happen anymore to me (wiktionary projects), thanks!

Erutuon (talkcontribs)

I re-enabled the feature and so far it seems to be behaving. Whew!