Topic on Talk:ResourceLoader/Migration guide (users)

Jump to navigation Jump to search

Informing communities before the breaking changes

3
Kenrick95 (talkcontribs)

Hi, I'm Kenrick from Indonesian Wikipedia and was not happy that you proceed, without communication with us, to require all gadgets to use ResourceLoader per the MediaWiki 1.26 update. Hence, all of our legacy gadgets are unusable until someone reported it today. Although the fix is simple and I've done it in less than 15 minutes, I think it is still a good idea to inform communities before doing a change that may break the legacy gadgets. Thank you.

Nikkimaria (talkcontribs)

+1. This broke a lot of things, and confused and frustrated a lot of people. Not everyone has the technical understanding to figure out what the problem is and how to fix it - we just see things that aren't working.

Mike Peel (talkcontribs)