Topic on Extension talk:ParserFunctions

Fatal exception of type MWException Error

Summary by Ciencia Al Poder

This is a generic error. Please add $wgShowExceptionDetails = true; at the end of your LocalSettings.php, it should give a more detailed error, then ask in a new thread if it's still not clear from the error message what's the cause of the problem and how to solve it. (talkcontribs)

Fatal exception of type MWException Error Seen this in several threads but have not found a solution.

How do I fix this? (talkcontribs)

After adding - require_once( "extensions/ParserFunctions/ParserFunctions.php" );

I get "Fatal exception of type MWException Error", seen this in several threads but have not found a solution.

How do I fix this?

Technical 13 (talkcontribs)

Firstly, I thought this extension was part of the MW core now and there was no reason to install it separately (which would cause an internal conflict if I'm right about that). Secondly, you're not following the directions in Extension:ParserFunctions#Installation which says you should add require_once( "$IP/extensions/ParserFunctions/ParserFunctions.php" ); (talkcontribs)

1) I did reupload the files contained just to be sure and it still gives me that error. 2) That is what I put in LocalSettings.php it was just a typo in my post here..

So still have no idea what is wrong... (talkcontribs)

I get the same error after installing the mediawiki-package and uploading the created LocalSettings.php. Any solution? (talkcontribs)

Hello, maybe this will help some people with that error. I got the error when uploading the LocalSettings.php aswell, so I tried and tried to reinstall it and at one point I skipped the configuration process and noticed it worked without. Later I noticed I could need the configuration anyway and skipping it isn't a good sollution so I tried to remove everything from the LocalSettings.php which was not on the unconfigurated one one after the other till it worked. For me it was the following line:

require_once( "$IP/extensions/LocalisationUpdate/LocalisationUpdate.php" );

which caused this error. Simply removing it from the LocalSettings.php removed the error. (talkcontribs)

@ Thanks, it worked for me as :) As an experienced net expert I'm sorry for such a script containing this problem. (talkcontribs)

Great! it worked for me as well. Thanks for your research. (talkcontribs)

I'm getting this error when MediaWiki attempt to send any emails. But I don't have the line

require_once( "$IP/extensions/LocalisationUpdate/LocalisationUpdate.php" );

in my LocalSettings.php file.

Any other ideas? (talkcontribs)

I got the same problem as yours. Have you solve it? (talkcontribs)

I am experiencing the same issue as you and the fixes described in this forum do not address it. If anyone has a fix for the email issue please share! (talkcontribs)

Old thread, but since I came across this while looking for a solution, I thought I'd let future googlers know what I found. running "pear install mail" and possibly "pear install Net_SMTP" fixed this error. After that I just had to make sure my smtp settings in localsettings.php.

I hope this helps someone! (talkcontribs)

WORKED!!! This solution is quite hidden between the answers, but for a fresh install in a Debian Wheezy (MW v1.26.2), based on a proxmox CT, is needed.

Thanks a lot. (talkcontribs)

Thanks you! It's works. (talkcontribs)

how do you removed this? "MediaWiki internal error. Exception caught inside exception handler." and "Fatal exception of type MWException" it has stopped me from editing wikipedia.. what did i do to make this happen? i do the same things every day? how can i fix this???

Jonesey95 (talkcontribs)

I'm getting a lot of these on WP today as well. Everything worked fine yesterday. Example: "[7e0f687c] 2013-06-28 04:56:55: Fatal exception of type MWException".

I can load the main page and click on wikilinks, but clicking "View History" or doing any kind of search results in the above error.

DaHuzyBru (talkcontribs)

I know what you mean. Seems to be back for me now... (talkcontribs)

Awesome ;9 Thanky you a thousend! (talkcontribs)

Great! it worked for me as well. Thanks for your research. (copy and paste)

Protnet (talkcontribs)

You don't need to remove LocalisationUpdate! See Bug 46885 - Fatal error after installation when using LocalisationUpdate. The problem is that the MW installer does not do the proper configuration of LU extension. All you have to do is add the cache dir below the require_once like this:

require_once( "$EXT/LocalisationUpdate/LocalisationUpdate.php" );
$wgLocalisationUpdateDirectory = "$IP/cache"; (talkcontribs)

Perhaps wrong place to comment this here but I do it anyway because googling this issues directed me here. This same problem still is with MW 1.22.4 when doing fresh installation of MW and in case LocalisationUpdate is included in initial setup. (talkcontribs)

Thanks, works for me with Synology Diskstation (talkcontribs)

When I add:

require_once( "$EXT/LocalisationUpdate/LocalisationUpdate.php" ); $wgLocalisationUpdateDirectory = "$IP/cache";

I get:

Warning: require_once(/LocalisationUpdate/LocalisationUpdate.php) [function.require-once]: failed to open stream: No such file or directory in /home/ideakwty/public_html/ on line 134

Fatal error: require_once() [function.require]: Failed opening required '/LocalisationUpdate/LocalisationUpdate.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ideakwty/public_html/ on line 134 (talkcontribs)

it works, thanks! (talkcontribs)

Thanks Dude. It worked for me!! You're the Master!!

by best wishes, Danilo. (talkcontribs)

Was same for me!! (talkcontribs)

Thank you! It worked for me! :D (talkcontribs)

Well, when I Put your solution:

require_once( "$EXT/LocalisationUpdate/LocalisationUpdate.php" ); $wgLocalisationUpdateDirectory = "$IP/cache";

The page turns white, and nothing appears... :S why?

Kghbln (talkcontribs)

Usually your error log should tell you or the browser when setting

$wgShowExceptionDetails = true;

Try this for a change:

require_once "$IP/LocalisationUpdate/LocalisationUpdate.php";
$wgLocalisationUpdateDirectory = "$IP/cache";

I am not sure about this $EXT bit since I have so far never come across something like this.

Protnet (talkcontribs)

$IP = wiki's root dir (i.e. yourdomain/wiki)

$EXT = extension's dir (i.e. yourdomain/wiki/extensions)

Kghbln (talkcontribs)

Great, I did not know this existeted. This points me to a mistake in my previous post. It should be

require_once "$IP/extensions/LocalisationUpdate/LocalisationUpdate.php";
$wgLocalisationUpdateDirectory = "$IP/cache";

However this is no different to the previous suggestion. So back to the log file and exception details. (talkcontribs)

Beware, that if you try to install the VisualEditor Extension, you need at least mediawiki-core 1.23 (still in development). Otherwise, you got this error too. (talkcontribs)

You talk way too much but the solution is good. Learn to get to the point. (talkcontribs)

All you have to do is add this following line to the end of your Localsettings.php

$wgLocalisationUpdateDirectory = "$IP/cache";
Supasaru (talkcontribs)

I know this thread is a little old, but I just had this error upgrading from 1.22.8 to 1.23.1, and I thought I'd provide the solution that helped me.

In my case, I had a poorly-coded skin that seemed to work on 1.22.8. I guess it used deprecated functions or something, and didn't work caused the Fatal Error when I accessed Special:Preferences.

I changed the default skin to Vector, and all is well in the world. (talkcontribs)

I faced this problem and it was because I'm using the master image of ParserFunctions . you have to checkout to the version fit your mediawiki version : for me :

git checkout -b mywork origin/REL1_24 (talkcontribs)

Just as a might want to check that your images folder is writable. I received the same MCException error when it wasn't writable. Which of course I made it writable by chown, chgrp to the apache account. (talkcontribs)

This was the problem for me too - I had to give 'other' write privileges on the images folder in my install, after that it all seems to work correctly. (talkcontribs)

same for me, images folder did not have the good rights so apache could not 'mkdir' (talkcontribs)

After recent update it stopped working because my hoster still uses Magic quotes which are deprecated. I just added following lined to an existing .htaccess file in the root of MW:

php_flag magic_quotes_gpc Off php_value magic_quotes_gpc Off

...and it worked :-) (talkcontribs)

The same error appears when the owner of the wiki's folder(s) isn't apache

Make you sure about that

chown -R apache.apache wiki_folder/
Casablanca1950 (talkcontribs)

Problem for me is: All folders are owned by me, not by Apache. My ISP doesn't allow me to change this ownership, and I get the same error after having uploaded the LocalSettings.php file.

I did all suggestions in this thread. None worked for me.

I do not have a require_once( "$EXT/LocalisationUpdate/LocalisationUpdate.php" ); $wgLocalisationUpdateDirectory = "$IP/cache"; line

If I add it the program complains about a missing directory /LocalisationUpdate which actually does not exist:

Warning: require_once(/LocalisationUpdate/LocalisationUpdate.php): failed to open stream: No such file or directory in /home/www/62585963bc9e2a5e92eba0113c714f19/web/AAT/inventaire/LocalSettings.php on line 136

Fatal error: require_once(): Failed opening required '/LocalisationUpdate/LocalisationUpdate.php' (include_path='.:/opt/php/lib/php') in /home/www/62585963bc9e2a5e92eba0113c714f19/web/AAT/inventaire/LocalSettings.php on line 136

Any other clue, anyone, please? Thanks.

EDIT: Some files had size set to 0. Uploaded whole kit again, issue fixed. (talkcontribs)


The issue has been fixed by disabling magic quotes. (talkcontribs)

I fix this error by set permission to 775


$ chgrp -R apache images/

$ chmod -R 775 images/ (talkcontribs)

Thanks. I also had the same problem because I manually copied the latest mediawiki version to the debian standard folder /var/lib/mediawiki but without checking the group settings of the images/ folder.

For Debian Jessie the apache2.4 group is www-data. Changing the group and the 755 chmod did the fix. (talkcontribs)

Fixed my problem also. (talkcontribs)

I disable SE linux it is resilve problem. (centos7)

Knut Krüger (talkcontribs)

I did a fresh install of Mediawiki and the Extension:VisualEditor when enabling the extention it is asking for Mediawiki 1.26?

[84e98a00] /Spezial:Einstellungen MWException from line 3215 of /var/www/.../includes/GlobalFunctions.php: MediaWiki 1.26wmf12 required--this is only 1.25.2


#0 /var/www/clients/client1/web39/web/wiki/extensions/VisualEditor/VisualEditor.hooks.php(20): wfUseMW(string) #1 [internal function]: VisualEditorHooks::onSetup() #2 /var/www/.../includes/Setup.php(676): call_user_func(string) #3 /var/www/.../includes/WebStart.php(138): require_once(string) #4 /var/www/.../index.php(38): require(string) #5 {main}

Knut Krüger (talkcontribs) (talkcontribs)

Got the same MWException Error after fresh installation.

Resolved installing missing package php-apc .

Regards, Mateusz

PhysicsScientist (talkcontribs)

Reply to "Fatal exception of type MWException Error" How to fix this problem? Please help me.

This post was hidden by Nuclearsugar (history)
This post was hidden by Nuclearsugar (history)
This post was hidden by 2601:19B:201:8039:792C:6D53:D546:68A3 (history)
This post was hidden by Nuclearsugar (history)
Ciencia Al Poder (talkcontribs)

Your error about temp directory has nothing to do with ParserFunctions

Ihebbensalem (talkcontribs)

After a while the problem was solved for me .

Fir-stable I highly recommend for you to enable the Debugging mode .

add this 2 lines in the end of LocalSettings.php

error_reporting( -1 );

ini_set( 'display_errors', 1 );

then the errors will shown up .

The problem was in the permission to rename /tmp/l10n_cache-en.cdb ,so ,In your terminal

$ cd /tmp

$ sudo mv l10n_cache-en.cdb l10n_cache-en.cdb.tmp.697754271

Now refresh the index page !

Solved :) .

Ciencia Al Poder (talkcontribs)

To solve a problem with permissions you should give the necessary permissions. I wouldn't expect doing the rename manually would solve the problem if the long term, when something makes the localisation cache to be invalidated.

Ffulbert (talkcontribs)

My site is down since some time. I don't believe I had edited anything that caused this so I find this strange.

I got the Fatal exception MWException error, so following the recommendation above I added at the end of Phpmyadmin.php :

$wgShowExceptionDetails = true;

As a result I get the following more detailed diagnosis which I struggle to make sense of and to know where to start my investigation.

May you help ?

Many thanks in advance.


When I open page

I get :

[088720a5] /wiki/Accueil Exception from line 222 of /home/coetus/public_html/w/includes/Hooks.php: Detected bug in an extension! Hook ExtVariables::init has invalid call signature; Parameter 1 to ExtVariables::init() expected to be a reference, value given


#0 /home/coetus/public_html/w/includes/GlobalFunctions.php(4004): Hooks::run(string, array, NULL)

#1 /home/coetus/public_html/w/includes/parser/Parser.php(275): wfRunHooks(string, array)

#2 /home/coetus/public_html/w/includes/cache/MessageCache.php(1023): Parser->firstCallInit()

#3 /home/coetus/public_html/w/includes/cache/MessageCache.php(1000): MessageCache->getParser()

#4 /home/coetus/public_html/w/includes/Message.php(977): MessageCache->transform(string, boolean, Language, Title)

#5 /home/coetus/public_html/w/includes/Message.php(669): Message->transformText(string)

#6 /home/coetus/public_html/w/includes/Message.php(732): Message->toString()

#7 /home/coetus/public_html/w/includes/OutputPage.php(853): Message->text()

#8 /home/coetus/public_html/w/includes/OutputPage.php(898): OutputPage->setHTMLTitle(Message)

#9 /home/coetus/public_html/w/includes/Article.php(556): OutputPage->setPageTitle(string)

#10 /home/coetus/public_html/w/includes/actions/ViewAction.php(44): Article->view()

#11 /home/coetus/public_html/w/includes/Wiki.php(428): ViewAction->show()

#12 /home/coetus/public_html/w/includes/Wiki.php(292): MediaWiki->performAction(Article, Title)

#13 /home/coetus/public_html/w/includes/Wiki.php(588): MediaWiki->performRequest()

#14 /home/coetus/public_html/w/includes/Wiki.php(447): MediaWiki->main()

#15 /home/coetus/public_html/w/index.php(46): MediaWiki->run()

#16 {main}

Ciencia Al Poder (talkcontribs)

One of your MediaWiki extensions is not compatible with the MediaWiki version you're using.

If you upgraded MediaWiki recently, be sure to also upgrade your extensions as well, by downloading them for the same version of MediaWiki you're using. Note that some extensions may be unmaintained and may not work for your MediaWiki version even if you download it for the version you're using.

To know which extension is causing the problem, comment all require_once() or wfLoadExtension() that loads extensions from your LocalSettings, and enable them one by one until you find the one that causes the error.

2A01:CB04:788:2F00:B40B:9CB5:B72B:8C88 (talkcontribs)

thanks for the tips.I believed it was working before it crashed but perhaps I had changed something. I'll follow your suggestion to investigate. Many thanks !

2001:16B8:6688:4800:64ED:3FD4:3FA7:B255 (talkcontribs)

I had a pretty bad night which resulted in my MediaWiki being down. Now I have everything half-way working again, only I can't edit anything now. Now I need someone to held me with this error message.

Maybe you can help me figure it out.

Many thanks in advance

[XVdr8b-myRv10DFSRxmpHgAAAAs] /vampire/index.php?title=Hauptseite&action=edit Error from line 3978 of /home/sites/site24/web/vampire/includes/OutputPage.php: Class 'OOUI\MediaWikiTheme' not found


#0 /home/sites/site24/web/vampire/includes/OutputPage.php(3991): OutputPage::setupOOUI(string, string)

#1 /home/sites/site24/web/vampire/includes/EditPage.php(2762): OutputPage->enableOOUI()

#2 /home/sites/site24/web/vampire/includes/EditPage.php(659): EditPage->showEditForm()

#3 /home/sites/site24/web/vampire/includes/actions/EditAction.php(59): EditPage->edit()

#4 /home/sites/site24/web/vampire/includes/MediaWiki.php(499): EditAction->show()

#5 /home/sites/site24/web/vampire/includes/MediaWiki.php(293): MediaWiki->performAction(Article, Title)

#6 /home/sites/site24/web/vampire/includes/MediaWiki.php(862): MediaWiki->performRequest()

#7 /home/sites/site24/web/vampire/includes/MediaWiki.php(523): MediaWiki->main()

#8 /home/sites/site24/web/vampire/index.php(43): MediaWiki->run()

#9 {main}

Ciencia Al Poder (talkcontribs)