Talk:Gerrit/Tutorial

Jump to navigation Jump to search

About this board

Archive


Forgot to branch master and then committed to gerrit

3
Summary by Tinss

Change the topic flag within gerrit's web UI.

Tinss (talkcontribs)

I absentmindedly forgot to branch master and then committed my change to gerrit. I know it's not the way things are supposed to be done, but do I need to abandon my change on gerrit and redo it?

Samwilson (talkcontribs)

You could rename the current branch (git branch -m new-name) and then review as normal. Or you could use the -t flag for git-review, and explicitly set the topic (git review -t new-name). I normally do the former in that situation. If later you do want a local master branch, you can just create it then (git checkout -b master gerrit/master).

Or there's probably another more correct way that I'm forgetting. :-) That's usually the case with Git.

Oh, sorry, I just realised: do you mean you've already pushed the change for review? In that case the topic flag is the way to go I think, or you can just change the topic via the web UI.

Tinss (talkcontribs)

Yes it's been pushed for review. I've set the topic flag in gerrit. Thanks!

"Network unreachable" message when making ssh connection to Gerrit

6
Asrajmane193 (talkcontribs)

Hello, I have started with the initial set up. I have everything upto adding ssh key to use with git.

I am running the command to make ssh connection to Gerrit: ssh asrajmane193@gerrit.wikimedia.org -p 29418

It gives me the message "ssh: connect to host gerrit.wikimedia.org port 29418: Network is unreachable". I tried changing the port to some random number, 29000. Still no luck.

I am fairly new here. Please help.

Florianschmidtwelzow (talkcontribs)

Can you try to ping gerrit.wikimedia.org? What is the result? (i assume you're using a linux distro?)

Xqt (talkcontribs)

29418 is the right port. Maybe it is blocked by a local router or firewall?

Shrutika719 (talkcontribs)

Is this problem resolved? Because I am still facing this problem, I tried switching the ports but all in vain

Darthbhyrava (talkcontribs)

I am facing a similar problem. I think it's the proxy. But even after I installed corkscrew, shifted the installed binary to /bin and made appropriate changes to .ssh/config, I get the same error.

The ping to gerrit is fine, btw.

Any leads?

Edit: Resolved.

There was an error in the path to my corkscrew binary in .ssh/config. I corrected it, added my public keys to gerrit, and it worked. :)

This post was hidden by AKlapper (WMF) (history)
Guycn2 (talkcontribs)

I have installed Git from this link and set my username and email.

When I type ls ~/.ssh in the command line, I get the following message:

'ls' is not recognized as an internal or external command, operable program or batch file.

What have I done wrong?

KTC (talkcontribs)

Use the Git Bash shell, not Windows Command Prompt.

Guycn2 (talkcontribs)

Thank you @KTC, I succeeded, but now I encounter another problem: I can't install git-review. When I run Git Bash as administrator and run the following command: pip install git-review, I get an error message saying:

bash: pip: command not found

I ran this command after I had installed Python 3.6, but it still doesn't work...

KTC (talkcontribs)

Try "python -m pip ..." or "python3.6 -m pip ...".

Guycn2 (talkcontribs)

@KTC, I still get this error: "bash: python: command not found".

Is it possible to submit Gerrit patches without installing git-review?

KTC (talkcontribs)

If you can't even run python despite having it installed, then something's not set up right in your environment.

Guycn2 (talkcontribs)

My Python is installed in the following directory: C:/Users/Guy/AppData/Local/Programs/Python/Python36-32

Maybe it has something to do with it?

Reply to "Can't set up SSH keys"
Nikerabbit (talkcontribs)
Qgil-WMF (talkcontribs)

Whats with those "quotes from the community"?

2
Sophivorus (talkcontribs)

They're hardly useful, I feel they shouldn't be there. Anyone objects to their removal?

Qgil-WMF (talkcontribs)
172.56.39.38 (talkcontribs)

add new language in welcome.py pywikibot

2
Ainur bai (talkcontribs)

good morning!

Maybe I'm turning to the wrong address, if so please direct me.

I started with the problem of adding a new language to script welcome.py in pywikibot. I created the necessary pages from the bot and added a text to the text. But I can not fix the changes

:

Git.exe push --progress "origin" master: master

Remote: Unauthorized

Fatal: Authentication failed for 'https://gerrit.wikimedia.org/r/pywikibot/core.git/ь

But I'm registered at https://gerrit.wikimedia.org/

Help me please!

Xqt (talkcontribs)
Reply to "add new language in welcome.py pywikibot"
Summary by Malyacko

Off-topic unrelated. Please do not test here.

107.0.58.212 (talkcontribs)

msmsm

IvRud (talkcontribs)
AKlapper (WMF) (talkcontribs)
Reply to "Rusyn language needs a Latin variant"
PiRSquared17 (talkcontribs)

I don't know much about BSD, but I'm guessing "cd cd" is wrong. πr2 (tc) 15:35, 4 December 2013 (UTC)

SPage (WMF) (talkcontribs)