MediaWiki 1.27/cs

From MediaWiki.org
Jump to navigation Jump to search
This page is a translated version of the page MediaWiki 1.27 and the translation is 79% complete.

Outdated translations are marked like this.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Tiếng Việt • ‎dansk • ‎español • ‎français • ‎italiano • ‎magyar • ‎polski • ‎português • ‎português do Brasil • ‎čeština • ‎русский • ‎中文 • ‎日本語 • ‎한국어

MediaWiki 1.27 byla dlouhodobě udržované vydání MediaWiki. Úplný seznam změn najdete v souboru $1. Na všechny wiki Wikimedia Foundation byla postupně instalovaná z větví "1.27/wmfNN" které se začaly zakládat od 29. září 2015 do března 2016 (podrobnosti ke každé z nich viz zde).

Stabilní verze 1.27.0 byla uvolněna 28. června 2016[1], a byla coby dlouhodobě podporované vydání (LTS - Long Term Support) udržovaná po dobu tří let.

[$releases-link Poslední vydání] si můžete stáhnout buď jako archiv, nebo získat tak, že si stáhnete Git repozitář a uděláte checkout na větev REL1_27, která následovala toto vydání.

Nové možnosti

InstantCommons made easier and cheaper

InstantCommons will now truly work out of the box, as long as your users can connect to upload.wikimedia.org: thumbnails will be served from that domain instead of requiring local generation (gerrit:251556).

More documentation translation

Pokračovaly práce na migraci k rozšíření Translate, které se používalo již na více než 3000 stránkách. Velikost překládaných textů byla navýšena na megabajty. Thanks go to our tireless translation administrators and translators but also to Google Code-in 2015 students, in particular IoannisKydonis who migrated thousands of translations including the entire Manual:FAQ.

Poznámky k aktualizaci pro administrátory MediaWiki

Zlomové změny

  • Toto vydání MediaWiki vyžaduje PHP minimálně verze 5.5.9. To odpovídá HHVM 3.1.[2]
  • PHP rozšíření od teď vyžadují mbstring.
  • Pokud není dostupné openssl a mcrypt, nebude možné používat PHP rozšíření, při pokusu o uložení vytvořeného zabezpečeného sezení (které se používá pro přihlášení) dojde k vyvolání výjimky. Tuto výjimku lze potlačit nastavením $wgSessionInsecureSecrets = true; . Vemte však na vědomí, že se to není řešení, protože tím obcházíte zabezpečení. Nedělejte to.
  • Po aktualizaci může mít hodně uživatelů problém s tím, že se některé stránky, nezobrazí v příslušných kategoriích, přestože jsou kategorizovány správně. Ve většině případů je za tím problémem fronta úloh. Jejich problém tkví v tom, že se jim stránky nezobrazí v jejich kategoriích ihned. Příčiny mohou být různé. A je možné, že fronta úloh nepracuje správně. Přečtěte si $wgRunJobsAsync a postupujte podle pokynů, které by vám měly pomoci vyřešit tento problém.
  • Rozšíření RandomRootPage bylo začleněno do jádra MediaWiki. Pokud ho máte nainstalované, tak byste ho měli odinstalovat.
  • Rozšíření ApiSandbox bylo začleněno do jádra MediaWiki. Pokud ho máte nainstalované, tak byste ho měli odinstalovat.
  • Proměnná $wgSessionsInObjectCache se již nebude používat, proto bude vracet za všech okolností true. Sezení se již delší dobu neukládají přes relace které spravuje PHP (např. session.save_path). Pokud máte problém s tím, že se vám ukončuje sezení během přihlášení, zkontrolujte, kam se má podle $wgSessionCacheType ukládat sezení.
  • AuthManager. Pokud píšete nové rozšíření, můžete po aktualizaci na 1.27 konečně postupovat podle manuálové stránky Manual:SessionManager and AuthManager. Pokud se chcete přesvědčit, že je vaše rozšíření kompatibilní s 1.27, prostudujte tipy pro aktualizaci.

Nekompatibilní rozšíření

Upozorňujeme, že nová větev sebou přináší zlomové změny pro řadu rozšíření a mnoho z nich bude vyžadovat aktualizaci. Zkontrolujte otevřené podúkoly na task T110291, kde je seznam rozšíření, u kterých bylo zjištěno, že vyžadují aktualizaci. Pokud některé z nich požíváte, musíte vyzkoušet, jestli bude ve vašem prostředí fungovat ještě předtím, než uděláte aktualizaci vaší produkční wiki. Záplaty pro aktualizaci těchto rozšíření jsou vítané.

Plán vydání

Předpokládaná data vydání klíčových verzí pro 1.27 byla následující:

Vydání Datum
1.27.0 2016-06-28[1]
1.27.1 2016-08-22[3]
1.27.2 2017-04-06[4]
1.27.3 2017-04-30[5]
1.27.4 2017-11-14[6]
1.27.5 2018-09-20[7]
1.27.6 2019-06-06[8]
1.27.7 2019-06-07[9]

Podstránky