Extension talk:MediaWiki Bulletin Board

From MediaWiki.org
Jump to navigation Jump to search
If you have any suggestions, please see the Modification Page and see if your suggestion has already been made.


The following discussion has been transferred from Meta-Wiki.
Any user names refer to users of that site, who are not necessarily users of MediaWiki.org (even if they share the same username).

Demo Page[edit]

Is there any demo-page to try out this extension? --Nyks 14:12, 25 October 2006 (UTC)

Pretty Cool[edit]

I have this running on tmug.org here here are some issues

  • when setting up a fourm, if users only is selected, error is returned, saying forum_perm was left blank
  • it is confusing - what is specials group?
  • PM system - users can't delete a PM - kind of understandable because of delete permissions w/i MW itself

TMUG 01:22, 27 October 2006 (UTC)

thanks for the demo. But we need to be a member to post and there is no message. The only way to really know how it works still seems to install it. Any other demo? --70.52.210.6 14:28, 13 December 2006 (UTC)

Simple, effective[edit]

I installed MediaWiki Bulletin Board here on Dirtopia. Some of the CSS is embedded, but what do you want? It's version 0.1! Thanks. --Travisk 07:38, 17 December 2006 (UTC)

Update 2 August 2009: It appears that MWBB has been replaced with PHPBB on Dirtopia. Brian7632416 19:28, 2 August 2009 (UTC)

Error message[edit]

Warning: Cannot modify header information - headers already sent by (output started at /chroot/home/yes0song/wiki/extensions/mwbb/mwbb.php:95) in /chroot/home/yes0song/wiki/includes/WebResponse.php on line 9

Warning: Cannot modify header information - headers already sent by (output started at /chroot/home/yes0song/wiki/extensions/mwbb/mwbb.php:95) in /chroot/home/yes0song/wiki/includes/WebResponse.php on line 9

--Yes0song 10:58, 27 January 2007 (UTC)

I also have this problem. The output started at is whichever page you currently are accessing. --68.150.34.225 03:40, 16 August 2007 (UTC)

I solved the problem by deleting the closing tag(<? ) in mwbb.php. (version 1.11alpha)--Courant 01:21, 8 September 2007 (UTC)

I got another problem. --Courant 01:33, 8 September 2007 (UTC) (Original exception: exception 'MWException' with message 'Detected bug in an extension! Hook wfpmnav failed to return a value; should return true to continue hook processing or false to abort.' in C:\xampp\xampp\htdocs\mediawiki\includes\Hooks.php:133)

I got the same problem as Courant, MediaWiki 1.11.0 says, 'Detected bug in an extension! Hook wfpmnav failed to return a value; ....' It installed fine, but it seems the newer MediaWiki maybe is a little more careful about returns being proper. Anyone know how to fix this? Sketch 02:27, 26 September 2007 (UTC)

I solved my own problem by adding return true; before the closing } in the following functions in PM.php and SpecialPM.php - wfpmcheck function and wfpmnav function. Watch out also for the return earlier in the function. This is probably a hack and should have some type of validation to return true, anyway it works for me. --Sketch 22:12, 27 September 2007 (UTC)

Admin panel[edit]

I can't see the link to the Admin panel anywhere. There is text saying visit the Admin panel, but no link. How do I access it. Thanks Gsix14 08:41, 28 January 2007 (UTC)

Install.php did not work for me[edit]

Install.php did not work for me. So, I copied the /extensions/mwbb/schema.sql into MySql to create a table. I replaced the %s with the prefix of my data, and it worked. I have MediaWiki v1.9 and I didn't find the code on SkinTemplate.php mentioned in the pm install section. Is this because v1.9 has its own pm message function?--Kohyin 07:36, 11 February 2007 (UTC)

I am a MySQL retard. How do I edit the .sql file so that I can manually install . . . and for that matter . . . how do I manually install? When I run the install.php, I get There is an error stopping the installation please check your database immediately. I am assuming that communication is happening because I get an auth error when i intentionally screw up my credentials. Any help is greatly appreciated. Jimmy anathema.pth@gmail.com

Typo in common.php[edit]

Hello developper. I use MWBB-0.1.zip. I attached diff file.

--- common.php.orig     2007-03-31 12:10:22.000000000 +0900
+++ common.php  2007-03-31 12:10:22.000000000 +0900
@@ -33,6 +33,6 @@
 'no_cat_admin'=>'There is no category. Please create a category first!',
 'no_cat_delete'=>'There is only 1 category. You can\'t delete all categories!!',
 'no_forum_delete'=>'There is only 1 forum. You can\'t delete all forums!!',
-'powered_by'=>'<div style="vertical-align:bottom; text-align:center; font-size:10px">Forum section Powered by <a href="htpp://sourceforge.net/project/mwbb/">MWBB</a></div>' 
+'powered_by'=>'<div style="vertical-align:bottom; text-align:center; font-size:10px">Forum section Powered by <a href="http://sourceforge.net/projects/mwbb/">MWBB</a></div>'
 ));
 ?>

--Kamataki 03:31, 31 March 2007 (UTC)

Actually to tell you the truth, that's PHP's way of telling it that isn't part of the code. /' just tells it to show ' instead of ending the script. Hope this helps! --67.141.8.226 01:41, 21 September 2007 (UTC)

Help![edit]

http://kdeopsys.110mb.com/wiki/index.php/Special:Forum (my site) is set up but not working. HELP!

Nice bit of software. Modding it up now.[edit]

For a 0.1 version bit of code, this is pretty darned decent. Seems to work just peachy in mediawiki 1.9. I am using it as a framework and trying to supe it up a little to do some of what I need. First off, I have set up the topic display to be actually readable... in the existing version, long topics are pretty much illegible. Next up I am de-embedding all the CSS. When I have made a slightly more skinnable version with the CSS separate I will post it here for all to enjoy. If I can get avatars and things like that working after, I will continue to post any successes here.
221.29.158.74 05:19, 8 April 2007 (UTC)

WikiCode[edit]

I've worked on enabling wikicode on MWBB. I'm not a programmer, you see, but i've tried out something like that:

1. I found the lines in topic.php:
 $html.=' |   '.$skin->makeKnownLink('Special:Post/reply','Quote','tid='.$topic_data['topic_id'].'&quote='.$data[$i]['post_id']);	
	$html.='</b></p>';
	$html.='<hr />';
 }  
			
 return $html;
 } 
And after "return $html" and before " } " i've put
 $html=$wgOut->addHTML($html);
 $html=$wgOut->addwikiText($html); 


That's providing an bold ('''bold'''), italic (''italic'') text, links ([[links]]), and graphics ([[Image:foo.jpg]]). The signatures (~~~ and ~~~~) does not work.

I'm testing it now.

Author?[edit]

I couldn't find the author for this page when adding the template Bouncingmolar 02:46, 15 July 2007 (UTC)

Compatibility problems with IE7.[edit]

--TDeeming 09:59, 7 August 2007 (UTC)

After installing to my MW 1.93... and using several of the hints above to get it working... Thanks!
  • like manually creating the msql tables...
I found that the monobook skin layout was distorted.
  • There is a space between the tabs and the pages.
  • The navigation bar has disappeared on some pages... like the help page...
    • I had experienced this after installation of the "myblogs" extension... but at some point the problem just went away, but I am not sure why.
Just for fun, I decided to try another browser (Firefox 2.0)... and the format of the pages was fine.
The MWBB extension itself "appears" to be working without any immediate problems, but with this formating problem with IE7... I'm afraid I will have to disable it again.
  • I also entered this information on the sourceforge site Bulliten Board... but it seems as if nobody is monitoring it.
Anyone have any ideas?

Monobook formatting[edit]

I finally found an easy way to install a forum but this extension causes me too much trouble to adjust it to my needs. Same formatting problem in IE as described above and even in Firefox when the edit/post box appears, the sidebar shows up below the body content (works fine in other skins though). I'd be happy to see the normal wiki post box load at the bottom of the topic like this > Extension:TalkHere uses it. --Subfader 20:45, 21 August 2007 (UTC)

EditToolbar[edit]

Why does the EditToolbar doesn't appear when posting / editing --Subfader 20:45, 21 August 2007 (UTC)

Preview button[edit]

Instead of the (useless) Reset button a Preview buton would make much more sense. --Subfader 20:45, 21 August 2007 (UTC)

Normal text format instead of wiki format[edit]

The text should be formatted like in pre tags to enable easy posting like in a normal forum, cos the <br /> tag is a hell of a bitch :)
Some wiki codes are already ignored so maybe this would be easy to implent? --Subfader 20:45, 21 August 2007 (UTC)

Number of topics / replies[edit]

The Admin forum lists the number of topics (not working) and posts. I want that overview for the main forums when in Special:Forums where it makes much more sense! --Subfader 20:45, 21 August 2007 (UTC)--Martin, 2007-08-20

Permalinks[edit]

This should def be possible like on Bugzilla. --Subfader 20:45, 21 August 2007 (UTC)

Forum Search / Namespace[edit]

The forum is not searchable. It should have its own namespace in order to do so. This way it would also be possible to call "latest posts" like you can do now on Special:Newpages for the TALK namespace. --Subfader 20:45, 21 August 2007 (UTC)

How the hell would they do that? --83.104.41.175 15:27, 20 September 2007 (UTC)

Skin.php[edit]

Where in skin.php can I change the background color of the topic posts? Or is it not possible because you'd actually have to post a background color? --Subfader 15:56, 21 August 2007 (UTC)

Private Messages[edit]

The PM's are limited to 200 by default, but since there is no way for the user to delete them, the admin nees to rise the number to unlimited? --Subfader 17:06, 21 August 2007 (UTC)



But since there seems to be no workaround I'd be happy if anyone can recommend another forum extension before i waste too much time configuring and going live with it. --Martin, 2007-08-20

Please take a look at DPLForum. The DPLforum is a heavily-adapted derivation of DynamicPageList 1.12, geared toward displaying forum-style layouts. It's not as fancy MWBB, but the information can be searched... which was another one of the complaints I had the MWBB and I don't have the skin problems. Anyway, I am planning to use it until MWBB becomes stable.--TDeeming 11:40, 21 August 2007 (UTC)
The DPLForum doesn't look like a real forum. No Reply buttons etc and I don't understand the category thingy in there. --Subfader 20:45, 21 August 2007 (UTC)

Images bug[edit]

posting images in a thumb box like [[image:picture.jpg|thumb|]] destroys the post. --Subfader 16:43, 22 August 2007 (UTC)

Signatures[edit]

Add this to post.php directly after line 264, it will make signatures work.

$d = $wgContLang->timeanddate( date( 'YmdHis' ), false, false) . ' (' . date( 'T' ) . ')';
$sigText = $wgParser->getUserSig( $wgUser );

$data['text'] = strtr( $data['text'], array(
	'~~~~~' => $d,
	'~~~~' => "$sigText $d",
	'~~~' => $sigText) );

--EdK 15:00, 20 September 2007 (UTC)

MediWiki 1.11 breaks PM[edit]

MediaWiki v1.11 errors on this extension.

MediaWiki internal error.

Original exception: exception 'MWException' with message 'Detected bug in an extension! Hook wfpmnav failed 
to return a value; should return true to continue hook processing or false to abort.' 
in /var/www/html/mediawiki-1.11.0/includes/Hooks.php:133

This version does not like the setting of $wgHooks found in mwbb.php. By commenting out the two lines that set $wgHooks the wiki successfully displays. I have not explored what gets broken by removing these hooks.

SpecialPage::addPage( new SpecialPage( 'Pm','',true,false,'$wgforum_root/SpecialPm.php') );
## $wgHooks['PersonalTabsbeforelogout'][]= array('wfpmcheck');
## $wgHooks['SkinTemplateBuildNavUrlsNav_urlsAfterPermalink'][]=array('wfpmnav');

--PBM 164.44.67.4 18:20, 10 October 2007 (UTC)

Problem with New Topic and Navigation List[edit]

Hi, when i start a new Topic or when i want to replay on a topic, My Navigation bar goes down.... What is the Problem or what can I do to solve this Problem? I have tried it with Version 0.1 and also today with 0.2....

Please help me

Kin

need help[edit]

The hook "beforetempexec" dosen't work, so I want to know where I can add this hook(like "wfRunHooks( beforetempexec, array( ... ));"). Thanks! -Alpha3 11:26, 7 November 2007 (UTC)

Bug in install.php[edit]

Line 12 in install.php should read...

DataBase Server:</td><td><input tabindex="1" type="text" value="<? echo $data['dbserver'] ?>" name="dbserver" maxlength="200" size="25" /></td></tr>


This bug only kicks in when trying to install using a DB that can't be accessed using 'Localhost' for the server.


Is this being worked on?[edit]

It's been a while since the previous update, so are you really working on this? (January 20, 2008)

  • I don't think this extension is active anymore - and - the title table is misleading - it reads as if this extension is written by and fully supported by WikiMedia Foundation. It isn't. From the table MWBB is Mediawiki Bulletin Board, a Message board or forum extension for Mediawiki by Wikimedia Foundation. this isn't by Wikimedia Foundation, mediawiki is but not the extension. I say this extension is no longer active - D'oh 20:47, 26 January 2008 (UTC)

Comparison to AWC Forum Extension[edit]

I had this extension installed, and love the admin features, but hated the skin and it lacks basic forum details such as last post and number of threads/posts...

But I have now managed to install AWC's forum extension on mediawiki 1.11....

It has a much better basic skin, more like a proper forum while still looking wikied, stating the number of posts/threads, and last post...

But it does lack the admin features of MWBB, such as:

  • Forum specific permissions with Moderator, Forum administrator, Special Member rights
  • Topic moderation: Closed, Sticky, Global Announcement topics

It would be great to see the front end of the AWC forum extension merged with the back end of the MWBB extension...

Anyone interested?

This is how the AWC forum extension looks on mediawiki 1.11 (my htpc wiki)

--HTPCnz 10:02, 26 January 2008 (UTC)

***UPDATE***

The AWC forum extension is now being updated and I have provided a link to a working beta version, that now includes nearly all the admin features of this MWBB extension and works on the latest version of mediawiki, hence in my mind is now far far better, as the MWBB extension lacks basic features such as displaying the most recent posts etc on the forum main page etc...

More information can be found here AWC Mediawiki Forums

AWC Forum example (now works on latest version of Mediawiki, and includes all above admin features)

This user is right, at a glance, AWC looks much better and more like a message board than the standard Mediawiki Bulletin Board.
Odessaukrain 20:22, 31 March 2008 (UTC)

****Modifications!****[edit]

I have released a few modifications! Click here for more information. —The TattleTale Strangler 02:33, 19 February 2008 (UTC)

PM´S[edit]

I have installed this on my Wiki 1.11, a couple of questions, did anyone get the pm notification to work on 1.11? Another question, are their any plans to somehow allow users to delete their pm´s once they have read them? Last but by no means least, I liked a few of the mods for this, but for what version of Media wiki were they for? The quote button went in ok, but the Avatar and Signature one, just blanked the pages. Forgot to mention, i have tried other forums for wiki mentioned here, this is the first one that i got to work after having to install the database manually, apart from that, i am impressed--Krillmeed 21:29, 4 March 2008 (UTC)

Hey Krillmeed! The answer is simple: all you had to do was just put in a line in a file and it'll do it for you. It tells you on the article page. As for anything else, look on the Modification link on the article page and you'll find some extensions for this extension. ;D --74.130.45.110 04:43, 6 March 2008 (UTC)

MW 1.12?[edit]

I'm using MW 1.12 atm. When I try to edit (reply, new topic / pm) I get:
Fatal error: Call to a member function getTitle() on a non-object in \includes\EditPage.php on line 92. Which is:

90	function EditPage( $article ) {
91		$this->mArticle =& $article;
92		$this->mTitle = $article->getTitle();
I just posted a fix to it on the extension page. —The TattleTale Strangler 01:04, 25 March 2008 (UTC)
The fix fixes it but unfortunately makes the liquid threads extension stop working. not sure how to manage since i would like to have both extensions working on my wiki but currently it looks like i have to go with one or the other.

Kay

Inbox / Outbox[edit]

On the Inbox page (Special:Pm) there should be a link on top to a list of my sent messages. --Subfader 20:41, 15 March 2008 (UTC)

Delete PM's[edit]

An option to delete certain messages from the inbox was requested very often to me. --Subfader 20:42, 15 March 2008 (UTC)

PM reply: Quote[edit]

When writing a PM reply the old message should be loaded as a forum quote with space on top for the new message. --Subfader 21:57, 15 March 2008 (UTC)

MW 1.12 Fix Available[edit]

If you have recently installed MediaWiki 1.12, the fix is on the extension page. Thanks! —The TattleTale Strangler 01:05, 25 March 2008 (UTC)

Feature request[edit]

Hi, i tried this extension and it's really great, but i miss some options that i think could let this more interesting and make me much more happier.

  • I think that each forum could be an article page. So for each article we could create topics and add replies. And this could replace the talk page.
  • The categories could be the namespaces that exist on the wiki.
What do you think? any chance to have this option?

Lleoliveirabr 00:23, 26 March 2008 (UTC)

I think MWBB is pretty good already as it is. If you want, you check out some modifications I made to it. As for your suggestions, I don't think that's very forum-like. The purpose of MWBB is to be a forum, not a wiki. —The TattleTale Strangler 00:40, 26 March 2008 (UTC)
Understand your point of view. I gave this suggestion just because will be great to my particular idea. But do you think the feature i requested will be hard to implement? could be implemented as option, don't you think?
The TattleTale Strangler is kind of right. If you mean like... discussion pages go to the forum, then I think that's possible, but that would probably have to be on the next version. Thank you for the suggestion though. ;D --74.130.39.67 01:12, 26 March 2008 (UTC)
If you are the extension developer, please look for this request please. Even better: when a person go to talk page of an article, if a forum is not created, will be created the forum with the name of the article, so the user will have the option to create a topic or reply on the topics that already exists. What do you think?

Lleoliveirabr 01:41, 26 March 2008 (UTC)

Minor bug, Question, Comment[edit]

minor bug[edit]

There is a minor bug when installing on a system where the MySQL server is not localhost. In install.php, this line:

DataBase Server:</td><td><input tabindex="1" type="text" value="<? echo $data['dbserver'] ?>" name="dbname" maxlength="200" size="25" /></td></tr>

Should be changed to:

DataBase Server:</td><td><input tabindex="1" type="text" value="<? echo $data['dbserver'] ?>" name="dbserver" maxlength="200" size="25" /></td></tr>

(Also, why aren't these values simply pulled from LocalSettings.php, at least as defaults?)

question[edit]

No matter which file I download from SourceForge, the version number in code is always 0.1 even when it is labeled as version 0.2 on SF.

  • install.php: $mwbb_version='0.1';
  • mwbb.php: 'version' => '0.1',

Can anyone provide a link directly to the 0.2 download? Or is the version number in the code simply wrong?

comment[edit]

It would be nice if MWBB could keep its data in a different database than the one MediaWiki uses, but if that would slow things down (I see that it goes through MW's db caching) then maybe it's not worth it.

--Woozle 13:18, 13 May 2008 (UTC)

Recommendation[edit]

I recommend everyone to check Extension:AWC Forum before installing this bugged extension. <--True that. DHS --85.88.18.8 18:50, 14 July 2008 (UTC)

Error[edit]

I get this

Fatal error: Call to a member function getTitle() on a non-object in C:\xampp\htdocs\includes\EditPage.php on line 97

Error when trying to post. Suggestions/help? Rgoodermote 02:25, 6 July 2009 (UTC)

I'm running the latest version of the software in xampp. Rgoodermote 03:30, 6 July 2009 (UTC)


how do we allow anonymous posting??[edit]

Help me.. plz

Add forums to watchlist[edit]

Is there any way to add the forums to the watchlist or receive notifications??

PHP Fatal error: Call to undefined method SpecialPage[edit]

[28-Jul-2013 14:46:32] PHP Fatal error: Call to undefined method SpecialPage::addPage() in /var/www/vhosts/xxxx/wiki/extensions/mwbb/mwbb.php on line 80

Hello! What is wrong?

Mediawiki 1.21.1 MWBB 0.1

Can you help me please

Thx Thorsten