Extension talk:ExternalLinks

Jump to navigation Jump to search

About this board

BrentLaabs (talkcontribs)

Hey, just wanted to let you know that there are some pretty obvious XSS flaws in this extension.

The variables $filterURL and $filterURLnot are fetched from the http request and put right back into the HTML without validation. Consider using the HTML class instead of raw HTML.

Subfader (talkcontribs)
Reply to "XSS Vulnerabilites"
Rob Kam (talkcontribs)
Reply to "Regarding alternatives"

Declined extension on Miraheze

1
Rob Kam (talkcontribs)

The extension has been declined on Miraheze wiki farm because of security concerns. https://phabricator.miraheze.org/T1555

Please can these be resolved? This is a vital extension for any wiki (imho should be in core).

Reply to "Declined extension on Miraheze"
Rob Kam (talkcontribs)

Breaks the wiki if $wgELuserRight is used. Then although it's listed at Special:Version Special:ExternalLinks doesn't work. Also there is no Validate external URLs in sidebar.

Subfader (talkcontribs)
Rob Kam (talkcontribs)

Working nicely again. Special:ExternalLinks also, although a link from Special:Version is missing. Many thanks. It's a very handy extension.

Subfader (talkcontribs)

Cannot fix since I can't even log in to MW 1.27.1.

Anthomyjaycorman (talkcontribs)

Just installed 1.1.3 with MW 1.27.1 - added $wgELvalidationMode = 'cURL'; to LocalSettings.php. Links are detected correctly but not validated. Anything else required to enable validation?

Anthomyjaycorman (talkcontribs)

Very strange: reinstalling in a clean MW 1.28, I see ExternalLinks in Versions but not listed on Special Pages. In the PHP error log I see this: PHP Warning: Parameter 1 to efExternalLinksToolbox() expected to be a reference, value given in /Applications/MAMP/htdocs/wiki/includes/Hooks.php on line 195

Reply to "Not working on MW 1.27.1"
Krabina (talkcontribs)
Reply to "Solution for https"
178.7.186.131 (talkcontribs)
Reply to "https support"
-revi (talkcontribs)
Kghbln (talkcontribs)

Yes, since this extension is not handled via the WMF repository and is thus not getting translations. However, I do not know how this fits into existing code, i.e. if the extension provides I18n capabilities.

-revi (talkcontribs)

I will contact author of this extension to ask if it is valid.

This post was posted by -revi, but signed as Hym411.

Kghbln (talkcontribs)

Great idea. Probably he will incorporate the translations into the next version.

89.166.60.185 (talkcontribs)

I think you talk about finnish translation I few hours ago added. I translated it for my own use and supposed it would be handy for some others if needed. I did not find extension from translatewiki.net so I added it to the page you offered. It works fine when just add it after english and german translations in existing file.

-revi (talkcontribs)

Yep, but I think translation of MediaWiki extensions are usually done in transltewiki.net and I thought it was not a good way of translations. It should be in the code already when you get the code.

This post was posted by -revi, but signed as Hym411.

89.166.60.185 (talkcontribs)

Yes, I agree with you! I tried this extensions's front page link (in the green box) Translate the ExternalLinks extension if possible but there was not translation for that in translatewiki. I'm not yet familiar how to add a translation there.

Many times when you click same kind of link on other extensions, they straight open the translatewiki.net page on your language and you can straight start to translate. I supposed, there is not any translation of this extension and that was my reason to do this way. If I find a way to do it in translatewiki, I'll be happy to move them there.

Kghbln (talkcontribs)

It is only possible to translate an extension if it is available at translatewiki.net, so if the link points into the void it is not available there. An extension must be in the WMF repo for this as mentioned in my first post to this thread. I have done a change to the wording within the info box. If it lasts it will hopefully be easier to figure out and not as confusing.

Reply to "Extension:ExternalLinks/Translation"
Amabu (talkcontribs)

I use Mediawiki 1.19.2 and habe Problems with links like

  • Wikichemie
  • which have falsely the error Domain Not Found?

    I use the parameters as in the example

    Amabu (talkcontribs)

    I further have a strange field Site ID [ ] and no results. Works only for the first site when id=1 , otheriwse the wiki returns to the startsite

    Amabu (talkcontribs)

    This plugin scans only one page with problems and is not supported The proposed alternative is a firefox-ping-plugin, but ....

    The better solution is XENU with wildcards http://home.snafu.de/tilman/xenulink.html#wild (because of the scan of old deleted pages) with like

    • action=history*
    • /Discussion:*

    and also *oldid=* and

    • Special:Änderungen_an_verlinkten_Seiten* (changes of linked pages)
    • action=edit*
    • printable=yes*
    Reply to "Wiki urls"

    Table in German Mediawiki 1.22

    1
    Bmrberlin (talkcontribs)

    I Think, the wikitable script ist not loaded. Is there a switch, to turn it on?

    Reply to "Table in German Mediawiki 1.22"

    Question mark in Server response

    1
    89.166.60.185 (talkcontribs)

    I installed the extension, but in Server response it only shows ? -mark for real external links. But links which are pointed to same wiki http://mywiki.com/wiki/pagename are shown correctly. How would I solve the problem?

    My MediaWiki version is 1.22.2 and with $wgELvalidationMode = 'cURL'; the php info() for "cURL support" is "enabled".

    Thanks!

    Reply to "Question mark in Server response"