User talk:Krusher

From MediaWiki.org
Jump to navigation Jump to search

Social Profile[edit]

Hello Krusher,

Can you explain a little bit clearer how you've fixed the extension Semantic Profile. I want to fix it to for my wiki, but I can't follow your idea. Thanks! --McNamara84 (talk) 15:12, 24 June 2013 (UTC)

The idea is you have to define attributes of a clase before using them. If you don't, objects won't have scope to the actual attributes. So edit the UserProfilePage class, in UserProfilePage.php file, and declare these attributes:
public $user_id;
public $user_name;
public $user;
public $is_owner;

That should do.

--213.227.38.164 15:16, 24 June 2013 (UTC)
Oops that was me unloged. --Krusher (talk) 15:17, 24 June 2013 (UTC)


Hey Krusher,

Your tip really helped me out in getting SocialProfile working, but I still get this strange error appearing on the top of the user profile page:

Notice: Inaccessible property via __get(): profile_data in X/includes/Article.php on line 1918

(X is the root directory of my mediawiki install). Have you experienced something like this?

Thank you, -ixxie

I've noticed that error in my logs, but I've been unable to fix it yet. --Krusher (talk) 20:11, 1 July 2013 (UTC)

A barnstar for you![edit]

Original Barnstar Hires.png The Original Barnstar
Hi Krusher,

I was looking for a solution to not being able to access my userpage after installing Social Profile - well there was a bit more involved than that as it's a fresh setup, but anyway - and I found your solution posted on the talk pages. I was actually searching for a solution for this database error which pointed me towards Social Profile:

"UserStatsTrack::updateWeeklyPoints". Database returned error "1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE up_user_id = '1 at line 1 (localhost)".

I put your declarations in the class section of that file and voila! got access to the userpages again.

I'm still looking for a solution to the database error that comes up when I make a blog post, but am so pleased to have access to my userpages again.

I am running the same versions - MW 1.21 and the latest Social Profile, I think v1.50?

THANK YOU SO MUCH for posting that.

Robin RobinMacI (talk) 19:57, 30 June 2013 (UTC)

Sorry, I'm not use that particular extension. You might get some help in #mediawiki in freenode, the author hang there sometimes. --Krusher (talk) 20:36, 30 June 2013 (UTC)