Jump to content

Topic on Project:Support desk

Problem with Database-Update to 1.39.3

Rainerhamm (talkcontribs)


I hope that issue is easy for a specialist - just not for me.

In the process of upgrading to Mediawiki from 1.35 to 1.39.3 with mw-config I started the database-update. An error 1091 occures:

"Table revision contains rev_text_id field. Dropping...

An error occurred:

Error 1091: Can't DROP INDEX `user_timestamp`; check that it exists

Function: Wikimedia\Rdbms\Database::sourceFile( /home/www/mediawiki_kempedia_3903/maintenance/archives/patch-revision-actor-comment-MCR.sql )

Query: ALTER TABLE `revision`

DROP INDEX user_timestamp,

DROP INDEX page_user_timestamp,

DROP INDEX usertext_timestamp,

DROP COLUMN rev_text_id,

DROP COLUMN rev_comment,

DROP COLUMN rev_user,

DROP COLUMN rev_user_text,

DROP COLUMN rev_content_model,

DROP COLUMN rev_content_format"

In deed the table revision show only following indices in phpmyadmin:


The indices the system want to drop don't exist.

Can anybody help me? What can I do?

Best regards


Rainerhamm (talkcontribs)

Sorry, here are the requested data:

  • MediaWiki version: see above
  • PHP 7.4.33
  • DB: 10.5.18-MariaDB-0+deb11u1-log
  • URL: www.kempedia.de
Rainerhamm (talkcontribs)

Can't anybody help?

Malyacko (talkcontribs)
Rainerhamm (talkcontribs)

Yes, it looks similar.

Now I am at a loss, because there is no reaction an no support.

I tried to update to 1.38.6. That was successful.

Update from 1.38.6 to 1.39.3 brings the same error.

What can I do????

Crashone (talkcontribs)

Did you find a solution ?

Kghbln (talkcontribs)

I just ran into this issue and added my experience to task T331608. Let's hope for someone who perhaps has a clue about what to do in this situation. For me, the update to 1.39.6 fails.

Reply to "Problem with Database-Update to 1.39.3"