Topic on Extension talk:DiscussionTools

Reply buttons not working after upgrade to MediaWiki 1.39

Summary by Sophivorus
Sophivorus (talkcontribs)

Hi! I recently upgraded MediaWiki and extensions from 1.35 to 1.39. Before the upgrade DisucssionTools worked fine, and after the upgrade the site works ok but for some reason the reply buttons added by DiscussionTools are either not showing or not working.

On content pages they don't show, see for example (we're not using the Vector skin but if you visit the problem persists, so it's not skin-related).

In user talk pages, the reply buttons show, but only in messages by the "owner" of the talk page, and when you click them they throw a "comment not found" error, see for example

Notice that when creating a new topic, the new DiscussionTools interface loads and works perfectly, so the problem doesn't seem to be with the extension but rather with the reply feature.

Our LocalSettings.php has the following:

$wgFragmentMode = [ 'html5' ];
$wgLocaltimezone = 'UTC';
date_default_timezone_set( $wgLocaltimezone );

There're no JavaScript errors to be seen in the console. What could be the cause?? Thanks for any help and also for the awesome, super-useful and friendly extension!!

This post was hidden by Sophivorus (history)
Sophivorus (talkcontribs)

I tried enabling DiscussionTools in a test wiki, with the same table prefix, same MediaWiki version, PHP version, Parsoid version, etc. but DiscussionTools worked perfectly.

Then I tried deleting and recreating the DiscussionTools database tables in (maybe something had gone wrong during the table upgrade) but the reply buttons still don't work.

I'm a bit baffled at this point. What could be wrong?

Sophivorus (talkcontribs)

After some more testing, I was able to reproduce the issue by importing a dump of the current database into the test wiki. It seems then that the issue is related to the database schema or to the data itself. I suspect it's the database schema, since I noticed it's using the outdated latin1_swedish_ci collation, so I'm trying to update the schema to the current one. Will close this issue when I figure it out, but still any insights are welcome, cheers!

Sophivorus (talkcontribs)

Well, I created a fresh test wiki (with a fresh 1.39 database schema). Then I truncated all the tables and imported the old data into the new schema. After a few tries I got the wiki to work, but the bug persists! This can (probably) only mean that the problem is with the data itself and not with the schema. What could it be?? I'm officially out of ideas, any help is welcome, thanks!

Sophivorus (talkcontribs)

I tried adding /wiki to the URL path of the test wiki and DiscussionTools started to work perfectly (see here). It appears then that this is a path issue. However, when I did the fresh install of the test wiki (see above), DiscussionTools worked well even without /wiki in the path. Strange!